Subject: Re: Re: [magma] Behaviour IGMPv3 Routers...

From: "Rajasekaran R" <[email-masked]>
Date: 30 May 2005 10:51:57 -0000

Regarding the IGMPv3 General Query being processed by v2 Host...
Will not the v2 Host interpret the Checksum field as 8 bytes and reject the packet, since in the v3 Packets checksum is calculated using 12 bytes ?

- R. Rajasekaran.

On Fri, 27 May 2005 Brian Haberman wrote :
>See in-line...
>
>On May 26, 2005, at 10:27, Rajasekaran R wrote:
>
>>  It is said in the RFC 3376 that per Group Record Version is maintained in IGMPv3 router, if there exist hosts of IGMPv2 and IGMPv3. 
>>  If the router wants to know the membership interest information from the network, then, it is obvious that it should a periodic general query. 
>>  If the general query is of type IGMPv2 then its shall step down all hosts (including IGMPv3 hosts) to IGMPv2, which is not desired.
>>
>>  If the general query is of type IGMPv3 then IGMPv2 host shall not respond with a Membership information and there may exist a chance that routers shall not be able to know about the group containing IGMPv2 hosts.
>
>This is an incorrect assessment of IGMP behavior.  The Query message
>(Type = 0x11 in all versions) is the same within the first 8 bytes of the
>message.  That means that IGMPv2 hosts will respond to Queries sent
>by IGMPv3 routers.  When the router receives the IGMPv2 Reports, it
>will maintain the per Group Record as indicating the presence of IGMPv2
>hosts.
>
>
>>
>>  In this scenario how does Multicast routers behave ?  Does it send periodic IGMPv3 general queries or a periodic group specific queries based on the version maintained by the router for each group ?
>>
>>  Have anybody experienced this case in real time.
>>
>>  Kindly help me.
>>
>>  - R. Rajasekaran.
>>
>>   
>>
>>_______________________________________________
>>magma mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/magma
>>
>
_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Brian Haberman <[email-masked]>
Date: Mon, 30 May 2005 20:39:13 -0400

The processing of IGMP Queries by an IGMPv2 host is defined in
the IGMPv2 spec.  The checksum is calculated over the entire length
of the message, but the host only uses data in the first 8 bytes of the
message.

Regards,
Brian

On May 30, 2005, at 6:51, Rajasekaran R wrote:

>  Will not the v2 Host interpret the Checksum field as 8 bytes and 
> reject the packet, since in the v3 Packets checksum is calculated 
> using 12 bytes ?
>
>  - R. Rajasekaran.
>
>
>  >>  It is said in the RFC 3376 that per Group Record Version is 
> maintained in IGMPv3 router, if there exist hosts of IGMPv2 and 
> IGMPv3. 
>  >>  If the router wants to know the membership interest information 
> from the network, then, it is obvious that it should a periodic 
> general query. 
>  >>  If the general query is of type IGMPv2 then its shall step down 
> all hosts (including IGMPv3 hosts) to IGMPv2, which is not desired.
>  >>
>  >>  If the general query is of type IGMPv3 then IGMPv2 host shall not 
> respond with a Membership information and there may exist a chance 
> that routers shall not be able to know about the group containing 
> IGMPv2 hosts.
>  >
>  >>  In this scenario how does Multicast routers behave ?  Does it 
> send periodic IGMPv3 general queries or a periodic group specific 
> queries based on the version maintained by the router for each group ?
>  >>