Subject: [magma] IGMP Protocol behaviour in Switched LAN

From: "Rajasekaran R" <[email-masked]>
Date: 20 May 2005 11:18:21 -0000

I do like to clarify the following doubts regarding IGMP protocol :-

In a Switched LAN, I do have multicast source and multicast receiver.  

I want multicast receiver to subscribe the multicast source for transmitting multicast packets.

Is it possible for the multicast communication to happen in this scenario **without a Multicast router*** present in this network ?  

Do I need a any other devices (like IGMP Proxy device ) running elsewhere in the network ?

- R. Rajasekaran. 
_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Marshall Eubanks <[email-masked]>
Date: Fri, 20 May 2005 13:03:28 -0400

Hello;

On 20 May 2005 11:18:21 -0000, Rajasekaran  R
<[email-masked]> wrote:
>  Is it possible for the multicast communication to happen in this scenario
> **without a Multicast router*** present in this network ?  
>  

In most switched LANs, the multicasts will be flooded to all hosts, so the
receiver will be able to get the stream by default.

If you are running IGMP snooping then you can get multicasts if the snooping is
set up correctly.

Some switches block multicasts (or have optional blocking or rate
limiting) - most wireless LAN switches do, for example, to conserve
bandwidth.

>  Do I need a any other devices (like IGMP Proxy device ) running elsewhere

Not in the case of sources and receivers on the same LAN.

>  - R. Rajasekaran. 

Regards
Marshall Eubanks