Subject: [magma] Behaviour IGMPv3 Routers...

From: "Rajasekaran R" <[email-masked]>
Date: 26 May 2005 14:27:13 -0000

It is said in the RFC 3376 that per Group Record Version is maintained in IGMPv3 router, if there exist hosts of IGMPv2 and IGMPv3.  

If the router wants to know the membership interest information from the network, then, it is obvious that it should a periodic general query.  

If the general query is of type IGMPv2 then its shall step down all hosts (including IGMPv3 hosts) to IGMPv2, which is not desired.

If the general query is of type IGMPv3 then IGMPv2 host shall not respond with a Membership information and there may exist a chance that routers shall not be able to know about the group containing IGMPv2 hosts.

In this scenario how does Multicast routers behave ?  Does it send periodic IGMPv3 general queries or a periodic group specific queries based on the version maintained by the router for each group ?

Have anybody experienced this case in real time.

Kindly help me.

- R. Rajasekaran.

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Brian Haberman <[email-masked]>
Date: Fri, 27 May 2005 09:24:29 -0400

See in-line...

On May 26, 2005, at 10:27, Rajasekaran R wrote:

>  It is said in the RFC 3376 that per Group Record Version is 
> maintained in IGMPv3 router, if there exist hosts of IGMPv2 and 
> IGMPv3. 
>
>  If the router wants to know the membership interest information from 
> the network, then, it is obvious that it should a periodic general 
> query. 
>
>  If the general query is of type IGMPv2 then its shall step down all 
> hosts (including IGMPv3 hosts) to IGMPv2, which is not desired.
>
>  If the general query is of type IGMPv3 then IGMPv2 host shall not 
> respond with a Membership information and there may exist a chance 
> that routers shall not be able to know about the group containing 
> IGMPv2 hosts.

This is an incorrect assessment of IGMP behavior.  The Query message
(Type = 0x11 in all versions) is the same within the first 8 bytes of 
the
message.  That means that IGMPv2 hosts will respond to Queries sent
by IGMPv3 routers.  When the router receives the IGMPv2 Reports, it
will maintain the per Group Record as indicating the presence of IGMPv2
hosts.

>
>  In this scenario how does Multicast routers behave ?  Does it send 
> periodic IGMPv3 general queries or a periodic group specific queries 
> based on the version maintained by the router for each group ?
>