Subject: [magma] IGMPv3 Host Behaviour

From: "Rajasekaran R" <[email-masked]>
Date: 20 May 2005 11:19:53 -0000

I do like to clarify the following doubts regarding IGMP protocol :-

If a IGMPv3 multicast Host wishes to join a multicast group, 
then how does it subcribes to Multicast Source ?

Does it subscribes with Resport Message type as IS_INCLUDE,
only when the router sends a query message ?

Or is it possible for the Host to send its subscription before 
a Router Query message is received ?
If yes, What is the type of Report message it uses to subcribe initially ?

- R. Rajasekaran.

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: [email-masked]
Date: Fri, 20 May 2005 17:41:39 +0530

Hi Rajasekaran,
 
When ever a mulitcast host needs to join a group, it can do
it by sending a report asynchronously without waiting for the query
message.
The host can specify the interested source addresse/addresses along with
the mode
parameter in IGMPv3. The host can specify the list of source addresses 
from which it wishes to receive packets using INCLUDE mode and to
specify the list of uninterested sources using EXCLUDE mode. The message
type can be IS_INCLUDE or IS_EXCLUDE .
However, either of this modes can be specified in
one report for a particulat multicast group.
 
I hope I could clarify your doubt.
With best regards, 
Sanjeev R.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Rajasekaran R
Sent: Friday, May 20, 2005 4:50 PM
To: [email-masked]
Subject: [magma] IGMPv3 Host Behaviour

Or is it possible for the Host to send its subscription before 
a Router Query message is received ?
If yes, What is the type of Report message it uses to subcribe initially
?

- R. Rajasekaran.

 <http://clients.rediff.com/signature/track_sig.asp>

---

From: mark fine <[email-masked]>
Date: Fri, 20 May 2005 14:39:20 -0600 (MDT)

from my understanding, for unsolicited reporting and to capture a change 
in the interface's filter mode (i.e., join a group), you would use a 
"state-change record" (TO_INCLUDE, TO_EXCLUDE, ALLOW_NEW, BLOCK_OLD), as 
opposed to a "current-state record" (IS_INCLUDE, IS_EXCLUDE), which should 
only be used in response to a query.

---

From: [email-masked]
Date: Sat, 21 May 2005 11:14:57 +0530

Ya,
That's correct..IS_INCLUDE and IS_EXCLUDE
Are sent in response to the queries.

-----Original Message-----
From: mark fine [mailto:[email-masked]] 
Sent: Saturday, May 21, 2005 2:09 AM
To: Sanjeev Ravindran (WT01 - TELECOM SOLUTIONS)
Cc: [email-masked]; [email-masked]
Subject: RE: [magma] IGMPv3 Host Behaviour

opposed to a "current-state record" (IS_INCLUDE, IS_EXCLUDE), which
should 
only be used in response to a query.

On Fri, 20 May 2005 [email-masked] wrote:

> Hi Rajasekaran,
>
> When ever a mulitcast host needs to join a group, it can do it by 
> sending a report asynchronously without waiting for the query message.

> If a IGMPv3 multicast Host wishes to join a multicast group, then how 
> does it subcribes to Multicast Source ?
>
> Does it subscribes with Resport Message type as IS_INCLUDE, only when 
> the router sends a query message ?
>
> Or is it possible for the Host to send its subscription before a 
> Router Query message is received ? If yes, What is the type of Report 
> message it uses to subcribe initially ?
>
> - R. Rajasekaran.
>
>
>
>
>
>