Subject: Re: [magma] igmp snooping

From: "Rajasekaran R" <[email-masked]>
Date: 25 Oct 2005 10:50:55 -0000

IGMP ROUTER2 shall to known to SNOOPING switch by mean of "IGMP
Multicast Router Discovery " as described in the "draft-ietf-magma-snoop-12.txt".

- R. Rajasekaran.

On Tue, 25 Oct 2005 Shenoy,Vivekananda(Vivek) wrote :
>
>Hi,
>
>My topology is below
>
>  +---------+
>  |ROUTER1  |        |
>  |         |IGMP    |
>  |         ---------|
>  |         |        |
>  |         |        |
>  +---------+        |        +---------+
>                     |        |         |
>                     |        |         |
>                     |        |SNOOPING |
>                     |--------|         |
>                     |        |SWITCH   |
>                     |        |         |
>                     |        +---------+
>                     |
>  +----------+       |
>  |          |       |
>  |          |       |
>  |ROUTER2   --------|
>  |          |IGMP   |
>  |          |       |
>  +----------+
>
>A scenario where I have 2 IGMP routers on a single LAN, we know that one
>of them will be a querier since only he can send IGMP queries say
>Router1 in my case.
>
>My doubt is how snooping switch will know about the Router2 who is the
>non-querier since switch is not receiving any queries from Router2.I
>have seen snooping switch maintaining 2 tables 1)Querier table (ROUTER1
>in this case) 2)Router table (ROUTER2 in this case).
>
>This scenario may exist where Router1 may act as the IGMP querier and
>Router2 may be the destination DR who is forwarding the traffic on to
>the LAN
>
>PIM or any multicast routing protocol is not enabled on the IGMP
>interfaces so switch cannot see these hellos.
>
>Thanks
>Vivek
>
>
>_______________________________________________
>magma mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/magma
_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: "Rajasekaran R" <[email-masked]>
Date: 25 Oct 2005 10:51:08 -0000

- R. Rajasekaran.