Subject: [magma] IGMP V3 Router States...

From: Michael Grimes <[email-masked]>
Date: Wed, 05 Oct 2005 17:27:52 -0500

All,
I am currently working on an implementation of IGMP V3 and have been
looking at RFC 3376, in particular the filter mode and source lists maintained
by the router.  In 6.4.1 and 6.4.2 they show the old/new router states when
receiving reports.  This involves the set expressions "A+B", "A*B" and "A-B".
I have tried to run through some examples using these tables, but they
are just not making any sense to me.  If anyone could point me to some examples
and/or explanations of how the source lists are processed by the router based
upon these tables I would greatly appreciate it.

Regards,

Michael Grimes

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Anupam S <[email-masked]>
Date: Thu, 6 Oct 2005 01:07:53 -0700 (PDT)

Good question! ;)

Id suggest you implement it as:
- a patricia-trie for Grp Addr
- Each such Grp Addr node contains two p-tries, one
for Set A (Incl Set, with Src Timers ticking) and
another for Set B (Excl Set, Src Timers !ticking.

Every time you want to do an operation such as A+B,
ie., a union, just lookup B in Trie A, if not present
add it. Opposite for A-B. The tricky things are A*B,
or multiple combinations of resultant Sets - you need
to be creative, a hint - just start with a new trie
and replace the old one(/s) entirely. Believe me, its
efficient and it works! 

> upon these tables I would greatly appreciate it.

__________________________________ 
Yahoo! Mail - PC Magazine Editors' Choice 2005 
http://mail.yahoo.com