Subject: [magma] IGMP host behaviour on reception of group and source specific query

From: ravikumar vj <[email-masked]>
Date: Tue, 11 Jul 2006 07:56:32 -0700 (PDT)

Hi all,
         I have got some doubts on IGMP host behaviour on reception of group and source specific query. Somebody please clarify
   
  Consider the following secnarios, where the host state is given for group G1
   
  1) Exclude ( S1, S2) and received a query Q(G1, S1)

  2) Exclude ( S1, S2) and received a query Q(G1, S3)
  3) Include (S1, S2) and received a query Q(G1, S1)
  4) Include (S1, S2) and received a query Q(G1, S3)
     
  Is the given result, the correct behaviour?
   
  1) Send nothing
  2) Send IS_INCL (S3)
  3) Send IS_INCL (S1)
  4) Send nothing
   
  Is there any need to send IS_EXCL(A) report, as a response to Group and source specific query?
   
  Thanks in advance
  Ravikumar

 		
---------------------------------
How low will we go? Check out Yahoo! Messenger’s low  PC-to-Phone call rates.

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: "Rolland Vida" <[email-masked]>
Date: Wed, 19 Jul 2006 19:00:57 +0200

Hi Ravikumar,

Sorry for the late answer. Please find my comments inline

>       I have got some doubts on IGMP host behaviour on reception of
group > and source specific query. Somebody please clarify
> 
> Consider the following secnarios, where the host state is given for
group > G1
> Is the given result, the correct behaviour?

Right

> 2) Send IS_INCL (S3)

Right

> 3) Send IS_INCL (S1)

Right

> 4) Send nothing

Right. All these are straightforward from the table at the end of
section 5.2.  
 
> Is there any need to send IS_EXCL(A) report, as a response to Group
and source specific query?

No, there is no case when an IS_EX report is sent for a group and source
specific query.

Cheers,
Rolland