Subject: [magma] One basic doubt in MLD

From: Indranil Bhattacharya <[email-masked]>
Date: Mon, 8 Jun 2009 15:12:00 +0530

Hello All,

             I have a basic doubt. I see that MLD is encapsulated in ICMPv6
packet and it is not a separate protocol like IGMP is in IPV4. Could you
please tell me for what reasons it has been designed like this?

Thanks,
Indranil

---

From: Brian Haberman <[email-masked]>
Date: Mon, 08 Jun 2009 07:42:06 -0400

Indranil,
      During the early development of IPv6, it was determined that there 
was a sufficient amount of similarity between the group management 
signaling and ICMPv6.  In essence, ICMPv6 was meant to be the generic 
node-node signaling protocol for IPv6.

Regards,
Brian

Indranil Bhattacharya wrote:
> Hello All,
>  
>              I have a basic doubt. I see that MLD is encapsulated in 
> ICMPv6 packet and it is not a separate protocol like IGMP is in IPV4. 
> Could you please tell me for what reasons it has been designed like this?
>  
> Thanks,
> Indranil
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> magma mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/magma