Subject: Robustness of MANET protocols

From: Pascale Minet <[email-masked]>
Date: Thu, 14 Sep 2000 10:57:26 +0200

Hi everybody,

I am joining the MANET mailing list, and I would like to discuss
the robustness of routing protocols in MANET.

The protocol ability to cope with undesirable events
like for instance, a memory error or an intrusion
is very important in MANET.
In such a case, the nodes can be in an incorrect state,
a short recovery time is desirable.

In AODV and OLSR, each entry in the tables is valid only
for a limited duration. Upon expiration of its lifetime,
an entry is deleted from the table, allowing to escape
from incorrect state in a short time.

But it is unclear with TBRPF. This protocol is designed
with a focus on efficiency:
- only the "updates" are sent and not all the link state information,
- all multicasts are sent along a minimum hop path tree
rooted at the multicast source.
Moreover, concerning the robustness,
different mechanisms (e.g. ack, nack) have been introduced
to maintain the nodes in a correct state,
ASSUMING that initially they were in a correct state.
Could the TBRPF designers clarify how the protocol recovers
from an incorrect state ?

Pascale

---

From: Håkan Olin <[email-masked]>
Date: Mon, 18 Sep 2000 10:56:58 +0200

I am curious if there are any commercial implementations of ad-hoc routing?

Thanks, Hakan Olin

-- 
Dr Hakan Olin
Physics and Engineering Physics
Chalmers University of Technology
SE-412 96 Goteborg
Sweden
tel. +46-31-772 3338
fax +46-31-772 3367
mobile +46-70-30 88 99 0
e-mail [email-masked]
home page http://fy.chalmers.se/~f4aolin

---

From: WANG Wooi Ghee <[email-masked]>
Date: Tue, 19 Sep 2000 12:20:20 +0900 (JST)

At Mon, 18 Sep 2000 10:56:58 +0200
In Message-ID: <[email-masked]>
> I am curious if there are any commercial implementations of ad-hoc routing?

Hi, I was asking the same question. With the new technology Bluetooth,
there will be tremendous commercial applications of ad-hoc networking.
Check some of the pages related to bluetooth like:
http://www.motorola.com/bluetooth/action/index.html

---

From: "Salavat R. Magazov" <[email-masked]>
Date: Tue, 19 Sep 2000 21:50:00 +0100

Hello

----- Original Message -----
From: "WANG Wooi Ghee" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, September 19, 2000 4:20 AM
Subject: Re: Commercial implementations of ad-hoc routing?

> http://www.motorola.com/bluetooth/action/index.html

As far as I am aware of communication systems Bluetooth can be easily
implemented without any MANET functionality in the mobile nodes. Frankly
speaking, I do not know how Bluetooth works but from what I have read seems
to me that it would
be far better employing fixed base stations with wireless interfaces
interconnected by, for example, fibre optics (e.g. Radio-over-fibre
technology). The two main advantages (I think) are: simpler (therefore
cheaper) mobile terminals (no complex routing protocols) and higher
bandwidth (crucial parameter for the technology to become sellable). The
only point in the description of Bluetooth seemed to communicate with each
other directly was when PDAs were discovering each other at the trade show,
what can be done without Ad hoc network functionality. In all other
instances PDA was communicating with fixed device, which can be a usual
router with one or more wireless interfaces and one or more wired interfaces
to connect to each other and to Internet.
I think that the main advantage of Ad hoc networking is that no pre-existing
infrastructure is needed. And this is what drives the research in this area
and must be used.
If I am wrong could somebody point where exactly. I would really appreciate
this.

> > Thanks, Hakan Olin

Regards
Sal

---

From: "Salavat R. Magazov" <[email-masked]>
Date: Tue, 19 Sep 2000 21:50:00 +0100

Hello

----- Original Message -----
From: "WANG Wooi Ghee" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, September 19, 2000 4:20 AM
Subject: Re: Commercial implementations of ad-hoc routing?

Regards
Sal

---

From: "Salavat R. Magazov \(BT\)" <[email-masked]>
Date: Tue, 19 Sep 2000 22:05:35 +0100

Hello

----- Original Message -----
From: "WANG Wooi Ghee" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, September 19, 2000 4:20 AM
Subject: Re: Commercial implementations of ad-hoc routing?

Regards
Sal

---

From: WANG Wooi Ghee <[email-masked]>
Date: Thu, 21 Sep 2000 12:28:45 +0900 (JST)

Dear Salavat

I think we still haven't answered Hakan's question that is:
The real commercial value / implementations of ad-hoc networking.

> infrastructure is needed. And this is what drives the research in this area
 
In the military and emergency cases, it is certainly that we need the 
ad-hoc network without pre-existing infrastructure.
How about in the commercial field ?

Someone has suggested some implementations like:
Businessmen at an airport lounge might need to hold meetings
that need an ad-hoc network.

But these kinds of networking is likely to be within one/two hops
and most of the nodes would be static almost all of the time.

To sum up my question:

" What is the concrete commercial implementations that involve
multihops ad-hoc routing with high speed of moving nodes ? "

If there is few or limited impletations of such kind of routing 
in commercial world, then it is very unlikely ad-hoc networking
will be popular in the future.

If I am wrong could somebody point where exactly. 
I would really appreciate this.

Regards
ghee