Subject: AODV HELLO PACKET TRADEOFF

From: hridesh rajan <[email-masked]>
Date: Mon, 23 Oct 2000 23:29:48 -0700 (PDT)

Hi All,

The message complexity required for local connectivity
can be adjusted according to mobilty . Let us assume 
that there are nodes which do not change position over

time. In that case it will be wastage to continuously 
send location updates in the form of Hello packets. It
will also be a good idea to restrict hello packets
propogation on the basis of the information of 
position change in it.

Mobility can also affect the duration of validity of 
a routing entry.It can be safely assumed that if there
is no movement there is no need to send routing 
updates, because the old path is still valid. Furthur 
the Hello packets will be minimal in the case of ON
DEMAND routing when there are a few packets to be sent

after a long interval.

regards
Hridesh
> > ----- Original Message -----
> > From: <[email-masked]>
> > To: <[email-masked]>
> > Cc: <[email-masked]>
> > Sent: Monday, October 23, 2000 6:57 PM
> > Subject: AODV HELLO PACKET
> >
> >
> > > Dear Dr/Mr Charles E. Perkins,Dr/Mr Mahesh
> Marina,Dr/Mr Samir
> > >
> > > Thank you very much for replying to my mail.
> > > As Samir has mentioned that the Hello Packet is
> to
> > maintain "local"
> > > connectivity information. I totally agree that
> Hello
> > Packet is needed to
> > > check if there is any link failure in the path
> ACTIVELY IN USE for
> > > transfering of data.
> > >
> > > My question was do we really need to maintain
> > > "local connectivity" among nodes that is not
> involving in
> > the transfering
> > > of real data ?  Do we really need to maintain
> local
> > connectivity of the
> > > whole network ?
> > >
> > > Imagine that there are 20 nodes in an area and
> > > they move randomly. There is a long period of
> time that these
> > > nodes are in SLEEPY MODE where no data is
> transfered among
> > > them. Do we still need to maintain the expensive
> cost of
> > > "local connectivity" that consumes battery power
> of all nodes
> > > when no actual data packet travelling in the
> network ?
> > >
> > > If I am wrong,please kindly correct me.
> > > Thank you very much
> > >
> > > ghee
> > >
> >
> >
> 

__________________________________________________
Do You Yahoo!?
Yahoo! Messenger - Talk while you surf!  It's FREE.
http://im.yahoo.com/

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 24 Oct 2000 08:16:21 -0700

Hello Hridesh,

> can be adjusted according to mobilty.

Does this mean "message frequency"?

How can a node tell if it is moving fast or slow?

>                                          Let us assume

What does it mean, "hello packets propagation"?
Aren't hello messages, when transmitted for the purpose
of neighborhood detection, discarded after processing
(i.e., not forwarded)?

> DEMAND routing when there are a few packets to be sent

But a node cannot tell if it has moved or not,
especially in relation to its neighbors, without
some signal that can be used for detection.
And, I'm not sure how your last statement follows
from the previous ideas.

Regards,
Charlie P.