Subject: AODV cached information

From: WANG Wooi Ghee <[email-masked]>
Date: Wed, 25 Oct 2000 18:58:07 +0900 (JST)

Hai all

I have two questions here concerning the AODV protocol.
If anyone has any idea on those questions please kindly
comment. Thank you.

Question 1
----------
   
   When there is a link failure occured during data transfering, 
how does  the AODV know whether 

to perform "local recovery"

or 

to inform the source node that link failure has occured
in order to broadcast a new RREQ for the destination node.
   
Question 2
----------
Does AODV  first try using the cached information 
before broadcasting a new RREQ ?
The using of cached route information in the intermediate nodes 
and the source node may help limiting the propagation of RREQ. 
I agree with this but I really doubt that using
cached route information may improve performance
over all. 
It may end up generating more RREQ messages instead.

thank you
ghee

---

From: "George N. Aggelou" <[email-masked]>
Date: Wed, 25 Oct 2000 13:26:06 +0100

Hello Wang Wooi,

We have studied the impact of query quenching (route chaching) on the
performance of routing protocols and compared the performance of
AODV/DSR with our RDMAR protocol. Discussion and results could be found
in our WoWMoM99 paper.
Also referring to you question_#1, since RDMAR performs localisation
during the Route Discovery and the Route Maintenance phase, you can find
useful information on when/how RDMAR nodes either repair a route locally
or send error messages back to affected data sources instead.. 

Also D.Maltz & D. Johnson have studied the performance tradeoffs of
route caching. So you may try David's homepage and see some of their
papers.

Regards,
George A.

-- 
*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.     
George N. Aggelou
Research Fellow
Centre for Communications Systems Research   
University of Surrey  		     

http://www.ee.surrey.ac.uk/Personal/G.Aggelou
*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.*.

---

From: "Samir R. Das" <[email-masked]>
Date: Wed, 25 Oct 2000 11:20:03 -0400

>Question 1

The protocol does not really "know" which way would be better. But
one can think of heuristics that would perform well. For example,
if the source is too far in number of hops may be you can go for
local recovery.

>Question 2

I don't follow your point clearly as AODV does not use caching explicitly.
Do you mean that an intermediate node having a valid route to destination
and replying to RREQ is equivalent to caching? Tnen AODV already does what
you mentioned.

Samir