Subject: AODV HELLO PACKET

From: "" <[email-masked]>
Date: Mon, 23 Oct 2000 16:57:23 GMT

Dear Dr/Mr Charles E. Perkins,Dr/Mr Mahesh Marina,Dr/Mr Samir

Thank you very much for replying to my mail.
As Samir has mentioned that the Hello Packet is to maintain "local"
connectivity information. I totally agree that Hello Packet is needed to
check if there is any link failure in the path ACTIVELY IN USE for
transfering of data.

My question was do we really need to maintain
"local connectivity" among nodes that is not involving in the transfering
of real data ?  Do we really need to maintain local connectivity of the
whole network ?

Imagine that there are 20 nodes in an area and
they move randomly. There is a long period of time that these
nodes are in SLEEPY MODE where no data is transfered among
them. Do we still need to maintain the expensive cost of
"local connectivity" that consumes battery power of all nodes
when no actual data packet travelling in the network ?

If I am wrong,please kindly correct me.
Thank you very much

ghee

----- Original Message -----
From: Charles E. Perkins <[email-masked]>
To: WANG Wooi Ghee <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; Elizabeth Royer 
<[email-masked]>; Samir R. Das <[email-masked]>
Sent: Monday, October 23, 2000 11:25 PM
Subject: Re: When the AODV Hello Packet is exchanged ?

>Hello,
>
>It is true that Hello packets consume bandwidth,
>and that we'd like to get rid of them.
>
>According to the specification, Hello packets would
>be transmitted periodically by all nodes if no
>other means of neighbor detection were available.
>
>However, your first choice (a):
>
> > (a) only within nodes along which the RREP packet path is taken.
>
>is intriguing, and I don't recall that we ever thought of
>that idea before.  What _could_ happen is the following:
>
>1) Broadcast RREQ
>2) Unicast RREP
>3) Hello never transmitted unless precursor list nonempty.
>
>I don't see anything wrong with this scenario.
>
>Regards,
>Charlie P.
>
>
>
>WANG Wooi Ghee wrote:
> > > Hai Wong
> > >    Thank you for replying to my question.
> > If the Hello packet is exchanged periodically over ALL
> > of the nodes, won't the hello packet waste the bandwidth
> > and power supply of nodes that are not actively involved
> > in forwarding of real data packet ?
> > Besides, we might piggyback the routing table over the
> > hello packet and spread the routing table over the
> > whole network.
> > But this sounds controversial to the idea of basic
> > on-demand routing protocol where route searching is
> > initiated  ONLY WHEN a sending node originates a data
> > packet addressed to that node.
> > >    If I am wrong please kindly correct me and
> > I really appreciate this.
> > > Thank you
> > > ghee
> > > Author Wong Hau Shian <[email-masked]> wrote:
> > > Hello packets are for neighbour discovery. So packets are exchanged
> > > periodically.
> > >
> > > Regards
> > > HS
> > >
> > >
> > >
> > > > Hai All
> > > >      I am wondering when the Hello packet of AODV is exchanged 
>during
> > > > its oparation.
> > > >
> > > > I wonder that the Hello packet is exchanged within neighboring nodes
> > > >
> > > > (a) only within nodes along which  the RREP packet path is taken.
> > > >
> > > > (b) within nodes after receiving RREQ packet.
> > > >
> > > > (a) actively all of time
> > > >
> > > > If anyone has any idea with this, please kindly inform me.
> > > > I really appreciate this.
> > > >
> > > > Thank you
> > > > ghee
> > >
> > >

_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

Share information about yourself, create your own public profile at 
http://profiles.msn.com.

---

From: "Miguel Sanchez" <[email-masked]>
Date: Mon, 23 Oct 2000 20:34:37 +0200

Hi Ghee,

I see your point but, ... how do you know when a node should be powered up
again? The problem I see is that if you shutdown a node that currently is
not forwarding packets, then nobody can power it up when needed.

Of course some kind of negotiated and time-limited shutdown can be of some
help to conserve node power.

That's my thought.

Regards,

Miguel Sanchez

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 23 Oct 2000 12:32:22 -0700

Hello again,

I have not yet been able to think of any requirement
why a node should have to broadcast and/or receive
Hello messages when it is not actively involved with
any communication or packet forwarding operations.

> of real data ?  Do we really need to maintain local connectivity of the

I would say "probably not".

But, I'll be interested to hear more discussion from
other people who may have thought more about it.

Regards,
Charlie P.

---

From: "Samir R. Das" <[email-masked]>
Date: Mon, 23 Oct 2000 16:01:23 -0400

Deborah Estrin's group in UCLA/USC/ISI has extended AODV to do
something very similar. They have a report on the web available from
http://lecs.cs.ucla.edu/~estrin/
titled "Adaptive Energy Conserving Routing for Mobile Ad Hoc Network."

Samir

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Miguel Sanchez
> Sent: Monday, October 23, 2000 2:35 PM
> To: [email-masked]; [email-masked]
> Subject: Re: AODV HELLO PACKET
>
>
> Hi Ghee,
>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 23 Oct 2000 13:16:58 -0700

Hello again,

I would assume that this strategy can only work in conjunction
with some other protocol operation (perhaps at layer 2) that
causes RREQ broadcasts to have the appropriate effect.
If broadcasts work, then having a node go into reduced power
mode will still be O.K.

Regards,
Charlie P.

---

From: Kwan-Wu Chin <[email-masked]>
Date: Tue, 24 Oct 2000 07:59:19 +1100

Dear Ghee,

> of real data ?  Do we really need to maintain local connectivity of the

 IMHO,  you do not need to maintain local connectivity if you do NOT have
active sessions going through you.   If you have routes which are currently
being used, then certainly yes because you would want to
tell the source ASAP.

> when no actual data packet travelling in the network ?

No, however you might want to maintain connectivity if you
are thinking of doing local recovery through neigboring nodes
which might not be maintaining any routes.

A better way might be to just listen in to neighboring nodes
transmissions and form local connectivity information. <shrug>

kwan

---

From: Kwan-Wu Chin <[email-masked]>
Date: Tue, 24 Oct 2000 08:01:45 +1100

> help to conserve node power.

Dear Miguel,

> Miguel Sanchez

Have a look at a protocol call PAMAS, I think it does do power up and
power down dynamically.

Kwan

---

From: "wooighee" <[email-masked]>
Date: Wed, 25 Oct 2000 12:37:18 +0900

Hello Kwan-Wu
> which might not be maintaining any routes.

Are you trying to say that local recovery is to sharing 
the route information cached in the neighbouring nodes ?