Subject: About MAC using RTS/CTS

From: "Shingo Horisawa" <[email-masked]>
Date: Mon, 19 Feb 2001 13:38:43 +0900

Hi, all.

I have a question about MAC using RTS/CTS.

In the following figure, B sends RTS whose target is C
to neighbor nodes, then A and C, which are neighbor of B, 
receive the RTS. Since A isn't  the target of the RTS,
A enters NAV(RTS) period. The other side, since C is the target
of the RTS, C sends CTS to neighbors. D which receives 
the CTS enter NAV(CTS) period, and B can send data to C. 

  A     B     C     D     E
  | RTS | RTS |     |     |  
  |<----|---->|     |     |  
  *     | CTS | CTS |     |  
  *     |<----|---->|     |  
  *     |     |     * RTS | RTS
  *<----|---->|     *<----|---->  
  *<-D--|--D->|     *  .  |  .
  *<-A--|--A->|     *  .  |  .
  *<-T--|--T->|     *  .  |  .
  *<-A--|--A->|     *     |  
  *<----|---->|     * RTS | RTS 
  *     | ACK | ACK *<----|---->
  *     |<----|---->*     |  
  |     |     |     |     |  
  |     |     |     |     |  

At this point, if the other node E sends RTS to D when E wants to
send DATA to D, since D can't reply to the RTS, E resend RTS to 
the number of times of the maximum retry limit.
If the NAV period of D is long enough, E's retry limit may reach to 
maximum before D's NAV period end.

In this case, is the DATA packet which E wants to send to D dropped?
If so, I think many packets may be dropped when there are a certain 
amount of traffic because congestion occurs in forwarding node. 

Is this true?

Regards.

--  Shingo Horisawa

---

From: "Dr. Obscure" <[email-masked]>
Date: Mon, 19 Feb 2001 07:35:49 -0800

>amount of traffic because congestion occurs in forwarding node.

Shingo, what you suggest is certainly plausible in a multihop wireless 
network, and the protocol designer/implementor must consider congestion and 
fairness  to mitigate the situation you reference.  Generally, (in random 
access protocols) the solution has been to increase back off times when 
packets are dropped (or RTSs go unanswered) to account for 
congestion.  (unfortunately, fading and congestion look a lot alike and 
what is good for one is not necessarily good for the other, but that's a 
different discussion :)  Of course, as with any random access protocol 
excessive traffic can bring the network to it's knees to the point little 
or no real data traffic gets through...

--chane

---

From: "Dr. Obscure" <[email-masked]>
Date: Mon, 19 Feb 2001 07:35:49 -0800

--chane