Subject: Re: Challenges for the MANET addressing model

From: Nitin H Vaidya <[email-masked]>
Date: Fri, 30 Mar 2001 15:00:40 -0600 (CST)

Kevin:

  >> Date: Fri, 30 Mar 2001 09:06:21 -0500
  >> From: Kevin Grace <[email-masked]>
  >> 
  >> In the traditional wired world, the raison d'etre for IP subnets is to
  >> enable route aggregation. Rather than having routes to a bunch of IP
  >> interfaces which are all connected to the same media, a single network
  >> route suffices; a big win for reducing the size of forwarding tables
  >> as well as the amount of information exchanged by routing protocols.
  >> 
  >> But, the underlying requirement is that all IP interfaces for a subnet
  >> appear to be directly reachable from each other (ie. appear to IP to
  >> be one hop neighbors). If this requirement does not hold, then the use
  >> of subnets is not possible and it appears likely that MANET's will not

Don't we have a similar problem when doing IP-over-ATM ?
Or is there something unique here for MANET that I am missing?
          (aside from the fact that the nodes may be mobile).

I have not followed the entire thread so far, so sorry if I am
repeating something that has been said already.

Regards.

- nitin

---

From: "Fred L. Templin" <[email-masked]>
Date: Fri, 30 Mar 2001 14:59:00 -0800

Nitin,

> repeating something that has been said already.

This subject hasn't come out in this thread yet, but it has
occurred to me that there may be some lessons to be learned
from the work done on NHRP (RFC 2332) for ATM and other such
NBMA (non-broadcast, multiple access) networks.

The difference is that MANETs which use link layers such as
IEEE 802.11 are *not* non-broadcast in the traditional sense.
Instead, broadcasts sent from such nodes are heard by some (but
not necessarily all) nodes in the MANET. Perhaps a new term
such as "Limited Broadcast Multiple Access" (LBMA?) would be
more appropriate?

Fred Templin
[email-masked]