Subject: AODV:How about adding a common header...

From: [email-masked]
Date: Tue, 13 Nov 2001 17:47:31 +0900

Hi all,

This is just a suggestion....please correct me if am wrong.

I strongly feel that AODV needs some addtional header formt appart from
the current  RREQ , RREP and RERR messages.It can be a common header 
which may contain lot of useful information.

Some of the fields in this common header can be  version of the protocol , check sum and the length of the packet that follows 
and above all the most important is  previous hop, etc....
Why i am stressing on the last field ( prevous  hop) is , at lot of places in implementation , i need the
previous hop ( in particular while setting up the revers route ). this may be the implementation  dependent 
issue, But i  fell it will be nice and clear i we get this inforamtion from protocol . 

The other fields like checksum ,length of the packet etc will be helpful for detecting the transmission errors.
I don't know how for these filds will be relevant our MANET protocols, because i have just given this with my previous 
experience in MPLS protocols.Any how, my strong belief is that AODV will require one more additional field "previous hop".
Ofcourse, this may increase the packet size and intern consume  more bandwidth which is against the 
philosophy of MANET.

These fields are just a sub set and may be we require more  latter.

So.. any corrections to my thoughts..

ThanQ

PRASAD
Senior Software Engineer
Samsung India Software Operations
Bangalore-1
INDIA
Tel: 91-80-5550555 <ext 2250>

---

From: Henrik Lundgren <[email-masked]>
Date: Tue, 13 Nov 2001 15:02:35 +0100 (MET)

Hello Prasad,

> issue, But i  fell it will be nice and clear i we get this inforamtion from protocol . 

Maybe I am missing something, but I don't see why you would need to 
have a header field with "previous hop". You can easily get this 
info from the IP header (in the case of reverse route, it even says 
so in the draft, v.9, section 8.5).

regards,
Henrik Lundgren

---

From: "Samir R. Das" <[email-masked]>
Date: Tue, 13 Nov 2001 12:43:19 -0500

Hello Prasad,

Everything you need here (checksum, length, previous hop etc.) is already in
the IP header. No need to duplicate all these in AODV.

Samir

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of [email-masked]
> Sent: Tuesday, November 13, 2001 3:48 AM
> To: [email-masked]
> Subject: AODV:How about adding a common header...
>
>
> Hi all,
>
> Some of the fields in this common header can be  version of the
> protocol , check sum and the length of the packet that follows
> The other fields like checksum ,length of the packet etc will be
> helpful for detecting the transmission errors.
> I don't know how for these filds will be relevant our MANET
> protocols, because i have just given this with my previous
> experience in MPLS protocols.Any how, my strong belief is that
> AODV will require one more additional field "previous hop".