Subject: RE: AODV:How about adding a common header...

From: "Samir R. Das" <[email-masked]>
Date: Tue, 13 Nov 2001 20:28:14 -0500

Sorry, my mistake. Checksum in IP header is for the IP header only. So,
looks like we have to depend on the link layer to guarantee the integrity of
routing packets. I wonder whether any other MANET protocol includes an error
checking mechanism as a part of the routing packet ...

Samir

> -----Original Message-----
> From: Casey Carter [mailto:[email-masked]]
> Sent: Tuesday, November 13, 2001 8:09 PM
> To: Samir R. Das
> Cc: [email-masked]; [email-masked]
> Subject: Re: AODV:How about adding a common header...
>
>
> But the checksum in the IP header covers only the IP header.  The AODV
> header is unprotected.
>
> Samir R. Das wrote:
>
> > Hello Prasad,
> >
> > Everything you need here (checksum, length, previous hop etc.)
> is already in
> > the IP header. No need to duplicate all these in AODV.
> >
> > Samir
> >
> >
> >
> >>-----Original Message-----
> >>From: [email-masked]
> >>[mailto:[email-masked]]On Behalf Of [email-masked]
> >>Sent: Tuesday, November 13, 2001 3:48 AM
> >>To: [email-masked]
> >>Subject: AODV:How about adding a common header...
> >>
> >>
> >>Hi all,
> >>
> >>This is just a suggestion....please correct me if am wrong.
> >>
> >>I strongly feel that AODV needs some addtional header formt appart from
> >>the current  RREQ , RREP and RERR messages.It can be a common header
> >>which may contain lot of useful information.
> >>
> >>Some of the fields in this common header can be  version of the
> >>protocol , check sum and the length of the packet that follows
> >>and above all the most important is  previous hop, etc....
> >>Why i am stressing on the last field ( prevous  hop) is , at lot
> >>of places in implementation , i need the
> >>previous hop ( in particular while setting up the revers route ).
> >>this may be the implementation  dependent
> >>issue, But i  fell it will be nice and clear i we get this
> >>inforamtion from protocol .
> >>
> >>The other fields like checksum ,length of the packet etc will be
> >>helpful for detecting the transmission errors.
> >>I don't know how for these filds will be relevant our MANET
> >>protocols, because i have just given this with my previous
> >>experience in MPLS protocols.Any how, my strong belief is that
> >>AODV will require one more additional field "previous hop".
> >>Ofcourse, this may increase the packet size and intern consume
> >>more bandwidth which is against the
> >>philosophy of MANET.
> >>
> >>These fields are just a sub set and may be we require more  latter.
> >>
> >>So.. any corrections to my thoughts..
> >>
> >>ThanQ
> >>
> >>
> >>
> >>
> >>
> >>
> >>PRASAD
> >>Senior Software Engineer
> >>Samsung India Software Operations
> >>Bangalore-1
> >>INDIA
> >>Tel: 91-80-5550555 <ext 2250>
> >>
> >
>
>
> --
> Casey Carter
> [email-masked]
> [email-masked]
> AIM: cartec69
>

---

From: Ville Typp� <[email-masked]>
Date: Wed, 14 Nov 2001 11:47:50 +0200

As far as I know AODV packets are delivered with UDP. And UDP header 
checksum is calculated also over the data field, i.e. over the AODV packet. 
Shouldn't this be enough?

-Ville

---

From: Antti J Tuominen <[email-masked]>
Date: Wed, 14 Nov 2001 12:09:32 +0200

> checking mechanism as a part of the routing packet ...

And IPv6 header doesn't even have checksum, but come on..  AODV
messages are sent over UDP and UDP has checksum covering also the
data.  Or am I missing something fundamental here?

Regards,

Antti