Subject: Give me some advice!

From: Wu Xiaobing <[email-masked]>
Date: Wed, 19 Dec 2001 19:47:8 +0800

Hello researchers,
	We can divide the current routing protocols into 3 categories,namely,table-driven,on-demand and hybrid.On-demand routing always has 2 major parts:route discovery and route maintenace.And
the route discovery function requires some forms of flooding(correct me if I am wrong).
    We know that flooding always results in an increase of overhead which we here are striving to avoid because of the bandwidth constraints of an ad hoc network.Meanwhile it is safe to say that when we fail to find a feasible route,we'd better try again.
    When we use a TTL field to restrict the range of flooding,thus decreasing overhead.Some try to
use a static number(e.g.,a number of hops),while some try to use an estimated number which depicts the biggest distance value inside the network.
    My idea is that when we fail with a value of x,we try again with 2x.Next time we try again with 4x and so on.Anyway initially,we can use a reasonalbe number.This kind of mechanism may also result in a high overhead.But in my mind,when we fail to find a route,we have to try again.Why not try again with a better possibility of success?
	Welcome your comments!
    Merry Christmas to all!

Xiaobing Wu

---

From: Joe Macker <[email-masked]>
Date: Wed, 19 Dec 2001 12:47:46 -0500

Expanding ring search techniques have been suggested and applied in some cases already. See AODV and DSR as well as other protocols (e.g., multicast variants).  There is  certainly a set of scenario dependent tradeoffs to consider when applying such techniques and particular searching algorithms but the basic technique is well known.

---

From: Dinesh Dharmaraju <[email-masked]>
Date: Wed, 19 Dec 2001 16:57:55 -0500 (EST)

Hi,
  We have done some studies with expanding ring search in TORA. Though we
have not been conclusive about the way hop-count incremennting should be
done, it can be seen that kind of increments to the hop-counts you want to
have will depend on the scenario you have. If you have uniform node
density, you might do good having increments of x, sqrt(2)*x,
sqrt(3)*x,....  to have an additive increase in the number of nodes you
want to cover in each query ring. If you want to go faster, you will
either do an additive or a multiplicative increase in the hop-count.
Regards,
Dinesh

---

From: Nadeem Akhtar <[email-masked]>
Date: Thu, 20 Dec 2001 12:10:59 +0000 (GMT)

Hi Wu,
 I read your thoughts with great interest. It is indeed true that flooding
the network with route-request results in a big overhead. We have been
investigating ways to localise the route search so that resources are
utilised more efficiently. George Aggelou (University of Surrey) proposed
the 'Relative Distance Micro Area Discovery Routing' (RDMAR) protocol. The
USP of this protocol was that before the actual route discovery initiation, 
the source node first tried to estimate the location of the destination
node and then launch the query with TTL equal to the predicted 
distance. An Internet Draft was posted and we are in the process of
reviving it. We intend to put it up again asap.

Cheers,
Nadeem

Nadeem Akhtar
Centre for Comm. Systems Research
University of Surrey
Guildford, Surrey GU2 7XH
United Kingdom

Tel (CCSR) : 01483-689488