Subject: Re: Shadowing in network simulator

From: Yi Lv <[email-masked]>
Date: Tue, 29 Jan 2002 09:43:23 -0500 (EST)

On Mon, 28 Jan 2002, Raymond Wang wrote:
Hi, Ray:

Thanks for your reply!
Actually, i didn't really get into the simulators GloMoSim and OPNET, but
i did see through the code of ns-2 and didn't find anything regarding
lognormal shadowing. The version i read was ns 2.1b4a and cmu extension
1.1.2, could you please designate the version that added the shadowing, if
any?

Thanks a lot!
Yi Lu

> Hi Yi,
> 
> Not sure where you got that info, but as far as I
> know, GloMoSim/Qualnet, ns-2, and OPNET all support
> lognormal shadowing, aka "large-scale" fading which is
> usually on the order of distances of ~100 m.  For most
> of the foreseeable applications of ad hoc networks,
> lognormal shadowing will be much less of a factor than
> path loss and multipath, or "small-scale", fading
> since these applications will generally be on a small
> scale (i.e. <= 100 m) or, in many military apps, in an
> environment where there is little to no shadowing. 
> 
> Ray
> 
> --- Yi Lv <[email-masked]> wrote:
> > Dear All:
> > 
> > I am wondering if there's some network simulator
> > that includes the
> > shadowing in the propagation model. As i know,
> > GloMoSim, ns-2 and OPNET
> > all do not inlcude shadowing, while they have added
> > or are going to add
> > multipath fading. Is that because shadowing is not
> > an main factor in
> > ad-hoc network environment? Or is it hard to
> > simulate?
> > 
> > Thanks a lot!
> > BR/Yi Lu
> > 
> > 
> 
> 
> __________________________________________________
> Do You Yahoo!?
> Great stuff seeking new owners in Yahoo! Auctions! 
> http://auctions.yahoo.com
>

---

From: Raymond Wang <[email-masked]>
Date: Tue, 29 Jan 2002 09:41:58 -0800

Yi,

I am using ns-2.1b8a which comes with shadowing support.  To answer your 
question below whether it is hard to simulate, it's pretty simple to 
simulate large-scale fading for any packet-level simulator.  The real 
challenge is trying to simulate bit-level effects like small-scale fading.

Ray

---

From: Joe Macker <[email-masked]>
Date: Tue, 29 Jan 2002 14:41:51 -0500

I found it in 2.1b7a so more recent releases should also have it.

---

From: Yi Lv <[email-masked]>
Date: Tue, 29 Jan 2002 21:11:40 -0500 (EST)

On Tue, 29 Jan 2002, Raymond Wang wrote:
Hi, Ray:

I just checked the ns-2.1b8a. Thanks!

Here are some more questions.

1. Shadowing was modulated in the free space path loss, rather than a
combination of free space path loss or two-ray ground path loss, with a
breaking-point distance d0, which was implemented in class TwoRayGround
without shadowing. Why changing the path loss model in the case of
shadowing?

2. As we know, shadowing is caused by large obstructions such as buildings
and hills. Is that reasonable only adding a random variable with
log-normal distribution, while not taking the terrain infomation into
account? In other words, seems that there's no such information in the
scenario, right?

3. Still not see any multipath fading model in this version, does anybody
have idea about how important it is for the performance of upper layer
protocol?

4. I am a new comer in the simulation, and i am wondering if there's some
report that indicated how the result of simulation fits the real case, if
there's some real product that has been taken field test, so that i could
get more confidence doing that, since there are so many issues which might
seem not realistic.

Thanks a lot!

BR/yi lu