Subject: a problem in TORA for highly mobile ad hoc networks

From: mustafa ozdemir <[email-masked]>
Date: Wed, 16 Jan 2002 13:58:15 -0800 (PST)

Hi all,
In the case of very highly mobile nodes, there is a
problem using TORA when a network partition happens.
For example, let's say a network partition happened
and one of the nodes lost its last downstream link and
it generated a new reference level. Under normal
conditions we are expecting that this reference level
will reflect and come back to the originator node of
this reference level that will detect the partition
and delete all the routes. However, after the last
reference level, there will be another node that will
loose the last downstream link due to a link failure
and that will generate another reference level. That's
because of highly mobility. In other words, in the
convergency time of detecting network partion, there
will be other nodes generating new reference levels.
Because of that, we can't detect network partion.
Do you know any solution to this problem?
Thank you
mustafa

__________________________________________________
Do You Yahoo!?
Send FREE video emails in Yahoo! Mail!
http://promo.yahoo.com/videomail/

---

From: Dinesh Dharmaraju <[email-masked]>
Date: Fri, 18 Jan 2002 10:58:22 -0500 (EST)

Hi Mustafa,
  For any partition detection in a network, you need the 
"partition detection" messages starting from a node to reach the edge of
the network and return back to you. In this period, you need to have the
connectivity graph of your partition of the network to remain static.
  If the connectivity graph changes by the time the partition-detection
messages return back to the node that generated them, your network
dynamics are too fast for the partition detection mechanism.
  
  The same holds good for the 3 pass generation, propagation and
reflection mechanism in TORA.