Subject: plot the trace file??

From: Michael Sessinghaus <[email-masked]>
Date: Wed, 30 Jan 2002 14:52:17 +0100

Hi,

I have a problem to plot the data streams from ns trace format.
How I convert the ns trace to xgraph or matlab??
I search for a tutorial but i find nothing.
I want to plot TCP throughput, goodput and other related data streams.

PLEASE HELP ME!

Thankful for your help.
Best Regards, Michael.

________________________________________________________________
Keine verlorenen Lotto-Quittungen, keine vergessenen Gewinne mehr! 
Beim WEB.DE Lottoservice: http://tippen2.web.de/?x=13

---

From: Joe Macker <[email-masked]>
Date: Wed, 30 Jan 2002 15:24:27 -0500

Michael:

There are lots of possible tools for this and some very specific detailed tcp ones that are good.  The ns distribution also has some example scripts.  

As another tool for your bag of tricks, you could look at something we developed, trpr, which has trace parsing and statistical analysis routines and acts as a front end to gnuplot.  We use it to plot drec and tcpdump outputs both in real-time and non-realtime modes.  We recently added an ns capability recently as well which may work for you. There is a description, source code, and user's guide here.
 
http://proteantools.pf.itd.nrl.navy.mil/
and a source code project site at
http://pf.itd.nrl.navy.mil/projects/proteantools/

-joe