Subject: Will GPS be very important in ad hoc network?

From: "veron@263" <[email-masked]>
Date: Wed, 16 Jan 2002 13:8:0 +0800

Hello all, 
       I'd like to know if a GPS is implemented in the node of the ad hoc network, Will the topology management problem can be solved? and the routing protocol can also be simpler than nowadays? If location can be sure of, the communication problem can be changed into "power consumption(saving) problem" and "MAC problem"? Thanks in advance, who have interests on this fields.

　　　　　　　　　　　　　　veron
　　　　　　　　　　　　　　[email-masked]
　　　　　　　　　　　　　　　　　2002-01-16

---

From: "Philippe Jacquet" <[email-masked]>
Date: Wed, 16 Jan 2002 11:40:41 +0100

This is an old question. GPS can only be used outdoor and does not
necessarily reflect the connectivity of the network. For example two nodes
may have close coordinates but are out of radio range because there is an
obstacle between them (tree, cars, building, hill). Conversely two nodes
maybe far away and are within radio range because of favorable echos (two
nodes in a long narrow street between steel-glass buildings).

Philippe
----- Original Message -----
From: "veron@263" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, January 16, 2002 12:00 AM
Subject: Will GPS be very important in ad hoc network?

> Hello all,
>        I'd like to know if a GPS is implemented in the node of the ad hoc
network, Will the topology management problem can be solved? and the routing
protocol can also be simpler than nowadays? If location can be sure of, the
communication problem can be changed into "power consumption(saving)
problem" and "MAC problem"? Thanks in advance, who have interests on this
fields.

---

From: Hannes Hartenstein <[email-masked]>
Date: Wed, 16 Jan 2002 15:46:46 +0000

We have recently published a survey on position-based routing for mobile
ad hoc networks in IEEE Network Magazine, November/December 2001 issue.

Title:" A Survey on Position-Based Routing in Mobile Ad Hoc Networks"
Authors: M. Mauve, J. Widmer, H. Hartenstein

We think that position-based routing might be a promising approach for
vehicular ad hoc networks ... results are underway ...

Hannes

"veron@263" wrote:

> ¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡veron
> ¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡[email-masked]
> ¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡2002-01-16

--
Dr Hannes Hartenstein           [email-masked]
Senior Research Staff Member    Tel.: +49 6221 13708 14
Network Laboratories            Fax.: +49 6221 13708 28
NEC Europe Ltd.
Adenauerplatz 6
69115 Heidelberg, Germany       http://www.ccrle.nec.de/

---

From: Joe Macker <[email-masked]>
Date: Wed, 16 Jan 2002 10:40:16 -0500

At 01:08 PM 1/16/2002 +0800, veron@263 wrote:
>Hello all, 
>       I'd like to know if a GPS is implemented in the node of the ad hoc network, Will the topology management problem can be solved? and the routing protocol can also be 

No it will not be solved. It MAY help in some cases/specific systems (it is interesting and of some value).

A couple points real quick begin a person who has experimented significantly with such systems...

(1) GPS does not operate well in many environments of interest, inside buildings being the obvious one.

(2) Geographic topology does not necessarily reflect desired routing topology or actual achievable wireless topology (non-homogeneous, non-symmetric  propagation medium).

Also, we have had this debate many times in the past. My thought is it can be useful as optimization aid in certain cases and under certain conditions. Also knowing location doesn't tell me the power requirement (it can be order of magnitude off), unless I have a known homogeneous propagation medium.  Simple example is, I am Node A, Node B is north 500 feet away down a clear line-of-sight roadway with little obstructions, Node C is south 300 feet away from me through dense foliage.  I likely need alot more transmit power to reach C. The radio propagation environment's limiting factors are very scenario specific and dynamic due to shadowing, diffraction,etc. evem when nodes are not mobile themselves..

>simpler than nowadays? If location can be sure of, the communication problem can be changed into "power consumption(saving) problem" and "MAC problem"? Thanks in advance, who have interests on this fields.
>
>

---

From: Olivier Coutant <[email-masked]>
Date: Wed, 16 Jan 2002 18:04:13 +0100

Hi,
just a comment from a future user of MANET protocol. We develop seismic
recorders for field experiment (ie outdoors) that includes
both 802.11b radio and GPS.
- The GPS first purpose is to give an accurate time (better than ms) to the
recorder. Thus, the first use  of the
GPS-radio association will be the ability of setting precise time window where
radios are supposed to talk and sleep, that is
a power-saving concern.
- The second GPS possible application is to obtain from the receiver one of the
two phases (named L1) and to perform relative location
   by postprocessing. The relative location accuracy is expected to be <1cm when
aperture do not exceed ~km.
   We plan to use that to display a geometry of the network in the field.

Cheers
O. Coutant

--
Laboratoire de Geophysique Interne et Tectonophysique (UMR CNRS C5559),
Universite Joseph Fourier

adresse: BP 53X F38041 Grenoble Cedex, France
Tel:     +33 (0)4 76828029
Fax:     +33 (0)4 76828101

---

From: Rex Buddenberg <[email-masked]>
Date: Wed, 16 Jan 2002 09:22:41 -0800

>?Hello all,
>        I'd like to know if a GPS is implemented in the node of the 
>ad hoc network, Will the topology management problem can be solved? 
>and the routing protocol can also be simpler than nowadays? If 
>location can be sure of, the communication problem can be changed 
>into "power consumption(saving) problem" and "MAC problem"? Thanks 
>in advance, who have interests on this fields.
>
>
>??????????????veron
>??????????????[email-masked]
?????????????????2002-01-16
No.

Physical position does not reflect reachability (which drives the 
logical topology in a network).  A trivial, but real world, example. 
If I have a node with an 802.11 interface and the guy 5 feet away 
from me has a node with an HF radio-WAN interface or a wired ethernet 
interface, we both have to find the nearest router to communicate 
with each other (ignoring the out of band 'Hey, Bub' externalities).

Further, GPS is far from a complete solution.  For example, it 
doesn't work indoors (1.6GHz line of sight propagation) and where it 
does work indoors it's getting reflections from somewhere -- 
multipath propagation is occasionally useful in comms, but it's 
ALWAYS BAD in radionav.

and

At 4:17 PM +0800 1/16/02, Marwaha Shivanajay wrote:
>I have come across a v. useful paper which shows that using GPS info, the
>route discovery flooding can be controlled in a given zone called the
>routing zone thereby not flooding the entire network. I think this was by
>Prof. Nitin Vaidya (most probably).

I'm sure this rests on the assumption that physical proximity and 
reachability are the same.  False assumption in real world.

>
>Other papers can also be found which use GPS info.  For military purposes
>not only GPS but also UAVs can be used for getting locaion info.
>
>But like military satellites that give v accurate location info, do
>commercial satellites also give reasonably accurate location?

There are satellite navigation systems that predate GPS but use 
exactly the same physics.  But they work on ranging from 
geosynchronous satellites that were placed in orbit for different 
purposes (comms).  These work fine in mid-latitudes, but are below 
the horizon at high latitudes and the geometric dilution of precision 
goes to Hell at low latitudes (translation: the geometry's bad).

>Also, I want to know whether it is cost affective and what is the coverage
>and availability aspect of GPS in non-military applications of MANETs.

Availability (Ao, as in uptime/total time) for GPS is about 99.8%. 
The remaining 0.2% falls into engineering problems (the satellite 
fails) and environmental ones (the sun spews out a bunch of junk that 
interrupts things).  This availability figure is about what we get 
out of Loran too, except all the failure modes are entirely different 
(no single points of failure between the two technologies).

But your question implies some broader issues:
   - integrity.  GPS, like all nav systems, has the ability to lie to 
you.  And unlike Loran, GPS has no built-in alarming system to tell 
the user it's on the fritz.  In the US maritime world, we sealed that 
up with differential GPS (I think Singapore has done the same).

   - the positioning error budget for GPS has 6 components in it:
      o ephemeris errors -- the satellites aren't quite at predicted positions
      o timing errors -- each satellite has a cesium, see the US Naval 
Observatory web page for the error measurements
      o selective availaibility  -- deliberate error introduced by the 
operators to degrade targeting.  Currently turned off.
      o ionospheric distortion
      o tropospheric distortion
      o receiver noise.

Differential GPS addresses the first five of these errors.  In the 
sixth, the largest component is usually multipath -- urban canyons 
and crowded parking lots are bad news for GPS.

>Regards,
>Shivanajay Marwaha
>-~-~-~-~-~-~-~-~
>RS, ECE Dept., NUS.
>Singapore.
>http://www.nus.edu.sg/

-- 
b