Subject: Re: summary of response to dumber

From: Joe Macker <[email-masked]>
Date: Wed, 09 Jan 2002 16:31:36 -0500

At 02:53 PM 1/8/2002 -0800, Nast, Douglas P wrote:

>By way of clarifification, "flooding" to me is sending a packet out on every
>interface but the one you received it on.   It generates a lot of duplicates
>and wastes a lot of bandwidth.  RPF is appreciably better in theory
>(although Fred warns me against it). 

Doug, 

I just wanted to correct the flooding definition above which uses the term interface,

For some wireless interfaces, forwarding out the physical interface a packet is received is allowed and expected when flooding and when generally forwarding.  This is because the interface is semi-broadcast in nature (e.g, two neighbors I have logical connections to on the interface don't necessarily connect to each other directly). MPR based flooding and other manet-techniques deal with these characteristics that are different from the typical wired interface.

Also, in some MAC cases (and we should be designing for some heterogeneity here) it is important to verify neighbor bidirectionality. Subtle but important points manet protocol designers address.  Non-wireless connections often assume certain physical characteristics that don't apply necessarily here.  It might be useful to have an informational to better expose some of these basic design issues to the broader Internet community.
 
-Joe

>Everybody seems to agree that the answer to the "manet flooding" question is
>IP multicast. So the only question is which protocol?
>
>So what's the problem?   
>
>Doug Nast, Boeing
>
>
>
>
>
>
>

---

From: [email-masked]
Date: Wed, 09 Jan 2002 17:34:55 -0800

We still are not agreeing on the definition of "flooding", as I explain below.
I hope we can clear this up and come up with a definition that we can agree on.
Internet Drafts are supposed to define their terms, but I have not seen
the term "flooding" actually defined in either of the following drafts:

  draft-ietf-manet-bcast-00.txt 
  draft-ietf-manet-simple-mbcast-01.txt

First I will summarize how some people define "flooding":

Joe Macker wrote:

> For some wireless interfaces, forwarding out the physical interface a packet is received 
> is allowed and expected when flooding and when generally forwarding. 

Let's assume for simplicity that every node in the MANET has a single broadcast interface.  
If we correct Doug Nast's definition according to Joe, then each flooded packet 
will be transmitted by every node in the network.

Brad Williams wrote:

> In my opinion, the term Flooding indicates the specific protocol
> in which each node rebroadcasts each originated flooded packet exactly one
> time  (Internet Draft - A Simple Protocol for Multicast and Broadcast in Mobile
> Ad Hoc Networks, 2001 -  provides the details).

OK.  Brad's definition agrees with Doug's definition corrected by Joe.  
This also agrees with the flooding protocol described in draft-ietf-manet-bcast-00.txt.
This is often called "classical flooding".  So far, so good.

However, people are now using the term "flooding" to mean something different.

For example, Charlie Perkins implied that a tree *could* be used for flooding:

> For reliable flooding in an ad hoc network, there would be a lot of bookkeeping
> and maybe a tree would after all be the right thing,...

This would not be the same as "classical flooding", e.g., the leaves of the tree would 
not have to retransmit each packet.

For another example, Joe Macker noted that flooding can be achieved using multipoint 
relays.  Again, this is not "classical flooding", since not all nodes would have to
retransmit each packet.

Charlie Perkins wrote:

> I think there should be two work items for the manet working group:
> 1) Unreliable, "best-effort" flooding
> 2) Multicast.

Frankly, I don't know whether Charlie means "classical flooding" or is allowing
the possibility of a more efficient mechanism for network-wide broadcast.

This confusion can be cleared up by using the term suggested by Brad Williams:
"network-wide broadcast".  To me, "flooding" is one mechanism for achieving 
network-wide broadcast.    

I don't think the working group should dictate the *mechanism* for achieving
network-wide broadcast, so I suggest that the first work item above
be changed to "unreliable, network-wide broadcast".   

Another possility is to define "flooding" to be more than just "classical flooding",
but this seems to confuse some people.

Of course, network-wide broadcast can also be used for multicast if a 
multicast protocol is not available (but would be less efficient).

Richard

> Also, in some MAC cases (and we should be designing for some heterogeneity here) it is important to
 verify neighbor bidirectionality. Subtle but important points manet protocol designers address.  Non
-wireless connections often assume certain physical characteristics that don't apply necessarily here
.  It might be useful to have an informational to better expose some of these basic design issues to 
the broader Internet community.

---

From: Charlie Perkins <[email-masked]>
Date: Wed, 09 Jan 2002 22:10:00 -0800

Hello Richard,

There is a definition in "draft-manner-seamoby-terms-00.txt", which
was taken from a very old draft submitted for consideration within
the manet working group.  I still think it would be a good idea to
have a terminology draft, and the abovementioned draft would not
be such a bad place to start.

> not have to retransmit each packet.

I agree with you that this would be different.  Wouldn't it still be flooding, though?

> the possibility of a more efficient mechanism for network-wide broadcast.

I thought that "flooding" meant making an attempt to send some payload
to every node.  If that's right, then whether it is done "classically" or by
some other algorithm might not change the name of what is actually done.

> "network-wide broadcast".  To me, "flooding" is one mechanism for achieving

I understand that, but on the other hand "broadcast" has its own pile of baggage.
There's "limited broadcast", "network-wide broadcast", "directed broadcast",
and probably still "unreliable" vs. "reliable" broadcast ...

> be changed to "unreliable, network-wide broadcast".

I'm happy with whatever terminology people agree on.

> but this seems to confuse some people.

Why is it confusing?

Regards,
Charlie P.

---

From: [email-masked]
Date: Thu, 10 Jan 2002 00:40:53 -0800

Hi Charlie,

I see that we both work late at night.

> be such a bad place to start.

Thanks, but that draft does not seem to be available - maybe it has expired.
Can you post the draft or at least the definition?

> I agree with you that this would be different.  Wouldn't it still be flooding, though?

That depends on the definition of "flooding", which still is not clear to me.
(I tend to agree with two recent posters who consider "flooding" to be
essentially the same as "classical flooding".)

> some other algorithm might not change the name of what is actually done.

My point is that I am not sure this is the correct definition of flooding.
In the 80's, "flooding" meant what we now call "classical flooding".
Other terms (e.g., limited flooding) were used when each packet was
transmitted by only a subset of nodes.  Has this definition changed?
Two people who recently posted to this list seem to think that the
definition has not changed.

> and probably still "unreliable" vs. "reliable" broadcast ...

That's true.  But isn't it clear and unambigous what "network-wide broadcast" means?

> > but this seems to confuse some people.

I think I addressed this above.  At least two recent posters have stated
that "flooding" means what we are calling "classical flooding".
I am concerned that this could confuse many more people in the future,
*if* a significant number of people also think this.

On the other hand, "network-wide broadcast" seems to be unambiguous.

Regards,
Richard

---

From: [email-masked]
Date: Thu, 10 Jan 2002 14:03:49 +0100 (CET)

Hi Richard,

> Can you post the draft or at least the definition?

I asked google. The draft is available here:

http://alternic.net/drafts/drafts-m-n/draft-manner-seamoby-terms-00.txt

<SNIP>

Best regards

--thomas

-- 

-------------------------------------------
  Thomas Heide Clausen
  Civilingeniør i Datateknik (cand.polyt)
  M.Sc in Computer Engineering

  E-Mail: [email-masked]
  WWW:    http://www.cs.auc.dk/~voop
-------------------------------------------

---

From: Joe Macker <[email-masked]>
Date: Fri, 11 Jan 2002 10:39:33 -0500

>will be transmitted by every node in the network.

Richard, the above is not what I meant in clarifying Doug's definition.  I was only pointing out the "semi-broadcast nature" of some wireless MAC layers and that for wireless interfaces one cannot assume that forwarding out the interface it came in on is wrong. This does not imply every node has to transmit the packet.  So .. the interface term was a wrong one to use for a flooding definition..that's an implementation specific thing.  It just so happens that it is often an implementation assumption for flooding techniques in wired networks.  Also, even when forwarding out the same interface (as needed) not every node has to transmit the packet to more optimally flood so the two are issues are separable.

Its a good terminology discussion I just wanted to further clarify what I meant by adding to Doug's message .... for some of you its second nature by now but to the larger community I feel some of the unique wireless routing interface issues may sometimes be misunderstood ... so we should be careful in any discussion in laying out assumptions and techniques.

-Joe