Subject: Address Allocation

From: MEDDOUR Djamal Eddine thesard FTRD/DAC/LAN <[email-masked]>
Date: Wed, 23 Jan 2002 11:30:46 +0100

hi every body

is anyone know the manner used by an Ad Hoc host to get an IP address ? is
there a differences betwwen a local area and a large nnetwork for the
allocation ?

best regards

---

From: Kilian Weniger <[email-masked]>
Date: Fri, 25 Jan 2002 22:32:17 +0100 (CET)

We have a paper about IPv6 Stateless Address Autoconfiguration
in large mobile ad hoc networks.

In our approach, an hierarchical address space is build up
and the flooding during the Duplicate Address Detection
is limited. Therefore, we claim to achieve an improved scalability.
Furthermore, unique addresses are also guaranteed in the case
that two independently configured networks merge.

You can download the paper at our IPonAir-project homepage:

  http://www.iponair.de/publications_en.shtml

Kilian Weniger

On Thu, 24 Jan 2002, Elizabeth M. Belding-Royer wrote:

>
>
> > At 02:30 AM 1/23/2002, MEDDOUR Djamal Eddine thesard FTRD/DAC/LAN wrote:
> > I don't see any draft that specifically addresses that.
> >
>
> Our revised Internet Draft on address autoconfiguration
> (revised for the last IETF) addresses this issue for both
> IPv4 and IPv6 networks.  The basic mechanism is that
> a mobile node selects an address from some address space,
> and then it must perform duplicate address detection to
> ensure that address is not already claimed within the network.
>
> The draft name is draft-perkins-manet-autoconf-01.txt.
> Its in the Internet Draft repository.
>
> Elizabeth
>

-- 
----------------------------------------------------------------------------------------
Dipl.-Ing. Kilian Weniger           phone: (+49)(0)721-608 6415
Institute of Telematics             fax:   (+49)(0)721-388097
Department of Computer Science      email: [email-masked]
University of Karlsruhe 	    homepage: http://www.tm.uka.de/~weniger/
D-76128 Karlsruhe