Subject: [manet] Protocol reference list

From: David Lundberg <[email-masked]>
Date: Tue, 30 Jul 2002 17:51:26 +0200 (CEST)

During the work with my MSc thesis i have created a list with the
protocols I've come across. Comments on categories, sorting and of course
errors are very welcome. It would be usefull to have a discussion if it
really is possible to have ONE protocol serving all needs...

-------------------------------------------------------------------------

Pro-active: (Table-driven)

CGSR Clusterhead Gateway Switch Routing protocol
DBF Distributed Bellman-Ford routing protocol
DSDV Distance Source Distance Vector routing protcol
DTDV Higly Dynamic Destination-Sequenced Distance Vector routing protocol
HSR Hierarchical State Routing protocol
HSLS Hazy Sighted Link State routing protocol
LCA Linked Cluster Architecture
OLSR Optimized Link State Routing Protocol
STAR Source Tree Adaptive routing protocol
TBRPF Topology Broadcast based on Reverse-Path Forwarding routing protocol
WRP Wireless Routing Protocol 

Reactive: (On-demand)

AODV Ad hoc On Demand Distance Vector routing protocol
ABR Associativity Based Routing protcol
BSR Backup Source Routing protocol 
DSR Dynamic Source Routing protocol
DSRFLOW Flow State in the Dynamic Source Routing protocol
FORP Flow Oriented Routing Protocol
LMR Lightweight Mobile Routing protcol
LUNAR Lightweight Underlay Network Ad hoc Routing
RDMAR Relative-Distance Micro-discovery Ad hoc Routing protocol
SSR Signal Stability Routing protocol
TORA Temporally-Ordered Routing Algorithm routing protocol

Hierarchical:

CBRP Cluster Based Routing Protocol
CEDAR Core Extraction Distributed Ad hoc Routing
GSR Global State Routing protocol
FSR Fisheye State Routing protocol
HARP Hybrid Ad Hoc Routing Protocol
HSR Host Specific Routing protocol
LANMAR Landmark Routing Protocol for Large Scale Networks (table?)
ZRP Zone Routing Protocol protocol
BRP Bordercast Resolution Protocol
IARP Intrazone Routing Protocol
IERP Interzone Routing Protocol

Geographical:

DREAM Distance Routing Effect Algorithm for Mobility
GLS(Grid) Geographic Location Service
LAR Location-Aided Routing protocol
ZHLS Zone-Based Hierarchical Link State Routing

Multicast:

ADMR Adaptive Demand-Driven Multicast Routing protocol

AMRIS Ad hoc Multicast Routing protocol utilising Increasing id-numbers
AMRoute Ad hoc Multicast Routing Protocol
CAMP Core-Assisted Mesh Protocol
DDM Differential Destination Multicast
LAM Lightweight Adaptive Multicast protocol
DSR-MB Simple Protocol for Multicast and Broadcast using DSR
MAODV Multicast Ad hoc On-Demand Distance Vector routing
MZR Multicast Zone Routing protocol
ODMRP On-Demand Multicast Routing Protocol
SRMP Source Routing-based Multicast Protocol

Still assorted:

PARO Power-Aware Routing Optimization Protocol (table?)
DDR Distributed Dynamic Routing Algorithm

-------------------------------------------------------------------------

My final draft on my thesis can be found on the locations below for those
intrested in references etc.

http://www.docs.uu.se/~davidlu/thesis.pdf
http://www.docs.uu.se/~davidlu/thesis.ps
http://www.docs.uu.se/~davidlu/thesis/ (HTML)

Regards,

// David //

--------------------------------------------------------------
David Lundberg            Phone: Home(Uppsala)  +46-018-460356
Mail: [email-masked]        Home(Gävle)    +46-026-146743
Http: www.update.uu.se/~davidl   Cellular      +46-070-3531696
ICQ:  13440550                   DoCS @ UU     +46-018-4716231
--------------------------------------------------------------

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Jorge Nuevo <[email-masked]>
Date: Tue, 30 Jul 2002 13:39:52 -0400 (EDT)

Hello David,

Some protocols that can be added to your complete list may be the following

Geographical Multicast (Geocasting):

 LBM - Location Based Multicast (Y.Ko and Vaidya 1998)
 GeoGRID (Liao, Tseng, Lo and Sheu 2000)
 GeoTORA 
 Mesh-Based Geocast Routing (Boleng, Camp and Tolety 2001)

Multicast

 FGMP - Forwarding Group Multicast Protocol (Chiang, Gerla, Zhang 1998)
 ABAM - On-Demand Associativity-Based Multicast 
 MCEDAR - Multicast CEDAR (Sinha and Bharghavan 1999)

 Jorge
 [email-masked]

---

From: Jorge Nuevo <[email-masked]>
Date: Tue, 30 Jul 2002 13:39:52 -0400 (EDT)

Hello David,

Multicast

 
 Jorge