Subject: RE: OSPF to AODV bridging was Re: [manet] RE: Gateway Advertiseme nts

From: "Manfredi, Albert E" <[email-masked]>
Date: Fri, 26 Jul 2002 14:43:58 -0400

To the extent that "me too"s are worth anything, I second Phil's points. There is no need, IMO, for a special "foreign agent" advertisement. I'd also stick with existing standards, since they seem to provide all the required features as is, as far as what is required of the wired Internet. If Mobile IP doesn't need a FA advertisement, I really fail to see why MANET would.

Bert

> -----Original Message-----
> From: Phil Neumiller [mailto:[email-masked]]
> Sent: Friday, July 26, 2002 8:54 AM
> To: Charlie Perkins; Elizabeth M.Belding-Royer; [email-masked]
> Cc: Mobile Ad Hoc IETF working group
> Subject: Re: OSPF to AODV bridging was Re: [manet] RE: Gateway
> Advertisements
> 
> 
> Hi Charlie, Elizabeth, Yuan,
> 
> I have some comments on draft-royer-manet-globalv4-00.txt.  I did not
> like some things about the draft so please be patient with my 
> complaints.  :-)  
> I have suggested a possible alternative approach that I 
> believe is more "generic".
> 
> There seems to be a few different classes of things that use 
> similar mechanisms to
> Router Discovery as proposed in RFC 1256 (I am sticking with 
> IPv4 in this letter).  
> 
> o Foreign Agent / Home Agent Advertisement uses RFC-1256 with 
> extensions. 
> o IGPs such as OSPF / EIGRP etc use RFC-1256 directly.
> o Draft draft-royer-manet-globalv4-00.txt makes does not make 
> direct use of RFC-1256.
> 
> A quote from draft-royer-manet-globalv4-00.txt states
> 
>     "Agent Advertisement messages initiated by foreign agents 
> are re-broadcast
>      by the nodes within the ad hoc network so that mobile 
> nodes may learn of the
>      presence of the FA".
> 
> 1). This can only imply limited flooding, which should always 
> be avoided if possible.
> 
> 2).  The draft implies a change is needed for MIP FAs.  This 
> does not seem like
>       a good idea to me.  Furthermore, the suggested change 
> only addresses AODV 
>       not other MANET protocols.
> 
> 3).  I believe a "clean use" of RFC 1256 is possible without 
> any modification to 
>       MIP.
> 
> 4).  I believe the term access point should be avoided.  The 
> industry trend for
>       access points is towards dumb wireless to wireline 
> bridges, i.e. 802.11b/a/g
>       APs.  A more appropriate word might be fixed network 
> /wireline router.
> 
> 5).  The method also implies that AODV nodes are being 
> proactive about 
>        mobility agents and always putting a default route 
> into to an FA when 
>        they "hear" advertisements (or the flood occurs).
> 
> 6).  It may be necessary to discover land-line IGP routers 
> that are on the path 
>       between the path of the AODV network and the FA/HA. 
> 
> 7).  I believe its a very bad idea to force the MANET node to 
> issue a RREQ
>       to proactively discover a foreign agent.  A far more 
> generic approach would
>       be to use RFC-1256 directly.  That way all MANET 
> protocols could use the
>       same method (not just AODV).   The MANET nodes can 
> proxy response
>       Router/Agent solicitations over ICMP.
> 
> 8).  The case where the MANET protocol does not support 
> mulit-cast must be
>       addressed in more detail.
> 
> 9).  NETWORK_DIAMETER is not a stable number (I don't believe you can
>        just set this to 10 and be happy).  In some cases this 
> could completely swamp
>        the ad hoc network.  An expanded ring search COULD 
> work, but I like ICMP
>        proxy responders much better (explained below).  
> 
> My proposal is to stick to RFC-1256.  Each MANET node (not 
> just an AODV) node
> will relay ICMP broadcasts and decrement the TTL field.  This 
> provides the flood
> limiting.  Furthermore, MANET nodes that have discovered a 
> land line router OR a
> mobility agent can proxy response for ICMP Router 
> Solicitations.  This has the 
> very same affect as does the RREQ (AODV specific) proposal.
>    
> BTW, the title of this draft is a bit presumptuous being 
> called "manet-globalv4" since
> it really advocates an AODV specific solution.  I think the 
> technique can be more
> generic if only ICMP messages are used.  Th
> 
> Best regards,
> 
> Phil
> 
> ----- Original Message ----- 
> From: "Charlie Perkins" <[email-masked]>
> To: "Phil Neumiller" <[email-masked]>
> Cc: "Mobile Ad Hoc IETF working group" <[email-masked]>
> Sent: Thursday, July 25, 2002 5:01 PM
> Subject: Re: OSPF to AODV bridging was Re: [manet] RE: 
> Gateway Advertisements
> 
> 
> > Hello Phil,
> > 
> > Phil Neumiller wrote:
> > 
> > > Hi,
> > >
> > >
> > > The AODV draft 11 does not specifically say what a mobile 
> router is to do with
> > > ICMP Router Discovery messages.  Specifically, it does 
> not address the ICMP
> > > Router Advertisements or Router Solicitation messages 
> that will be multicast
> > > ICMP broadcasts as used by OSPF, BGP, etc.  Right?
> > 
> > Is a mobile router the thing that is under consideration 
> within [nemo]?
> > 
> > > I propose that as an ad hoc network node detects that its 
> current default fixed
> > > network routing connection is failing (a matter of debate 
> in PILC, mobileip,
> > > seamoby, etc), that it mcast a ICMP Router Solicatation.
> > 
> > What do you think about the proposal in Ryuji Wakikawa's draft?
> > It is specified how to find a default router.  Your 
> suggestion is, indeed,
> > used within that draft.
> > 
> > Regards,
> > Charlie P.
> > 
> 
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Fri, 26 Jul 2002 14:43:58 -0400

Bert