Subject: [manet] Re: Gateway Advertisements

From: Ryuji Wakikawa<[email-masked]>
Date: Thu, 11 Jul 2002 10:11:20 +0900

Hello again Fredrik and Thanks Anders.

At Tue, 9 Jul 2002 13:08:24 +0200 ,
Fredrik Alriksson (EAB) wrote:
> 
> For the solution described in the draft, unsolicited gateway
> advertisements are not neccessary for the correct operation of the
> protocol.
> 
> [Fredrik Alriksson] I never questioned that. You state that "Sending
> them (advertisements) periodically would generate unnecessary
> packets in the Manet", but as I've said in previous emails _not_
> sending them periodically may generate _more_ traffic in the Manet.

Can you elaborate what is the most reason for generating more traffic
when GW does not flood advertisements.

> I see your point and I think that it is question of whether a reactive or a more proactive approach
> should be used. 
> 
> [Fredrik Alriksson] Perhaps a combination is preferable?

Does it depend on network topology? (a number of manet nodes, a number
of GWs, size of manet) 

> 
> One of the reasons for not recomending gateway advertisement
> flooding is when you consider the scenario where some nodes might
> need internet access, and some might not.
> 
> [Fredrik Alriksson] Well, the nodes which do not need internet
> access may still benefit from the periodic floodings, since they
> probably are involved in the communication between the gateways and
> the manet nodes what do need internet access. Decreasing the total
> number of packet transmissions does not only benefit the nodes that
> need internet access!

We assume that base manet protocol supports next hop forwarding like
AODV.  And if some base manet protocols do not support it (like DSR),
we recommend to the use of routing header.

When a node sends packets to the Internet, a node put a GW address
into a routing header.  During packet routing inside manet, the
destination is the GW addressed in the routing header, therefore
intermediate nodes routes packets to GW according to base manet
operation.  The route is maintained by base manet protocol because GW
can be seen as a normal manet node from the nodes which do not need
Internet access. The route towards the GW is basically constructed
when the node requests advertisements.

What I want to say here is that intermediate nodes just forward/route
packets to the GW and this is the operations of general manet
protocol. Intermediate nodes may create routes while some node set up
global connectivity, but they are basically nothing to do with the
operation of internet connectivity.

> When flooding of advertisements is being used, packets are being
> flooded periodicly over all nodes in the ad hoc network, regardsless
> of their need for internet connectivity. This is where hop_limit
> (TTL) considerations becomes important since every advertisement is
> rebroadcasted as long as allowed by the hop_limit. So, what value
> for this hop_limit should be used? If we choose a too small value we
> might not reach all nodes, and choosing a high value will introduce
> lots of traffic.
> 
> [Fredrik Alriksson] Can't a node that does not get the periodic
> advertisments send solicitations?
> 
> 
> Nodes that have no need for internet connectivity will also receive and process this traffic, uneccessary.
> 
> [Fredrik Alriksson] Even though the advertisements are not
> _necessary_ for the non-internet connected nodes, they may still
> benefit from the periodic advertisments indirectly, since the total
> number of packets that they have to forward (including both the
> advertisements _and_ the user data) may decrease!

Sorry, I can not see your point in last sentence. 
Why may the total number of packets decrease?

> In the draft we instead propose that the node itself should initiate
> this process, the gateway discovery process. In the case where there
> are multiple gateways, the node should upon receiving these
> advertisements choose the closest gateway.
> 
> [Fredrik Alriksson] Aren't we talking about _mobile_ ad hoc
> networks? For how long will the chosen gateway remain the closest
> gateway?

Yes, talking about manet  :-)

Best Regards,
ryuji

> regards,
> 
> Anders
> 
> 
> [Fredrik Alriksson] BR, Fredrik
> 
>  
> 
> Fredrik Alriksson (EAB) wrote:
> 
> Hi Ryuji,
> 
> In what sense are the gateway advertisements unnecessary?
> 
> In case there are multiple gateways, the flooding of gateway advertisements may actually _decrease_ the total number of packet transmissions (control and user data transmissions) in the MANET! 
> 
> Flooding gateway advertisements can enable manet nodes which already have a global address to select a _closer_ gateway. This means that the average distance between gateway and manet node can be decreased. This in turn decreases the number of packet transmissions required to deliver user data between the gateways and the manet nodes. Depending on the user activity, this reduction can be larger than the increase in control packet transmissions. 
> 
> Other benefits are that the average user data delay decreases, and that the manet nodes loose contact with their gateway less frequently.
> 
> Regarding TTL, I don't see the problem, unless advertisements were forwarded on non-manet 
> interfaces. Can you please elaborate a bit?
> 
> BR,
> Fredrik
> 
> 
> 
> -----Original Message-----
> From: Ryuji Wakikawa [ mailto:[email-masked] <mailto:[email-masked]> ]
> Sent: den 8 juli 2002 18:40
> To:  [email-masked] <mailto:[email-masked]> 
> Cc:  [email-masked] <mailto:[email-masked]> ;  [email-masked] <mailto:[email-masked]> ;
> [email-masked] <mailto:[email-masked]> ;  [email-masked] <mailto:[email-masked]> ;  [email-masked] <mailto:[email-masked]> ;
> [email-masked] <mailto:[email-masked]> 
> Subject: Re: Gateway Advertisements
> 
> 
> 
> Hello Fred
> rik.
> 
> In the draft, unnecessary packets basically indicates un-necessary
> gateway advertisements. For example, if a gateway generates a route
> advertisement every 1 sec, most of router advertisements are redundant
> for manet nodes which have already had a global address. They may
> update lifetime of their global address, but the interval(1sec) is
> still too short for this operations.
> 
> Since flooding packets is easy to cause performance damage in manet,
> our approach tries to reduce a number of packets which are 
> flooded over
> manet. I think manet nodes should not wait flooded advertisements from
> gateway, instead manet node should discover gateways on their
> initiative.
> 
> It is also difficult for gateways to decide TTL for flooded
> advertisements. Expanding ring search technique can not be applied to
> this situation, because advertisements should reach at the edge of
> manet. It can imagine that unnecessary network-wide dissemination of
> advertisements will occur when a gateway sets larger TTL than manet
> scale.
> 
> regards,
> ryuji
> 
> 
> At Mon, 8 Jul 2002 17:27:19 +0200 ,
> Fredrik Alriksson (EAB) wrote:
> 
> 
> Hi All,
> 
> In draft-wakikawa-manet-globalv6-00.txt you claim that 
> 
> sending gateway advertisements peridically would generate 
> unnecessary packets in the Manet. Can you please explain how 
> you came to that conclusion? Our simulation study on MIPMANET 
> from '99 ( http://www.e.kth.se/~e94_fal/mipmanet.pdf <http://www.e.kth.se/~e94_fal/mipmanet.pdf> ) 
> indicates that it actually can decrease the number of packet 
> transmissions in the MANET.
> 
> BR,
> Fredrik
> 
> ---
> Fredrik Alriksson, Ericsson Research
> Email:  [email-masked] <mailto:[email-masked]> 
> 
> 
> 
> 
> 
> 
>  
> 
> [2  <text/html; iso-8859-1 (7bit)>]
> 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Ryuji Wakikawa<[email-masked]>
Date: Thu, 11 Jul 2002 10:11:20 +0900

Best Regards,
ryuji