Subject: RE: [manet] RE: Gateway Advertisements

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Mon, 22 Jul 2002 13:35:34 +0200

Hi Guillaume,

> I think discovering and selecting Gateway Nodes has something 
> to do with the 
> routing protocol used in the MANet. All the problems we have 
> to deal with look
> similar to the ones we have in routing: discovering the 
> gateway (proactive or
> reactive approach), construction of the route to the gateway 
> (proactive or
> rreq/rrep scheme), handling of mobility (reconstruction of 
> route or selection of
> a new gateway). This is something all routing protocols can 
> already easily deal
> with (or with minor modifications). It can be done by the 
> addition of a
> "Gateway" bit in C messages of OLSR TC packets, by the 
> definition of an "All
> Gateways" address to use with rreq in DSR or AODV... It is 
> often a work that has
> already be done.

Sure, it _can_ be done that way.

> Moreover, the question whether Gateways should advertise 
> themselves or only
> respond to requests is similar to the question whether 
> routing protocols must be
> reactive or procactive. Arguments are also similar: if the 
> network is stable,
> Gateway advertisments induce unnecessary load; if it is 
> unstable, gateway
> advertisments are interesting... 

The question is similar, but the nature of the communication between mobile and GW is quite different than that of communication between two mobile nodes, so conclusions drawn from mobile-to-mobile scenarios are not automatically valid for mobile-GW scenarios.

> It seems to me everybody has 
> accepted that, in
> some cases, proactive schemes are sometimes better than 
> reactive ones, and in
> other cases, the opposite is true. 

Well, draft-wakikawa-manet-globalv6-00.txt says that a proactive scheme SHOULD NOT be used, and I haven't seen any comments about that previously, so my impression was that everybody had "accepted" that a reactive approach is better in _most_ cases.
 
> My opinion is that we should not split the gateway 
> advertisement mechanism from
> the routing protocol. It is the protocol responsability to 
> propose a mechanism
> which allows a node to discover gateways and to manage routes 
> between nodes to
> gateways.

So, you don't see any need for e.g. draft-wakikawa-manet-globalv6-00.txt?

BR,
Fredrik

> Regards, 
> Guillaume Chelius.
> 
> -----------------
> Guillaume Chelius
> PhD student
> Ares Team, Inria, Citi Insa-Lyon
> Tel: (+33) 472 436 421
> Email: [email-masked]
> 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Guillaume Chelius <[email-masked]>
Date: Mon, 22 Jul 2002 14:41:08 +0200 (CEST)

Hello Fredrik, 

> The question is similar, but the nature of the communication between
> mobile and GW is quite different than that of communication between two
> mobile nodes, so conclusions drawn from mobile-to-mobile scenarios are
> not automatically valid for mobile-GW scenarios.

They are not so different to me.
 
> Well, draft-wakikawa-manet-globalv6-00.txt says that a proactive scheme
> SHOULD NOT be used, and I haven't seen any comments about that
> previously, so my impression was that everybody had "accepted" that a
> reactive approach is better in _most_ cases.

I don't think everybody has accepted it, at least you and I haven't. Many other
schemes have to be studied. Hybrid protocols for example. GW may flood
advertisements with a low TTL and support a solicitation/advertisment protocol
as well. Nodes receiving unsolicited advertisements will be able to select the
closest GW and nodes not receiving any unsolicited advertisement will request
for a GW. After mobility, nodes starting to receive new unsolicited
advertisments will be able to reselect a closer GW. This is an example. 
  
> draft-wakikawa-manet-globalv6-00.txt?

The fact is that routing protocols integrate or may easily integrate a GW
discovery protocol. This integration is often more efficient than defining a
separate protocol. It is not worth defining and flooding a new packet in a MANet
with OLSR, when the use of one bit in TC messages leads to the same result. For
a basic GW discovery protocol, I think draft-wakikawa-manet-globalv6-00.txt is
useless. Not tobe misunderstood, I precise that its content is not useless. But
I think this problem should not be addressed in a specific draft.

I see one reason that could make this draft interesting: 

- The definition of a generic service discovery protocol.
draft-wakikawa-manet-globalv6-00.txt addresses the problem of discovering and
using Internet GWs. As I already said, I think it can be better done by routing
protocols. However, it could/should address a more general problem which is
service location. Instead of simply answering to "I'm looking for an Internet
GW" it should provide the way to answer more complex questions like "I'm looking
for a Web/FTP Proxy with high bandwidth"...  

Regards, 
Guillaume.
-----------------
Guillaume Chelius
PhD student

---

From: Guillaume Chelius <[email-masked]>
Date: Mon, 22 Jul 2002 14:41:08 +0200 (CEST)

Hello Fredrik, 

 

Regards, 
Guillaume.
-----------------
Guillaume Chelius
PhD student