Subject: Re: Re: [manet] how does ad hoc network do something?

From: "naveen_bits" <[email-masked]>
Date: Thu, 25 Jul 2002 12:23:54 +0530

Hi Bin,

Please correct me , If I am wrong , but this is what I think about the concerned problem described below.

Let there be some nodes A &amp; B , such that A is the node that requires services of B

Logically speaking there can be following ways to depict the information:-

First, If A knows the services it wants to use it may ask the node B that "is this service is provided by you"? If yes then B can act as a serverand provide these services. B Acknowledges yes or no by 

acknowledgement or A waits some randomn amount of time &amp; inquires other nodes in the vicinity.In extention to this B can also ask the node in the vicinity if they can provide with the service that A wants 

Definately security has to be kept in mind before going for this kind of protocol.
 
Second, For performance reasons A can broadcast and ask "Is there any node that provides this services"?. Then the node providing the services that A requires is send as an acknowledgement containing the 

IP address. If multiple nodes provides the same then the best path can be choosen. This is kind of flooding. This can be done in some controlled manner.

Third if A doesnot know the services and want to use the services than the nodes in the vicinity can broadcast "Do you want this service"? If yes then it can use the service if wants to...

Actually, as far as I think in normal scinarios the combination of second &amp; third scheme is used? It broadcast for some periof´ds with certain no retries(may be configurable). If fails then then there is no option 

but to use third option......

 

Regards
Naveen Kumar Lall 

"zb" wrote:

Hi, Frank,

Thanks your reply.

I think, to make an ad hoc network to do something, two thing must be
done:
1) to get an IP address of itself
2) to find the node which can provide the required service and get its IP
address
Then, the data can be exchanged between the two nodes. In MANET, there are
drafts on routing and IP address autoconfiguration. But, how to do service
discovery in ad hoc network? It seems there is no working group on service
discovery. Does it belong to upper layer which is out of IETF? Besides, how
does the service discovery collaborate with the routing in ad hoc network?

regard,

bin
----- Original Message -----
From: "Frank Dinies" 
To: "zb" 
Cc: 
Sent: Wednesday, July 24, 2002 7:01 PM
Subject: Re: [manet] how does ad hoc network do something?

Hi Zhen,

for proactive algorithmens like ADV or FSR there is no problem. Mainly
because
this algorithmens rely on periodically sent advertisments. So after a short
boot-up-time, when a new device wants to participate, it knows about his
enviroment and vice versa. But this is only true for proactive algorithmens.

For reactive algorithmens or on-demand-algorithmens this is not true. This
algorithmens rely on special information or mechanismens for the boot-uptime
to scan their enviroment.

But keep in mind. Proactive algorithmens are best in enviroments with rapid
change and much participants. On-demand-ones roughly for the contrary. For
sensors that transmit from time to time small amounts of data for example is
an on-demand-one perfect.

hope this helps

frank

looking in the RFCs or drafts could give you an idea. the bootup problem
mostly is not trivial !

Am Mittwoch, 24. Juli 2002 07:22 schrieb zb:
&gt; Hi,
&gt;
&gt; I have a question on how does the ad hoc network begin to work? When
device
&gt; A and device B are in a MANET, they do not know IP address and service
&gt; ability of each other. There can be multihop between device A and device
B.
&gt; How does the device A know it can get required service from device B and
&gt; communicate with device B?
&gt;
&gt; Thanx.
&gt;
&gt; bin
&gt; *************************************
&gt; Zhen Bin
&gt;
&gt; i-Networking lab,
&gt; Samsung Advanced Institute of Technology,
&gt; San14-1, NongSeo-ri, Kiheung-Eup,
&gt; Yongin, Kyungki-do, 440600, Korea
&gt;
&gt; 82-31-2809569 (fax)
&gt; 82-31-2809534 (o)
&gt; 82-31-2122268 (h)
&gt; *************************************
&gt;
&gt;
&gt;
&gt; _______________________________________________
&gt; manet mailing list
&gt; [email-masked]
&gt; https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

Get Your Private, Free E-mail from Indiatimes at  http://email.indiatimes.com
Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from http://www.planetm.co.in

---

From: "naveen_bits" <[email-masked]>
Date: Thu, 25 Jul 2002 12:23:54 +0530

Hi Bin,

 

 

Regards
Naveen Kumar Lall 

"zb" wrote:

Hi, Frank,

Thanks your reply.

regard,

bin
----- Original Message -----
From: "Frank Dinies" 
To: "zb" 
Cc: 
Sent: Wednesday, July 24, 2002 7:01 PM
Subject: Re: [manet] how does ad hoc network do something?

Hi Zhen,

hope this helps

frank

---

From: "MEDDOUR Djamal Eddine thesard FTRD/DAC/LAN" <[email-masked]>
Date: Thu, 25 Jul 2002 09:52:15 +0200

Hi all

I have two questions about this subject:

Which type of services we need (or car provided) at MANET? 

Which node will act as service provider?

regards

-----Message d'origine-----
De : naveen_bits [mailto:[email-masked]] 
Envoyé : jeudi 25 juillet 2002 08:54
À : zb; Frank Dinies
Cc : [email-masked]
Objet : Re: Re: [manet] how does ad hoc network do something?

Hi Bin,

Let there be some nodes A & B , such that A is the node that requires services of B

acknowledgement or A waits some randomn amount of time & inquires other nodes in the vicinity.In extention to this B can also ask the node in the vicinity if they can provide with the service that A wants 

Actually, as far as I think in normal scinarios the combination of second & third scheme is used? It broadcast for some periof4ds with certain no retries(may be configurable). If fails then then there is no option 

 

Regards
Naveen Kumar Lall 

"zb" wrote:

	Hi, Frank,
	
	Thanks your reply.

	regard,
	
	bin
	----- Original Message -----
	From: "Frank Dinies" 
	To: "zb" 
	Cc: 
	Sent: Wednesday, July 24, 2002 7:01 PM
	Subject: Re: [manet] how does ad hoc network do somethi! ng! ?

	Hi Zhen,

	
	
	hope this helps
	
	frank

	Am Mittwoch, 24. Juli 2002 07:22! s! chrieb zb:
	> Hi,
	>
	> I have a question on how does the ad hoc network begin to work? When
	device
	> A and device B are in a MANET, they do not know IP address and service
	> ability of each other. There can be multihop between device A and device
	B.
	> How does the device A know it can get required service from device B and
	> communicate with device B?
	>
	> Thanx.
	>
	> bin
	> *************************************
	> Zhen Bin
	>
	> i-Networking lab,
	> Samsung Advanced Institute of Technology,
	> San14-1, NongSeo-ri, Kiheung-Eup,
	> Yongin, Kyungki-do, 440600, Korea
	>
	> 82-31-2809569 (fax)
	> 82-31-2809534 (o)
	> 82-31-2122268 (h)
	> *************************************
	>
	>
	>
	> https://www1.ietf.org/mailman/listinfo/mane! t

  _____  

Get Your Private, Free E-mail from Indiatimes at http://email.indiatimes.com <http://email.indiatimes.com> 
Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from http://www.planetm.co.in

---

From: "MEDDOUR Djamal Eddine thesard FTRD/DAC/LAN" <[email-masked]>
Date: Thu, 25 Jul 2002 09:52:15 +0200

Hi all

regards

-----Message d'origine-----
De : naveen_bits [mailto:[email-masked]] 
Envoyé : jeudi 25 juillet 2002 08:54
À : zb; Frank Dinies
Cc : [email-masked]
Objet : Re: Re: [manet] how does ad hoc network do something?

Hi Bin,

 

 

Regards
Naveen Kumar Lall 

"zb" wrote:

	Hi, Frank,
	
	Thanks your reply.

	regard,
	
	bin
	----- Original Message -----
	From: "Frank Dinies" 
	To: "zb" 
	Cc: 
	Sent: Wednesday, July 24, 2002 7:01 PM
	Subject: Re: [manet] how does ad hoc network do somethi! ng! ?

	Hi Zhen,

	
	
	hope this helps
	
	frank

	device
	B.

  _____

---

From: "Mullen, John P. (Contractor)" <[email-masked]>
Date: Thu, 25 Jul 2002 07:00:44 -0600

Hi,
 
The answer would depend on the MANET.
 
In the general definition of a MANET, nodes are free to join or leave the
MANET without any central control.  Security may be an issue, but that would
depend on the MANET as well.  The key thing is that at any time, a node may
join the MANET and that the node in question might offer some sort of
service that other nodes do not generally offer or possess.  Examples would
include:

*	A shared printer, say at a conference or hotel,
*	A gateway to the Internet
*	Emergency Medical services
*	Information services, such as a directory or technical database

When such a node enters, existing nodes may not be aware that the services
it offers even exist on the MANET.  In addition, even if a node suspected
that a service existed, it has the problem of finding the IP of a node that
offers such a service.  
 
Bear in mind that in wired nets, the existence and location of such services
is known to the network administrators, who take care of both problems at
initial node setup and propagate changes as they occur.  However, in a
MANET, these things are supposed to happen automatically.
 
John Mullen

-----Original Message-----
From: MEDDOUR Djamal Eddine thesard FTRD/DAC/LAN
[mailto:[email-masked]]
Sent: Thursday, July 25, 2002 1:52 AM
To: naveen_bits; zb; Frank Dinies
Cc: [email-masked]
Subject: RE : Re: [manet] how does ad hoc network do something?

Hi all

regards

-----Message d'origine-----
De : naveen_bits [mailto:[email-masked]] 
Envoyé : jeudi 25 juillet 2002 08:54
À : zb; Frank Dinies
Cc : [email-masked]
Objet : Re: Re: [manet] how does ad hoc network do something?

Hi Bin,

Please correct me , If I am wrong , but this is what I think about the
concerned problem described below.

Let there be some nodes A & B , such that A is the node that requires
services of B

First, If A knows the services it wants to use it may ask the node B that
"is this service is provided by you"? If yes then B can act as a serverand
provide these services. B Acknowledges yes or no by 

acknowledgement or A waits some randomn amount of time & inquires other
nodes in the vicinity.In extention to this B can also ask the node in the
vicinity if they can provide with the service that A wants 

Definately security has to be kept in mind before going for this kind of
protocol.
 
Second, For performance reasons A can broadcast and ask "Is there any node
that provides this services"?. Then the node providing the services that A
requires is send as an acknowledgement containing the 

IP address. If multiple nodes provides the same then the best path can be
choosen. This is kind of flooding. This can be done in some controlled
manner.

Third if A doesnot know the services and want to use the services than the
nodes in the vicinity can broadcast "Do you want this service"? If yes then
it can use the service if wants to...

Actually, as far as I think in normal scinarios the combination of second &
third scheme is used? It broadcast for some periof4ds with certain no
retries(may be configurable). If fails then then there is no option 

 

Regards
Naveen Kumar Lall 

"zb" wrote:

Hi, Frank,

Thanks your reply.

regard,

bin
----- Original Message -----
From: "Frank Dinies" 
To: "zb" 
Cc: 
Sent: Wednesday, July 24, 2002 7:01 PM
Subject: Re: [manet] how does ad hoc network do somethi! ng! ?

Hi Zhen,

hope this helps

frank

device
B.

  _____  

Get Your Private, Free E-mail from Indiatimes at
<http://email.indiatimes.com> http://email.indiatimes.com
Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from
http://www.planetm.co.in <http://www.planetm.co.in>

---

From: "Mullen, John P. (Contractor)" <[email-masked]>
Date: Thu, 25 Jul 2002 07:00:44 -0600

Hi,

 
 
John Mullen

-----Original Message-----

Hi all

regards

-----Message d'origine-----
De : naveen_bits [mailto:[email-masked]] 
Envoyé : jeudi 25 juillet 2002 08:54
À : zb; Frank Dinies
Cc : [email-masked]
Objet : Re: Re: [manet] how does ad hoc network do something?

Hi Bin,

 

 

Regards
Naveen Kumar Lall 

"zb" wrote:

Hi, Frank,

Thanks your reply.

regard,

bin
----- Original Message -----
From: "Frank Dinies" 
To: "zb" 
Cc: 
Sent: Wednesday, July 24, 2002 7:01 PM
Subject: Re: [manet] how does ad hoc network do somethi! ng! ?

Hi Zhen,

hope this helps

frank

device
B.

  _____

---

From: Einar Vollset <[email-masked]>
Date: Thu, 25 Jul 2002 10:47:00 +0100

Hi Frank,

>have you seen the approach from Fisheye-State-Routing ? It is a proactive
>algorithmen with maintains a global routing table. But it maintains the
>information in respect to the distance. To do this it sends periodically
>beacons to its neighbours only. Every neighbour accumulates this information
>and send the information in different update times. Information about nearer
>nodes much more often than information about nodes farer away.

Yes I have. I believe FSR is also used as part of LANMAR.

>In this way
>this algorithmen scales pretty well with large networks and positionchanges
>not nescessarily triggers update information.

I agree that only keeping a distance based routing table will reduce the
overhead of maintaining routing information in FSR. And there are other
proactive protocols that have mechanisms to reduce the number of nodes
it needs to maintain routing information to as well(LANMAR that I
metioned uses group mobility). 
However, I think that proactive protocols in the general case will perform
worse than on-demand protocols in a high mobility scenario simply because
the overhead of updating routes to all (or a selected subset) of the nodes
in the network will congest the network sufficently to render it useless
(at least at the high mobility scenarios you suggest, and if we assume that
bandwidth isn't abundant).

>
>On-demand protocols have the problem the route-prechaching is unsufficient 
for
>high mobility.

That's true, and if the overhead of maintaining routes to all nodes can be
kept at an acceptable level, then pro-active protocols have an edge on 
on-demand ones.
However, in the case where mobility is high, this is hard to achieve.

>Another point is that a route could even be absolute before a
>sender gets the route-information back.

I agree, but the same thing can be said for proactive protocols if
the mobility is sufficiently high. One way of alleviating this would
be for the protocol to find multiple routes, and hope that not all
these become obsolete. This of course adds to the processing and
communication overhead of the manet.. :-(

>unfortunalety there is no silver bullet for all kind of situations ;)

Not yet :-)

Cheers,

Einar

>
>> Hi Frank,
>>
>> >But keep in mind. Proactive algorithmens are best in enviroments with
>> > rapid change and much participants. On-demand-ones roughly for the
>> > contrary. For sensors that transmit from time to time small amounts of
>> > data for example is an on-demand-one perfect.
>>
>> I was under the impression that it was the other way around, with proactive
>> protocols performing worse in environments with rapid change, as the
>> overhead with maintaining the (global) routing information would be
>> prohibitive. Where as an on-demand protocol would perform better in this
>> scenario?
>>
>> Or am I confused? :-)
>>
>> Cheers,
>>
>> Einar
>
>

---

From: Einar Vollset <[email-masked]>
Date: Thu, 25 Jul 2002 10:47:00 +0100

Hi Frank,

for

Not yet :-)

Cheers,

Einar