Subject: RE: [manet] Gateway address resolution

From: "Manfredi, Albert E" <[email-masked]>
Date: Mon, 1 Jul 2002 10:06:47 -0400

Mullen, John P. wrote:

> Hi,
> 
> I know I'm missing something here.
> 
> Why can't the MANET be treated as a local intranet with each 
> of its nodes
> having a common Internet subnet mask (augmented by whatever 
> is needed to
> affect routing within the MANET, of course.)  When a gateway 
> sees a packet
> bearing an IP with the MANET subnet mask, it knows it is 
> intended for a node
> within the MANET, while one with a different pattern would be clearly
> intended for the Internet.

Because that wouldn't be the general solution. Seems that many want to be able to turn on their MANET host anywhere and have it join the MANET, without needing DHCP or other server, and without having to enter a MANET-specific IP address and mask manually. And the host must be capable of roaming freely.

If you expect the MANET hosts to belong to a particular IP subnet, that mandates some sort of manual or automatic IP address/mask configuration, with the requisite changes as the host roams.

Bert

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 01 Jul 2002 10:14:46 -0700

Hello Bert,

> If you expect the MANET hosts to belong to a particular IP subnet, that mandates some sort of manual or automatic IP address/mask configuration, with the requisite changes as the host roams.

We have a draft:
    draft-wakikawa-manet-globalv6-01.txt
also available at:
    http://people.nokia.net/charliep/txt/aodvid/globalv6.txt
        (but the formatting isn't perfect).
that offers a solution for enabling Internet connectivity for
manet nodes.  In our solution, a node can keep its old address
and work fine in the ad hoc network.  However, if it wants
Internet connectivity, then it has to configure an address
that is topologically correct for the point of attachment of
the MANET to the Internet.

If the node has no address, it can stateless autoconfigure
one for the manet, using a predefined site-local prefix.
It can also stateless autoconfigue a topologically correct
address if it gets information from the gateway.  Finally,
the node can use its pre-existing IP address (not topologically
correct) for bidirectional Internet communications, but in
that case it has to use Mobile IP.

Regards,
Charlie P.

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 01 Jul 2002 10:14:46 -0700

Hello Bert,

We have a draft:

Regards,
Charlie P.