Subject: RE: [manet] Gateway address resolution

From: "Yasser A. Lotfy" <[email-masked]>
Date: Mon, 01 Jul 2002 13:33:44 -0400

Hi,

Your e-mail holds many interesting ideas. It clearly raises the need to understand why MANET should not rely on a pool of contiguous IP addresses.

1) Nodes should be able to roam freely in the network. If a cellular node connected to the cellular network via address xxxx came into accessable range of a bluetooth MANET based network, it might decide to join. Obviously, the node prefer to keep its xxxx address.

2) Imagine the situation when you have many MANET networks scaterd in somewhat geographically limited area. Every network will be able to adminstrate itself (ie assign contiguous IP addresses, and subnet mask). Those MANET networks will have occasional interference in shared areas (areas that may belong to more than one MANET). Shared areas obviously have dynamic nature. Nodes roaming from one MANET network to the next should be able to do so without giving up it's IP address.

3) The use of anytype of DHCP requires adminstration both at the node level, and centralized level. In addition, centralized management of MANET contradicts it's charter.

4) Users are entitled to have thier own IP addresses. Assume my PDA address is yyyy, and it is a static IP that is recognizable throughout the internet. Part of the IPv6 effort is to allow personal IP addresses. Overiding this address contradicts with IPv6 directions.

However, I understand that having a pool of contiguous addresses may be the common case. Yet, building the network should be based on the more general case.

Comments?

Yasser

____________________________________________________________
Win a first-class trip to New Orleans and vacation Elvis Style!.
Enter NOW!
http://r.lycos.com/r/sagel_mail/http://www.elvis.lycos.com/sweepstakes/

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Phil Neumiller" <[email-masked]>
Date: Wed, 10 Jul 2002 10:08:28 -0400

>
> 1) Nodes should be able to roam freely in the network. If a cellular node connected to the cellular network via address xxxx came
into accessable range of a bluetooth MANET based network, it might decide to join. Obviously, the node prefer to keep its xxxx
address.

NOTE:  IP addresses are assigned to interfaces not hosts.  In the Bluetooth scenario you mention, you would
need to have a seperate Care-of-address on the cell phone network and the Bluetooth network.  You could
of course maintain your home address at all times.  The host has to either be multi-homed (in which case it
can route over both interfaces) or it must support MIP with either co-located care-of addresses in IPv6 or
a FA in IPv4.

>
> 2) Imagine the situation when you have many MANET networks scaterd in somewhat geographically limited area. Every network will be
able to adminstrate itself (ie assign contiguous IP addresses, and subnet mask).

NOTE:  I know of no MANET algorithm that can "assign" a subnet mask in the true sense.  ZRP has zones.
CGSR and CBRP have clusters.

<Those MANET networks will have occasional interference in shared areas (areas that may belong to more than one MANET). Shared areas
obviously have dynamic nature. Nodes roaming from one MANET network to the next should be able to do so without giving up it's IP
address.
>
> 3) The use of anytype of DHCP requires adminstration both at the node level, and centralized level. In addition, centralized
management of MANET contradicts it's charter.

No, I don't believe it does.  The use of infrastructure is really going to be required by practical MANET implementaitons
of any scale.  People in general will need to get on the global Internet FROM their MANETs.  They will also want to be
reachable.
>
> 4) Users are entitled to have thier own IP addresses. Assume my PDA address is yyyy, and it is a static IP that is recognizable
throughout the internet. Part of the IPv6 effort is to allow personal IP addresses. Overiding this address contradicts with IPv6
directions.

The only feasible static address here is a mobile IP home address.

> However, I understand that having a pool of contiguous addresses may be the common case. Yet, building the network should be based
on the more general case.

Having a pool of contiguous addresses is no longer common.  CIDR and OSPF/BGP allow many tiny little non-contiguous
subnets to be in any ISPs pool of allocatable addresses.

---

From: "Phil Neumiller" <[email-masked]>
Date: Wed, 10 Jul 2002 10:08:28 -0400