Subject: RE: [manet] promiscuous mode

From: "Mullen, John P. (Contractor)" <[email-masked]>
Date: Wed, 17 Jul 2002 08:33:34 -0600

Hi Zygmunt,

Thanks.  

I think of promiscuous mode as an example of capitalizing on what would
otherwise would be a disadvantage.  I don't know who was the first bright
guy to figure out that eavesdropping could turn the wait for an open channel
into useful information gathering, but he or she had one heck of an idea!

:-)

Which leads me to ask:

Eavesdropping is an effective MANET strategy that could be used in a number
of protocols.  Another related strategy is the implicit ACK.  There are a
number of additional fundamental strategies.  Has anyone ever sat down and
described these basic MANET tools, independent of a specific protocol?

Wondering,

John Mullen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, July 17, 2002 8:04 AM
To: Mullen, John P. (Contractor)
Cc: [email-masked]; [email-masked]
Subject: RE: [manet] promiscuous mode

Hi John,

In general, use of promiscuous mode can lead to substantial saving in
control traffic in most of the reactive protocols, for example by
eavesdropping on the route replies and storing this information to reply
to future route requests.

Just as another point of reference, ZRP also uses promiscuous mode to
eavesdrop on the propagation of the route request queries, thus reducing
the unnecessary control traffic load. (This is one of the elements of 
the Query Control scheme in IERP).

Zygmunt.
===--====
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-
Prof. Zygmunt J. Haas                    http://people.ece.cornell.edu/haas 
Wireless Networks Laboratory		 http://wnl.ece.cornell.edu
School of Electrical Engineering         
Cornell University			 tel: +1-607-255-3454
323 Frank Rhodes Hall			 fax: +1-607-255-9072
Ithaca, NY 14853			 e-mail: [email-masked]
U.S.A                             
	WNL web page: http://wnl.ece.cornell.edu
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-

On Wed, 17 Jul 2002, Mullen, John P. (Contractor) wrote:

> Hi Jack,
> 
> The two ad hoc protocols I am aware of that employ promiscuous mode are
> Dynamic Source Routing (DSR), and Source Tree Adaptive Routing (STAR).
> 
> John Mullen
> 
> 
> -----Original Message-----
> From: Jack Wang [mailto:[email-masked]]
> Sent: Tuesday, July 16, 2002 11:46 AM
> To: [email-masked]
> Subject: [manet] promiscuous mode
> 
> 
> 
> 
> 
> --EXCITEBOUNDARY_000__7705a3bdad555dd407e51a76672516d1
> Content-Type: text/plain; charset="us-ascii"
> Content-Transfer-Encoding: 7bit
> 
>  Hi All: We know "promiscuous mode" can be used to monitor data traffic in
a
> network. How about its application in ad hoc networks?Is there any
published
> materials that I can refer to? Thanks. Jack 
> 
> ------------------------------------------------
> Join Excite! - http://www.excite.com
> The most personalized portal on the Web!
> 
> --EXCITEBOUNDARY_000__7705a3bdad555dd407e51a76672516d1
> Content-Type: text/html; charset="us-ascii"
> Content-Transfer-Encoding: 7bit
> 
>  <table cellpadding=10 cellspacing=0 border=0 width=100% bgcolor=white><tr
> height=200><td width=100%><font size=2 color=black><DIV>Hi All:</DIV><DIV>
> </DIV><DIV>We know "promiscuous mode" can be used to monitor data traffic
in
> a network. How about its application in ad hoc networks?</DIV><DIV>Is
there
> any published materials that I can refer to?</DIV><DIV>
> </DIV><DIV>Thanks.</DIV><DIV> </DIV><DIV>Jack
> <BR><BR><BR><BR></DIV></font></td></tr></table><p><hr><b>Join Excite! - <a
> href="http://www.excite.com/?PG=Email&SEC=Signature"
> target=_top>http://www.excite.com</a></b><br>The most personalized portal
on
> the Web!
> 
> --EXCITEBOUNDARY_000__7705a3bdad555dd407e51a76672516d1--
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Jürgen Nagler <[email-masked]>
Date: Wed, 17 Jul 2002 19:05:52 +0200

Hi,
 
> described these basic MANET tools, independent of a specific protocol?

yes, but only in German. I described in my diploma thesis some of the
common concepts used in many MANET protocols. We needed this step for
creating a framework for all protocols. I used two chapters: one
describing criterions of differentiation and one describing basic
modules for all protocols.

Criterions of differentiation covered "time of route discovery
(proactive, reactive)", "algorithms for route discorvery", "structuring
mechanisms", "supported address types", "more influences (energy,
location-aware)", "transport of data". But many protocolls used at least
one solution in each section.

Basic modules covered "broadcast and flooding", "sequence numbers",
"link control (which covered promiscuous mode)", "topology dump" and
"tabelles".

I think it's sure not complete but it's a begin.

We also have a section "common functions" in our (sorry) German paper "A
framework for MANET routing protocols"
http://medien.informatik.uni-ulm.de/forschung/publikationen/wman02.pdf

Regards,
Jürgen Nagler

PS: Sorry for my poor English.

---

From: Jürgen Nagler <[email-masked]>
Date: Wed, 17 Jul 2002 19:05:52 +0200

Hi,

Regards,
Jürgen Nagler