Subject: Re: [manet] Re: Gateway Advertisements

From: Anders Nilsson <[email-masked]>
Date: Thu, 11 Jul 2002 16:29:59 +0200

Hello Fredrik!

>
>But you can't know which of the advertisements that are "unnecessary" beforehand. I would say that sending the periodic advertisements too frequently creates unnecessary overhead, and that the problem is to define an "optimal" period. This is not at all the same as to say that periodic advertisements SHOULD NOT be used at all!
>
You are absolutely right. This is always what you should try to optimize 
when you have an proactive approach , like yours. Our approach is more 
reactive. So for the real question; is a proactive, a reactive or a hybrid
solution the best one? I think the answer depends on several factors, 
such as network size, mobility
rate, traffic load, but also on battery life, routing protocol, security 
etc. I think I can agree on that your proposal is better in some 
situations and scenarios, but that our solution is better in some. I 
think that these are questions that needs to be more thoroughly simulated.

>
>For how long is the metrics about the GWs in the GW list valid (e.g. hop count)? 
>How does the Manet node know when to re-flood the request?
>How large fraction of all relevant topology changes will the Manet node detect?
>
>My conclusion is still: it is better to let the GW flood periodically.
>
Are you absolutely sure that this will be the optimal solution in all 
situations?

>
>
>>In appendix A, we explain how to use the most appropriate GW with a
>>routing header. I think the draft can be adapted to your above
>>situation. What do you think?
>>
>>--Snip from the drat
>>   Using a routing header is also preferable if there are 
>>more than two
>>Internet-gateways, because the node then have the ability to decide
>>which Internet-gateway is the best, by distance in hops, or by some
>>other priority.  By assign a priority number for each 
>>Internet-gateway,
>>the route reply message and the Manet Router Advertisement messages
>>could be extended to support a candidate Internet-gateway 
>>option in it.
>>-----
>>
>
>I'm sorry, I don't really follow you here. In what sense is the text you refer to about sending advertisements periodically or not?
>
He describes how the gateway selection process can be implemented.

>
>Well, it does if the Manet node unicasts the solicitation, which use list as one alternative if I understand the draft correct.
>
>Furthermore, if using flooding, how often should Manet nodes flood the solicitations?
>
... needs more testing...

>>>Regarding TTL, I don't see the problem, unless advertisements were
>>>forwarded on non-manet interfaces. Can you please elaborate a bit?
>>>
>>In your thesis, you mentioned "Limited TTL". This is almost what I
>>want to explain here. If there is a single GW in manet, RA should be
>>flooded over whole manet. You can not use optimization like expanding
>>ring search for flooding. If Manet nodes can not get RAs sent with
>>limited TTL by GW, it has to discover GW by solicited requests.
>>
>
>Sure, but is that really a problem?
>
No, and I think that it could be a good hybrid solution.

[and in your previous mail:] Can you elaborate what is the most reason for generating more traffic
> when GW does not flood advertisements.

>The average hop count between the GW and the Manet node increases, 
>since the probability that a Manet node will use a sub-optimal 
> GW increases.

>Then I think I didn't express myself clearly enough. My point is 
>that using a 4-hop route between Manet node and GW1 consumes more 
>resources in the Manet as a whole than using a 2-hop route between the 
>same Manet node and GW2. Thus being able to select the closest gateway 
>is a concern for all nodes in the Manet, including those that do not 
>use internet connectivity.

But minimizing the hop count is, of course, also the purpose of our 
solution. The question is whether it really
does differ in average hop, or whether it really is more costful. 
Flooding could be very costful for battery sensitive devices. As for 
choosing the closest gateway, this should always be the ambition. The 
node could either rerequest gateway information, or maybe we could 
piggyback this information somewhere, in case a "handover"is needed.

best regards,

Anders

---

From: Anders Nilsson <[email-masked]>
Date: Thu, 11 Jul 2002 16:29:59 +0200

Hello Fredrik!

best regards,

Anders

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 11 Jul 2002 08:42:53 -0700

Hello Fredrik,

Anders has already replied, but I wanted to make
additional discussion about one part of your exchange...

> For how long is the metrics about the GWs in the GW list valid (e.g. hop count)?

This answer is the same as for the metric field in any other
AODV destination route.  Due to route repairs, the metric
may not represent the actual hop count to a destination,
and yet the destination remains reachable.

> How does the Manet node know when to re-flood the request?

When the manet node needs a route to a node in the Internet,
and it does not have a default route, it will re-flood
the request.  Is this your concern?

> How large fraction of all relevant topology changes will the Manet node detect?

The best case would be for it to detect _none_ of the topology
changes, and yet retain routability to all of its communication
partners.

> My conclusion is still: it is better to let the GW flood periodically.

I think the argument for periodic advertisement is the same
as for any other manet-wide advertisement.  The decision about
whether to go for periodic vs. reactive depends on traffic
patterns in either case.

Regards,
Charlie P.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 11 Jul 2002 08:42:53 -0700

Hello Fredrik,

Regards,
Charlie P.

---

From: Ryuji Wakikawa<[email-masked]>
Date: Fri, 12 Jul 2002 00:56:02 +0900

Hi Fredrik.

Fredrik Alriksson (EAB) wrote:
> 
> But you can't know which of the advertisements that are
> "unnecessary" beforehand. I would say that sending the periodic
> advertisements too frequently creates unnecessary overhead, and that
> the problem is to define an "optimal" period. This is not at all the
> same as to say that periodic advertisements SHOULD NOT be used at
> all!
> 

I need more consideration for this. I will try to leave out the
sentence about "SHOULD NOT" and put more texts about this.
I will ask you comments when I write this.

> For how long is the metrics about the GWs in the GW list valid

Manet node does not keep a hop count which is known by advertisements from GW.
Hop count is alway updated during maintenance of the route path to GW by a manet protocol.
But if the route is expired, manet node have to discover the route again.

> How does the Manet node know when to re-flood the request?  

We haven't specified yet. maybe when hop count change, movements
detection, receiving RERR.

> How large fraction of all relevant topology changes will the Manet node detect?

It depends on a base manet protocol. For example, the manet node may not
know the changes since AODV has local repair functions.

> > I think we should clarify much more about situations when multiple GWs
> > are located.
> > 
> > # Can you explain more about simulated unicast situation.  Can a manet
> >   node receive RA from only associated GW? Didn't you use solicited
> >   request from the manet node? If not, GW will discover the manet node
> >   route, when it sends RA to the node and can not find fresh route for
> >   the node. 
> 
> I think you have a good point here; we did use RA's but perhaps not optimally.
> 
> > This does not happen to our solution.
> 
> Well, it does if the Manet node unicasts the solicitation, which use
> list as one alternative if I understand the draft correct.

You are right.
But this happens once. not periodically. During being using the gateway,
the Manet node can maintain route path by manet protocol.
I think this is not exact same as the problem of proactive, 
although it still depends on many situations.

> Sure, but is that really a problem?

I think Anders replied to this question.

regards,
ryuji

> BR,
> Fredrik
> 
> > best regards,
> > ryuji
> > 
> > > BR,
> > > Fredrik
> > > 
> > > > -----Original Message-----
> > > > From: Ryuji Wakikawa [mailto:[email-masked]]
> > > > Sent: den 8 juli 2002 18:40
> > > > To: [email-masked]
> > > > Cc: [email-masked]; [email-masked];
> > > > [email-masked]; [email-masked]; 
> > [email-masked];
> > > > [email-masked]
> > > > Subject: Re: Gateway Advertisements
> > > > 
> > > > 
> > > > 
> > > > Hello Fredrik.
> > > > 
> > > > In the draft, unnecessary packets basically indicates un-necessary
> > > > gateway advertisements. For example, if a gateway 
> > generates a route
> > > > advertisement every 1 sec, most of router advertisements 
> > are redundant
> > > > for manet nodes which have already had a global address. They may
> > > > update lifetime of their global address, but the interval(1sec) is
> > > > still too short for this operations.
> > > > 
> > > > Since flooding packets is easy to cause performance 
> > damage in manet,
> > > > our approach tries to reduce a number of packets which are 
> > > > flooded over
> > > > manet. I think manet nodes should not wait flooded 
> > advertisements from
> > > > gateway, instead manet node should discover gateways on their
> > > > initiative.
> > > > 
> > > > It is also difficult for gateways to decide TTL for flooded
> > > > advertisements. Expanding ring search technique can not 
> > be applied to
> > > > this situation, because advertisements should reach at the edge of
> > > > manet. It can imagine that unnecessary network-wide 
> > dissemination of
> > > > advertisements will occur when a gateway sets larger TTL 
> > than manet
> > > > scale.
> > > > 
> > > > regards,
> > > > r
> > > > 
> > > > 
> > > > At Mon, 8 Jul 2002 17:27:19 +0200 ,
> > > > Fredrik Alriksson (EAB) wrote:
> > > > > 
> > > > > Hi All,
> > > > > 
> > > > > In draft-wakikawa-manet-globalv6-00.txt you claim that 
> > > > sending gateway advertisements peridically would generate 
> > > > unnecessary packets in the Manet. Can you please explain how 
> > > > you came to that conclusion? Our simulation study on MIPMANET 
> > > > from '99 (http://www.e.kth.se/~e94_fal/mipmanet.pdf) 
> > > > indicates that it actually can decrease the number of packet 
> > > > transmissions in the MANET.
> > > > > 
> > > > > BR,
> > > > > Fredrik
> > > > > 
> > > > > ---
> > > > > Fredrik Alriksson, Ericsson Research
> > > > > Email: [email-masked]
> > > > > 
> > > > > 
> > > > 
> >

---

From: Ryuji Wakikawa<[email-masked]>
Date: Fri, 12 Jul 2002 00:56:02 +0900

Hi Fredrik.

You are right.

regards,
ryuji