Subject: Re: [manet] Re: Gateway Advertisements

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 11 Jul 2002 10:26:37 -0700

Hello Fredrik,

"Fredrik Alriksson (EAB)" wrote:

> My concern is that a Manet node that is communicating via a GW
> will stick to this GW even if better GW's become available in
> the Manet. Someone commented that the Manet node can re-flood
> requests whenever they want to find better GWs; in response
> to that I wonder how the Manet node can know that there is a
> better GW available and that it thus should re-flood a request.
> The answer is of course that in many cases it cannot know.

I basically agree with your statements in this paragraph.
A mobile might use a default route even when a better route
is available.  This, however, might become true for any
destination, as you can quickly verify.  In fact, the
difference from optimal (lowest) can change from an arbitrarily
high value to even 1 without the mobile node's awareness.
These are properties across all periodic vs. reactive
approaches.  The fact that this one instance has to do
with Internet Gateways doesn't change the nature of the
basic phenomenon.

>> The best case would be for it to detect _none_ of the topology
>> changes, and yet retain routability to all of its communication
>> partners.
> 
> Even if the total traffic load, mean delay, etc. are higher?

These are the tradeoffs that have to be made.  As has been
mentioned, it's not very clearly understood about the
scenarios which favor reactive, and yet it seems that
reactive _typically_ offers advantages on total traffic
load, and disadvantages for mean delay.

> Regarding traffic patterns: I suspect that the traffic
> patterns will be quite different in an Internet connected
> Manet than in a standalone Manet (which is the most common
> scenario in previous simulation studies).

Agreed, and yet for many natural traffic patterns
I expect that a reactive approach will provide
good service.  In our approach, we suggest that
each node can be a default router, as well as a
next hop for aspecific destination.   A next-hop
node would agree to serve as a default router if
it had a a default route itself, and so on
until some node nearby the gateway had use of
the gateway as a default router.

In this scenario, the default router can easily
change direction from one gateway to another
gateway, either by route repairs, or the natural
progress of various route discovery operations.

Regards,
Charlie P.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 11 Jul 2002 10:26:37 -0700

Hello Fredrik,

Regards,
Charlie P.