Subject: Re: [manet] Re: Gateway Advertisements

From: Ryuji Wakikawa<[email-masked]>
Date: Fri, 12 Jul 2002 00:59:10 +0900

Hi again

At Thu, 11 Jul 2002 16:57:57 +0200,
Fredrik Alriksson (EAB) wrote:
> 
> 
> [Fredrik Alriksson] Then I think we agree; I originally started this
> thread since you in the draft claim that a proactive approach SHOULD
> NOT be used, but now you say that it depends and that we don't
> really know. Will that be reflected in the draft as well?

Yes, I want to consider proactive way. 
By the way, will you come IETF Yokohama in next week?

> For how long is the metrics about the GWs in the GW list valid (e.g. hop count)? 
> How does the Manet node know when to re-flood the request?
> How large fraction of all relevant topology changes will the Manet node detect?
> 
> My conclusion is still: it is better to let the GW flood periodically.
> 
> Are you absolutely sure that this will be the optimal solution in all situations?
> 
> 
> [Fredrik Alriksson] No, not in all situations. Isn't that a general
> 'feature' with MANETs, no single solution will ever be optimal for
> all MANETs ;-)
> 

I agree:-)

> 
> 
> In appendix A, we explain how to use the most appropriate GW with a
> routing header. I think the draft can be adapted to your above
> situation. What do you think?
> 
> --Snip from the drat
>    Using a routing header is also preferable if there are 
> more than two
> Internet-gateways, because the node then have the ability to decide
> which Internet-gateway is the best, by distance in hops, or by some
> other priority.  By assign a priority number for each 
> Internet-gateway,
> the route reply message and the Manet Router Advertisement messages
> could be extended to support a candidate Internet-gateway 
> option in it.
> -----
> 
> 
> I'm sorry, I don't really follow you here. In what sense is the text you refer to about sending advertisements periodically or not?
> 
> He describes how the gateway selection process can be implemented. 
> 
> 
> [Fredrik Alriksson] ...which is somewhat independent from how the advertisements are distributed...right?

I just wanted to explain reactive way can select closer one (if it
maybe inefficient). We have already considered hop limits to GW and
unfortunantely our solutions seems not enough...

> Well, it does if the Manet node unicasts the solicitation, which use list as one alternative if I understand the draft correct.
> 
> Furthermore, if using flooding, how often should Manet nodes flood the solicitations?
> 
> ... needs more testing... 
> 
> 
> [Fredrik Alriksson] The reason for asking is this: assume a MANET
> with 2 GWs and 10 manet nodes using these 2 GWs for Internet
> access. What is the overhead with proactive vs. reactive? Assuming
> that the periodicity is the same: reactive: 10 floodings, proactive:
> 2 floodings.
> 

I do not know if this example is good enough, because we can get
another results depending on topology changes, measurements periods:-)

After first discovery, reactive stop flooding and start unicasting instead.
So the result will change after first discovery.
For 10 sec: reactive: 0 floodings, proactive 10 floodings.
Well this is best case for reactive, another result can be expected, of
course!

> 
> >Then I think I didn't express myself clearly enough. My point is 
> >that using a 4-hop route between Manet node and GW1 consumes more 
> >resources in the Manet as a whole than using a 2-hop route between the 
> >same Manet node and GW2. Thus being able to select the closest gateway 
> >is a concern for all nodes in the Manet, including those that do not 
> >use internet connectivity.
> But minimizing the hop count is, of course, also the purpose of our solution. The question is whether it really
> does differ in average hop, or whether it really is more costful. Flooding could be very costful for battery sensitive devices. As for choosing the closest gateway, this should always be the ambition. The node could either rerequest gateway information, or maybe we could piggyback this information somewhere, in case a "handover"is needed.
> 
> 
> [Fredrik Alriksson] The question with a reactive approach is how to
> detect that a reaction is needed. Could you please describe that
> again?

Actually, the use of multiple GW is not considered enough yet, we just
mention our rough idea in the draft.  So I don't know if I have good
answer for this.

regards,
ryuji

> BR,
> Fredrik
> 
>  
> 
> best regards,
> 
> Anders 
> 
> 
> 
> 
> 
> 
> [2  <text/html; iso-8859-1 (quoted-printable)>]
> 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Ryuji Wakikawa<[email-masked]>
Date: Fri, 12 Jul 2002 00:59:10 +0900

Hi again

I agree:-)

regards,
ryuji