Subject: [manet] How do you compute normalized routing load?

From: Jonas Nielsen <[email-masked]>
Date: 01 Jul 2002 10:46:15 +0200

In most articles "Normalized routing load" is computed as sent (and
forwarded) DSR control packets divided by number of data packets
received. I use the following perl script to compute the normalized
routing load but the numbers i get are wrong compared to the results
from articles I compare the results with. I also use a similar script
to compute the packet delivery ratio and her i get the right results
on the same trace files.  

Here is the perl script:

#/usr/bin/perl

$file = 'wireless1-out.tr';
$DSRSent = 0;
$cbrReceived = 0;
open(TRACEFILE, "<$file" ) || die "\n" ;
while(<TRACEFILE>) {
  if ($_ =~/^(s|f).*\-It DSR/) {
    $DSRSent++;
    #print $_;
  }
  if ($_ =~/^r.*\-It cbr/) {
    $cbrReceived++;
    #print $_;
  }
}

print "DSR control packets sent\t$DSRSent\n";
print "Data (cbr) packets received\t$cbrReceived\n";
$load = 1.0*$DSRSent /$cbrReceived;

print "Normalized routing load:\t$load\n";

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: [email-masked]
Date: Wed, 17 Jul 2002 14:53:33 +0300 (EEST)

Hello
I simulate Ad Hoc networks and use AODV and DSR routing protocols. As I 
understood I have to parse trace file to get some results. But I have problems 
with understanding these files, because i found sources, but they have 
different format. In my case i have the following trace file 

s 127.936679222 _0_ AGT  --- 0 cbr 512 [0 0 0 0] ------- [0:0 2:0 32 0] [0] 0 3
r 128.033408580 _2_ AGT  --- 0 cbr 544 [a2 2 1 800] ------- [0:0 2:0 32 2] [0] 
2 3

I undersood that
s - event (send)
127.936679222 - time
_0_ from node
AGT  trace level
---  flag 
0 i don't know what it is
cbr constant bit rate
512 number of bytes

But other characters I don't understand, I suppose that [0:0 2:0 32 0] means 
source and destination address in form of "node:port".Can somebody give me 
advice how to explain these characters, please? Actually I need to have packet 
id and how to distinguish data from routing information.
Thanks in advance.
Best regards, Georgiy.

---

From: [email-masked]
Date: Wed, 17 Jul 2002 14:53:33 +0300 (EEST)

Hello

I undersood that
s - event (send)
127.936679222 - time
_0_ from node
AGT  trace level
---  flag

---

From: "Moustafa Hasnaa" <[email-masked]>
Date: Wed, 17 Jul 2002 14:28:28 +0200

Concerning the trace files, i do not know exactly which version of ns are u
using.
 As far as i know for verion 2.17 , parsing trace files is well explained in
the manuel.
     The ns Manual (formely ns Notes and Documentation)

Hope this can help
regards

---

From: "Moustafa Hasnaa" <[email-masked]>
Date: Wed, 17 Jul 2002 14:28:28 +0200

Hope this can help
regards