Subject: [manet] AODV and Mobile IP References

From: "Michael Sessinghaus" <[email-masked]>
Date: Fri, 5 Jul 2002 15:40:38 +0200

Hi people,

Has any research been done on simulation of aodv and mobile ip to assure connectivity to internet?
Any ns-simulation (tcl scripts) and references?

Thanks for your Help

Best regards, Michael.

---

From: Jin Xi <[email-masked]>
Date: Wed, 10 Jul 2002 11:31:04 +0200

Hello, Michael,

We are doing research in the same direction as Ad hoc Internet access,
but not restrict the routing algorithm to AODV. The abstract of a paper
on this topic can be found in
http://www.lkn.ei.tum.de/lkn/mitarbeiter/chris/publications/xi_bettstetter_3gwireless2002.html.

Currently we are working on gateway discovery simulation with Glomosim.
More information will be available once the simulation is completed.

Regards

Jane
--
Jin Xi
Institute of Communication Networks, Munich University of Technology
Building 4, Room 0407, Arcisstr. 21, 80290 Munich, Germany
Tel.: +49 (0)89/289-25821, Fax: +49 (0)89/289-23523
mailto:[email-masked], WWW: http://www.lkn.ei.tum.de/~jix

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Jin Xi <[email-masked]>
Date: Wed, 10 Jul 2002 11:31:04 +0200

Hello, Michael,

Regards

Jane

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Mon, 8 Jul 2002 17:10:47 +0200

Hi Michael, 

At http://www.e.kth.se/~e94_fal/mipmanet.pdf you can find our M.Sc. thesis from ´99 called MIPMANET, which is about connecting IPv4 MANETs to the Internet. We've identified many of the problems, proposed several solutions, and compared a few of them by means of simulations. The work was also published at the first MobiHOC workshop in August, 2000; send me an email if you're interested in a soft copy of this paper.

I haven't really followed the MANET-list lately, but the approach taken in draft-royer-manet-globalv4-00.txt seems to be very similar to ours. If going for IPv6, you get some things 'for free' and the solution can be much nicer, as is shown in draft-wakikawa-manet-globalv6-00.txt, but many of the problems we discuss in our thesis are still valid.

BR,
Fredrik

---
Fredrik Alriksson, Ericsson Research
[email-masked]

> -----Original Message-----
> From: Ryuji Wakikawa [mailto:[email-masked]]
> Sent: den 5 juli 2002 19:49
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [manet] AODV and Mobile IP References
> 
> 
> 
> Hello Michael.
> 
> We are working on this and have drafts about internet 
> connectivity (IPv6) for manet.
> Please check the draft here.
> http://search.ietf.org/internet-drafts/draft-wakikawa-manet-gl
obalv6-01.txt

We have already implemented the system (AODV6 + global6-draft) on
Linux and make sure to provide internet connectivity to mobile node
and to general nodes from manet.

I am also implementing AODV6+global6-draft on ANY-BSD+kamestack. I
hope it will be soon available in public. 

We also simulate the system (not test MIP6 case).

Prof.Elizabeth Belding-Royer is working on IPv4 connectivity for manet.
http://www.cs.ucsb.edu/~eroyer/txt/globalv4.txt

The draft for address auto-configuration in manet is also available.
http://www.cs.ucsb.edu/~eroyer/txt/autoconf.txt

best regards,
ryuji	

At Fri, 5 Jul 2002 15:40:38 +0200,
Michael Sessinghaus wrote:
> 
> [1  <text/plain; iso-8859-1 (quoted-printable)>]
> Hi people,
> 
> [2  <text/html; iso-8859-1 (quoted-printable)>]
>

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Mon, 8 Jul 2002 17:10:47 +0200

Hi Michael, 

BR,
Fredrik

---

obalv6-01.txt

best regards,
ryuji