Subject: Re: [manet] IP addresses in MANET

From: "Phil Neumiller" <[email-masked]>
Date: Wed, 10 Jul 2002 09:22:29 -0400

Hello Yasser,

Sorry I have not responded to this subject sooner, since it is of great interest to me.  I have been on
vacation for a spell.

> Good day everybody,
>
> I've been following on the IP addressing proplem, and want to contribute some thoughts
> 1) I believe ad hoc will adopt IPv6. Since no comercial solution is available for ad-hoc, it makes absolute sense to use
> IPv6 for addressing. This solve the problem of "Internet running out of space" and introduce the problem of "Personal IP" > which
is global vs local IP

Not quite.  We (my company) have some commercially (beta) available MANET solutions that are quite
friendly to IPv4.  Adopting IPv6 in a small, battery driven device is not really all that feasible yet.
A small PDA running an ARM processor has to keep its software workload pretty light.  Also
the "born on" IP addressing scheme you propose is not feasible for the same reason truly permanent
phone numbers are not feasible.  There is a security issue and a privacy issue here.  You could become
vulnerable to all kinds of attacks if your "permanent" IP address is known to some crank.

>
> 2) Assigning "pool of addresses" for an ad-hoc network is so difficult in the absense of central authority. This means that nodes
will have to announce an IP address when joining the network, get authenticated (how the authentication could be done is a different
issue), then the nodes can move within the same ad-hoc freely by keeping their IP.

When a host attaches to the global Internet it becomes part of the global Internet and extends it.  The
host in all instances should be reachable, i.e. globally addressable if it is an IPv4 or IPv6 host.  The only
realistic solution today is Mobile IP.  This means that a Mobile IP home address can be acquired from
an operator that provides mobility service.  The MANET system (doesn't really matter if its DSR, AODV,
etc) can route using the home address since the most developed MANET algorithms know nothing of
hierarchy.  Many of these issues are being addressed by the MONET group.

NOTE:  I would really like to see a stab at a "classless" MANET routing protocol where the concept of
a subnet for a MANET is defined and subnet masks are propogated in route updates.  M-CIDR???
>
> 3) Local traffic (within the same ad-hoc) can be routed easly. Internet traffic will be subject to (gateway address resolution).
Since many gateways may work for the same ad-hoc, we need to guarantee consistency between all gateways.
>
> This way no central authority is needed which is very consistent with the MANET charter. Also, if an individual nodes has a static
IP it should be able to use it. The authentication process can elementate the possibility of IP address conflict.
With respect to the MANET charter, it does not preclude one from using MANET algorithms in a
heterogeneous fixed infrastructure and mobile environment.  In fact we have found it quite desirable to
pepper a coverage area with fixed infrastructure (running MANET algorithms) that provide basic
coverage and connectivity to the Internet.  My feeling is that this will be the most practical large scaled
deployment of MANETs.

Thanks,

Phil

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Phil Neumiller" <[email-masked]>
Date: Wed, 10 Jul 2002 09:22:29 -0400

Hello Yasser,

is global vs local IP

Thanks,

Phil

---

From: "Fred L. Templin" <[email-masked]>
Date: Wed, 10 Jul 2002 09:00:44 -0700

Hi Phil,

I generally liked your note, but beg to differ on one minor point:

Phil Neumiller wrote:
> Adopting IPv6 in a small, battery driven device is not really all that feasible yet.
> A small PDA running an ARM processor has to keep its software workload pretty light.

I disagree about the feasibility arguement; I've been running IPv6 on
PDAs for a long time now and the added code footprint/computational
complexity for running IPv6 present no technical challenges. There
may be business/marketing related reasons behind the slow adoption
of IPv6 on PDAs, but no technical issues that I can think of.

Regards,

Fred
[email-masked]

---

From: "Fred L. Templin" <[email-masked]>
Date: Wed, 10 Jul 2002 09:00:44 -0700

Hi Phil,

Regards,

Fred
[email-masked]