Subject: Re: [manet] Gateway address resolution

From: Anders Nilsson <[email-masked]>
Date: Mon, 01 Jul 2002 09:27:37 +0200

Hi!

There is a few groups out there working on these questions, and two drafts:
draft-wakikawa-manet-globalv6-00.txt
draft-royet-manet-globalv4-00.txt

regards,

Anders N

Scott C. Lemon wrote:

>Yes!
>
>I agree 100% ... think of the MANETs as roaming flat networks ... and each
>node becomes a possible router with NAT using a second interface - wireless
>*or* wired - to provide connectivity from the MANET to the Internet.
>
>This is the direction that we are working right now ...
>
>
>Scott C. Lemon
>HumanXtensions L.L.C.
>http://www.HumanXtensions.com
>http://the.Inevitable.Org/anism
>
>   "People often talk about it being the journey, not the destination.
>        Consider the possibility that there is no destination ...
>                    that in life there is only journey!"
>
>----- Original Message -----
>From: "kuldip Singh pabla" <[email-masked]>
>To: <[email-masked]>; <[email-masked]>
>Sent: Friday, June 28, 2002 3:50 PM
>Subject: Re: [manet] Gateway address resolution
>
>
>>Yasser,
>>
>>How about treating the ad-hoc network as a NATed community in this case!
>>
>>-Kuldip
>>
>>"Yasser A. Lotfy" wrote:
>>
>>>Hi,
>>>
>>>Seems like many have agreed on the general ideas in my original e-mail.
>>>
>However, one point yet need further discussion:
>
>>>Gateway address resolution;
>>>Since ad-hoc IP addresses don't represent a pool of addresses, the idea
>>>
>of subnet mask can not be used. Hince, distinguishing intranet traffic from
>internet traaffic becomes a critical challenge.
>
>>>For example ad-hoc gateways can read distination address and check
>>>
>againest table of all ad-hoc IP addresses. This can raise scalability
>issues. Can IPv6 provide a way to distinguish local ad-hoc nodes from fixed
>structure nodes? Any other ideas?
>
>>>Yasser
>>>Carleton U
>>>Ottawa, Canada
>>>
>>>____________________________________________________________
>>>Win a first-class trip to New Orleans and vacation Elvis Style!.
>>>Enter NOW!
>>>http://r.lycos.com/r/sagel_mail/http://www.elvis.lycos.com/sweepstakes/
>>>
>>>_______________________________________________
>>>manet mailing list
>>>[email-masked]
>>>https://www1.ietf.org/mailman/listinfo/manet
>>>
>>--
>>Kuldip Singh Pabla
>>Peer-2-Peer Networking
>>External: 408.276.6118 Internal: x16118
>>
>>_______________________________________________
>>manet mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/manet
>>
>
>
>_______________________________________________
>manet mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/manet
>

---

From: Anders Nilsson <[email-masked]>
Date: Mon, 01 Jul 2002 09:27:37 +0200

Hi!

regards,

Anders N