Subject: [manet] DSR RREQs

From: [email-masked] (Noah H. Miller)
Date: 25 Jul 2002 12:42:54 EDT

Hello,

I have several questions about DSR Requests:

First, upon retransmission of a Request (in the case in which no Reply was received before timeout), does the ID number of the Request get incremented?  If not, that is if the same ID is used for successive Request retransmissions, other nodes will ignore
 all but the first transmission, which seems like a waste.

Second, the following line on page 20 of Draft 7 confuses me.  The Route Request table is expected to record "The number of consecutive Route Discoveries initiated for this target since receiving a valid Route Reply giving a route to that target."  If thi
s node already has a route, why would it initiate a new Route Discovery?

Third, what are default values for retransmission of a Request?  Section 9 of Draft 7 suggests 16 retransmissions, with the first delay of 500 milliseconds, and subsequent delays of 500*2^(number of retransmissions).  This exponential backoff would reach 
tens of thousands of seconds by retransmission #16.  But there is also a Max Request Period of 10 seconds listed, which would allow only 4 retransmissions.  Is that enough?

Thank you,
Noah Miller
ISTS, Dartmouth College

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Anna Saputera <[email-masked]>
Date: Thu, 25 Jul 2002 11:27:59 -0700 (PDT)

Hi Noah,
I was trying to think about your questions. But, I am
not sure how I can find the "draft" that you mentioned
several times. Would you tell me where I can read it?

Thanks,
Anna

--- "Noah H. Miller" <[email-masked]>
wrote:
> First, upon retransmission of a Request (in the case
> in which no Reply was received before timeout), does
> the ID number of the Request get incremented?  If
> not, that is if the same ID is used for successive
> Request retransmissions, other nodes will ignore
> Second, the following line on page 20 of Draft 7
> confuses me.  The Route Request table is expected to
> record "The number of consecutive Route Discoveries
> initiated for this target since receiving a valid
> Route Reply giving a route to that target."  If thi
> Third, what are default values for retransmission of
> a Request?  Section 9 of Draft 7 suggests 16
> retransmissions, with the first delay of 500
> milliseconds, and subsequent delays of 500*2^(number
> of retransmissions).  This exponential backoff would
> reach 
> tens of thousands of seconds by retransmission #16. 
> But there is also a Max Request Period of 10 seconds
> listed, which would allow only 4 retransmissions. 
> Is that enough?
> 
> Thank you,
> Noah Miller
> ISTS, Dartmouth College
> 

=====
Anna Saputera

__________________________________________________
Do You Yahoo!?
Yahoo! Health - Feel better, live better
http://health.yahoo.com

---

From: Anna Saputera <[email-masked]>
Date: Thu, 25 Jul 2002 11:27:59 -0700 (PDT)

Hi Noah,

Thanks,
Anna

=====
Anna Saputera