Subject: RE: [manet] Gateway address resolution

From: "Mullen, John P. (Contractor)" <[email-masked]>
Date: Mon, 1 Jul 2002 07:47:32 -0600

Hi,

I know I'm missing something here.

Why can't the MANET be treated as a local intranet with each of its nodes
having a common Internet subnet mask (augmented by whatever is needed to
affect routing within the MANET, of course.)  When a gateway sees a packet
bearing an IP with the MANET subnet mask, it knows it is intended for a node
within the MANET, while one with a different pattern would be clearly
intended for the Internet.  

John Mullen

-----Original Message-----
From: Yasser A. Lotfy [mailto:[email-masked]]
Sent: Friday, June 28, 2002 3:40 PM
To: [email-masked]; Kuldip Singh Pabla; Charles E. Perkins; Rex
Buddenberg
Cc: [email-masked]
Subject: [manet] Gateway address resolution

Hi,

Seems like many have agreed on the general ideas in my original e-mail.
However, one point yet need further discussion:

Gateway address resolution; 
Since ad-hoc IP addresses don't represent a pool of addresses, the idea of
subnet mask can not be used. Hince, distinguishing intranet traffic from
internet traaffic becomes a critical challenge.

For example ad-hoc gateways can read distination address and check againest
table of all ad-hoc IP addresses. This can raise scalability issues. Can
IPv6 provide a way to distinguish local ad-hoc nodes from fixed structure
nodes? Any other ideas?

Yasser 
Carleton U
Ottawa, Canada

____________________________________________________________
Win a first-class trip to New Orleans and vacation Elvis Style!.
Enter NOW!
http://r.lycos.com/r/sagel_mail/http://www.elvis.lycos.com/sweepstakes/

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 01 Jul 2002 10:07:59 -0700

Hello John,

> intended for the Internet.

This can be done, yes.  And yet, it should at the same time be possible
for nodes to join the MANET without having to conform to the subnet
addressability that is offered.  Those nodes, however, may be unable to
make use of the bidirectional Internet connectivity offered by the gateway.

Regards,
Charlie P.

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 01 Jul 2002 10:07:59 -0700

Hello John,

Regards,
Charlie P.

---

From: "Phil Neumiller" <[email-masked]>
Date: Wed, 10 Jul 2002 09:50:14 -0400

Hi John,

> affect routing within the MANET, of course.)  

Because all current MANET algorithms are classful in the sense that the routing
algorithm does not propagate subnet bits masks.  How do you define a subnet in
a MANET?  I have pondered this for quite some time.  The only reasonable answer
I have currently is to elect a subnet leader and make the neighbors of the leader
the subnet.  Maybe the neighbors neighbors too.  When a node gets to far (too 
many hops away) from a subnet leader and sees a closer one it can acquire that
subnet mask.  Of course all the MANET protocols would need to change to 
support mask propagation.  This would take some work.

---

From: "Phil Neumiller" <[email-masked]>
Date: Wed, 10 Jul 2002 09:50:14 -0400

Hi John,

---

From: Guillaume Chelius <[email-masked]>
Date: Wed, 10 Jul 2002 16:27:58 +0200 (CEST)

Hello, 

> Because all current MANET algorithms are classful in the sense that the
> routing algorithm does not propagate subnet bits masks.  How do you define a
> subnet in a MANET?  

It could work with IPv6 since there is no need for subnet propagation. By
default, all nodes would use the link-local prefix. If a global prefix is
broadcasted, nodes also acquire the global prefix as you describe above.

> I have pondered this for quite some time.  The only reasonable answer
> I have currently is to elect a subnet leader and make the neighbors of
> the leader the subnet.  Maybe the neighbors neighbors too.  When a node gets
> to far (too many hops away) from a subnet leader and sees a closer one it can
> acquire that subnet mask.  Of course all the MANET protocols would need to 
> change to support mask propagation.  This would take some work.  

-----------------
Guillaume Chelius
PhD student
Ares Team, Inria, Citi Insa-Lyon
Tel: (+33) 472 436 421
Email: [email-masked]

---

From: Guillaume Chelius <[email-masked]>
Date: Wed, 10 Jul 2002 16:27:58 +0200 (CEST)

Hello, 

-----------------
Guillaume Chelius
PhD student

---

From: Charlie Perkins <[email-masked]>
Date: Wed, 10 Jul 2002 07:39:13 -0700

Hello Phil,

AODV does support subnet mask propagation.

The subnet leader is responsible for coordinating
the routability of the subnet.  All RREQs for any
node on the subnet have to be answered as if the
subnet leader were providing the response.

Causing the subnet to be formed from random
neighbors works better if the neighbors are likely
to hang together for a while, and if they don't
already have some other addresses they would
like to keep.

AODV does not support discontiguous ranges
of addresses forming a "subnet" (whatever that
word would mean).

Regards,
Charlie P.

---

From: Charlie Perkins <[email-masked]>
Date: Wed, 10 Jul 2002 07:39:13 -0700

Hello Phil,

Regards,
Charlie P.

---

From: "Phil Neumiller" <[email-masked]>
Date: Wed, 10 Jul 2002 11:08:17 -0400

Ouch!  Sorry Charlie (tuna that tastes bad or something).  I must be stuck in the
past.  I see this in the latest draft.  I stand [VERY] corrected.  Does DSR have
plans to follow suit?

---

From: "Phil Neumiller" <[email-masked]>
Date: Wed, 10 Jul 2002 11:08:17 -0400

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 10 Jul 2002 08:40:45 -0700

Hello Phil,

Phil Neumiller wrote:

> past.  I see this in the latest draft.

The subnet mask propagation has been there for years, but it's
easy to miss and hasn't been discussed much within [manet].

I'm puzzling over what percentage of the respondents to
this list will recognize your tuna reference...

Regards,
Charlie P.

PS. You can tune a piano, and you can tune a guitar, but you can't tunefs.
    (screams of agony are blissfully unheard over e-mail)

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 10 Jul 2002 08:40:45 -0700

Hello Phil,

Regards,
Charlie P.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 10 Jul 2002 09:06:24 -0700

Hello Guillaume,

> broadcasted, nodes also acquire the global prefix as you describe above.

We use the idea of disseminating the global prefix, but not by
broadcast.

Using link-local addresses is problematic because no router is
supposed to forward them.  In our draft, we defined a distinguished
site-local address for this purpose.

It remains to be seen whether site-local addressing will survive
within IPv6.  If not, then maybe instead we can define some variant
of the link-local addresses that can be forwarded.  We could call
them "manet-local" addresses, and they would use a distinguished
"manet-local" prefix.

Regards,
Charlie P.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 10 Jul 2002 09:06:24 -0700

Hello Guillaume,

Regards,
Charlie P.

---

From: "Phil Neumiller" <[email-masked]>
Date: Wed, 10 Jul 2002 13:52:55 -0400

For the inquiring minds...

"Sorry Charlie, Starfish doesn't want Tuna with good taste, Starfish wants Tuna that taste good!"

Is an old TV commercial slogan from Starfish [canned] Tuna company which was played
over and over again during episodes of Leave it to Beaver and Gilligan's Island....

I have re-read this section 6 and 7 and I have the following questions about it (now that I
been conked upside the head with it).

1). Don't MANET nodes that use mobile IP have to route on their static home addresses?

2). If the "bunch of mobiles" that are to be aggregated, are random mobiles from a large
     variety of different home networks, how can a subnet of consequitive addresses be
     formed?  

3). The definition of "subnet" that is introduced in section 6 sounds much looser, more like
      a MONET to me.

4).  Why couldn't every node in the "subnet" as defined, proxy for all others in the RREP?
       i.e. why do other subnet nodes need to FORWARD RREQs to the subnet leader?
       That seems to be a point of vulnerability.  It seems that any entity in the subnet blob
       should be able to answer for the subnet blob - in case the subnet leader fails.

5).   Why would we not want all nodes to be advertising reachability?  It seems that 
        the subnet leader could easily be out of range from mobile nodes wishing to 
        communicate with the subnet.  Or is this just because they would end up relaying
        each others gratuitous RREPs w/ subnet bits and that would be redundant.

6).    Do all nodes in the subnet have to be one hop away from the subnet leader?
         i.e. have a closed bi-directional link to the leader?  If not, how many hops away
         can they be.

Thanks,

Phil

---

From: "Phil Neumiller" <[email-masked]>
Date: Wed, 10 Jul 2002 13:52:55 -0400

Thanks,

Phil

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 10 Jul 2002 11:15:00 -0700

Hello Phil,

Phil Neumiller wrote:

> I have re-read this section 6 and 7 and I have the following questions about it
> (now that I been conked upside the head with it).
> 

A node "should" be able to use Mobile IP for any address it owns,
and for which there is a home agent (or maybe not even that for
the experimental "homeless" variants).

> 2). If the "bunch of mobiles" that are to be aggregated, are random mobiles
>     from a large variety of different home networks, how can a subnet of
>     consequitive addresses be formed?

If nodes are using random addresses, then it can't.

On the other hand, can you tell me what it means to have a subnet
of non-consecutive addresses?

Maybe somebody here has horror stories about using the
"more flexible" subnet masks of old versions of BSD Unix.

> 3). The definition of "subnet" that is introduced in section 6 sounds much
>     looser, more like a MONET to me.

It includes only the features needed by AODV.  But those are
hard requirements, as far as I know.

> 4).  Why couldn't every node in the "subnet" as defined, proxy for

They could, as long as they keep the sequence number consistent.

>        That seems to be a point of vulnerability.  It seems that any entity in the
>        subnet blob should be able to answer for the subnet blob - in case the
>        subnet leader fails.

This is a special case of a much more general problem, though.
How does any system function, if the central control point fails?
Usually, by redundancy and distribution of failover data.
You'll have to weigh the benefits vs. the cost for each instance.
For the case of the subnet in an ad hoc network, one would have
to write the protocol for maintaining subnet semantics.  I reckon
it would resemble what you would do for an anycast group.

>         communicate with the subnet.  Or is this just because they would end up
>         relaying each others gratuitous RREPs w/ subnet bits and that would be
>         redundant.

Nodes outside the subnet need to have some useful sequence number
assignable to the route towards the subnet.  As long as you can have
all the nodes advertising consistent sequence number information,
it will work.  For example, they could advertise the SAME sequence
number, but other solutions are also possible.

> 6).    Do all nodes in the subnet have to be one hop away from the subnet leader?

No.

>          If not, how many hops away can they be.

As many as your system design can manage, within the constraint
of obeying subnet semantics.

Regards,
Charlie P.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 10 Jul 2002 11:15:00 -0700

Hello Phil,

No.

Regards,
Charlie P.

---

From: "Phil Neumiller" <[email-masked]>
Date: Wed, 10 Jul 2002 14:35:09 -0400

I stand corrected again.  It was "Starkist Tuna" not Starfish Tuna!

---

From: "Phil Neumiller" <[email-masked]>
Date: Wed, 10 Jul 2002 14:35:09 -0400