Subject: Re: [manet] QoS over a wireless Ad Hoc network

From: John Tapsell <[email-masked]>
Date: Wed, 3 Jul 2002 14:27:47 +0100

Harpeet,
  Hi!   I'm replying in reference to the Simulation Study of the 
Feasibility of Differentiated Services Framework for QoS in
MANET's (long title..)

  An excellent paper :)

  A few comments:
	Is having 3 layers of priority enough?
	Should control packets for non-priority traffic be considered
		higher priority as priority traffic itself?
	What if you have more high priority traffic than bandwidth?
		In such a situation you need to either try to take
		another route (dynamically adjust weighting(cost) at the
		routing level), throttle back the clients (dynamically
		adjust output based on bandwidth), or drop some streams
		for the sake of others (perhaps could be done with more
		layers of priority)
Comments!

JohnFlux

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: John Tapsell <[email-masked]>
Date: Wed, 3 Jul 2002 14:27:47 +0100

Harpeet,

  An excellent paper :)

  A few comments:

JohnFlux

---

From: Yang Xiao <[email-masked]>
Date: Wed, 3 Jul 2002 09:27:43 -0700 (PDT)

Harpeet and JohnFlux

I did not follow this thread. Where can I find this paper?

Thanks

Yang

> 		for the sake of others (perhaps could be done with more

__________________________________________________
Do You Yahoo!?
Sign up for SBC Yahoo! Dial - First Month Free
http://sbc.yahoo.com

---

From: Yang Xiao <[email-masked]>
Date: Wed, 3 Jul 2002 09:27:43 -0700 (PDT)

Harpeet and JohnFlux

Thanks

Yang

---

From: Harpreet Arora <[email-masked]>
Date: Wed, 03 Jul 2002 17:12:16 -0400 (EDT)

Hi John,

The number of levels of priority depends on the types of applications
supported by the network and also on the situations where the network is
used. For example a network used for rescue operations can have
voice traffic with different priorities depending upon the urgency of the
message. For commercial purposes, this decision I guess depends on the way
the service providers
decide to charge for the bandwidth and priority. 

If the bandwidth required by the high priority flow is greater than
available, then the way it is processed can depend on the priority level
of the flow. FOr example, for short urgent messages, the bandwidth of
other flows can surely be throttled for a short time to make way for this
flow. Else, the new flow can be denied admittance to ensure that the
already existing flows are not disrupted for a long time.

I think all these factors are completely dependent on the situation the
network is used for and the kind of applications supported. 

Harpreet

---

From: Harpreet Arora <[email-masked]>
Date: Wed, 03 Jul 2002 17:12:16 -0400 (EDT)

Hi John,

Harpreet

---

From: "Andrew T. Campbell" <[email-masked]>
Date: Wed, 3 Jul 2002 17:32:21 -0400

John, Yang and Harpreet:

I think its difficult to implement the classic DiffServ
paradigm in wireline networks, nevermind ad hoc mobile and
wireless networks. I think best you can do is
have fast local rate control of best effort traffic to
yield the necessary low delays and stable bandwidth for
real-time traffic. 

You can take a look at the SWAN approach that uses this
in combination with a slower time scale and coarser end-to-end 
algorithms for admission control and regulation.

SWAN follows the end to end argument pushing the smarts to
the 'edge' (source/destination) and leaving the 'network' stateless.

See:

http://comet.columbia.edu/swan/

for some papers.  We are planning on submitting an ID soon
and releasing the ns-2 and testbed code.

---
Andrew
http://comet.columbia.edu/~campbell

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Yang Xiao
> Sent: Wednesday, July 03, 2002 12:28 PM
> To: John Tapsell; Harpreet Arora
> Cc: [email-masked]
> Subject: Re: [manet] QoS over a wireless Ad Hoc network
> 
> 
> Harpeet and JohnFlux
>

---

From: "Andrew T. Campbell" <[email-masked]>
Date: Wed, 3 Jul 2002 17:32:21 -0400

John, Yang and Harpreet:

See:

---
Andrew