Subject: [manet] a list of papers on security for ad hoc networks

From: feng zhu <[email-masked]>
Date: Tue, 30 Jul 2002 12:34:51 -0700 (PDT)

Hi, All,

I made a webpage to contain a list of papers on
security for ad hoc networks.

http://www.ccs.neu.edu/home/zhufeng/security_manet.html

If you wrote and/or know of any papers concerning
security for ad hoc networks that are not listed here,
please let me know.

Contract me: [email-masked]

Best,
Feng

The following is a part of the list.
========================================

Key Exchange and Distribution:

[AG] N. Asokan, Philip Ginzboorg Key agreement in ad
hoc networks  

[H] Maarit Hietalahti  Key Establishment in Ad-hoc
Networks

[CBH]Srdjan Capkuny, Levente Buttyan and Jean-Pierre
Hubaux Self-Organized Public-Key Management for Mobile
Ad Hoc Networks

Secure Routing:

[BT] Jim Brinkley William Trost Authenticated Ad Hoc
Routing at the Link Layer for Mobile Systems 1996 

[DLRS]Bridget Dahill, Brian Neil Levine, Elizabeth
Royer, Clay Shields. A Secure Routing Protocol for Ad
Hoc Networks

[HPJ] Yih-Chun Hu, Adrian Perrig, David B. Johnson.
Ariadne: A secure On-Demand Routing Protocol for Ad
hoc Networks

[MGLB] Sergio Marti and T. J. Giuli and Kevin Lai and
Mary Baker. Mitigating routing misbehavior in mobile
ad hoc networks. Mobile Computing and Networking
(2000): 

[PH] Panagiotis Papadimitratos and Zygmunt J. Haas
Secure Routing for Mobile Ad hoc Networks and  
[slides]

[SMG] Bradley R. Smith, Shree Murthy, J.J.
Garcia-Luna-Aceves Securing Distance-Vector Routing
Protocols

[YNK] Seung Yi, Prasad Naldurg, Robin Kravets. A
Security-Aware Ad Hoc Routing Protocol for Wireless
Networks [2]

[L] Janne Lundberg Routing Security in Ad Hoc Networks

[HJP] Yih-Chun Hu, David B. Johnson, and Adrian
Perrig. SEAD: Secure Efficient Distance Vector Routing
for Mobile Wireless Ad Hoc Networks. Proceedings of
the 4th IEEE Workshop on Mobile Computing Systems &
Applications (WMCSA 2002), pp. 3-13, IEEE, Calicoon,
NY, June 2002.

[Z]Manel Guerrero Zapata Secure Ad hoc On-Demand
Distance Vector (SAODV) Routing

Group Communication:

[YD] Alec Yasinsac Jim Davis. Modeling Protocols for
Secure Group Communication in Ad Hoc Networks
(Extended Abstract)

[MAH ]Silja Mäki, Tuomas Aura, Maarit Hietalahti
Robust Membership Management for Ad-hoc Groups

Other Security issues: 

[CK] Candolin, H. Kari, A Security Architecture for
Wireless Ad hoc Networks, to be published at IEEE
Milcom 2002, Anaheim, California, October 7-10, 2002

[EGN] Pasi Eronen, Christian Gehrmann, Pekka Nikander
Securing ad hoc Jini services

[HBC} Jean-Pierre Hubaux, Levente Buttyan, Srdjan
Capkun (Swiss Federal Institute of Technology) The
Quest for Security in Mobile Ad Hoc Networks

[LKZLZ] Haiyun Luo, Jiejun Kong, Petros Zerfos, Songwu
Lu and Lixia Zhang, Self-securing Ad Hoc Wireless
Networks  

[K] Vesa Karpijoki Security in Ad Hoc Networks 

[SA] Frank Stajano and Ross Anderson The Resurrecting
Duckling: Security Issues for Ad-hoc Wireless Networks

[SH] Christian Schwingenschlögl and Marc-Philipp Horn
Build Blocks for Secure Communication in Ad-hoc
Networks

[V] Anne Vanhala Security in Ad-hoc Networks 

[ZH] Lidong Zhou, Zygmunt J. Haas. Securing ad hoc
networks. IEEE Communications, Vol. 13 No. 6

[ZL] Yongguang Zhang & Wenke Lee, Intrusion Detection
in Wireless Ad-Hoc Networks

[LL] Haiyun Luo, Songwu Lu Ubiquitous and Robust
Authentication Services for Ad Hoc Wireless Networks, 

[KZLLZ] Jiejun Kong, Petros Zerfos, Haiyun Luo, Songwu
Lu and Lixia Zhang.  Providing Robust and Ubiquitous
Security Support for Mobile Ad-Hoc Networks

[GN] Christian Gehrmann (Ericsson Research), and Pekka
Nikander (Helsinki Institute of Technology) Securing
Ad Hoc Services, a Jini View

[KLXGGL] Jiejun Kong, Haiyun Luo, Kaixin Xu, Daniel
Lihui Gu, Mario Gerla, Songwu Lu Adaptive Security for
Multi-layer Ad-hoc Networks

[BH]Levente Buttyan and Jean-Pierre Hubaux  Enforcing
Service Availability in Mobile Ad-Hoc WANs  

[VA]Lakshmi Venkatraman and Dharma P. Agrawal  A Novel
Authentication scheme for Ad hoc Networks

[BSSW]Dirk Balfanz, D. K. Smetters, Paul Stewart and
H. Chi Wong Talking To Strangers: Authentication in
Ad-Hoc Wireless Networks

[J]Stuart Jacobs MANET Authentication Architecture
<draft-jacobs-imep-auth-arch-00.txt> (slides)

__________________________________________________
Do You Yahoo!?
Yahoo! Health - Feel better, live better
http://health.yahoo.com

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Sridhar K N <[email-masked]>
Date: Wed, 31 Jul 2002 09:40:52 +0800 (GMT-8)

here are some other papers.

1. A distributed Light-weight AUthentication Model for Ad-Hoc Networks, 
by ANdre Weimerskirch and Gilles Thonet.

2. Nodes Bearing Grudges: Towards Routing Security, Fairness and
Roubustness in Mobile Ad Hoc Networks. by Sonja Buchegger and Jean-Yves Le
Boudec.

3. AT&T Labs Technical Report, Using the Fluhrer, Mantin, and Shamir
Attack to Break WEP.

Regards
Sridhar

#############################################################################

---

From: Sridhar K N <[email-masked]>
Date: Wed, 31 Jul 2002 09:40:52 +0800 (GMT-8)

Regards
Sridhar

---

From: feng zhu <[email-masked]>
Date: Tue, 30 Jul 2002 22:24:19 -0700 (PDT)

Hi, 

Thank you for your information.

I have updated the web page

The first two papers have been listed in the web page.
But the 3rd paper is about WEP and IEEE802.11, not ad
hoc network. So I did not add it into the web page.

Best,
Feng

---

From: feng zhu <[email-masked]>
Date: Tue, 30 Jul 2002 22:24:19 -0700 (PDT)

Hi, 

Best,
Feng

---

From: Sonja Buchegger <[email-masked]>
Date: 31 Jul 2002 11:39:23 +0200

Hi Feng,

some more references: the following is a more detailed description of
our approach outlined in the 'nodes bearing grudges' paper as listed on
your site, and it also gives simulation results.

Sonja Buchegger and Jean-Yves Le Boudec. Performance Analysis of the
CONFIDANT Protocol: Cooperation Of Nodes - Fairness In Distributed
Ad-hoc NeTworks. In Proceedings of the Third ACM International Symposium
on Mobile Ad Hoc Networking and Computing MobiHOC 2002, p.226-236,
Lausanne, CH, June 2002. 

And here's a short overview paper i wrote on security in ad-hoc
networks, you'll probably find more references for your website in
there:

Sonja Buchegger and Jean-Yves Le Boudec. Cooperative Routing in Mobile
Ad-hoc Networks: Current Efforts Against Malice and Selfishness. In
Lecture Notes on Informatics, Mobile Internet Workshop, Informatik 2002,
Dortmund, Germany, October 2002. Springer.

It is yet to appear, but you can download it e.g. from
http://lcawww.epfl.ch , where you can also find the papers on your list
and more by Levente Buttyan, Srdjan Capcun, and Jean-Pierre Hubaux. Also
there are relevant papers coming out of the terminodes project, keep
checking out the terminodes page at http://www.terminodes.org .

Best regards,
Sonja

_/  _/  _/  _/  _/  _/  _/  _/  _/  _/  _/  _/  _/  _/  _/  _/  _/  _/  

 Sonja Buchegger
 IBM Zurich Research Lab    email: [email-masked]
 Saeumerstr. 4              phone: +41/1/724 82 37
 CH-8803 Rueschlikon        fax : +41/1/724 89 55
 Switzerland                http://www.zurich.ibm.com/~sob

---

From: Sonja Buchegger <[email-masked]>
Date: 31 Jul 2002 11:39:23 +0200

Hi Feng,

Best regards,
Sonja

 Sonja Buchegger

---

From: feng zhu <[email-masked]>
Date: Wed, 31 Jul 2002 12:20:44 -0700 (PDT)

Hi, Buchegger,

I will update the web page today and add those papers
into the list.

Thanks

Best,
Feng

---

From: feng zhu <[email-masked]>
Date: Wed, 31 Jul 2002 12:20:44 -0700 (PDT)

Hi, Buchegger,

Thanks

Best,
Feng