Subject: [manet] RE: Gateway Advertisements

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Fri, 19 Jul 2002 10:17:35 +0200

Hi again,

> -----Original Message-----
> From: Ryuji Wakikawa [mailto:[email-masked]]
> Sent: den 11 juli 2002 03:11
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: Gateway Advertisements
> 
> 
> 
> Hello again Fredrik and Thanks Anders.
> 
> At Tue, 9 Jul 2002 13:08:24 +0200 ,
> Fredrik Alriksson (EAB) wrote:
> > 
> > For the solution described in the draft, unsolicited gateway
> > advertisements are not neccessary for the correct operation of the
> > protocol.
> > 
> > [Fredrik Alriksson] I never questioned that. You state that "Sending
> > them (advertisements) periodically would generate unnecessary
> > packets in the Manet", but as I've said in previous emails _not_
> > sending them periodically may generate _more_ traffic in the Manet.
> 
> Can you elaborate what is the most reason for generating more traffic
> when GW does not flood advertisements.

The average hop count between the GW and the Manet node increases, since the probability that a Manet node will use a sub-optimal GW increases.
 
> > I see your point and I think that it is question of whether 
> a reactive or a more proactive approach
> > should be used. 
> > 
> > [Fredrik Alriksson] Perhaps a combination is preferable?
> 
> Does it depend on network topology? (a number of manet nodes, a number
> of GWs, size of manet) 

Yes, and how dynamic the topology. The activity within the Manet should also be considered.
 
> > 
> > One of the reasons for not recomending gateway advertisement
> > flooding is when you consider the scenario where some nodes might
> > need internet access, and some might not.
> > 
> > [Fredrik Alriksson] Well, the nodes which do not need internet
> > access may still benefit from the periodic floodings, since they
> > probably are involved in the communication between the gateways and
> > the manet nodes what do need internet access. Decreasing the total
> > number of packet transmissions does not only benefit the nodes that
> > need internet access!
> 
> We assume that base manet protocol supports next hop forwarding like
> AODV.  And if some base manet protocols do not support it (like DSR),
> we recommend to the use of routing header.
> 
> When a node sends packets to the Internet, a node put a GW address
> into a routing header.  During packet routing inside manet, the
> destination is the GW addressed in the routing header, therefore
> intermediate nodes routes packets to GW according to base manet
> operation.  The route is maintained by base manet protocol because GW
> can be seen as a normal manet node from the nodes which do not need
> Internet access. The route towards the GW is basically constructed
> when the node requests advertisements.
> 
> What I want to say here is that intermediate nodes just forward/route
> packets to the GW and this is the operations of general manet
> protocol. Intermediate nodes may create routes while some node set up
> global connectivity, but they are basically nothing to do with the
> operation of internet connectivity.

Then I think I didn't express myself clearly enough. My point is that using a 4-hop route between Manet node and GW1 consumes more resources in the Manet as a whole than using a 2-hop route between the same Manet node and GW2. Thus being able to select the closest gateway is a concern for all nodes in the Manet, including those that do not use internet connectivity.

> 
> > When flooding of advertisements is being used, packets are being
> > flooded periodicly over all nodes in the ad hoc network, regardsless
> > of their need for internet connectivity. This is where hop_limit
> > (TTL) considerations becomes important since every advertisement is
> > rebroadcasted as long as allowed by the hop_limit. So, what value
> > for this hop_limit should be used? If we choose a too small value we
> > might not reach all nodes, and choosing a high value will introduce
> > lots of traffic.
> > 
> > [Fredrik Alriksson] Can't a node that does not get the periodic
> > advertisments send solicitations?
> > 
> > 
> > Nodes that have no need for internet connectivity will also 
> receive and process this traffic, uneccessary.
> > 
> > [Fredrik Alriksson] Even though the advertisements are not
> > _necessary_ for the non-internet connected nodes, they may still
> > benefit from the periodic advertisments indirectly, since the total
> > number of packets that they have to forward (including both the
> > advertisements _and_ the user data) may decrease!
> 
> Sorry, I can not see your point in last sentence. 
> Why may the total number of packets decrease?

I think this should be clear from my comment above.

> > In the draft we instead propose that the node itself should initiate
> > this process, the gateway discovery process. In the case where there
> > are multiple gateways, the node should upon receiving these
> > advertisements choose the closest gateway.
> > 
> > [Fredrik Alriksson] Aren't we talking about _mobile_ ad hoc
> > networks? For how long will the chosen gateway remain the closest
> > gateway?
> 
> Yes, talking about manet  :-)

So, it is not enough to make the decision once, since the topology is dynamic.

BR,
Fredrik

> Best Regards,
> ryuji
> 
> 
> > regards,
> > 
> > Anders
> > 
> > 
> > [Fredrik Alriksson] BR, Fredrik
> > 
> >  
> > 
> > Fredrik Alriksson (EAB) wrote:
> > 
> > Hi Ryuji,
> > 
> > In what sense are the gateway advertisements unnecessary?
> > 
> > In case there are multiple gateways, the flooding of 
> gateway advertisements may actually _decrease_ the total 
> number of packet transmissions (control and user data 
> transmissions) in the MANET! 
> > 
> > Flooding gateway advertisements can enable manet nodes 
> which already have a global address to select a _closer_ 
> gateway. This means that the average distance between gateway 
> and manet node can be decreased. This in turn decreases the 
> number of packet transmissions required to deliver user data 
> between the gateways and the manet nodes. Depending on the 
> user activity, this reduction can be larger than the increase 
> in control packet transmissions. 
> > 
> > Other benefits are that the average user data delay 
> decreases, and that the manet nodes loose contact with their 
> gateway less frequently.
> > 
> > Regarding TTL, I don't see the problem, unless 
> advertisements were forwarded on non-manet 
> > interfaces. Can you please elaborate a bit?
> > 
> > BR,
> > Fredrik
> > 
> > 
> > 
> > -----Original Message-----
> > From: Ryuji Wakikawa [ mailto:[email-masked] 
> <mailto:[email-masked]> ]
> > Sent: den 8 juli 2002 18:40
> > To:  [email-masked] 
> <mailto:[email-masked]> 
> > Cc:  [email-masked] 
> <mailto:[email-masked]> ;  [email-masked] 
> <mailto:[email-masked]> ;
> > [email-masked] <mailto:[email-masked]> ;  
> [email-masked] <mailto:[email-masked]> ;  
> [email-masked] <mailto:[email-masked]> ;
> > [email-masked] <mailto:[email-masked]> 
> > Subject: Re: Gateway Advertisements
> > 
> > 
> > 
> > Hello Fred
> > rik.
> > 
> > In the draft, unnecessary packets basically indicates un-necessary
> > gateway advertisements. For example, if a gateway generates a route
> > advertisement every 1 sec, most of router advertisements 
> are redundant
> > for manet nodes which have already had a global address. They may
> > update lifetime of their global address, but the interval(1sec) is
> > still too short for this operations.
> > 
> > Since flooding packets is easy to cause performance damage in manet,
> > our approach tries to reduce a number of packets which are 
> > flooded over
> > manet. I think manet nodes should not wait flooded 
> advertisements from
> > gateway, instead manet node should discover gateways on their
> > initiative.
> > 
> > It is also difficult for gateways to decide TTL for flooded
> > advertisements. Expanding ring search technique can not be 
> applied to
> > this situation, because advertisements should reach at the edge of
> > manet. It can imagine that unnecessary network-wide dissemination of
> > advertisements will occur when a gateway sets larger TTL than manet
> > scale.
> > 
> > regards,
> > ryuji
> > 
> > 
> > At Mon, 8 Jul 2002 17:27:19 +0200 ,
> > Fredrik Alriksson (EAB) wrote:
> > 
> > 
> > Hi All,
> > 
> > In draft-wakikawa-manet-globalv6-00.txt you claim that 
> > 
> > sending gateway advertisements peridically would generate 
> > unnecessary packets in the Manet. Can you please explain how 
> > you came to that conclusion? Our simulation study on MIPMANET 
> > from '99 ( http://www.e.kth.se/~e94_fal/mipmanet.pdf 
<http://www.e.kth.se/~e94_fal/mipmanet.pdf> ) 
> indicates that it actually can decrease the number of packet 
> transmissions in the MANET.
> 
> BR,
> Fredrik
> 
> ---
> Fredrik Alriksson, Ericsson Research
> Email:  [email-masked] <mailto:[email-masked]> 
> 
> 
> 
> 
> 
> 
>  
> 
> [2  <text/html; iso-8859-1 (7bit)>]
> 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Guillaume Chelius <[email-masked]>
Date: Mon, 22 Jul 2002 10:51:27 +0200 (CEST)

Hello, 

I think discovering and selecting Gateway Nodes has something to do with the 
routing protocol used in the MANet. All the problems we have to deal with look
similar to the ones we have in routing: discovering the gateway (proactive or
reactive approach), construction of the route to the gateway (proactive or
rreq/rrep scheme), handling of mobility (reconstruction of route or selection of
a new gateway). This is something all routing protocols can already easily deal
with (or with minor modifications). It can be done by the addition of a
"Gateway" bit in C messages of OLSR TC packets, by the definition of an "All
Gateways" address to use with rreq in DSR or AODV... It is often a work that has
already be done.

Moreover, the question whether Gateways should advertise themselves or only
respond to requests is similar to the question whether routing protocols must be
reactive or procactive. Arguments are also similar: if the network is stable,
Gateway advertisments induce unnecessary load; if it is unstable, gateway
advertisments are interesting... It seems to me everybody has accepted that, in
some cases, proactive schemes are sometimes better than reactive ones, and in
other cases, the opposite is true. 

My opinion is that we should not split the gateway advertisement mechanism from
the routing protocol. It is the protocol responsability to propose a mechanism
which allows a node to discover gateways and to manage routes between nodes to
gateways.

Regards, 
Guillaume Chelius.

-----------------
Guillaume Chelius
PhD student
Ares Team, Inria, Citi Insa-Lyon
Tel: (+33) 472 436 421
Email: [email-masked]

---

From: Guillaume Chelius <[email-masked]>
Date: Mon, 22 Jul 2002 10:51:27 +0200 (CEST)

Hello, 

Regards, 
Guillaume Chelius.

-----------------
Guillaume Chelius
PhD student

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 22 Jul 2002 07:04:12 -0700

Hello Guillaume,

Guillaume Chelius wrote:

> routing protocol used in the MANet. .....

This is true, but it's a very broad statement.

>                                                           ... It is often a work
> that has

I assume that you meant, "even before draft-wakikawa-...".

But that just isn't true.  There were a lot of problems that had to
be solved.  Even some things that may look easy in hindsight
are not easy to figure out before the fact.

> reactive or procactive. ....

This is more than just social acceptance.  It has been shown more
than once, and it is intuitively obvious if you think about extreme cases
of traffic patterns.

> which allows a node to discover gateways and to manage routes between nodes to

What about using a Router Discovery protocol extension that is not specific
to any routing protocol?  There is no reason such an approach is wrong,
a priori, although your statement would disallow it from consideration.

Regards,
Charlie P.

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 22 Jul 2002 07:04:12 -0700

Hello Guillaume,

Regards,
Charlie P.

---

From: Guillaume Chelius <[email-masked]>
Date: Mon, 22 Jul 2002 16:43:46 +0200 (CEST)

Hello Charlie,

> > ... It is often a work that has already be done.
> 

Yes. I  mean that some ad hoc routing protocols already include mechanisms to
discover Internet gateways or to interconnect a non  ad hoc network to a MANet.

> are not easy to figure out before the fact.

I easily believe you.

> > respond to requests is similar to the question whether routing protocols
> > must be reactive or procactive. ....
> 
> than once, and it is intuitively obvious if you think about extreme
> cases of traffic patterns.

I agree.

> > My opinion is that we should not split the gateway advertisement
> > mechanism from the routing protocol. It is the protocol responsability to 
> > propose a mechanism which allows a node to discover gateways and to manage 
> > routes between nodes to gateways.
> 
> What about using a Router Discovery protocol extension that is not
> specific to any routing protocol?  There is no reason such an approach is
> wrong, a priori, although your statement would disallow it from
> consideration.

I'm ok to say it is not wrong. However, I think the definition of a Router
Discovery protocol should not prevent routing protocols to do Router Discovery
if it can at low cost. It means to me that the independant Router Discovery
protocol should not load the network if not needed or should not process if we
don't want it to (some kind of passive mode). 

I also think such a document is interesting only if it is not restrictive in the
way we use the protocol. A reative-only protocol is not satisfaying. As Fredrik
states it, unsolicited advertisements may be interestings for many reasons, e.g.
a better mobility support or global prefix advertisement.

Why not using some king of adaptation of the Router/Prefix  discovery protocol
of IPv6 NDP (Neighbor Discovery Protocol) to ad hoc netorks. 
Basically, Routers are free to advertise or not. Routers must respond to
solicitation. The protocol relies on ad hoc flooding. The maintenance of routes
btw nodes and GW  remains the routing protocol work. This lets enough freedom to
tune the protocol depending on what we want and on the MANet characteristics.

Regards, 
Guillaume.

-----------------
Guillaume Chelius
PhD student

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 22 Jul 2002 08:24:38 -0700

Hello Guillaume,

> don't want it to (some kind of passive mode).

It could also be configurable at the gateway.  I would consider
that "passive" means "reactive", and the question of "reactive"
vs. "proactive" has just been discussed.

> tune the protocol depending on what we want and on the MANet characteristics.

This sounds a lot like draft-wakikawa, except that the flooding happens
from the other way around.

I think the advantages of having default routes have been overlooked
in this discussion.  For one thing, it allows automatic switching to a
new gateway for many circumstances when a node moves closer to a
different gateway than it formerly was using.

Regards,
Charlie P.

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 22 Jul 2002 08:24:38 -0700

Hello Guillaume,

Regards,
Charlie P.

---

From: Guillaume Chelius <[email-masked]>
Date: Mon, 22 Jul 2002 16:43:46 +0200 (CEST)

Hello Charlie,

I easily believe you.

I agree.

Regards, 
Guillaume.

-----------------
Guillaume Chelius
PhD student

---

From: Ryuji Wakikawa<[email-masked]>
Date: Tue, 23 Jul 2002 00:26:48 +0900

Hi, Guillaume

> a better mobility support or global prefix advertisement.

We will revise the draft to support proactive protocols, too.

> of IPv6 NDP (Neighbor Discovery Protocol) to ad hoc netorks. 

Because we believe NDP does not work with current rfc2461 on current MANET!
What kinds of adaptation? At least we need some agreement for this 
adaptations, otherwise we never have interoperability among
implementations. 

regards,
ryuji

---

From: Ryuji Wakikawa<[email-masked]>
Date: Tue, 23 Jul 2002 00:26:48 +0900

Hi, Guillaume

regards,
ryuji

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 22 Jul 2002 09:15:05 -0700

Hello Guillaume,

Guillaume Chelius wrote:

> Please Correct me if I'm wrong, but one problem with default routes is that
> they are not necessary the same on all nodes of a path to a default route. It
> may lead to endless loops:
> + Node A has a default route to gateway X through node B
> + Node B has a default route to gateway Y through node C
> + Node C has a default route to gateway Z through node A
> I agree this case is critical but it may occur.

With AODV or DSR this should never occur.

> More frequently, It may also lead to false IP-spoofing detection:
> + Node A has a default route to gateway X which advertises prefix M through
> node B
> + Node B has a default route to gateway Z which advertises prefix N
> Packets sent from node A with a source global address Prefix_M:ID_A  will be
> routed to gateway Z instead of gateway X. But gateway Z will refuse the packet,
> considering it as IP spoofing since prefix M does not correspond to gateway Z

This seems to depend on the gateways having certain inappropriate
behavior for ad hoc networks.

> Of course, partial source routing correts these errors. But then, you loose the
> advantage you gave about default route.

We're not sure how to get maximum benefit from default routes
in this case.

> A proactive or hybrid scheme may be interesting to handle these cases.

Agreed, but it's hard to know exactly the realm of beneficial applicability.

Regards,
Charlie P.

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 22 Jul 2002 09:15:05 -0700

Hello Guillaume,

Regards,
Charlie P.

---

From: Guillaume Chelius <[email-masked]>
Date: Mon, 22 Jul 2002 18:51:15 +0200 (CEST)

Hello Charlie, 

> > Please Correct me if I'm wrong, but one problem with default routes is
> > that they are not necessary the same on all nodes of a path to a default
> > route. It may lead to endless loops:

I agree.

> > + Node A has a default route to gateway X which advertises prefix M
> > through node B
> > Packets sent from node A with a source global address Prefix_M:ID_A 
> > will be routed to gateway Z instead of gateway X. But gateway Z will refuse
> > the packet, considering it as IP spoofing since prefix M does not 
> > correspond to gateway Z
> 

I disagree on this point. There is no reason for an ad hoc network not to be 
connected to several "classical" networks. This is a normal situation and even 
something we may desire. In this case, Gateways  naturally advertise different 
prefixes. It is also legitimate for gateways to filter packets depending on the 
source address. You do not want your network to be the source for IP spoofing 
attacks, specially in ad hoc networks where you have not necessary an idea 
about who is connected to you. You can not also ask your gateway to accept 
addresses with other ad hoc advertised prefixes (not advertised by you). First, 
this set of prefixes change depending on the MANet connectivity. Second, it is 
a seurity hole since, for example, an ad hoc node may not be authorized to use 
the corresponding prefix.

In this situation, the false IP Spoofing detection I described may easily 
occur. 

> > Of course, partial source routing correts these errors. But then, you
> > loose the advantage you gave about default route.
> 

I agree and I think this is a good reason not to prohibit proactive or hybrid 
schemes. 

Regards,
Guillaume Chelius.

-----------------
Guillaume Chelius
PhD student

---

From: Guillaume Chelius <[email-masked]>
Date: Mon, 22 Jul 2002 18:51:15 +0200 (CEST)

Hello Charlie, 

I agree.

Regards,
Guillaume Chelius.

-----------------
Guillaume Chelius
PhD student

---

From: "Phil Neumiller" <[email-masked]>
Date: Mon, 22 Jul 2002 15:37:48 -0400

Hi,

This is a long thread, but I have burning questions with respect to bridging AODV
with OSPF.

The AODV draft 11 does not specifically say what a mobile router is to do with
ICMP Router Discovery messages.  Specifically, it does not address the ICMP
Router Advertisements or Router Solicitation messages that will be multicast
ICMP broadcasts as used by OSPF, BGP, etc.  Right?

I propose that as an ad hoc network node detects that its current default fixed
network routing connection is failing (a matter of debate in PILC, mobileip,
seamoby, etc), that it mcast a ICMP Router Solicatation.  Furthermore, I recommend
that this ICMP have its TTL value set to 5 (or any other configurable value) (and be
interpreted as a hop count) by AODV  nodes.  This will allow the Router
Solicitation to hit a piece of OSPF,  BGP4, EIGRP, ISIS, etc. infrastructure within
5 hops from the mobile.  I believe this simple procedure would allow OSPF to be 
bridged in a natural way with AODV.  I am thinking that OSPF infrastructure equipment
will need to keep a route for each mobile seperately, since the definition of a subnet
in a mobile IP enabled MANET is quite far from being useable.   The OSPF router
may maintain its default 7 to 10 minute advertisement rate and it will also use a TTL
of 5 that is interpreted by AODV to mean hop count.  Does this make sense?

Since RFC-1256 is routing protocol agnostic this should work to bridge BGP with
AODV, AODV with DSR, or any other routing protocol to any other right?

To me this makes more sense than trying to get multi-hop (tunnelled) OSPF wiretapping
working over AODV.

Thanks,

Phil

---

From: "Phil Neumiller" <[email-masked]>
Date: Mon, 22 Jul 2002 15:37:48 -0400

Hi,

Thanks,

Phil

---

From: Charlie Perkins <[email-masked]>
Date: Thu, 25 Jul 2002 14:01:31 -0700

Hello Phil,

> ICMP broadcasts as used by OSPF, BGP, etc.  Right?

Is a mobile router the thing that is under consideration within [nemo]?

> seamoby, etc), that it mcast a ICMP Router Solicatation.

What do you think about the proposal in Ryuji Wakikawa's draft?
It is specified how to find a default router.  Your suggestion is, indeed,
used within that draft.

Regards,
Charlie P.

---

From: Charlie Perkins <[email-masked]>
Date: Thu, 25 Jul 2002 14:01:31 -0700

Hello Phil,

Regards,
Charlie P.

---

From: "Phil Neumiller" <[email-masked]>
Date: Fri, 26 Jul 2002 08:54:22 -0400

Hi Charlie, Elizabeth, Yuan,

I have some comments on draft-royer-manet-globalv4-00.txt.  I did not
like some things about the draft so please be patient with my complaints.  :-)  
I have suggested a possible alternative approach that I believe is more "generic".

There seems to be a few different classes of things that use similar mechanisms to
Router Discovery as proposed in RFC 1256 (I am sticking with IPv4 in this letter).  

o Foreign Agent / Home Agent Advertisement uses RFC-1256 with extensions. 
o IGPs such as OSPF / EIGRP etc use RFC-1256 directly.
o Draft draft-royer-manet-globalv4-00.txt makes does not make direct use of RFC-1256.

A quote from draft-royer-manet-globalv4-00.txt states

    "Agent Advertisement messages initiated by foreign agents are re-broadcast
     by the nodes within the ad hoc network so that mobile nodes may learn of the
     presence of the FA".

1). This can only imply limited flooding, which should always be avoided if possible.

2).  The draft implies a change is needed for MIP FAs.  This does not seem like
      a good idea to me.  Furthermore, the suggested change only addresses AODV 
      not other MANET protocols.

3).  I believe a "clean use" of RFC 1256 is possible without any modification to 
      MIP.

4).  I believe the term access point should be avoided.  The industry trend for
      access points is towards dumb wireless to wireline bridges, i.e. 802.11b/a/g
      APs.  A more appropriate word might be fixed network /wireline router.

5).  The method also implies that AODV nodes are being proactive about 
       mobility agents and always putting a default route into to an FA when 
       they "hear" advertisements (or the flood occurs).

6).  It may be necessary to discover land-line IGP routers that are on the path 
      between the path of the AODV network and the FA/HA. 

7).  I believe its a very bad idea to force the MANET node to issue a RREQ
      to proactively discover a foreign agent.  A far more generic approach would
      be to use RFC-1256 directly.  That way all MANET protocols could use the
      same method (not just AODV).   The MANET nodes can proxy response
      Router/Agent solicitations over ICMP.

8).  The case where the MANET protocol does not support mulit-cast must be
      addressed in more detail.

9).  NETWORK_DIAMETER is not a stable number (I don't believe you can
       just set this to 10 and be happy).  In some cases this could completely swamp
       the ad hoc network.  An expanded ring search COULD work, but I like ICMP
       proxy responders much better (explained below).  

My proposal is to stick to RFC-1256.  Each MANET node (not just an AODV) node
will relay ICMP broadcasts and decrement the TTL field.  This provides the flood
limiting.  Furthermore, MANET nodes that have discovered a land line router OR a
mobility agent can proxy response for ICMP Router Solicitations.  This has the 
very same affect as does the RREQ (AODV specific) proposal.
   
BTW, the title of this draft is a bit presumptuous being called "manet-globalv4" since
it really advocates an AODV specific solution.  I think the technique can be more
generic if only ICMP messages are used.  Th

Best regards,

Phil

---

From: "Phil Neumiller" <[email-masked]>
Date: Fri, 26 Jul 2002 08:54:22 -0400

Best regards,

Phil

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 26 Jul 2002 17:02:51 -0700

Hello Phil,

I have just a few comments.  If you've been tuning in, you'll
remember that there are many different opinions on this subject.
I reckon that it largely depends on one's assumptions, and I am
hoping we can find a good generic solution for the widest
class of applications (still not universal).

> Router Discovery as proposed in RFC 1256 (I am sticking with IPv4 in this letter).

RFC 1256 has various restrictions that orient it towards working on
a "link" (e.g., TTL=1).  That's a problem, albeit one not hard to
overcome.

> o Draft draft-royer-manet-globalv4-00.txt makes does not make direct use of RFC-1256.

Whether to model the advertisements as RFC-1256 or something else
is a matter of taste, not protocol correctness.  Plus, my own
experience with Mobile IP is that using RFC 1256 was a mistake.

> 1). This can only imply limited flooding, which should always be avoided if possible.

So you're saying no flooding?  Others say flooding is the "only answer".

>       not other MANET protocols.

I agree that other protocols should be addressed also.  This draft,
I think we can agree, needs further development.

Furthermore, I think that any such Internet Gateway node, as a
foreign agent would be here, needs to obey the routing protocol
in use in the ad hoc network.

> 3).  I believe a "clean use" of RFC 1256 is possible without any modification to

MIP already modifies RFC 1256.  I'm not clear where you're heading on this.

>       APs.  A more appropriate word might be fixed network /wireline router.

How about "access router", or "Internet Gateway"?

>        they "hear" advertisements (or the flood occurs).

Sentiment so far is that accessibility to the Internet is more
special than accessibility to random ad-hoc nodes.

>       between the path of the AODV network and the FA/HA.

Running co-located, the only thing that is important is to get
the prefix advertisement from the Internet Gateway.  If you're
gateway is a foreign agent, then the mobile node has more options.
Any [manet] draft for IPv4 connectivity ought not to be restrictive
on this point.

>       Router/Agent solicitations over ICMP.

As long as you "fix" RFC 1256, O.K.  And then there is the discussion
about proactive vs. reactive.  But I think that it's strange to describe
an "on-demand" discovery operation as "proactive".

I definitely agree that we should try to find something that works
for all [manet] protocols.

>       addressed in more detail.

Let me pass on this one for now, while merely noting that I would
like to see additional multicast work for mobile ad hoc networks.

>        proxy responders much better (explained below).

I thought it should be used for timing purposes, and selected
to be stable (i.e., "too-large").

> very same affect as does the RREQ (AODV specific) proposal.

Fine with me!

> generic if only ICMP messages are used.  Th

Perhaps instead of "presumptuous", one should say "optimistic".
A little optimism never hurts, especially if it's backed up by
good intentions and hard work.

Regards,
Charlie P.

PS. I did not specifically discuss items within the Wakikawa draft here.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 26 Jul 2002 17:02:51 -0700

Hello Phil,

Fine with me!

Regards,
Charlie P.

---

From: "Phil Neumiller" <[email-masked]>
Date: Mon, 29 Jul 2002 16:24:30 -0400

Until it is possible to fix the ICMP TTL=1 we could interpret as "-1" and 
increment the TTL when a MANET node.  This would be a short term hack
until the MIP extension of ICMP Router Discovery allows a > 1 TTL value.

I don't see any other way to solicit a router or an agent over multiple hops
with the ICMP mechanism (NOTE:  the floods can be avoided by allowing
for Router/Agent discovery proxies to respond within some timeout period).

---

From: "Phil Neumiller" <[email-masked]>
Date: Mon, 29 Jul 2002 16:24:30 -0400