Subject: [manet] Gateway Advertisements

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Fri, 19 Jul 2002 10:15:57 +0200

Hi All,

In draft-wakikawa-manet-globalv6-00.txt you claim that sending gateway advertisements peridically would generate unnecessary packets in the Manet. Can you please explain how you came to that conclusion? Our simulation study on MIPMANET from '99 (http://www.e.kth.se/~e94_fal/mipmanet.pdf) indicates that it actually can decrease the number of packet transmissions in the MANET.

BR,
Fredrik

---
Fredrik Alriksson, Ericsson Research
Email: [email-masked]

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Fri, 19 Jul 2002 10:17:14 +0200

Hi Ryuji,

> -----Original Message-----
> From: Ryuji Wakikawa [mailto:[email-masked]]
> Sent: den 11 juli 2002 02:38
> To: [email-masked]
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: [manet] Re: Gateway Advertisements
> 
> 
> 
> Hello Fredrik
> 
> I am catching up now, but let me reply to this first.
> 
> At Tue, 9 Jul 2002 09:46:15 +0200 ,
> Fredrik Alriksson (EAB) wrote:
> > 
> > Hi Ryuji,
> > 
> > In what sense are the gateway advertisements unnecessary?
> 
> I did not say all RAs which are periodically advertising are
> un-necessary.  If gateway advertise RAs periodically, some of RAs are 
> not processed by any nodes. And these RAs are flooded over manet
> network untill TTL is expired.

But you can't know which of the advertisements that are "unnecessary" beforehand. I would say that sending the periodic advertisements too frequently creates unnecessary overhead, and that the problem is to define an "optimal" period. This is not at all the same as to say that periodic advertisements SHOULD NOT be used at all!

> 
> 
> > In case there are multiple gateways, the flooding of gateway
> > advertisements may actually _decrease_ the total number of packet
> > transmissions (control and user data transmissions) in the MANET!
> > 
> > Flooding gateway advertisements can enable manet nodes which already
> > have a global address to select a _closer_ gateway. This means that
> > the average distance between gateway and manet node can be
> > decreased. This in turn decreases the number of packet transmissions
> > required to deliver user data between the gateways and the manet
> > nodes. Depending on the user activity, this reduction can be larger
> > than the increase in control packet transmissions.
> >
> > Other benefits are that the average user data delay decreases, and
> > that the manet nodes loose contact with their gateway less
> > frequently.
> 
> The draft said that once manet node gets global info from a GW, it can
> update the info by unicasting request message to the GW. 
> Manet node may change
> the GW to closer one any time by re-selecting an appropriate GW from
> the node's GW lists or by re-flooding requests to discover closer
> depending on some events like topology change.  
> GW lists is node introduced in the draft, but let's say it is the
> lists of GWs which are replyig to node's gateway discovery.

For how long is the metrics about the GWs in the GW list valid (e.g. hop count)? 
How does the Manet node know when to re-flood the request?
How large fraction of all relevant topology changes will the Manet node detect?

My conclusion is still: it is better to let the GW flood periodically.

> 
> In appendix A, we explain how to use the most appropriate GW with a
> routing header. I think the draft can be adapted to your above
> situation. What do you think?
> 
> --Snip from the drat
>    Using a routing header is also preferable if there are 
> more than two
> Internet-gateways, because the node then have the ability to decide
> which Internet-gateway is the best, by distance in hops, or by some
> other priority.  By assign a priority number for each 
> Internet-gateway,
> the route reply message and the Manet Router Advertisement messages
> could be extended to support a candidate Internet-gateway 
> option in it.
> -----

I'm sorry, I don't really follow you here. In what sense is the text you refer to about sending advertisements periodically or not?

> I think we should clarify much more about situations when multiple GWs
> are located.
> 
> # Can you explain more about simulated unicast situation.  Can a manet
>   node receive RA from only associated GW? Didn't you use solicited
>   request from the manet node? If not, GW will discover the manet node
>   route, when it sends RA to the node and can not find fresh route for
>   the node. 

I think you have a good point here; we did use RA's but perhaps not optimally.

> This does not happen to our solution.

Well, it does if the Manet node unicasts the solicitation, which use list as one alternative if I understand the draft correct.

Furthermore, if using flooding, how often should Manet nodes flood the solicitations?
 
> > Regarding TTL, I don't see the problem, unless advertisements were
> > forwarded on non-manet interfaces. Can you please elaborate a bit?
> 
> In your thesis, you mentioned "Limited TTL". This is almost what I
> want to explain here. If there is a single GW in manet, RA should be
> flooded over whole manet. You can not use optimization like expanding
> ring search for flooding. If Manet nodes can not get RAs sent with
> limited TTL by GW, it has to discover GW by solicited requests.

Sure, but is that really a problem?

BR,
Fredrik

> best regards,
> ryuji
> 
> > BR,
> > Fredrik
> > 
> > > -----Original Message-----
> > > From: Ryuji Wakikawa [mailto:[email-masked]]
> > > Sent: den 8 juli 2002 18:40
> > > To: [email-masked]
> > > Cc: [email-masked]; [email-masked];
> > > [email-masked]; [email-masked]; 
> [email-masked];
> > > [email-masked]
> > > Subject: Re: Gateway Advertisements
> > > 
> > > 
> > > 
> > > Hello Fredrik.
> > > 
> > > In the draft, unnecessary packets basically indicates un-necessary
> > > gateway advertisements. For example, if a gateway 
> generates a route
> > > advertisement every 1 sec, most of router advertisements 
> are redundant
> > > for manet nodes which have already had a global address. They may
> > > update lifetime of their global address, but the interval(1sec) is
> > > still too short for this operations.
> > > 
> > > Since flooding packets is easy to cause performance 
> damage in manet,
> > > our approach tries to reduce a number of packets which are 
> > > flooded over
> > > manet. I think manet nodes should not wait flooded 
> advertisements from
> > > gateway, instead manet node should discover gateways on their
> > > initiative.
> > > 
> > > It is also difficult for gateways to decide TTL for flooded
> > > advertisements. Expanding ring search technique can not 
> be applied to
> > > this situation, because advertisements should reach at the edge of
> > > manet. It can imagine that unnecessary network-wide 
> dissemination of
> > > advertisements will occur when a gateway sets larger TTL 
> than manet
> > > scale.
> > > 
> > > regards,
> > > ryuji
> > > 
> > > 
> > > At Mon, 8 Jul 2002 17:27:19 +0200 ,
> > > Fredrik Alriksson (EAB) wrote:
> > > > 
> > > > Hi All,
> > > > 
> > > > In draft-wakikawa-manet-globalv6-00.txt you claim that 
> > > sending gateway advertisements peridically would generate 
> > > unnecessary packets in the Manet. Can you please explain how 
> > > you came to that conclusion? Our simulation study on MIPMANET 
> > > from '99 (http://www.e.kth.se/~e94_fal/mipmanet.pdf) 
> > > indicates that it actually can decrease the number of packet 
> > > transmissions in the MANET.
> > > > 
> > > > BR,
> > > > Fredrik
> > > > 
> > > > ---

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Fri, 19 Jul 2002 10:17:14 +0200

Hi Ryuji,

 

BR,
Fredrik

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Fri, 19 Jul 2002 10:16:28 +0200

Hi Ryuji,

In case there are multiple gateways, the flooding of gateway advertisements may actually _decrease_ the total number of packet transmissions (control and user data transmissions) in the MANET! 

Flooding gateway advertisements can enable manet nodes which already have a global address to select a _closer_ gateway. This means that the average distance between gateway and manet node can be decreased. This in turn decreases the number of packet transmissions required to deliver user data between the gateways and the manet nodes. Depending on the user activity, this reduction can be larger than the increase in control packet transmissions. 

Other benefits are that the average user data delay decreases, and that the manet nodes loose contact with their gateway less frequently.

Regarding TTL, I don't see the problem, unless advertisements were forwarded on non-manet interfaces. Can you please elaborate a bit?

BR,
Fredrik

> gateway advertisements. For example, if a gateway generates a route
> advertisement every 1 sec, most of router advertisements are redundant
> Since flooding packets is easy to cause performance damage in manet,
> manet. I think manet nodes should not wait flooded advertisements from
> advertisements. Expanding ring search technique can not be applied to
> manet. It can imagine that unnecessary network-wide dissemination of
> advertisements will occur when a gateway sets larger TTL than manet
> scale.
> 
> regards,
> ryuji
> 
>

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Fri, 19 Jul 2002 10:16:28 +0200

Hi Ryuji,

BR,
Fredrik

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Fri, 19 Jul 2002 10:16:46 +0200

Hi Anders,
 
See comments inline.

-----Original Message-----
From: Anders Nilsson [mailto:[email-masked]]
Sent: den 9 juli 2002 11:29
To: Fredrik Alriksson (EAB); MANET mailing list
Cc: Ryuji Wakikawa
Subject: Re: Gateway Advertisements

Hello Fredrik!

For the solution described in the draft, unsolicited gateway advertisments are not neccessary
for the correct operation of the protocol.

[Fredrik Alriksson]  I never questioned that. You state that "Sending them (advertisements) periodically would generate unnecessary packets in the Manet", but as I've said in previous emails _not_ sending them periodically may generate _more_ traffic in the Manet.

I see your point and I think that it is question of whether a reactive or a more proactive approach
should be used. 

[Fredrik Alriksson] Perhaps a combination is preferable?

One of the reasons for not recomending gateway advertisement flooding is when you consider the scenario where some nodes might need internet access, and some might not.

[Fredrik Alriksson] Well, the nodes which do not need internet access may still benefit from the periodic floodings, since they probably are involved in the communication between the gateways and the manet nodes what do need internet access. Decreasing the total number of packet transmissions does not only benefit the nodes that need internet access!

When flooding of advertisements is being used,  packets are being flooded periodicly over all
nodes in the ad hoc network, regardsless of their need for internet connectivity. This is where hop_limit (TTL) considerations becomes important since every advertisement is rebroadcasted
as long as allowed by the hop_limit. So, what value for this hop_limit should be used? If we choose
a too small value we might not reach all nodes, and choosing a high value will introduce lots of traffic. 

[Fredrik Alriksson]  Can't a node that does not get the periodic advertisments send solicitations?

Nodes that have no need for internet connectivity will also receive and process this traffic, uneccessary.

[Fredrik Alriksson]  Even though the advertisements are not _necessary_ for the non-internet connected nodes, they may still benefit from the periodic advertisments indirectly, since the total number of packets that they have to forward (including both the advertisements _and_ the user data) may decrease!

In the draft we instead propose that the node itself should initiate this process, the gateway discovery process. In the case where there are multiple gateways, the node should upon receiving these advertisements choose the closest gateway.

[Fredrik Alriksson] Aren't we talking about _mobile_ ad hoc networks? For how long will the chosen gateway remain the closest gateway? 

regards,

Anders

[Fredrik Alriksson] BR, Fredrik

Hi Ryuji,

Regarding TTL, I don't see the problem, unless advertisements were forwarded on non-manet 
interfaces. Can you please elaborate a bit?

BR,
Fredrik

-----Original Message-----
From: Ryuji Wakikawa [ mailto:[email-masked] <mailto:[email-masked]> ]
Sent: den 8 juli 2002 18:40
To:  [email-masked] <mailto:[email-masked]> 
Cc:  [email-masked] <mailto:[email-masked]> ;  [email-masked] <mailto:[email-masked]> ;
[email-masked] <mailto:[email-masked]> ;  [email-masked] <mailto:[email-masked]> ;  [email-masked] <mailto:[email-masked]> ;
[email-masked] <mailto:[email-masked]> 
Subject: Re: Gateway Advertisements

Hello Fred
rik.

regards,
ryuji

Hi All,

from '99 ( http://www.e.kth.se/~e94_fal/mipmanet.pdf <http://www.e.kth.se/~e94_fal/mipmanet.pdf> ) 

BR,
Fredrik

---
Fredrik Alriksson, Ericsson Research
Email:  [email-masked] <mailto:[email-masked]>

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Fri, 19 Jul 2002 10:16:46 +0200

Hi Anders,
 
See comments inline.

-----Original Message-----
From: Anders Nilsson [mailto:[email-masked]]
Sent: den 9 juli 2002 11:29
To: Fredrik Alriksson (EAB); MANET mailing list
Cc: Ryuji Wakikawa
Subject: Re: Gateway Advertisements

Hello Fredrik!

regards,

Anders

Hi Ryuji,

BR,
Fredrik

-----Original Message-----
From: Ryuji Wakikawa [ mailto:[email-masked] <mailto:[email-masked]> ]
Sent: den 8 juli 2002 18:40
To:  [email-masked] <mailto:[email-masked]> 
Cc:  [email-masked] <mailto:[email-masked]> ;  [email-masked] <mailto:[email-masked]> ;

Hello Fred
rik.

regards,
ryuji

Hi All,

BR,
Fredrik

---

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Fri, 19 Jul 2002 10:20:31 +0200

Hi Charlie,

> This answer is the same as for the metric field in any other
> AODV destination route.  Due to route repairs, the metric
> may not represent the actual hop count to a destination,
> and yet the destination remains reachable.

Well, the question should be viewed in conjunction with Ryuji's(?) statement:
"Manet node may change the GW to closer one any time by re-selecting an appropriate GW from the node's GW lists or by re-flooding requests"

I suspect that selecting a _closer_ GW by just looking into the GW list, without updating the GW list, will only be a good strategy for a limited period of time. 

> When the manet node needs a route to a node in the Internet,
> and it does not have a default route, it will re-flood
> the request.  Is this your concern?

My concern is that a Manet node that is communicating via a GW will stick to this GW even if better GW's become available in the Manet. Someone commented that the Manet node can re-flood requests whenever they want to find better GWs; in response to that I wonder how the Manet node can know that there is a better GW available and that it thus should re-flood a request. The answer is of course that in many cases it cannot know. 

> The best case would be for it to detect _none_ of the topology
> changes, and yet retain routability to all of its communication
> partners.

Even if the total traffic load, mean delay, etc. are higher?

> I think the argument for periodic advertisement is the same
> as for any other manet-wide advertisement.  The decision about
> whether to go for periodic vs. reactive depends on traffic
> patterns in either case.

Sorry, the above statement was a slip from my side. However, I cannot conclude that periodic advertisements SHOULD NOT be used...

Regarding traffic patterns: I suspect that the traffic patterns will be quite different in an Internet connected Manet than in a standalone Manet (which is the most common scenario in previous simulation studies).

BR,
Fredrik

> Regards,
> Charlie P.

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Fri, 19 Jul 2002 10:20:31 +0200

Hi Charlie,

BR,
Fredrik

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Fri, 19 Jul 2002 10:20:16 +0200

Hi again Anders,

-----Original Message-----
From: Anders Nilsson [mailto:[email-masked]]
Sent: den 11 juli 2002 16:30
To: Fredrik Alriksson (EAB)
Cc: MANET mailing list; Ryuji Wakikawa
Subject: Re: [manet] Re: Gateway Advertisements

Hello Fredrik!

You are absolutely right. This is always what you should try to optimize when you have an proactive approach , like yours. Our approach is more reactive. So for the real question; is a proactive, a reactive or a hybrid
solution the best one? I think the answer depends on several factors, such as network size, mobility
rate, traffic load, but also on battery life, routing protocol, security etc. I think I can agree on that your proposal is better in some situations and scenarios, but that our solution is better in some. I think that these are questions that needs to be more thoroughly simulated. 

[Fredrik Alriksson]  Then I think we agree; I originally started this thread since you in the draft claim that a proactive approach SHOULD NOT be used, but now you say that it depends and that we don't really know. Will that be reflected in the draft as well?

Are you absolutely sure that this will be the optimal solution in all situations?

[Fredrik Alriksson] No, not in all situations. Isn't that a general 'feature' with MANETs, no single solution will ever be optimal for all MANETs ;-)

--Snip from the drat

He describes how the gateway selection process can be implemented. 

[Fredrik Alriksson] ...which is somewhat independent from how the advertisements are distributed...right?

... needs more testing... 

[Fredrik Alriksson] The reason for asking is this: assume a MANET with 2 GWs and 10 manet nodes using these 2 GWs for Internet access. What is the overhead with proactive vs. reactive? Assuming that the periodicity is the same: reactive: 10 floodings, proactive: 2 floodings. 

No, and I think that it could be a good hybrid solution.

[Fredrik Alriksson] Agreed.

[and in your previous mail:] Can you elaborate what is the most reason for generating more traffic

> when GW does not flood advertisements.

>The average hop count between the GW and the Manet node increases, 
>since the probability that a Manet node will use a sub-optimal 
> GW increases.

>Then I think I didn't express myself clearly enough. My point is 
>that using a 4-hop route between Manet node and GW1 consumes more 
>resources in the Manet as a whole than using a 2-hop route between the 
>same Manet node and GW2. Thus being able to select the closest gateway 
>is a concern for all nodes in the Manet, including those that do not 
>use internet connectivity.
But minimizing the hop count is, of course, also the purpose of our solution. The question is whether it really
does differ in average hop, or whether it really is more costful. Flooding could be very costful for battery sensitive devices. As for choosing the closest gateway, this should always be the ambition. The node could either rerequest gateway information, or maybe we could piggyback this information somewhere, in case a "handover"is needed.

[Fredrik Alriksson] The question with a reactive approach is how to detect that a reaction is needed. Could you please describe that again?
 
BR,
Fredrik

best regards,

Anders

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Fri, 19 Jul 2002 10:20:16 +0200

Hi again Anders,

-----Original Message-----
From: Anders Nilsson [mailto:[email-masked]]
Sent: den 11 juli 2002 16:30
To: Fredrik Alriksson (EAB)
Cc: MANET mailing list; Ryuji Wakikawa
Subject: Re: [manet] Re: Gateway Advertisements

Hello Fredrik!

--Snip from the drat

 
BR,
Fredrik

best regards,

Anders

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Fri, 19 Jul 2002 10:20:59 +0200

Hello,

> By the way, will you come IETF Yokohama in next week?

No, unfortunately not.

> > [Fredrik Alriksson] The reason for asking is this: assume a MANET
> > with 2 GWs and 10 manet nodes using these 2 GWs for Internet
> > access. What is the overhead with proactive vs. reactive? Assuming
> > that the periodicity is the same: reactive: 10 floodings, proactive:
> > 2 floodings.
> > 
> 
> I do not know if this example is good enough, because we can get
> another results depending on topology changes, measurements periods:-)
> 
> After first discovery, reactive stop flooding and start 
> unicasting instead.
> So the result will change after first discovery.
> For 10 sec: reactive: 0 floodings, proactive 10 floodings.
> Well this is best case for reactive, another result can be 
> expected, of
> course!

I agree; another example is of course the scenario we used in our thesis.

> > But minimizing the hop count is, of course, also the 
> purpose of our solution. The question is whether it really
> > does differ in average hop, or whether it really is more 
> costful. Flooding could be very costful for battery sensitive 
> devices. As for choosing the closest gateway, this should 
> always be the ambition. The node could either rerequest 
> gateway information, or maybe we could piggyback this 
> information somewhere, in case a "handover"is needed.
> > 
> > 
> > [Fredrik Alriksson] The question with a reactive approach is how to
> > detect that a reaction is needed. Could you please describe that
> > again?
> 
> Actually, the use of multiple GW is not considered enough yet, we just
> mention our rough idea in the draft.  So I don't know if I have good
> answer for this.

Ok, I see. Saving the best for last, are we ;-)

BR,
Fredrik

> regards,
> ryuji
> 
> > BR,
> > Fredrik
> > 
> >  
> > 
> > best regards,
> > 
> > Anders 
> > 
> > 
> > 
> > 
> > 
> > 
> > [2  <text/html; iso-8859-1 (quoted-printable)>]
> > 
>

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Fri, 19 Jul 2002 10:20:46 +0200

Hi Ryuji,

> Manet node does not keep a hop count which is known by 
> advertisements from GW.
> Hop count is alway updated during maintenance of the route 
> path to GW by a manet protocol.
> But if the route is expired, manet node have to discover the 
> route again.

But only the hop count to the GW that the Manet node currently is using is updated, right? If the metric of that route is changed, what is then the probability that the older metrics for the other GW in the GW list are correct? 
 
> We haven't specified yet. maybe when hop count change, movements
> detection, receiving RERR.

I suspect that there are many situations where better GWs become available without the Manet node being able to detect it.

> It depends on a base manet protocol. For example, the manet 
> node may not
> know the changes since AODV has local repair functions.

Note that the relevant topology changes are not limited to those that concern the active route to the currently selected gateway, but include topology changes that affect the distance to all the GWs in the Manet. Even if there were no local repair functions, the node would still not detect all relevant topology changes.

> > Well, it does if the Manet node unicasts the solicitation, which use
> > list as one alternative if I understand the draft correct.
> 
> You are right.
> But this happens once. not periodically. 

Doesn't the node have to do this every GWINFO_REFRESH (= 8 sec)? 

BR,
Fredrik

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Fri, 19 Jul 2002 10:20:46 +0200

Hi Ryuji,

 

BR,
Fredrik

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Fri, 19 Jul 2002 10:17:35 +0200

Hi again,

> Sent: den 11 juli 2002 03:11
> Cc: [email-masked]; [email-masked]; [email-masked]
> Hello again Fredrik and Thanks Anders.
> 
> At Tue, 9 Jul 2002 13:08:24 +0200 ,
> > For the solution described in the draft, unsolicited gateway
> > advertisements are not neccessary for the correct operation of the
> > protocol.
> > 
> > [Fredrik Alriksson] I never questioned that. You state that "Sending
> > them (advertisements) periodically would generate unnecessary
> > packets in the Manet", but as I've said in previous emails _not_
> > sending them periodically may generate _more_ traffic in the Manet.
> 
> Can you elaborate what is the most reason for generating more traffic

The average hop count between the GW and the Manet node increases, since the probability that a Manet node will use a sub-optimal GW increases.
 
> Does it depend on network topology? (a number of manet nodes, a number
> of GWs, size of manet) 

Yes, and how dynamic the topology. The activity within the Manet should also be considered.
 
> > 
> > One of the reasons for not recomending gateway advertisement
> > flooding is when you consider the scenario where some nodes might
> > need internet access, and some might not.
> > 
> > [Fredrik Alriksson] Well, the nodes which do not need internet
> > access may still benefit from the periodic floodings, since they
> > probably are involved in the communication between the gateways and
> > the manet nodes what do need internet access. Decreasing the total
> > number of packet transmissions does not only benefit the nodes that
> > need internet access!
> 
> We assume that base manet protocol supports next hop forwarding like
> AODV.  And if some base manet protocols do not support it (like DSR),
> we recommend to the use of routing header.
> 
> When a node sends packets to the Internet, a node put a GW address
> into a routing header.  During packet routing inside manet, the
> destination is the GW addressed in the routing header, therefore
> intermediate nodes routes packets to GW according to base manet
> operation.  The route is maintained by base manet protocol because GW
> can be seen as a normal manet node from the nodes which do not need
> Internet access. The route towards the GW is basically constructed
> when the node requests advertisements.
> 
> What I want to say here is that intermediate nodes just forward/route
> packets to the GW and this is the operations of general manet
> protocol. Intermediate nodes may create routes while some node set up
> global connectivity, but they are basically nothing to do with the
> operation of internet connectivity.

Then I think I didn't express myself clearly enough. My point is that using a 4-hop route between Manet node and GW1 consumes more resources in the Manet as a whole than using a 2-hop route between the same Manet node and GW2. Thus being able to select the closest gateway is a concern for all nodes in the Manet, including those that do not use internet connectivity.

> 
> > When flooding of advertisements is being used, packets are being
> > flooded periodicly over all nodes in the ad hoc network, regardsless
> > of their need for internet connectivity. This is where hop_limit
> > (TTL) considerations becomes important since every advertisement is
> > rebroadcasted as long as allowed by the hop_limit. So, what value
> > for this hop_limit should be used? If we choose a too small value we
> > might not reach all nodes, and choosing a high value will introduce
> > lots of traffic.
> > 
> > Nodes that have no need for internet connectivity will also 
> receive and process this traffic, uneccessary.
> > 
> > [Fredrik Alriksson] Even though the advertisements are not
> > _necessary_ for the non-internet connected nodes, they may still
> > benefit from the periodic advertisments indirectly, since the total
> > number of packets that they have to forward (including both the
> > advertisements _and_ the user data) may decrease!
> 
> Sorry, I can not see your point in last sentence. 
> Why may the total number of packets decrease?

I think this should be clear from my comment above.

> > In the draft we instead propose that the node itself should initiate
> > this process, the gateway discovery process. In the case where there
> > are multiple gateways, the node should upon receiving these
> > advertisements choose the closest gateway.
> > 
> > [Fredrik Alriksson] Aren't we talking about _mobile_ ad hoc
> > networks? For how long will the chosen gateway remain the closest
> > gateway?
> 
> Yes, talking about manet  :-)

So, it is not enough to make the decision once, since the topology is dynamic.

BR,
Fredrik

> Best Regards,
> > In case there are multiple gateways, the flooding of 
> gateway advertisements may actually _decrease_ the total 
> number of packet transmissions (control and user data 
> transmissions) in the MANET! 
> > 
> > Flooding gateway advertisements can enable manet nodes 
> which already have a global address to select a _closer_ 
> gateway. This means that the average distance between gateway 
> and manet node can be decreased. This in turn decreases the 
> number of packet transmissions required to deliver user data 
> between the gateways and the manet nodes. Depending on the 
> user activity, this reduction can be larger than the increase 
> in control packet transmissions. 
> > 
> > Other benefits are that the average user data delay 
> decreases, and that the manet nodes loose contact with their 
> gateway less frequently.
> > 
> > Regarding TTL, I don't see the problem, unless 
> advertisements were forwarded on non-manet 
> <mailto:[email-masked]> 
> > Cc:  [email-masked] 
> <mailto:[email-masked]> ;  [email-masked] 
> <mailto:[email-masked]> ;
> > [email-masked] <mailto:[email-masked]> ;  
> [email-masked] <mailto:[email-masked]> ;  
> [email-masked] <mailto:[email-masked]> ;
> > from '99 ( http://www.e.kth.se/~e94_fal/mipmanet.pdf 
<http://www.e.kth.se/~e94_fal/mipmanet.pdf> ) 
> [2  <text/html; iso-8859-1 (7bit)>]
>

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Fri, 19 Jul 2002 10:20:59 +0200

Hello,

No, unfortunately not.

BR,
Fredrik

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Mon, 22 Jul 2002 13:35:34 +0200

Hi Guillaume,

> I think discovering and selecting Gateway Nodes has something 
> to do with the 
> routing protocol used in the MANet. All the problems we have 
> to deal with look
> similar to the ones we have in routing: discovering the 
> gateway (proactive or
> reactive approach), construction of the route to the gateway 
> (proactive or
> rreq/rrep scheme), handling of mobility (reconstruction of 
> route or selection of
> a new gateway). This is something all routing protocols can 
> already easily deal
> with (or with minor modifications). It can be done by the 
> addition of a
> "Gateway" bit in C messages of OLSR TC packets, by the 
> definition of an "All
> Gateways" address to use with rreq in DSR or AODV... It is 
> often a work that has
> already be done.

Sure, it _can_ be done that way.

> Moreover, the question whether Gateways should advertise 
> themselves or only
> respond to requests is similar to the question whether 
> routing protocols must be
> reactive or procactive. Arguments are also similar: if the 
> network is stable,
> Gateway advertisments induce unnecessary load; if it is 
> unstable, gateway
> advertisments are interesting... 

The question is similar, but the nature of the communication between mobile and GW is quite different than that of communication between two mobile nodes, so conclusions drawn from mobile-to-mobile scenarios are not automatically valid for mobile-GW scenarios.

> It seems to me everybody has 
> accepted that, in
> some cases, proactive schemes are sometimes better than 
> reactive ones, and in
> other cases, the opposite is true. 

Well, draft-wakikawa-manet-globalv6-00.txt says that a proactive scheme SHOULD NOT be used, and I haven't seen any comments about that previously, so my impression was that everybody had "accepted" that a reactive approach is better in _most_ cases.
 
> My opinion is that we should not split the gateway 
> advertisement mechanism from
> the routing protocol. It is the protocol responsability to 
> propose a mechanism
> which allows a node to discover gateways and to manage routes 
> between nodes to
> gateways.

So, you don't see any need for e.g. draft-wakikawa-manet-globalv6-00.txt?

BR,
Fredrik

> Regards, 
> Guillaume Chelius.
> 
> -----------------
> Guillaume Chelius
> PhD student
> Ares Team, Inria, Citi Insa-Lyon
> Tel: (+33) 472 436 421
> Email: [email-masked]
>

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Mon, 22 Jul 2002 15:09:01 +0200

Hi again,

> > The question is similar, but the nature of the communication between
> > mobile and GW is quite different than that of communication 
> between two
> > mobile nodes, so conclusions drawn from mobile-to-mobile 
> scenarios are
> > not automatically valid for mobile-GW scenarios.
> 
> They are not so different to me.

So, the gateway is just like any other node in the network? The route to the gateway is used about as much as any other route in the network? The chance that some other node also wants a route to the gateway is the same as the chance that some other node also wants a route to a specific mobile node?

> > Well, draft-wakikawa-manet-globalv6-00.txt says that a 
> proactive scheme
> > SHOULD NOT be used, and I haven't seen any comments about that
> > previously, so my impression was that everybody had 
> "accepted" that a
> > reactive approach is better in _most_ cases.
> 
> I don't think everybody has accepted it, at least you and I 
> haven't. Many other
> schemes have to be studied. Hybrid protocols for example. GW may flood
> advertisements with a low TTL and support a 
> solicitation/advertisment protocol
> as well. Nodes receiving unsolicited advertisements will be 
> able to select the
> closest GW and nodes not receiving any unsolicited 
> advertisement will request
> for a GW. After mobility, nodes starting to receive new unsolicited
> advertisments will be able to reselect a closer GW. This is 
> an example. 

I think we agree on this.
   
> The fact is that routing protocols integrate or may easily 
> integrate a GW
> discovery protocol. This integration is often more efficient 
> than defining a
> separate protocol.

You'll have to give me some references on this matter to convince me I'm afraid... :-)

When using a proactive protocol, you are probably right, but I'm not so sure if we talk about reactive routing procotols.

> It is not worth defining and flooding a 
> new packet in a MANet
> with OLSR, when the use of one bit in TC messages leads to 
> the same result. 

Well, since OLSR is proactive, the result may be the same (I don't know OLSR that well). For reactive protocols, the result is not necessarily the same.

BR,
Fredrik

---

From: "Fredrik Alriksson (EAB)" <[email-masked]>
Date: Mon, 22 Jul 2002 15:09:01 +0200

Hi again,

   

BR,
Fredrik

---

From: Guillaume Chelius <[email-masked]>
Date: Mon, 22 Jul 2002 18:03:53 +0200 (CEST)

Hello Charlie,

> It could also be configurable at the gateway.  I would consider
> that "passive" means "reactive", and the question of "reactive"
> vs. "proactive" has just been discussed.

Yes, passive means no unsolicited advertisement: reactive.

> This sounds a lot like draft-wakikawa, except that the flooding
> happens
> from the other way around.

Yes it does, except that it basically allows unsolicited router advertisements.

> I think the advantages of having default routes have been overlooked
> in this discussion.  For one thing, it allows automatic switching to a
> new gateway for many circumstances when a node moves closer to a
> different gateway than it formerly was using.

Please Correct me if I'm wrong, but one problem with default routes is that
they are not necessary the same on all nodes of a path to a default route. It
may lead to endless loops:
+ Node A has a default route to gateway X through node B
+ Node B has a default route to gateway Y through node C
+ Node C has a default route to gateway Z through node A
I agree this case is critical but it may occur.

More frequently, It may also lead to false IP-spoofing detection:
+ Node A has a default route to gateway X which advertises prefix M through
node B
+ Node B has a default route to gateway Z which advertises prefix N
Packets sent from node A with a source global address Prefix_M:ID_A  will be
routed to gateway Z instead of gateway X. But gateway Z will refuse the packet, 
considering it as IP spoofing since prefix M does not correspond to gateway Z

Of course, partial source routing correts these errors. But then, you loose the 
advantage you gave about default route.

A proactive or hybrid scheme may be interesting to handle these cases.

Regards,
Guillaume Chelius.
-----------------
Guillaume Chelius
PhD student

---

From: Guillaume Chelius <[email-masked]>
Date: Mon, 22 Jul 2002 18:03:53 +0200 (CEST)

Hello Charlie,

Regards,
Guillaume Chelius.
-----------------
Guillaume Chelius
PhD student