Subject: RE: [manet] IP-802.11 interface

From: "Subrata Goswami" <[email-masked]>
Date: Tue, 25 Mar 2003 12:09:03 -0800

So you are saying something like the following ? 
The IP and 802.11 layers now has to somehow talk through  SNMP ? 
What are these API(?)'s ?

 Layer 5        [SNMP]
                  /\
                 /  \
 Layer 3     [IP ]   \
                      \
                       \
 Layer 2/1            [802.11]

Subrata

> -----Original Message-----
> From: Jim Thompson [mailto:[email-masked]]
> Sent: Tuesday, March 25, 2003 12:07 PM
> To: Subrata Goswami
> Subject: RE: [manet] IP-802.11 interface
> 
> 
> Link up, link down: traps (triggers work well too)
> Snr: mib variables
> 
> > -----Original Message-----
> > From: Subrata Goswami [mailto:[email-masked]]
> > Sent: Tuesday, March 25, 2003 11:43 AM
> > To: Jim Thompson; [email-masked]
> > Subject: RE: [manet] IP-802.11 interface
> > 
> > SNMP , how ??
> > 
> > 
> > > -----Original Message-----
> > > From: Jim Thompson [mailto:[email-masked]]
> > > Sent: Tuesday, March 25, 2003 11:45 AM
> > > To: Sukanta Kumar Hazra; Subrata Goswami
> > > Cc: [email-masked]
> > > Subject: RE: [manet] IP-802.11 interface
> > >
> > >
> > > Isn't this SNMP?
> > >
> > > > -----Original Message-----
> > > > From: Sukanta Kumar Hazra [mailto:[email-masked]]
> > > > Sent: Tuesday, March 25, 2003 11:13 AM
> > > > To: Subrata Goswami
> > > > Cc: [email-masked]
> > > > Subject: Re: [manet] IP-802.11 interface
> > > >
> > > > Subrata,
> > > >
> > > > Maybe it is premature to discuss the requirements for the
> > > API at this
> > > > time, however it could be something as simple as link layer
> > > providing
> > > > triggers (information) to upper layers regarding link
> > > status, SNR or
> > > > anything else that the upper layer may find important.
> I have seen
> > > > implementations of such schemes, what lacks is a standard API.
> > > >
> > > > - Sukanta
> > > > ----- Original Message -----
> > > > From: "Subrata Goswami <[email-masked]>"
> > > > Date: Tue, 25 Mar, 2003 23:50 SGT
> > > > Subject: RE: [manet] IP-802.11 interface
> > > >
> > > > > Questions. What would the IP-802.11 interface address
> ? Would it
> > > > > allow manipulation of 802.11 control/mangement frames ?
> > > What type of
> > > > > interface would this be - API ?
> > > > >
> > > > > Subrata
> > > > >
> > > > >
> > > > > > -----Original Message-----
> > > > > > From: [email-masked]
> > > [mailto:[email-masked]] On Behalf
> > > > > > Of Joe Macker
> > > > > > Sent: Tuesday, March 25, 2003 7:31 AM
> > > > > > To: Paul Tan Hock Lai; [email-masked];
> > > Sukanta Kumar
> > > > > > Hazra; [email-masked]
> > > > > > Cc: [email-masked]
> > > > > > Subject: RE: [manet] IP-802.11 interface
> > > > > >
> > > > > >
> > > > > > At 05:49 PM 3/25/2003 +0800, Paul Tan Hock Lai wrote:
> > > > > > >Hi,
> > > > > > >
> > > > > > >I am also interest in this issue too. I have actually tried
> to
> > > query
> > > > > > >the mailing list on the similar matter, but failed to get a
> > > > > > response.
> > > > > > >Maybe it's out of the scope of MANET. 8-)
> > > > > >
> > > > > > Its not that its out of scope, but that there has
> not been a
> > > > > > standard interface mechanisms to work with.  We
> have discussed
> > > > > > this quite a bit when the WG began. However, that
> doesn't one
> > > > > > can't do something. The MAC ACK monitoring approach
> has some
> > > > > > drawbacks (unicast only and congestion
> > > > > > problems) and shouldn't be seen as the best approach,
> > > even though
> > > > > > that is typically what is simulated.
> > > > > >
> > > > > > More precise link quality (filtered S/N-based) or
> simple link
> > > > > > up/down would be useful if available..
> > > > > >
> > > > > > In most specs the protocols are designed to work in the
> > > absence of
> > > > > > such mechanisms, but most have wording to say take advantage
> of
> > > > > > such an interface if available.
> > > > > >
> > > > > >
> > > > > > >> Some of the manet routing protocols (e.g., AODV abd DSR)
> have
> > > the
> > > > > > >> option of using MAC layer messages to realize link
> failures.
> > > > > > >
> > > > > > >MANET protocol (layer) requires triggers (link-up,
> > > > > > link-down, etc) from
> > > > > > >the mobile node (itself), I am not sure it TrigTrans can
> apply
> > > here
> > > > > > >(triggers sent by other entities).
> > > > > > >
> > > > > > >The timing and the reliability of the triggers are
> > > important too.
> > > > > >
> > > > > > Yes, these are important issues.
> > > > > >
> > > > > >
> > > > > >
> > > > > > _______________________________________________
> > > > > > manet mailing list
> > > > > > [email-masked] https://www1.ietf.org/mailman/listinfo/manet
> > > > > >
> > > > >
> > > > > _______________________________________________
> > > > > manet mailing list
> > > > > [email-masked] https://www1.ietf.org/mailman/listinfo/manet
> > > >
> > > > --
> > > > _______________________________________________
> > > > manet mailing list
> > > > [email-masked] https://www1.ietf.org/mailman/listinfo/manet
> > >
> 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Sumeeth Nagaraj <[email-masked]>
Date: Wed, 26 Mar 2003 01:45:21 -0700

Leping,

The upper bound derived for ad hoc networks by Gupta and Kumar is for network 
with static or stationary nodes- More information at
http://decision.csl.uiuc.edu/~piyush/pub_list.html
and also some simulations are done with the IEEE 802.11 MAC protocols and you 
can find more information at
http://www.pdos.lcs.mit.edu/papers/grid:mobicom01/

Hope this helps
Best Regards,
Sumeeth
----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, March 25, 2003 11:09 PM
Subject: RE: [manet] IP-802.11 interface

> Hi, AA:
>
> >Gupta and Kumar's work comes to mind, among others. Again,
> >I was wondering if you had some experimental results regarding this.
> It is quite important to have experimental experience before defining such 
IP-802.11 interface.
> Can you tell me the name/URL of some document/paper you know about such 
IP-802.11 interface work?
> such as "Gupta and Kumar's work":)
>
> Yours
> Leping
>
>
>
>
> From: "Yang, Lily L" <[email-masked]>
> To: "'Joe Macker'" <[email-masked]>; "Paul Tan Hock Lai"
> <[email-masked]>; <[email-masked]>; "Sukanta Kumar
> Hazra" <[email-masked]>; <[email-masked]>
> Cc: <[email-masked]>
> Sent: Tuesday, March 25, 2003 1:25 PM
> > In the recent IEEE Plenary meeting, Mesh Network presented a proposal to
> > extend 802.11 to better support mesh networking. One of the
> recommendations
> > is to extend the existing 802.11 standard MAC to allow information
> pertinent
> > to ad hoc networking to be passed across the network efficiently.  I quote
> a
> > few paragraphs relevant to the discussion here --
> > "Feedback from MAC/LLC to Routing implementation:
> > Immediate feedback of the TX and Rx status of packets received is critical
> > in
> > developing a reliable ad-hoc routing network. This status data is
> typically
> > available in some form from the MAC layer implementations of 802.11
> > hardware,
> > but is seldom available outside of the scope of the link layer. In Layer 2
> > routing
> > implementations based in or immediately above the link layer this
> > information
> > can be passed directly. In layer 3 implementations the cost of reporting
> > per-packet
> > information up to the network layer of a protocol stack may be
> > computationally or
> > architecturally prohibitive. In that case a cumulative derivative value
> can
> > be
> > computed in a small module collocated near the MAC. This value can then be
> > reported to the routing layer on a less frequent per-destination basis.
> Most
> > current
> > driver/stack combinations do not pass this information up in the stack.
> > Mac layer acknowledgements for transmitted directed packets must be
> reported
> > to
> > some agent of the routing implementations. This is necessary to determine
> > the
> > status of links in the multi-hop network.
> > Some normalized measure of signal quality or S/N ratio of received packets
> > must
> > be reported on a per packet basis to some agent of the routing
> > implementation.
> > Management packets should be made available to some agent of the routing
> > implementation so they can be used to inform the routing of status of
> > individual
> > neighboring stations."
> > "Feedback from the PHY:
> > A normalized measure of the number of corrected bit errors on a received
> > perpacket
> > should be made available to some agent of the routing implementation.
> > This can be used to predict degrading links in the network and proactively
> > switch
> > routes."
> >
> > The full presentation can be found at:
> > http://www.ieee802.org/meeting/meeting_files/Ad%20Hoc%20And%208022.pdf
> >
> > So maybe IEEE instead of IETF is the right place to do this ...
> > In any event, if 802.11 is going to work well for mesh networking, perhaps
> > it also calls for better coordination/interaction between the two groups.
> >
> > From: Joe Macker [mailto:[email-masked]]
> > To: Paul Tan Hock Lai; [email-masked]; Sukanta Kumar Hazra;
> > [email-masked]
> > Cc: [email-masked]
> > >I am also interest in this issue too. I have actually tried to query the
> > mailing list on the similar matter, but failed to get a response. Maybe
> it's
> > out of the scope of MANET. 8-)
> >
> > Its not that its out of scope, but that there has not been a standard
> > interface mechanisms to work with.  We have discussed this quite a bit
> when
> > the WG began. However, that doesn't one can't do something. The MAC ACK
> > monitoring approach has some drawbacks (unicast only and congestion
> > problems) and shouldn't be seen as the best approach, even though that is
> > typically what is simulated.
> >
> > More precise link quality (filtered S/N-based) or simple link up/down
> would
> > be useful if available..
> >
> > In most specs the protocols are designed to work in the absence of such
> > mechanisms, but most have wording to say take advantage of such an
> interface
> > if available.
> >
> >
> > >> Some of the manet routing protocols (e.g., AODV abd DSR) have the
> > >> option of using MAC layer messages to realize link failures.
> > >
> > >MANET protocol (layer) requires triggers (link-up, link-down, etc) from
> the
> > mobile node (itself),
> > >I am not sure it TrigTrans can apply here (triggers sent by other
> > entities).
> > >
> > >The timing and the reliability of the triggers are important too.
> >