Subject: RE: [manet] IP-802.11 interface

From: [email-masked]
Date: Wed, 26 Mar 2003 15:09:03 +0900

Hi, AA: 

>Gupta and Kumar's work comes to mind, among others. Again, 
>I was wondering if you had some experimental results regarding this.
It is quite important to have experimental experience before defining such IP-802.11 interface.
Can you tell me the name/URL of some document/paper you know about such IP-802.11 interface work?
such as "Gupta and Kumar's work":)

Yours
Leping

----- Original Message -----
From: "Yang, Lily L" <[email-masked]>
To: "'Joe Macker'" <[email-masked]>; "Paul Tan Hock Lai"
<[email-masked]>; <[email-masked]>; "Sukanta Kumar
Hazra" <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, March 25, 2003 1:25 PM
Subject: RE: [manet] IP-802.11 interface

>
> In the recent IEEE Plenary meeting, Mesh Network presented a proposal to
> extend 802.11 to better support mesh networking. One of the
recommendations
> is to extend the existing 802.11 standard MAC to allow information
pertinent
> to ad hoc networking to be passed across the network efficiently.  I quote
a
> few paragraphs relevant to the discussion here --
> "Feedback from MAC/LLC to Routing implementation:
> Immediate feedback of the TX and Rx status of packets received is critical
> in
> developing a reliable ad-hoc routing network. This status data is
typically
> available in some form from the MAC layer implementations of 802.11
> hardware,
> but is seldom available outside of the scope of the link layer. In Layer 2
> routing
> implementations based in or immediately above the link layer this
> information
> can be passed directly. In layer 3 implementations the cost of reporting
> per-packet
> information up to the network layer of a protocol stack may be
> computationally or
> architecturally prohibitive. In that case a cumulative derivative value
can
> be
> computed in a small module collocated near the MAC. This value can then be
> reported to the routing layer on a less frequent per-destination basis.
Most
> current
> driver/stack combinations do not pass this information up in the stack.
> Mac layer acknowledgements for transmitted directed packets must be
reported
> to
> some agent of the routing implementations. This is necessary to determine
> the
> status of links in the multi-hop network.
> Some normalized measure of signal quality or S/N ratio of received packets
> must
> be reported on a per packet basis to some agent of the routing
> implementation.
> Management packets should be made available to some agent of the routing
> implementation so they can be used to inform the routing of status of
> individual
> neighboring stations."
> "Feedback from the PHY:
> A normalized measure of the number of corrected bit errors on a received
> perpacket
> should be made available to some agent of the routing implementation.
> This can be used to predict degrading links in the network and proactively
> switch
> routes."
>
> The full presentation can be found at:
> http://www.ieee802.org/meeting/meeting_files/Ad%20Hoc%20And%208022.pdf
>
> So maybe IEEE instead of IETF is the right place to do this ...
> In any event, if 802.11 is going to work well for mesh networking, perhaps
> it also calls for better coordination/interaction between the two groups.
>
> -----Original Message-----
> From: Joe Macker [mailto:[email-masked]]
> Sent: Tuesday, March 25, 2003 7:31 AM
> To: Paul Tan Hock Lai; [email-masked]; Sukanta Kumar Hazra;
> [email-masked]
> Cc: [email-masked]
> Subject: RE: [manet] IP-802.11 interface
>
>
> At 05:49 PM 3/25/2003 +0800, Paul Tan Hock Lai wrote:
> >Hi,
> >
> >I am also interest in this issue too. I have actually tried to query the
> mailing list on the similar matter, but failed to get a response. Maybe
it's
> out of the scope of MANET. 8-)
>
> Its not that its out of scope, but that there has not been a standard
> interface mechanisms to work with.  We have discussed this quite a bit
when
> the WG began. However, that doesn't one can't do something. The MAC ACK
> monitoring approach has some drawbacks (unicast only and congestion
> problems) and shouldn't be seen as the best approach, even though that is
> typically what is simulated.
>
> More precise link quality (filtered S/N-based) or simple link up/down
would
> be useful if available..
>
> In most specs the protocols are designed to work in the absence of such
> mechanisms, but most have wording to say take advantage of such an
interface
> if available.
>
>
> >> Some of the manet routing protocols (e.g., AODV abd DSR) have the
> >> option of using MAC layer messages to realize link failures.
> >
> >MANET protocol (layer) requires triggers (link-up, link-down, etc) from
the
> mobile node (itself),
> >I am not sure it TrigTrans can apply here (triggers sent by other
> entities).
> >
> >The timing and the reliability of the triggers are important too.
>
> Yes, these are important issues.
>
>
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
>

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Sukanta Kumar Hazra <[email-masked]>
Date: Wed, 26 Mar 2003 15:23:12 +0800

----- Original Message -----
From: "[email-masked]"
Date: Wed, 26 Mar, 2003 14:09 SGT
Subject: RE: [manet] IP-802.11 interface

> such as "Gupta and Kumar's work":)

Gupta kumar (Capcity of Wirless Networks)
(http://citeseer.nj.nec.com/gupta99capacity.html)

the following might be of interest as well
	- Capacity of ad hoc wireless networks
	  (http://www.pdos.lcs.mit.edu/papers/grid:mobicom01/paper.pdf)
	- Mobility increases the capacity of ad hoc networks
	  (http://www.ece.utexas.edu/~jandrews/ee381k/EE381KTA/tse_mobility.pdf)

They do not deal with IP-802.11 interface, but are followup to gupta and
kumar's work.

- Sukanta

--