Subject: Re: [manet] Some questions on multicast routing protocols]

From: Jorjeta Gueorguieva Jetcheva <[email-masked]>
Date: Thu, 6 Mar 2003 11:35:42 -0500 (EST)

There have been many protocol proposals for multicast.  Most of them
include both proactive and reactive mechanisms.  Proactive mechanisms are
ones that rely on periodic control packet transmissions such as neighbor
detection and periodic flooding.  Routing functionality can roughly
be divided into two parts: route discovery and route maintenance.  Most
multicast routing protocols perform the route discovery part on-demand
and most perform the route maintenance part proactively, e.g., they use
periodic neighbor detection packets, or refresh the multicast state
periodically.

As far as I am aware, the only general-purpose multicast protocol that
performs both route discovery and maintenance on-demand is ADMR.  By
general-purpose, I mean a protocol that is not meant to only operate
with multicast groups of a limited size, or in small networks (e.g.,
DDM, which encodes all receivers for the multicast group in the
packet header).

A description and evaluation of ADMR along with a brief classification of
multicast protocols according to whether they use reactive or on-demand
mechanisms is described in the following paper:

---
Jorjeta G. Jetcheva and David B. Johnson.
Adaptive Demand-Driven Multicast Routing in Multi-Hop Wireless Ad Hoc
Networks.
Proceedings of the 2001 ACM International Symposium on Mobile Ad Hoc
Networking & Computing (MobiHoc 2001), pp. 33-44, ACM, Long Beach, CA,
October, 2001.
---

You can download this paper from
http://www.monarch.cs.rice.edu/papers.html.

> I know that most of them need an underlying unicast protocol. Those
> protocol maybe on-demand or proactive.

Actually, many multicast protocols do not require a unicast protocol.  If
a protocol relies on an underlying unicast protocol and cannot be made to
work with an on-demand unicast protocol, I'd classify it as proactive.

Jorjeta

------------------------------------------------------------------------

There exists MOLSR
http://hipercom.inria.fr/olsr/draft-ietf-manet-olsr-molsr.txt, a multicast
protocol based on the proactive protocol OLSR. There is also the protocol
XMAN http://scholar.lib.vt.edu/theses/available/etd-08142002-131727/.

I don't know about a multicast version of DSDV

On the reactive side, there is MAODV and a multicast version of DSR

Philippe
----- Original Message -----
From: Er Inn Inn <[email-masked]>
To: <[email-masked]>
Sent: Thursday, March 06, 2003 2:32 PM
Subject: [manet] Some questions on multicast routing protocols]

>
> Hi,
>
>     Thanks for the explaination. However, they are all unicast routing
> protocols. How about multicast routing protocol? Almost all proposed
> multicast protocols (for MANET) built the multicast tree or mesh when
> there are senders that wish to initiate multicast session... So could I
> classify them as on-demand? I know that most of them need an
> underlying unicast protocol. Those protocol maybe on-demand or
> proactive. Therefore, I am wondering whether the classification to
> proactive or reactive classes is not suitable for classifying
> multicast routing protocols?
>
>
>
> regards,
> inn inn
>
>
> > ----- Original Message -----
> > From: "Er Inn Inn" <[email-masked]>
> >
> >>     I am wondering whether we can classified the existing multicast
> >> routing protocol into 2 groups: Proactive and Reactive, as in unicast
> >> routing protocol. I have read some paper that classified the
> >> multicast protocols into whether on-demand or proactive. How to
> >> differentiate which protocol is on-demand and which one is proactive.
> >> As far as I understand, as long as the multicast tree or multicast
> >> mesh is built when it is needed (there is data to be sent) or it is
> >> initiated by the source, we may classify it as reactive protocol. Is
> >> this theory holds? What are the examples of proactive multicast
> >> routing protocol? Is AMRoute one of the examples of proactive
> >> multicast routing protocol?
> >
> >
> > REACTIVE : makes on-demand searches for a
> > path e.g AODV, DSR , ZRP
> > PROACTIVE : constantly updates the routing
> > table at each node to maintain a nearly global
> > view on the network topology e.g DSDV
> >
> > Warm Regards
> > Shubhranshu
>
>
>
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet

=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=
o  j		r		e		a   o		
=	 o		j		t	    =
o						    o	
=						    =
o 	        Jorjeta G. Jetcheva		    o
=	   Ph.D. student, Computer Science	    =
o 	    Carnegie Mellon University	            o
= 						    =
o         http://www.cs.cmu.edu/~jorjeta            o
=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Er Inn Inn <[email-masked]>
Date: Fri, 7 Mar 2003 08:59:08 +0800 (SGT)

Hi,

   I have read your paper on ADMR. AMRIS is classified as proactive
multicast protocol in your paper. However, the author of AMRIS
mentioned that their protocol is on-demand as well. Therefore, I am
wondering why? Thanks. As far as I know a special node (normally
source) in multicast group will initiate the route discovery (building
of DAG in this case). Therefore, based on what you explained, this is
one of the on-demand characteristics.

regards,
inn inn

> include both proactive and reactive mechanisms.  Proactive mechanisms
> are ones that rely on periodic control packet transmissions such as
> neighbor detection and periodic flooding.  Routing functionality can
> roughly be divided into two parts: route discovery and route
> maintenance.  Most multicast routing protocols perform the route
> discovery part on-demand and most perform the route maintenance part
> proactively, e.g., they use periodic neighbor detection packets, or
> refresh the multicast state periodically.
>
> A description and evaluation of ADMR along with a brief classification
> of multicast protocols according to whether they use reactive or
> on-demand mechanisms is described in the following paper:
>
> ---
> Networks. Proceedings of the 2001 ACM International Symposium on Mobile
> Ad Hoc Networking & Computing (MobiHoc 2001), pp. 33-44, ACM, Long
> Beach, CA, October, 2001.
> ---
>
> Actually, many multicast protocols do not require a unicast protocol.
> If a protocol relies on an underlying unicast protocol and cannot be
> made to work with an on-demand unicast protocol, I'd classify it as
> proactive.
>
> Jorjeta
>
> -------------------------------------------------------------------------
>
> There exists MOLSR
> http://hipercom.inria.fr/olsr/draft-ietf-manet-olsr-molsr.txt, a
> multicast protocol based on the proactive protocol OLSR. There is also
> the protocol XMAN
> http://scholar.lib.vt.edu/theses/available/etd-08142002-131727/.
>
>> there are senders that wish to initiate multicast session... So could
>> I classify them as on-demand? I know that most of them need an
>> >> routing protocol into 2 groups: Proactive and Reactive, as in
>> unicast routing protocol. I have read some paper that classified
>> the
>> differentiate which protocol is on-demand and which one is
>> proactive. As far as I understand, as long as the multicast tree or
>> multicast mesh is built when it is needed (there is data to be
>> sent) or it is initiated by the source, we may classify it as
>> reactive protocol. Is this theory holds? What are the examples of
>> proactive multicast routing protocol? Is AMRoute one of the
>> examples of proactive multicast routing protocol?
>> >
>> >

---

From: Jorjeta Gueorguieva Jetcheva <[email-masked]>
Date: Thu, 6 Mar 2003 21:31:55 -0500 (EST)

Hello Inn Inn,

In the Mobihoc paper, we say that AMRIS relies on proactive mechanisms 
for its operation.  The particular mechanism that we had in mind is the
periodic broadcasting of "multicast beacons" by all nodes in the
network that AMRIS uses for disseminating multicast state information
and for link break detection (Section 7 in the AMRIS Internet-Draft). 

Jorjeta

-----------------------------------------------------------------------

Hi,

regards,
inn inn