Subject: RE: [manet] IP-802.11 interface

From: "Paul Tan Hock Lai" <[email-masked]>
Date: Tue, 25 Mar 2003 17:49:21 +0800

Hi,

I am also interest in this issue too. I have actually tried to query the mailing list on the similar matter, but failed to get a response. Maybe it's out of the scope of MANET. 8-)

> Some of the manet routing protocols (e.g., AODV abd DSR) have the
> option of using MAC layer messages to realize link failures. 

MANET protocol (layer) requires triggers (link-up, link-down, etc) from the mobile node (itself),
I am not sure it TrigTrans can apply here (triggers sent by other entities).

The timing and the reliability of the triggers are important too.

Regards,
Paul

> simulation based papers have modeled the IEEE 802.11 MAC as providing
> such connectivity messages to the routing layer. However, is there
> any work on providing a "real" IP-to-802.11 interface? A broader
> issue concerns the design tradeoffs and performance gains when using such
> a vertical-layer or cross-layer design approach. Any studies or thoughts
> on these issues?
> 
> Is this problem in the scope of the MANET group?

>>> <[email-masked]> 25-Mar-03 4:36:57 PM >>>
Hi, Sukata:

I am also quite interested in this issue.
Do you still remember which WG was tackling this problem inside/outside IETF?
Are there any draft/RFC they produced?

I was told that there is a draft in MobileIPv6 WG, which may be related to this issue.
"Mobile IPv6 Fast Handovers for 802.11 Networks"
http://www.ietf.org/internet-drafts/draft-mccann-mobileip-80211fh-01.txt 

Yours
Leping

Hi Dmitri,

I recall that some effort (standard) in this direction was sought in the IP
trigger BOF in IETF some time ago. From what I remember they failed to
reach a consensus.

- Sukanta

----- Original Message -----
From: ""Dmitri D. Perkins" <[email-masked]>"
Date: Tue, 25 Mar, 2003 06:40 SGT
Subject: [manet] IP-802.11 interface

> 
> Some of the manet routing protocols (e.g., AODV abd DSR) have the
> option of using MAC layer messages to realize link failures. Several
> simulation based papers have modeled the IEEE 802.11 MAC as providing
> such connectivity messages to the routing layer. However, is there
> any work on providing a "real" IP-to-802.11 interface? A broader
> issue concerns the design tradeoffs and performance gains when using such
> a vertical-layer or cross-layer design approach. Any studies or thoughts
> on these issues?
> 
> Is this problem in the scope of the MANET group?
> 
> Thanks for you time...
> Dmitri
> 
> ==================================================
> Dr. Dmitri D. Perkins, Assistant Professor
> The Center for Advanced Computer Studies
> University of Louisiana at Lafayette
> P.O. Box 44330, Lafayette, LA 70504-4330
> 
> office: (337)482-6732	fax: (337)482-5791
> ==================================================
> 
> _______________________________________________
> manet mailing list
> [email-masked] 
> https://www1.ietf.org/mailman/listinfo/manet 

-- 
_______________________________________________
manet mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/manet 
_______________________________________________
manet mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Joe Macker <[email-masked]>
Date: Tue, 25 Mar 2003 10:30:58 -0500

>I am also interest in this issue too. I have actually tried to query the mailing list on the similar matter, but failed to get a response. Maybe it's out of the scope of MANET. 8-)

Its not that its out of scope, but that there has not been a standard interface mechanisms to work with.  We have discussed this quite a bit when the WG began. However, that doesn't one can't do something. The MAC ACK monitoring approach has some drawbacks (unicast only and congestion problems) and shouldn't be seen as the best approach, even though that is typically what is simulated.

More precise link quality (filtered S/N-based) or simple link up/down would be useful if available..

In most specs the protocols are designed to work in the absence of such mechanisms, but most have wording to say take advantage of such an interface if available.

>The timing and the reliability of the triggers are important too.

Yes, these are important issues.

---

From: "Subrata Goswami" <[email-masked]>
Date: Tue, 25 Mar 2003 07:50:56 -0800

Questions. What would the IP-802.11 interface address ?  
Would it allow manipulation of 802.11 control/mangement frames ?
What type of interface would this be - API ?

Subrata

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Joe Macker
> Sent: Tuesday, March 25, 2003 7:31 AM
> To: Paul Tan Hock Lai; [email-masked]; Sukanta 
> Kumar Hazra; [email-masked]
> Cc: [email-masked]
> Subject: RE: [manet] IP-802.11 interface
> 
> 
> >I am also interest in this issue too. I have actually tried to query 
> >the mailing list on the similar matter, but failed to get a 
> response. 
> >Maybe it's out of the scope of MANET. 8-)
> 
> Its not that its out of scope, but that there has not been a 
> standard interface mechanisms to work with.  We have 
> discussed this quite a bit when the WG began. However, that 
> doesn't one can't do something. The MAC ACK monitoring 
> approach has some drawbacks (unicast only and congestion 
> problems) and shouldn't be seen as the best approach, even 
> though that is typically what is simulated.
> 
> In most specs the protocols are designed to work in the 
> absence of such mechanisms, but most have wording to say take 
> advantage of such an interface if available.
> 
> 
> >MANET protocol (layer) requires triggers (link-up, 
> link-down, etc) from 
> >the mobile node (itself), I am not sure it TrigTrans can apply here 
> >(triggers sent by other entities).
> >

---

From: Sukanta Kumar Hazra <[email-masked]>
Date: Wed, 26 Mar 2003 02:32:10 +0800

Would it be fair to interpret that a standard approach for obtaining
link quality information is sought by the MANET group?

- Sukanta
----- Original Message -----
From: "Joe Macker <[email-masked]>"
Date: Tue, 25 Mar, 2003 23:30 SGT
Subject: RE: [manet] IP-802.11 interface

-- 
--------------------------------------------------------------------
Sukanta Kumar Hazra <[email-masked]>
Institute for Infocomm Research, Singapore
Phone: +65 68709338   Fax: +65 67795441
--------------------------------------------------------------------
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Subrata Goswami" <[email-masked]>
Date: Tue, 25 Mar 2003 10:49:30 -0800

Why limit the API just to link quality ?  That seems very myopic to me.
If an interface is defined then it needs to be general and be capable of
extensions.   

The general problem is of how to pass information between 802.11 and IP
other than IP being payload in 802.11. A standard way to pass
information (e.g. Information Elements, ) which are essentially of
control type is required.

Subrata

> Behalf Of Sukanta Kumar Hazra
> Sent: Tuesday, March 25, 2003 10:32 AM
> To: Joe Macker
> Cc: Paul Tan Hock Lai; [email-masked]; 
> [email-masked]; [email-masked]
> Subject: Re: [manet] IP-802.11 interface
> 
> 
> Would it be fair to interpret that a standard approach for 
> obtaining link quality information is sought by the MANET group?
> 
> - Sukanta
> > >the mailing list on the similar matter, but failed to get 
> a response. 
> > Its not that its out of scope, but that there has not been 
> a standard 
> > interface mechanisms to work with.  We have discussed this 
> quite a bit 
> > when the WG began. However, that doesn't one can't do 
> something. The 
> > MAC ACK monitoring approach has some drawbacks (unicast only and 
> > congestion problems) and shouldn't be seen as the best 
> approach, even 
> > More precise link quality (filtered S/N-based) or simple 
> link up/down 
> > would be useful if available..
> > 
> > In most specs the protocols are designed to work in the absence of 
> > such mechanisms, but most have wording to say take 
> advantage of such 
> > >MANET protocol (layer) requires triggers (link-up, link-down, etc) 
> > >from the mobile node (itself), I am not sure it TrigTrans 
> can apply 
> > >here (triggers sent by other entities).
> > >

---

From: Sukanta Kumar Hazra <[email-masked]>
Date: Wed, 26 Mar 2003 03:12:46 +0800

Subrata,

Maybe it is premature to discuss the requirements for the API at this
time, however it could be something as simple as link layer providing
triggers (information) to upper layers regarding link status, SNR or
anything else that the upper layer may find important. I have seen
implementations of such schemes, what lacks is a standard API.

- Sukanta

---

From: "Subrata Goswami" <[email-masked]>
Date: Tue, 25 Mar 2003 11:14:31 -0800

I do not think it is premature to discuss what is the problem we are
trying to solve. It is difficult to extend protocols/api's beyond what
they are designed for. If the effort to design an api(?) is to be spent
then, it (api?) should be at least bidirectional (i.e. both to and from
802.11) and extensible. 

Subrata

> From: Sukanta Kumar Hazra [mailto:[email-masked]] 
> Sent: Tuesday, March 25, 2003 11:13 AM
> To: Subrata Goswami
> Cc: [email-masked]
> Maybe it is premature to discuss the requirements for the API 
> at this time, however it could be something as simple as link 
> layer providing triggers (information) to upper layers 
> regarding link status, SNR or anything else that the upper 
> layer may find important. I have seen implementations of such 
> schemes, what lacks is a standard API.
> 
> - Sukanta

---

From: Mineo Takai <[email-masked]>
Date: Tue, 25 Mar 2003 11:51:08 -0800

Hi,

It is not an IETF effort, but the IEEE 802.11 Working Group created Task 
Group K (802.11k) to discuss what radio resource measurement data to 
provide to higher layers. It is not bidirectional (only from 802.11), 
but may be one of good starting points.

Mineo

Subrata Goswami wrote:
>>>>>>Some of the manet routing protocols (e.g., AODV abd 
>>>>>
>>DSR) have the
>>
>>>>>the mobile node (itself), I am not sure it TrigTrans can 
>>>>
>>apply here
>>

---

From: "Subrata Goswami" <[email-masked]>
Date: Tue, 25 Mar 2003 11:48:07 -0800

That is good to know, IETF should get involved with anything that
provides info to layers below IP, should not it ? A parallel work to
802.11K in IETF is required, is not it ?

Subrata

> From: Mineo Takai [mailto:[email-masked]] 
> Sent: Tuesday, March 25, 2003 11:51 AM
> To: Subrata Goswami
> Cc: [email-masked]
> > they are designed for. If the effort to design an api(?) is to be 
> > spent then, it (api?) should be at least bidirectional 
> (i.e. both to 
> > and from
> > 802.11) and extensible. 
> > 
> > Subrata
> > 
> > 
> > 
> >>>Questions. What would the IP-802.11 interface address ? Would it 
> >>>allow manipulation of 802.11 control/mangement frames ? 
> What type of 
> >>>>From: [email-masked] [mailto:[email-masked]] 
> On Behalf 
> >>>>Of Joe Macker
> discussed this 
> >>>>quite a bit when the WG began. However, that doesn't one can't do 
> >>>>something. The MAC ACK monitoring approach has some drawbacks 
> >>>>(unicast only and congestion
> absence of

---

From: Sukanta Kumar Hazra <[email-masked]>
Date: Wed, 26 Mar 2003 03:56:16 +0800

Agreed. I should have phrased it better (as an example, link quality).
And not just 802.11 but lets call it link later.

- Sukanta