Subject: [manet] discussion on the routing protocol at Link Layer

From: "lu guoxiang" <[email-masked]>
Date: Tue, 18 Mar 2003 01:36:29 +0000

hi all,

i am implementing a bridging method by which the data forwarding function is 
realised at the data link layer. i would like to hear your comment on the 
pros and cons of this protocol.

first of all, the nodes will form clusters and the bridges which are used to 
communicate neighboring clusters are selected.

and, it is a reactive routing protocol. b4 sending data to dst, the src will 
multicast a "Request_MAC" message that asking the mac address of the dst. 
only the bridges elected are resposible to forwarding the "Request_Mac" 
message.
when dst recv the "Request_Mac", it will unitcast a reply back with its MAC 
address. this process is like AODV except for the addtional MAC address of 
the dst. same as the AODV, during the request and reply process, all the 
intermediate nodes that either receive request or reply know the way to the 
src or dst or both.

after the src get dst's MAC address, it will unicast the data pkt to the 
dst. when a intermediate node recv a data pkt, it will check whether it has 
the route or not. if it has, just forward the pkt to the dst. otherwise, it 
will multicast the pkt to bridges.

the intermediate nodes, which relay the data pkt, actually do the routing at 
the datalink layer. it won't pass the pkt to the network layer, cause it 
knows the dst's mac addr as well as next hop's mac addr. by doing this, we 
can reduce some processing time.

and by the cluster formation, we the "Request_MAC" message are not blindly 
flooded. thus, we can reduce the routing load.

ok, it is just a brief description on my routing protocol. your valuable 
comments on it are greatly appreciated.

cheers,
guoxiang

_________________________________________________________________
Take a break! Find destinations on MSN Travel. http://www.msn.com.sg/travel/

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "lu guoxiang" <[email-masked]>
Date: Thu, 20 Mar 2003 03:17:55 +0000

hi all,

thanks for your guys' replies. i am just thinking out of the algo & 
mechanism right now. however, i will write document on it. once i am done, i 
will put it on the web to share with you. :)

regards,
guoxiang

>From: Michael Neufeld <[email-masked]>
>To: Manish Karir <[email-masked]>
>CC: "Yang, Lily L" <[email-masked]>,   "'lu guoxiang'" 
><[email-masked]>, [email-masked]
>Subject: Re: [manet] discussion on the routing protocol at Link Layer
>Date: Wed, 19 Mar 2003 13:46:21 -0700
>
>While they aren't explicitly "ad hoc" routing protocols, SmartBridge 
>(http://citeseer.nj.nec.com/rodeheffer00smartbridge.html) and STAR Bridge 
>(can't find the website right now) both do layer 2 bridging with an eye 
>towards scalability.
>
>-Mike
>
>Manish Karir wrote:
>>
>>
>>I think LUNAR did something along those lines as well...:
>>
>>http://www.docs.uu.se/docs/research/projects/selnet/lunar/
>>
>>manish
>>
>>
>>Yang, Lily L wrote:
>>
>>>Guoxiang --
>>>This certainly sounds interesting. Most of the existing routing protocols
>>>for MENET are done at one layer up but we also believe there are certain
>>>advantages of doing this at the data link layer. Do you have a more 
>>>complete documentation on this that you can share with
>>>us?
>>>Lily
>>>
>>>-----Original Message-----
>>>From: lu guoxiang [mailto:[email-masked]]
>>>Sent: Monday, March 17, 2003 5:36 PM
>>>To: [email-masked]
>>>Subject: [manet] discussion on the routing protocol at Link Layer
>>>
>>>hi all,
>>>
>>>when dst recv the "Request_Mac", it will unitcast a reply back with its 
>>>MAC address. this process is like AODV except for the addtional MAC 
>>>address of the dst. same as the AODV, during the request and reply 
>>>process, all the intermediate nodes that either receive request or reply 
>>>know the way to the src or dst or both.
>>>
>>>dst. when a intermediate node recv a data pkt, it will check whether it 
>>>has the route or not. if it has, just forward the pkt to the dst. 
>>>otherwise, it will multicast the pkt to bridges.
>>>
>>>knows the dst's mac addr as well as next hop's mac addr. by doing this, 
>>>we can reduce some processing time.
>>>
>>>and by the cluster formation, we the "Request_MAC" message are not 
>>>blindly flooded. thus, we can reduce the routing load.
>>>

_________________________________________________________________
Find gifts, buy online with MSN Shopping. http://shopping.msn.com.sg/

---

From: "Yang, Lily L" <[email-masked]>
Date: Wed, 19 Mar 2003 13:37:25 -0800

Anybody aware of any technical comprehensive analysis or comparison of doing
this for mesh networks at layer 2 versus layer 3 ?

-----Original Message-----
From: Joe Macker [mailto:[email-masked]]
Sent: Wednesday, March 19, 2003 1:10 PM
To: Mineo Takai; Yang, Lily L
Cc: 'lu guoxiang'; [email-masked]
Subject: Re: [manet] discussion on the routing protocol at Link Layer

HIPERLAN 1, also was a such a technique  at a lower layer and OLSR is
loosely based upon that work.  There are also many other historical subnet
approaches.  MANET is chartered to work IP layer solutions.

-Joe

---

From: "Paul Tan Hock Lai" <[email-masked]>
Date: Fri, 21 Mar 2003 01:54:48 +0800

hi all,

my observation from the mailing list is that MANET's routing protocols are mostly implemented or simulated on ieee802.11 radio. i believed that implementing routing at the ip layer enables heterogenous mixture of links/networks. i am not sure abt the benefits from doing it in the L2 layer (link-specific).
maybe the community would like to share info/advantages on doing it in L2 with us.

cheers,
Paul Tan

>>> "Yang, Lily L" <[email-masked]> 03/19/03 01:37PM >>>

-----Original Message-----
From: Joe Macker [mailto:[email-masked]] 
Sent: Wednesday, March 19, 2003 1:10 PM
To: Mineo Takai; Yang, Lily L
Cc: 'lu guoxiang'; [email-masked] 
Subject: Re: [manet] discussion on the routing protocol at Link Layer

-Joe

---

From: Shaiful <[email-masked]>
Date: Fri, 21 Mar 2003 16:19:56 -0800 (PST)

Hi,

I think when he said layer 2, he really meant layer
2.5 ;-) Similar to what MPLS does for wired network.  

In another jargon, it is "under-lay" as opposed to
"over-lay" network as in p2p.

Regards,
Shaiful

Paul tan wrote:

my observation from the mailing list is that MANET's
routing protocols 
are mostly implemented or simulated on ieee802.11
radio. i believed 
that implementing routing at the ip layer enables
heterogenous mixture of 
links/networks. i am not sure abt the benefits from
doing it in the L2 
layer (link-specific).
maybe the community would like to share
info/advantages on doing it in 
L2 with us.

__________________________________________________
Do you Yahoo!?
Yahoo! Platinum - Watch CBS' NCAA March Madness, live on your desktop!
http://platinum.yahoo.com
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet