Subject: [manet] "setdest" problem in ns2

From: fxbaloch <[email-masked]>
Date: Thu, 29 Apr 2004 00:02:39 -0500

Hello everyone,

I have a problem regarding "setdest" in ns2. I have ns2.27 allinone installed.
It is working fine except I cant seem to get setdest command working. After
doing "config" in main ns directory I did "make" in setdest directory( as is
written in README FILE) but it is giving following error,

../../autoconf.h error: namspace 'CPP_NAMESPACE' undeclared.

Does anyone know how to get around with this problem and get setdest
executable file. Any input will be appreciated ASAP.

Thanks
Fariha Baloch

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Sukanta K. Hazra" <[email-masked]>
Date: Thu, 29 Apr 2004 16:43:55 +0800

>From the setdest directory edit the file ../../../autoconf.h

Look for the section on stl (last section in file) and define CPP_NAMESPACE to std.

/* stl */
#ifdef __cplusplus
#define HAVE_STL 1
#define CPP_NAMESPACE std  [ Add this line ]  
#define CPP_REQUIRES_NAMESPACE 1
#ifdef CPP_REQUIRES_NAMESPACE
using namespace CPP_NAMESPACE;
#endif /* CPP_NAMESPACE */
#endif /* __cplusplus */

Hope it works.

- Sukanta