Subject: [manet] [manet]what's the difference between Link-State & Distance Vector?

From: [email-masked]
Date: Tue, 27 Apr 2004 22:21:57 +0800 (CST)

Hi,

   I'm a student. And although I have saw something about Ad Hoc, still I don't know the difference between Link-State and Distance Vector. Maybe it is a stupid question,but it is important to me.
   Wait for reply. Thank you!

                                                                         Xie Min

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "z yt" <[email-masked]>
Date: Wed, 28 Apr 2004 21:36:01 +0800

Dear Xie Min:

Distance Vector: 

To find the optimal path by distance infomation. 
A packet add its hop-count when pass through a node. 
The path that has the least count is the best.
For examples, RIP, IGRP.

Link State:

Also called Shortest Path First (SPF).
Each node has 3 tables:
1st is used to trace the neighbor nodes (directly connected),
2nd is used to store the topology of the networks,
3rd is routing table.

Link State reqires more info of the networks than Distance Vector does.

Good luck!