Subject: [manet] Average number of neighbors

From: [email-masked]
Date: Sat, 24 Apr 2004 11:23:01 +0800 (SGT)

Hi all,

     Is there anyone have any paper on how to calculate average number of
neighbors in a MANET? Thank you in advance!

regards,
inn inn

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Ash Mohammad Abbas <[email-masked]>
Date: Sat, 24 Apr 2004 13:43:12 +0100 (BST)

I do not know in which context you are talking.
However, I came across a paper by J. Liu and B. Li
published in the proc. of ICCCN 2002 titled
"MobileGrid: Capacity-aware Topology Control in Mobile
  Ad hoc Networks". In this paper, the authors have
argued that number of neighbors of a node should be
around 3-9 to achieve better connectivity and not to
have too much congestion. The neighbours can be 
estimated using a parameter Contention Index (CI).
Further CI can be computed by overhearing RTS/CTS/ACK.
An advantage of this method is that it does not
require 
additional overheads. But a node which remains silent
is not detected.
You may download the above paper from IEEE site, if
you or your institute has subscribed it.
Hope this helps,
Abbas

 --- [email-masked] wrote: > Hi all,
> neighbors in a MANET? Thank you in advance!

=====
Ash Mohammad Abbashttp://www.cse.iitd.ernet.in/~abbas

________________________________________________________________________
Yahoo! India Matrimony: Find your partner online. http://yahoo.shaadi.com/india-matrimony/

---

From: [email-masked]
Date: Sat, 24 Apr 2004 14:45:29 -0700 (MST)

Hi,

You can calculate the number of neighbors in 2 different ways:
- If you do not take the energy model into consideration, then the number of
neighbors of a node is simply the number of nodes which are within a distance
of transmission range( which wont change, as there is no energy
depletion). You can calculate the no. of neighbors by simply calculating the
distance between a node and every other node and checking if the distance
between them is <= transmission range.
- However, for a more practical and accurate depiction you have to use the
Propagation model, calculate  Reception range of a node(based on the current
energy of the node, distance between the 2 nodes and antenna model)  and see
if this is within the reception threshold of a node. If so, then the nodes are
neighbors. (This is kinda involved. If you are using NS2, there is plenty of
material on the NS2 mailing list).
I hope this helps!
Good luck!

Sruthi Yellamraju
Graduate Student, Dept of Computer Science & Engineering
Arizona State University, Tempe - 85281