Subject: [manet] Olsr Route Table calculation

From: manet user <[email-masked]>
Date: Tue, 20 Apr 2004 09:32:22 -0700 (PDT)

Hi,
 
According to Olsr RFC section 10, while selecting next hop for a dest_addr for h= 1, ties should be broken with highest willingness and MPR selectors are preferred as next hop.
 
My questions is: why MPR selectors are preferred over MPR nodes for next hop in case of h=1. For example, a two hop nbr is reachable through two nodes, one of them is MPR and other is not (but it is in my mpr selector list). According to RFC algorithm, we will select non MPR node as next hop to reach this two hop node. Is there any particular reason for this ?
 
Please advise. Your comments will be of great help.
 
Thanks in advance.
-MU

---------------------------------
Do you Yahoo!?
Yahoo! Photos: High-quality 4x6 digital prints for 25¢

---

From: Shivanajay Marwaha <[email-masked]>
Date: Tue, 20 Apr 2004 23:34:47 -0700 (PDT)

Hi all,

If two ad hoc networks using a decentralised
reservation based transmission scheduling algo merge,
how is the new reservation schedule calculated? 

Thankz.
Shivanajay

		
__________________________________
Do you Yahoo!?
Yahoo! Photos: High-quality 4x6 digital prints for 25¢
http://photos.yahoo.com/ph/print_splash

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Philippe Jacquet" <[email-masked]>
Date: Wed, 21 Apr 2004 11:49:33 +0200

Hi, MU,

There is no specific reason as long as we consider neighbor or two-hop neighbor destinations. However for further destinations, by taking a MPR selector and if the link fails then the intermediate node will immediately issue a TC message that will inform the whole network of a MPR selector link breakage. If the intermediate node takes a non MPR selector as next hop, it will take several link breakage detections and several switches to alternative links before actually realizing the MPR selector link breakage. 

Philippe
  ----- Original Message ----- 
  From: manet user 
  To: [email-masked] 
  Cc: [email-masked] 
  Sent: Tuesday, April 20, 2004 6:32 PM
  Subject: [manet] Olsr Route Table calculation

  Hi,

  Thanks in advance.
  -MU

------------------------------------------------------------------------------
  Do you Yahoo!?
  Yahoo! Photos: High-quality 4x6 digital prints for 25¢