Subject: [manet] Re:Connectivity

From: Ali El-Husseini <[email-masked]>
Date: Mon, 26 Apr 2004 12:46:55 -0400

In general, most of the on-demand routing published papers for routing in MANET (DSR AODV,
etc..) assumes that they may hit cases where full connectivity is not possible due to node
mobility.
They try to solve this issue by setting a timer before sending RREQ. Upon time-out, they give
a second try. If the second try wasn't successful, they stop trying.

Proactive routing algorithms (e.g., DSDV) lists all destinations in their routing table and a
cost metric beside each entry. Any destination with cost metric equal to infinity means
unreachable. This happens during node mobility which may cause either temporary or permanent
disconnected network.

Logically, if the network is disconnected, there will be no way to deliver the message to or
from the disconnected destination. In this particular case, On-demand routing generates more
routing overhead in comparison to proactive routing approaches. This due to RREQ that will be
flooding the network twice before declaring the target node is unreachable.

For research studies, if you are measuring delivery rate  make sure that the network is
connected between the source and the destination since it would be unfair to say that the
algorithm is not delivering the msg in case there was no route from the source to destination.
Note, some routing techniques (e.g. Routing with guaranteed delivery, by Stojmenovic etal.)
came out to solve delivery problem in connected network.

For verifying that the network is connected, Dijkestra algorithm can be used for that.

Regards,
Ali El-Husseini

> Message: 1
> Date: Fri, 23 Apr 2004 15:30:39 -0300
> To: [email-masked]
> From: "Maen M. Artimy" <[email-masked]>
> Subject: [manet] Connectivity
>
> Hi,
>
> Do MANET routing protocols always assume full network connectivity?
> Can you guide me to any work on this subject?
>
> Thanks.
>
> Maen
>

---

From: "John Mullen" <[email-masked]>
Date: Wed, 28 Apr 2004 21:04:13 -0600

Hi Ali,

Good points, but I'd like to add a few.

Partition is a network phenomena and is relative.  If the network is
partitioned (divided into two or more subnetworks that cannot connect to
each other), then if Node A and B are in different partitions, they will
be disconnected.  However, the reality and the perception are two
different things.

This issue does not relate to node mobility directly.  A network may
become partitioned for a number of reasons, e.g. change in propagation
conditions, initial placement of the nodes, etc.  (Nodes placed
according to a uniform or Poisson distribution need not produce a
connected network, even if the average density is adequate.)  However,
mobility can certainly cause partition and disconnection.

While what you say about reactive protocols is true, it is also true
that many potential disconnects are never explored in a reactive
protocol.  That is, two nodes may be disconnected, but never have a need
to communicate with each other.  The idea of a reactive protocol is to
only update routing information that is necessary to effect current
communications.  In a proactive protocol, all routes, whether or not
they are needed, are maintained. Of course, if every node has a need to
talk to every other node, the proactive protocol would have less
latency.  However, in many situations, this is not the case, hence the
attractiveness of the reactive protocol which can have significantly
lower overhead.

In short, depending on the circumstances, either sort of protocol might
be preferred.

John Mullen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Ali El-Husseini
Sent: Monday, April 26, 2004 9:47 AM
To: [email-masked]
Subject: [manet] Re:Connectivity

In general, most of the on-demand routing published papers for routing
in MANET (DSR AODV,
etc..) assumes that they may hit cases where full connectivity is not
possible due to node mobility. They try to solve this issue by setting a
timer before sending RREQ. Upon time-out, they give a second try. If the
second try wasn't successful, they stop trying.

Proactive routing algorithms (e.g., DSDV) lists all destinations in
their routing table and a cost metric beside each entry. Any destination
with cost metric equal to infinity means unreachable. This happens
during node mobility which may cause either temporary or permanent
disconnected network.

Logically, if the network is disconnected, there will be no way to
deliver the message to or from the disconnected destination. In this
particular case, On-demand routing generates more routing overhead in
comparison to proactive routing approaches. This due to RREQ that will
be flooding the network twice before declaring the target node is
unreachable.

For research studies, if you are measuring delivery rate  make sure that
the network is connected between the source and the destination since it
would be unfair to say that the algorithm is not delivering the msg in
case there was no route from the source to destination. Note, some
routing techniques (e.g. Routing with guaranteed delivery, by
Stojmenovic etal.) came out to solve delivery problem in connected
network.

For verifying that the network is connected, Dijkestra algorithm can be
used for that.

Regards,
Ali El-Husseini

> Can you guide me to any work on this subject?

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet