Subject: Re: [manet] Average number of neighbors

From: Feng Xue <[email-masked]>
Date: Mon, 26 Apr 2004 21:26:36 -0500 (CDT)

I don't know what exactly you are looking for.
I know several papers considered the question of how many neighbors
a node should have in order to maximize throughput or to maintain connectivity.

If the network is modeled as Poission point process on a plane, in order to
maximize the one hop progress of a packet in the desired direction under
certain transmission protocols, H. Takagi and L. Kleinrock showed 
6 or 8 is the "magic number".
"Optimal transmission ranges for randomly distributed packet radio terminals,"
IEEE Trans. Commun., vol. COM-32, pp. 246-257, 1984.
Several papers followed this paper and former paper by Kleinrock et al.

If the wireless network is modeled as n nodes distributed uniformly within
some fixed area, say, a disk, and suppose the question is to choose a common range 
for the nodes to maintain connectivity with high probability, 
P. Gupta and PR Kumar show that the critical
range should be choosen such that each node has on average log(n) neighbors. 
If the question is to choose a common number of neighbors that
each node needs to connect to, then F. Xue and PR Kumar show that
O(log(n)) is needed. Both papers can be found from Kumar's (UIUC) webpage.

Erran L. Li et al at Bell-labs considered a "cone-based" distributed topology
control algorithm to maintain connectivity, where they considered the
following question: Suppose each node connects to neighboring nodes such
that there is at least one with any angle of degree \alpha, how should \alpha
be choosen to achieve connectivity? They show \alpha=5 \pi/6 is critical.
The paper can be found from Li's webpage at Bell-labs.

Hope this can help.

Feng

 --- [email-masked] wrote: 

>Hi all,
>
>     Is there anyone have any paper on how to calculate average number of
>neighbors in a MANET? Thank you in advance!
>
>
>regards,
>inn inn
>
>_______________________________________________
>manet mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Tommaso Melodia" <[email-masked]>
Date: Tue, 27 Apr 2004 00:06:12 -0400

Inn Inn,

if you are interested in topology control, you might also want to have a
look at our paper:

T. Melodia, D. Pompili, Ian F. Akyildiz, "Optimal Local Topology
Knowledge for Energy Efficient Geographical Routing in Sensor Networks",
in Proceedings of IEEE INFOCOM 2004, Hong Kong SAR, PRC.

It is on my web page:
http://users.ece.gatech.edu/tommaso/

Hope this helps,
Tommaso

> -----Messaggio originale-----
> Da: [email-masked] [mailto:[email-masked]] Per conto di
Feng
> Xue
> Inviato: lunedì 26 aprile 2004 22.27
> A: [email-masked]
> Cc: [email-masked]
> Oggetto: Re: [manet] Average number of neighbors
> 
> If the network is modeled as Poission point process on a plane, in
order
> to