Subject: [manet] Humid IPv6 addresses

From: Pars MUTAF <[email-masked]>
Date: Thu, 9 Nov 2006 22:00:41 +0100

Hi,

Could you please comment on the following I-D ?

http://www.ietf.org/internet-drafts/draft-mutaf-ipv6humid-02.txt

You have experience in ad-hoc mode communication.
Could you please tell me if the usage example
section makes sense?

This I-D is not destined for your WG. It has also other
motivations than wireless ad-hoc netw. But I would
very much appreciate your comments, if you have time.

Regards,

Pars Mutaf

ps: the code is available here (simple, just to show
the basic usage principle):
http://www.freewebs.com/pmutaf/humid_code.tgz

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: David Young <[email-masked]>
Date: Mon, 13 Nov 2006 10:15:52 -0600

> http://www.ietf.org/internet-drafts/draft-mutaf-ipv6humid-02.txt

Why isn't Multicast DNS a solution to the problem you are trying to solve,
i.e., a decentralized, ad hoc name service?

Dave

-- 
David Young             OJC Technologies
[email-masked]      Urbana, IL * (217) 278-3933

---

From: Pars Mutaf <[email-masked]>
Date: Mon, 13 Nov 2006 17:43:17 +0100

> i.e., a decentralized, ad hoc name service?

Thanks for asking THE question.

I don't need multicast DNS, in fact.

Just basic IPv6. 

pars

---

From: David Young <[email-masked]>
Date: Mon, 13 Nov 2006 11:18:33 -0600

> I don't need multicast DNS, in fact.

Let me try another tack: there is no need for HUMID, Multicast DNS
already solves the problem.

Dave

---

From: Pars Mutaf <[email-masked]>
Date: Mon, 13 Nov 2006 18:39:13 +0100

> already solves the problem.

:-) OK. What about this one?:

"Multicast is inefficient, and it should be avoided where possible."

(and with some technologies e.g. wimax, nodes can't multicast, 
but I'm not sure if this point is important in MANET..)

pars