Subject: [manet] Ad-hoc Network Emulator?

From: "Omar Qayyam" <[email-masked]>
Date: Mon, 8 Dec 2008 10:17:04 +0330

Hi all,

Is there any valuable emulator for ad-hoc networks?

Thanks,
--
Qayyam Omar
_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

---

From: Christoph Sommer <[email-masked]>
Date: Mon, 08 Dec 2008 15:45:41 +0100

Dear Omar,

> Is there any valuable emulator for ad-hoc networks?

We've used OMNeT++ to simulate an Ad-Hoc network (based on the DYMO
routing protocol). See
<http://www7.informatik.uni-erlangen.de/~sommer/omnet/dymo/> for info,
docs and downloads of the simulation model and a small scenario.

If you have any questions, just drop me a mail!

Cheers,

  Christoph

---

From: "Henderson, Thomas R" <[email-masked]>
Date: Tue, 9 Dec 2008 22:29:16 -0800

Omar,
 
You might be interested in a new open source emulator project that NRL
has graciously agreed to host.  Details are available here:
http://cs.itd.nrl.navy.mil/work/core/index.php
 
We use this tool quite extensively for our OSPF MANET testing; it comes
with quagga (OSPF MANET-enhanced) built-in, and can run other MANET
protocols, and in general any other FreeBSD applications, directly on
the emulated MANET nodes.
 
Here is a brief flash movie that shows an OSPF MANET emulation example:
http://cs.itd.nrl.navy.mil/work/core/demo3.php
 
We're in the process of setting up the rest of the open source
infrastructure (tracker, wiki) but we have a couple of mailing lists set
up already:
http://pf.itd.nrl.navy.mil/mailman/listinfo/core-dev
http://pf.itd.nrl.navy.mil/mailman/listinfo/core-users
 
- Tom

________________________________

	From: Omar Qayyam [mailto:[email-masked]] 
	Sent: Sunday, December 07, 2008 10:47 PM
	To: [email-masked]
	Subject: [manet] Ad-hoc Network Emulator?

	Hi all,

	Thanks,
	--
	Qayyam Omar

---

From: Bruce M Simpson <[email-masked]>
Date: Sun, 14 Dec 2008 12:31:33 +0000

> Is there any valuable emulator for ad-hoc networks?

There is a protocol simulator in XORP's OLSR code base, although it is 
mostly limited to exercising the implementation.

cheers
BMS