Subject: [manet] On Demand and Hello messages

From: Bringo Shawn <[email-masked]>
Date: Mon, 18 May 2009 12:11:19 -0700 (PDT)

Hi there.I am studing on demand (reactive protocols). Please tell me if I am wrong:A protocol that sends hello messages periodically MAY or MAY NOT be a reactive or on demand protocol but a protocol that plays its role only when it is needed such as a route to some node is required, must be a reactive or on demand protocol. Am I righ?

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 18 May 2009 12:19:09 -0700

Hello,

Yes, this is right.  But maybe it is better to not enforce allegiance
to this definitional characterization.  If periodic HELLO messages
make the protocol work better, it doesn't matter whether that
violates any measure of protocol purity.

Unfortunately, it's usually not so easy measuring "better" unless
you have a goal -- say, reducing latency.  Then, whether or not
to proactively carry out neighborhood discovery would be
determined by checking what is needed to meet your goals.

Regards,
Charlie P.

Bringo Shawn wrote:
> Hi there.
> I am studing on demand (reactive protocols). Please tell me if I am wrong:
> A protocol that sends hello messages periodically MAY or MAY NOT be a 
> reactive or on demand protocol but a protocol that plays its role only 
> when it is needed such as a route to some node is required, must be a 
> reactive or on demand protocol. Am I righ?
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>