Subject: Re: [manet] [Autoconf] call for consensus about link local address support

From: [email-masked]
Date: Tue, 22 Sep 2009 23:54:43 +0200 (CEST)

Hi Charlie,

|> EUI-64 is one mechanism, especially useful when there is a globally
|> unique MAC address available. Any unique MAC address on the box
|> will do.
|> Another practical approach is using random interface-id and accept
|> an almost zero chance on a duplicate.
|
|In the past, some random number generators have been "bad",
|to use the technical nomenclature.  Perhaps you would like to
|make it illegal by international law to enable user-selectable MAC
|addresses.

I'll repeat my opinion: I think DAD is optional. It helps for misbehaving
nodes (or manual configuration). Wellbehaving nodes have the overhead.
And thus I think it is useless. And harmful, because the risk of a DoS
attack.

And yes, random means random.

|>  I don't see a reason why
|> DYMO won't send messages with link-locals.
|
|That one I can answer.  It's because link-locals (almost by definition)
|do not contain any information useful for the purposes of DYMO
|(i.e., creating routes to destination IP addresses).

???
The source IP address of a DYMO message has little to do with routes
to be created. It is needed for 1-hop connectivity only.
So link-locals work well for DYMO :-)
But for sure, the created routes are ULA or global (or new type
"ManetLocal").

Regards, Teco.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 22 Sep 2009 15:14:03 -0700

Hello Teco,

[email-masked] wrote:
> ...
> ...

We don't have to resolve this disagreement right now :-)

> And yes, random means random.

No problem there, but the question is whether or not
random is _achievable_.

> So link-locals work well for DYMO :-)

If they are unique (and exist), they work great.  If they do not
exist, they don't work well for DYMO.  If they aren't unique,
they do not work well for DYMO.  I was never favorable
to restricting DYMO so that it would only be applicable in
situations admitting the configuration of unique link-local
addresses.

And, after all these years, I never regretted that decision.

Regards,
Charlie P.