Subject: [manet] My DYMO Plan

From: Ian Chakeres <[email-masked]>
Date: Fri, 29 Jan 2010 14:30:08 -0500

I am planning to refresh the DYMO draft. My goal is prepare the draft for WGLC and IESG. I aim to tie up any loose ends, and ensure that that the packet format diagrams conform to the PacketBB RFC.

I intend to retain the DYMO identifier (DID) to help ensure consistent configuration among participating DYMO nodes. I had hoped that the several of the MANET protocols would incorporate an ID field for this purpose, but I have not seen strong support for adding this concept into the other MANET protocols.

If you have any feedback on the existing DYMO draft, please feel free to email me your comments/suggestions.

Thanks.
Ian Chakeres

---

From: "Justin Dean" <[email-masked]>
Date: Fri, 29 Jan 2010 16:17:40 -0500

Have you thought about using moving/merging the DID into the security TLV
document (currently personal draft) which does key exchanges also.
Basically use it as a fancy pants identifier.  Although I think that would
be a good spot for a DID type of behavior to live.  Giving a basic or
fallback mode of operation to the security TLV document when keys aren't
available or processing isn't up to the task to do simple ID behaviors would
be a good thing IMO.  It doesn't distinguish between DYMO "areas" but it
could be used for network wide configuration and the DymoID could then be
used as well.

Justin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Ian Chakeres
> Sent: Friday, January 29, 2010 2:30 PM
> To: MANET IETF
> Subject: [manet] My DYMO Plan
> 
> I am planning to refresh the DYMO draft. My goal is prepare the draft
> for WGLC and IESG. I aim to tie up any loose ends, and ensure that that
> the packet format diagrams conform to the PacketBB RFC.
> 
> I intend to retain the DYMO identifier (DID) to help ensure consistent
> configuration among participating DYMO nodes. I had hoped that the
> several of the MANET protocols would incorporate an ID field for this
> purpose, but I have not seen strong support for adding this concept
> into the other MANET protocols.
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Ian Chakeres <[email-masked]>
Date: Fri, 29 Jan 2010 17:35:51 -0500

I support the security TLV concept, but I feel that the DID concept
needs to be part of the base protocol document. Implementing DID as an
extension reduces its usability because one implementation could not
depend on another implementation/configuration to take the proper
action.

As you mentioned, I believe both the security-TLV and DID are
complementary tools.

Thanks.
Ian Chakeres