Subject: Re: [manet] MANET routing module: draft-ramrekha-manet-cam-00.txt

From: Ulrich Herberg <[email-masked]>
Date: Fri, 2 Jul 2010 00:08:51 +0200

Hi,

are there any concrete examples and evaluations how this module can improve
the performance of MANET routing protocols, or how it could simplify
parametrization of these protocols? Is there any implementation of CAM?

Ulrich

On Thu, Jun 24, 2010 at 3:18 AM, Ramrekha, Arvind <[email-masked]
> wrote:

> Dear all,
>
> We have submitted a personal I-D :
>
> Filename: draft-ramrekha-manet-cam-00.txt
> Link:  http://www.ietf.org/id/draft-ramrekha-manet-cam-00.txt
>
> We feel that it presents materials about MANET routing protocols (design
> features e.g. configurable adaptive and hybrid components) and thus should
> be considered by the MANET WG.
>
> The Cognitive and Adaptive Module (CAM) for MANET routing protocols is a
> module that helps in logically segmenting protocol features such as done by
> NHDP to make them cognitive and adaptive.
> This in turn SHOULD help in developing hybrid and adaptive protocols for
> dynamic mobile ad hoc networks. CAM SHOULD also make MANET routing protocols
> more (auto) configurable to suit different use cases and encourage the use
> of MANETs for a wider range of scenarios. This draft also presents the
> design of the hybrid CML protocol (based on OLSRv2 and DYMO features) using
> CAM.
>
> Please provide us with feedback related to this draft.
>
> Kind regards,
>
> Arvind.
>
> Tipu Arvind Ramrekha (PhD Student)
> Wireless & Multimedia Networking (WMN) Research Group
> Faculty of Computing, Information Systems & Mathematics, Kingston
> University London
> Kingston upon Thames
> Tel: +44 (0)20 84177025
> www.kingston.ac.uk/cism
>
> This email has been scanned for all viruses by the MessageLabs Email
> Security System.
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: "Ramrekha, Arvind" <[email-masked]>
Date: Fri, 2 Jul 2010 03:36:50 +0100

Hi

>>are there any concrete examples and evaluations how this module can improve the performance of MANET routing protocols, or how it could simplify parametrization of these protocols? 
Currently, no. But we should shortly have some research based analysis of such a module with initial simulation results. In addition, such a module will give similar benefits to that obtained when segmenting Hello messaging from OLSR into NHDP. It could in a way be regarded as an extension of such work where we would allow implementors to develop their own protocol components while protocols remain interoperable. This may be particularly useful for the application of MANETs in different scenarios where user's requirements differ. For example, ETX metric based routing could be very efficient in user domains where the applications are (delay tolerant, loss intolerant) but not efficient for (delay intolerant, loss tolerant) user applications. Another example cited is bursty traffic environments where OLSR or OLSRv2 proactive route maintenance would not be a green solution if data traffic profile is bursty and sparse.
We also mention a probable use case for OLSRv2, DYMO and NHDP components. 

>>Is there any implementation of CAM?
We are currently working towards implementing such a module to facilitate hybridisation of MANET routing protocols and promoting cross operability of MANET routing protocols. 

We are specifically interested in developing the twining of the ETX metric with another QoS metric so that it could be more suitable for real time applications in MANETs. Is the consideration of the ETX metric alone sufficient to support such applications in a mobile environment? 

Kind regards

Arvind.
________________________________________
From: Ulrich Herberg [[email-masked]]
Sent: 01 July 2010 23:08
To: Ramrekha, Arvind
Cc: [email-masked]; Millar, Grant P; Politis, Christos; Panaousis, Emmanouil
Subject: Re: [manet] MANET routing module: draft-ramrekha-manet-cam-00.txt

Hi,

are there any concrete examples and evaluations how this module can improve the performance of MANET routing protocols, or how it could simplify parametrization of these protocols? Is there any implementation of CAM?

Ulrich

On Thu, Jun 24, 2010 at 3:18 AM, Ramrekha, Arvind <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

We feel that it presents materials about MANET routing protocols (design features e.g. configurable adaptive and hybrid components) and thus should be considered by the MANET WG.

The Cognitive and Adaptive Module (CAM) for MANET routing protocols is a module that helps in logically segmenting protocol features such as done by NHDP to make them cognitive and adaptive.
This in turn SHOULD help in developing hybrid and adaptive protocols for dynamic mobile ad hoc networks. CAM SHOULD also make MANET routing protocols more (auto) configurable to suit different use cases and encourage the use of MANETs for a wider range of scenarios. This draft also presents the design of the hybrid CML protocol (based on OLSRv2 and DYMO features) using CAM.

Kind regards,

Arvind.

Tipu Arvind Ramrekha (PhD Student)
Wireless & Multimedia Networking (WMN) Research Group
Faculty of Computing, Information Systems & Mathematics, Kingston University London
Kingston upon Thames
Tel: +44 (0)20 84177025
www.kingston.ac.uk/cism<http://www.kingston.ac.uk/cism>

This email has been scanned for all viruses by the MessageLabs Email
Security System.
_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet