Subject: Re: [manet] A view on packet-BB

From: JP Vasseur <[email-masked]>
Date: Sun, 1 Apr 2012 18:28:46 -0700

On Apr 1, 2012, at 12:55 PM, JP Vasseur wrote:

> Hi Charlie,
> 
> On Mar 29, 2012, at 7:31 AM, Charles E. Perkins wrote:
> 
>> 
>> Hello folks,
>> 
>> I have not participated very much in any discussions about
>> packet-BB other than to encourage header size reduction and
>> offer a few suggestions about how to achieve it.  During that
>> time, it was claimed that for many networks of interest, the
>> use of packet-BB would *decrease* header size, perhaps
>> especially for proactive protocols.  This is a question
>> very suitable for resolution by way of simulation.
>> 
>> If, as I suspect, packet-BB does (on average) introduce
>> header enlargement on some networks that cannot afford it,
>> I would be in favor to introduce the option to run AODV
>> (or OLSR, for that matter) with some sort of "reduced"
>> header.  This should only be deployed in networks where
>> otherwise there would be no feasible deployment of an
>> ad-hoc networking protocol.  From that perspective, it's
>> almost a no brainer -- either deploy the standard stripped-
>> down version, or deploy something else nonstandard that
>> looks exactly like the stripped-down version.
>> 
>> In summary, if there are cases where the [manet] protocols
>> can only be deployed without packet-BB header overhead,
>> then I think we should provide a solution for those cases.
>> 
>> To be clear, I am happy either way, whether or not packet-BB
>> headers are mandates in all cases.
>> 
>> Also, to be clear, we can standardize AODVv2 *with* packet-BB
>> right now, and submit for consideration another document for
>> AODVv2 that does not require packet-BB.  Or, we can enable both
>> ways in the next revision.  Or, we can standardize AODVv2
>> that does NOT use packet-BB, and then submit for consideration
>> another document that DOES use packet-BB.  All cases are just
>> fine with me, depending on what the working group wants.
> 
> Completely sharing your view.
> 
> Cheers.
> 
> JP.
> 
>> 
>> Regards,
>> Charlie P.
>> 
>> 
>> 
>> 
>> _______________________________________________
>> manet mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/manet
>

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 2 Apr 2012 11:27:20 +0100

Before commenting, could you provide examples please.

I would also note that RFC 5498 mandates use of RFC 5444 on the UDP port and IP protocol that it reserves. This is necessary for interoperability of those protocols that do use those. Other ports/protocols are of course another issue.

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Charles E. Perkins
Sent: 29 March 2012 15:31
To: Manet
Subject: [manet] A view on packet-BB

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

Hello folks,

Regards,
Charlie P.

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: JP Vasseur <[email-masked]>
Date: Sun, 1 Apr 2012 12:55:46 -0700

Hi Charlie,

Cheers.

JP.