Subject: [manet] Congestion avoidance routing in MANET

From: <[email-masked]>
Date: Sat, 28 Apr 2012 15:46:44 +0100

Dear all,

my feeling is that the issues on congestion avoidance in MANET are bogus topic.
I had read a paper entitled on "Adapting connectionless approach to mobile ad hoc networks in obstacle environment "
on Wireless Pervasive Computing, 2006 1st International Symposium on 2006.  the authors found
the packet loss increases if the nodes send more traffic over cross path links. then the cross point
of two paths in MANET could be the congestion area. 

I have quite not agreed with the claim that existing MANET routing " may suffer from packet loss because 
the packet  forwarding policy doesn't consider traffic congestion". 

my fellow colleagues, do you know what scenarios or when the congestion could happen in MANET? 
I don't think the packet loss is due to congestion in high dynamic scenario, it may be occurred due to
link quality becoming bad. therefore, I feel that congestion avoidance routing investigation in MANETs
is a bogus topic, am I right?

Best Regards,

=======================================
Dan He
Research Fellow

---

From: Henning Rogge <[email-masked]>
Date: Sat, 28 Apr 2012 20:15:57 +0200

The problem of "conventional" MANET systems is that when you detect
the congestion, its most likely already to late to do much about it,
because you cannot talk anymore to your neighbors.

The problem with a lot of "too clever" approaches to routing depending
on current traffic  patterns is that they can lead to highly
fluctuating routes or even routing loops.

Henning Rogge

On Sat, Apr 28, 2012 at 16:46,  <[email-masked]> wrote:
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

-- 
Steven Hawkings about cosmic inflation: "An increase of billions of
billions of percent in a tiny fraction of a second. Of course, that
was before the present government."

---

From: Jiazi YI <[email-masked]>
Date: Sun, 29 Apr 2012 15:29:07 +0200

Hi dear Dan,

I didn't read the paper you mentioned before. According to my experience
based on simulation, for example, in a field of 1000m*1000m, with 100
routers, the congestion can happen for the routers in the central area
of the network. There are packets dropped because of the queue is full.

Could you elaborate why you think the congestion avoidance doesn't work,
maybe with some simulation/testbed experience?

best

-- 
Jiazi YI

Hipercom@LIX, Ecole Polytechnique
91128 Palaiseau Cedex France

---

From: <[email-masked]>
Date: Sun, 29 Apr 2012 16:38:36 +0100

Hi Jiazi,

Thanks for your answer. I simply thought that some observations like you found packet loss in simulation
then people concluded that we need congestion avoidance in router that was not entirely true. 
the queue may be in full that the fact of your application injected too much packets into the network.  
This actually brings us back to the fundamental network design question: do we want the network smart 
or MISS?  I would say if too complication mechanism brings into routing layer, it is hard to optimize the
networks. so I would say congestion avoidance  should be put on transportation  protocol, such as
TCP. if we do the same job as TCP does at routing protocol, do we need TCP protocol any more?

Best Regards,

Dan

From: Jiazi YI [[email-masked]]
Sent: 29 April 2012 14:29
To: He D  Dr (CCSR)
Cc: [email-masked]
Subject: Re: [manet] Congestion avoidance routing in MANET

Hi dear Dan,

best

--
Jiazi YI

---

From: Philippe Jacquet <[email-masked]>
Date: Sun, 29 Apr 2012 18:48:02 +0200 (CEST)

In an ideal world, the congestion will disrupt some links and the disruption will be detected by the routing protocol by an increase of route length or by a decrease of route quality. So that traffic will be diverted from congested areas. In real life you may have hysteresis and some other burstiness problems (the capacity of the network is limited afterall), that would require long term traffic shaping such as with TCP. 

Philippe

----- Mail original -----
De: "D He" <[email-masked]>
À: [email-masked]
Envoyé: Samedi 28 Avril 2012 16:46:44
Objet: [manet] Congestion avoidance routing in MANET

Dear all,

Best Regards,

---

From: <[email-masked]>
Date: Sun, 29 Apr 2012 18:08:50 +0100

Thanks Philippe,

It does make sense. so olsrd hysteresis was designed for congestion avoidance purpose or not?

Dan
________________________________________
From: Philippe Jacquet [[email-masked]]
Sent: 29 April 2012 17:48
To: He D  Dr (CCSR)
Cc: [email-masked]
Subject: Re: [manet] Congestion avoidance routing in MANET

Philippe

----- Mail original -----
De: "D He" <[email-masked]>
À: [email-masked]
Envoyé: Samedi 28 Avril 2012 16:46:44
Objet: [manet] Congestion avoidance routing in MANET

Dear all,

Best Regards,

---

From: Henning Rogge <[email-masked]>
Date: Sun, 29 Apr 2012 19:16:20 +0200

It was designed to prevent the traffic-linkmetric feedback loop from
going to overdrive. You need to accumulate data to make a decision
over the quality of a link, if you just take a single event (like a
single lost Hello), you just get too many statistical flukes.

Think about a mesh network where you have two equal paths to your
target. Your network use a very accurate "link congestion/free
airtime" metric and propagates it quickly through the network.

At the start both paths are perfect, so you choose randomly the part A
towards your target.

In the next measurement period your routing protocol notice that path
A now has some congestion and path B is still perfect... so it switch
to B... but now B has congestion and A has none... so you switch back.
I think you see the problem, right?

Henning Rogge

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 30 Apr 2012 09:11:17 +0000

Note that link quality hysteresis is in OLSR (RFC 3626) not invented by olsrd (though the details may differ, I don't know). OLSRv2 uses the term hysteresis more carefully (OLSRv1 didn't quite so carefully distinguish link quality from hysteresis in its wording ) and is less prescriptive in how to do it.

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Henning Rogge
Sent: 29 April 2012 18:16
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [manet] Congestion avoidance routing in MANET

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

Henning Rogge

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************