Subject: [manet] State changed for draft draft-ietf-manet-olsrv2

From: Stan Ratliff <[email-masked]>
Date: Sat, 14 Apr 2012 22:05:38 -0400

All,

Per agreement in Paris, OLSRv2 was to be moved to WGLC with a 30-day  
period. 2 weeks of that period have already passed, so OLSRv2 has been  
moved to WGLC with the last call period ending May 10, 2012.

Regards,
Stan

Begin forwarded message:

> From: IETF Secretariat <[email-masked]>
> Date: April 14, 2012 10:00:57 PM EDT
>
> Subject: State changed for draft draft-ietf-manet-olsrv2
>
> The state of document draft-ietf-manet-olsrv2 has been updated. See  
> more information below.
>
> Previous state: WG Document
> Current state: In WG Last Call
> Transition date: 2012-04-14 19:00
> Author of the change: Stan Ratliff
>
> Comment:
> A 30-day WGLC was agreed to at IETF 83. WGLC will end May 10, 2012.

---

From: Henning Rogge <[email-masked]>
Date: Wed, 18 Apr 2012 10:54:33 +0200

> moved to WGLC with the last call period ending May 10, 2012.

I have a question about the Local Attached Network Set (section 7.2) and 
its usage during routing.

Attached networks have both a link metric and a 'hopcount distance'. Do 
I understand the current draft correct that the metric is used for 
selecting the attached network the node will route to (there can be 
multiple nodes with the same attached network!) and that the hopcount 
field is just used to set the distance field in the kernel routing table?

Henning Rogge

-- 
Diplom-Informatiker Henning Rogge , Fraunhofer-Institut für
Kommunikation, Informationsverarbeitung und Ergonomie FKIE
Kommunikationssysteme (KOM)
Neuenahrer Straße 20, 53343 Wachtberg, Germany
Telefon +49 228 9435-961,   Fax +49 228 9435 685
mailto:[email-masked] http://www.fkie.fraunhofer.de
GPG: E1C6 0914 490B 3909 D944 F80D 4487 C67C 55EC CFE0

---

From: Ulrich Herberg <[email-masked]>
Date: Wed, 18 Apr 2012 15:22:49 -0700

Hi Henning,

I think the answer to your question is "yes"

:-)

Ulrich

On Wed, Apr 18, 2012 at 1:54 AM, Henning Rogge
<[email-masked]> wrote:
> I have a question about the Local Attached Network Set (section 7.2) and its
> usage during routing.
>
> Attached networks have both a link metric and a 'hopcount distance'. Do I
> understand the current draft correct that the metric is used for selecting
> the attached network the node will route to (there can be multiple nodes
> with the same attached network!) and that the hopcount field is just used to
> set the distance field in the kernel routing table?
>
> Henning Rogge
>
>
> --
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Thu, 19 Apr 2012 13:14:05 +0000

+1

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: Ulrich Herberg [mailto:[email-masked]] 
Sent: 18 April 2012 23:23
To: Henning Rogge
Cc: [email-masked]; Dearlove, Christopher (UK)
Subject: Re: [manet] State changed for draft draft-ietf-manet-olsrv2

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

Hi Henning,

:-)

Ulrich

> set the distance field in the kernel routing table?

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Teco Boot <[email-masked]>
Date: Thu, 19 Apr 2012 15:26:30 +0200

I would say: yes, no.

Yes: metric is used for path selection.
No:  hop-count is not to be used for putting in a routing table.

The "distance" info in routing tables is afaik not standardized.
Could be info-only, could be used as selector when multiple
routing protocols provide same paths. Or whatever.

Putting hop-count in a info-only attribute may be implemented.
It could be used as tie-breaker for single path / limited paths.
This needs no standardization.

Question: add OLSR hop_count to AL_dist? OLSR hop-count is for 
signaling, not for actual paths.

Teco

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Thu, 19 Apr 2012 13:41:06 +0000

That's a useful qualification. The hop count is available to be put in an IP routing table that (as at least some do) requires a hop count. OLSRv2 does not (as it says) mandate what you do with the Routing Set, just that it creates a Routing Set, which you can do whatever you like with. But of course in the real world, using the Routing Set to update the IP routing table is its main function. We ensure that the Routing Set has a hop count (R_dist) as well as a metric (R_metric) for when that's wanted. In order to have an R_dist, we need an AL_dist that sets the a hop count in a GATEWAY TLV, which hence sets an AN_dist in other routers, and hence R_dist. We already have all those. We also have an AL_metric and an AN_metric. Those are used for shortest path selection with length R_metric. Again, it's up to the implementation whether it records R_metric (which is a 32 bit value, thought will almost always be well short of that value) or anything derived from it.

R_dist does make a sensible, but not mandatory, tie-breaker for tied R_metric values.

-----Original Message-----
From: Teco Boot [mailto:[email-masked]] 
Sent: 19 April 2012 14:27
To: Ulrich Herberg; Henning Rogge
Cc: Dearlove, Christopher (UK); [email-masked] IETF
Subject: Re: [manet] State changed for draft draft-ietf-manet-olsrv2

I would say: yes, no.

Teco