Subject: Re: [manet] LOADng and handling this in LLN

From: JP Vasseur <[email-masked]>
Date: Sun, 1 Apr 2012 18:28:15 -0700

On Apr 1, 2012, at 12:59 PM, JP Vasseur wrote:

> 
> On Mar 30, 2012, at 2:31 AM, Teco Boot wrote:
> 
>> Before we (MANET WG) take a look to LOADng, we should discuss 
>> options for getting progress on decisions being made before. If 
>> the outcome is that we should look for alternatives for DYMO (or 
>> AODVv2, if WG accepts the name change as suggested and already 
>> effected by current WG doc editor).
>> 
>> Don't take me wrong, I do in no way say LOADng is not relevant.
>> I say: lets try to focus on what we decided to do, or discuss
>> new options if we need to. In that order.
> 
> Makes total sense to me too.
> 
> JP.
> 
>> 
>> Teco
>> 
>> 
>> Op 30 mrt. 2012, om 11:19 heeft Ulrich Herberg het volgende geschreven:
>> 
>>> Teco,
>>> 
>>> I don't think we compete with ROLL in this regards.
>>> 
>>> MANET is chartered to come up with a reactive protocol (and largely
>>> behind schedule). LOADng is a reactive protocol, and has many
>>> industrial, large-scale deployments and implementations. I believe the
>>> specification is in a very good shape, and close to being ready
>>> besides minors nits (and missing security considerations section). But
>>> we have already assigned the different tasks to the different authors,
>>> so I believe we will submit a new revision very soon with these issues
>>> fixed.
>>> 
>>> Of course, if the WG is interested in LOADng, editorial things (such
>>> as the word "MANET" or "LLN") may likely have to be changed, to make
>>> clear it is a MANET protocol.
>>> 
>>> We will certainly have a discussion amongst the authors to see if we
>>> can accommodate RFC5444. My personal believe is (strictly as
>>> individual WG member, not as opinion of the collective of the LOADng
>>> authors) that any reactive document in MANET should be RFC5444
>>> compliant.
>>> 
>>> Regards
>>> Ulrich
>>> 
>>> 
>>> On Thu, Mar 29, 2012 at 5:16 PM, Teco Boot <[email-masked]> wrote:
>>>> OK.
>>>> 
>>>> My message is that we (MANET) should not compete with ROLL. If someone
>>>> thinks it makes sense, or not, to use RFC 5444 for LLN, post it in ROLL.
>>>> 
>>>> If someone has idea's how to get the reactive manet protocol doc published
>>>> soon, great. I saw someone spending cycles on it. My turn to say thanks.
>>>> 
>>>> Teco
>>>> 
>>>> 
>>>> Op 29 mrt. 2012, om 17:00 heeft Emmanuel Baccelli het volgende geschreven:
>>>> 
>>>> Hi Teco,
>>>> maybe I was not clear enough in my previous email: there is no suggestion to
>>>> use packetBB in any ROLL draft I am aware of.
>>>> I meant that, so far, a MANET protocol (and thus AODVv2) is by default
>>>> supposed to use packetBB, whereas other protocols may not have to use packet
>>>> BB.
>>>> Emmanuel
>>>> 
>>>> 
>>>> On Thu, Mar 29, 2012 at 4:36 PM, Teco Boot <[email-masked]> wrote:
>>>>> 
>>>>> I saw someone presenting a reactive p2p routing protocol in ROLL. I was
>>>>> not aware of a suggestion on using packetBB. If you think it is useful, you
>>>>> could post it over there.
>>>>> 
>>>>> Teco
>>>>> 
>>>>> 
>>>>> Op 29 mrt. 2012, om 15:59 heeft Emmanuel Baccelli het volgende geschreven:
>>>>> 
>>>>> Hi Teco,
>>>>> that is a good question. Actually, as far as I can see, LOADng mainly
>>>>> derives from AODV, and so does AODVv2, obviously.
>>>>> Maybe there is a way to simply "reconcile" the two approaches and have
>>>>> just one protocol (as I tried to express on the mic today).
>>>>> At first sight the main difference between the two approaches is probably
>>>>> the use of packetBB, so far mandatory in MANET.
>>>>> Hence my question about the advantages of NOT using packetBB: I suppose it
>>>>> has to do with the size of packets being bigger, and maybe more difficult to
>>>>> fit into small frames such as radio frames used in some LLNs, indeed?
>>>>> Emmanuel
>>>>> 
>>>>> 
>>>>> 
>>>>> On Thu, Mar 29, 2012 at 3:38 PM, Teco Boot <[email-masked]> wrote:
>>>>>> 
>>>>>> For the record, I repeat a remark I made on the mic.
>>>>>> It looks to me LOADnd is targetted for the LLN use case
>>>>>> and IETF has a wonderful WG for this. It is not MANET.
>>>>>> 
>>>>>> Teco
>>>>>> _______________________________________________
>>>>>> manet mailing list
>>>>>> [email-masked]
>>>>>> https://www.ietf.org/mailman/listinfo/manet
>>>>> 
>>>>> 
>>>>> _______________________________________________
>>>>> manet mailing list
>>>>> [email-masked]
>>>>> https://www.ietf.org/mailman/listinfo/manet
>>>>> 
>>>>> 
>>>>> 
>>>>> _______________________________________________
>>>>> manet mailing list
>>>>> [email-masked]
>>>>> https://www.ietf.org/mailman/listinfo/manet
>>>>> 
>>>> 
>>>> _______________________________________________
>>>> manet mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/manet
>>>> 
>>>> 
>>>> 
>>>> _______________________________________________
>>>> manet mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/manet
>>>> 
>> 
>> _______________________________________________
>> manet mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/manet
>

---

From: JP Vasseur <[email-masked]>
Date: Sun, 1 Apr 2012 18:28:38 -0700

On Apr 1, 2012, at 12:57 PM, JP Vasseur wrote:

> 
> On Mar 29, 2012, at 8:23 AM, Stan Ratliff (sratliff) wrote:
> 
>> For the record, we're not trying to compete with ROLL. We have a charter item to produce a reactive routing protocol for MANET's. Work had effectively stopped on said reactive protocol for some time. We need to either (1) continue work on a reactive MANET protocol, or (2) go back to the AD's and tell them we've decided against it. So, I think it's logical to look at current reactive protocols like LOADng to see if they fit the MANET space. I've looked at RPL, and speaking as a working group membet (taking my co-chair hat off for a second), I don't believe RPL fits in the networks we deploy. Does LOADng? Good question.
> 
> Agree Stan. And I'd like to point out that LLN is not a type of mobile network … the fact that links are lossy and thus the
> topology is dynamic is not equivalent to a MANET 
> 
> Cheers.
> 
> JP.
> 
>>  
>> Regards,
>> Stan
>> 
>> From: [email-masked] on behalf of Teco Boot
>> Sent: Thu 3/29/2012 11:16 AM
>> To: Emmanuel Baccelli
>> Cc: [email-masked] IETF
>> Subject: Re: [manet] LOADng and handling this in LLN
>> 
>> OK.
>> 
>> My message is that we (MANET) should not compete with ROLL. If someone thinks it makes sense, or not, to use RFC 5444 for LLN, post it in ROLL.
>> 
>> If someone has idea's how to get the reactive manet protocol doc published soon, great. I saw someone spending cycles on it. My turn to say thanks.
>> 
>> Teco
>> 
>> 
>>> maybe I was not clear enough in my previous email: there is no suggestion to use packetBB in any ROLL draft I am aware of.
>>> I meant that, so far, a MANET protocol (and thus AODVv2) is by default supposed to use packetBB, whereas other protocols may not have to use packet BB.
>>> Emmanuel
>>> 
>>> 
>>> I saw someone presenting a reactive p2p routing protocol in ROLL. I was not aware of a suggestion on using packetBB. If you think it is useful, you could post it over there.
>>> 
>>> Teco
>>> 
>>> 
>>>> that is a good question. Actually, as far as I can see, LOADng mainly derives from AODV, and so does AODVv2, obviously.
>>>> Maybe there is a way to simply "reconcile" the two approaches and have just one protocol (as I tried to express on the mic today).
>>>> At first sight the main difference between the two approaches is probably the use of packetBB, so far mandatory in MANET.
>>>> Hence my question about the advantages of NOT using packetBB: I suppose it has to do with the size of packets being bigger, and maybe more difficult to fit into small frames such as radio frames used in some LLNs, indeed?
>>>> Emmanuel
>>>> 
>>>> 
>>>>

---

From: JP Vasseur <[email-masked]>
Date: Sun, 1 Apr 2012 18:28:54 -0700

On Apr 1, 2012, at 12:56 PM, JP Vasseur wrote:

> Hi,
> 
> On Mar 29, 2012, at 8:00 AM, Emmanuel Baccelli wrote:
> 
>> Hi Teco,
> Correct.

---

From: JP Vasseur <[email-masked]>
Date: Sun, 1 Apr 2012 18:28:58 -0700

On Apr 1, 2012, at 12:54 PM, JP Vasseur wrote:

> Hi Emanuel,
> 
> On Mar 29, 2012, at 6:59 AM, Emmanuel Baccelli wrote:
> 
>> Hi Teco,
> JP> Absolutely ! I would have made the same comment, sorry I did not know that the discussion was at the agenda.
> 
> JP> Not sure … if targeted for LLNs, we have one protocol with two flavors already, one being reactive for environments
> where Load-ng seems to operate …
> 
> Thanks.
> 
> JP.
> 
>> Emmanuel
>> 
>> 
>>

---

From: JP Vasseur <[email-masked]>
Date: Sun, 1 Apr 2012 12:54:19 -0700

Hi Emanuel,

Thanks.

JP.

---

From: JP Vasseur <[email-masked]>
Date: Sun, 1 Apr 2012 12:56:10 -0700

Hi,

Correct.

JP.

---

From: JP Vasseur <[email-masked]>
Date: Sun, 1 Apr 2012 12:57:54 -0700

Cheers.

JP.

---

From: JP Vasseur <[email-masked]>
Date: Sun, 1 Apr 2012 12:59:13 -0700

JP.

---

From: Thomas Heide Clausen <[email-masked]>
Date: Mon, 2 Apr 2012 17:42:45 +0200

Hi JP,

> topology is dynamic is not equivalent to a MANET 

I think that it is clear that LOADng works well for scenarios where RPL doesn't - which is the whole raison d'etre for LOADng. 

I do not really believe that this has anything to do with "mobility", though, although supporting also that is a nice benefit and a reason for discussing this also in MANET.

Best,

Thomas

---

From: JP Vasseur <[email-masked]>
Date: Mon, 2 Apr 2012 08:54:04 -0700

Hi Thomas,

On Apr 2, 2012, at 8:42 AM, Thomas Heide Clausen wrote:

> I think that it is clear

Could you elaborate a bit more ?

> that LOADng works well for scenarios where RPL doesn't - which is the whole raison d'etre for LOADng. 
> 

And provide more data ?

> I do not really believe that this has anything to do with "mobility", though, although supporting also that is a nice benefit and a reason for discussing this also in MANET.

So that we all understand, is Load-ng a MANET protocol or a reactive protocol for LLN ?

Thanks.

JP.

---

From: Thomas Heide Clausen <[email-masked]>
Date: Mon, 2 Apr 2012 17:55:59 +0200

Hi JP,

>> that LOADng works well for scenarios where RPL doesn't - which is the whole raison d'etre for LOADng. 

For example, it does avoid many of the inconveniences listed in the RPL-Experiences draft.

> So that we all understand, is Load-ng a MANET protocol or a reactive protocol for LLN ?

Yes - to both.

Best,

Thomas

---

From: JP Vasseur <[email-masked]>
Date: Mon, 2 Apr 2012 12:46:04 -0700

Dear Thomas,

> For example, it does avoid many of the inconveniences listed in the RPL-Experiences draft.

But as you know, introducing a reactive routing protocol in LLNs introduces a number of issues, listed in various papers.
This is the reason why the ROLL WG ended up electing a pro-active for LLN after years of work and discussion in the WG
group, just wanted to share it with the MANET WG.

>> So that we all understand, is Load-ng a MANET protocol or a reactive protocol for LLN ?

In the former case, then discussion should be taken place here (talking under the control of the MANET WG's chairs of course).
In the later case, ROLL is the place to discuss it but already made a decision on this ...

Best Regards.

JP.