Subject: Re: [manet] I-D Action: draft-ietf-manet-olsrv2-15.txt

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 16 May 2012 18:03:30 +0200

Hi Herberg,

I had some comments on OLSRv2-14 and I was informed that there will be
no change only if rough consensus. Now I received a new draft
OLSRv2-15 announced, does this mean that suggestions (to add
explainations) as in the discussion had no rough consensus so no
change is needed? or does it mean that no one has responded to the
confusion observed so it was with no value?

Please note that I need to know the outcome decision of the MANET-WG,
so I can know how to review OLSRv2-15, or I wait for the decision
result to the suggestion of adding explainations in the previous draft
14. Thanking you,

Abdussalam Baryun,
University of Glamorgan, UK

++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Abdussalam,

so far, nobody else seemed to be confused on which layer OLSRv2 is
used (or how the interfaces are defined). IMO, unless other people in
the WG see the same danger of confusion, I would not change it.

Regards
Ulrich

+++++++++++++++++++++++++++++++++++++++++++++++++++++++

The IETF does not work by means of "majority" (which is not even
possible since there is no formal membership), but by rough consensus
(and running code). And every individual can (and should!) review a
document and give suggestions, which can help to improve a document. I
just don't see how your suggestions about the MANET/OLSRv2 interfaces
would improve the OLSRv2 draft (for the reasons that Chris, Thomas and
I have pointed out).

Regards
Ulrich

---

From: Ulrich Herberg <[email-masked]>
Date: Wed, 16 May 2012 10:16:14 -0700

Abdusallam,

OLSRv2-15 only contains some minor editorial updates (spelling mistakes and
grammatical errors) and no change to the specification.

Best regards
Ulrich

---

From: Stan Ratliff <[email-masked]>
Date: Wed, 16 May 2012 14:00:52 -0400

Abdusallam, 

I would add - the Working Group Last Call (WGLC) period for this document has expired. OLSRv2-15 is intended to be sent forward to the area directors and the IESG for their review, and ultimately, publication as a standards track RFC. Your comments on this draft are welcome on the list, but don't expect anything to change - unless, of course, you've found a "doomsday scenario" where OLSRv2 completely breaks down… ;-)

Regards,
Stan

On May 16, 2012, at 1:16 PM, Ulrich Herberg wrote:

> Abdusallam,
> 
> OLSRv2-15 only contains some minor editorial updates (spelling mistakes and grammatical errors) and no change to the specification.
> 
> Best regards
> Ulrich
> 
> On Wed, May 16, 2012 at 9:03 AM, Abdussalam Baryun <[email-masked]> wrote:
> Hi Herberg,
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 17 May 2012 21:14:00 +0200

Hi Stan,

I thought that for olsrv2-14 the last call expires on 10.05.2012 (my
suggestion submitted before 10 May), but then I received the notice of
olsrv2-15 on 15.05.2012. I did not expect changes, but I expected to
know the outcome of the WG decision regarding suggestions. I just
expect a respond from WG to my input. The authors' decision or respond
was received, but not the group's.

However, I understand from your reply that the decision of the WG is:
there is no need for updates to the OLSRv2-14 and OLSRv2-15 documents.
Thanking you,

Abdussalam Baryun,
University of Glamorgan, UK
+++++++++++++++++++++++++++++++++++++++++++++++++++

On 5/16/12, Stan Ratliff <[email-masked]> wrote:
> Abdusallam,
>
> I would add - the Working Group Last Call (WGLC) period for this document
> has expired. OLSRv2-15 is intended to be sent forward to the area directors
> and the IESG for their review, and ultimately, publication as a standards
> track RFC. Your comments on this draft are welcome on the list, but don't
> expect anything to change - unless, of course, you've found a "doomsday
> scenario" where OLSRv2 completely breaks down… ;-)
>
> Regards,
> Stan
>
>> OLSRv2-15 only contains some minor editorial updates (spelling mistakes
>> and grammatical errors) and no change to the specification.
>>
>> Best regards
>> Ulrich
>>

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 17 May 2012 21:45:42 +0200

Hi Ulrich,

It was suggested adding information for clarification without touching
specification. however, comparing OLSRv2-14 to OLSRv2-15 it seems not
minor grammer error, but minor words/sentences replacings or delets.

Regards
Abdussalam
============

---

From: Ulrich Herberg <[email-masked]>
Date: Thu, 17 May 2012 13:26:07 -0700

Abdussalam,

I am not quite sure what you request. Your comments during the WGLC
have been heard, and the authors replied to your emails, arguing why
we believe that the current terminology is fine. There did not seem to
be any WG consensus that there should be changes like you suggested.

Best regards
Ulrich

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 18 May 2012 09:00:35 +0200

Ulrich,

I did not request first it was a respond to the call. I received the
request/call of drafts olsrv2-14 and now olsrv2-15, so I responded
suggestions, and for last-call-olsrv2-14 (expirs 10.05.2012) I
requested before the expiry to adding information to the document to
avoid confusions, because I while reading it was confused. I discussed
with authors and they didn't agree to add information. Then I
requested a respond from the WG to my input, so we can have progress
in the review process or WG process. Then I received the chair respond
which I will understand is the WG respond to the suggestions.

 If I received a respond from the WG to the suggestion (i.e. it was
the only respond to the last call request of olsrv2-14) I would not
have send a request of wg respond. It is in the procedure for working
group process RFC2418.

Best Regards

Abdussalam Baryun
University of Glamorgan, UK
+++++++++++++++++++++++++++++++++

On 5/17/12, Ulrich Herberg <[email-masked]> wrote:
>>> and

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 18 May 2012 09:17:31 +0000

The was a WGLC on OLSRv2, which happened to be at -14. Typical practice after a WGLC concludes is to produce a revised document incorporating any changes, which in this case happens to be -15. Note that -15 didn't appear until after WGLC had closed, so it is not relevant to the submission of comments in response to that call. This sort of upissue does not re-open a WGLC unless in the opinion of the WG chairs, responsible AD etc. the changes are significant and require that. I don't speak for those people, but their actions go along with that, and the authors would have been surprised otherwise. The changes made mostly represent nits that the authors (who also reviewed the document) found. Most aren't actually errors but just the usual editorial process of tightening wording. I see nothing that contradicts RFC 2418, and I've now seen this process happen five times for a document I'm an author of, all similarly.

Within the WGLC the authors responded to your comments. No one else chose to support them, and hence there was clearly no consensus (and probably a consensus against) making those changes.

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Abdussalam Baryun
Sent: 18 May 2012 08:01
To: Ulrich Herberg
Cc: [email-masked]; manet; [email-masked]
Subject: Re: [manet] I-D Action: draft-ietf-manet-olsrv2-15.txt

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

Ulrich,

Best Regards

Abdussalam Baryun

>> minor grammer error, but minor words/sentences replacings or delets.
_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 18 May 2012 14:03:55 +0200

Hi Chris,

On 5/18/12, Dearlove, Christopher (UK) <[email-masked]> wrote:
> The was a WGLC on OLSRv2, which happened to be at -14. Typical practice
> after a WGLC concludes is to produce a revised document incorporating any
> changes, which in this case happens to be -15. Note that -15 didn't appear
> until after WGLC had closed, so it is not relevant to the submission of
> comments in response to that call. This sort of upissue does not re-open a
> WGLC unless in the opinion of the WG chairs, responsible AD etc. the changes
> are significant and require that. I don't speak for those people, but their
> actions go along with that, and the authors would have been surprised
> otherwise.

I have no problem with the issue 15 after closing WGLC, but was
expecting to see result of my input to the last call of draft-14. It
is reasonable for reviewers to see the response (WG respond and
decision if they don't agree with authors) to their comments on 14
before receiving the 15. IMHO it is good for the process, if the group
thinks that things are not required it informs who thinks it is
required.

> The changes made mostly represent nits that the authors (who also
> reviewed the document) found. Most aren't actually errors but just the usual
> editorial process of tightening wording. I see nothing that contradicts RFC
> 2418, and I've now seen this process happen five times for a document I'm an
> author of, all similarly.
>

I have read once in RFC2418 that means if a suggestion required, the
group concensus can be collected. My comments reported a confusion in
reply to the last call, and I wanted to see the process reaction to
this input. Therefore, I needed a response from the group. However, I
received from the group chair the response after the 15 issue, that 14
was intended to sent forward. If I knew that I will not make an input
for 14, and not sure why we have last call not mentioning this
important information? In addition, the issue of suggestion of big
change or minor change I don't read it in 2418, I think any suggestion
is respected the same value.

> Within the WGLC the authors responded to your comments. No one else chose to
> support them, and hence there was clearly no consensus (and probably a
> consensus against) making those changes.
>
I agree with you, authors were helpful to address their position which
I am not confused any more after the discussion. Other readers in the
future may have the same, however, their was no one other than authors
responded infavour nor against, and that is why I replied when I
received the announcement of 15 (i.e. the subject title).

I thank you for your reply,

Abdussalam Baryun

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 18 May 2012 16:14:29 +0200

Hi

I beleive that olsrv2-15 has important sentences changes which change
few previous information meanings (which I agree on). If undertood
correctly the changes were made by authors revision decision.

 I want to know why were the below changes made, because the
explanation will help the WG in better understanding of the minor
amendments or of the new issue 15?

OLSRv2-15 Deleted the below paragraph:

Enables source routing, i.e., each router can use its local
information provided by this protocol to specify the complete path
for a packet. (This will require the retention of additional
information during the Routing Set evaluation.)
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
In OLSRv2-14:

OLSRv2, as defined in this specification, allows links to have a
metric (also known as a cost). Link metrics as defined in OLSRv2 are
additive, and the routes that are to be created are minimum length
routes, where the length of a route is defined as the sum of the
metrics of the links in that route.

In OLSRv2-15 Replaced above by:

OLSRv2, as defined in this specification, supports metric-based
routing, i.e., it allows links to each have a chosen metric. Link
metrics as defined in OLSRv2 are additive, and the routes that are to
be created are those with the minimum sum of the link metrics along
that route.
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

In OLSRv2-14:

R_local_iface_addr is the network address of the local OLSRv2
interface over which an IP packet MUST be sent to reach the
destination by the selected path.

In OLSRv2-15 Replaced by:

R_local_iface_addr is an address of the local interface over which
an IP packet MUST be sent to reach the destination by the selected
path.

Thanking you,

Abdussalam Baryun

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 18 May 2012 14:37:41 +0000

Nothing here is significant.

The source routing point (which is purely explanatory, it has no effect on the protocol) removed a late added observation that actually there's been no demand for, and had a technical problem that source routing would only progress to external gateways, not beyond them. It seemed pointless to retain it, as all it did was point out you could do something, but not how to do it.

The second point is entirely editorial, simplifying text to just use the term metric.

The third point essentially corrected from "the" address to "an" address, because an interface can have more than one address, and then cleaned up wording.

Anyone with an implementation of OLSRv2 would not have to change even a comment in that code, let alone any function.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Abdussalam Baryun
Sent: 18 May 2012 15:14
To: manet
Subject: Re: [manet] I-D Action: draft-ietf-manet-olsrv2-15.txt

Hi

In OLSRv2-14:

Thanking you,

Abdussalam Baryun

---

From: Stan Ratliff <[email-masked]>
Date: Fri, 18 May 2012 10:51:50 -0400

> thinks that things are not required it informs who thinks it is

It has never been the process (at least in the MANET working group) to formally track each and every comment coming in on a draft and actively notify/dispose of said items. This is rooted in the notion that the IETF is a volunteer organization; as such, we've all got "day jobs", and do the best we can. Another reason for this (slightly informal) process model is to keep the group from spinning ad-nauseum, generating vast amounts of email on trivial topics. This discussion is a reasonably good example of that very thing. 

You made some comments/suggestions on OLSRv2. They were considered by the authors, and by the working group members. The authors didn't agree with you in all cases, and the working group, via its silence, indicated *they* didn't agree with you either. And now, apparently, you want to re-litigate all or part of that. I for one am not interested. 

My opinion is that OSLRv2-15 has cleared WGLC, and will be forwarded to the AD's/IESG for review and publication. If the working group members *DO NOT* agree with me, then let the fire-storm of emails commence.

Regards,
Stan

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 19 May 2012 09:41:33 +0200

Dear All,

I beleive that we are all informally equal in terms of rights and
responsibilities, but in organisations we have formal responsibilities
and rights to make work-processes progress to the direction of the aim
and objectives of the organisation, not in the direction of some
individuals decisions. I beleive the best practice for IETF groups is
in RFC2418 and RFC3934.

On 5/18/12, Stan Ratliff <[email-masked]> wrote:
> It has never been the process (at least in the MANET working group) to
> formally track each and every comment coming in on a draft and actively
> notify/dispose of said items. This is rooted in the notion that the IETF is
> a volunteer organization; as such, we've all got "day jobs", and do the best
> we can. Another reason for this (slightly informal) process model is to keep
> the group from spinning ad-nauseum, generating vast amounts of email on
> trivial topics. This discussion is a reasonably good example of that very
> thing.

The process for MANET WG SHOULD follow the RFC2418. IMHO the IETF is a
formal organisation, and yes it is structured of volunteering members,
but it is not informal organisation. Please note that number of emails
SHOULD not be restricted, but the content of messages MAY be
restricted. Yes our relationships are RECOMMENDED to be friendly and
informally social to inhance the group activities.

All informal models give chances of more power to organisation
managers. I don't agree with the informal-process model, but agree
with RFC2418-process model.

>
> You made some comments/suggestions on OLSRv2. They were considered by the
> authors, and by the working group members. The authors didn't agree with you
> in all cases, and the working group, via its silence, indicated *they*
> didn't agree with you either. And now, apparently, you want to re-litigate
> all or part of that. I for one am not interested.
>

Silence is not a reaction (e.g. not an indication), because as you
mentioned we are volunteers and we have jobs, therefore, silence most
possibility means I am bussy, not meaning I agree nor disagree.

> My opinion is that OSLRv2-15 has cleared WGLC, and will be forwarded to the
> AD's/IESG for review and publication. If the working group members *DO NOT*
> agree with me, then let the fire-storm of emails commence.
>

I reply to this call that I *DO NOT* agree to give forward to
OLSRv2-14 or OLSRv2-15 until I comment on it, or only after concensus
collected for the decision (i.e. it is easy to collect electronically,
as in RFC2418 does not have to be face-to-face collecting). Regarding
the OLSRv2-15 draft it is better than OLSRv2-14 because it reduced my
confusions, but I will need some time to review OLSRv2-15 and comment
on it as well. Regarding fire-storm emails, it seems it will not be
happening in MANET WG, maybe active memebrs are about 60, not sure.

In conclusion, from the group chair last message, I understand that
there was no concensus collected for OLSRv2 to go forward, so the
MANET-WG still didn't make last decision yet.

I am sorry if I made any disturbing to any. In the end of all
processes I am interested in understanding and participating in IETF.
If the group or group chairs decides that I stop emailing in MANET, I
will stop without any complains to higher levels, and go to another
IETF group. Thanking you,

Best Regards,
Abdussalam

>>> Registered Office: Warwick House, PO Box 87, Farnborough Aerospace
>>> Centre,
>>> Farnborough, Hants, GU14 6YU, UK
>>> From: [email-masked] [mailto:[email-masked]] On Behalf
>>> Of
>>> Abdussalam Baryun
>>> Sent: 18 May 2012 08:01
>>> To: Ulrich Herberg