Subject: [manet] On the scope of NHDP-sec-threats

From: Jiazi Yi <[email-masked]>
Date: Tue, 15 May 2012 23:35:11 +0200

Hi dear all,

In the Paris IETF, we had lots of valuable comments on the nhdp-sec-threats document, and it was adopted as wg document. 
In the discussion, the issue concerned most is the scope of the document: should we include the common attacks for networks, and the interaction with protocols using NHDP (OLSRv2, SMF, ...). 

Regarding the common attacks, the idea is that it's necessary to include the common threats in wireless networks that are remarkable in MANET neighbor discovery procedure. It's inevitable to have some overlaps with other threat documents, but we think it's worth to emphasize those critical threats for NHDP. 
Currently, we have the jamming and eavesdropping in the document. For jamming, it is an important attack vector in this kind of decentralized environment because of restricted resource, especially when the HELLO message can be triggered by state change of the network - which is further discussion in the "indirect jamming" section.  For eavesdropping, it provides network information required for enabling other attacks, such as link/node spoofing, which are introduced in later sections. 

The current revision of the document also includes a section for the impacts on protocols using NHDP. The rationale is that, as a neighbor discovery protocol, NHDP is used in combination with other protocols most of the time. Therefore, the document describes how the those protocols might be disrupted by the misbehavior of NHDP (in common sense, such as MPR calculation, data sinkhole, etc. ). If we are going to produce more threats documents in the future, there is no need to worry about those common ones in NHDP (for example, we probably don't want to discuss the threats in MPR selection in both SMF-threats and OLSRv2-threats). 

Of course, we are also looking for more comments on the vulnerabilities proposed in the documents, and new possible attacks. 

best

YI Jiazi

http://www.jiaziyi.com
Hipercom@LIX, Ecole Polytechnique
Route de Saclay 91128 Palaiseau Cedex France

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 16 May 2012 13:59:31 +0200

Hi

>In the Paris IETF, we had lots of valuable comments on the nhdp-sec-threats >document, and it was adopted as wg document.
>In the discussion, the issue concerned most is the scope of the document: should >we include the common attacks for networks, and the interaction with protocols >using NHDP (OLSRv2, SMF, ...).

In general, both common and interaction attacks need to be documented
per protocol, it is more useful to have the scope of protocol's
vulnerability without excluding common network attacks and issues. Any
additional attacks should be considered, otherwise the document scope
section should specify if it excludes something.

>The current revision of the document also includes a section for the impacts on >protocols using NHDP. The rationale is that, as a neighbor discovery protocol, >NHDP is used in combination with other protocols most of the time. Therefore, the >document describes how the those protocols might be disrupted by the >misbehavior of NHDP (in common sense, such as MPR calculation, data sinkhole, >etc. ). If we are going to produce more threats documents in the future, there is no >need to worry about those common ones in NHDP (for example, we probably don't >want to discuss the threats in MPR selection in both SMF-threats and OLSRv2->threats).

Maybe you mean only threats-documents that use NHDP, so they need to
refer to this NHDP-sec-threats document, but if a protocol is not
using NHDP, it is important that its threat document scope includes
all attacks/threats possibilities.

Abdussalam Baryun
University of Glamorgan, UK.