Subject: Re: [manet] Reactive Protocol Situation

From: Jon Black <[email-masked]>
Date: Wed, 31 Oct 2012 10:48:49 -0700 (PDT)

Certainlysmart meters are one of the types of networks that are MANETs.  Just because houses do not move it does not mean that the connectivity between those meters isn't changing.  A smart meter network is most certainly a MANET.  [One could argue that it is not an LLN since at least from the electrical power there is no lack of power.]

Totally agree that one size does not fit all.

  Jon

On October 31, 2012 John.Dowdell wrote:

While I am very pleased for you and your
co-authors that the LOADng work has been so fruitful, I am not really sure that
smart meters are really the kind of MANET devices that the working group was
intended to address. I have been party to the conversations for only a year or two,
so I am very happy to be corrected by those with longer histories, but MANET to
me means dynamically moving nodes, with links being established and broken often
and without prior warning. Examples may be communications networks built out of
nodes contained in cars, trucks and aircraft of all sizes. I appreciate a
comment on the list a while back that the RF environment for smart metering is
actually more difficult than one would think, but I would suggest to the chairs
that unless LOADng has applications in this dynamically mobile environment (and
I have to admit I have not read the spec in enough detail to determine if this
is the case), then we come to the conclusion that the DYMO/AODVv2 path should
be followed unless we collectively feel that such a direction is not worth
pursuing (and note I am definitely not proposing that view).
 
In the two years or so that I have been
working with MANETs, the only conclusion I have come to is that very many use
cases exist, and that one size does not fit all.
 
Regards
 
John

---

From: Bo Berry <[email-masked]>
Date: Wed, 31 Oct 2012 14:29:59 -0400

For background and perspective, ran across these two docs on the origin 
and performance of Loadng.  The WG may find helpful.

-Bo

The LLN On-demand Ad hoc Distance-vector Routing Protocol - Next Generation (LOADng)	
By T. Clausen. A. Colin de Verdiere. 
Published in INRIA Research Report 7692 on 2011-07-25.
http://hipercom.thomasclausen.net/resteam/data/publications/414efa79c4c772e5af46f426e77ca581.pdf

A Comparative Performance Study of the Routing Protocols LOAD and RPL with Bi-Directional Traffic in Low-power and Lossy Networks (LLN)	
By T. Clausen, U. Herberg. 
Published in INRIA Research Report 7637 on 2011-06-01.
http://hipercom.thomasclausen.net/resteam/data/publications/49eaae3228cf686a462108aef8332ceb.pdf

On Oct 31, 2012, at 1:48 PM, Jon Black wrote:

> Certainly smart meters are one of the types of networks that are MANETs.  Just because houses do not move it does not mean that the connectivity between those meters isn't changing.  A smart meter network is most certainly a MANET.  [One could argue that it is not an LLN since at least from the electrical power there is no lack of power.]
> 
> While I am very pleased for you and your co-authors that the LOADng work has been so fruitful, I am not really sure that smart meters are really the kind of MANET devices that the working group was intended to address. I have been party to the conversations for only a year or two, so I am very happy to be corrected by those with longer histories, but MANET to me means dynamically moving nodes, with links being established and broken often and without prior warning. Examples may be communications networks built out of nodes contained in cars, trucks and aircraft of all sizes. I appreciate a comment on the list a while back that the RF environment for smart metering is actually more difficult than one would think, but I would suggest to the chairs that unless LOADng has applications in this dynamically mobile environment (and I have to admit I have not read the spec in enough detail to determine if this is the case), then we come to the conclusion that the DYMO/AODVv2 path should be followed unless we collectively feel that such a direction is not worth pursuing (and note I am definitely not proposing that view).
>  
> In the two years or so that I have been working with MANETs, the only conclusion I have come to is that very many use cases exist, and that one size does not fit all.
>  
> Regards
>  
> John
> 
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Wed, 31 Oct 2012 22:00:53 +0000

On Oct 31, 2012, at 6:48 PM, Jon Black wrote:

JP> Just observe the loosiness on these network and how much on bandwidth you get especially when using PLC and you will see why
this is a LLN …

  Jon

Regards

John

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Wed, 31 Oct 2012 22:12:20 +0000

Hi Bo,

We need to be very careful there … these documents provide results that CANNOT be generalized to say the least.
Hypothesis made on traffic flows are such that you get the results that you would like to see …

Thanks

JP.

On Oct 31, 2012, at 7:29 PM, Bo Berry wrote:

>> While I am very pleased for you and your co-authors that the LOADng work has been so fruitful, I am not really sure that smart meters are really the kind of MANET devices that the working group was intended to address. I have been party to the conversations for only a year or two, so I am very happy to be corrected by those with longer histories, but MANET to me means dynamically moving nodes, with links being established and broken often and without prior warning. Examples may be communications networks built out of nodes contained in cars, trucks and aircraft of all sizes. I appreciate a comment on the list a while back that the RF environment for smart metering is actually more difficult than one would think, but I would suggest to the chairs that unless LOADng has applications in this dynamically mobile environment (and I have to admit I have not read the spec in enough detail to determine if this is the case), then we come to the conclusion that the DYMO/AODVv2 path sh
> ould be followed unless we collectively feel that such a direction is not worth pursuing (and note I am definitely not proposing that view).
>>

---

From: Axel Colin de Verdière <[email-masked]>
Date: Wed, 31 Oct 2012 15:26:03 -0700

Hi JP,

As usual, there isn't just one situation, be it in MANETs in general or in LLNs in particular. The simulations shown did make some assumptions on the traffic, and some other assumptions might show different results, but that's true of any protocol. Which is why I would also be interested in your results concerning LOADng in LLNs.

Best,

Axel

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Wed, 31 Oct 2012 22:30:58 +0000

Hi Axel,

> As usual, there isn't just one situation, be it in MANETs in general or in LLNs in particular. The simulations shown did make some assumptions on the traffic, and some other assumptions might show…

Will send some results - but I think that the priority was to first see what the chairs decide on which way to go.
See this is the real issue with reactive routing in LLNs … assumption on the traffic will dictate how the protocol performs and anyone
with real life traces can easily reproduce the control plane behavior and see dramatic limitations ….

Thanks.

JP.