Subject: [manet] MANET protocols in the community network as Funkfeuer.

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 13 Oct 2012 14:41:13 +0200

I think some people in WG are interested also in Funkfeuer routing
metric [1], it was mentioned in MANET meeting 84. I hope we will see
the draft [2] to be accepted as a MANET WG draft shortly for
informational about Funkfeuer.

AB>suggest for title>
Packet Sequence Number based ETX Metric for Funkfeuer  Networking.

AB> suggest the Abstract>
This document specifies the ETX metric and its usage in Funkfeuer's
OLSRv2 Routers.

I recommend to include this draft [2] or a renewal in the Agenda 85,
if the authors are welling to present it.

[1] http://www.ietf.org/mail-archive/web/manet/current/msg12077.html
[2] http://tools.ietf.org/html/draft-funkfeuer-manet-olsrv2-etx-01

AB
++
On 10/12/12, Henning Rogge <[email-masked]> wrote:
> On 10/12/2012 09:53 AM, Abdussalam Baryun wrote:
>> +1
>>
>> It is an excellent draft/work, I support the draft and your process.
>> Thanks to all: authors, you and the WG,
>
> The document will be a great help as a pointer for people who still
> arguing the use of link metrics. Good to see it here.
>
> Henning Rogge
>
>
> --
> Diplom-Informatiker Henning Rogge , Fraunhofer-Institut für
> Kommunikation, Informationsverarbeitung und Ergonomie FKIE
> Kommunikationssysteme (KOM)
> Fraunhofer Straße 20, 53343 Wachtberg, Germany
> Telefon +49 228 9435-961,   Fax +49 228 9435 685
> mailto:[email-masked] http://www.fkie.fraunhofer.de
>
>

---

From: Ulrich Herberg <[email-masked]>
Date: Sat, 13 Oct 2012 08:37:40 -0700

I think this draft is indeed interesting, and I wonder if there is any work
planned to continue it. It seems to be a bit of a mixture between
specifying how to use ETX in OLSRv2, and a deployment experience of ETX
with OLSR in the FunkFeuer network. Is that the right way to go forward, or
should that not better be separated in two drafts?

Ulrich

On Sat, Oct 13, 2012 at 5:41 AM, Abdussalam Baryun <
[email-masked]> wrote:

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: Henning Rogge <[email-masked]>
Date: Sat, 13 Oct 2012 23:18:23 +0200

Interesting question... the last time we worked on the draft the
discussion bogged down with the question if this is the "right way" to
do ETX.

Maybe a split would be a good idea, we could have an informal document
specifying the strategy we are using at Freifunk/Funkfeuer for ETX.
And then we could work on how to transform this into a good OLSRv2
metric.

Henning Rogge

On Sat, Oct 13, 2012 at 5:37 PM, Ulrich Herberg <[email-masked]> wrote:
> planned to continue it. It seems to be a bit of a mixture between specifying
> how to use ETX in OLSRv2, and a deployment experience of ETX with OLSR in
> the FunkFeuer network. Is that the right way to go forward, or should that
> not better be separated in two drafts?
>
> Ulrich
>
>
> On Sat, Oct 13, 2012 at 5:41 AM, Abdussalam Baryun
> <[email-masked]> wrote:
>>

-- 
Steven Hawkings about cosmic inflation: "An increase of billions of
billions of percent in a tiny fraction of a second. Of course, that
was before the present government."

---

From: Joseph Macker <[email-masked]>
Date: Sat, 13 Oct 2012 18:57:32 -0400

Henning:

I remember similar offline discussion in Paris related to this and whether
it would be a good idea to split out.  This would be  a good agenda item
discussion in my opinion also.

-Joe

On Sat, Oct 13, 2012 at 5:18 PM, Henning Rogge <[email-masked]>wrote:

> specifying

---

From: Henning Rogge <[email-masked]>
Date: Sun, 14 Oct 2012 02:07:18 +0200

I will not be able to attend the coming IETF.

Henning Rogge

---

From: Thomas Heide Clausen <[email-masked]>
Date: Sun, 14 Oct 2012 09:46:21 +0200

> And then we could work on how to transform this into a good OLSRv2

I do not know if a split is the right thing to do - then again, I do not know that it isn't either. 

I think that what the previous version of the I-D failed to do, and what caused the bogged-down discussion, was to frame properly what the content was about. 

I think that producing an informational RFC saying something of the kind:

	"This is one way of doing ETX, specifically the one way that has shown to work 
	  well in a large deployment in continuous operation. It is probably not the only way,
	  and perhaps not the best way, of doing ETX, but this is one way that's proven to 
	  work well"

Would be quite useful.

I don't know if one "best way of calculating ETX" exists -- I do know that there's a saying that can be adapted to be appropriate here: "Best is the enemy of good".

Thomas

---

From: Henning Rogge <[email-masked]>
Date: Sun, 14 Oct 2012 10:23:44 +0200

> I do not know if a split is the right thing to do - then again, I do not know that it isn't either.

Maybe instead of splitting it into two Drafts, splitting the draft
into two parts... one explaining what is used in the
Freifunk/Funkfeuer networks currently and another one that suggests a
way to use this strategy for OLSRv2 metrics.

>           and perhaps not the best way, of doing ETX, but this is one way that's proven to

Another reason why it bogged down was the introduction of the new TLV
to have a "out-of-band" channel between both end of the link for the
routing metric calculation. The current Freifunk/Funkfeuer metric
cannot be done without one.

Henning Rogge

---

From: Thomas Heide Clausen <[email-masked]>
Date: Sun, 14 Oct 2012 10:28:25 +0200

> cannot be done without one.

Yes, but that would (IMO) be fair enough in the "this is one way of doing ETX that we've got operational experience with as working - but, not the only one".

The only snag would be that care should be made that the defined TLV would be "flexible" enough to support other such signaling, but I do not see that as a huge problem....

Thomas

---

From: Henning Rogge <[email-masked]>
Date: Sun, 14 Oct 2012 10:31:09 +0200

> Yes, but that would (IMO) be fair enough in the "this is one way of doing ETX that we've got operational experience with as working - but, not the only one".

Okay.

> The only snag would be that care should be made that the defined TLV would be "flexible" enough to support other such signaling, but I do not see that as a huge problem....

My suggestion was to make it "content defined by metric with same
extension type". Which means that the algorithm calculating the metric
TLV with extension type X can decide to use the "Internal Metric Data"
TLV with any kind of data and length.

Henning Rogge

---

From: Thomas Heide Clausen <[email-masked]>
Date: Sun, 14 Oct 2012 10:32:17 +0200

> TLV with any kind of data and length.

Which would be one workable option, indeed.

Thomas