Subject: [manet] Flooding: how to make a normative reference?

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 30 Oct 2012 12:39:31 -0700

Hello folks,

I think it is well recognized that brute force flooding often leads to
poor performance in ad hoc networks with many nodes.  Thus, we
have RFC 6621 to describe various other approaches.  Plus, we have
MPR flooding as described in the OLSRv2 document.

For reactive, it is quite important to enable "better" algorithms
for flooding.  AODVv2 could quite reasonable use a MPR-based
flooding, or flooding based over any connected dominating set.

It seems wrong to have AODVv2 cite OLSRv2 in any normative
fashion, just to get access to the MPR flooding mechanism which
can run independently of the routing protocol (and, perhaps,
should do so).  It also seems wrong to cite RFC 6621 in any
normative fashion since that is an Experimental specification.

Don't we need to have some Proposed Standard documents that
specify more scalable approaches to flooding, that are independent
of routing protocols?

I guess it's too late to suggest that the MPR specification should
be pulled out of OLSRv2 for this purpose...

I looked back for some discussion about this on the list, but I
didn't find it, but my search was hardly exhaustive.

-- 
Regards,
Charlie P.

---

From: Joseph Macker <[email-masked]>
Date: Tue, 30 Oct 2012 16:25:45 -0400

We could take 6621 Standards Track.  It is beginning to be adopted and
conceptually used by others we are implementing both adaptive unicast and
adaptive multicast schemes.  I was going to suggest that as a short agenda
item but with the bulk of the discussion to center around reactive protocol
work status I was holding off on that. Still a good idea at some point. So
that's one way forward.

In the meantime, a suggestion might be that there are also publications
outside the IETF that are citable which include distributed CDS algorithm
pseudocode. I dont see what would be wrong with that? But perhaps someone
will correct that the IETF must only cite IETF documents. I think the key
thing is that its not a "work in progress".

The following basically covers the algorithms in 6621.

Macker, J., Downard, I., Dean, J., and R. Adamson, "Evaluation of
Distributed Cover Set Algorithms in Mobile
Ad hoc Network for Simplified Multicast Forwarding", ACM SIGMOBILE
Mobile Computing and Communications Review, Volume 11, Issue 3, July
2007.

This article had pseudocode for various CDS algorithms also cited in RFC
6621 so it may be an alternative normative reference for your purposes.

I know there are other articles detailing other CDSes as well like MPR
related variants.

On Tue, Oct 30, 2012 at 3:39 PM, Charles E. Perkins
<[email-masked]>wrote:

> ______________________________**_________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/manet<https://www.ietf.org/mailman/listinfo/manet>
>

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 31 Oct 2012 09:53:58 +0000

Pulling MPR flooding out of OLSRv2 is, as you say, too late. In my ideal world the five documents that make up OLSRv2 would be seven or eight (the forwarding/processing mechanism is usefully reusable as well). However various reasons (both the effort to do, and the effort to shepherd more documents through the process) argued against it.

But if using MPRs you will have to reference OLSRv2 normatively, as it defines the MPR TLV, and defining a new one just to avoid referencing it would not be acceptable.

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Charles E. Perkins
Sent: 30 October 2012 19:40
To: manet
Subject: [manet] Flooding: how to make a normative reference?

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

Hello folks,

-- 
Regards,
Charlie P.

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 31 Oct 2012 11:30:49 +0100

Agree 100% with Chris here. 

Thomas

-- 
Thomas Heide Clausen
http://www.thomasclausen.org

"Today's scientists have substituted mathematics for 
  experiments, and they wander off through equation 
  after equation, and eventually  build a structure 
  which has no relation to reality."
 - Nikola Tesla, 
    Modern Mechanics and Inventions, July, 1934