Subject: Re: [manet] Reactive Protocol Situation

From: "Dowdell, John" <[email-masked]>
Date: Wed, 31 Oct 2012 15:56:02 -0000

Thierry

While I am very pleased for you and your co-authors that the LOADng work
has been so fruitful, I am not really sure that smart meters are really
the kind of MANET devices that the working group was intended to
address. I have been party to the conversations for only a year or two,
so I am very happy to be corrected by those with longer histories, but
MANET to me means dynamically moving nodes, with links being established
and broken often and without prior warning. Examples may be
communications networks built out of nodes contained in cars, trucks and
aircraft of all sizes. I appreciate a comment on the list a while back
that the RF environment for smart metering is actually more difficult
than one would think, but I would suggest to the chairs that unless
LOADng has applications in this dynamically mobile environment (and I
have to admit I have not read the spec in enough detail to determine if
this is the case), then we come to the conclusion that the DYMO/AODVv2
path should be followed unless we collectively feel that such a
direction is not worth pursuing (and note I am definitely not proposing
that view).

In the two years or so that I have been working with MANETs, the only
conclusion I have come to is that very many use cases exist, and that
one size does not fit all.

Regards

John

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Thierry LYS
Sent: 31 October 2012 14:54
To: [email-masked]
Subject: Re: [manet] Reactive Protocol Situation

Hi Joe, 

I speak in the name of EDF group. 

We started first to use LOAD as a routing algorithm and deployed 2000
PLC-meters for smart grid purposes in 2011. Taking advantage of this
field test, we have been actively participating to the working group to
adopt enhancements in the LOADng specification. 
We are now extremely pleased with what LOADng is capable of and are
confident that future deployements will be equipped with it. 

"We believe in rough consensus and running code" 

rough consensus : Don't you think we have a rough consensus on LOADng
compared to DYMO ? 10 authors and major companies are supporters of
LOADng. 

running code : interoperability has been checked with 4 sources and
other implementations are in progress. 

We hope that IETF will realize how urgent and promising is the market
for the smart grid. 
So to answer your question : We opt for answer 2 ! 

Best regards, 

Thierry Lys (ERDF, EDF Group) 
and Cedric Lavenu (EDF R&D, EDF Group)

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Wed, 31 Oct 2012 16:50:34 +0000

Hi Thierry,

I cannot agree more with you.

Thanks.

JP.

On Oct 31, 2012, at 4:56 PM, Dowdell, John wrote:

Thierry

While I am very pleased for you and your co-authors that the LOADng work has been so fruitful, I am not really sure that smart meters are really the kind of MANET devices that the working group was intended to address. I have been party to the conversations for only a year or two, so I am very happy to be corrected by those with longer histories, but MANET to me means dynamically moving nodes, with links being established and broken often and without prior warning. Examples may be communications networks built out of nodes contained in cars, trucks and aircraft of all sizes. I appreciate a comment on the list a while back that the RF environment for smart metering is actually more difficult than one would think, but I would suggest to the chairs that unless LOADng has applications in this dynamically mobile environment (and I have to admit I have not read the spec in enough detail to determine if this is the case), then we come to the conclusion that the DYMO/AODVv2 path should be followed unless we collectively feel that such a direction is not worth pursuing (and note I am definitely not proposing that view).

In the two years or so that I have been working with MANETs, the only conclusion I have come to is that very many use cases exist, and that one size does not fit all.

Regards

John
________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Thierry LYS
Sent: 31 October 2012 14:54
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [manet] Reactive Protocol Situation

Hi Joe,

We started first to use LOAD as a routing algorithm and deployed 2000 PLC-meters for smart grid purposes in 2011. Taking advantage of this field test, we have been actively participating to the working group to adopt enhancements in the LOADng specification.
We are now extremely pleased with what LOADng is capable of and are confident that future deployements will be equipped with it.

rough consensus : Don't you think we have a rough consensus on LOADng compared to DYMO ? 10 authors and major companies are supporters of LOADng.

running code : interoperability has been checked with 4 sources and other implementations are in progress.

We hope that IETF will realize how urgent and promising is the market for the smart grid.
So to answer your question : We opt for answer 2 !

Best regards,

Thierry Lys (ERDF, EDF Group)
and Cedric Lavenu (EDF R&D, EDF Group)
_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Wed, 31 Oct 2012 17:07:04 +0000

Sorry … I meant:

John,

JP.

On Oct 31, 2012, at 5:50 PM, JP Vasseur wrote:

Hi Thierry,

Thanks.

JP.

Thierry

Regards

John

Hi Joe,

Best regards,

---

From: Jiazi YI <[email-masked]>
Date: Wed, 31 Oct 2012 18:31:07 +0100

Dear John, dear all,

There have been a lot of discussions on LLNs and MANET in other sessions, and I don't think it's necessary to repeat the whole discussion here. 
My opinion is:
1) LLN is a subset of MANET, and 
2) As a derivative of AODV, LOADng can be also adapted to some mobile scenarios (as you said, one size does not fit all), and the LOADng authors are willing to work to meet the requirement of the WG.  

On reactive issue, I fully agree with what Chris said before. The more important is the technical questions. 

1) Are those two approaches (LOADng and DYMO) at the same point after two years?

My personal answer is no. LOADng has already concrete results, implementations, interop test, running code. 
I have read the latest DYMO revision in detail, which still have a lot of major flaws. If I'm going to implement DYMO based on the specification, I can't imagine how I can finish the work without my personal guess, which surely makes the protocol impossible to interoperate. In fact, after the effort of trying to be "compatible" with LOADng, the current DYMO-23 has much more inconsistencies and worse shape than DYMO-21 two years ago. 
Of course, I would like to hear your opinion after you reading the DYMO draft. 

In fact, I don't get the point when the DYMO editor said "make DYMO compatible with LOADng". LOADng is a protocol that still evolving, in the aspect of packet format, mechanisms, etc. to make the protocol more efficient. I can't understand how DYMO can be compatible with LOADng without keeping taking ideas/text from LOADng (as DYMO already did, in absence of the agreement of other LOADng authors). I don't think this is appropriate behavior in the WG.

2) How much effort / time do we still need from where we are?

LOADng is already relatively mature with running code, interop test, etc. I know that there are several technical issues to address which are required by the WG chairs, and believe it can be resolved in very short time. All the related documents: interop report, mib would be updated timely. Last but not least, all the LOADng authors are eager to see it happen as soon as possible and willing to put all efforts necessary in it. 

In the meantime, DYMO is now addressing the comments from two years ago, in a worse shape compared to dymo-21 when trying to be "compatible" with LOADng, and has intention to *follow* LOADng specification. Giving all those, I really don't have any idea how much effort/time is needed. I have no doubt that the editor of DYMO has technical excellence to finish the job if he had enough time. I would strongly support him doing so if I was in 2010.  But now we are in 2012, and rolling back to 2010 is unacceptable. 

best

Jiazi

On Oct 31, 2012, at 4:56 PM, "Dowdell, John" <[email-masked]> wrote:

> From: [email-masked] [mailto:[email-masked]] On Behalf OfThierry LYS
> [email-masked]