Subject: [manet] Use of RFC 5444 in AODVv2

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 26 Oct 2012 17:28:41 -0700

Hello folks,

Several people have pointed out to me that DYMO and now AODVv2 have
not really been conformant with the design of RFC 5444.  I have studied this
matter in some detail, and it turns out to be quite confusing.  In order to
avoid getting confused over and over again, I wrote up a long description
of a design evolution, first correcting errors that had to be corrected, and
aiming towards a more serviceable design for the "usual" cases that would
be probably encountered in AODVv2 networks.

I expect to include this as an appendix in the next revision of AODVv2,
which I will make available next week.   In the meantime, I have put the
following text on my website, for anyone interested.
       http://www.psg.com/~charliep/AODVv2-rfc5444-ideas.txt
I still need to proofread it, but it's mostly correct, and if it is 
acceptable
then it will pretty much form a roadmap for the design of the RFC 5444
formats for other AODVv2 messages (RREP and RERR).

I have also had several people express frustration that the document is
not easy to read.  I have always thought that myself, and I have come up
with some changes in terminology that might go a long way towards
helping with that.  For instance, I define "router client" to be a host in
an AODVv2 network that relies on the service of an AODVv2 router,
but is not itself an AODVv2 router.  It is intended that a "router client"
doesn't have to know anything about AODVv2.  This avoids having to
use the previous terminology about "router responsibility" which did
not seem to illuminate the concepts very well.

I'll make a more complete proposal for changing terminology early
next week.  Please excuse the remaining errors in the recently released
version of AODVv2.  I wish I had started much much earlier to do these
revisions.

Lastly, it is my intention to submit these changes also as issues in the
issue tracker.  There are at least a half-dozen such issues that need to be
included -- some small, some (like RFC 5444 compliance) not so small.

-- 
Regards,
Charlie P.

---

From: Abdussalam Baryun <[email-masked]>
Date: Sun, 28 Oct 2012 12:00:28 +0100

Hi Charlie,

If you are suggesting to modify the RFC5444 packet format, I agree to
make modification to RFC5444 to fit our reactive standards.

AB

On 10/27/12, Charles E. Perkins <[email-masked]> wrote:
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: Henning Rogge <[email-masked]>
Date: Sun, 28 Oct 2012 15:43:37 +0100

I dont think we need to change RFC544 for reactive protocols.

Henning Rogge

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 29 Oct 2012 13:35:00 -0700

Hello Abdussalam,

While studying whether AODVv2 was properly in
compliance with RFC 5444, I found a few things that
I feel should have been done differently.

However:
- there is no doubt that AODVv2 can be made conformant to
    RFC 5444, as you can see by reading through my longish note
    about the possible design alternatives for RREQ
- Certain simple changes to RFC 5444 would allow for more
    compact message representation -- but, the savings are not so
    dramatic as to motivate immediate action on my part, and
    I don't really have time to carry on that argument right now.

Maybe I'll write up a small proposal and send it to the
list.  However, the offline discussions I have had lead me
to the conclusion that a lot of people are not that
interested in saving header space, and that they strongly
feel it is far too late to discuss the matter.  This doesn't match
my understanding of requirements from other groups, so
maybe in the future we should reopen the discussion, I
don't know.

Regards,
Charlie P.

-- 
Regards,
Charlie P.

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 30 Oct 2012 10:10:01 +0000

A possibility (I'm not arguing for or against it, just putting it out there) is to specify the protocol in terms of message contents in an abstract manner (though one described in terms of addresses and associated information would be good) and then provide a mapping (a) of this to 5444, for use on manet port, and which is flexible and extensible, and (b) a highly compressed representation for use over highly bandwidth constrained interfaces, possibly not supporting all options, not easily extensible, possibly using e.g. compressed addresses.

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Charles E. Perkins
Sent: 29 October 2012 20:35
To: Abdussalam Baryun
Cc: manet
Subject: Re: [manet] Use of RFC 5444 in AODVv2

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

Hello Abdussalam,

However:

Regards,
Charlie P.

-- 
Regards,
Charlie P.

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 30 Oct 2012 09:08:14 -0700

Hello Chris,

I think that this is what Ian had tried to do.  I am in the process of 
basically
completing his effort.  I think that some attention to terminology is 
important
for this effort, and I will make a proposal soon about that.

Regards,
Charlie P.

-- 
Regards,
Charlie P.