Subject: [manet] (no subject)

From: Jon Black <[email-masked]>
Date: Wed, 31 Oct 2012 10:57:43 -0700 (PDT)

On October 31, 2012 Thierry.Lys wrote:

I speak in the name of EDF group.  

We started first to use LOAD as a routing
algorithm and deployed 2000 PLC-meters for smart grid purposes in 2011.
Taking advantage of this field test, we have been actively participating
to the working group to adopt enhancements in the LOADng specification. 
We are now extremely pleased with what
LOADng is capable of and are confident that future deployements will be
equipped with it. 

This would seem to indicate that LOADng does work and in a rather large deployment.

"We believe in rough consensus
and running code" 

rough consensus : Don't you think we
have a rough consensus on LOADng compared to DYMO ? 10 authors and major
companies are supporters of LOADng.  

running code : interoperability has
been checked with 4 sources and other implementations are in progress. 

Obviously from the list we don't have rough consensus.  We have two alternatives each with proponents.  The WG should weigh the technical benefits (design, implementation/running code, maturity)  of each and the group should choose a path forward.

In my opinion option 3 is not an option - this is the working group shirking its responsibility.

Jon

---

From: Joseph Macker <[email-masked]>
Date: Wed, 31 Oct 2012 14:37:02 -0400

Jon:

You make some good points in the technical category if we are to not choose
(3).  Perhaps people could provide input and discussion in these areas more
as a guide.  I realize these designs are not finalized and would evolve as
part of the WG process but it would give us a better idea on the starting
line.

Design:  Does it have the features we require of a modernized MANET
protocol? Does it perform well as a MANET protocol?  Are its features
well-specified and clear to implement it both in an effective and
interoperable manner?  Of course this is an evolving process since the WG
will have some ownership of the design. Extensible?

Implementation/Running Code:  Always a benefit and gives community a chance
to test features and report,etc. Confidence in going forward on STD track
path. Need some manet-oriented results to gain confidence in operational
modes under particular expected scenarios.  Also a beneficial if there is
prototype open source version available to broaden the exposure and
experimentation.  Interops,etc ?

Maturity: Has it been used or gone through relevant use cases. Are any
algorithms or subprocesses well understood (goes along with design in that
sense)?

On Wed, Oct 31, 2012 at 1:57 PM, Jon Black <[email-masked]> wrote:

> We started first to use LOAD as a routing algorithm and deployed 2000
> PLC-meters for smart grid purposes in 2011. Taking advantage of this field
> test, we have been actively participating to the working group to adopt
> enhancements in the LOADng specification.
> We are now extremely pleased with what LOADng is capable of and are
> confident that future deployements will be equipped with it.
>
> "We believe in rough consensus and running code"
>
> rough consensus : Don't you think we have a rough consensus on LOADng
> compared to DYMO ? 10 authors and major companies are supporters of LOADng.
>
> running code : interoperability has been checked with 4 sources and other
> implementations are in progress.
>
> Obviously from the list we don't have rough consensus.  We have two
> alternatives each with proponents.  The WG should weigh the technical
> benefits (design, implementation/running code, maturity)  of each and the
> group should choose a path forward.
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>
>

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Wed, 31 Oct 2012 22:09:05 +0000

On Oct 31, 2012, at 6:57 PM, Jon Black wrote:

We started first to use LOAD as a routing algorithm and deployed 2000 PLC-meters for smart grid purposes in 2011. Taking advantage of this field test, we have been actively participating to the working group to adopt enhancements in the LOADng specification.
We are now extremely pleased with what LOADng is capable of and are confident that future deployements will be equipped with it.

JP> No this means that LoadNG works in *a* network. But the major technical difference here is that reactive routing is highly impacted
by the user traffic … If you poll a meter every 24 hours, it may work perfectly well. Now if you start having more frequent traffic flows
you can either cache paths (ending up with more frequent broken paths considering how flappy these networks are, thus leading to more
floods … very undesirable … especially when you have hundreds of meters sharing a few Kbits/s) or you use short cache timers and you
keep flooding :-( If you take actual traces of these networks (both using 15.4g and P1901.2) and you start adjusting the user traffic rate you
immediately see the issues in terms of scalability. Yes you can try to mitigate the undesirable flooding effect to some extends but showing
the limits in terms of scalability is easy to show. Note that I MOT against reactive routing by any means, this is IMO just not applicable to
LLNs unless the traffic flows are deterministic and very well knows … Lessons from the past show us how difficult it is to predict user
applications. We all started with meter reading to continue with that example and now many utilities wants to use these smart metering
networks for a number of applications which different SLA, …

Hope this helps. Once again, when/if required I would be happy to share many results.

rough consensus : Don't you think we have a rough consensus on LOADng compared to DYMO ? 10 authors and major companies are supporters of LOADng.

running code : interoperability has been checked with 4 sources and other implementations are in progress.

This is an option … since listed by the chairs. I agree that we should avoid it, especially when I think we have a very reasonable solution
(option1).

JP.

Jon

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

---

From: Jon Black <[email-masked]>
Date: Wed, 31 Oct 2012 16:39:37 -0700 (PDT)

Yes it shows that it does work in a rather large deployment.  I have heard others say that it works in other deployments as well - just the same as you say RPL works in some deployments.

Please share your results.  You keeps saying you will and you we keep asking you to - where's the results so they can be reviewed.

Jon

________________________________
 From: JP Vasseur (jvasseur) <[email-masked]>
To: Jon Black <[email-masked]> 
Cc: "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]> 
Sent: Wednesday, October 31, 2012 4:09 PM
Subject: Re: [manet] (no subject)

JP.