Subject: [manet] AD review of draft-kelsey-intarea-mesh-link-establishment

From: "Ralph Droms (rdroms)" <[email-masked]>
Date: Mon, 22 Oct 2012 17:52:49 +0000

I've been asked to sponsor draft-kelsey-intarea-mesh-link-establishment as an AD-sponsored individual submission.  As part of my AD review of the document, I'm soliciting input from a variety of relevant communities, including the manet WG.

I expect to complete my review next week and then send the document out for IETF last call.  Please respond with comments by next Monday, Oct 29, either to the mailing list or directly to me.   I'm aware that the last call will overlap the IETF meeting in Atlanta but it will be a four week last call, which should be enough for reviewing this document.

- Ralph

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Mon, 22 Oct 2012 18:00:43 +0000

Ralph, 

Thanks for the notice. 

WG - please review and comment. 

Regards,
Stan

On Oct 22, 2012, at 1:52 PM, Ralph Droms (rdroms) wrote:

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 23 Oct 2012 14:32:38 +0000

Reading the Introduction to this draft, I don't accept the description of NHDP (RFC 6130) that it gives. NHDP does not "recommend that messages are sent over secured links", nor does it use "already-configured links" (of course it could, but that's not the universal use case).

The document claims to go further than NHDP by making initialisation of link-layer security a main function. But distribution and derivation of keys is explicitly excluded. That really rather makes this pointless - key distribution is the hard part, and the issues of key management in a less-managed network (which is what an ad hoc - or mesh if the authors prefer the term - network wants to be) are the real problem - and impacts on the rest of your solution. This gets something of the worst of both worlds of not doing security while claiming to do security. Furthermore "secured as described in 802.15.4" does not answer all the questions I would have. This is why NHDP does not do security itself - which is not the same as saying use secured links, an RFC 6622-based solution may be used for example (and given time and support I'd like to define one for NHDP+OLSRv2, but that's another matter). Half a solution constrains but does not help.

I would appreciate background here - is this an attempt to put what is a competing proprietary protocol onto the Standards Track without any of the proper discussion in the relevant WGs (this one for a start) prior to IETF LC? Has it any wider support than one company? Any implementations?

Incidentally, the main reason this draft can be simpler than NHDP is that it doesn't handle multiple interfaces, or multiple addressing, which are the major sources of complexity in NHDP. Also the document is pretty much absent on the issue of how data should be recorded (which it must be if to be used - by what?) and on its assumed validity time, timeouts etc.

In short, I think that the status of this document needs reviewing, why should it be on the Standards Track and why has it bypassed WGs, and that (probably not coincidentally) it lacks the attention to detail that WG documents don't progress without.

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ralph Droms (rdroms)
Sent: 22 October 2012 18:53
To: manet
Subject: [manet] AD review of draft-kelsey-intarea-mesh-link-establishment

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

- Ralph

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************