Subject: [manet] DLEP: How RADIO side produce the information for the MANET router?

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 16 Oct 2012 12:51:51 +0200

Hi Henning,

I agree with Martin, Router process is out of scope in DLEP. However,
understand your concerns which are important.

> Otherwise the router will not be sure what the
> information means.

I think that will be the routers problem, which the user or
router-developer should solve. We can see it with DLEP eyes: Will the
RADIO be sure about the router information needed? Do we make DLEP for
specific routers (AODVv2 or OLSRv2). I agree with not specific to such
router.

AB

On 10/15/12, Henning Rogge <[email-masked]> wrote:
> On Mon, Oct 15, 2012 at 4:10 PM, Duke, Martin <[email-masked]>
> wrote:
>> The reason I haven't responded to this request is because I haven't been
>> able to find anywhere in the draft that instructs the router on how to
>> handle ANY of these metrics- RLQ, Latency, whatever. In fact, I thought
>> the way the router used information about the radio was out of scope for
>> this draft.
>
> I still think we need rules how the RADIO side produce the
> information. Otherwise the router will not be sure what the
> information means.
>
> Henning Rogge
>
> --
> Steven Hawkings about cosmic inflation: "An increase of billions of
> billions of percent in a tiny fraction of a second. Of course, that
> was before the present government."
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: Henning Rogge <[email-masked]>
Date: Tue, 16 Oct 2012 12:56:53 +0200

> specific routers (AODVv2 or OLSRv2). I agree with not specific to such

If the radio is allowed to produce the same output to the router for 
different input, the router cannot compensate for this. How shall a 
router implementation drop a link which the radio does know nothing 
about if the radio just signals "link is perfect".

That is why I am also interested in more "raw data" metric TLVs.
Just have a look at all the data you can get from a modern Linux wifi card.

Henning Rogge

-- 
Diplom-Informatiker Henning Rogge , Fraunhofer-Institut für
Kommunikation, Informationsverarbeitung und Ergonomie FKIE
Kommunikationssysteme (KOM)
Fraunhofer Straße 20, 53343 Wachtberg, Germany
Telefon +49 228 9435-961,   Fax +49 228 9435 685
mailto:[email-masked] http://www.fkie.fraunhofer.de