Subject: [manet] Micro-history about reactive protocol evolution

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 01 Feb 2013 13:52:27 -0800

Hello folks,

As part of the process of making progress on the reactive protocol
specification, it was suggested that a bit of history might be helpful
to understand how we have arrived at the current state.  Since most
people on this list have been around for a while and have seen first
hand the recent discussions, I won't go into that.  Instead, I'd like
to make a very short summary of what might be unfamiliar to many
people involved in the current discussion.

AODV and DSR were published as experimental RFCs for reactive protocols.
OLSR and TBRPF were published as experimental RFCs for proactive.
The plan was to have two later RFCs -- one for proactive, one for reactive.
The proponents of TBRPF didn't stick around too long, so, the proactive
protocol became simply OLSRv2.  The proponents of AODV and DSR took it
as their job to merge the two "experimental" protocols into a new reactive
standards track protocol.  AODV and DSR together have had hundreds
(thousands?) of citations in peer-reviewed papers, so their features are
pretty well understood.

The main difference between AODV and DSR is that DSR uses source
routes whereas AODV uses distance-vector.  The authors determined
that the best way to do the merge was to have a feature allowing
"path accumulation", which is now optional in AODVv2.  There were
some other features that were dropped from the specification, in
particular "local repair".  The name "DYMO" was picked because it
was neither "AODV" nor "DSR", and we all thought it was better to
represent the protocol as a fresh start.  Ian Chakeres took over as
editor when Dave Johnson eventually stopped coming to IETF and as
I almost dropped out myself, being in a start-up, etc.  In retrospect,
we lost name recognition and the new name never really caught on.
In 2011, when I was asked to resume editorial duties, several people
(frequent contributors to this mailing list) convinced me that the
protocol should be called AODVv2.

Ian was co-author (with Luke Klein-Berndt) for a protocol called
"AODV Jr.", and so Ian was quite favorable towards crafting DYMO
as a "stripped-down" version of AODV.  This is one reason why DYMO
de-emphasized some of the other features of AODV, while yet
incorporating features from DSR.

The main changes to DYMO have been:
- conversion to RFC 5444 packet formats
- moving Intermediate RREP to separate document
- simplification of rules for incrementing sequence numbers
- renaming to be AODVv2, numerous terminology simplifications
- lastly, enabling the use of alternate metrics

I hope this is helpful to understand the evolution of the reactive
protocol effort within [manet].  I wrote it from memory, and so I
might have missed one or two details.  There is a lot more that
could be written, but then this email would get way too long.

-- 
Regards,
Charlie P.

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 2 Feb 2013 02:29:34 +0100

Thanks, it is always special to hear history from the actors themself.
I recommend that we start an initial historical I-D including these
memories (Proactive and Reactive Protocols) to be submitted not later
than June 2017. At least each 20 years WG participants could document
their technical involvement history within WG work. Some MANET
addition IETF history dates as;

Start of MANET WG:            12 Jun 1997
Start publish of AODV:          20 Nov 1997
Discussion list Started:         30 Jan 2002
RFC3561 AODV:                  01 July 2003
Start Publish of DYMO:         01 Jan 2005
Start DYMO to AODVv2:       12 Mar 2012

AB
++
On 2/1/13, Charles E. Perkins <[email-masked]> wrote:
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: Jiazi Yi <[email-masked]>
Date: Sun, 17 Feb 2013 23:53:40 +0100

Dear Charlie, all:

As long as there is a mail on the *history* as suggested, if you don't mind, please allow me to add the one or two details that missed, which are kind of important. 
I have no intention to bring any dispute at this moment, but just to keep a record of what happened in the past several years on reactive routing protocol. 

I'm trying my best to be objective, and writing all those down without personal comment, but with related references to the archive (which makes the mail a little long). If there is any important detail missing, or wrong, please don't hesitate to correct me. 

Jul. 27 2010 - 78 IETF Maastricht, MANET meeting
	DYMO-21 was submitted before the meeting, but the editors didn't present the draft. 
	From that time, DYMO was actually "parked" in the following 2~ years, because of lack of interest and activity in the WG. 

Jul. 28 2010 -  To stimulate the work of DYMO, long comments were given from different participants. 
	dymo review from Ulrich http://www.ietf.org/mail-archive/web/manet/current/msg11859.html (July 2010)
   	dymo review from Thomas http://www.ietf.org/mail-archive/web/manet/current/msg11858.html (July 2010)
	dymo review from Georg http://www.ietf.org/mail-archive/web/manet/current/msg11974.html (Jan. 2011)

Nov. 2010 (IETF Beijing)
Mar. 2011 (IETF Prague) 
Jul. 2011 (IETF Quebec)
	There was no presentation and no discussion on DYMO. 
	The dymo editor expressed that he had no time and no passion to work on the reactive protocol, on different occasions. 
	See minutes:
	http://tools.ietf.org/wg/manet/minutes?item=minutes79.html (IETF 79)
	http://tools.ietf.org/wg/manet/minutes?item=minutes80.html (IETF 80)
	Slides: (IETF80)
	http://www.ietf.org/proceedings/80/slides/manet-6.pdf 
	Revision needed, no revision planned by authors (PARKED DOCUMENT) 
	http://tools.ietf.org/wg/manet/minutes?item=minutes81.html (IETF 81)
	"Currently it is in "parked" status, there is nobody committed to work on it " (Joe, in 81IETF meeting)

Oct. 2011 -00 submission of LOADng, as an individual draft. 

Nov 2011 13-18, IETF Taipei. The dymo editor was aware of the LOAng work, and expressed the interested to join. 
	On Nov 18, from 9am to 11 am, there was meeting between the DYMO editor and part of LOADng authors in the Hyatt hotel of Taipei. On that meeting, all the participants expressed their interest in working together on reactive protocol, based on the LOADng document + companion documents. Renaming it to AODVv2 was discussed, but as not all authors were party to this meeting, no decision was made on this point. 
	After several mail exchanges, a mail is sent to the WG chairs, after getting OK from all the authors, including the DYMO editor:
> From: Ulrich Herberg <[email-masked]>
> Date: November 29, 2011 7:00:08 PM GMT+01:00
> Subject: DYMO
> Joe, Stan,
> 
> During the IETF, Thomas mentioned that we are working on a draft, called "LOADng" (draft-clausen-lln-loadng). The draft specifies a reactive routing protocol, mainly intended for low-power and lossy networks (LLNs). As such, it contains a number of simplifications compared to AODV and a smaller message overhead.
> 
> During the IETF, we discussed that Charlie join the author list, and that this document be submitted in place of the currently stalled DYMO I-D, to satisfy the charter item of a reactive routing protocol.
> 
> Any thoughts on this matter?
> 
> On behalf of the authors,

The reply from the chairs was that, they were OK, as long as there was agreement between the authors. 
Then the technical discussion continued. 

Mar. 2012, Paris IETF, dymo editor submitted dymo-22, mostly based on the design of LOADng
	http://tools.ietf.org/html/draft-ietf-manet-dymo-22#appendix-A
	The LOADng authors had expressed that it would be beneficial to get together - LOADng and DYMO authors - in Paris, and discuss with the WG prior to submitting an update of DYMO - since having two seemingly competing documents would be confusing and potentially contentious. The LOADng authors were unhappy that the DYMO editor dismissed this opinion. 

Jul. 2012, the DYMO editor said that he wanted to officially join the author team of LOADng, and to be listed as first author. 
	While accepting the DYMO editor in the LOAng author list, the request of being first author from the DYMO editor was declined.  This, because so far the author list order was simply reflecting  the order in which each individual had joined the LOADng document. While re-ordering that (e.g., based on amount of contributions or alphabetically, or ...) was not excluded, the argument was made that this could be done later / at the end of the work / by the WG, if the document was adopted.
	In addition to the first author issue, there were also other two issues:
		o The LOADng authors prefer no designated editors, or editors are only honorific title, while the DYMO editor insisted that he should be the designated editor, and the one holding the pen. 
		o The LOADng authors prefer continue the editing process that has been proven to be productive (issue tracker + consensus based), while the DYMO editor insisted that he wanted to be able to more liberty in rewriting the draft. 
	There were hundreds mails exchanged in the following 2~ months, but the DYMO editor was against all the other 9 LOADng authors on the 3 issues listed above.

Oct. 18, 2012, a mail was sent to WG chairs and AD, proposing a way to go forward, in the spirit of "rough" consensus of the author team:
		o Select Thomas Clausen and Charlie Perkins as editors. 
		o The "editor" title doesn't change to current editing process of LOADng. 
		o The author order is unchanged. 
	It was called "rough", because the DYMO editor didn't support it. 

Oct. 22, 2012, the DYMO editor began replying to the reviews 2+ years ago. 
	http://www.ietf.org/mail-archive/web/manet/current/msg13821.html
	http://www.ietf.org/mail-archive/web/manet/current/msg13811.html

	At the same time, after 1~ year development cycle, the status of LOADng was: 
		o at its -06 revision,
			http://tools.ietf.org/html/draft-clausen-lln-loadng-06
		o with 4 known interoperable running implementations
		o having completed 4 interop events, documented in an interop report  
			http://tools.ietf.org/html/draft-lavenu-lln-loadng-interoperability-report-04
		o deployed in field with 2000+ nodes
	
Oct. 30 2012: The 300~mail storm on reactive protocol before Atlanta IETF 
	http://www.ietf.org/mail-archive/web/manet/current/msg13872.html

Nov. 7, 2012, IETF manet meeting, Atlanta. No decision was made, but "wait for DYMO-24"
	
Dec. 17 2012, AD asked for "mood" from the working group
	http://www.ietf.org/mail-archive/web/manet/current/msg14446.html

Jan. 14, 2013, AD made the decision to take DYMO
	http://www.ietf.org/mail-archive/web/manet/current/msg14598.html

Again, this mail is just to record the facts that happened. The text above is based on meeting minutes/audio stream/mails exchanged/mailing list archive. 

best

Jiazi

---

From: Ulrich Herberg <[email-masked]>
Date: Mon, 18 Feb 2013 11:41:28 -0800

Thanks Jiazi for summarizing the history. It reflects very much how I
remember it, too.

Ulrich

Sent from my iPhone

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 18 Feb 2013 23:23:10 +0100

Don't ignore the history sequence;

Discuss reactive status of starting renew WG draft on 19 Oct 2012:
http://www.ietf.org/mail-archive/web/manet/current/msg13801.html
http://www.ietf.org/mail-archive/web/manet/current/msg13805.html

Reply to old comment because it was parked and no WG replied;
http://www.ietf.org/mail-archive/web/manet/current/msg13811.html

Chairs request input;

AB