Subject: [manet] I-D Action: draft-ietf-manet-olsrv2-metrics-rationale-02.txt

From: [email-masked]
Date: Fri, 22 Feb 2013 03:28:47 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Mobile Ad-hoc Networks Working Group of the IETF.

	Title           : Link Metrics for the Mobile Ad Hoc Network (MANET) Routing Protocol OLSRv2 - Rationale
	Author(s)       : Christopher Dearlove
                          Thomas Heide Clausen
                          Philippe Jacquet
	Filename        : draft-ietf-manet-olsrv2-metrics-rationale-02.txt
	Pages           : 29
	Date            : 2013-02-22

Abstract:
   OLSRv2 includes the ability to assign metrics to links and to use
   those metrics to allow routing by other than minimum hop count
   routes.  This document provides a historic record of the rationale
   for, and design considerations behind, how link metrics were included
   in OLSRv2.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-manet-olsrv2-metrics-rationale

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-manet-olsrv2-metrics-rationale-02

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-manet-olsrv2-metrics-rationale-02

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Thomas Heide Clausen <[email-masked]>
Date: Fri, 22 Feb 2013 12:37:20 +0100

Just a heads up. This review folds in a couple of suggestions that our AD made from his review. In summary, it amounts to a sentence in the abstract and a paragraph in the introduction explaining the motivation for publishing this document, plus a couple of nits that he caught (thanks!).

Thank you, Adrian, for your review and assistance on this matter

For the authors,

Thomas

On Feb 22, 2013, at 12:28 , [email-masked] wrote:

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Henning Rogge <[email-masked]>
Date: Fri, 22 Feb 2013 12:41:04 +0100

> 	Filename        : draft-ietf-manet-olsrv2-metrics-rationale-02.txt

The changes look quite reasonable.

Henning Rogge

-- 
Diplom-Informatiker Henning Rogge , Fraunhofer-Institut für
Kommunikation, Informationsverarbeitung und Ergonomie FKIE
Kommunikationssysteme (KOM)
Fraunhofer Straße 20, 53343 Wachtberg, Germany
Telefon +49 228 9435-961,   Fax +49 228 9435 685
mailto:[email-masked] http://www.fkie.fraunhofer.de

---

From: Thomas Clausen <[email-masked]>
Date: Fri, 22 Feb 2013 12:42:30 +0100

Thank you, Henning.

We were just following reasonable advice from a reasonable man :D

Thomas

---

From: Ulrich Herberg <[email-masked]>
Date: Fri, 22 Feb 2013 04:17:59 -0800

I agree with Henning. Thanks for the update of the draft.

Ulrich

On Fri, Feb 22, 2013 at 3:41 AM, Henning Rogge <
[email-masked]> wrote:

>>         Title           : Link Metrics for the Mobile Ad Hoc Network
>> (MANET) Routing Protocol OLSRv2 - Rationale
>>         Filename        : draft-ietf-manet-olsrv2-**
>> metrics-rationale-02.txt
>>         Pages           : 29
>>         Date            : 2013-02-22
>>
>
> mailto:henning.rogge@fkie.**fraunhofer.de<[email-masked]>
> http://www.fkie.fraunhofer.de
>
>

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 22 Feb 2013 16:02:06 -0500

Thomas:

Thank you for revising this draft which has been helpful in understanding
your motivations. 
If you'd like specific how it has been helpful.. just ask (private or
public). 

Sue Hares

[snip] 
Thomas

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 23 Feb 2013 01:03:16 +0100

Hi Thomas,

Thanks for update, it covers the two main point of the review.
However, while checking the AD review [1], not sure there was a reply
to AD review from authors (did they do private, because one reply was
happy christmas) on the WG list. I recommend we get a reply to the
review then the update. The reason is because IMHO the review mentions
that :

*As usual, all my comments are open for discussion.*, I did not want
to discuss but was waiting for authors to start a reply, but now see a
jump to update,

I hope we can see reply to AD review [1] including last two points,
please advise,

[1] http://www.ietf.org/mail-archive/web/manet/current/msg14440.html

AB

On 2/22/13, Thomas Heide Clausen <[email-masked]> wrote:
> Just a heads up. This review folds in a couple of suggestions that our AD
> made from his review. In summary, it amounts to a sentence in the abstract
> and a paragraph in the introduction explaining the motivation for publishing
> this document, plus a couple of nits that he caught (thanks!).
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 23 Feb 2013 19:41:00 -0000

Hi Thomas,

Thanks for the update.

I've been through the diff and (as noted by some others) the changes look
reasonable.

>From my original review there were a couple of points where you didn't make
changes, and didn't make any comments to me or on the list. This is not a big
deal (as my comments were largely for discussion), but for cleanliness, I'll
make some statements on the list here, and you can disagree or let them stand:

---

> I wonder whether you want to make any comments about node
> metrics. Obviously, you don't have them (neighbor metrics being
> a different thing), but you could comment on why you don't have 
> them (if this was ever discussed).
>
> The question is slightly touched on in 5.2 in discussion of "delay".

The issue was never discussed as an idea for inclusion in OLSRv2, and while node
metrics could be added in the future, there was no suggestion that there is a
requirement.  Thus, there is no reason to add any notes on node metrics to this
document.

---

> Section 8
>
> Were there any security considerations that cropped up while
> designing metric support in OSLRv2? If so, here would be the
> place to mention them.

Security issues arising from the inclusion of metrics in OLSRv2 did not get any
specific discussion. Since OLSRv2 has its own security considerations to cover
the whole protocol, there is nothing further to say in this document.

---

If you have any responses to these points that need to be addressed in the text,
we can handle it in IETF last call which I will start with no further (well, you
know, real time and all that) delay.

Cheers,
Adrian

> -----Original Message-----
> From: Thomas Heide Clausen [mailto:[email-masked]]
> Sent: 22 February 2013 11:37
> To: manet List
> Cc: Adrian Farrel
> Subject: Re: [manet] I-D Action:
draft-ietf-manet-olsrv2-metrics-rationale-02.txt
> 
> Just a heads up. This review folds in a couple of suggestions that our AD made
> from his review. In summary, it amounts to a sentence in the abstract and a
> paragraph in the introduction explaining the motivation for publishing this
> document, plus a couple of nits that he caught (thanks!).
> 
> > 	Title           : Link Metrics for the Mobile Ad Hoc Network (MANET)
Routing
> Protocol OLSRv2 - Rationale

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 26 Feb 2013 15:42:00 +0000

We had intended to put in a comment that if you want a node metric, add it to incoming link metrics. I think from the author team I dropped the ball on that one.

I'm not sure if there's anything to say on security. It wasn't part of this rationale. Any OLSRv2 threats document could consider link metrics.

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: 23 February 2013 19:41
To: 'Thomas Heide Clausen'
Cc: [email-masked]; 'manet List'
Subject: Re: [manet] I-D Action: draft-ietf-manet-olsrv2-metrics-rationale-02.txt

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

Hi Thomas,

Thanks for the update.

---

---

---

Cheers,
Adrian

Routing

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 26 Feb 2013 15:47:08 +0000

I omitted to say, that we will treat the node metrics as an IETF LC  comment. Or at least that's the plan.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: 23 February 2013 19:41
To: 'Thomas Heide Clausen'
Cc: [email-masked]; 'manet List'
Subject: Re: [manet] I-D Action: draft-ietf-manet-olsrv2-metrics-rationale-02.txt

Hi Thomas,

Thanks for the update.

---

---

---

Cheers,
Adrian

Routing