Subject: [manet] An input (was Re: [Technical Errata Reported] RFC5444 (3496))

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 26 Feb 2013 16:16:30 +0000

No one have right to try to discourage inputs, discussions are what this
list is for. I know that editors don't like comments, but they have to live
with it. For others that don't author work, please just do your job (not to
comment on numbers of posts/input, or time spend) or keep quite,

AB

On Tue, Feb 26, 2013 at 4:10 PM, Daniel He <[email-masked]> wrote:

> It is no good to discuss on the mailing list if it is not technical
> relevant. Otherwise, we received too many useless emails without any
> technical information. It is not a BBS
> website.
>
>
>
> On 26 February 2013 16:00, Abdussalam Baryun <[email-masked]>wrote:
>
>> There is no harm in discussing, issues related to NHDP or RFC5444, or
>> erratas, even after they were publish as we all know they are Request For
>> Comments,
>>
>> AB
>>
>> On Tue, Feb 26, 2013 at 3:57 PM, Dearlove, Christopher (UK) <
>> [email-masked]> wrote:
>>
>>>  NHDP has made it to RFC, and OLSRv2 has made it to one AD short of RFC
>>> - and not for any related reason - without anyone thinking "we really
>>> should use that because it might be there - though it also might not".
>>> Which suggests your technical answer is wrong. And anyway, procedurally
>>> it's multiple steps too late.****
>>>
>>> ** **
>>>
>>> -- ****
>>>
>>> Christopher Dearlove****
>>>
>>> Senior Principal Engineer, Communications Group
>>> Communications, Networks and Image Analysis Capability
>>> BAE Systems Advanced Technology Centre
>>> West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
>>> Tel: +44 1245 242194 |  Fax: +44 1245 242124****
>>>
>>> [email-masked] | http://www.baesystems.com
>>>
>>> BAE Systems (Operations) Limited
>>> Registered Office: Warwick House, PO Box 87, Farnborough Aerospace
>>> Centre, Farnborough, Hants, GU14 6YU, UK
>>> Registered in England & Wales No: 1996687****
>>>
>>> ** **
>>>
>>> *From:* [email-masked] [mailto:[email-masked]] *On
>>> Behalf Of *Abdussalam Baryun
>>> *Sent:* 26 February 2013 15:50
>>> *To:* Thomas Heide Clausen
>>> *Cc:* [email-masked]
>>>
>>> *Subject:* Re: [manet] [Technical Errata Reported] RFC5444 (3496)****
>>>
>>> ** **
>>>
>>> ** **
>>>
>>> **** WARNING ****
>>>
>>> *This message originates from outside our organisation, either from an
>>> external partner or the internet.**
>>> Keep this in mind if you answer this message.
>>> Please see this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>on how to deal with suspicious emails.
>>> *****
>>>
>>> On Tue, Feb 26, 2013 at 3:13 PM, Thomas Heide Clausen <
>>> [email-masked]> wrote:****
>>>
>>> ** **
>>>
>>> On 26 févr. 2013, at 16:00, Abdussalam Baryun <
>>> [email-masked]> wrote:****
>>>
>>>  I like that protocols use the packet sequence number, if thoes
>>> protocols you refered to don't use the packet SQN, then I recommend they
>>> reconsider.****
>>>
>>>  ** **
>>>
>>> Why?****
>>>
>>> ** **
>>>
>>> "Like" is not a technical argument.****
>>>
>>> ** **
>>>
>>>  ****
>>>
>>> I agree that it not a technical word, but also agree that *like* can be
>>> used in technical volunteer discussions. For example; Why OLSRv2 protocol
>>> does not use the packet sequence number SQN? does it accept random packets
>>> and ignore to sense sequence packets? Why the designers like it to be that
>>> way? Why does AB like protocols to sense SQN?****
>>>
>>>  ****
>>>
>>> My technical answer is better if it got into a technical draft, however,
>>> if a protocol senses the SQN it will be more rebust and more organised
>>> in MANET communication.****
>>>
>>>  ****
>>>
>>> AB****
>>>
>>>
>>> ********************************************************************
>>> This email and any attachments are confidential to the intended
>>> recipient and may also be privileged. If you are not the intended
>>> recipient please delete it from your system and notify the sender.
>>> You should not copy it or use it for any purpose nor disclose or
>>> distribute its contents to any other person.
>>> ********************************************************************
>>>
>>>
>>
>> _______________________________________________
>> manet mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/manet
>>
>>
>
>
> --
> Dan He
> ---------------------
> openstack contributor
> GPU stream programming
>
> http://wiki.openstack.org/Contributors
>
> Tel: +44-788-686-3428
>

---

From: Henning Rogge <[email-masked]>
Date: Tue, 26 Feb 2013 17:23:12 +0100

You are wrong...

Ulrich (to name the person you are talking about) likes input and
constructive feedback.

Your posts of the last weeks were not. You fought for DAYS against the
removal of the "packet sequence number attack" from the nhdp-threats
document without even understanding that it doesn't apply to NHDP.

On mailing lists like this there is an invisible thing called
"reputation"... the more noise someone makes about things that turn
out nothing at all, the less people will listen in the future.

That is why I suggested you should read the documents more carefully.

Henning Rogge

On Tue, Feb 26, 2013 at 5:16 PM, Abdussalam Baryun
<[email-masked]> wrote:
>>> On Tue, Feb 26, 2013 at 3:57 PM, Dearlove, Christopher (UK)
>>> <[email-masked]> wrote:
>>>>
>>>> NHDP has made it to RFC, and OLSRv2 has made it to one AD short of RFC -
>>>> and not for any related reason - without anyone thinking "we really should
>>>> use that because it might be there - though it also might not". Which
>>>> suggests your technical answer is wrong. And anyway, procedurally it's
>>>> multiple steps too late.
>>>>
>>>>
>>>>
>>>> --
>>>>
>>>> Christopher Dearlove
>>>>
>>>> Tel: +44 1245 242194 |  Fax: +44 1245 242124
>>>>
>>>> Registered in England & Wales No: 1996687
>>>>
>>>>
>>>>
>>>> From: [email-masked] [mailto:[email-masked]] On Behalf
>>>> Of Abdussalam Baryun
>>>> Sent: 26 February 2013 15:50
>>>> To: Thomas Heide Clausen
>>>> Cc: [email-masked]
>>>>
>>>>
>>>> Subject: Re: [manet] [Technical Errata Reported] RFC5444 (3496)
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> *** WARNING ***
>>>>
>>>> This message originates from outside our organisation, either from an
>>>> external partner or the internet.
>>>> Please see this process on how to deal with suspicious emails.
>>>>
>>>> On Tue, Feb 26, 2013 at 3:13 PM, Thomas Heide Clausen
>>>> <[email-masked]> wrote:
>>>>
>>>>
>>>>
>>>> On 26 févr. 2013, at 16:00, Abdussalam Baryun
>>>> <[email-masked]> wrote:
>>>>
>>>> I like that protocols use the packet sequence number, if thoes protocols
>>>> you refered to don't use the packet SQN, then I recommend they reconsider.
>>>>
>>>>
>>>>
>>>> Why?
>>>>
>>>>
>>>>
>>>> "Like" is not a technical argument.
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> way? Why does AB like protocols to sense SQN?
>>>>
>>>>
>>>>
>>>> if a protocol senses the SQN it will be more rebust and more organised in
>>>> MANET communication.
>>>>
>>>>
>>>>
>>>> AB
>>>>
>>>>

-- 
We began as wanderers, and we are wanderers still. We have lingured
long enough on the shores of the cosmic ocean. We are ready at last to
set sail for the stars - Carl Sagan

---

From: Thomas Clausen <[email-masked]>
Date: Tue, 26 Feb 2013 17:25:15 +0100

On Feb 26, 2013, at 5:16 PM, Abdussalam Baryun <[email-masked]> wrote:

> No one have right to try to discourage inputs, discussions are what this list is for. I know that editors don't like comments,

I do not believe that any editor/author of any WG document in this WG has refused to consider serious and well reasoned comments.
 
Note that "consider" may imply "finding that they did not apply", and that the operative words also are "serious and well reasoned".

Thomas

> but they have to live with it. For others that don't author work, please just do your job (not to comment on numbers of posts/input, or time spend) or keep quite,
>  
> AB
> 
> It is no good to discuss on the mailing list if it is not technical relevant. Otherwise, we received too many useless emails without any technical information. It is not a BBS
> website. 
> 
> 
> 
> On 26 February 2013 16:00, Abdussalam Baryun <[email-masked]> wrote:
> There is no harm in discussing, issues related to NHDP or RFC5444, or erratas, even after they were publish as we all know they are Request For Comments,
>  
> AB
> 
> On Tue, Feb 26, 2013 at 3:57 PM, Dearlove, Christopher (UK) <[email-masked]> wrote:
> NHDP has made it to RFC, and OLSRv2 has made it to one AD short of RFC - and not for any related reason - without anyone thinking "we really should use that because it might be there - though it also might not". Which suggests your technical answer is wrong. And anyway, procedurally it's multiple steps too late.
> 
>  
> 
> --
> 
> Christopher Dearlove
> 
> Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Abdussalam Baryun
> This message originates from outside our organisation, either from an external partner or the internet.
> On Tue, Feb 26, 2013 at 3:13 PM, Thomas Heide Clausen <[email-masked]> wrote:
> 
>  
> 
> On 26 févr. 2013, at 16:00, Abdussalam Baryun <[email-masked]> wrote:
> 
> I like that protocols use the packet sequence number, if thoes protocols you refered to don't use the packet SQN, then I recommend they reconsider.
> 
>  
> 
> Why?
> 
>  
> 
> I agree that it not a technical word, but also agree that *like* can be used in technical volunteer discussions. For example; Why OLSRv2 protocol does not use the packet sequence number SQN? does it accept random packets and ignore to sense sequence packets? Why the designers like it to be that way? Why does AB like protocols to sense SQN?
> 
>  
> 
> My technical answer is better if it got into a technical draft, however, if a protocol senses the SQN it will be more rebust and more organised in MANET communication.
> 
>  
> 
> AB
> 
> 
>

---

From: Daniel He <[email-masked]>
Date: Tue, 26 Feb 2013 16:27:09 +0000

That's not true. If you so called input is just as noise if they are not
technical relevant.
it wastes my time and my mailbox storage. I think most of other mailing
list users
will feel it as I felt.

Comments are most welcome if the comments are relevant.if the comments are
technical and critical. Comments should not be a "remind". you should not
speak
for the others. for example, " There was a input of John which I refered to
in the ticket,". you speak for yourself!!

On 26 February 2013 16:16, Abdussalam Baryun <[email-masked]>wrote:

>>  On 26 February 2013 16:00, Abdussalam Baryun <[email-masked]
>> > wrote:
>>
>>>>  NHDP has made it to RFC, and OLSRv2 has made it to one AD short of
>>>> RFC - and not for any related reason - without anyone thinking "we really
>>>> My technical answer is better if it got into a technical draft,
>>>> however, if a protocol senses the SQN it will be more rebust and more
>>>> organised in MANET communication.****
>>>>
>>>>  ****
>>>>
>>>> AB****
>>>>
>>>>

-- 
Dan He
---------------------
openstack contributor
GPU stream programming

Tel: +44-788-686-3428

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 26 Feb 2013 16:33:28 +0000

I do speak for my self, and if I use any input or draft in my input there
is no harm, but if editors say that I am the only input and if  they are
wrong, I may refer to other input.

AB

On Tue, Feb 26, 2013 at 4:27 PM, Daniel He <[email-masked]> wrote:

> for the others. for example, " There was a input of John which I refered
> to in the ticket,". you speak for yourself!!
>
>
>
>
>
>>>>> *This message originates from outside our organisation, either from
>>>>> an external partner or the internet.**
>>>>> I agree that it not a technical word, but also agree that *like* can
>>>>> be used in technical volunteer discussions. For example; Why OLSRv2
>>>>> protocol does not use the packet sequence number SQN? does it accept random
>>>>> packets and ignore to sense sequence packets? Why the designers like it to
>>>>> be that way? Why does AB like protocols to sense SQN?****
>>>>>
>>>>>  ****
>>>>>

---

From: Don Sturek <[email-masked]>
Date: Tue, 26 Feb 2013 08:33:56 -0800

Hi AB,

Sorry to wade in here but the comment "For others that don't author work,
please just do your job (not to comment on numbers of posts/input, or time
spend) or keep quite," makes no sense.

So far, as far as I can tell, there is no other support for your suggestion
to add sequence numbers to NHDP.   Whether other MANET members say that
explicitly (as Daniel did) or simply provide no support should mean the same
thing to the authors.

Don

From:  Abdussalam Baryun <[email-masked]>
Date:  Tuesday, February 26, 2013 8:16 AM
To:  Daniel He <[email-masked]>
Cc:  "[email-masked]" <[email-masked]>
Subject:  [manet] An input (was Re: [Technical Errata Reported] RFC5444
(3496))

AB

On Tue, Feb 26, 2013 at 4:10 PM, Daniel He <[email-masked]> wrote:
> It is no good to discuss on the mailing list if it is not technical relevant.
> Otherwise, we received too many useless emails without any technical
> information. It is not a BBS
> website. 
> 
> 
> 
>>> NHDP has made it to RFC, and OLSRv2 has made it to one AD short of RFC - and
>>> not for any related reason - without anyone thinking "we really should use
>>> that because it might be there - though it also might not". Which suggests
>>> your technical answer is wrong. And anyway, procedurally it's multiple steps
>>> too late.
>>> 
>>>  
>>> -- 
>>> Christopher Dearlove
>>> Tel: +44 1245 242194 <tel:%2B44%201245%20242194>  |  Fax: +44 1245 242124
>>> <tel:%2B44%201245%20242124>
>>> [email-masked] <mailto:[email-masked]>  |
>>> http://www.baesystems.com
>>> 
>>> Please see this process
>>> <http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/
>>> Dealing%20With%20Suspicious%20Emails.pdf>  on how to deal with suspicious
>>> emails.
>>> 
>>> I agree that it not a technical word, but also agree that *like* can be used
>>> in technical volunteer discussions. For example; Why OLSRv2 protocol does
>>> not use the packet sequence number SQN? does it accept random packets and
>>> ignore to sense sequence packets? Why the designers like it to be that way?
>>> Why does AB like protocols to sense SQN?
>>> 
>>>  
>>> 
>>> My technical answer is better if it got into a technical draft, however, if
>>> a protocol senses the SQN it will be more rebust and more organised in MANET
>>> communication.
>>> 
>>>  
>>> 
>>> AB
>>>  
> Tel: +44-788-686-3428 <tel:%2B44-788-686-3428>

_______________________________________________ manet mailing list
[email-masked] https://www.ietf.org/mailman/listinfo/manet

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 26 Feb 2013 16:35:21 +0000

I don't care about your mailbox, this is not my bussiness, you try to find
to solve your problems. Don't wats my time by your noise to my work in IETF
please,

AB

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 26 Feb 2013 16:37:11 +0000

On Tue, Feb 26, 2013 at 4:27 PM, Daniel He <[email-masked]> wrote:

> Comments are most welcome if the comments are relevant.

Who decides what is relavent. Please let the CHair do his job and never put
your nose into other peoples work

AB

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 26 Feb 2013 16:45:38 +0000

Hi Henning,

thanks for your respected advise and input,

> Ulrich (to name the person you are talking about) likes input and
His mistake is that he judge the consensus before it was clear, please read
Teco respond to the editor (Ulrich).

> document without even understanding that it doesn't apply to NHDP.

Is there a rule in MANET WG that I don't know about, please point,
otherwise every one can choose his/her strategy in confincing people/others

> out nothing at all, the less people will listen in the future.

I beleive what is important in IETF is not the participant reputation. the
more important is the WG reputation or the work reputation or the draft
reputation. Maybe I will add the editor reputation :) .........( pleae note
that my voise is never shouting)

> That is why I suggested you should read the documents more carefully.

I accept your suggestion and advises, and will try my best, don't forget
this will take some time for improving, as many drafts in IETF are
improving but still they do submit even if they are noise for some other
mailboxes.

AB

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 26 Feb 2013 16:48:16 +0000

It is ok, your comment is your opinion,

Thanks
AB

On Tue, Feb 26, 2013 at 4:33 PM, Don Sturek <[email-masked]> wrote:

> So far, as far as I can tell, there is no other support for your
> suggestion to add sequence numbers to NHDP.   Whether other MANET members
> say that explicitly (as Daniel did) or simply provide no support should
> mean the same thing to the authors.
>
> Don
>
>

---

From: Daniel He <[email-masked]>
Date: Tue, 26 Feb 2013 16:48:45 +0000

It is yourself decides what is relevant. if you have no sense whether you
are beating dead house, you are not a technical guy!
"what is chair's job", please refer to RFC2418.

On 26 February 2013 16:37, Abdussalam Baryun <[email-masked]>wrote:

> Who decides what is relavent. Please let the CHair do his job and never
> put your nose into other peoples work
>
> AB
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 26 Feb 2013 16:51:38 +0000

> are beating dead house, you are not a technical guy!

We all  know that, the one who decides what is not relavent or noise is the
Chair not you,

AB

> "what is chair's job", please refer to RFC2418.
I don't need to read any thing, just please stop taking my time,

AB

---

From: Daniel He <[email-masked]>
Date: Tue, 26 Feb 2013 17:57:54 +0000

you mean "pillar of salt"!

On 26 February 2013 16:35, Abdussalam Baryun <[email-masked]>wrote:

>> Comments are most welcome if the comments are relevant.if the comments
>> are technical and critical. Comments should not be a "remind". you should
>> not speak
>>>>>  There is no harm in discussing, issues related to NHDP or RFC5444,
>>>>> or erratas, even after they were publish as we all know they are Request
>>>>> For Comments,
>>>>>
>>>>> AB
>>>>>
>>>>>
>>>>>
>>>>>
>>>>

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Tue, 26 Feb 2013 18:02:51 +0000

Speaking as a co-chair -

This discussion has now gotten out of line. AB, you DON'T get the option of telling others to "keep quiet". This needs to stop. Now.

Stan

On Feb 26, 2013, at 11:16 AM, Abdussalam Baryun wrote:

No one have right to try to discourage inputs, discussions are what this list is for. I know that editors don't like comments, but they have to live with it. For others that don't author work, please just do your job (not to comment on numbers of posts/input, or time spend) or keep quite,

AB

On Tue, Feb 26, 2013 at 4:10 PM, Daniel He <[email-masked]<mailto:[email-masked]>> wrote:
It is no good to discuss on the mailing list if it is not technical relevant. Otherwise, we received too many useless emails without any technical information. It is not a BBS
website.

On 26 February 2013 16:00, Abdussalam Baryun <[email-masked]<mailto:[email-masked]>> wrote:
There is no harm in discussing, issues related to NHDP or RFC5444, or erratas, even after they were publish as we all know they are Request For Comments,

AB

On Tue, Feb 26, 2013 at 3:57 PM, Dearlove, Christopher (UK) <[email-masked]<mailto:[email-masked]>> wrote:
NHDP has made it to RFC, and OLSRv2 has made it to one AD short of RFC - and not for any related reason - without anyone thinking "we really should use that because it might be there - though it also might not". Which suggests your technical answer is wrong. And anyway, procedurally it's multiple steps too late.

--
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194<tel:%2B44%201245%20242194> |  Fax: +44 1245 242124<tel:%2B44%201245%20242124>
[email-masked]<mailto:[email-masked]> | http://www.baesystems.com<http://www.baesystems.com/>

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Abdussalam Baryun
Sent: 26 February 2013 15:50
To: Thomas Heide Clausen
Cc: [email-masked]<mailto:[email-masked]>

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Keep this in mind if you answer this message.
Please see this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf> on how to deal with suspicious emails.
On Tue, Feb 26, 2013 at 3:13 PM, Thomas Heide Clausen <[email-masked]<mailto:[email-masked]>> wrote:

On 26 févr. 2013, at 16:00, Abdussalam Baryun <[email-masked]<mailto:[email-masked]>> wrote:
I like that protocols use the packet sequence number, if thoes protocols you refered to don't use the packet SQN, then I recommend they reconsider.

Why?

AB

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

--
Dan He
---------------------
openstack contributor
GPU stream programming

Tel: +44-788-686-3428<tel:%2B44-788-686-3428>

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Tue, 26 Feb 2013 18:04:04 +0000

OK, as a chair, I'll reply to this email as well.

THIS. IS. NOISE. It is not relevant. Please halt, cease, and desist.

Stan

On Feb 26, 2013, at 11:51 AM, Abdussalam Baryun wrote:

On Tue, Feb 26, 2013 at 4:48 PM, Daniel He <[email-masked]<mailto:[email-masked]>> wrote:
It is yourself decides what is relevant. if you have no sense whether you
are beating dead house, you are not a technical guy!

We all  know that, the one who decides what is not relavent or noise is the Chair not you,

AB

AB

On 26 February 2013 16:37, Abdussalam Baryun <[email-masked]<mailto:[email-masked]>> wrote:
On Tue, Feb 26, 2013 at 4:27 PM, Daniel He <[email-masked]<mailto:[email-masked]>> wrote:
That's not true. If you so called input is just as noise if they are not technical relevant.
it wastes my time and my mailbox storage. I think most of other mailing list users
will feel it as I felt.

Who decides what is relavent. Please let the CHair do his job and never put your nose into other peoples work

AB

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 26 Feb 2013 18:14:14 +0000

I did not tell others to keep quite, I said that not to claim that I am
noise or spam, you misunderstood me, I like comments, but never discouraging
Any way I will stop replying to such messages that don't respect others,

AB
On Tue, Feb 26, 2013 at 6:02 PM, Stan Ratliff (sratliff) <[email-masked]

>  Speaking as a co-chair -
>
>  This discussion has now gotten out of line. AB, you DON'T get the option
> of telling others to "keep quiet". This needs to stop. Now.
>
>  Stan
>