Subject: [manet] 'Useless' in AODVv2 draft 25

From: "Dowdell, John" <[email-masked]>
Date: Mon, 4 Feb 2013 11:26:30 +0000

Charlie

I note that in draft-ietf-manet-dymo-25 you use the word 'useless' in sections 5.7, 7.4, 7.5.1, 7.6 and 13.4.

Please can you clarify the meaning of the word as you use it here, assuming the meaning is the same in all those sections? Do you mean:

-          out of date (in that the overall situation has changed and the content is wrong)
-          repeated (in that the content has previously been advised and is being re-advised in the same form)
-          not needed (because the content advises a less satisfactory route)
-          or some other meaning?

Regards
John

The information contained within this e-mail and any files attached to this e-mail is private and in addition may include commercially sensitive information. The contents of this e-mail are for the intended recipient only and therefore if you wish to disclose the information contained within this e-mail or attached files, please contact the sender prior to any such disclosure. If you are not the intended recipient, any disclosure, copying or distribution is prohibited. Please also contact the sender and inform them of the error and delete the e-mail, including any attached files from your system. Cassidian Limited, Registered Office : Quadrant House, Celtic Springs, Coedkernew, Newport, NP10 8FZ Company No: 04191036 http://www.cassidian.com

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 04 Feb 2013 11:35:53 -0800

Hello John,

The word "useless" means "redundant" in the various places it appears
in the document.  In each case where "useless" appears, I have checked
that "redundant" keeps the proper meaning.  I agree that your other
two meanings of "useless" ("out-of-date" or "suboptimal") are often
used, but not in the AODVv2 specification.

I looked for instances of "useful".  There are occurrences of "useful"
that do NOT mean "not redundant".  For instance, "useful" has the
meaning "relevant" at certain places in the document.  "useful" also
means "applicable".

If you think that some of these uses are similarly ambiguous,
please don't hesitate to point them out.

Regards,
Charlie P.

On 2/4/2013 3:26 AM, Dowdell, John wrote:
> Please can you clarify the meaning of the word as you use it here, 
> assuming the meaning is the same in all those sections? Do you mean:
>
> -out of date (in that the overall situation has changed and the 
> content is wrong)
>
> -repeated (in that the content has previously been advised and is 
> being re-advised in the same form)
>
> -not needed (because the content advises a less satisfactory route)
>
> -or some other meaning?
>
> Regards
>
> John
>
> The information contained within this e-mail and any files attached to 
> this e-mail is private and in addition may include commercially 
> sensitive information. The contents of this e-mail are for the 
> intended recipient only and therefore if you wish to disclose the 
> information contained within this e-mail or attached files, please 
> contact the sender prior to any such disclosure. If you are not the 
> intended recipient, any disclosure, copying or distribution is 
> prohibited. Please also contact the sender and inform them of the 
> error and delete the e-mail, including any attached files from your 
> system. Cassidian Limited, Registered Office : Quadrant House, Celtic 
> Springs, Coedkernew, Newport, NP10 8FZ Company No: 04191036 
> http://www.cassidian.com
>
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

-- 
Regards,
Charlie P.

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 5 Feb 2013 11:42:41 +0000

I think the word useful means useful and useless means useless, we cannot
change English meanings only if specified in draft. I understood that
useless means NOT USED or NOT USEFUL, in my interpretation.

If the author meant *redundant*, or other, then recommend mention that in
the draft.

AB

On Mon, Feb 4, 2013 at 7:35 PM, Charles E. Perkins <[email-masked]>wrote:

> I note that in draft-ietf-manet-dymo-25 you use the word ‘useless’ in
> sections 5.7, 7.4, 7.5.1, 7.6 and 13.4.
>
>
>
> this e-mail is private and in addition may include commercially sensitive
> information. The contents of this e-mail are for the intended recipient
> only and therefore if you wish to disclose the information contained within
> this e-mail or attached files, please contact the sender prior to any such
> disclosure. If you are not the intended recipient, any disclosure, copying
> or distribution is prohibited. Please also contact the sender and inform
> them of the error and delete the e-mail, including any attached files from
> your system. Cassidian Limited, Registered Office : Quadrant House, Celtic
> manet mailing [email-masked]://www.ietf.org/mailman/listinfo/manet
>
>
>
> --
> Regards,
> Charlie P.
>
>

---

From: "Dowdell, John" <[email-masked]>
Date: Tue, 5 Feb 2013 11:58:38 +0000

Abdussalam

As you point out, 'useless' can have a number of meanings depending on the context in which the word is used, and is therefore open to interpretation. I was asking Charlie to clarify the meaning that he wanted to convey in each of the contexts in which he used the word, so that the scope for different interpretations can be reduced or eliminated. He has now done so, and I believe he will amend the next draft to use a word that conveys a more specific meaning.

John

________________________________
From: Abdussalam Baryun [mailto:[email-masked]]
Sent: 05 February 2013 11:43
To: manet
Cc: Dowdell, John; Charles E. Perkins
Subject: Re: [manet] 'Useless' in AODVv2 draft 25

I think the word useful means useful and useless means useless, we cannot change English meanings only if specified in draft. I understood that useless means NOT USED or NOT USEFUL, in my interpretation.

If the author meant *redundant*, or other, then recommend mention that in the draft.

AB
On Mon, Feb 4, 2013 at 7:35 PM, Charles E. Perkins <[email-masked]<mailto:[email-masked]>> wrote:

Hello John,

Regards,
Charlie P.

Regards
John

manet mailing list

[email-masked]<mailto:[email-masked]>

--

Regards,

Charlie P.

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 5 Feb 2013 13:03:18 +0000

On Tue, Feb 5, 2013 at 11:58 AM, Dowdell, John
<[email-masked]>wrote:

>  Abdussalam
>
>
>
> As you point out, ‘useless’ can have a number of meanings depending on the
> context in which the word is used, and is therefore open to interpretation.
> I was asking Charlie to clarify the meaning that he wanted to convey in
> each of the contexts in which he used the word, so that the scope for
> different interpretations can be reduced or eliminated. He has now done so,
> and I believe he will amend the next draft to use a word that conveys a
> more specific meaning.
>
>
>
>
>
The reply of the I-D authors to your message did not include any amendment
nor intention of change to be done, please advise,

AB

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 05 Feb 2013 12:00:37 -0800

Hello Abdussalam,

Here are a few changes that I have proposed, in accordance with the
terminology discussions.  These proposals include a suggestion about
replacing "useless" by "redundant".

> The term "HandlingRtr" appears in various places of the AODVv2
> specification.  Most of the appearances are located in section 7.5,
> "Handling a Received RteMsg".  It turns out that the section reads
> quite well if "HandlingRtr" is simply replaced by "the router", as
> long as it is made clear in the beginning of the section that the
> router under discussion is the router handling the RteMsg.
>
> I propose to make this change, and to investigate whether other
> instances of "HandlingRtr" are amenable to better wordsmithing.
>
> According to the earlier discussion about "useless", I propose
> to replace existing instances of "useless" by "redundant". Then,
> section 7.6 becomes "Suppressing Redundant RteMsgs".
>
> Another aspect of simplification would be to replace occurrences
> of "RteMsg" by "RREQ" within section 7.6, since the specification
> does not mandate suppressing redundant RREP messages.  Such
> redundant RREP messages typically would not occur unless the
> optional feature in section 13.4 were implemented.  With this
> additional change, section 7.6 would be entitled
> "Suppressing Redundant RREQ messages".

Regards,
Charlie P.

On 2/5/2013 5:03 AM, Abdussalam Baryun wrote:
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Abdussalam
>
>     As you point out, ‘useless’ can have a number of meanings
>     depending on the context in which the word is used, and is
>     therefore open to interpretation. I was asking Charlie to clarify
>     the meaning that he wanted to convey in each of the contexts in
>     which he used the word, so that the scope for different
>     interpretations can be reduced or eliminated. He has now done so,
>     and I believe he will amend the next draft to use a word that
>     conveys a more specific meaning.
>
> The reply of the I-D authors to your message did not include any 
> amendment nor intention of change to be done, please advise,
> AB
>

-- 
Regards,
Charlie P.

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 6 Feb 2013 04:18:39 +0100

IMO, I still like the word useless because more related if we read the
full draft. Not sure why it is needed to be change, the three meanings
that were asked have no harm, or do you think they do? or do you think
redundant covers the three asked meanings?

In your first reply message you mention like a missing of meaning of
the word useful more than useless.

I don't think your proposal will be reasonable for me if you ignore
changing the AODVv2 test of usefulness in draft. The change proposed
for section 7.6 is ok.

AB