Subject: [manet] DYMO Implementation

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 21 Feb 2013 15:42:09 +0100

Hi Jiazi,

Yes there are many implementation but not presented well, I think the
authors have an implementation, and also many researchers have tested
the old DYMO,

AB
++
Sub: Re: [manet] Why the WG Reactive Protocol to be Compatible with another?
On 2/20/13, Jiazi Yi <[email-masked]> wrote:
> I have no idea if there is DYMO implementation,
>
http://www.ietf.org/mail-archive/web/manet/current/msg14948.html

---

From: Henning Rogge <[email-masked]>
Date: Thu, 21 Feb 2013 15:46:26 +0100

> authors have an implementation, and also many researchers have tested

This is a very bold statement... do you have some evidence for this?

I remember a few people trying to track down a working AODV 
implementation and failing.

But I never have seen a DYMO implementation.

If someone on this list HAS an implementation, I would like to hear 
about it.

Henning Rogge
-- 
Diplom-Informatiker Henning Rogge , Fraunhofer-Institut für
Kommunikation, Informationsverarbeitung und Ergonomie FKIE
Kommunikationssysteme (KOM)
Fraunhofer Straße 20, 53343 Wachtberg, Germany
Telefon +49 228 9435-961,   Fax +49 228 9435 685
mailto:[email-masked] http://www.fkie.fraunhofer.de

---

From: Francisco Javier Ros Muñoz <[email-masked]>
Date: Thu, 21 Feb 2013 16:02:41 +0100

Hi Henning,

A long time ago I wrote an implementation that is mostly compliant with draft dymo-04, and it incorporates some features from dymo-05. Therefore, I'm afraid that the codebase is far from being compliant with aodvv2-00. Unfortunately, I have no time to maintain this code any more. However it is publicly available, so if anyone is interested in updating it please go ahead (I don't know whether this is better than starting from scratch).

DYMOUM:
http://masimum.inf.um.es/fjrm/?page_id=126

You can find a list of other implementations (AFAIK also outdated) in
http://www.ianchak.com/dymo/

Best,
fran

El 21/02/2013, a las 15:46, Henning Rogge escribió:

> I remember a few people trying to track down a working AODV implementation and failing.
> 
> If someone on this list HAS an implementation, I would like to hear about it.
> 
> Henning Rogge
> -- 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

--
Francisco J. Ros, PhD
Dept. of Information and Communications Engineering
University of Murcia, Murcia (Spain)
http://masimum.inf.um.es/fjrm/

---

From: Jiazi Yi <[email-masked]>
Date: Thu, 21 Feb 2013 16:15:12 +0100

AB, 

I'm aware of some dymo implementation in academic conferences. However, that was quite long time ago. DYMO had very big changes since its -21. 

When I'm saying implementations, I actually mean:
	o It's complaint to the latest version of the document
	o It's publicly known (not necessarily open source)

For example, when I'm saying LOADng has 4 publicly known implementations, it means:
	o It's updated to the latest (or very recent) revision
	o Those four are publicly known, in the interop draft, and different scientific publications. I know there are several others, but at this point, I can't disclose them (so they are not counted into 4 known implementations). 

best

Jiazi

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 21 Feb 2013 16:24:12 +0100

Hi Jiazi,

I know that DYMO implements are old, (hopfully developed to new
AODVv2) I already stated that, just wanted to answer to your question.
Regarding LOADng it was an implementation for LLNs not for MANETs. So
far there is no implementation that uses the RFC5498, which I am
interested in as OLSRv2 is using,

AB

On 2/21/13, Jiazi Yi <[email-masked]> wrote:
> AB,
>
> I'm aware of some dymo implementation in academic conferences. However, that
> was quite long time ago. DYMO had very big changes since its -21.
>
> 	o Those four are publicly known, in the interop draft, and different
> scientific publications. I know there are several others, but at this point,
> I can't disclose them (so they are not counted into 4 known
> implementations).
>
> best
>
> Jiazi
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 21 Feb 2013 16:39:17 +0100

I agree with your advise, we will need to look into the available DYMO
implementations and use the best for the new reactive protocol, I hope
the authors can give us advise on this important matter,

As I agree with one participant's input that IETF is about running code,

AB

On 2/21/13, Francisco Javier Ros Muñoz <[email-masked]> wrote:
> Hi Henning,
>
> A long time ago I wrote an implementation that is mostly compliant with
> draft dymo-04, and it incorporates some features from dymo-05. Therefore,
> I'm afraid that the codebase is far from being compliant with aodvv2-00.
> Unfortunately, I have no time to maintain this code any more. However it is
> publicly available, so if anyone is interested in updating it please go
> ahead (I don't know whether this is better than starting from scratch).
>
> DYMOUM:

---

From: Jiazi Yi <[email-masked]>
Date: Thu, 21 Feb 2013 16:40:42 +0100

On Feb 21, 2013, at 4:24 PM, Abdussalam Baryun <[email-masked]> wrote:

> Regarding LOADng it was an implementation for LLNs not for MANETs.

That's not true. 

> So
> far there is no implementation that uses the RFC5498,

the using of ports is just a matter of setting one parameter in the code. 

Jiazi

> which I am

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 21 Feb 2013 17:47:17 +0100

As reply to [*] I want more to discuss the DYMO implementations,
interoperability and running code than to discuss comparison with
others,

[*] http://www.ietf.org/mail-archive/web/manet/current/msg14951.html

AB

---

From: C Chauvenet <[email-masked]>
Date: Thu, 21 Feb 2013 16:56:02 +0000

HI,

Le 21 févr. 2013 à 16:40, Jiazi Yi a écrit :

On Feb 21, 2013, at 4:24 PM, Abdussalam Baryun <[email-masked]<mailto:[email-masked]>> wrote:

Hi Jiazi,

That's not true.

Maybe AB had this feeling when reading this previously quoted mail ? :

From: Ulrich Herberg <[email-masked]<mailto:[email-masked]>>
Date: November 29, 2011 7:00:08 PM GMT+01:00
Subject: DYMO
Joe, Stan,

During the IETF, Thomas mentioned that we are working on a draft, called "LOADng" (draft-clausen-lln-loadng). The draft specifies a reactive routing protocol, mainly intended for low-power and lossy networks (LLNs).

Cédric.

So

Jiazi

which I am

AB

On 2/21/13, Jiazi Yi <[email-masked]<mailto:[email-masked]>> wrote:
AB,

For example, when I'm saying LOADng has 4 publicly known implementations, it
means:

best

Jiazi

On Feb 21, 2013, at 3:42 PM, Abdussalam Baryun <[email-masked]<mailto:[email-masked]>>
wrote:

Hi Jiazi,

AB
++
Sub: Re: [manet] Why the WG Reactive Protocol to be Compatible with
another?
On 2/20/13, Jiazi Yi <[email-masked]<mailto:[email-masked]>> wrote:
I have no idea if there is DYMO implementation,

http://www.ietf.org/mail-archive/web/manet/current/msg14948.html
_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

---

From: Jiazi Yi <[email-masked]>
Date: Thu, 21 Feb 2013 18:14:48 +0100

Hi, 

> Maybe AB had this feeling when reading this previously quoted mail ? : 

Then this *feeling* is wrong. 

Jiazi

> 
>> From: Ulrich Herberg <[email-masked]>

---

From: Ulrich Herberg <[email-masked]>
Date: Thu, 21 Feb 2013 13:15:49 -0800

Cédric,

do we honestly want to start this discussion about LLNs vs MANET again?
Personally, I don't want to.

AB, I don't know how often we have to repeat this on the list: The LOADng
implementations tested in the interop tests are conform with the latest
LOADng revision and use RFC5444/5498.

Best regards
Ulrich

On Thu, Feb 21, 2013 at 8:56 AM, C Chauvenet <[email-masked]>wrote:

>  During the IETF, Thomas mentioned that we are working on a draft, called
> "LOADng" (draft-clausen-lln-loadng). The draft specifies a reactive routing
> protocol, mainly intended for low-power and lossy networks (LLNs).
>
>
>
>  Cédric.
>
>
> So
>
>   On Feb 21, 2013, at 3:42 PM, Abdussalam Baryun <
> [email-masked]>
>
>  wrote:
>
>
>   Hi Jiazi,
>
>

---

From: C Chauvenet <[email-masked]>
Date: Thu, 21 Feb 2013 21:41:58 +0000

Le 21 févr. 2013 à 22:15, Ulrich Herberg a écrit :

Cédric,

do we honestly want to start this discussion about LLNs vs MANET again? Personally, I don't want to.

Not at all.
As requested by chairs, I think that we should now act decisions and move on toward a good WG document.

Cédric

AB, I don't know how often we have to repeat this on the list: The LOADng implementations tested in the interop tests are conform with the latest LOADng revision and use RFC5444/5498.

Best regards
Ulrich

On Thu, Feb 21, 2013 at 8:56 AM, C Chauvenet <[email-masked]<mailto:[email-masked]>> wrote:
HI,

Hi Jiazi,

That's not true.

Cédric.

So

Jiazi

which I am

AB

best

Jiazi

Hi Jiazi,

AB
++

---

From: Henning Rogge <[email-masked]>
Date: Fri, 22 Feb 2013 07:23:30 +0100

> http://www.ianchak.com/dymo/

I have look through the list of the implementations.

One of them is DYMO-10 (aka July 2007).
One is DYMO-9 (aka May 2007).

the rest is DYMO-4 or DYMO-5 (March/June 2006).

I was unable to track down a more recent implementation on my own.

If this list is representative, there is no current DYMO implementation, 
not even close.

@Charles E. Perkins:

Are you aware of a recent DYMO implementation (maybe something done in 
2012?).

Henning Rogge