Subject: [manet] DLEP flow control scheme on shared medium radio

From: Henning Rogge <[email-masked]>
Date: Tue, 13 Aug 2013 14:04:57 +0200

Hi,

I have been looking at the DLEP flow control mechanism and wonder how to 
make it work on a radio with a shared medium.

Instead of having a queue for each neighbor, radios with a shared medium 
might have only a single queue in total (or maybe one per layer-2 priority).

How can we support this with the DLEP flow control?

Henning Rogge
-- 
Diplom-Informatiker Henning Rogge , Fraunhofer-Institut für
Kommunikation, Informationsverarbeitung und Ergonomie FKIE
Kommunikationssysteme (KOM)
Fraunhofer Straße 20, 53343 Wachtberg, Germany
Telefon +49 228 9435-961,   Fax +49 228 9435 685
mailto:[email-masked] http://www.fkie.fraunhofer.de

---

From: "Duke, Martin" <[email-masked]>
Date: Tue, 13 Aug 2013 15:34:43 +0000

I concur -- it would be easy enough to allow flow control TLVs in peer update messages if the context is appropriate.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Henning Rogge
Sent: Tuesday, August 13, 2013 5:05 AM
To: [email-masked]
Subject: [manet] DLEP flow control scheme on shared medium radio

Hi,

I have been looking at the DLEP flow control mechanism and wonder how to make it work on a radio with a shared medium.

Instead of having a queue for each neighbor, radios with a shared medium might have only a single queue in total (or maybe one per layer-2 priority).

Henning Rogge
--
Diplom-Informatiker Henning Rogge , Fraunhofer-Institut für Kommunikation, Informationsverarbeitung und Ergonomie FKIE Kommunikationssysteme (KOM) Fraunhofer Straße 20, 53343 Wachtberg, Germany
Telefon +49 228 9435-961,   Fax +49 228 9435 685
mailto:[email-masked] http://www.fkie.fraunhofer.de

---

From: Henning Rogge <[email-masked]>
Date: Tue, 13 Aug 2013 17:53:57 +0200

Without DLEP flow control its practically impossible to run QoS on the
router when connected to an external radio.

We could just activate "fq-codel", but that would still kill priorization.

Henning Rogge

On Tue, Aug 13, 2013 at 5:34 PM, Duke, Martin <[email-masked]> wrote:
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

-- 
We began as wanderers, and we are wanderers still. We have lingered
long enough on the shores of the cosmic ocean. We are ready at last to
set sail for the stars - Carl Sagan