Subject: [manet] DLEP and modem Link Property Advertisements

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 5 Mar 2014 08:47:01 +0100

Hi Will and Henning,

I am not sure of the work in progress related to draft-ivancic and
draft-rogge mentioned below. However, I think they are interesting to
be consider by the WG. Was there a decision made on the drafts by the
authors or was it to be submitted else where. Please help. Thanking you,

AB

On Monday, October 22, 2012, Ivancic, William D. (GRC-RHN0) wrote:

>    A few months ago (time flies), the authors of modemLPA have been in discussion with the authors of
>    "Dynamic Link Exchange Protocol (DLEP)" [I-D.ietf-manet-dlep] to
>    determine if DLEP will fullfil the needs that ModemLPA is targeted
>    at.  DLEP is currently a client/server session oriented protocol that
>    provides link layer information to directly connected devices -
>    generally routers.  The Modem Link Property Advertisment protocol
>    broadcasts link status notifications to directly-attached devices and
>    devices or applications that may be multiple hops away from the modem
>    (or other sending device).
>
>    It should be possible to use the DLEP message formats without all the
>    signalling required for the DLEP client/server session to perform the
>    functions addressed in this draft.  The modem would simply provide
>    link states out via multicast or unicast UDP datagrams (DLEP-Lite).
>    Whether or not this is a good idea, or acceptable to the manet group,
>    is yet to be determined.
>
> In the mean time, This modemLPA document was originally submitted to the IRTF mobopts research group as an individual submission draft-ivancic-mobopts-modemlpa-01.  That research group as recently closed down.  I am looking for a new place to put updates until a decision is made on DLEP-Lite. Is the manet group the right place?  I really don't know if this is the right group or if someplace else may be more appropriate.  I see no other working groups or research groups really looking at layer-2 triggers.
>
>
> Finally:
>
>    A PERL script, modem-LPA-packetgen.pl <http://modem-lpa-packetgen.pl/>, has been placed in sourceforge
>    as open source software.  The PERL script generates modemLPA packets
>    base on the modem link property advertisement draft,
>    "draft-ivancic-mobopts-modemlpa-01".
>
>    The script was used to demonstrate modemLPA by controlling the rate
>    on a file transfer protocol.  The file transfer protocol used was
>    Saratoga and is implemented in a PERL script.  The Saratoga PERL
>    script is available on SourceForge.  Search for saratoga and the
>    script will be in the directory saratoga-v1-perl.
>
>    This script and the Saratoga implementation currently use a multicast
>    address of 226.1.1.2.  The all routers address of 224.0.0.2 is
>    suppose to be used, but the particular Linux machines we where
>    running on did not want to pass 224.0.0.2 and we did not have
>    sufficient time to determine why.
>
>    Eventually, we hope to include code for GNU radios that implement
>    modemLPA (Or perhap DLEP-lite).
>
>    Code is available for modemLPA from
>    http://sourceforge.net/projects/modemlpa/
>
>    Code is available for Saratoga from
>    http://saratoga.cvs.sourceforge.net/viewvc/saratoga/
>
>
> I am currently planning on attending the IETF meetings in Atlanta.
>
> - Will Ivancic
>

On Monday, November 5, 2012, Henning Rogge wrote:

> On Thu, Oct 25, 2012 at 8:56 AM, Henning Rogge
> <[email-masked]> wrote:
> > Hi,
> >
> > I have uploaded my draft document to our eu-project webpage. I cannot
> upload
> > it to the IETF tracker at the moment because of the coming IETF.
>
> Now that the submission block period is over, I have also uploaded the
> draft properly to the IETF as a personal draft:
>
> https://datatracker.ietf.org/doc/draft-rogge-stateless-rfc5444-dlep/
>
> Henning Rogge
>
> --
> Steven Hawkings about cosmic inflation: "An increase of billions of
> billions of percent in a tiny fraction of a second. Of course, that
> was before the present government."
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: Henning Rogge <[email-masked]>
Date: Wed, 5 Mar 2014 20:48:38 +0000

Hi,

we talked about the different approaches for DLEP a LONG time ago... I
suggested a "stateless UDP" approach, but the WG consensus decided for
Stans DLEP approach.

I backed down and began to work on helping to improve Stan's DLEP draft.

Can we consider this issue resolved (with WG consensus) after you
didn't even raised the point at the WG meeting today?

Henning

On Wed, Mar 5, 2014 at 7:47 AM, Abdussalam Baryun
<[email-masked]> wrote:
> draft-rogge mentioned below. However, I think they are interesting to be
> consider by the WG. Was there a decision made on the drafts by the authors
> or was it to be submitted else where. Please help. Thanking you,
>
> AB
>
>
>> In the mean time, This modemLPA document was originally submitted to the
>> IRTF mobopts research group as an individual submission
>> draft-ivancic-mobopts-modemlpa-01.  That research group as recently closed
>> down.  I am looking for a new place to put updates until a decision is made
>> on DLEP-Lite. Is the manet group the right place?  I really don't know if
>> this is the right group or if someplace else may be more appropriate.  I see
>> no other working groups or research groups really looking at layer-2
>> triggers.
>>
>>
>> Finally:
>>
>>    A PERL script, modem-LPA-packetgen.pl, has been placed in sourceforge

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 5 Mar 2014 22:27:31 +0100

Yes Henning,

I decided to back down to get progress for the DLEP, or to find that my
argument may not get change done. But did you plan to progress that draft
below of yours.

AB

On Wednesday, March 5, 2014, Henning Rogge wrote:

> > .

---

From: Henning Rogge <[email-masked]>
Date: Wed, 5 Mar 2014 21:28:48 +0000

No,

because of the WG consensus about DLEP I don't plan to continue to
work on my informal draft about rfc5444 dlep.

Henning