Subject: [manet] draft-rogge-baccelli-olsrv2-ett-metric

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Wed, 5 Mar 2014 11:12:24 +0000

Working Group Participants, 

The consensus in the room this morning at IETF 89 is to accept this as a working group document. If there is opposition to this action, please respond on the list no later than March 7, 2014. 

Regards,
Stan

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 5 Mar 2014 12:21:58 +0100

> On 5 mars 2014, at 12:12, "Stan Ratliff (sratliff)" <[email-masked]> wrote:
> 

I'd like to respond with STRONG SUPPORT for this document being adopted by the WG. 

I believe that it's interesting, is needed, and is quite readable. I've found a few nits and issues, and a few things were raised at the mike today that probably should be developed in the document -  but I am quite confident that the authors will be able to hammer those out quickly, once the document is adopted.

Let's do it!

Thomas

> Regards,
> Stan
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Teco Boot <[email-masked]>
Date: Wed, 5 Mar 2014 12:23:00 +0100

May I suggest to rename to draft-manet-olsrv2-dat-metric?

Teco

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 5 Mar 2014 12:25:21 +0100

> On 5 mars 2014, at 12:23, Teco Boot <[email-masked]> wrote:
> 

That's actually not a bad suggestion, seconded.

Also, while we're listing things, I think that the most important missing bit is "a section discussing the experiments intended" to be developed.

Best,

Thomas

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 5 Mar 2014 12:51:41 +0100

I support the proposal, thanks to authors,

AB

On Wednesday, March 5, 2014, Stan Ratliff (sratliff) wrote:

> The consensus in the room this morning at IETF 89 is to accept this as a
> working group document. If there is opposition to this action, please
> respond on the list no later than March 7, 2014.
>
> Regards,
> Stan
> [email-masked] <javascript:;>

---

From: Jiazi YI <[email-masked]>
Date: Wed, 5 Mar 2014 12:55:45 +0100

I'm in favor of accepting it as WG document

Jiazi

On Wed, Mar 5, 2014 at 12:12 PM, Stan Ratliff (sratliff) <[email-masked]
> wrote:

---

From: Henning Rogge <[email-masked]>
Date: Wed, 5 Mar 2014 12:21:28 +0000

I planned to rename it to something similar to this anyways, so I am okay
with this suggestion.

Henning

---

From: Ulrich Herberg <[email-masked]>
Date: Wed, 5 Mar 2014 13:23:21 +0000

Hi,

I also support adoption of the document.

Regarding the name, I am not sure I understand the proposal. Do you suggest
to rename it to draft-*ietf*-manet-olsrv2-dat-metric, or
draft-*rogge*-manet-olsrv2-dat-metric?
(i.e., to rename the draft while it is still an individual draft or when
submitting it as WG document should it be adopted).

Regards
Ulrich

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 5 Mar 2014 14:30:08 +0100

Ulrich,

Spinning through another draft-rogge- just for renaming does seem a little excessive. I believe that the tracker can easily get populated with appropriate "replaced by" information, regardless of name changes.

Thomas

On 05 Mar 2014, at 14:23 , Ulrich Herberg <[email-masked]> wrote:

> Regarding the name, I am not sure I understand the proposal. Do you suggest to rename it to draft-ietf-manet-olsrv2-dat-metric, or draft-rogge-manet-olsrv2-dat-metric? (i.e., to rename the draft while it is still an individual draft or when submitting it as WG document should it be adopted). 
> 
> Regards
> Ulrich
> 
>

---

From: Ulrich Herberg <[email-masked]>
Date: Wed, 5 Mar 2014 13:33:08 +0000

Thomas,

yes, that's what I thought, too. It's just that Teco suggested to rename it
to draft-manet-... (without ietf or rogge after "draft"). It's of course
not a requirement for an individual draft. I just wanted to make sure I
understand the proposal correctly.
I also suggest to not rename the current draft, but when submitting it as
WG document (if that is the consensus of the WG). Once the draft is
uploaded, I can set the "replaced by" accordingly.

Regards
Ulrich

On Wed, Mar 5, 2014 at 1:30 PM, Thomas Heide Clausen <
[email-masked]> wrote:

> Ulrich,
>
> Spinning through another draft-rogge- just for renaming does seem a little
> excessive. I believe that the tracker can easily get populated with
> appropriate "replaced by" information, regardless of name changes.
>
> Thomas
>
> Regarding the name, I am not sure I understand the proposal. Do you
> suggest to rename it to draft-*ietf*-manet-olsrv2-dat-metric, or draft-
> *rogge*-manet-olsrv2-dat-metric? (i.e., to rename the draft while it is
> still an individual draft or when submitting it as WG document should it be
> adopted).
>
> Regards
> Ulrich
>
>
>> Op 5 mrt. 2014, om 12:12 heeft Stan Ratliff (sratliff) <
>> [email-masked]> het volgende geschreven:
>>
>> > The consensus in the room this morning at IETF 89 is to accept this as
>> a working group document. If there is opposition to this action, please

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 5 Mar 2014 20:51:59 +0100

Hi Teco

I thought you and Henning agreed that it is not must related to OLSRv2.
However, I don't mind your suggestion.

AB

On Wednesday, March 5, 2014, Teco Boot wrote:

> Op 5 mrt. 2014, om 12:12 heeft Stan Ratliff (sratliff) <[email-masked]<javascript:;>>
> het volgende geschreven:
>

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Wed, 5 Mar 2014 20:11:25 +0000

Yeah, I also heard some chatter about uses that are not associated with OLSRv2. Having said that, I don't have a strong opinion either way. I'll just ask - are we sure we want to rename it as an OSLRv2 doc?

Regards,
Stan

On Mar 5, 2014, at 2:51 PM, Abdussalam Baryun <[email-masked]<mailto:[email-masked]>> wrote:

Hi Teco

I thought you and Henning agreed that it is not must related to OLSRv2. However, I don't mind your suggestion.

AB

Teco

Op 5 mrt. 2014, om 12:12 heeft Stan Ratliff (sratliff) <[email-masked]<javascript:;>> het volgende geschreven:

> [email-masked]<javascript:;>

_______________________________________________
manet mailing list
[email-masked]<javascript:;>
https://www.ietf.org/mailman/listinfo/manet

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 5 Mar 2014 20:16:04 +0000

We need to scope the experiment correctly so as to get any meaningful results and feedback. 

My experience is that proactive and reactive protocols have and behave *very* different wrt metrics and I would not bet on being able to get meaningful results from mushing them together willy-nilly. 

-- 
Thomas Heide Clausen
http://www.thomasclausen.org

"Today's scientists have substituted mathematics for 
  experiments, and they wander off through equation 
  after equation, and eventually  build a structure 
  which has no relation to reality."
 - Nikola Tesla, 
    Modern Mechanics and Inventions, July, 1934

> On 5 mars 2014, at 20:11, "Stan Ratliff (sratliff)" <[email-masked]> wrote:
> 
>> On Mar 5, 2014, at 2:51 PM, Abdussalam Baryun <[email-masked]> wrote:
>> 
>> Hi Teco
>>

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 5 Mar 2014 21:32:10 +0100

I really agree more with the author presenting today (Henning) that this
work is for both reactive and proactive protocols. So I understood that we
adopted it as link-metrics not as metrics for only OLSRv2, of you read the
item it's clear I think,

AB

On Wednesday, March 5, 2014, Stan Ratliff (sratliff) wrote:

>  Yeah, I also heard some chatter about uses that are not associated with
> OLSRv2. Having said that, I don't have a strong opinion either way. I'll
> just ask - are we sure we want to rename it as an OSLRv2 doc?
>
>  Regards,
> Stan
>
>  On Mar 5, 2014, at 2:51 PM, Abdussalam Baryun <[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>>
> wrote:
>
> Hi Teco
>

---

From: Henning Rogge <[email-masked]>
Date: Wed, 5 Mar 2014 20:36:54 +0000

As I said today, main problem to use this with a reactive routing
protocol is that you would lack a source of packet loss data.

Henning

On Wed, Mar 5, 2014 at 8:32 PM, Abdussalam Baryun
<[email-masked]> wrote:
>>> Op 5 mrt. 2014, om 12:12 heeft Stan Ratliff (sratliff)
>>> <[email-masked]> het volgende geschreven:
>>>

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 5 Mar 2014 21:39:27 +0100

My operational and deployment experience is, that there's a substantial difference in how link metrics apply in the two different protocol categories. Do you (or anybody) have operational evidence to the contrary?

Thomas

Sent from my iPad

> On 5 mars 2014, at 21:32, Abdussalam Baryun <[email-masked]> wrote:
> 
> I really agree more with the author presenting today (Henning) that this work is for both reactive and proactive protocols. So I understood that we adopted it as link-metrics not as metrics for only OLSRv2, of you read the item it's clear I think, 
> 
> AB
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 5 Mar 2014 21:43:46 +0100

Hi Thomas

I see that the draft is not about routing results, but formatting metrics
for purposes.

AB

> We need to scope the experiment correctly so as to get any meaningful

I agree only if we find that the draft is not scoped. Did you find some
error in scope in draft. Please help.

>
> My experience is that proactive and reactive protocols have and behave
> *very* different wrt metrics and I would not bet on being able to get
> meaningful results from mushing them together willy-nilly.
>

The reactive and proactive have and behave "very" different in messages
send/receive/information but still we agreed to have RFC5444 for both, and
NHDP for both. Why not metric, please help.

AB

If not from math then there is no practice.

---

From: Henning Rogge <[email-masked]>
Date: Wed, 5 Mar 2014 20:45:09 +0000

> NHDP for both. Why not metric, please help.

If you are running NHDP, you are not running a completely reactive protocol.

Henning

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 5 Mar 2014 21:48:32 +0100

Dear Abdussalam,

> On 5 mars 2014, at 21:43, Abdussalam Baryun <[email-masked]> wrote:
> 
> Hi Thomas
> 
> I see that the draft is not about routing results, but formatting metrics for purposes. 
> 
> AB
> 
> I agree only if we find that the draft is not scoped. Did you find some error in scope in draft. Please help. 

AFAIK, the draft is scoping for and aiming at OLSRv2. For that purpose, it is quite appropriate.

> The reactive and proactive have and behave "very" different in messages send/receive/information but still we agreed to have RFC5444 for both, and NHDP for both. Why not metric, please help. 
> 

1) try to deploy networks with reactive and proactive protocols, using the same metric,

2) the ID of Henning talks about pkt sequence numbers and HELLO messages, none of which are present in the reactive protocol

Even if 1) wasn't applicable (though, it is), the difference wrt 2) makes that moot: it's simply not the same mechanism that applies in the two cases.

Thomas

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 5 Mar 2014 21:49:08 +0100

> On 5 mars 2014, at 21:45, Henning Rogge <[email-masked]> wrote:
> 

That, too.

Thomas

---

From: Thomas Clausen <[email-masked]>
Date: Mon, 10 Mar 2014 14:43:02 +0100

> I see that the draft is not about routing results, but formatting metrics for purposes. 

With the purpose being to "run a routing protocol".

And, proactive and reactive protocols are *very* different in how they use metrics....and, as Henning points out, in how metrics values can be estimated.

> The reactive and proactive have and behave "very" different in messages send/receive/information but still we agreed to have RFC5444 for both, and NHDP for both. Why not metric, please help. 

Because it's not the same thing at all.

Thomas

---

From: Thomas Clausen <[email-masked]>
Date: Mon, 10 Mar 2014 14:46:55 +0100

(Oh boy, this was a long week, I'd entirely forgotten that I'd already replied to this. Mea culpa, apologies for the double-posting)

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Mon, 10 Mar 2014 17:23:58 +0000

Working group, 

The time period for commons having past without *any* objections, this document is accepted as a Working Group document. 

Co-authors, please post the next version of the draft with the "draft-ietf-manet" prefix. 

Regards,
Stan

---

From: Henning Rogge <[email-masked]>
Date: Mon, 10 Mar 2014 17:28:13 +0000

I am in a business trip in Antwerpen this week, I will publish the new
version on Monday.

Henning Rogge
On Mar 10, 2014 6:23 PM, "Stan Ratliff (sratliff)" <[email-masked]>
wrote:

> Working group,
>
> The time period for commons having past without *any* objections, this
> document is accepted as a Working Group document.
>