Subject: Re: [manet] DLEP performance with and without TCP (was Re: DLEP DT summary

From: Shawn Jury <[email-masked]>
Date: Mon, 3 Mar 2014 11:15:53 -0500

AB, 

    I'm not sure your following where TCP is being used in DLEP.  The draft defines TCP between the routing device and the radio.  This is normally a fairly stable connection (ethernet in the radios I have seen, but could be serial or anything really).  Because of this, the normal issues with Manet networks do not apply.  This is just to support Henning's reply of DLEP is not "over the air".

    If you still have concerns, it might be a better idea that you tell us what your concerns are as opposed to us convincing you of why it was changed.  I think that might allow us to address your concerns quicker as opposed to you waiting for us to tell you something and you cherry picking what you want out of it.

Hope this helps,

Shawn
On Mar 3, 2014, at 10:37 AM, [email-masked] wrote:

> 
> What you write make no sense at all. I am not even sure it has much to do
> with my answer.
> 
> DLEP is not an "over the air" protocol... I also recommend to look up "stop
> and wait" protocol.
> 
> Henning
> On Mar 3, 2014 4:31 PM, "Abdussalam Baryun" <[email-masked]>
> wrote:
> 
>> Hi Henning,
>> 
>> Do you mean if the DLEP ACK messages are dropped then DLEP performance
>> will be below 70 percent and 30 percent losses? MANET protocols always have
>> percentages of errors.
>> 
>> So do I understand that if there is ACK messages in any MANET protocol
>> (which uses transport layer) then there are only three options as below. I
>> think AODV is already has option of ACK message but still it works perfect
>> with UDP,
>> 
>> AB
>

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Mon, 3 Mar 2014 18:00:45 +0000

>>> will be below 70 percent and 30 percent losses? MANET protocols always have

I want to emphasize what Henning and Shawn have already said - DLEP is specified *between a router and its locally-attached radio*. There is NO "over the air" signaling specified in DLEP. Discovery of remote MAC (and Layer 3) IP addresses *implies* some sort of proprietary OTR signaling, but those specifications are not in DLEP. As such, the DLEP protocol will typically be running over a local Ethernet connection, and should be stable (with low error rates). 

Regards,
Stan

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Teco Boot <[email-masked]>
Date: Mon, 3 Mar 2014 21:06:37 +0100

Op 3 mrt. 2014, om 19:00 heeft Stan Ratliff (sratliff) <[email-masked]> het volgende geschreven:

//skipped//

>  Discovery of remote MAC (and Layer 3) IP addresses *implies* some sort of proprietary OTR signaling, but those specifications are not in DLEP.

I don’t think any proprietary OTR signaling is needed. The modem just provide transparent 802.1D bridging. How to implement such bridge service is up to implementer.

The Layer 3 IP address service is optional and is not standards based. It may speed up ARP/NDP address resolving, although there are other ways to do that without over the air messages (e.g. L2 header snooping from routing protocol messages).

Teco