Subject: [manet] IETF89 preliminary minutes

From: Ulrich Herberg <[email-masked]>
Date: Fri, 7 Mar 2014 19:04:08 -0800

Hello,

I uploaded the preliminary minutes to:
http://www.ietf.org/proceedings/89/minutes/minutes-89-manet

Please verify correctness and send edits to me by email.
Many thanks to Justin and Axel for taking the minutes. I have edited and
merged them.

Best regards
Ulrich

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 8 Mar 2014 05:34:19 +0000

Hi Ulrich,

Quick Minutes amendment points:

-Your draft in the last presentation was asked to be adopted by WG but not
to be in WGLC.

-There was only one WG chair present, the minutes show that there were two.
Please delete the name that was not in session chair position in the room.

-Names of participants when they input are not consistent. Please add:
Abdussalam Baryun (AB) in start, then use AB in all following
inputs. Please do same for Teco, Rick, Stan. Also abbreviate These
following not related to names; CP, JC, EB, RT, etc.

- the name should be Rick Taylor (RT), please amend and then use RT,
because the surname was repeated different ( as Tayler).

-IMHO we need to make minutes clear of participant hat or power. For
example WG chair which was Stan or SR, please show his power if he is
talking as chair, as SR (WG chair) and if he says I am as participant then
only put SR. (This point can be checked with chair or AD if acceptable or
not).

-Also IMHO when Adrian the AD talked as AD, please make it Adrian (WG AD).
We had two AD, so Stewart input may add to it (WG AD). (This point can be
checked with chair or AD if acceptable or not).

I will try to listen to the recording to see if there are more comments.

Thanks Ulrich, Stan, Justin and Alex.

Best Wishes,

AB

---

From: Ulrich Herberg <[email-masked]>
Date: Fri, 7 Mar 2014 21:48:04 -0800

Hello Abdussalam,

see below

> -Your draft in the last presentation was asked to be adopted by WG but not

That is correct. I updated the minutes accordingly. Thanks.

>
> -There was only one WG chair present, the minutes show that there were
> two. Please delete the name that was not in session chair position in the
> room.
>

Joe is WG co-chair. I had already made clear that he was not attending the
session by adding "(absent)".

> following not related to names; CP, JC, EB, RT, etc.

In the latest update, I have expanded each name at least once. If you want
to have full consistency (with abbreviations), then I invite you to send me
the updated text file.

> because the surname was repeated different ( as Tayler).

I corrected Tayler to Taylor.

> only put SR. (This point can be checked with chair or AD if acceptable or

I disagree. In my opinion, it would be inappropriate for the minute takers
to interpret with which "hat" each speaker was talking. Important is to
know who said what.

> -Also IMHO when Adrian the AD talked as AD, please make it Adrian (WG AD).

There is no "WG AG". There is a responsible AD for each WG. It is clear
from the WG page that Adrian is our responsible AD. In my opinion, there is
no need to repeat that in the minutes.

> checked with chair or AD if acceptable or not).

I am not sure what you request here. I expanded the name correctly. You can
check on the IESG page that Stewart was AD at the time of the meeting.

> I will try to listen to the recording to see if there are more comments.

You are free to do so.

Best regards
Ulrich

---

From: Thomas Clausen <[email-masked]>
Date: Mon, 10 Mar 2014 14:50:12 +0100

Ulrich,

Thank you for prompt posting of minutes.
 
A couple of things that I would like to make more precise, all the same, in the minutes:

> o draft-ietf-manet-olsrv2-multitopology: Dearlove

<SNIP>
> Teco: Why not make this document standards track?
> CD: If people implement this and it's great.  Then I'm find  fine changing this to standards track if that's the case.
> TC: I do not think as a working group that we should go down the standards track document without many implementations as that has happened in other places within the IETF and document quality has suffered.
I honestly do not think that Chris would make that typo, even when speaking ;)
> CD: If it gets stuck in the queue for 4 years we may have enough experience that we may want to push for standards track.
> Rick Taylor: Is there any record of this for this draft being experimental and then changing to standards track later down the line?
> CD: We will post something up on the list.
> TC: I think that experimental should have an explanation on what the experiment is and what the successful experiment is and what the conclusion is.
> Ulrich: Do you have intention to add a description of what those experiments are and what will make them successful?
> Adrian Farrel: Yes, he does have that intention.
As it reads in the above, it sounds as if I'm making a demand, that Adrian is committing Chris to satisfy. That's not exactly how it went down, so perhaps we should clarify that in the minutes?
I'd like to go on record here, that I did not say that it "should have an explanation" to cater to my whim, but that I (as I actually stated at the mike) I was reciting what I had heard was an IESG statement/requirement (so: I thought it was the IESGs whim to be satisfied).

Adrian then clarified this, that it was not an "IESG statement/requirement" as such, but that the current routing ADs (which include him, so his whim) who require this"

<SNIP>

>  o draft-rogge-baccelli-olsrv2-ett-metric: Rogge

<SNIP>
> Henning: It will also not break anything if different values are used as the values are unit-less so the routes might be crazy but they will work.
> TC: I think experimental is exactly the place for this document
> Emmanuel: I would like to comment to Rick's earlier comment about if this is related to OLSRv2.  It uses building blocks such as sequence numbers in RFC5444 and missed NHDP HELLO messages to calculate the metric, so in that regard it could be used with other protocols and is not only tied to OLSRv2.
> CD: There needs to be a section describing the experiments. 
> TC: I think this draft should be focused to OLSRv2 (and not other protocols) and not make it something overly broad and have it stall out.
> Henning: For AODV this metric would be a problem as there isn't normally control traffic or any unicast traffic on a link, so there is nothing to measure.

I believe that what I said was that my experience with both proactive and reactive protocol deployments leave me to believe that metrics "make sense in very different ways in these two protocol families", and therefore would need to be considered separately. Specifically, constructing an "experiment for a metric for a proactive protocol" (which, as this is going Experimental, is a requirement by the RTG ADs) is easy - whereas constructing an "experiment for the same metric for both a proactive and a reactive protocol" is a lot harder to do correctly, and probably will just make us stall.

Therefore, given that the existing operational experience, on which this document is based, is exclusively for proactive / OLSR, only, my preference is simply to document the metric as for OLSR, and design the experiment accordingly.

<SNIP>

>  o draft-gerla-manet-odmrp: Colin de Verdiere
>    draft-gerla-manet-odmrp-asym
Brain-fart here, but I actually do not recall if the authors requested WG adoption "now", "a bit later", or "not at all but just wanted to inform the WG what we're doing"? - Or was it "none of the above"?

<SNIP>

> o draft-clausen-manet-olsrv2-management-snapshot: Herberg
> UH: Presenting. Requesting WG adoption

Have I missed something, or was WG adoption for this document already called for on the list? If not, any reasons for "not"?

<SNIP>

> 
>  o OLSRv2 + RFC6971: Clausen
> No time for presentation (slides in the proceedings), brought to the mailing list.

It'd be kind if the minutes contains a link to the message which Ulrich started and wherein the discussion was brought forward:

	In the new "archive format" (which I am given to understand is being reworked to show the threads) that'd be:
		http://mailarchive.ietf.org/arch/msg/manet/Loj8AP3uxKExI5NPbafy5Vet9ek

	or, the format that actually allows seeing the threads, and which is useful currently:
		http://www.ietf.org/mail-archive/web/manet/current/msg16016.html

Cheers,

Thomas

On 08 Mar 2014, at 04:04, Ulrich Herberg <[email-masked]> wrote:

> Many thanks to Justin and Axel for taking the minutes. I have edited and merged them.
> 
> Best regards
> Ulrich
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 10 Mar 2014 14:24:53 +0000

If we're nitpicking, then "Then" should not start a new sentence.

As for Adrian's comment, I took it as a lighthearted way of saying that if we wanted a smooth passage, that's what we should do.

(I partly regret making the four year reference. I'd be horrified if it took that long. But if it took a long time - four years being just a random figure - we'd be ready for ST then.)

--
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

From: manet [mailto:[email-masked]] On Behalf Of Thomas Clausen
Sent: 10 March 2014 13:50
To: Ulrich Herberg
Cc: <[email-masked]>; MANET IETF
Subject: Re: [manet] IETF89 preliminary minutes

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
For information regarding Red Flags that you can look out for in emails you receive, click here<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.
If you feel the email is suspicious, please follow this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>.
Ulrich,

<SNIP>

<SNIP>

<SNIP>

<SNIP>

<SNIP>

Cheers,

Thomas

On 08 Mar 2014, at 04:04, Ulrich Herberg <[email-masked]<mailto:[email-masked]>> wrote:

Hello,

Best regards
Ulrich
_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Thomas Clausen <[email-masked]>
Date: Mon, 10 Mar 2014 15:31:30 +0100

On 10 Mar 2014, at 15:24, Dearlove, Christopher (UK) <[email-masked]> wrote:

> If we’re nitpicking, then “Then” should not start a new sentence. 

;)

> As for Adrian’s comment, I took it as a lighthearted way of saying that if we wanted a smooth passage, that’s what we should do.

That was my reading, also.

> (I partly regret making the four year reference. I’d be horrified if it took that long. But if it took a long time – four years being just a random figure – we’d be ready for ST then.)

Agreed. I'm personally shooting for something closer to "4 months" as a horizon for seeing this forward, though, as experimental....

> [email-masked] | http://www.baesystems.com
> 
> For information regarding Red Flags that you can look out for in emails you receive, click here.
> If you feel the email is suspicious, please follow this process.
> 
> Ulrich,
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 10 Mar 2014 17:08:03 +0100

Hi Thomas,

Thanks for the update. I don't think the latest multicast draft was
requested to be adopted in the meeting, but Ulrich did request his it for
his draft, and I am waiting for announce on the list for DLEP plan and
all adoption request in WG meeting.

AB

On Monday, March 10, 2014, Thomas Clausen wrote:

> I'd like to go on record here, that I did not say that it "should have an
> explanation" to cater to my whim, but that I (as I actually stated at the
> mike) I was reciting what I had heard was an IESG statement/requirement
> (so: I thought it was the IESGs whim to be satisfied).
>
> Adrian then clarified this, that it was not an "IESG
> statement/requirement" as such, but that the current routing ADs (which
> include him, so his whim) who require this"
>
> <SNIP>
>
> CD: There needs to be a section describing the experiments. TC: I think this draft should be focused to OLSRv2 (and not other protocols) and not make it something overly broad and have it stall out.Henning: For AODV this metric would be a problem as there isn't normally control traffic or any unicast traffic on a link, so there is nothing to measure.
>
>
> I believe that what I said was that my experience with both proactive and
> reactive protocol deployments leave me to believe that metrics "make sense
> in very different ways in these two protocol families", and therefore would
> need to be considered separately. Specifically, constructing an "experiment
> for a metric for a proactive protocol" (which, as this is going
> Experimental, is a requirement by the RTG ADs) is easy - whereas
> constructing an "experiment for the same metric for both a proactive and a
> reactive protocol" is a lot harder to do correctly, and probably will just
> make us stall.
>
> Therefore, given that the existing operational experience, on which this
> document is based, is exclusively for proactive / OLSR, only, my preference
> is simply to document the metric as for OLSR, and design the experiment
> accordingly.
>
>
> <SNIP>
>
> Brain-fart here, but I actually do not recall if the authors requested WG
> adoption "now", "a bit later", or "not at all but just wanted to inform the
> WG what we're doing"? - Or was it "none of the above"?
>
> <SNIP>
>
> It'd be kind if the minutes contains a link to the message which Ulrich
> started and wherein the discussion was brought forward:
>
> On 08 Mar 2014, at 04:04, Ulrich Herberg <[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>>
> wrote:
>
> Hello,
>
> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>

---

From: Axel Colin de Verdière <[email-masked]>
Date: Mon, 10 Mar 2014 17:13:00 +0100

Hi all,

We did not in fact request WG adoption for ODMRP and ODMRP_ASYM at this time, but we felt that the drafts were in good enough shape to ask for your comments and move in that direction.

Axel

Le 10 mars 2014 à 17:08, Abdussalam Baryun <[email-masked]> a écrit :

> Hi Thomas,
> 
> Thanks for the update. I don't think the latest multicast draft was requested to be adopted in the meeting, but Ulrich did request his it for his draft, and I am waiting for announce on the list for DLEP plan and all adoption request in WG meeting. 
> 
> AB
>

---

From: Christopher Dearlove <[email-masked]>
Date: Mon, 10 Mar 2014 16:25:29 +0000

The multicast draft has already been accepted by the WG. The next process stage is WGLC, which we haven't requested yet. Now is the time for any comments before we do request that.

-- 
Christopher Dearlove
[email-masked] (iPhone)
[email-masked] (home)

> On 10 Mar 2014, at 16:08, Abdussalam Baryun <[email-masked]> wrote:
> 
> Hi Thomas,
>

---

From: Thomas Clausen <[email-masked]>
Date: Mon, 10 Mar 2014 17:29:18 +0100

> The multicast draft has already been accepted by the WG. The next process stage is WGLC, which we haven't requested yet. Now is the time for any comments before we do request that.

Are you sure, Chris? 

I am almost betting that you're mistaken "Multi-Topology" and "Multicast".....the former, surely, is WG document. The latter (which Axel presented) is not (yet, at least, and was what I asked about)

Of course, there may be a secret multicast WG document that I am not aware of :D

Thomas

---

From: Ulrich Herberg <[email-masked]>
Date: Mon, 10 Mar 2014 09:36:50 -0700

Thank you, Thomas (and others), for the corrections. Of course, you would
do me an immense favo(u)r if you sent me the exact BEFORE/AFTER text,
rather than me having to listen to the audio again :-D Just because I am
lazy ;-)

Ulrich

---

From: Thomas Clausen <[email-masked]>
Date: Mon, 10 Mar 2014 17:43:19 +0100

Ulrich,

On 10 Mar 2014, at 17:36, Ulrich Herberg <[email-masked]> wrote:

> Thank you, Thomas (and others), for the corrections. Of course, you would do me an immense favo(u)r if you sent me the exact BEFORE/AFTER text, rather than me having to listen to the audio again :-D Just because I am lazy ;-)
> 

Wait, so what are you getting paid the big bucks as IETF WG Secretary for, again? ;)

Thomas

> Ulrich
> 
> 
> On Mon, Mar 10, 2014 at 6:50 AM, Thomas Clausen <[email-masked]> wrote:
> Ulrich,
>

---

From: Ulrich Herberg <[email-masked]>
Date: Mon, 10 Mar 2014 09:49:10 -0700

Thomas,

I have uploaded a revised revision of the minutes. Please confirm if that
reflects what has been said, or otherwise send me the precise wording :-)

Regards
Ulrich

---

From: Thomas Clausen <[email-masked]>
Date: Mon, 10 Mar 2014 17:52:00 +0100

I'll take a look - and, I sincerely hope that you did notice the smiley?

Thomas

On 10 Mar 2014, at 17:49, Ulrich Herberg <[email-masked]> wrote:

> Thomas,
> 
> I have uploaded a revised revision of the minutes. Please confirm if that reflects what has been said, or otherwise send me the precise wording :-)
> 
> Regards
> Ulrich
> 
> 
> On Mon, Mar 10, 2014 at 9:43 AM, Thomas Clausen <[email-masked]> wrote:
> Ulrich,
>

---

From: Thomas Clausen <[email-masked]>
Date: Mon, 10 Mar 2014 17:56:12 +0100

Alright, I have looked. The revised version updates my concerns, thank you for your hard work.

Thomas