Subject: [manet] Fwd: New Version Notification for draft-gerla-manet-odmrp-02.txt

From: Axel Colin de Verdière <[email-masked]>
Date: Wed, 5 Mar 2014 12:00:19 +0000

Hi all,

We just pushed a new revision of ODMRP out, the -02 version presented at the meeting. I got some comments during this week and plan to integrate them into a -03 revision pretty soon. I'd be happy to discuss additional suggestions or remarks that could be added to that revision.

Thanks,

Axel

Début du message réexpédié :

> De: [email-masked]
> Objet: New Version Notification for draft-gerla-manet-odmrp-02.txt
> Date: 5 mars 2014 11:53:33 UTC
> À: "William Su" <[email-masked]>, "Yunjung Yi" <[email-masked]>, "Axel Coli Verdiere" <[email-masked]>, "Sung-Ju Lee" <[email-masked]>, Mario Gerla <[email-masked]>, "Professor Mario Gerla" <[email-masked]>, William Su <[email-masked]>, Axel Colin de Verdiere <[email-masked]>
> 
> 
> A new version of I-D, draft-gerla-manet-odmrp-02.txt
> has been successfully submitted by Axel Colin de Verdiere and posted to the
> IETF repository.
> 
> Name:		draft-gerla-manet-odmrp
> Revision:	02
> Title:		On-Demand Multicast Routing Protocol (ODMRP) for Ad Hoc Networks
> Document date:	2014-03-05
> Group:		Individual Submission
> Pages:		30
> URL:            http://www.ietf.org/internet-drafts/draft-gerla-manet-odmrp-02.txt
> Status:         https://datatracker.ietf.org/doc/draft-gerla-manet-odmrp/
> Htmlized:       http://tools.ietf.org/html/draft-gerla-manet-odmrp-02
> Diff:           http://www.ietf.org/rfcdiff?url2=draft-gerla-manet-odmrp-02
> 
> Abstract:
>   The On-Demand Multicast Routing Protocol (ODMRP) is a multicast
>   routing protocol designed for ad hoc networks with mobile hosts.
>   ODMRP is a mesh-based, rather than a conventional tree-based,
>   multicast scheme and uses a forwarding group concept (only a subset
>   of nodes forwards the multicast packets via scoped flooding).  It
>   applies on-demand procedures to dynamically build routes and maintain
>   multicast group membership.  ODMRP is well suited for ad hoc wireless
>   networks with mobile hosts where bandwidth is limited, topology
>   changes frequently and rapidly, and power is constrained.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Joe Macker <[email-masked]>
Date: Mon, 10 Mar 2014 20:04:42 -0400

Sorry I was working with pdf document here are my very basic exported comments that might hep with a revision.
More in the second set of comments. The general comments are just for general discussio going forward.
There are plenty more things but I did not do a comprehensive review yet.

-------
First off nice work!

General Comments:

(1) In a future revision, it would probably be good to discuss the design issues associated with finding the right value of Route Query refresh flooding intervals.  As you know, there have been plenty of published papers on the subject relating to ODMRP.

(2) Might want to discuss any relationship with any SSM from the IGMPv2, MLD perspective,etc.  Is there an intention to support SSM?The state is certainly source specific.

(3) We could discuss more about how this could work with RFC 6130 concepts or where similar security considerations may lie.  This could be done down the road as we flesh things out more and consider acceptance as a  WG item.

Summary of More Specific Minor Comments on draft-gerla-manet-odmrp-02.pdf

Page: 4
Author: macker Subject: Sticky Note Date: 3/10/14, 7:05:03 PM
of a "forwarding group"
also avril -> april in reference

Page: 7
Author: macker Subject: Sticky Note Date: 3/10/14, 7:11:34 PM
disctinct -> distinct

Page: 8
Author: macker Subject: Sticky Note Date: 3/10/14, 7:15:10 PM
neighbour->neighbor
I personally have no issue with British spellings in IETF docs.
But since RFC 6130 and Crhis Dearlove go this way 

Page: 9
Author: macker Subject: Sticky Note Date: 3/10/14, 7:18:27 PM
Security Considerations for sequencing
Replay etc (see later in pg 22 comments)
Page: 11
Author: macker Subject: Sticky Note Date: 3/10/14, 7:20:36 PM
Fix sentence grammar:
recommend remove "when"
Page: 21
Author: macker Subject: Sticky Note Date: 3/10/14, 7:34:41 PM
I think its great to have some potential convergence of capability here.
The sentence duplication packets and message detection is malformed at least in the pdf version of the draft. Perhaps an xml,etc.
Scoped flooding may be assisted by an SMF implementation as well.
We have published and some unpublished improvements to these optimized flooding mechanisms (e.g., ECDS) that might provide more stability.
both ipv4 and ipv6.
Page: 22
Author: macker Subject: Sticky Note Date: 3/10/14, 7:36:26 PM
There are likely particular security vulnerabilities that can be discussed regarding monotic sequences as used in control plane.. See SMF and other documents for similar issues such as replay,etc. Something for a future revision.

On Mar 5, 2014, at 7:00 AM, Axel Colin de Verdière <[email-masked]> wrote:

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Joe Macker <[email-masked]>
Date: Mon, 10 Mar 2014 20:09:12 -0400

#3 I misreferenced an RFC although the comment may still apply.

> (3) We could discuss more about how this could work with RFC 6130 concepts or where similar security considerations may lie.  This could be done down the road as we flesh things out more and consid…

I meant RFC 6621(SMF) sorry for any confusion. 6130 is NHDP of course..

---

From: Christopher Dearlove <[email-masked]>
Date: Tue, 11 Mar 2014 07:02:09 +0000

I believe on British English, the RFC Editor's rules can be summarised as:
- British English is permitted.
- But in practice no one does.

So, yes, I have misspelled neighbour in all the drafts I have co-authored.

But it's spelled correctly in my software ;)

-- 
Christopher Dearlove
[email-masked]

> On 11 Mar 2014, at 00:04, Joe Macker <[email-masked]> wrote:
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 11 Mar 2014 09:00:01 +0100

Comments below

On Tuesday, March 11, 2014, Joe Macker wrote:

>
> -------
> First off nice work!
>
> General Comments:
>
> (1) In a future revision, it would probably be good to discuss the design
> issues associated with finding the right value of Route Query refresh
> flooding intervals.  As you know, there have been plenty of published
> papers on the subject relating to ODMRP.

This is important to determine to get less network overhead.

> (2) Might want to discuss any relationship with any SSM from the IGMPv2,
> MLD perspective,etc.  Is there an intention to support SSM?The state is
> certainly source specific.

Agree

>
> (3) We could discuss more about how this could work with RFC 6130 concepts
> or where similar security considerations may lie.  This could be done down
> the road as we flesh things out more and consider acceptance as a  WG item.

I was thinking how the protocol works with 6130 as Thomas mentioned in his
review the multiple interfaces and addresses.

> But since RFC 6130 and Crhis Dearlove go this way

I prefer shorter words so neighbor is perfect, as long as it is understood.

> The sentence duplication packets and message detection is malformed at
> least in the pdf version of the draft. Perhaps an xml,etc.
> We have published and some unpublished improvements to these optimized
> flooding mechanisms (e.g., ECDS) that might provide more stability.
> both ipv4 and ipv6.

Please provide reference to the published optimized flooding.

Thanks
AB

---

From: Rick Taylor <[email-masked]>
Date: Tue, 11 Mar 2014 12:30:06 +0000

Surely you mean believe *in* British English  ;)

________________________________________
From: manet [[email-masked]] on behalf of Christopher Dearlove [[email-masked]]
Sent: 11 March 2014 07:02
To: Joe Macker
Cc: <[email-masked]> List; Axel Colin de Verdière; gerla; Soon Young Oh
Subject: Re: [manet] Basic initial comment for draft-gerla-manet-odmrp-02.txt

---

From: Joseph Macker <[email-masked]>
Date: Tue, 11 Mar 2014 14:13:13 -0400

I will not quote Oscar Wilde as that is obvious.

But all those zeds are the real menace.

On Tue, Mar 11, 2014 at 3:02 AM, Christopher Dearlove <
[email-masked]> wrote:

> > (1) In a future revision, it would probably be good to discuss the
> design issues associated with finding the right value of Route Query
> refresh flooding intervals.  As you know, there have been plenty of
> published papers on the subject relating to ODMRP.
> >
> > (3) We could discuss more about how this could work with RFC 6130
> concepts or where similar security considerations may lie.  This could be
> done down the road as we flesh things out more and consider acceptance as a
>  WG item.
> >
> >
> > There are likely particular security vulnerabilities that can be
> discussed regarding monotic sequences as used in control plane.. See SMF
> and other documents for similar issues such as replay,etc. Something for a
> future revision.
> >
> >
> >> We just pushed a new revision of ODMRP out, the -02 version presented
> at the meeting. I got some comments during this week and plan to integrate
> them into a -03 revision pretty soon. I'd be happy to discuss additional
> suggestions or remarks that could be added to that revision.
> >>
> >> Thanks,
> >>
> >> Axel
> >>
> >>
> >>> À: "William Su" <[email-masked]>, "Yunjung Yi" <
> [email-masked]>, "Axel Coli Verdiere" <
> [email-masked]>, "Sung-Ju Lee" <[email-masked]>,
> Mario Gerla <[email-masked]>, "Professor Mario Gerla" <
> [email-masked]>, William Su <[email-masked]>, Axel Colin de
> Verdiere <[email-masked]>
> >>>
> >>>
> >>> URL:
> http://www.ietf.org/internet-drafts/draft-gerla-manet-odmrp-02.txt
> >>> Status:
> https://datatracker.ietf.org/doc/draft-gerla-manet-odmrp/
> >>> Diff:
> http://www.ietf.org/rfcdiff?url2=draft-gerla-manet-odmrp-02
> >>>
> >>> Abstract:

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 12 Mar 2014 01:14:20 +0100

https://www.rfc-editor.org/rfcfaq.html#british

> On 11 mars 2014, at 08:02, Christopher Dearlove <[email-masked]> wrote:
>