Subject: [manet] New DLEP Extension draft

From: Rick Taylor <[email-masked]>
Date: Tue, 30 May 2017 15:57:17 +0000

Hi All,

I have just submitted a draft DLEP extension to try to work around some
of the problems associated with implementing DLEP on modems that do not
operate over a single Layer 2 domain, such as LTE, WiFi APs, and WAN
radios. 

Please can you have a look, as I'm looking for WG adoption.

https://datatracker.ietf.org/doc/draft-dlep-lid/

Cheers,

Rick

---

From: Teco Boot <[email-masked]>
Date: Tue, 30 May 2017 20:01:08 +0200

Rick,

I think your proposed extension enlarges applicability of DLEP. So I support your efforts.

I wonder why you don't suggest an IP Destination prefix (or even Source+Destination prefixes, to support SADR) as ID. In many cases the ID would be a default route. For backbone edge routers, metrics to nearby destinations would differ from far destinations.

I know this opens a discussion towards route distribution. But let that be out of scope, the main purpose is to provide link metrics (or path metrics, if we are at layer-3).

I don't get how your proposal helps in the multi-hop layer-2 use case. AFAIR it is up to such a sub-IP layer to provide MAC end-to-end link metrics. I understand the difficulties, as current multi-hop sub-IP stuff typically do not support required functions.

Teco

> Op 30 mei 2017, om 17:57 heeft Rick Taylor <[email-masked]> het volgende geschreven:
> 
> Hi All,
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Rick Taylor <[email-masked]>
Date: Tue, 30 May 2017 18:24:51 +0000

(Top posting in Outlook, sorry)

Hi Teco,

Thanks for the support!

I didn't choose IP destination and prefix as the identifier, as we already support multiple IP addresses and subnets per destination dynamically, so I wanted one consistent number that wasn't related and was static for the session.  In some modems that I'm aware of some bits of the subnet is often the node id, but I want to keep it more general.

I think the route distribution door is already ajar with DLEP Attached Subnets, but I don't think I'm opening it any wider.  If I was going to extend subnets into full routing I would suggest another extension including Source, Priority and Via IP addresses which are missing from core-DLEP.

I wasn't trying to address the multiple layer-2 hops problem in general, just address a few common cases:
1) Access Points: E.g. "The Internet is this way, the link is up and at X Mbps"
2) WAN Radios: E.g. "I can get traffic to 10.0/16 via Y, but don't expect Ethernet frames end-to-end"

As I see it, both use-cases can use this extension without adding lots of complexity, and it can work in parallel with the existing DLEP implementations.

Cheers,

Rick

-----Original Message-----
From: Teco Boot [mailto:[email-masked]] 
Sent: 30 May 2017 19:01
To: Rick Taylor
Cc: [email-masked]
Subject: Re: [manet] New DLEP Extension draft

Rick,

Teco

> I have just submitted a draft DLEP extension to try to work around 
> some of the problems associated with implementing DLEP on modems that 
> do not operate over a single Layer 2 domain, such as LTE, WiFi APs, 
> and WAN radios.
>