Subject: [manet] [Editorial Errata Reported] RFC7183 (5144)

From: RFC Errata System <[email-masked]>
Date: Wed, 4 Oct 2017 14:02:33 -0700 (PDT)

The following errata report has been submitted for RFC7183,
"Integrity Protection for the Neighborhood Discovery Protocol (NHDP) and Optimized Link State Routing Protocol Version 2 (OLSRv2)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5144

--------------------------------------
Type: Editorial
Reported by: Denis Ovsienko <[email-masked]>

Section: 8.1.3

Original Text
-------------
   is contained in message.  As an attacker cannot modify the content of
   this timestamp (as it is protected by the identity check value), an
   attacker cannot replay messages after this time.  Within this time

Corrected Text
--------------
   is contained in message.  As an attacker cannot modify the content of
   this timestamp (as it is protected by the integrity check value), an
   attacker cannot replay messages after this time.  Within this time

Notes
-----
Integrity check value (ICV) is the means of protection in this document.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7183 (draft-ietf-manet-nhdp-olsrv2-sec-05)
--------------------------------------
Title               : Integrity Protection for the Neighborhood Discovery Protocol (NHDP) and Optimized Link State Routing Protocol Version 2 (OLSRv2)
Publication Date    : April 2014
Author(s)           : U. Herberg, C. Dearlove, T. Clausen
Category            : PROPOSED STANDARD
Source              : Mobile Ad-hoc Networks
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: Christopher Dearlove <[email-masked]>
Date: Wed, 4 Oct 2017 23:56:16 +0100

(Co-author.)

Yes, that’s a good erratum and should be accepted. Thanks to Denis and annoyance to self for letting it through.

Christopher

> On 4 Oct 2017, at 22:02, RFC Errata System <[email-masked]> wrote:
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Ulrich Herberg <[email-masked]>
Date: Wed, 4 Oct 2017 16:24:10 -0700

I agree. Good catch!