Subject: Re: [manet] I-D Action: draft-ietf-manet-dlep-multi-hop-extension-02.txt

From: Rick Taylor <[email-masked]>
Date: Wed, 15 Nov 2017 10:24:55 +0000

That I would suggest was the purpose of the Session Update Message. Which unlike the Destination Update has a corresponding Response message.

Rick

(Sent from my phone)

----- Reply message -----
From: "Henning Rogge" <[email-masked]>
To: "Rick Taylor" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [manet] I-D Action: draft-ietf-manet-dlep-multi-hop-extension-02.txt
Date: Wed, Nov 15, 2017 14:55

The "Link Characteristic Request" message has a mandatory MAC item,
which means it can only be used for neighbor specific requests.

I think if the router has to ask for a "change" of the whole session
(and not for a specific neighbor) we should introduce a new message
type.

Henning

On Wed, Nov 15, 2017 at 3:35 AM, Rick Taylor
<[email-masked]> wrote:
> Clarification inline...
>
> On Wed, 2017-11-15 at 01:47 +0000, Rick Taylor wrote:
>> On Tue, 2017-11-14 at 15:55 +0000, Ratliff, Stanley wrote:
>> > > -----Original Message-----
>> > > From: manet [mailto:[email-masked]] On Behalf Of Henning
>> > > Rogge
>> > > Sent: Tuesday, November 14, 2017 2:51 AM
>> > > To: MANET IETF <[email-masked]>
>> > > Subject: Re: [manet] I-D Action: draft-ietf-manet-dlep-multi-hop-
>> > > extension-
>> > > 02.txt
>> > >
>> > > I wonder if should have a "request channel characteristics"
>> > > message
>> > > to allow
>> > > the user to change the behavior of the Session, similar to the
>> > > "request link
>> > > characteristics" message.
>> > >
>> >
>> > Wouldn't the channel be a "characteristic" of the link? What I mean
>> > by that is - should we look a whole new message, or new data items
>> > describing the channel to add to LCR?
>>
>> Yes.
>
> Yes, I think Link Characteristics Request message is the right message.
>
> No, we don't need a new message.
>
> Rick

---

From: Henning Rogge <[email-masked]>
Date: Wed, 15 Nov 2017 12:14:07 +0100

On Wed, Nov 15, 2017 at 11:24 AM, Rick Taylor
<[email-masked]> wrote:
> That I would suggest was the purpose of the Session Update Message. Which
> unlike the Destination Update has a corresponding Response message.

I always thought that the difference of "Destination Update" and
"Request Link Characteristic" is that the first sets a value that the
originator of the message is responsible for and the second asks the
other side if it could maybe reconfigure...

That's why I thought about a "Request Channel/Interface
Characteristic", to mirror the "I would like something like this"
mechanic for the interface.

Henning