Subject: [manet] I-D Action: draft-ietf-manet-dlep-multi-hop-extension-02.txt

From: [email-masked]
Date: Sun, 12 Nov 2017 08:56:46 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Mobile Ad-hoc Networks WG of the IETF.

        Title           : DLEP Multi-Hop Forwarding Extension
        Authors         : Bow-Nan Cheng
                          Lou Berger
	Filename        : draft-ietf-manet-dlep-multi-hop-extension-02.txt
	Pages           : 10
	Date            : 2017-11-12

Abstract:
   This document defines an extension to the DLEP protocol that enables
   the reporting and control of Multi-Hop Forwarding by DLEP capable
   modems.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-manet-dlep-multi-hop-extension/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-manet-dlep-multi-hop-extension-02
https://datatracker.ietf.org/doc/html/draft-ietf-manet-dlep-multi-hop-extension-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-manet-dlep-multi-hop-extension-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Henning Rogge <[email-masked]>
Date: Tue, 14 Nov 2017 08:51:25 +0100

I wonder if should have a "request channel characteristics" message to
allow the user to change the behavior of the Session, similar to the
"request link characteristics" message.

Henning Rogge

On Sun, Nov 12, 2017 at 5:56 PM,  <[email-masked]> wrote:
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Rick Taylor <[email-masked]>
Date: Tue, 14 Nov 2017 09:15:10 +0000

> "request link characteristics" message.

Sounds like an interesting idea.  It doesn't currently exist because we
never needed it, but it does seem to fit the DLEP model.

Rick

---

From: "Ratliff, Stanley" <[email-masked]>
Date: Tue, 14 Nov 2017 15:55:52 +0000

> -----Original Message-----
> From: manet [mailto:[email-masked]] On Behalf Of Henning Rogge
> Sent: Tuesday, November 14, 2017 2:51 AM
> To: MANET IETF <[email-masked]>
> Subject: Re: [manet] I-D Action: draft-ietf-manet-dlep-multi-hop-extension-
> 02.txt
> 
> I wonder if should have a "request channel characteristics" message to allow
> the user to change the behavior of the Session, similar to the "request link
> characteristics" message.
> 

Wouldn't the channel be a "characteristic" of the link? What I mean by that is - should we look a whole new message, or new data items describing the channel to add to LCR?

Regards,
Stan

> > https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.
> > org_doc_draft-2Dietf-2Dmanet-2Ddlep-2Dmulti-2Dhop-
> 2Dextension_&d=DwICA
> > g&c=LlUvidvlhStGUSxQl0giOA&r=QzgCKlK-
> eUsbLW5r8KZAL9L_yqNON1dbKtMa-Wbxn
> >
> a8&m=VlMAeuuKQeUdLGkFVIYvVZzQvp2W6YfCLor55oGNjsk&s=xbiNgu8fv5
> -qBdl-xWO
> > GfftYJsd5fkJyy9eDzAzoXQw&e=
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_ht
> > ml_draft-2Dietf-2Dmanet-2Ddlep-2Dmulti-2Dhop-2Dextension-
> 2D02&d=DwICAg
> > &c=LlUvidvlhStGUSxQl0giOA&r=QzgCKlK-
> eUsbLW5r8KZAL9L_yqNON1dbKtMa-Wbxna
> >
> 8&m=VlMAeuuKQeUdLGkFVIYvVZzQvp2W6YfCLor55oGNjsk&s=zfnGTDaSRN
> sE9RgeWvZU
> > nmgR7-vcP-dLniigRIL9lbs&e=
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.
> > org_doc_html_draft-2Dietf-2Dmanet-2Ddlep-2Dmulti-2Dhop-2Dextension-
> 2D0
> > 2&d=DwICAg&c=LlUvidvlhStGUSxQl0giOA&r=QzgCKlK-
> eUsbLW5r8KZAL9L_yqNON1db
> > KtMa-
> Wbxna8&m=VlMAeuuKQeUdLGkFVIYvVZzQvp2W6YfCLor55oGNjsk&s=QCn4
> jkJOmR
> > 0822Ysd96UosxliiK5dGumTMW-y-Pw3QY&e=
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_rfcd
> > iff-3Furl2-3Ddraft-2Dietf-2Dmanet-2Ddlep-2Dmulti-2Dhop-2Dextension-
> 2D0
> > 2&d=DwICAg&c=LlUvidvlhStGUSxQl0giOA&r=QzgCKlK-
> eUsbLW5r8KZAL9L_yqNON1db
> > KtMa-
> Wbxna8&m=VlMAeuuKQeUdLGkFVIYvVZzQvp2W6YfCLor55oGNjsk&s=OT9E
> UKnRND
> > ec4g9Wtw2OsUTm1qL4hSMRpY_8xJe99ek&e=
> >
> >
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at tools.ietf.org.
> >
> > https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_intern
> > et-2Ddrafts_&d=DwICAg&c=LlUvidvlhStGUSxQl0giOA&r=QzgCKlK-
> eUsbLW5r8KZAL
> > 9L_yqNON1dbKtMa-
> Wbxna8&m=VlMAeuuKQeUdLGkFVIYvVZzQvp2W6YfCLor55oGNjsk&s
> > =qUU7s7BTDSzsFrs6OgxRXVh4hZRYqEM_hcIS4xFGUec&e=
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mail
> > man_listinfo_manet&d=DwICAg&c=LlUvidvlhStGUSxQl0giOA&r=QzgCKlK-
> eUsbLW5
> > r8KZAL9L_yqNON1dbKtMa-
> Wbxna8&m=VlMAeuuKQeUdLGkFVIYvVZzQvp2W6YfCLor55oG
> > Njsk&s=j4d9yj0FQdfUmLCP8b9SQNZwgLeXFW15337XKwaHf0E&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_manet&d=DwICAg&c=LlUvidvlhStGUSx
> Ql0giOA&r=QzgCKlK-eUsbLW5r8KZAL9L_yqNON1dbKtMa-
> Wbxna8&m=VlMAeuuKQeUdLGkFVIYvVZzQvp2W6YfCLor55oGNjsk&s=j4d9y
> j0FQdfUmLCP8b9SQNZwgLeXFW15337XKwaHf0E&e=

============================================================================================================================================
This electronic message and any files transmitted with it contains
information from iDirect, which may be privileged, proprietary
and/or confidential. It is intended solely for the use of the individual
or entity to whom they are addressed. If you are not the original
recipient or the person responsible for delivering the email to the
intended recipient, be advised that you have received this email
in error, and that any use, dissemination, forwarding, printing, or
copying of this email is strictly prohibited. If you received this email
in error, please delete it and immediately notify the sender.

---

From: Rick Taylor <[email-masked]>
Date: Wed, 15 Nov 2017 01:47:52 +0000

On Tue, 2017-11-14 at 15:55 +0000, Ratliff, Stanley wrote:
> Wouldn't the channel be a "characteristic" of the link? What I mean
> by that is - should we look a whole new message, or new data items
> describing the channel to add to LCR?

Yes.

The problem with quickly responding to emails while sat in WG meetings
is that one inevitably doesn't think through the problem.

Much like a LinkID data item, a Queue/Channel/Flow Data Item just
discriminates the Q/C/F, so the Link Characteristics Message is the
right message.

It goes without saying I'm sat in a WG meeting.

Rick

---

From: Rick Taylor <[email-masked]>
Date: Wed, 15 Nov 2017 02:35:57 +0000

Clarification inline...

On Wed, 2017-11-15 at 01:47 +0000, Rick Taylor wrote:
> > > I wonder if should have a "request channel characteristics"
> > > message
> > > to allow

Yes, I think Link Characteristics Request message is the right message.

No, we don't need a new message.

Rick

---

From: Henning Rogge <[email-masked]>
Date: Wed, 15 Nov 2017 07:54:29 +0100

The "Link Characteristic Request" message has a mandatory MAC item,
which means it can only be used for neighbor specific requests.

I think if the router has to ask for a "change" of the whole session
(and not for a specific neighbor) we should introduce a new message
type.

Henning

---

From: Henning Rogge <[email-masked]>
Date: Fri, 24 Nov 2017 08:04:36 +0100

One more idea about the multihop extension.

Should we have a bit flag to tell the router that we talk about IP
hops instead of layer-2 radio hops? This will make it easier to reuse
this extension with IP-routing radios and the (already in progress)
link-id extension.

If we do this, we might also consider to include a flag to signal that
the radio-to-router connection is an additional IP-hop.

Henning