Subject: Re: [manet] I-D Action: draft-ietf-manet-dlep-multi-hop-extension-01.txt

From: Henning Rogge <[email-masked]>
Date: Wed, 8 Nov 2017 08:21:05 +0100

Hi,

First, why do you need the "reserved" bytes at the end of the TLVs...
DLEP already contains TLVs with a length not dividable by 4.

I am a bit concerned about the "hop control" data item, it packs A LOT
more complexity than the "hop count" one.

I also wonder if "hop control" should be part of a "request link
characteristic" message.

Thoughts about it?

Henning Rogge

On Mon, Oct 30, 2017 at 7:11 PM, Lou Berger <[email-masked]> wrote:
> Hi,
>
> This version included updated references and some minor editorial fixes.
>
> Lou (for authors)
>
> On 10/30/2017 2:07 PM, [email-masked] wrote:
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>> This draft is a work item of the Mobile Ad-hoc Networks WG of the IETF.
>>
>>         Title           : DLEP Multi-Hop Forwarding Extension
>>         Authors         : Bow-Nan Cheng
>>                           Lou Berger
>>       Filename        : draft-ietf-manet-dlep-multi-hop-extension-01.txt
>>       Pages           : 9
>>       Date            : 2017-10-30
>>
>> Abstract:
>>    This document defines an extension to the DLEP protocol that enables
>>    the reporting and control of Multi-Hop Forwarding by DLEP capable
>>    modems.
>>
>>
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-manet-dlep-multi-hop-extension/
>>
>> There are also htmlized versions available at:
>> https://tools.ietf.org/html/draft-ietf-manet-dlep-multi-hop-extension-01
>> https://datatracker.ietf.org/doc/html/draft-ietf-manet-dlep-multi-hop-extension-01
>>
>> A diff from the previous version is available at:
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-manet-dlep-multi-hop-extension-01
>>
>>
>> Please note that it may take a couple of minutes from the time of submission
>> until the htmlized version and diff are available at tools.ietf.org.
>>
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>>
>> _______________________________________________
>> manet mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/manet
>>
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Lou Berger <[email-masked]>
Date: Wed, 8 Nov 2017 08:36:38 -0500

Henning,

Thank you for the comments! see below for in-line response.

> DLEP already contains TLVs with a length not dividable by 4.
I'm fine with byte alignment, but alos thought it would be nice to leave
room for more flags definition without requiring a new data item.  Bits
are cheap in the control plane.  That said, I'm okay with
reducing/eliminating them if that's WG consensus.

> more complexity than the "hop count" one.
Agreed.  Note that the modem controls if a router can do any control via
the Hop Count Data Item P bit.

> I also wonder if "hop control" should be part of a "request link
I'm very interested in such a message, but also like small and focused
function increments from both standards and implementation
perspectives.  My inclination is to move forward with this one and start
thinking and working on the details of such a request message/DI.  What
do you think?

Lou

---

From: Rick Taylor <[email-masked]>
Date: Wed, 8 Nov 2017 13:49:31 +0000

Comments inline...

> thinking and working on the details of such a request message/DI. 

Lou, the Link Characteristics Request message already exists in
RFC8175, and I think Hop Control data items should probably live there
instead.

Rick

---

From: Lou Berger <[email-masked]>
Date: Wed, 8 Nov 2017 09:05:12 -0500

> RFC8175, and I think Hop Control data items should probably live there

Yikes! clearly I should have had coffee before responding! You are both
right.  I'll make the change in the draft.

Lou