Subject: Re: [manet] planned next steps based on IETF 102

From: "Ratliff, Stanley" <[email-masked]>
Date: Wed, 1 Aug 2018 21:38:43 +0000

Lou, 
No objections here. 

Regards,
Stan

> -----Original Message-----
> From: manet [mailto:[email-masked]] On Behalf Of Lou Berger
> Sent: Monday, July 30, 2018 6:03 PM
> To: MANET IETF <[email-masked]>
> Cc: [email-masked]
> Subject: [manet] planned next steps based on IETF 102
> 
> ***WARNING! THIS EMAIL ORIGINATES FROM OUTSIDE VT IDIRECT.*** .
> 
> Hi,
> 
>      I wanted to confirm a few points discussed at the last meeting (hosted by
> CCAMP) before making any changes.  Here's what I understood from the
> meeting:
> 
> 1) WRT draft-ietf-manet-dlep-credit-flow-control-02 :
> 
> The discussion concluded that the credit window control mechanisms
> (messages and DIs) should be split from the traffic classification
> mechanisms.  Assuming there is agreement, the traffic classification will be
> moved into draft-ietf-manet-dlep-traffic-classification.  Stan will also be
> added as an author of draft-ietf-manet-dlep-credit-flow-control as credit
> window control is derivative of his earlier work.
> 
> Does anyone object to this change?
> 
> Do the chairs agree with this change?  (once you do, I'll submit the related
> updates -- this impacts the four drafts.)
> 
> 
> 2) WRT draft-berger-manet-dlep-ether-credit-extension-00
> 
> The few people in the room who were interested in the topic, were
> supportive of adopting this draft.
> 
> WG chairs, can we proceed with an adoption poll or is the more WG
> organization decisions to be made?
> 
> That's it,
> Lou
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_manet&d=DwIGaQ&c=LlUvidvlhStGUS
> xQl0giOA&r=QzgCKlK-eUsbLW5r8KZAL9L_yqNON1dbKtMa-
> Wbxna8&m=qKxbx0l1JcLLOhKJNYY0WvdCpXDEF2kxU9ofjzk6Uqo&s=6KLiSOy
> AvoycjlVYyaPBaLWrz4HOFi5NbsIvDSfs7QA&e=

============================================================================================================================================
This electronic message and any files transmitted with it contains
information from iDirect, which may be privileged, proprietary
and/or confidential. It is intended solely for the use of the individual
or entity to whom they are addressed. If you are not the original
recipient or the person responsible for delivering the email to the
intended recipient, be advised that you have received this email
in error, and that any use, dissemination, forwarding, printing, or
copying of this email is strictly prohibited. If you received this email
in error, please delete it and immediately notify the sender.

---

From: Rick Taylor <[email-masked]>
Date: Thu, 2 Aug 2018 13:45:29 +0000

Hi Lou,

I fully support the split (I was one of the proponents).

Also I'm glad to see Stan's name back on the Credit Windowing draft, as
we seem to have gone full-circle, but I think we are back to a sensible
place.

I will give better feedback once I've had a chance to review the split
more extensively.

I'm reserving judgement on the ether-credit extension, as I need to
read the split drafts more carefully.  Yes, I want to use Ether-TOS
markings (explicitly VLAN-IDs) but not necessarily with credit
windowing.  I wonder whether we are requesting too many extension
points from IANA, and whether fewer, e.g. FlowIDs, Credits, might be a
better level of granularity, and result in less drafts just requesting
an extensions point.

I promise a more coherent response when I have some more time next
week.

Cheers,

Rick

On Tue, 2018-07-31 at 13:40 -0400, Lou Berger wrote:
> Please see https://github.com/louberger/dlep-extensions to see a
> preview 
> of the split discussed below (per IETF102).
> 
> Lou
> 
> On 7/30/2018 6:02 PM, Lou Berger wrote:
> > Hi,
> > 
> >       I wanted to confirm a few points discussed at the last
> > meeting
> > (hosted by CCAMP) before making any changes.  Here's what I
> > understood
> > from the meeting:
> > 
> > mechanisms.  Assuming there is agreement, the traffic
> > classification
> > will be moved into draft-ietf-manet-dlep-traffic-classification. 
> > Stan
> > will also be added as an author of
> > draft-ietf-manet-dlep-credit-flow-control as credit window control
> > is
> > derivative of his earlier work.
> > 
> > Do the chairs agree with this change?  (once you do, I'll submit
> > the
> > related updates -- this impacts the four drafts.)
> > 
> > 
> > https://www.ietf.org/mailman/listinfo/manet
> 
> https://www.ietf.org/mailman/listinfo/manet

---

From: Lou Berger <[email-masked]>
Date: Thu, 2 Aug 2018 10:26:42 -0400

Hi Rick,

> we seem to have gone full-circle, but I think we are back to a sensible
Thanks - given's stan's message I'll push these versions of the 
documents today.

> I will give better feedback once I've had a chance to review the split
great.

> windowing.
This is enabled by the ethernet definition in the traffic classification 
DI.  Let me know if you disagree after your review.

>   I wonder whether we are requesting too many extension
The extension point is needed to enable negotiation on session 
establishment so both endpoints know what the other supports and what 
functions are being used on the session.  Let's points would either 
result in ambiguity or the need for secondary negation. Again, let me/us 
know if you disagree after your review.

> I promise a more coherent response when I have some more time next
Thanks again!
Lou

---

From: Justin Dean <[email-masked]>
Date: Thu, 2 Aug 2018 11:07:24 -0400

I've no objection to this path forward.

Justin

On Thu, Aug 2, 2018 at 10:26 AM, Lou Berger <[email-masked]> wrote:

> Thanks - given's stan's message I'll push these versions of the documents
> today.
>
> functions are being used on the session.  Let's points would either result
> in ambiguity or the need for secondary negation. Again, let me/us know if
> you disagree after your review.
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 3 Aug 2018 08:33:04 +0200

+1

AB

On Wed, Aug 1, 2018 at 11:38 PM, Ratliff, Stanley <[email-masked]>
wrote:

> ============================================================
> ============================================================
> ====================