Subject: [martini] GIN and user=insane

From: Cullen Jennings <[email-masked]>
Date: Wed, 16 Jun 2010 11:01:22 -0600

I'm objecting to the autouser stuff in GIN. The rest of this message is just a longer rant saying the same thing so you can stop reading here if you don't care. 

We discussed user=X forever at IETF and never came to any satisfactory resolution because the truth of the matter is that it was classic IETF over engineering and in practice it was easy to ignore with no bad consequences. This resulted in many problem - the worst way to fix theses problems would be to make the situation even more complicated. The best way would be to simplify the situation. In practice, people don't have users names that are all numeric, and they don't have dial strings that start with +. Think of how much simpler life would be if we just assumed things that started with a + were an E.164 number, things that were all numeric where a dial string and some times a dial string happened to be exactly the same as the related phone number and things that looked like were alpha number where email style user names. I am not aware of single deployment that does not fit the above model. From a purely pragmatic point of view, many systems already implicitly assume the above. I've yet to see a deployment where both calls to 123@domain and 123@domain;user=phone both work yet go to different places. Yes, I understand it is possible in theory but it would be nuts to deploy that. 

For years people have tried to clarify this whole things by adding more definition, yet implementations mostly just ignored it  - and for good reason - it did not really matter. So now we have the issue where some PBX want user=phone and some do not. To implement GIN on theses PBX, code is going to have to change, so instead of making the situation worse with autouser=true, why don't we just fix the bugs and cause the PBX to be be generous in what they are willing to receive.

---

From: Hans Erik van Elburg <[email-masked]>
Date: Wed, 16 Jun 2010 19:53:20 +0200

+1

/Hans Erik van Elburg

On Wed, Jun 16, 2010 at 7:01 PM, Cullen Jennings <[email-masked]> wrote:

>
> I'm objecting to the autouser stuff in GIN. The rest of this message is
> just a longer rant saying the same thing so you can stop reading here if you
> don't care.
>
>
>

---

From: "Leis, Peter (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 17 Jun 2010 09:36:24 +0200

+1

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of ext Hans Erik van Elburg
	Sent: Wednesday, June 16, 2010 7:53 PM
	To: Cullen Jennings
	Cc: [email-masked]
	Subject: Re: [martini] GIN and user=insane

	+1
	
	/Hans Erik van Elburg

	On Wed, Jun 16, 2010 at 7:01 PM, Cullen Jennings
<[email-masked]> wrote:

		I'm objecting to the autouser stuff in GIN. The rest of
this message is just a longer rant saying the same thing so you can stop
reading here if you don't care.