Subject: Re: [Masque] Closing remaining IP proxying requirements

From: Mirja Kuehlewind <[email-masked]>
Date: Mon, 3 May 2021 08:48:15 +0000

Hi Chris, hi Eric, hi all,

I don't really see support for your assessment of consensus. What I see is that for issues #12 and #25 there was very little discussion at the interim and basically no feedback for the consensus call. Those few people who did discuss did not reach consensus.

For #26 as I already said I also don't see consensus. In the previous interim there was obviously no consensus and those people who spoke up based on the call on the list later already participated in that interim, so that was no new input.

Again, I think we should not even try to reach consensus here and just move on. The document fulfilled the purpose that we discussed some of the issues and different viewpoints and now have a better mutual understanding. That's all what we need to move on!

Mirja

On 01.05.21, 00:33, "Masque on behalf of Christopher Wood" <[email-masked] on behalf of [email-masked]> wrote:

    Thanks to everyone for their patience! Based on this consensus call, issues #24, #29, #25, and #26 have resolutions. We filed a new issue -- #30 -- to track a non-editorial concern from #25. At this point, we ask that the editors submit a new version of this document incorporating the resolution from each issue.

    Issue #30 is the last remaining issue as we prepare to enter WGLC for this document. As such, the chairs would like begin a consensus call lasting one week for this issue alone. Once complete, we will begin WGLC to solidify the document in its entirety. To that end, we ask that you chime in here or on the issue so that we can assess consensus. 

    The call will complete on Friday, May 7.

    Best,
    Chris and Eric

    On Thu, Apr 29, 2021, at 2:38 AM, Eric Kinnear wrote:
    > Hi all, 
    > 
    > Thanks to everyone who chimed in on the remaining topics for this 
    > document. Chris and I are reviewing the feedback and discussing next 
    > steps. Stay tuned!
    > 
    > Thanks,
    > Eric
    > 
    > 
    > > On Apr 15, 2021, at 5:23 PM, Christopher Wood <[email-masked]> wrote:
    > > 
    > > Based on today's interim meeting, we would like to close out the remaining IP requirements issues alongside the existing consensus call. To that end, please review the following issues and let us know if you support the proposed resolutions before April 27.
    > > 
    > > * Issue #24 (https://protect2.fireeye.com/v1/url?k=eff80d29-b063346a-eff84db2-861fcb972bfc-30c43186a82c8e7f&q=1&e=d697438d-1694-434b-8df6-fd3835152b5f&u=https%3A%2F%2Fgithub.com%2Fietf-wg-masque%2Fdraft-ietf-masque-ip-proxy-reqs%2Fissues%2F24): Requirement to support HTTP/2
    > > 	Proposed resolution: merge PR #28
    > > 
    > > * Issue #25 (https://protect2.fireeye.com/v1/url?k=95521b2c-cac9226f-95525bb7-861fcb972bfc-c94f9cf872b824db&q=1&e=d697438d-1694-434b-8df6-fd3835152b5f&u=https%3A%2F%2Fgithub.com%2Fietf-wg-masque%2Fdraft-ietf-masque-ip-proxy-reqs%2Fissues%2F25): Clarify Route Negotiation
    > > 	Proposed resolution: merge PR #27 
    > > 
    > > * Issue #12 (https://protect2.fireeye.com/v1/url?k=80a97b42-df324201-80a93bd9-861fcb972bfc-fefee9eacd9aa381&q=1&e=d697438d-1694-434b-8df6-fd3835152b5f&u=https%3A%2F%2Fgithub.com%2Fietf-wg-masque%2Fdraft-ietf-masque-ip-proxy-reqs%2Fissues%2F12): Address Assignment isn't validated
    > > 	Proposed resolution: merge PR #29
    > > 
    > > Thanks,
    > > Chris and Eric
    > > 
    > > -- 
    > > Masque mailing list
    > > [email-masked]
    > > https://www.ietf.org/mailman/listinfo/masque
    > 
    > 

    -- 
    Masque mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/masque

---

From: "Christopher Wood" <[email-masked]>
Date: Tue, 04 May 2021 16:53:03 -0700

Hi Mirja, 

Thank you for bringing these concerns to our attention! In order to provide additional insight and clarity into our process for determining consensus on the previous consensus calls, we’ve started a new thread [1] in order to keep this focused on issue #30. 

The currently running consensus call is seeking input on the proposal to remove route negotiation as a requirement (issue #30). Technical ideas and comments are always encouraged, and we really appreciate the active engagement and participation from members of the WG. 

Does anyone have new information that the WG should be aware of which would affect the presence of route negotiation as a requirement? Are there use cases that would be prohibited by keeping it as a requirement? Are there any use cases that would be prohibited if it were not present as a requirement?

Thanks,
Chris and Eric

[1] https://mailarchive.ietf.org/arch/msg/masque/LXObvy1DDuxLs-3dndyNKY0W4Gs/

On Mon, May 3, 2021, at 1:48 AM, Mirja Kuehlewind wrote:
> I don't really see support for your assessment of consensus. What I see 
> is that for issues #12 and #25 there was very little discussion at the 
> interim and basically no feedback for the consensus call. Those few 
> people who did discuss did not reach consensus.
> 
> For #26 as I already said I also don't see consensus. In the previous 
> interim there was obviously no consensus and those people who spoke up 
> based on the call on the list later already participated in that 
> interim, so that was no new input.
> 
> Again, I think we should not even try to reach consensus here and just 
> move on. The document fulfilled the purpose that we discussed some of 
> the issues and different viewpoints and now have a better mutual 
> understanding. That's all what we need to move on!
> 
> Mirja
> 
> 
> 
> On 01.05.21, 00:33, "Masque on behalf of Christopher Wood" 
> <[email-masked] on behalf of [email-masked]> wrote:
> 
>     Thanks to everyone for their patience! Based on this consensus 
> call, issues #24, #29, #25, and #26 have resolutions. We filed a new 
> issue -- #30 -- to track a non-editorial concern from #25. At this 
> point, we ask that the editors submit a new version of this document 
> incorporating the resolution from each issue.
> 
>     Issue #30 is the last remaining issue as we prepare to enter WGLC 
> for this document. As such, the chairs would like begin a consensus 
> call lasting one week for this issue alone. Once complete, we will 
> begin WGLC to solidify the document in its entirety. To that end, we 
> ask that you chime in here or on the issue so that we can assess 
> consensus. 
> 
>     > > Based on today's interim meeting, we would like to close out 
> the remaining IP requirements issues alongside the existing consensus 
> call. To that end, please review the following issues and let us know 
> if you support the proposed resolutions before April 27.
>     > > 
>     > > * Issue #24 
> (https://protect2.fireeye.com/v1/url?k=eff80d29-b063346a-eff84db2-861fcb972bfc-30c43186a82c8e7f&q=1&e=d697438d-1694-434b-8df6-fd3835152b5f&u=https%3A%2F%2Fgithub.com%2Fietf-wg-masque%2Fdraft-ietf-masque-ip-proxy-reqs%2Fissues%2F24): Requirement to support HTTP/2
>     > > * Issue #25 
> (https://protect2.fireeye.com/v1/url?k=95521b2c-cac9226f-95525bb7-861fcb972bfc-c94f9cf872b824db&q=1&e=d697438d-1694-434b-8df6-fd3835152b5f&u=https%3A%2F%2Fgithub.com%2Fietf-wg-masque%2Fdraft-ietf-masque-ip-proxy-reqs%2Fissues%2F25): Clarify Route Negotiation
>     > > * Issue #12 
> (https://protect2.fireeye.com/v1/url?k=80a97b42-df324201-80a93bd9-861fcb972bfc-fefee9eacd9aa381&q=1&e=d697438d-1694-434b-8df6-fd3835152b5f&u=https%3A%2F%2Fgithub.com%2Fietf-wg-masque%2Fdraft-ietf-masque-ip-proxy-reqs%2Fissues%2F12): Address Assignment isn't validated

---

From: "Christopher Wood" <[email-masked]>
Date: Thu, 13 May 2021 15:50:53 -0700

Hearing no support for the proposal in the issue, it has been closed. We'll now work on soliciting wider reviews and beginning the WGLC process. As a reminder, WGLC is meant to solidify requirements for the eventual solutions as best we can.

Thanks,
Chris and Eric

On Fri, Apr 30, 2021, at 3:32 PM, Christopher Wood wrote:
> Thanks to everyone for their patience! Based on this consensus call, 
> issues #24, #29, #25, and #26 have resolutions. We filed a new issue -- 
> #30 -- to track a non-editorial concern from #25. At this point, we ask 
> that the editors submit a new version of this document incorporating 
> the resolution from each issue.
> 
> Issue #30 is the last remaining issue as we prepare to enter WGLC for 
> this document. As such, the chairs would like begin a consensus call 
> lasting one week for this issue alone. Once complete, we will begin 
> WGLC to solidify the document in its entirety. To that end, we ask that 
> you chime in here or on the issue so that we can assess consensus. 
> 
> > > * Issue #24 (https://github.com/ietf-wg-masque/draft-ietf-masque-ip-proxy-reqs/issues/24): Requirement to support HTTP/2
> > > * Issue #25 (https://github.com/ietf-wg-masque/draft-ietf-masque-ip-proxy-reqs/issues/25): Clarify Route Negotiation
> > > * Issue #12 (https://github.com/ietf-wg-masque/draft-ietf-masque-ip-proxy-reqs/issues/12): Address Assignment isn't validated

---

From: Mirja Kuehlewind <[email-masked]>
Date: Mon, 17 May 2021 12:29:25 +0000

Hi Chris,

I didn't understand that the proposal was to keep the text as it is. Issue #30 mainly raised a question and we raised concern in issue #25; I didn't think I need to restate the same concerns in issue #30. However, there was no further discussion in #30, so I don't anything was resolved at all.

Mirja

On 14.05.21, 00:52, "Masque on behalf of Christopher Wood" <[email-masked] on behalf of [email-masked]> wrote:

    Thanks,
    Chris and Eric

    On Fri, Apr 30, 2021, at 3:32 PM, Christopher Wood wrote:
    > > > * Issue #24 (https://protect2.fireeye.com/v1/url?k=13f86f1d-4c635650-13f82f86-86b568293eb5-0d0cc3d1b70e0f7b&q=1&e=35d6ba52-106a-43aa-8659-39f1262b11ea&u=https%3A%2F%2Fgithub.com%2Fietf-wg-masque%2Fdraft-ietf-masque-ip-proxy-reqs%2Fissues%2F24): Requirement to support HTTP/2
    > > > * Issue #25 (https://protect2.fireeye.com/v1/url?k=c5a42ef0-9a3f17bd-c5a46e6b-86b568293eb5-c27695eeace86844&q=1&e=35d6ba52-106a-43aa-8659-39f1262b11ea&u=https%3A%2F%2Fgithub.com%2Fietf-wg-masque%2Fdraft-ietf-masque-ip-proxy-reqs%2Fissues%2F25): Clarify Route Negotiation
    > > > * Issue #12 (https://protect2.fireeye.com/v1/url?k=9696d15d-c90de810-969691c6-86b568293eb5-c159e4589b081941&q=1&e=35d6ba52-106a-43aa-8659-39f1262b11ea&u=https%3A%2F%2Fgithub.com%2Fietf-wg-masque%2Fdraft-ietf-masque-ip-proxy-reqs%2Fissues%2F12): Address Assignment isn't validated