Subject: RE: mboned: Historic-able multicast RFCs?

From: "Dave Thaler" <[email-masked]>
Date: Tue, 3 Aug 2004 13:49:22 -0700

Can you be more specific about what in 2908 is causing problems?

I'm not sure Experimental protocols need to be made historic, but
I would argue against the others, except possibly 2907 (which I 
have no data on either way). 

-Dave

> -----Original Message-----
> From: [email-masked] [mailto:owner-
> [email-masked]] On Behalf Of Pekka Savola
> Sent: Sunday, August 01, 2004 2:49 PM
> To: [email-masked]
> Subject: mboned: Historic-able multicast RFCs?
> 
> Hi,
> 
> When reading a draft which had a completely wrong picture of IP
> multicast, it started to seem that we'd need to do some spring
> cleaning, e.g., by moving some RFCs to Historic.
> 
> I listed a couple of possible ones below, with their category.
> 
> I think at least RC2908 must be made historic -- it is causing no end
> of problems (or better yet, write a better one! :-).  I don't have a
> strong opinion on the rest, but it seems most of the malloc WG's
> products are more trouble than they're worth...
> 
> Thoughts?
> 
> RFC3559
> Multicast Address Allocation MIB (PS)
> 
> RFC2909
> The Multicast Address-Set Claim (MASC) Protocol (Exp)
> 
> RFC2908
> The Internet Multicast Address Allocation Architecture (Info)
> 
> RFC2907
> MADCAP Multicast Scope Nesting State Option (PS)
> 
> RFC2776
> Multicast-Scope Zone Announcement Protocol (MZAP)  (PS)
> 
> RFC2771
> An Abstract API for Multicast Address Allocation (Info)
> 
> RFC2730
> Multicast Address Dynamic Client Allocation Protocol (MADCAP) (PS)
> 
> --
> Pekka Savola                 "You each name yourselves king, yet the
> Netcore Oy                    kingdom bleeds."
> Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
> 
> _______________________________________________________________
> user interface: http://darkwing.uoregon.edu/~llynch/mboned.html
> web archive:  http://darkwing.uoregon.edu/~llynch/mboned/

_______________________________________________________________
user interface: http://darkwing.uoregon.edu/~llynch/mboned.html
web archive:  http://darkwing.uoregon.edu/~llynch/mboned/

---

From: Pekka Savola <[email-masked]>
Date: Wed, 4 Aug 2004 18:56:07 +0300 (EEST)

> Can you be more specific about what in 2908 is causing problems?

Take a look at the Introduction of
draft-ietf-ipv6-link-scoped-mcast-04.txt.  Previous to that, I've
tutored a few MSc-level studies of multicast routing & addressing;  
invariably, all of them found RFC2908 and thought that the multicast
allocation & assignment processes described there were valid.

IMHO, this calls very strongly for a new IP multicast
allocation/assignment document (this was brought up with IMDOC an IETF
or two ago), making the current one Historic.

> have no data on either way). 

How about moving some or all of them to Experimental?  Would you be 
strongly opposed to that?