Subject: [MBONED] Updated Draft: IGMP/MLD Proxy Upstream Interface Learning

From: "Jayanth Chennamangalam" <[email-masked]>
Date: Sun, 1 Jul 2007 17:32:39 +0530

Hi!

We have submitted a new draft on "IGMP/MLD Proxy Upstream Interface
Learning" (draft-vijay-mboned-igmpproxy-upstream-learning-00) to the MBONED
Working Group as an update to
draft-vijay-magma-igmpproxy-upstream-intf-learning-00.

The document specifies a mechanism for the dynamic determination of the
upstream interface of a device running IGMP/MLD Proxy, as opposed to manual
configuration. The learning of the upstream interface is achieved by
listening for IGMP/MLD General Query messages on the interfaces of the proxy
device.

The updates include an additional "no-querier" alarm, and support for
Multicast Router Advertisement messages for the determination of the
upstream interface.

I would greatly appreciate it if the WG members could review the draft and
send me comments. The draft is available at:
http://tools.ietf.org/html/draft-vijay-mboned-igmpproxy-upstream-learning-00

Thanks and regards,

Jayanth
_______________________________________________
MBONED mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mboned

---

From: "Alvaro Fernandez" <[email-masked]>
Date: Sun, 1 Jul 2007 17:57:53 +0200

Hi Jayanth:
 
Just one comment:
 
Sending General Query Messages on the Downstream (4.6)
 
The host will be answering different General Querys and this is not necesary.
 
You can add another timer and send the General Query to downstream interfaces based on this timer and not every time the proxy receives a General Query from one usptream interfaces. General Querys can produce "feedback implosion" and it is diffcult for one DSLAM to process them. There are some patents from Alcatel that explains this problem.
 
Regards

Alvaro

________________________________

De: Jayanth Chennamangalam [mailto:[email-masked]]
Enviado el: dom 01/07/2007 14:02
Para: [email-masked]
CC: Krishna Agarwal
Asunto: [MBONED] Updated Draft: IGMP/MLD Proxy Upstream Interface Learning

Hi!

We have submitted a new draft on "IGMP/MLD Proxy Upstream Interface Learning" (draft-vijay-mboned-igmpproxy-upstream-learning-00) to the MBONED Working Group as an update to draft-vijay-magma-igmpproxy-upstream-intf-learning-00. 

The document specifies a mechanism for the dynamic determination of the upstream interface of a device running IGMP/MLD Proxy, as opposed to manual configuration. The learning of the upstream interface is achieved by listening for IGMP/MLD General Query messages on the interfaces of the proxy device. 

The updates include an additional "no-querier" alarm, and support for Multicast Router Advertisement messages for the determination of the upstream interface.

I would greatly appreciate it if the WG members could review the draft and send me comments. The draft is available at: http://tools.ietf.org/html/draft-vijay-mboned-igmpproxy-upstream-learning-00

Thanks and regards,

Jayanth

---

From: "Alvaro Fernandez" <[email-masked]>
Date: Sun, 1 Jul 2007 17:57:53 +0200

Hi Jayanth:
 
Just one comment:

 
 
Regards

Alvaro

Hi!

Thanks and regards,

Jayanth

---

From: "Jayanth Chennamangalam" <[email-masked]>
Date: Mon, 2 Jul 2007 23:10:29 +0530

Hi Alvaro,

Thank you for the comment!

Our mechanism for sending General Query messages is based on a timer, and is
not dependent on the General Queries received on the upstream. The check for
upstream convergence that is mentioned in Section 4.6 is to find out the
interface to exclude (upstream interface) while flooding the Queries. In
case of convergence, the converged interface is the upstream interface, so
the flooding process must exclude that interface. If the system has not
converged, we assume that the last-learnt interface is the real upstream
interface, and exclude it from Query flooding.

Thanks and regards,

Jayanth

On 7/1/07, Alvaro Fernandez <[email-masked]> wrote:
> You can add another timer and send the General Query to downstream
> interfaces based on this timer and not every time the proxy receives a
> General Query from one usptream interfaces. General Querys can produce
> "feedback implosion" and it is diffcult for one DSLAM to process them. There
> are some patents from Alcatel that explains this problem.
>
> Regards
>
> Alvaro
>
>
>
>
>
>  ------------------------------
>  *De:* Jayanth Chennamangalam [mailto:[email-masked]]
> *Enviado el:* dom 01/07/2007 14:02
> *Para:* [email-masked]
> *CC:* Krishna Agarwal
> *Asunto:* [MBONED] Updated Draft: IGMP/MLD Proxy Upstream Interface
> Learning
>
> Hi!
>

---

From: "Jayanth Chennamangalam" <[email-masked]>
Date: Mon, 2 Jul 2007 23:10:29 +0530

Hi Alvaro,

Thanks and regards,

Jayanth