Subject: [MBONED] Adoption of Multicast Filtering Practices draft

From: Leonard Giuliano <[email-masked]>
Date: Fri, 12 Aug 2011 11:48:04 -0700

draft-chown-mboned-multicast-filtering was presented in MBONED in Quebec. 
There was solid interest in the room to adopt this draft (10-15 yea's, 0 
nay's), so we are taking this to the list. Please respond here on the list 
if you are for or against adopting draft-chown-mboned-multicast-filtering 
as a working group item in MBONED.

Draft can be found at:
http://tools.ietf.org/html/draft-chown-mboned-multicast-filtering-01

---

From: Bill Atwood <[email-masked]>
Date: Fri, 12 Aug 2011 15:54:23 -0400

I was present in the room, and voted yes.  I still vote yes.

  Bill

On 8/12/2011 2:48 PM, Leonard Giuliano wrote:
>
> draft-chown-mboned-multicast-filtering was presented in MBONED in
> Quebec. There was solid interest in the room to adopt this draft
> (10-15 yea's, 0 nay's), so we are taking this to the list. Please
> respond here on the list if you are for or against adopting
> draft-chown-mboned-multicast-filtering as a working group item in MBONED.
>
> Draft can be found at:
> _______________________________________________
> MBONED mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mboned

-- 

Dr. J.W. Atwood, Eng.             tel:   +1 (514) 848-2424 x3046
Distinguished Professor Emeritus  fax:   +1 (514) 848-2830
Department of Computer Science
   and Software Engineering
Concordia University EV 3.185     email: [email-masked]
1455 de Maisonneuve Blvd. West    http: //users.encs.concordia.ca/~bill
Montreal, Quebec Canada H3G 1M8

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Fri, 12 Aug 2011 15:07:28 -0500

In general, I don't have any objections. But I did object to this:

   As a general principle, multicast sourced from private address ranges
   [RFC1918] or from 169.254.0.0/16, 192.0.2.0/24 or 127.0.0.0/8 should
   be dropped, regardless of the multicast destination.

It's the "from private address ranges" that bothers me. It is not so far-fetched that an organizational network would be using at least some RFC 1918 addresses, and that these would be legitimate sources of IP multicasts.

Especially these days, when public IPv4 addresses have essentially run out.

Bert 

--

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Fri, 12 Aug 2011 15:56:39 -0500

Perhaps a more accurate rule would be to say, "As a general principle, multicasts sent to 239.0.0.0/8 multicast groups from sources using private IP address ranges (RFC 1918) may be legitimate. However, multicasts sourced from private IP address ranges to other multicast group ranges, or multicasts from sources 169.254.0.0/16 or 127.0.0.0/8, should generally be dropped."

Bert

-----Original Message-----
From: Manfredi, Albert E 
Sent: Friday, August 12, 2011 4:07 PM
To: [email-masked]
Subject: RE: [MBONED] Adoption of Multicast Filtering Practices draft

Bert

---

From: "William F. Maton Sotomayor" <[email-masked]>
Date: Fri, 12 Aug 2011 17:41:22 -0400 (EDT)

On Fri, 12 Aug 2011, Leonard Giuliano wrote:

> nay's), so we are taking this to the list. Please respond here on the list if 
> you are for or against adopting draft-chown-mboned-multicast-filtering as a 
> working group item in MBONED.

I favour adoption by the WG.

wfms

---

From: <[email-masked]>
Date: Mon, 15 Aug 2011 11:39:52 +0200

Hi,

I do support the draft becoming a WG document.

  regards

     Nic

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Leonard Giuliano
Gesendet: Freitag, 12. August 2011 20:48
An: MBONED WG
Betreff: [MBONED] Adoption of Multicast Filtering Practices draft

Draft can be found at:

---

From: <[email-masked]>
Date: Mon, 15 Aug 2011 11:59:16 +0200

Hi,

> It's the "from private address ranges" that bothers me. It is not so far-fetched
> that an organizational network would be using at least some RFC 1918 addresses,
> and that these would be legitimate sources of IP multicasts.
>
I think thats already the case in certain deployments, but mainly for "internal" Multicast
traffic with source addresses which are not being routed outside of your own network.
Therefore the interesting questions is, do we expect multicast traffic with RFC1918
sources crossing MSDP peers or border routers. From my point of view this is not
very likely (and might be tricky because of potentially overlapping RFC1918 address
ranges).

  Regards

     Nic

--

---

From: Hitoshi Asaeda <[email-masked]>
Date: Tue, 16 Aug 2011 11:11:22 +0900 (JST)

Hi,

> http://tools.ietf.org/html/draft-chown-mboned-multicast-filtering-01

I support this draft adoption.
Regards,
--
Hitoshi Asaeda

---

From: Greg Shepherd <[email-masked]>
Date: Mon, 29 Aug 2011 10:53:54 -0700

I too support the adoption of this draft.

Greg

---

From: Leonard Giuliano <[email-masked]>
Date: Wed, 31 Aug 2011 14:02:58 -0700

Based on unanimous support in the mtg and on the list, there appears to be 
consensus to adopt as a WG doc. 

Tim, please submit a new 00 draft as a WG document.

Thanks,
Lenny

-) 
-) draft-chown-mboned-multicast-filtering was presented in MBONED in Quebec.
-) There was solid interest in the room to adopt this draft (10-15 yea's, 0
-) nay's), so we are taking this to the list. Please respond here on the list if
-) you are for or against adopting draft-chown-mboned-multicast-filtering as a
-) working group item in MBONED.
-) 
-) Draft can be found at:
-) http://tools.ietf.org/html/draft-chown-mboned-multicast-filtering-01
-) 
-)