Subject: Re: [MBONED] Proposed interim date and agenda

From: Jacni Qin <[email-masked]>
Date: Thu, 1 Mar 2012 21:20:44 +0800

Hi Stig,

On Sat, Feb 25, 2012 at 3:03 AM, Stig Venaas <[email-masked]> wrote:

> On 2/24/2012 12:26 AM, Jacni Qin wrote:
>
>> Re-,
>>
>>
>> On Tue, Feb 21, 2012 at 10:56 AM, Tina TSOU
>> <[email-masked] <mailto:Tina.Tsou.Zouting@**huawei.com<[email-masked]>>>
>> wrote:
>>
>>    We have at least for topics to discuss.
>>    1. The degree to which the AF is stateless.
>>    2. Which strategy looks more promising in the Address Acquisition
>> draft?
>>    3. Routing crosses address boundaries, loop avoidance.
>>    4. What does the AF do when it lives on a machine that speaks IGMP
>>    or MLD out one side and PIM out the other? Does it translate between
>>    IGMP and MLD, or does it maintain all of the state that it needs to
>>    interface between IGMP or MLD and PIM?
>>
>>
>> Sorry, I don't understand what you mean by the 1.
>>
>
> Hi Jacni. Regarding number 1. In my opinion, the question is whether
> stateful or stateless, similar to what has been discussed for unicast.
>
> Thank you for clarifing that.

> I believe you can easily do stateless translation from IPv4 to IPv6
> by embedding IPv4 address into IPv6. But in the other direction, it
> is likely that you need state.

> Basically you can map a set of IPv6 addresses to IPv4, but that
> mapping either needs to be a statically configured mapping, or
> somehow learned dynamically.
>
> Yes, IMO, the other direction can also be done without any state but
algorithmically.
The prefixes used for that can be assigned, say stateless DHCP.

Cheers,
Jacni

> Stig
>
>  Not sure yet about the 2., still reading the draft.
>> About the 3 &4, please refer to Christian's message earler, or you can
>> read the http://tools.ietf.org/html/**draft-jaclee-behave-v4v6-**
>> mcast-ps-03<http://tools.ietf.org/html/draft-jaclee-behave-v4v6-mcast-ps-03>
>> ,
>> not all cases are covered, but you can get the clue to the answer.
>>
>>
>> Cheers,
>> Jacni
>>
>>
>>    That's actually a discussion that requires relatively high
>>    bandwidth. It is better suited to a conference call than an email
>>    exchange.
>>
>>    Tina
>>
>>
>>     > -----Original Message-----
>>     > From: [email-masked] <mailto:mboned-bounces@ietf.**org<[email-masked]>
>> >
>>    [mailto:mboned-bounces@ietf.**org <[email-masked]> <mailto:
>> mboned-bounces@ietf.**org <[email-masked]>>] On
>>    Behalf
>>     > Of Ronald Bonica
>>     > Sent: Monday, February 20, 2012 6:28 PM
>>     > To: [email-masked] <mailto:[email-masked]>
>>     > Subject: Re: [MBONED] Proposed interim date and agenda
>>     >
>>     > Jacni,
>>     >
>>     > Good question! I have seen pretty good progress on both the multrans
>>     > overview and addressing drafts. The interim may not be needed.
>>     >
>>     > However, I will let the proponents of this meeting speak for
>>    themselves.
>>     > If they still want to hold this meeting, they can tell us what
>> topics
>>     > remain open for discussion. If however, they no longer want to
>>    hold this
>>     > meeting, they always have the option to cancel it.
>>     >
>>     >                                     Ron
>>     >
>>     >
>>     > > Message: 1
>>     > > Date: Tue, 21 Feb 2012 09:51:26 +0800
>>     > > From: Jacni Qin <[email-masked] <mailto:[email-masked]>>
>>     > > To: Marc Blanchet <[email-masked]
>>    <mailto:marc.blanchet@**viagenie.ca <[email-masked]>>>
>>     > > Cc: MBONED WG <[email-masked] <mailto:[email-masked]>>
>>
>>     > > Subject: Re: [MBONED] Proposed interim date and agenda
>>     > > Message-ID:
>>     > > <CAHmj1Weabs9=P-
>>     > > 4aBqZs3dSXWNiqR5_**BACc0HguwG4AArEGoPg@mail.**gmail.com<[email-masked]>
>>    <mailto:4aBqZs3dSXWNiqR5_**BACc0HguwG4AArEGoPg@mail.**gmail.com<[email-masked]>
>> >>
>>
>>     > > Content-Type: text/plain; charset="iso-8859-1"
>>     > >
>>     > > Re-,
>>     > >
>>     > > Sorry, may I ask why we need this interim meeting?
>>     > >
>>     > >
>>     > > Cheers,
>>     > > Jacni
>>     > >
>>     > >
>>     > ****************
>>     > ______________________________**_________________
>>     > MBONED mailing list
>>     > [email-masked] <mailto:[email-masked]>
>>
>>     > https://www.ietf.org/mailman/**listinfo/mboned<https://www.ietf.org/mailman/listinfo/mboned>
>>    ______________________________**_________________
>>    MBONED mailing list
>>    [email-masked] <mailto:[email-masked]>
>>
>>    https://www.ietf.org/mailman/**listinfo/mboned<https://www.ietf.org/mailman/listinfo/mboned>
>>
>>
>>
>>
>> ______________________________**_________________
>> MBONED mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/**listinfo/mboned<https://www.ietf.org/mailman/listinfo/mboned>
>>
>
>

---

From: Jacni Qin <[email-masked]>
Date: Thu, 1 Mar 2012 21:30:51 +0800

Re-,

On Wed, Feb 29, 2012 at 2:38 AM, Tina TSOU <[email-masked]>wrote:

> 1. Welcome introduction and agenda bashing (mboned chairs)
>
> 2. What work items to be completed (all)
>
> 3. Discuss what should be the baseline overview? (all)
> http://tools.ietf.org/html/draft-jaclee-behave-v4v6-mcast-ps-03
> or
> http://datatracker.ietf.org/doc/draft-eubanks-mboned-transition-overview/
>
> 4. Outstanding issues discussion (all)
> a. The degree to which the AF is stateless.
> b. Which strategy looks more promising in the Address Acquisition draft?
> c. Routing crosses address boundaries, loop avoidance.
> d. What does the AF do when it lives on a machine that speaks IGMP or MLD
> out one side and PIM out the other? Does it translate between IGMP and MLD,
> or does it maintain all of the state that it needs to interface between
> IGMP or MLD and PIM?
>
> Much more of the No. 4 are in the solution space, I don't think it's
necessary to discuss those  before any conclusion or consensus are reached
on the Problems/Use Cases.

Cheers,
Jacni

> 5. Wrap-up: action items, next steps, AOB. (all)
>
>
> Tina
> _______________________________________________
> MBONED mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mboned
>

---

From: "Lee, Yiu" <[email-masked]>
Date: Thu, 1 Mar 2012 14:59:50 +0000

I agree with Jacni that we should focus on problems and use cases first,
then we start discussing solution space.

From:  Jacni Qin <[email-masked]>
Date:  Thu, 1 Mar 2012 21:30:51 +0800
To:  Tina TSOU <[email-masked]>
Cc:  "[email-masked]" <[email-masked]>, Ron Bonica <[email-masked]>
Subject:  Re: [MBONED] Proposed interim agenda

Re-,

On Wed, Feb 29, 2012 at 2:38 AM, Tina TSOU <[email-masked]>
wrote:
> d. What does the AF do when it lives on a machine that speaks IGMP or MLD out
> one side and PIM out the other? Does it translate between IGMP and MLD, or
> does it maintain all of the state that it needs to interface between IGMP or
> MLD and PIM?
> 

Cheers,
Jacni
 
> 5. Wrap-up: action items, next steps, AOB. (all)

_______________________________________________ MBONED mailing list
[email-masked] https://www.ietf.org/mailman/listinfo/mboned