Subject: Re: [MBONED] Multicast transition work in MBONED

From: Ronald Bonica <[email-masked]>
Date: Tue, 12 Jun 2012 00:25:14 -0400

Simon,

Lenny's question is not only appropriate, but necessary. In order to scope the MLTRANS work, the WG needs to know which of the use-cases described in draft-ietf-mboned-v4v6-mcast-ps are likely to be deployed.

So far, exactly one operator has stepped forward to say that he is deploying use-cases 3.4 and 3.5 (aka, the dual-stack use-cases). In response to that post, the WG has identified the following solutions:

1) Source the stream twice, once over IPv4 and once over IPv6
2) Source the stream once. Deploy a box near the source that translates the stream from IPvX to IPvY and sources the stream a second time over IPvY (Antonio, Do I have that right?)
3) Source the stream once. Deploy multicast routers that are capable of grafting IPvX receivers onto IPvY distribution trees.

Solutions 1 and 2 are simple, but may consume twice as much bandwidth as Solution 3. Solution 3 trades simplicity for bandwidth. 

Of the operators who are deploying use-cases 3.4 and 3.5, do any prefer Solution 3 over the other two solutions? Are any operators planning to deploy use-cases other than 3.4 and 3.5?

Lacking this information, the WG has no idea what protocol machinery is actually required.

                                                   Ron
                                                   /speaking as AD

> 
> Are you looking for answers from operators other than the ones co-
> authoring the drafts?
> 
> I mean, just by looking at the two adopted drafts I'm counting 4
> operators among the authors lists. 3 more in the acknowledgements
> section. Many others have been involved in the mailing list
> discussions.
> 
> Why are we asking this question yet again?
> 
> Isn't the problem statement draft supposed to be the definitive answer
> to this question?
> 
> Simon

---

From: Antonio Querubin <[email-masked]>
Date: Tue, 12 Jun 2012 03:40:03 -1000 (HST)

On Tue, 12 Jun 2012, Ronald Bonica wrote:

> 2) Source the stream once. Deploy a box near the source that translates 
> the stream from IPvX to IPvY and sources the stream a second time over 
> IPvY (Antonio, Do I have that right?)

On or near, depending on whether the source box itself is dual-stack.  I 
suspect it's pretty rare to find an OS that is not dual-stack capable any 
more.

Antonio Querubin
e-mail:  [email-masked]
xmpp:  [email-masked]

---

From: Simon Perreault <[email-masked]>
Date: Tue, 12 Jun 2012 10:46:04 -0400

> Lenny's question is not only appropriate, but necessary. In order to scope the MLTRANS work, the WG needs to know which of the use-cases described in draft-ietf-mboned-v4v6-mcast-ps are likely to b…

Yes the question is appropriate and necessary, but I feel like it has 
been asked and answered many times before.

> So far, exactly one operator has stepped forward

What about the operators co-authoring the drafts? Can we count them too?

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: Ronald Bonica <[email-masked]>
Date: Tue, 12 Jun 2012 11:30:36 -0400

Simon,

I may have missed something. Can you point me to a set of emails in which operators identify the specific use-cases in which they are interested. So far, I only see two such messages and both were in response to Lenny's request.

                                                        Ron

> -----Original Message-----
> From: Simon Perreault [mailto:[email-masked]]
> Sent: Tuesday, June 12, 2012 10:46 AM
> To: Ronald Bonica
> Cc: [email-masked]
> Subject: Re: [MBONED] Multicast transition work in MBONED
> 
> > Lenny's question is not only appropriate, but necessary. In order to
> scope the MLTRANS work, the WG needs to know which of the use-cases
> described in draft-ietf-mboned-v4v6-mcast-ps are likely to be deployed.
>

---

From: Simon Perreault <[email-masked]>
Date: Tue, 12 Jun 2012 12:29:59 -0400

> I may have missed something. Can you point me to a set of emails in which operators identify the specific use-cases in which they are interested. So far, I only see two such messages and both were…

I don't think you have missed anything, but maybe we're not talking 
about the same thing. In my view, almost all discussions around 
multicast translation have been about use cases. There was a dedicated 
mailing list:

http://www.ietf.org/mail-archive/web/multrans/current/maillist.html

Two BOFs were taken on this topic:

IETF 81
Slides: http://www.ietf.org/proceedings/81/multrans.html
Minutes: http://www.ietf.org/jabber/logs/multrans/2011-07-25.html

IETF 82
Slides: http://www.ietf.org/proceedings/82/multrans.html
Minutes: http://www.ietf.org/jabber/logs/multrans/2011-11-17.html

The culmination of these discussions is 
draft-ietf-mboned-v4v6-mcast-ps-00. The whole point of this draft is 
answering the question of use cases.

I don't see why we're having some kind of vote instead of simply 
discussing the draft, just like any other draft. Let's argue about use 
cases that are in the draft but should not, and use cases that are not 
in the draft but should be. That would be productive. It would make the 
draft better, and chairs (of mboned and other working groups) could then 
use the draft, and the building of a consensus around it, as guidance.

Or maybe Lenny's question was intended to generate discussion on the 
draft, and I misinterpreted it as some kind of vote?

Simon