Subject: Re: [MBONED] [hackathon] AMT project at the IETF 98 hackathon

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 9 Mar 2017 19:13:57 +0000

Hi Jake,

Looks like a great project. Thanks for championing it. 
I see interop testing with equipment from various vendors listed in the set of potential projects. Are there any specific requirements on the network above and beyond what is typically provided on the IETF network? 

Thanks,
Charles

-----Original Message-----
From: hackathon <[email-masked]> on behalf of "Holland, Jake" <[email-masked]>
Date: Wednesday, March 8, 2017 at 11:53 AM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [hackathon] AMT project at the IETF 98 hackathon

    Hi folks,
    
    I’ll be attending the IETF 98 Hackathon and working on the AMT implementation from the mboned wg a few years back, trying to make it as useful as I can, in hopes it will help to realize the promise of multicast.
    
    Champions:
    • Jake Holland ([email-masked])
    • Others very welcome
    Projects:
    • The current code is at https://github.com/GrumpyOldTroll/amt (descended from http://www.utdallas.edu/~ksarac/amt/ )
    • Port amtrelayd to at least one wifi router under OpenWRT or similar
    • Add and test IPv6 support
    • Conformance tests vs. RFC 7450
    • Interop testing with other AMT implementations (Cisco, Juniper, etc.)
    • Stream some multicasted video through it
    • Make a libamtgw library for embedding AMT gateway functionality in client apps
    • Anything else that might make this technology easier to adopt and deploy
    
    Cheers,
    Jake
    
    _______________________________________________
    hackathon mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/hackathon

---

From: "Holland, Jake" <[email-masked]>
Date: Thu, 9 Mar 2017 20:19:44 +0000

Hi Charles,

I don’t think I need anything unusual from the network.

A wired Ethernet connection is maybe a nice-to-have but not essential. Another possible nice-to-have is maybe about 8mb of bandwidth available occasionally for non-responsive traffic, but I was planning as though that will not be available.

The interop testing I was going to try with Cisco and Juniper will be with their virtual router implementations. I’ll bring a desktop machine set up as a vm host that will be running those, plus a couple of small devices. Unless the power is especially problematic, I expect they can all work off a power strip.

Thanks for checking.

-Jake

On 3/9/17, 11:13 AM, "Charles Eckel (eckelcu)" <[email-masked]> wrote:

Hi Jake,

Thanks,
Charles

-----Original Message-----
From: hackathon <[email-masked]> on behalf of "Holland, Jake" <[email-masked]>
Date: Wednesday, March 8, 2017 at 11:53 AM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [hackathon] AMT project at the IETF 98 hackathon

    Hi folks,

    Champions:
    
    Cheers,
    Jake

---

From: William Atwood <[email-masked]>
Date: Thu, 9 Mar 2017 15:33:55 -0500

Jake,

In my lab at Concordia, we got the UTD version of AMT working for both
Windows and Linux.  The end result was then archived on SourceForge:

https://sourceforge.net/projects/automulticastnoexplicittunnels/

I have not looked at it for a couple of years, and I was never deeply
involved in it.

My main reason for coming to the Hackathon is to work on the Anima
software.  However, I will try to collect the AMT stuff that we have and
bring it along.  I will certainly look in on your work during the two days.

  Bill

On 09/03/2017 2:13 PM, Charles Eckel (eckelcu) wrote:
> MBONED mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mboned
> 

-- 

Dr. J.W. Atwood, Eng.             tel:   +1 (514) 848-2424 x3046
Distinguished Professor Emeritus  fax:   +1 (514) 848-2830
Department of Computer Science
   and Software Engineering
Concordia University EV 3.185     email:[email-masked]
1455 de Maisonneuve Blvd. West    http://users.encs.concordia.ca/~bill
Montreal, Quebec Canada H3G 1M8

---

From: "Holland, Jake" <[email-masked]>
Date: Thu, 9 Mar 2017 21:57:07 +0000

Excellent, thanks Bill! Good to know about.

I’ll take a look at the diffs, that seems likely to have some useful things to merge.

Cheers,
Jake

On 3/9/17, 12:33 PM, "William Atwood" <[email-masked]> wrote:

Jake,

  Bill

--