Subject: [MBONED] I-D Action: draft-ietf-mboned-mtrace-v2-18.txt

From: [email-masked]
Date: Mon, 28 Aug 2017 19:08:40 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the MBONE Deployment WG of the IETF.

        Title           : Mtrace Version 2: Traceroute Facility for IP Multicast
        Authors         : Hitoshi Asaeda
                          Kerry Meyer
                          WeeSan Lee
	Filename        : draft-ietf-mboned-mtrace-v2-18.txt
	Pages           : 36
	Date            : 2017-08-28

Abstract:
   This document describes the IP multicast traceroute facility, named
   Mtrace version 2 (Mtrace2).  Unlike unicast traceroute, Mtrace2
   requires special implementations on the part of routers.  This
   specification describes the required functionality in multicast
   routers, as well as how an Mtrace2 client invokes a query and
   receives a reply.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-mboned-mtrace-v2/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-mboned-mtrace-v2-18
https://datatracker.ietf.org/doc/html/draft-ietf-mboned-mtrace-v2-18

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-mboned-mtrace-v2-18

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Hitoshi Asaeda <[email-masked]>
Date: Tue, 29 Aug 2017 11:31:40 +0900

Hello folks,

We received comments from Jake/Lenny and Mankamana during the WGLC for the mtrace2 draft.
We then applied the comments to the draft and have submitted the revised one.

The followings are the summary of the changes.
If there are no other concerns or comments, we'd like to ask chairs to move it forward.

Changes:

1. section 1, add the following sentence to clarify the target and scope of this document;

"This document describes the base specification of Mtrace2 that can serve as a basis for future proposals such as Mtrace2 for AMT [9] and Mtrace2 for MVPN [10]. They are therefore out of the scope of this document."

2. section 3.2.2, add the following sentence at the end of the first paragraph to make the meaning more clearer;

"If the actual number of hops is not known, an Mtrace2 client could send an initial Query message with a large # Hops (e.g., 0xffffffff), in order to try to trace the full path."

3. section 4.4, change the first paragraph as follows, to clearly explain the meaning;

"An Mtrace2 Reply MUST be returned to the client by a router if any of the following conditions occur:

1.  The total number of the traced routers are equal to the # of hops
    in the request (including the one just added) plus the number of
    the returned blocks, if any.

2.  Appending the Standard Response Block would make the Mtrace2
    Request packet longer than the MTU of the Incoming interface.
    (In case of IPv6 not more than 1280 bytes; see Section 4.3.3 for
    additional details on handling of this case.)

3.  The request has reached the RP for a non source specific query or
    has reached the first hop router for a source specific query (see
    Section 4.2.2, items 9 and 10 for additional details)."

Regards,
--
Hitoshi Asaeda

> 2017/08/29 11:08, [email-masked] wrote:
> 
> 
> _______________________________________________
> MBONED mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mboned