Subject: Re: [MBONED] WGLC for draft-ietf-mboned-mtrace-v2

From: Stig Venaas <[email-masked]>
Date: Wed, 2 Aug 2017 14:30:21 -0700

Hi

Is there a 2nd WGLC going on now? I don't see anything. Or are you
about to start one?

Stig

On Thu, Aug 18, 2016 at 12:33 PM, Leonard Giuliano <[email-masked]> wrote:
>
> We would like to begin working group last call for
> draft-ietf-mboned-mtrace-v2.  Please post any and all comments
> supporting/opposing the draft to the list by Sep 16.  Also, please note if
> you are aware of any IPR involved in this draft (we must heard from all
> authors about IPR).
>
> Most recent version of the draft can be found here:
>
> https://datatracker.ietf.org/doc/draft-ietf-mboned-mtrace-v2/
>
> _______________________________________________
> MBONED mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mboned

---

From: Leonard Giuliano <[email-masked]>
Date: Wed, 2 Aug 2017 15:29:30 -0700

Yes, there is:

https://www.ietf.org/mail-archive/web/mboned/current/msg02303.html

So far, we've only heard from Stig in support.  Would really like to hear 
from more folks.  Please speak up folks if you want to see this advanced.

-Lenny

On Wed, 2 Aug 2017, Stig Venaas wrote:

| Hi
| 
| Is there a 2nd WGLC going on now? I don't see anything. Or are you
| about to start one?
| 
| Stig
| 
| 
| On Thu, Aug 18, 2016 at 12:33 PM, Leonard Giuliano <[email-masked]> wrote:
| >
| > We would like to begin working group last call for
| > draft-ietf-mboned-mtrace-v2.  Please post any and all comments
| > supporting/opposing the draft to the list by Sep 16.  Also, please note if
| > you are aware of any IPR involved in this draft (we must heard from all
| > authors about IPR).
| >
| > Most recent version of the draft can be found here:
| >
| > https://datatracker.ietf.org/doc/draft-ietf-mboned-mtrace-v2/
| >
| > _______________________________________________
| > MBONED mailing list
| > [email-masked]
| > https://www.ietf.org/mailman/listinfo/mboned
|

---

From: "TARAPORE, PERCY S" <[email-masked]>
Date: Wed, 2 Aug 2017 22:30:24 +0000

I support

Percy

Sent from my iPad

> On Aug 2, 2017, at 6:29 PM, Leonard Giuliano <[email-masked]> wrote:
> 
> 
> Yes, there is:
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mail-2Darchive_web_mboned_current_msg02303.html&d=DwICAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=4Z9x1ZAReZp_mJahI6h9bQ&m=hojGaXp98AUghGH2GdaPk4ZqCydDiaVR1rBG1_3UAcs&s=-2Zfb7aabc4phX8LFZagsmFB7tqkWdoMy-Y8tag0LXM&e= 
> 
> | > https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dmboned-2Dmtrace-2Dv2_&d=DwICAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=4Z9x1ZAReZp_mJahI6h9bQ&m=hojGaXp98AUghGH2GdaPk4ZqCydDiaVR1rBG1_3UAcs&s=Kips1jLVErWgR42HCZbihw2NyXYb31KBdf_Ro5jMHXU&e= 
> | >
> | > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_mboned&d=DwICAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=4Z9x1ZAReZp_mJahI6h9bQ&m=hojGaXp98AUghGH2GdaPk4ZqCydDiaVR1rBG1_3UAcs&s=_A7nLBhn7FIXcI3OWOhJqGbBcYGNfbAwtTfLojzr5fc&e= 
> | 
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_mboned&d=DwICAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=4Z9x1ZAReZp_mJahI6h9bQ&m=hojGaXp98AUghGH2GdaPk4ZqCydDiaVR1rBG1_3UAcs&s=_A7nLBhn7FIXcI3OWOhJqGbBcYGNfbAwtTfLojzr5fc&e=

---

From: "Holland, Jake" <[email-masked]>
Date: Thu, 3 Aug 2017 03:53:03 +0000

I support this. It looks very useful.

One hopefully minor point I noticed:
I assume an AMT gateway would meet the definition of a gateway, if a request arrives at a router with an AMT gateway as the next hop RPF interface, but I don’t think there’s a path to the upstream router or an appropriate multicast address on the RPF interface, since AMT doesn’t provide a path to send non-IGMP/MLD packets upstream over the tunnel.

It doesn’t look like section 4.5 covers this scenario, or do I have it wrong?  I assume that having nowhere to send the proxied query packet, no reply will be received and it would time out, but I’m not sure how an implementation could satisfy the MUST in the final paragraph of 4.5.

Kind regards,
Jake

On 8/2/17, 3:29 PM, "Leonard Giuliano" <[email-masked]> wrote:

Yes, there is:

-Lenny

| Hi
|

---

From: Hitoshi Asaeda <[email-masked]>
Date: Thu, 3 Aug 2017 14:24:52 +0900

Hi Jake,

> It doesn’t look like section 4.5 covers this scenario, or do I have it wrong?  I assume that having nowhere to send the proxied query packet, no reply will be received and it would time out, but I’…

That’s right.

This draft has a long history and there was no discussion about AMT in the primary draft.
After we recognized AMT’s importance, I added some text for AMT support in the draft (e.g., -07, -08), but I thought it would be good to propose the “mtrace for AMT” in a separate draft after this base specification was formalized. This is because AMT itself was not standardized at that time, and furthermore, the "mtrace for AMT" specification should be carefully considered using more (additional) time.
I don’t remember at which IETF meeting I mentioned this thought, but after that, the mtrace for AMT section was deprecated.

Generally speaking, regarding “mtrace for xxx”, there may be various xxx. Such specifications can be discussed based on this base specification. If you or someone initiate to describe the specification, I’m happy to cooperate with it.

Regards,

Hitoshi

--
Hitoshi Asaeda

---

From: Leonard Giuliano <[email-masked]>
Date: Thu, 3 Aug 2017 06:57:24 -0700

On Thu, 3 Aug 2017, Hitoshi Asaeda wrote:

| Hi Jake,
| 
| > One hopefully minor point I noticed:
| > I assume an AMT gateway would meet the definition of a gateway, if a request arrives at a router with an AMT gateway as the next hop RPF interface, but I don’t think there’s a path to the upstream router or an appropriate multicast address on the RPF interface, since AMT doesn’t provide a path to send non-IGMP/MLD packets upstream over the tunnel.
| > 
| > It doesn’t look like section 4.5 covers this scenario, or do I have it wrong?  I assume that having nowhere to send the proxied query packet, no reply will be received and it would time out, but I’m not sure how an implementation could satisfy the MUST in the final paragraph of 4.5.
| 
| That’s right.
| 
| This draft has a long history and there was no discussion about AMT in 
| the primary draft. After we recognized AMT’s importance, I added some 
| text for AMT support in the draft (e.g., -07, -08), but I thought it 
| would be good to propose the “mtrace for AMT” in a separate draft after 
| this base specification was formalized. This is because AMT itself was 
| not standardized at that time, and furthermore, the "mtrace for AMT" 
| specification should be carefully considered using more (additional) 
| time. I don’t remember at which IETF meeting I mentioned this thought, 
| but after that, the mtrace for AMT section was deprecated.
| 
| Generally speaking, regarding “mtrace for xxx”, there may be various 
| xxx. Such specifications can be discussed based on this base 

Hitoshi- I think this might be useful to add explicitly to the spec, as I 
have had folks ask if this covers mvpn, for example. Maybe just a sentence 
that this is a base spec that can serve as a basis for future proopsals, 
but "mtrace for xxx" is outside the scope of this doc (where xxx is AMT, 
mvpn, other?).

| specification. If you or someone initiate to describe the specification, 
| I’m happy to cooperate with it.
| 
| Regards,
| 
| Hitoshi
| 
| 
| > 
| > 
| > On 8/2/17, 3:29 PM, "Leonard Giuliano" <[email-masked]> wrote:
| > 
| > 
| > Yes, there is:
| > 
| > https://www.ietf.org/mail-archive/web/mboned/current/msg02303.html
| > 
| > So far, we've only heard from Stig in support.  Would really like to hear 
| > from more folks.  Please speak up folks if you want to see this advanced.
| > 
| > -Lenny
| > 
| > On Wed, 2 Aug 2017, Stig Venaas wrote:
| > 
| > | Hi
| > | 
| > | Is there a 2nd WGLC going on now? I don't see anything. Or are you
| > | about to start one?
| > | 
| > | Stig
| > | 
| > | 
| > | On Thu, Aug 18, 2016 at 12:33 PM, Leonard Giuliano <[email-masked]> wrote:
| > | >
| > | > We would like to begin working group last call for
| > | > draft-ietf-mboned-mtrace-v2.  Please post any and all comments
| > | > supporting/opposing the draft to the list by Sep 16.  Also, please note if
| > | > you are aware of any IPR involved in this draft (we must heard from all
| > | > authors about IPR).
| > | >
| > | > Most recent version of the draft can be found here:
| > | >
| > | > https://datatracker.ietf.org/doc/draft-ietf-mboned-mtrace-v2/
| > | >
| > | > _______________________________________________
| > | > MBONED mailing list
| > | > [email-masked]
| > | > https://www.ietf.org/mailman/listinfo/mboned
| > | 
| > 
| > _______________________________________________
| > MBONED mailing list
| > [email-masked]
| > https://www.ietf.org/mailman/listinfo/mboned
| > 
| > 
| > _______________________________________________
| > MBONED mailing list
| > [email-masked]
| > https://www.ietf.org/mailman/listinfo/mboned
| 
| --
| Hitoshi Asaeda
| 
| 
| 
| 
| _______________________________________________
| MBONED mailing list
| [email-masked]
| https://www.ietf.org/mailman/listinfo/mboned
|

---

From: "Holland, Jake" <[email-masked]>
Date: Thu, 3 Aug 2017 15:19:44 +0000

Hi Hitoshi,

Thanks for clarifying, that makes sense.

I support the mtrace-v2 draft.

Kind regards,
Jake

On 8/2/17, 10:24 PM, "Hitoshi Asaeda" <[email-masked]> wrote:

Hi Jake,

That’s right.

Regards,

Hitoshi

--
Hitoshi Asaeda

---

From: Hitoshi Asaeda <[email-masked]>
Date: Fri, 4 Aug 2017 14:27:33 +0900

> but "mtrace for xxx" is outside the scope of this doc (where xxx is AMT, 

Sounds reasonable.
We’ll add such text in the revised draft after this WGLC.

Thanks.

Hitoshi

---

From: "Mankamana Mishra (mankamis)" <[email-masked]>
Date: Thu, 31 Aug 2017 23:33:26 +0000

Support to move forward with this draft. 

Thanks 
Mankamana 

-----Original Message-----
From: MBONED <[email-masked]> on behalf of Leonard Giuliano <[email-masked]>
Date: Wednesday, August 2, 2017 at 3:29 PM
To: Stig Venaas <[email-masked]>
Cc: MBONED WG <[email-masked]>
Subject: Re: [MBONED] WGLC for draft-ietf-mboned-mtrace-v2

    Yes, there is:

    
    -Lenny

    | Hi
    |