Subject: [media-types] Can we please bring media type registrations into the 21st century--Mac File Type codes

From: Sean Leonard <[email-masked]>
Date: Sun, 21 Sep 2014 19:43:16 -0700

While looking over the registrations, I noticed that it is required to 
provide Mac OS File Type codes.

That is all well and good, but Mac OS File Type codes are so 1993. I 
mean, literally **1993**. Mac OS X has been using Uniform Type 
Identifiers since 2001.

How do people feel about updating the registration template to include 
Apple Uniform Type Identifiers, and hopefully also to remove Mac File 
Type codes?

Thanks,

Sean

---

From: Ned Freed <[email-masked]>
Date: Sun, 21 Sep 2014 23:15:29 -0700 (PDT)

> provide Mac OS File Type codes.

That's incorrect. You can provide such a code if you want to. It is no no way, shape,
or form required.

> Apple Uniform Type Identifiers, and hopefully also to remove Mac File

Asked and answered during the discussions leading up to the revised procedures
specified in RFC 6838 about 18 months back. But feel free to make the
suggestion when RFC 6838bis are underway, say, 6 years from now.

				Ned

---

From: Paul Libbrecht <[email-masked]>
Date: Mon, 22 Sep 2014 08:52:24 +0200

Sean,

beyond what Ned has been indicating, I've been asking each submitter of a media-type that could have a clipboard flavor, sometimes only privately, to consider adding a UTI and a windows clipboard name. I have been following the experience we had in the MathML media type development doing this.  This succeeded for just a few, e.g. for SVG.

It had a fairly small success as quite many media types' authors do not feel like clipboard or drag-and-drop are "expected operations" with their content. 
It's not exactly the same thing. And indeed, as far as I know, Apple's own Finder does not user UTI (but I could be wrong).

Something more that can be done? 
(e.g. something more in the direction of the Finder, Windows or Linux file explorers?)

paul

On 22 sept. 2014, at 08:15, Ned Freed <[email-masked]> wrote:

> _______________________________________________
> media-types mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/media-types

---

From: Chris Lilley <[email-masked]>
Date: Mon, 22 Sep 2014 05:20:06 +0200

Hello Sean,

> Apple Uniform Type Identifiers, and hopefully also to remove Mac File 

Yes, absolutely.

-- 
Best regards,
 Chris                            mailto:[email-masked]