Subject: Re: [media-types] Mime type for patch files?

From: Mitar <[email-masked]>
Date: Tue, 29 Oct 2019 12:26:09 -0700

Hi!

FYI, I just submitted a media type registration request for
text/unified-diff (and after that found this thread).

Mitar

On Fri, Jul 19, 2019 at 12:15 AM Petter Reinholdtsen <[email-masked]> wrote:
>
> [Petter Reinholdtsen]
> > I do not understand the way forward from here.  Can someone who know the
> > process bring some clarity?  Who make decisions?  Who are just making
> > comments on the sideline?  What am I supposed to do now to try to get a
> > registered mime type for patches?
>
> I still do not quite understand  what to do next, but assume sending in
> the IANA form might be a good start.  I have started on a pad to draft
> the answers to the form fields on
> <URL: https://pad.sfconservancy.org/p/iana-register-mime-diff >.  Please
> help me fill in a good set of answers, and I'll try to submit the
> application by the end of the month.
>
> --
> Happy hacking
> Petter Reinholdtsen
>
> _______________________________________________
> media-types mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/media-types

-- 
http://mitar.tnode.com/
https://twitter.com/mitar_m

---

From: Petter Reinholdtsen <[email-masked]>
Date: Tue, 29 Oct 2019 21:40:31 +0100

[Mitar]
> text/unified-diff (and after that found this thread).

Aha.  Where can we see what you submitted?  I do not believe I have seen
that MIME type used for diffs anywhere.  Where is it used?

The ones I have seen are listed in
<URL: http://people.skolelinux.org/pere/blog/Time_for_an_official_MIME_type_for_patches_.html >.

-- 
Happy hacking
Petter Reinholdtsen

---

From: Mitar <[email-masked]>
Date: Tue, 29 Oct 2019 17:38:57 -0700

Hi!

On Tue, Oct 29, 2019 at 1:40 PM Petter Reinholdtsen <[email-masked]> wrote:
> Aha.  Where can we see what you submitted?

I do not think it is public. :-( Or at least I do not know how to access it.

> I do not believe I have seen

Yes, it is a brand new. Because if we want to standardize it, we
should use a standard tree. We cannot just standardize a private one
(especially because they all use obsolete x- prefix).

Now, I picked a standard tree and not vendor tree even if there is no
official standard associated with it, and I hope it will go through
and that some IETF working group will approve it. Otherwise we will
have to resubmit it as text/vnd.unified-diff which looks not as nice,
especially for something so common as unified diff.

Mitar

---

From: Julian Reschke <[email-masked]>
Date: Wed, 30 Oct 2019 07:41:25 +0100

On 30.10.2019 01:38, Mitar wrote:
> ...

Well, what exactly did you submit? If it's supposed to be in the
standards tree, it should come with a pointer to a specification...

Best regards, Julian

---

From: Petter Reinholdtsen <[email-masked]>
Date: Wed, 30 Oct 2019 09:29:51 +0100

[Mitar]
> I do not think it is public. :-( Or at least I do not know how to

Well, can you make the text you submitted public?  For example by
posting it here?  If that is impossible, what about using
<URL: https://0bin.net/ > or some other pastebin service, if you have no
better suggestion.

> (especially because they all use obsolete x- prefix).

The currently used ones are or text/x-diff (most popular) and
text/x-patch.  Would it be impossible to register the first one based on
historic usage?

-- 
Happy hacking
Petter Reinholdtsen

---

From: Mitar <[email-masked]>
Date: Wed, 30 Oct 2019 09:42:04 -0700

Hi!

In the form it says:

> Registrations in the standards tree must be approved by the IESG or must correspond to a formal publication by a recognized standards body.

So I am hopping for approval by IESG. Am I misunderstanding something?

Mitar