Subject: [media-types] Proposal to register 'haptics' as a top-level media type

From: Yeshwant Muthusamy <[email-masked]>
Date: Fri, 14 Aug 2020 18:35:01 +0000

Hi,

My name is Yeshwant Muthusamy. I lead Immersion Corporation's standardization and ecosystem activities.

Based on our recent proposals to MPEG (that have been accepted and are proceeding through the standardization process), and given the increasing commercial use of haptics in mobile devices, automobiles, gaming, and other aspects of our lives, we believe that the time is right to register 'haptics' as a top-level media type. It would only reflect the realities of the marketplace.

The attached document makes a more detailed case for 'haptics' to be treated as a top-level media type, akin to 'audio' and 'video'.

Comments/questions welcome.

Thanks,
Yeshwant

Yeshwant Muthusamy, Ph.D. | Senior Director, Standards
[email-masked]<mailto:[email-masked]> | +1 469-583-2171

---

From: Clemens Ladisch <[email-masked]>
Date: Mon, 17 Aug 2020 12:21:14 +0200

Yeshwant Muthusamy wrote:
> The attached document ...

That document contains nothing that could not have been represented in
a plain-text e-mail.

> makes a more detailed case for ‘haptics’ to be treated as a top-level
> media type

For a top-level type, you have to write a Standards Track RFC.

> [...]
> From the above arguments, it is clear that haptics does not really
> belong under any other media type. To reiterate, we see two main
> reasons why the haptics media type does not fit under the application/
> top-level type:
>
> o haptics connects to a sensory system, touch/motion, directly

This is not the reason why audio and image got their own top-level types.

>   and is more specific than the abstract application/ type,

This argument could be applied to any other application/ subtype.

> o application/ has historically been used for applications, i.e.,
>   code, which means it is viewed and treated with great care for
>   security.

Actually, most application/ subtypes are for non-executable data.
Security considerations are different for each subtype.

Anyway, I am not aware of any formal requirements for the
justification of a new top-level type.

The only other top-level type RFC I could find is for "font":
https://datatracker.ietf.org/doc/rfc8081/

So I guess you should register haptics/ together with the first
subtypes.

Regards,
Clemens