Subject: RE: [mediactrl] MediaCtrl Comments - overall summary of our comments

From: "Chris Boulton" <[email-masked]>
Date: Mon, 13 Feb 2006 10:19:30 GMT

<span style='font-size:10.0pt;font-family:
"Courier New"'>Adnan,

<span style='font-size:10.0pt;font-family:
"Courier New"'>Some thoughts and comments.

<span style='font-size:10.0pt;font-family:
"Courier New"'>Chris.

<span style='font-size:10.0pt;font-family:
"Courier New"'> 

<span style='font-size:10.0pt;font-family:
"Courier New"'>However, as noted in earlier comments posted for framework ID,
we believe that stipulating a TCP only control channel is too restrictive.
Ability to negotiate a TCP or SIP/INFO based communication interface between AS
and MS is more flexible provides framework.

<span style='font-size:10.0pt;font-family:
"Courier New"'>[cjb] OK – flexible framework for what?  The sole
purpose of this doc is to provide a ‘generic’ framework that allows
control using a reliable channel (see abstract).  In true IETF style it
does not try to solve the worlds media server problems.  ‘Yes’
– it is intended to be used for media server control BUT this could be
one of many potential usages.  I don’t feel we can just shoe horn a
secondary mechanism into the document that is intended to specify a ‘Generic
Control Channel’ mechanism. 

<span style='font-size:10.0pt;font-family:
"Courier New"'> It is understood that SIP control interface does impose
certain restrictions, such as message fragmentation and network traversals etc,

<span style='font-size:10.0pt;font-family:
"Courier New"'>[cjb] Agreed – hence the specification.

<span style='font-size:10.0pt;font-family:
"Courier New"'> however it also does provide several key advantages in
terms of SIP stack re-usability and simpler and more readily available interface,
just to name a few.

<span style='font-size:10.0pt;font-family:
"Courier New"'>[cjb] BUT one (using SIP INFO in such a manner) that historically
WILL NOT be standardized by the IETF + for all the positives there is an equal
number of negatives

<span style='font-size:10.0pt;font-family:
"Courier New"'> This is evident by the large scale current deployments,
where SIP is the choice for control interface. The framework itself should not
make this choice, rather facilitate the negotiation.

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>[cjb] Strongly disagree – as mentioned
earlier, the purpose of the framework is to provide a reliable control channel
leveraging SIP properties.  I am strongly against wavering from this
requirement.  If another mechanism is required then I personally think it
needs to be standardized in another documents – maybe at a later date.

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Chris.

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<span
style='font-size:10.0pt;font-family:Tahoma'>-----Original Message-----
From:
[email-masked]
[mailto:[email-masked]] <span style='font-weight:
bold'>On Behalf Of Adnan Saleem
Sent: 10 February
 2006<span style='font-size:10.0pt;
font-family:Tahoma'> <span
 style='font-size:10.0pt;font-family:Tahoma'>21:31<font size=2
face=Tahoma>
To:
[email-masked]
Subject: [mediactrl] MediaCtrl
Comments - overall summary of our comments

<font size=3
face="Times New Roman"> 

<font size=3
face="Times New Roman"> 

Information contained in this e-mail and any attachments are intended for the use of the addressee only, and may contain confidential information of Ubiquity Software Corporation. All unauthorized use, disclosure or distribution is strictly prohibited.  If you are not the addressee, please notify the sender immediately and destroy all copies of this email.  Unless otherwise expressly agreed in writing signed by an officer of Ubiquity Software Corporation, nothing in this communication shall be deemed to be legally binding. Thank-you

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 14 Feb 2006 17:52:13 GMT

I support this. And I would recall that Convedia agreed within MSF 
documentation that eventually the use of INFO would be replaced with the 
use of a control channel negotiuated by SIP.

Chris Boulton wrote:
Adnan,
Some thoughts and comments.
Chris.

However, as noted in earlier comments posted for framework ID, we
believe that stipulating a TCP only control channel is too restrictive.
Ability to negotiate a TCP or SIP/INFO based communication interface
between AS and MS is more flexible provides framework.
[cjb] OK - flexible framework for what?  The sole purpose of this doc is
to provide a 'generic' framework that allows control using a reliable
channel (see abstract).  In true IETF style it does not try to solve the
worlds media server problems.  'Yes' - it is intended to be used for
media server control BUT this could be one of many potential usages.  I
don't feel we can just shoe horn a secondary mechanism into the document
that is intended to specify a 'Generic Control Channel' mechanism. 

 It is understood that SIP control interface does impose certain
restrictions, such as message fragmentation and network traversals etc,
[cjb] Agreed - hence the specification.
 however it also does provide several key advantages in terms of SIP
stack re-usability and simpler and more readily available interface,
just to name a few.
[cjb] BUT one (using SIP INFO in such a manner) that historically WILL
NOT be standardized by the IETF + for all the positives there is an
equal number of negatives
 This is evident by the large scale current deployments, where SIP is
the choice for control interface. The framework itself should not make
this choice, rather facilitate the negotiation.
[cjb] Strongly disagree - as mentioned earlier, the purpose of the
framework is to provide a reliable control channel leveraging SIP
properties.  I am strongly against wavering from this requirement.  If
another mechanism is required then I personally think it needs to be
standardized in another documents - maybe at a later date.

Chris.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Adnan
Saleem
Sent: 10 February 2006 21:31
To: [email-masked]
Subject: [mediactrl] MediaCtrl Comments - overall summary of our
comments

Information contained in this e-mail and any attachments are intended for the use of the addressee only, and may contain confidential information of Ubiquity Software Corporation.  All unauthorized use, disclosure or distribution is strictly prohibited.  If you are not the addressee, please notify the sender immediately and destroy all copies of this email.  Unless otherwise expressly agreed in writing signed by an officer of Ubiquity Software Corporation, nothing in this communication shall be deemed to be legally binding.  Thank you.

--------------------------
Ubiquity Software does not control or endorse the content, messages or information found in this mail list and it specifically disclaims any liability with regard to these communications.
Ubiquity Software reserves the right the restrict access to any communications in violation of the Terms and Conditions of Use for this website or as otherwise deemed improper.