Subject: [mediactrl] MediaCtrl Comments - overall summary of our comments

From: "Adnan Saleem" <[email-masked]>
Date: Fri, 10 Feb 2006 21:23:42 GMT

<SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">Rather 
than replying to the very long threads of emails here, we thought it would be 
simpler to send one email summarizing our views on the key issues raised so 
far.  We think it's very important 
to lay out the architectural principals surrounding media servers.<SPAN 
style="mso-spacerun: yes"> Our apologies for the 
length.<SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">
<SPAN 
lang=EN-US 
style="FONT-FAMILY: 'Courier New'">draft-boulton-sip-control-framework-00<?xml:namespace 
prefix = o ns = "urn:schemas-microsoft-com:office:office" 
/>
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">
<SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">As 
noted in our recent comments email we generally support this draft and agree 
with the approach proposed to allow media control interface to be transport 
independent. 
<SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">However, 
as noted in earlier comments posted for framework ID, we believe that 
stipulating a TCP only control channel is too restrictive. Ability to negotiate 
a TCP or SIP/INFO based communication interface between AS and MS is more 
flexible provides framework. It is understood that SIP control interface does 
impose certain restrictions, such as message fragmentation and network 
traversals etc, however it also does provide several key advantages in terms of 
SIP stack re-usability and simpler and more readily available interface, just to 
name a few. This is evident by the large scale current deployments, where SIP is 
the choice for control interface. The framework itself should not make this 
choice, rather facilitate the negotiation.
<SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">draft-boulton-ivr-control-package-00
<SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">As 
noted in our recent comments email we don't support this draft's proposal, 
mainly because we think that VoiceXML is not a good general purpose media server 
control languages.  More 
below.
<SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">draft-dolly-xcon-mediacntrlframe-00<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">It was mentioned on the list that 
this document is a requirements document for media servers, but it's actually 
not so generic: it's a requirements document for media processing for 
conferencing.  
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"><SPAN 
style="mso-spacerun: yes"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"><SPAN 
style="mso-spacerun: yes"><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">We 
think it's critical that the MediaCtrl output be a generic MS control protocol 
and not tied to any particular service level application or application 
protocol, such as conferencing or XCON.  
A key tenet of a MS is that it's entirely service agnostic. The function 
of the MS is to provide all the necessary primitives and media processing 
building blocks for any service requiring media processing to be constructed by 
the AS, such as ivr or 
conferencing.
<SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">VoiceXML:<FONT 
size=2><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">We're agnostic on the "where do 
you put the VoiceXML issue": we think it's ok to put full VoiceXML (and CCXML) 
in the AS, and we think it's ok to put pure (meaning no call control) VoiceXML 
in the media server for IVR.  (CCXML 
has no place in a media server at all; more below.)<SPAN 
style="mso-spacerun: yes">  We do think that the best practical 
place for VoiceXML is usually the AS, not the MS.<SPAN 
style="mso-spacerun: yes">  But we don't think that putting pure (no 
call control) VoiceMXL into the MS violates any architectural 
principles.
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">
<SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">However, 
it's very important to understand what VoiceXML is.<SPAN 
style="mso-spacerun: yes">  VoiceXML was designed in the days when 
service platforms were one monolith box, before decomposition was recognized as 
important.  VoiceXML was designed to 
be a (mostly) single-party service creation language, not an efficient, 
powerful, and general purpose embedded media server control language.<SPAN 
style="mso-spacerun: yes">  So don't expect VoiceXML to come close 
to supporting all the media processing that a media server needs, and don't 
expect it to support efficiently what it does support. The processing 
inefficiencies are only observed when VoiceXML is forced into invoking only the 
smaller primitive level media processing tasks, while carrying the un-used and 
not-needed burden of application logic which is required by the AS.
<SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">As 
a result, we think it would be a mistake to make VoiceXML the minimum mandatory 
control protocol for media servers, because it's both too heavyweight and too 
weak from a granular media processing level:<SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">- Its media processing 
capabilities are not granular or powerful enough for many needs.
<SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">- 
Running VoiceXML in the media server requires an HTTP server with an app on top 
in addition to an AS and MS, and the AS and HTTP server need to be coupled 
somehow to share data.  This is not 
a great architecture for general purpose media serer control which requires 
granular media manipulation.<SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">- VoiceXML requires a large 
interpreter and is therefore quite burdensome from a processing 
perspective.  For example, starting 
up a VoiceXML interpreter to play a tone into a conference is definitely 
overkill.
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">This doesn't mean that pure 
VoiceXML should not be supported by media servers; it just means that it should 
not be mandatory for MSs to support it.
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">When VoiceXML is invoked in a 
media server it is through netann (RFC 4240)/burke-vxml or MSML.<SPAN 
style="mso-spacerun: yes">  So MSML can indeed invoke VoiceXML.<SPAN 
style="mso-spacerun: yes">  But we want to mention that Convedia has 
never actually implemented VoiceXML invoked by MSML (only through Netann).<SPAN 
style="mso-spacerun: yes">  Why?<SPAN 
style="mso-spacerun: yes">  Because no one wants it through MSML 
(only through Netann for relatively limited specific uses).<SPAN 
style="mso-spacerun: yes">  Given the very large number AS/CA 
partners, customers, and deployments we have, we think this says a lot, namely 
that the industry doesn't consider VoiceXML to be a general purpose control 
protocol for media servers.
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">So 
in summary, the issue for us is not "should VoiceXML be in the AS or the MS", 
rather it is "should VoiceXML be the baseline media server control language", to 
which we answer "no".
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"> 
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">VoiceXML/CCXML 
syntax:
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><FONT 
face=Arial> <SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">It's been suggested on the list 
that there could be one "package" for MSML/MOML and another "package" for 
VoiceXML, but we don't think it makes sense to create a special subset of 
VoiceXML to embed in an MS control language.<SPAN 
style="mso-spacerun: yes">  MSML/MOML already has the ability to 
invoke and control full VoiceXML, and we think this is 
enough.
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">As 
noted on the list, MSML/MOML have, wherever possible, drawn on VoiceXML and 
CCXML for some of their syntax, since we didn't want to invent a new syntax for 
no reason.  But we took only a small 
portion of the VoiceXML and CCXML syntaxes, so MSML/MOML do in no way "embed" 
VoiceXML or CCXML, and MSML/MOML don't need/use an HTTP server with 
scripting.
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"> 
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">Decomposition:
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"> <SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">It was suggested on the list 
that:
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"><SPAN 
style="mso-spacerun: yes">   "In the media server scenario, the 
VoiceXML is simply a standard way of encoding the presentation layer in an 
interaction: it carries out the media interaction ordered by the AS and 
returns its result to the AS which handles flow control and data 
management. However, if an application wishes to, they can delegate 
more complex parts of the application flow to VoiceXML."
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">This is not a good idea in our 
view as it violates the principle of application layer / media layer 
decomposition, which is fundamental to every NGN architecture, including 
IMS.  In other word, if a box 
supports both application layer and media layer functionality it's not a media 
server.
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">It was also suggested on the list 
that a media server may need to support TDM interfaces.<SPAN 
style="mso-spacerun: yes">  Again, this is not a good idea in our 
view as it violates the media media gateway / media server decomposition, which, 
too, is in every architecture.  In 
other words, if it supports TDM it's not a media server.
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">There's 
a good reason why all NGN architectures, including IMS, have a pure media server 
component, and I hope I'm preaching to the choir.
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"> <SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">
<SPAN 
lang=EN-US 
style="FONT-FAMILY: 'Courier New'">CCXML:
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">Our educated assumption, for our 
comments here, is that the future conf-control-package draft will give CCXML a 
central position in the same way that ivr-control-package gives a central 
position to VoiceXML.  

<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">In our view, CCXML has no place in 
a media server at all.  NGN 
architectures (e.g., IMS) decomposes a service platform into two layers, an app 
server and a media server.  CCXML is 
a scripting language with responsibility for call control, signalling, and 
invoking external media processing dialogs.<SPAN 
style="mso-spacerun: yes">  
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">As a result when CCXML is mapped 
to the NGN architecture, it fits cleanly into the AS component since it is a 
service creation language dealing with service logic, call control, and 
signalling, not media processing.  
And since it doesn't deal with media processing, the central task of the 
media server, the decomposition principle calls for CCXML to be located outside 
the media server, at the application layer.
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">Of 
course, when CCXML (and/or VoiceXML) executes in an app server, a SIP based 
language such as MSML/MOML is the ideal way for the AS to control the MS for 
whatever media processing is required.
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><FONT 
face=Arial> <SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">SIP vs. 
H.248:
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">H.248 and MGCP are often portrayed 
as a low level media server control protocol and SIP as a higher level media 
server control protocol.  In our 
view this is a false distinction.  
H.248, MGCP, and SIP, for media servers, have two roles: set up RTP 
streams and tell the media server what to do with those streams.<SPAN 
style="mso-spacerun: yes">  Yes, SIP tends to use XML for the latter 
while H.248 and MGCP don?t, but they are fundamentally controlling the same 
media operations, e.g., play, record, collect, mix, etc.<SPAN 
style="mso-spacerun: yes">  
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">For example, MSML/MOML's media 
control is just as "low level" as H.248's and MGCP's.<SPAN 
style="mso-spacerun: yes">  This should be no surprise because 
MSML/MOML is used for the full range of media processing tasks in the industry 
today, not just for the "high level" ones (whatever those are supposed to 
be).
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">The 
reason for SIP's popularity for media server control isn't that it's "high 
level" and H.248 is "low level": it's popular because it's SIP.<SPAN 
style="mso-spacerun: yes">  There are many architectural and 
practical reasons why SIP is, in our view, the best media server control 
language, but this has already been well debated and published 
elsewhere.
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><FONT 
face=Arial> <SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">Media servers in 
3GPP:
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">Recently in 3GPP/TISPAN the 
prevailing view has become that a SIP media server is an MRF (Mr control 
interface), while an H.248 media server is an MRFP (Mp control interface), and 
these are both valid options in IMS.  
Although the architecture diagrams show that an MRF is composed of an 
MRFC and MRFP, what's evolving is that there are really two different deployment 
options: you choose an MRFP is you want H.248 and an MRF if you want SIP.<SPAN 
style="mso-spacerun: yes">  Either way you're getting the same kind 
of media server.  In 
summary:
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"><SPAN 
style="mso-spacerun: yes">   SIP<SPAN 
style="mso-spacerun: yes">   MS = MRF<SPAN 
style="mso-spacerun: yes">   - control interface is 
Mr
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"><SPAN 
style="mso-spacerun: yes">   H.248 MS = MRFP<SPAN 
style="mso-spacerun: yes">  - control interface is 
Mp
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">It 
was suggested on the list that SIP+MSML/MOML could be assigned to the Mp 
interface.  Convedia did try to 
argue this position to 3GPP over a long period of time but we constantly ran 
into the "we don't want to change any past IMS architectural decisions" 
argument.  We finally gave up and 
accepted that the best, and only, way to map a SIP media server to IMS is to map 
it to the MRF, and this is indeed the view that we've seen emerge and be 
accepted 
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><FONT 
face=Arial> 
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">There 
is a spec nearing completion for the Mp (H.248) interface 
(http://www.3gpp.org/ftp/Specs/html-info/29333.htm) but not yet for the Mr (SIP) 
interface.  There is, however, a CT1 
Work Item proposal from HP for Mr Stage 3 (protocols) specification work that 
will be discussed at the 3GPP CT1#41 meeting next week in Denver.<SPAN 
style="mso-spacerun: yes">  You can get the proposal 
here:<SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"><SPAN 
style="mso-spacerun: yes">   <A 
href="ftp://ftp.3gpp.org/tsg_ct/WG1_mm-cc-sm_ex-CN1/TSGC1_41/Docs/C1-060273.zip">ftp://ftp.3gpp.org/tsg_ct/WG1_mm-cc-sm_ex-CN1/TSGC1_41/Docs/C1-060273.zip
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">In 
our view this WI proposal is improperly biased toward VoiceXML and CCXML, rather 
than leaving the choice of protocol open for selection as part of the work 
item.  Our concern is that if this 
WI proposal is approved, it could serve to shut down the current debate in 
MediaCtrl on the grounds that "3GPP has decided".<SPAN 
style="mso-spacerun: yes">  MediaCtrl members that are also in 3GPP 
may wish to voice their views next week in Denver.
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"> <SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">Reinventing the 
wheel:
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">Finally, we want to reiterate that 
MSML/MSML already supports all the media processing required of almost any SIP 
media server (and MSCML already supports the needs of many media servers) so we 
wonder why there is a need to invent yet another media processing control 
language (YAMPCL), especially when it doesn't seem to add any 
value.
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">OTHER MISCELLANEOUS 
POINTS:
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">AS-MS 
association:
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">We agree that the AS-MS 
association should be static for now, which reflects how most SPs want to deploy 
MSs.  In the future it will 
doubtless become more dynamic and a discovery and capabilities mechanism would 
be required.
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">The 
issue of how many TCP connections there are between AS and MS was raised on the 
list.  MSML/MOML allows a lot 
flexibility, e.g., one or more per MS, one per conference, one per session, 
etc.  This was done because 
different ASs have different ideas of what they want.
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><FONT 
face=Arial> <SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">
<SPAN 
lang=EN-US 
style="FONT-FAMILY: 'Courier New'">Charging:
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">We don't think a MS should 
generate charging records (CDRs).  
In our view the better model is for the MS to return usage information to 
the AS at the end of the RTP session, and for the AS to then use the information 
as it sees fit (e.g., include it in the charging record it 
generates).
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'">Speech 
servers:
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">We're 
agnostic on the "how do you control speech servers" issue: we think it's ok for 
the AS to control the speech servers directly (using MRCP), and we think it's ok 
for the AS to let the media servers control (and load balance, etc.) the speech 
servers (using MRCP).  (MSML/MOML 
has a set of elements allowing it to support full ASR/TTS.)<SPAN 
style="mso-spacerun: yes">  We think both are architecturally sound 
and that the choice is simply an implementation decision.
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"> 
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">Thanks
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"> 
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA">Garland/Adnan

---

From: "McGlashan, Scott" <[email-masked]>
Date: Sat, 11 Feb 2006 19:15:33 GMT

<SPAN 
class=333252717-11022006>Hi Adnan,
<SPAN 
class=333252717-11022006> 
<SPAN 
class=333252717-11022006>Good to see a clarification of Convedia's position on 
everything related to media processing. 
<SPAN 
class=333252717-11022006> 
<SPAN 
class=333252717-11022006>We'll respond to your original comments on 
the ivr-control package next week, but in the meantime some initial 
comments:
<SPAN 
class=333252717-11022006> 
<SPAN 
class=333252717-11022006>[1]  <FONT 
face="Courier New">MSML
<SPAN 
class=333252717-11022006> 
<SPAN 
class=333252717-11022006>Can you clarify the status of 
MSML? It has been withdrawn by the IETF and is no longer an active 
internet-draft. 
<SPAN 
class=333252717-11022006> 
<SPAN 
class=333252717-11022006>[2] <SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-FAMILY: 'Courier New'">Media servers in 
3GPP:
<SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-FAMILY: 'Courier New'"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006>The 3GPP work item 

<SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-FAMILY: 'Courier New'"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 

<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"><SPAN 
style="mso-spacerun: yes">   <A 
href="ftp://ftp.3gpp.org/tsg_ct/WG1_mm-cc-sm_ex-CN1/TSGC1_41/Docs/C1-060273.zip">ftp://ftp.3gpp.org/tsg_ct/WG1_mm-cc-sm_ex-CN1/TSGC1_41/Docs/C1-060273.zip
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"><FONT 
face=Arial> 
<SPAN 
lang=EN-US style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006>is being promoted by a number of companies not 
just HP. The key request is to initiate work on the definition 
of Mr protocol, including transport channel issues, package requirements, 
TISPAN alignment and, if appropriate, to provide 3GPP requirements on the 
protocol to IETF - hopefully thereby supporting the informal 
MediaCtrl Group in securing more formal status within the IETF. The 
work item does reference (and promote) VoiceXML as potentially relevant 
existing IVR standard, but it also references M* proposals (MSCP, 
MSCML, MSML) as well as netann, burke-vxml, etc. So, far from shutting 
down the debate in MediaCtrl, its intention is to stimulate debate and 
identify how this group's work could be (the basis for) the Mr 
protocol. I agree that 3GPP members should voice their views next week in 
Denver. 
<SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><FONT 
face=Arial size=2><SPAN lang=EN-US 
style="FONT-FAMILY: 'Courier New'"> 
<SPAN 
class=333252717-11022006> 
<SPAN 
class=333252717-11022006>[3]  <SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><FONT 
color=#000000>draft-dolly-xcon-mediacntrlframe-00
<SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"> 
<SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006>If you are dissatisfied with 
the requirements, you have always 
had the opportunity to add requirements for discussion (Convedia 
representatives were present at the Vancouver meeting when they were 
discussed). I agree that we may need to address more requirements than 
xcon conferencing, and look forward to seeing your specific 
requirements.
<SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006> 
<SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006> 
<SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006>[4] <SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><FONT 
color=#000000>VoiceXML:
<SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"> 
<SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006>It is good to see that you recognize VoiceXML could be 
part of an MS. Whether it is mandatory for a basic ivr package is, I agree, 
something we may need to revisit. This doesn't mean we need a low-level media 
processing language, just something more lightweight which 
fits application 
developer needs <FONT 
face=Arial color=#0000ff size=2><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006>(more on that next week). 

<SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006> 
<SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006>I didn't realize you were involved in the design of 
VoiceXML :-) 

<SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006> 
<SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006>VoiceXML platform do follow a decomposition 
model (it is inherent in VoiceXML's design - separation of service 
definition from execution environment) and, as Mark pointed out, most 
implementations already use protocols towards media processors (e.g. MRCP for 
speech processors). 

<SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006> 
<SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006>The value of VoiceXML is that it is an 
existing international standard for IVR media servers, with extensive and 
large-scale deployments (e.g. single sites with 10000+ ports), a 
conformance program and service creation tool support. 
<FONT 
face=Arial color=#0000ff size=2><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006>Judging by existing AS applications and their 
media control requirements -- playing prompts, collecting dtmf, making 
recordings on connections and conferences, etc - it is fit for purpose. 
Maybe we need more input from AS vendors and application developers on their 
requirements for a media server language? 

<SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006> 
<SPAN 
class=333252717-11022006><SPAN lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
lang=EN-US 
style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN 
class=333252717-11022006>The HTTP interface is a red herring. If any media 
server allows audio prompts to be referenced by an HTTP URI, then an outbound 
HTTP interface is required. Even H.248.9 allows this. 

<FONT face="Courier New" color=#0000ff 
size=2>thanks
<FONT face="Courier New" color=#0000ff 
size=2> 
<FONT face="Courier New" color=#0000ff 
size=2>Scott

From: [email-masked] 
[mailto:[email-masked]] On Behalf Of Adnan 
SaleemSent: Friday, February 10, 2006 22:31To: 
[email-masked]: [mediactrl] MediaCtrl 
Comments - overall summary of our comments

<SPAN lang=EN-US 
style="FONT-FAMILY: 'Courier New'">draft-boulton-sip-control-framework-00

<SPAN 
while H.248 and MGCP don’t, but they are fundamentally controlling the same