Subject: [mediactrl] RE: Some comments to draft-even-media-server-req-01.txt

From: "Even, Roni" <[email-masked]>
Date: Tue, 13 Jun 2006 22:07:50 +0100

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Sasha,

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>This is an old document that I just
resubmitted. It was posted before any of the other documents and that is the
reason for the old references. The requirement will be in Martin's document so
this document will expire. Please read the other documents including the
requirements in draft-dolly-xcon-mediacntrlframe-01.txt and comment.

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Roni

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<font size=3
face="Times New Roman">

<span style='font-size:10.0pt;
font-family:Tahoma;font-weight:bold'>From:<font size=2
face=Tahoma> Sasha Ruditsky
[mailto:[email-masked]] 
Sent: Tuesday, June 13, 2006 8:39
PM
To: Even, Roni
Cc: Mediactrl
Subject: Some comments to draft-even-media-server-req-01.txt

<span style='font-size:
12.0pt'> 

<span style='font-size:10.0pt;
font-family:Arial'>Hi Roni,

<span style='font-size:
12.0pt'> 

<span style='font-size:10.0pt;
font-family:Arial'>I have several comments/questions to your requirements
document (draft-even-media-server-req-01.txt):

<span style='font-size:
12.0pt'> 

<span style='font-size:10.0pt;
font-family:Arial'>1) In the "current protocol" section references do
not seem to be up-to date.

<span style='font-size:10.0pt;
font-family:Arial'>   According to my knowledge:

<span style='font-size:10.0pt;
font-family:Arial'>   a) MSCML is draft-vandyke-mscml-08

<span style='font-size:10.0pt;
font-family:Arial'>   b) MSML is draft-saleem-msml-00.txt

<span style='font-size:10.0pt;
font-family:Arial'>   c) MOML is draft-melanchuk-sipping-moml-06

<span style='font-size:10.0pt;
font-family:Arial'>   d) NETAN is RFC 4240
   e) CCCP is draft-levin-xcon-cccp-04

<span style='font-size:10.0pt;
font-family:Arial'>   f) ITU H.248.19 is ITU H.248.19 Am1

<span style='font-size:10.0pt;
font-family:Arial'>   

<span style='font-size:10.0pt;
font-family:Arial'>    And BTW: Why draft-boulton-sip-control-framework-02
is not on this list?

<span style='font-size:
12.0pt'> 

<span style='font-size:10.0pt;
font-family:Arial'>2) General requirement 9 says: "The AS shall be
able to request the MS to create, delete, and
   manipulate a mixing, IVR or announcement session." For this
means that only these three kinds of sessions are supported.

<span style='font-size:10.0pt;
font-family:Arial'>   If this is the case then I think it contradicts
the General requirement 6 which says: "The protocol should be
extendable."

<span style='font-size:10.0pt;
font-family:Arial'>    <span
style='font-family:Arial'>
<span style='font-size:10.0pt;font-family:
Arial'>3) Does the requirement "The AS may be able to define a custom
video layout built of
   rectangular sub windows." allow overlapped windows (PIP
style)?

<span style='font-size:
12.0pt'> 

<span style='font-size:10.0pt;
font-family:Arial'>4) Why in "The AS shall be able to tell the MS if the
message can be delayed
   if the MS cannot play it immediately." it says
"message" and not "announcement"? 

<span style='font-size:
12.0pt'> 

<span style='font-size:10.0pt;
font-family:Arial'>5) In "The AS shall be able to mange the IVR session by
sending
   announcements and receiving the response (DTMF)"
"mange" should be "manage".

<font size=3
face="Times New Roman"> 

<span style='font-size:
12.0pt'>
<span style='font-size:10.0pt;font-family:
Arial'>Thanks,

<span style='font-size:10.0pt;
font-family:Arial'>Sasha

---

From: "Sasha Ruditsky" <[email-masked]>
Date: Tue, 13 Jun 2006 22:17:50 +0100

Hi 
Roni,
<FONT face=Arial color=#0000ff 
size=2> 
I 
see.
<FONT face=Arial color=#0000ff 
size=2> 
<FONT face=Arial color=#0000ff 
size=2>Thanks,
<FONT face=Arial color=#0000ff 
size=2>Sasha

From: Even, Roni 
[mailto:[email-masked]] Sent: Tuesday, June 13, 2006 5:10 
PMTo: Sasha RuditskyCc: MediactrlSubject: RE: 
Some comments to draft-even-media-server-req-01.txt

<SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">Sasha,
<SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">This is an old document 
that I just resubmitted. It was posted before any of the other documents and 
that is the reason for the old references. The requirement will be in Martin's 
document so this document will expire. Please read the other documents including 
the requirements in draft-dolly-xcon-mediacntrlframe-01.txt and 
comment.
<SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">Roni
<SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
<DIV 
style="BORDER-RIGHT: medium none; PADDING-RIGHT: 0cm; BORDER-TOP: medium none; PADDING-LEFT: 4pt; PADDING-BOTTOM: 0cm; BORDER-LEFT: blue 1.5pt solid; PADDING-TOP: 0cm; BORDER-BOTTOM: medium none">

<FONT 
face="Times New Roman" size=3>

<SPAN 
style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; FONT-FAMILY: Tahoma">From:<FONT 
face=Tahoma size=2> Sasha 
Ruditsky [mailto:[email-masked]] <SPAN 
style="FONT-WEIGHT: bold">Sent: Tuesday, June 13, 2006 8:39 
PMTo: Even, Roni<SPAN 
style="FONT-WEIGHT: bold">Cc: Mediactrl<SPAN 
style="FONT-WEIGHT: bold">Subject: Some comments to 
draft-even-media-server-req-01.txt
<SPAN 
style="FONT-SIZE: 12pt"> 

<SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">Hi 
Roni,

<SPAN 
style="FONT-SIZE: 12pt"> 

<SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">I have several comments/questions to 
your requirements document 
(draft-even-media-server-req-01.txt):

<SPAN 
style="FONT-SIZE: 12pt"> 

<SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">1) In the "current protocol" section 
references do not seem to be up-to date.

<SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">   According to my 
knowledge:

<SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">   a) MSCML is 
draft-vandyke-mscml-08

<SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">   b) MSML is 
draft-saleem-msml-00.txt

<SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">   c) MOML is 
draft-melanchuk-sipping-moml-06

<SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">   d) NETAN is RFC 
4240   e) CCCP is 
draft-levin-xcon-cccp-04

<SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">   f) ITU H.248.19 is 
ITU H.248.19 Am1

<SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">   

<SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">    And BTW: Why 
draft-boulton-sip-control-framework-02 is not on this 
list?

<SPAN 
style="FONT-SIZE: 12pt"> 

<SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">2) General requirement 9 says: 
"The AS shall be able to request the MS to create, delete, and   
manipulate a mixing, IVR or announcement session." For this means that only 
these three kinds of sessions are supported.

<SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">   If this is the case 
then I think it contradicts the General requirement 6 which says: "The protocol 
should be extendable."

<SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">    
<SPAN 
style="FONT-FAMILY: Arial"><SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">3) Does the requirement "The AS 
may be able to define a custom video layout built of   rectangular 
sub windows." allow overlapped windows (PIP 
style)?

<SPAN 
style="FONT-SIZE: 12pt"> 

<SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">4) Why in "The AS shall be able to 
tell the MS if the message can be delayed   if the MS cannot play 
it immediately." it says "message" and not "announcement"? 

<SPAN 
style="FONT-SIZE: 12pt"> 

<SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">5) In "The AS shall be able to mange 
the IVR session by sending   announcements and receiving the 
response (DTMF)" "mange" should be "manage".

<FONT face="Times New Roman" 
size=3> 

<SPAN 
style="FONT-SIZE: 12pt"><SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">Thanks,

<SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">Sasha