Subject: RE: [mediactrl] New version of Control Framework - draft-boulton-sip-control-framework-02

From: "Even, Roni" <[email-masked]>
Date: Wed, 7 Jun 2006 14:07:47 +0100

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Chris,

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>My claims are as follows:

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

 <font size=2
     color=navy face=Arial>The
     connection between the AS and MS can be made before any use of the MS, in
     this mode there will be one connection between the AS and MS for all
     control sessions.
 <font size=2
     color=navy face=Arial>The
     connection between the AS and MS can be established for each control
     session. (IVR session, Conference). Personally I prefer one connection. Both
     modes should be supported if possible.
 <font size=2
     color=navy face=Arial>A
     control message between the AS and MS MUST be exchanged before the SIP
     call leg can be established. If you think different please explain the
     flow that will create a conference when the first participant calls. I
     assume one control connection per a conference and not for each
     participant. I know that this is part of the difference between the
     different MxMLs but I thought we agreed that we will use the model of one
     control connection per conference.

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>This text is from the <st1:place
 w:st="on">Paris meeting summary

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<span style='font-size:
12.0pt'>Some agreements:

<span style='font-size:
12.0pt'>The RTP goes from the edges.

<span style='font-size:
12.0pt'>There will be a Control channel from AS to MS.  This is a conference
level channel. There was a concern about the number of connections between AS
to MS (BTW: my comment here is that if we have a conference identifier in the
protocol we may look at having one connection from AS to each MS and multiplex
control for all conferences based on conference identifier)

<span style='font-size:
12.0pt'>On the control channel we need commands to the MS and indication to the
AS.

<span style='font-size:
12.0pt'>Need to deal with simple IVR non vxml systems and video.

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'>The solution will allow but not mandate a proxy between the AS and MS
to direct to the right MS and to handle resources it may contradict the
proposed requirements.

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Roni 

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<font size=3
face="Times New Roman">

<span style='font-size:10.0pt;
font-family:Tahoma;font-weight:bold'>From:<font size=2
face=Tahoma> Chris Boulton
[mailto:[email-masked]] 
Sent: Wednesday, June 07, 2006
3:52 PM
To: Even, Roni; [email-masked];
[email-masked]
Subject: RE: [mediactrl] New
version of Control Framework - draft-boulton-sip-control-framework-02

<span style='font-size:
12.0pt'> 

<font size=2 color=navy
face=Arial> 

<font
size=2 color=blue face=Arial><span style='font-size:11.0pt;font-family:Arial;
color:blue'>   A) *Must* the control channel be established before a
call leg is brought to the Media Server? The Control Framework for SIP draft
seems to only talk about setting up the control channel before a call leg is
brought to the MS. It might be useful to allow for both, don’t know
whether it’s problematic. Either way, it should be clarified.

<font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy;font-weight:bold;font-style:italic'> 

<font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy;font-weight:bold;font-style:italic'>[Chris Boulton] I don’t
see why you MUST have a control channel established.  It would just mean
that you can’t issue any commands on that media stream.  Does that
seem ok to everyone? At the end of the day we are talking about two mechanisms
that are not dependant on each other.   I will clarify the text in
the next revision if no-one opposes.

<font size=2 color=navy
face=Arial>[Roni
Even] My view is that you need to have the control channel established first.
There is a relationship between the control and the call leg. One example is
that the MS may need to convey a conference identifier to be used for
establishing the call leg. In the IVR case you can start with establishing the
call leg and use the dialog identifier to correlate with the control session.
My view is that it will be better to establish the TCP control channel
connection at startup and use it for all sessions. 

<font size=2 color=navy
face=Arial> 

<font size=2 color=red
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:red;
font-weight:bold;font-style:italic'>[Chris Boulton] OK – but should this
be in the framework?  Remember that the Framework is not supposed to be
media server specific.  Perhaps specific detail like this belongs in the
individual usages of the framework (Packages)  e.g. the IVR package states
that a connection should be initiated – as per ……..

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'>[RE:] Chris – this is not media
server specific but it defines the flow. The correlation between the Control
and SIP call leg is needed. If you establish the SIP call leg first, you can
use the dialog identifier. If you start with Control first then there is no SIP
dialog for the call leg first. This is not package specific but general
mechanism. I was also stating that for conference you need to have a URI for
the SIP call leg, so maybe the model will be to create the control session
start the specific package and then connect the call leg.

<font size=2 color=navy
face=Arial> 

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] Roni – I think we talking on different
issues.  From what I read in your latest comment I totally agree and that
is how the draft is written today.  There is a definite correlation
between the state of the SIP dialog and the connection pipe.  The
connection pipe can not exist without the SIP dialog.  If the SIP dialog
is created/terminated – the control channel is created/terminated. 
I was just commenting on the fact that the control framework does not mandate when
the connection is made for a conference – it will more than likely be
made before the first participant SIP dialog is connected BUT maybe after
– but that isn’t mandated.

<font size=3
face="Times New Roman"> 

<span style='font-size:
12.0pt'>

<span
style='font-size:7.5pt;font-family:Verdana'>Information contained in this
e-mail and any attachments are intended for the use of the addressee only, and
may contain confidential information of Ubiquity Software Corporation. All
unauthorized use, disclosure or distribution is strictly prohibited.  If
you are not the addressee, please notify the sender immediately and destroy all
copies of this email.  Unless otherwise expressly agreed in writing signed
by an officer of Ubiquity Software Corporation, nothing in this communication
shall be deemed to be legally binding. Thank-you

---

From: "Adnan Saleem" <[email-masked]>
Date: Wed, 7 Jun 2006 17:29:35 +0100

Hi 
Roni,
<FONT face=Arial color=#0000ff 
size=2> 
I 
think that the coupling of "one control connection per conference" is 
too restrictive an unnecessary. 
I view 
the control connection at the transport layer and the conference at the 
application layer. By not
<FONT face=Arial color=#0000ff 
size=2>mandating a control connection per conference, I think we will leave the 
flexibility to the user of the
<FONT face=Arial color=#0000ff 
size=2>interface, where one could use a one-to-one model OR one-to-many. Please 
help me understand if I've
<FONT face=Arial color=#0000ff 
size=2>misunderstood this issue.
<FONT face=Arial color=#0000ff 
size=2> 
Also, 
as pointed out in earlier threads, by not coupling the control connection to the 
application
<FONT face=Arial color=#0000ff 
size=2>resources/services, the control connection does not require to be long 
lived.
<FONT face=Arial color=#0000ff 
size=2> 
<FONT face=Arial color=#0000ff 
size=2>thanks
<FONT face=Arial color=#0000ff 
size=2>Adnan

  <FONT face=Tahoma 
  size=2>-----Original Message-----From: 
  [email-masked] 
  [mailto:[email-masked]]On Behalf Of Even, 
  RoniSent: June 7, 2006 6:10 AMTo: Chris Boulton; 
  [email-masked]; [email-masked]: RE: 
  [mediactrl] New version of Control Framework - 
  draft-boulton-sip-control-framework-02
  
  <SPAN 
  style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">Chris,
  <SPAN 
  style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">My claims are as 
  follows:
  <SPAN 
  style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
  
    <FONT 
    face=Arial color=navy size=2><SPAN 
    style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">The connection between the AS 
    and MS can be made before any use of the MS, in this mode there will be one 
    connection between the AS and MS for all control 
    sessions. 
    <FONT 
    face=Arial color=navy size=2><SPAN 
    style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">The connection between the AS 
    and MS can be established for each control session. (IVR session, 
    Conference). Personally I prefer one connection. Both modes should be 
    supported if possible. 
    <FONT 
    face=Arial color=navy size=2><SPAN 
    style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">A control message between the AS 
    and MS MUST be exchanged before the SIP call leg can be established. If you 
    think different please explain the flow that will create a conference when 
    the first participant calls. I assume one control connection per a 
    conference and not for each participant. I know that this is part of the 
    difference between the different MxMLs but I thought we agreed that we will 
    use the model of one control connection per 
    conference. 
  <SPAN 
  style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
  <SPAN 
  style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">This text is from the 
  Paris meeting 
  summary
  <SPAN 
  style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
  <SPAN 
  style="FONT-SIZE: 12pt">Some agreements:
  <SPAN 
  style="FONT-SIZE: 12pt">The RTP goes from the 
  edges.
  <SPAN 
  style="FONT-SIZE: 12pt">There will be a Control channel from AS to MS. 
   This is a conference level channel. There was a concern about the number 
  of connections between AS to MS (BTW: my comment here is that if we have a 
  conference identifier in the protocol we may look at having one connection 
  from AS to each MS and multiplex control for all conferences based on 
  conference identifier)
  <SPAN 
  style="FONT-SIZE: 12pt">On the control channel we need commands to the MS and 
  indication to the AS.
  <SPAN 
  style="FONT-SIZE: 12pt">Need to deal with simple IVR non vxml systems and 
  video.
  <SPAN 
  style="FONT-SIZE: 12pt"> 
  <SPAN 
  style="FONT-SIZE: 12pt">The solution will allow but not mandate a proxy 
  between the AS and MS to direct to the right MS and to handle resources it may 
  contradict the proposed requirements.
  <SPAN 
  style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
  <SPAN 
  style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
  <SPAN 
  style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">Roni 
  
  <SPAN 
  style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
  <DIV 
  style="BORDER-RIGHT: medium none; PADDING-RIGHT: 0cm; BORDER-TOP: medium none; PADDING-LEFT: 4pt; PADDING-BOTTOM: 0cm; BORDER-LEFT: blue 1.5pt solid; PADDING-TOP: 0cm; BORDER-BOTTOM: medium none">
  
  <FONT 
  face="Times New Roman" size=3>

  <SPAN 
  style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; FONT-FAMILY: Tahoma">From:<FONT 
  face=Tahoma size=2> Chris 
  Boulton [mailto:[email-masked]] <SPAN 
  style="FONT-WEIGHT: bold">Sent: Wednesday, June 07, 2006 3:52 
  PMTo: Even, Roni; 
  [email-masked]; [email-masked]<SPAN 
  style="FONT-WEIGHT: bold">Subject: RE: [mediactrl] New version of 
  Control Framework - 
  draft-boulton-sip-control-framework-02
  <SPAN 
  style="FONT-SIZE: 12pt"> 
  <DIV 
  style="BORDER-RIGHT: medium none; PADDING-RIGHT: 0cm; BORDER-TOP: medium none; PADDING-LEFT: 4pt; PADDING-BOTTOM: 0cm; BORDER-LEFT: blue 1.5pt solid; PADDING-TOP: 0cm; BORDER-BOTTOM: medium none">
  <FONT face=Arial color=navy 
  size=2><SPAN 
  style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
  <FONT face=Arial color=blue 
  size=2><SPAN 
  style="FONT-SIZE: 11pt; COLOR: blue; FONT-FAMILY: Arial">   A) 
  *Must* the control channel be established before a call leg is brought to the 
  Media Server? The Control Framework for SIP draft seems to only talk about 
  setting up the control channel before a call leg is brought to the MS. It 
  might be useful to allow for both, don’t know whether it’s problematic. Either 
  way, it should be clarified.
  <FONT face=Arial color=navy 
  size=2><SPAN 
  style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial"> 
  <FONT face=Arial color=navy 
  size=2><SPAN 
  style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial">[Chris 
  Boulton] I don’t see why you MUST have a control channel established.  It 
  would just mean that you can’t issue any commands on that media stream. 
   Does that seem ok to everyone? At the end of the day we are talking 
  about two mechanisms that are not dependant on each other.   I will 
  clarify the text in the next revision if no-one 
  opposes.
  <FONT face=Arial color=navy 
  size=2>[Roni 
  Even] My view is that you need to have the control channel established first. 
  There is a relationship between the control and the call leg. One example is 
  that the MS may need to convey a conference identifier to be used for 
  establishing the call leg. In the IVR case you can start with establishing the 
  call leg and use the dialog identifier to correlate with the control session. 
  My view is that it will be better to establish the TCP control channel 
  connection at startup and use it for all sessions. 
  
  <FONT face=Arial color=navy 
  size=2><SPAN 
  style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
  <FONT face=Arial color=red 
  size=2><SPAN 
  style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: red; FONT-STYLE: italic; FONT-FAMILY: Arial">[Chris 
  Boulton] OK – but should this be in the framework?  Remember that the 
  Framework is not supposed to be media server specific.  Perhaps specific 
  detail like this belongs in the individual usages of the framework (Packages) 
   e.g. the IVR package states that a connection should be initiated – as 
  per ……..
  <FONT face=Arial color=navy 
  size=2><SPAN 
  style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial">[RE:] 
  Chris – this is not media server specific but it defines the flow. The 
  correlation between the Control and SIP call leg is needed. If you establish 
  the SIP call leg first, you can use the dialog identifier. If you start with 
  Control first then there is no SIP dialog for the call leg first. This is not 
  package specific but general mechanism. I was also stating that for conference 
  you need to have a URI for the SIP call leg, so maybe the model will be to 
  create the control session start the specific package and then connect the 
  call leg.
  <FONT face=Arial color=navy 
  size=2><SPAN 
  style="FONT-SIZE: 11pt; COLOR: navy; FONT-FAMILY: Arial"> 
  <SPAN 
  style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial">[Chris 
  Boulton] Roni – I think we talking on different issues.  >From what I read 
  in your latest comment I totally agree and that is how the draft is written 
  today.  There is a definite correlation between the state of the SIP 
  dialog and the connection pipe.  The connection pipe can not exist 
  without the SIP dialog.  If the SIP dialog is created/terminated – the 
  control channel is created/terminated.  I was just commenting on the fact 
  that the control framework does not mandate when the connection is made for a 
  conference – it will more than likely be made before the first participant SIP 
  dialog is connected BUT maybe after – but that isn’t 
  mandated.
  <FONT face="Times New Roman" 
  size=3> 
  <SPAN 
  style="FONT-SIZE: 12pt"><FONT face=Verdana size=1 
  colour="#cccccc"><SPAN 
  style="FONT-SIZE: 7.5pt; FONT-FAMILY: Verdana">Information contained in this 
  e-mail and any attachments are intended for the use of the addressee only, and 
  may contain confidential information of Ubiquity Software Corporation. All 
  unauthorized use, disclosure or distribution is strictly prohibited.  If 
  you are not the addressee, please notify the sender immediately and destroy 
  all copies of this email.  Unless otherwise expressly agreed in writing 
  signed by an officer of Ubiquity Software Corporation, nothing in this 
  communication shall be deemed to be legally binding. Thank-you

---

From: "Adnan Saleem" <[email-masked]>
Date: Thu, 8 Jun 2006 07:14:15 +0100

<SPAN 
class=222491306-08062006>re-sending, as I think earlier email didn't come out on 
mediactrl list.
<SPAN 
class=222491306-08062006> 
<SPAN 
class=222491306-08062006>Adnan

  <FONT face=Tahoma 
  size=2>-----Original Message-----From: 
  [email-masked] 
  [mailto:[email-masked]]On Behalf Of Adnan 
  SaleemSent: June 7, 2006 9:31 AMTo: Even, Roni; Chris 
  Boulton; [email-masked]; 
  [email-masked]: RE: [mediactrl] New 
  version of Control Framework - 
  draft-boulton-sip-control-framework-02
  Hi 
  Roni,
  <FONT face=Arial color=#0000ff 
  size=2> 
  I 
  think that the coupling of "one control connection per conference" is 
  too restrictive an unnecessary. 
  I 
  view the control connection at the transport layer and the conference at the 
  application layer. By not
  <FONT face=Arial color=#0000ff 
  size=2>mandating a control connection per conference, I think we will leave 
  the flexibility to the user of the
  <FONT face=Arial color=#0000ff 
  size=2>interface, where one could use a one-to-one model OR one-to-many. 
  Please help me understand if I've
  <FONT face=Arial color=#0000ff 
  size=2>misunderstood this issue.
  <FONT face=Arial color=#0000ff 
  size=2> 
  <FONT face=Arial color=#0000ff 
  size=2>Also, as pointed out in earlier threads, by not coupling the control 
  connection to the application
  <FONT face=Arial color=#0000ff 
  size=2>resources/services, the control connection does not require to be long 
  lived.
  <FONT face=Arial color=#0000ff 
  size=2> 
  <FONT face=Arial color=#0000ff 
  size=2>thanks
  <FONT face=Arial color=#0000ff 
  size=2>Adnan
  
    <FONT face=Tahoma 
    size=2>-----Original Message-----From: 
    [email-masked] 
    [mailto:[email-masked]]On Behalf Of Even, 
    RoniSent: June 7, 2006 6:10 AMTo: Chris Boulton; 
    [email-masked]; [email-masked]: 
    RE: [mediactrl] New version of Control Framework - 
    draft-boulton-sip-control-framework-02
    
    <SPAN 
    
      <FONT 
      face=Arial color=navy size=2><SPAN 
      style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">The connection between the AS 
      and MS can be made before any use of the MS, in this mode there will be 
      one connection between the AS and MS for all control 
      sessions. 
      <FONT 
      face=Arial color=navy size=2><SPAN 
      style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">The connection between the AS 
      and MS can be established for each control session. (IVR session, 
      Conference). Personally I prefer one connection. Both modes should be 
      supported if possible. 
      <FONT 
      face=Arial color=navy size=2><SPAN 
      style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">A control message between the 
      AS and MS MUST be exchanged before the SIP call leg can be established. If 
      you think different please explain the flow that will create a conference 
      when the first participant calls. I assume one control connection per a 
      conference and not for each participant. I know that this is part of the 
      difference between the different MxMLs but I thought we agreed that we 
      will use the model of one control connection per 
      conference. 
    <SPAN 
    style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
    <SPAN 
    style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">This text is from 
    the Paris 
    meeting summary
    <SPAN 
    style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
    <SPAN 
    style="FONT-SIZE: 12pt">Some agreements:
    <SPAN 
    style="FONT-SIZE: 12pt">The RTP goes from the 
    edges.
    <SPAN 
    style="FONT-SIZE: 12pt">There will be a Control channel from AS to MS. 
     This is a conference level channel. There was a concern about the 
    number of connections between AS to MS (BTW: my comment here is that if we 
    have a conference identifier in the protocol we may look at having one 
    connection from AS to each MS and multiplex control for all conferences 
    based on conference identifier)
    <SPAN 
    style="FONT-SIZE: 12pt">On the control channel we need commands to the MS 
    and indication to the AS.
    <SPAN 
    style="FONT-SIZE: 12pt">Need to deal with simple IVR non vxml systems and 
    video.
    <SPAN 
    style="FONT-SIZE: 12pt"> 
    <SPAN 
    style="FONT-SIZE: 12pt">The solution will allow but not mandate a proxy 
    between the AS and MS to direct to the right MS and to handle resources it 
    may contradict the proposed requirements.
    <SPAN 
    style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
    <SPAN 
    style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
    <SPAN 
    style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">Roni 
    
    <SPAN 
    
    <FONT 

    <SPAN 
    style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; FONT-FAMILY: Tahoma">From:<FONT 
    face=Tahoma size=2> Chris 
    Boulton [mailto:[email-masked]] <SPAN 
    style="FONT-WEIGHT: bold">Sent: Wednesday, June 07, 2006 3:52 
    PMTo: Even, Roni; 
    [email-masked]; [email-masked]<SPAN 
    style="FONT-WEIGHT: bold">Subject: RE: [mediactrl] New version of 
    Control Framework - 
    draft-boulton-sip-control-framework-02
    <SPAN 
    style="FONT-SIZE: 12pt"> 
    <DIV 
    style="BORDER-RIGHT: medium none; PADDING-RIGHT: 0cm; BORDER-TOP: medium none; PADDING-LEFT: 4pt; PADDING-BOTTOM: 0cm; BORDER-LEFT: blue 1.5pt solid; PADDING-TOP: 0cm; BORDER-BOTTOM: medium none">
    <FONT face=Arial color=navy 
    size=2><SPAN 
    style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
    <FONT face=Arial color=blue 
    size=2><SPAN 
    style="FONT-SIZE: 11pt; COLOR: blue; FONT-FAMILY: Arial">   A) 
    *Must* the control channel be established before a call leg is brought to 
    the Media Server? The Control Framework for SIP draft seems to only talk 
    about setting up the control channel before a call leg is brought to the MS. 
    It might be useful to allow for both, don’t know whether it’s problematic. 
    Either way, it should be clarified.
    <FONT face=Arial 
    color=navy size=2><SPAN 
    style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial"> 
    <FONT face=Arial 
    color=navy size=2><SPAN 
    style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial">[Chris 
    Boulton] I don’t see why you MUST have a control channel established.  
    It would just mean that you can’t issue any commands on that media stream. 
     Does that seem ok to everyone? At the end of the day we are talking 
    about two mechanisms that are not dependant on each other.   I 
    will clarify the text in the next revision if no-one 
    opposes.
    <FONT face=Arial color=navy 
    size=2>[Roni 
    Even] My view is that you need to have the control channel established 
    first. There is a relationship between the control and the call leg. One 
    example is that the MS may need to convey a conference identifier to be used 
    for establishing the call leg. In the IVR case you can start with 
    establishing the call leg and use the dialog identifier to correlate with 
    the control session. My view is that it will be better to establish the TCP 
    control channel connection at startup and use it for all sessions. 
    
    <FONT face=Arial color=navy 
    size=2><SPAN 
    style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
    <FONT face=Arial 
    color=red size=2><SPAN 
    style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: red; FONT-STYLE: italic; FONT-FAMILY: Arial">[Chris 
    Boulton] OK – but should this be in the framework?  Remember that the 
    Framework is not supposed to be media server specific.  Perhaps 
    specific detail like this belongs in the individual usages of the framework 
    (Packages)  e.g. the IVR package states that a connection should be 
    initiated – as per ……..
    <FONT face=Arial 
    color=navy size=2><SPAN 
    style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial">[RE:] 
    Chris – this is not media server specific but it defines the flow. The 
    correlation between the Control and SIP call leg is needed. If you establish 
    the SIP call leg first, you can use the dialog identifier. If you start with 
    Control first then there is no SIP dialog for the call leg first. This is 
    not package specific but general mechanism. I was also stating that for 
    conference you need to have a URI for the SIP call leg, so maybe the model 
    will be to create the control session start the specific package and then 
    connect the call leg.
    <FONT face=Arial color=navy 
    size=2><SPAN 
    style="FONT-SIZE: 11pt; COLOR: navy; FONT-FAMILY: Arial"> 
    <SPAN 
    style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial">[Chris 
    Boulton] Roni – I think we talking on different issues.  >From what I 
    read in your latest comment I totally agree and that is how the draft is 
    written today.  There is a definite correlation between the state of 
    the SIP dialog and the connection pipe.  The connection pipe can not 
    exist without the SIP dialog.  If the SIP dialog is created/terminated 
    – the control channel is created/terminated.  I was just commenting on 
    the fact that the control framework does not mandate when the connection is 
    made for a conference – it will more than likely be made before the first 
    participant SIP dialog is connected BUT maybe after – but that isn’t 
    mandated.
    <FONT face="Times New Roman" 
    size=3><SPAN 
    style="FONT-SIZE: 12pt"> 
    <SPAN 
    style="FONT-SIZE: 12pt"><FONT face=Verdana size=1 
    colour="#cccccc"><SPAN 
    style="FONT-SIZE: 7.5pt; FONT-FAMILY: Verdana">Information contained in this 
    e-mail and any attachments are intended for the use of the addressee only, 
    and may contain confidential information of Ubiquity Software Corporation. 
    All unauthorized use, disclosure or distribution is strictly 
    prohibited.  If you are not the addressee, please notify the sender 
    immediately and destroy all copies of this email.  Unless otherwise 
    expressly agreed in writing signed by an officer of Ubiquity Software 
    Corporation, nothing in this communication shall be deemed to be legally 
    binding. Thank-you