Subject: [mediactrl] Some comments to draft-even-media-server-req-01.txt

From: "Sasha Ruditsky" <[email-masked]>
Date: Tue, 13 Jun 2006 18:36:43 +0100

Hi 
Roni,
<SPAN 
class=700593515-13062006> 
I have several 
comments/questions to your requirements document 
(draft-even-media-server-req-01.txt):
<SPAN 
class=700593515-13062006> 
1) In the "current 
protocol" section references do not seem to be up-to date.
   
According to my knowledge:
   a) 
MSCML is draft-vandyke-mscml-08
   b) MSML 
is draft-saleem-msml-00.txt
   c) MOML 
is draft-melanchuk-sipping-moml-06
   
d) NETAN is RFC 4240<SPAN 
class=700593515-13062006>   e) CCCP is 
draft-levin-xcon-cccp-04
   f) 
ITU H.248.19 is ITU H.248.19 Am1

And BTW: Why draft-boulton-sip-control-framework-02 is not on this 
list?
<SPAN 
class=700593515-13062006> 
2) General 
requirement 9 says: "The AS shall be able to request the MS to create, 
delete, and   manipulate a mixing, IVR or announcement session." 
For this means that only these three kinds of sessions are 
supported.
   If this 
is the case then I think it contradicts the <FONT face=Arial 
size=2>General requirement 6 which says: "The 
protocol should be extendable."
<FONT 
size=2>    <FONT face=Arial 
size=2>3) Does the 
requirement <SPAN 
class=700593515-13062006>"The AS may be able to define a custom video layout 
built of   rectangular sub windows." <FONT 
face=Arial>allow overlapped windows (PIP 
style)?
<SPAN 
class=700593515-13062006> 
4) Why in "The AS 
shall be able to tell the MS if the message can be delayed   if 
the MS cannot play it immediately." it says "message" and not "announcement"? 

<SPAN 
class=700593515-13062006> 
<FONT 
face=Arial size=2>5) In "The AS shall be able to mange the IVR session by 
sending   announcements and receiving the response (DTMF)" "mange" 
should be "manage".
<FONT 
size=2>
<FONT face=Arial 
size=2>Thanks,
<FONT face=Arial 
size=2>Sasha

---

From: "Adnan Saleem" <[email-masked]>
Date: Tue, 13 Jun 2006 19:09:00 +0100

please 
see some updates and comments inline:
<FONT face=Arial color=#0000ff 
size=2> 
<FONT face=Arial color=#0000ff 
size=2>thanks
<FONT face=Arial color=#0000ff 
size=2> 
<FONT face=Arial color=#0000ff 
size=2>Adnan

  <FONT face=Tahoma 
  size=2>-----Original Message-----From: 
  [email-masked] 
  [mailto:[email-masked]]On Behalf Of Sasha 
  RuditskySent: June 13, 2006 10:39 AMTo: Even, 
  RoniCc: MediactrlSubject: [mediactrl] Some comments to 
  draft-even-media-server-req-01.txt
  Hi 
  Roni,
  <SPAN 
  class=700593515-13062006> 
  I have several 
  comments/questions to your requirements document 
  (draft-even-media-server-req-01.txt):
  <SPAN 
  class=700593515-13062006> 
  1) In the "current 
  protocol" section references do not seem to be up-to date.
     
  According to my knowledge:
  <SPAN 
  class=700593515-13062006>   a) MSCML is 
  draft-vandyke-mscml-08
     b) 
  MSML is draft-saleem-msml-00.txt
     
  c) MOML is draft-melanchuk-sipping-moml-06<SPAN 
  class=792374817-13062006>[Adnan Saleem] c) does not 
  exist any more. There is *only*  "MSML is 
  draft-saleem-msml-00.txt" which covers/combines previous MSML/MOML 
  drafts.
  <SPAN 
  class=792374817-13062006>Also, the following item from Section 5. 
  [MSML] should be removed. "<FONT 
  color=#000000>Convedia has a second protocol called Media Objects Mark-up 
  Language (MOML [MOML] that can be used to specify individual user dialog or 
  media control commands."
  <SPAN 
  class=792374817-13062006> 
  <FONT color=#0000ff 
  size=2>I would suggest that the package scheme 
  of MSML should be briefly described. The modular structure of MSML and 
  the package scheme is described by the following 
  diagram.
  <SPAN 
  class=792374817-13062006> 
  <FONT face="Courier New" 
  color=#0000ff size=2><SPAN 
  class=792374817-13062006>                  
  +----------------------------------------------+ 
                    
  |                  
  MSML 
  Core                   
  | 
                    
  +----------------------------------------------+ 
                        
  /                                     
  \ 
                    
  +--------+                            
  +--------+ 
                    
  | Dialog 
  |                            
  | Conf   | 
                    
  | Core   
  |                            
  | Core   | 
               
  -  - +--------+ - -  -  -  -  -   
  -   -    +--------+ 
              
  /        
  /          
  \           
  \       \ 
         +--------+  +--------+ 
  +---------+ +------+ +------+        | 
  Dialog |  | Dialog | |Dialog   | |Dialog| |Dialog| 
         | Base   |  | 
  Group  | |Transform| |Speech| |Fax   | 
         +--------+  +--------+ 
  +---------+ +------+ +------+ 
  <FONT color=#0000ff 
  size=2> 
     
  d) NETAN is RFC 4240<SPAN 
  class=700593515-13062006>   e) CCCP is 
  draft-levin-xcon-cccp-04
  <SPAN 
  class=700593515-13062006>   f) ITU H.248.19 is ITU H.248.19 
  Am1

  And BTW: Why draft-boulton-sip-control-framework-02 is not on this 
  list?
  <SPAN 
  class=700593515-13062006> 
  2) General 
  requirement 9 says: "The AS shall be able to request the MS to create, 
  delete, and   manipulate a mixing, IVR or announcement session." 
  For this means that only these three kinds of sessions are 
  supported.
     If 
  this is the case then I think it contradicts the <SPAN 
  class=700593515-13062006>General requirement 6 
  which says: "The protocol should be extendable."<SPAN 
  class=792374817-13062006>[Adnan Saleem] I agree, 
  protocol must be extensibe with the a minimum base functionality as 
  described above. 
  <FONT 
  size=3>    <FONT 
  size=2>3) Does the 
  requirement <FONT 
  face=Arial size=2>"The AS may be able to define a custom video layout built 
  of   rectangular sub windows." <SPAN 
  class=700593515-13062006>allow overlapped 
  windows (PIP style)?<FONT 
  color=#0000ff>[Adnan Saleem] I also think that layering and priority 
  assignment to the layers is useful.
  <SPAN 
  class=700593515-13062006> 
  4) Why in 
  "The AS shall be able to tell the MS if the message can be 
  delayed   if the MS cannot play it immediately." it says 
  "message" and not "announcement"? <FONT 
  color=#0000ff>[Adnan Saleem] I'm not clear on this use-case, perhaps Roni 
  or someone else can elaborate. I'm assuming this is not related to early media 
  ?
  <SPAN 
  class=700593515-13062006> 
  <FONT 
  size=3>5) In "The AS shall be able to mange the IVR 
  session by sending   announcements and receiving the response 
  (DTMF)" "mange" should be "manage".
  <FONT 
  size=2>
  <FONT face=Arial 
  size=2>Thanks,
  <FONT face=Arial 
  size=2>Sasha