Subject: RE: [mediactrl] New version of Control Framework - draft-boulton-sip-control-framework-02

From: "Even, Roni" <[email-masked]>
Date: Tue, 6 Jun 2006 14:50:06 +0100

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Chris,

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Some of my thoughts

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<font size=2 color=blue
face=Arial>  
b) It will be a sizeable topic in its own right, so should be separated out.
(Divide and conquer/manage.)
There may be some implied corollary comments, having to do with how the AS
knows which MS it’s talking to over which control channel, which I
believe is an issue to include and address, but is only necessary with the use
of certain MS resource location approaches and not others.

<font size=2 color=navy
face=Arial> 

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] Yes – totally agree.  To be
honest you are correct in that this was only ever really meant to be a
placeholder and the intention was that if this work had legs it would become a
separate topic for discussion and documentation.  I can easily take it out
or leave it now that you know it is simply a pointer.

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>[Roni Even] – Currently we have a
framework document and packages which are not general mechanisms. I think that
until we define a different document structure, we should leave those sections and
discuss them. 

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<font size=2
color=blue face=Arial><span style='font-size:11.0pt;font-family:Arial;
color:blue'>   A) *Must* the control channel be established before a
call leg is brought to the Media Server? The Control Framework for SIP draft
seems to only talk about setting up the control channel before a call leg is
brought to the MS. It might be useful to allow for both, don’t know
whether it’s problematic. Either way, it should be clarified.

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'> 

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'>[Chris Boulton] I don’t see why you
MUST have a control channel established.  It would just mean that you
can’t issue any commands on that media stream.  Does that seem ok to
everyone? At the end of the day we are talking about two mechanisms that are
not dependant on each other.   I will clarify the text in the next
revision if no-one opposes.

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>[Roni Even] My view is that you need to
have the control channel established first. There is a relationship between the
control and the call leg. One example is that the MS may need to convey a
conference identifier to be used for establishing the call leg. In the IVR case
you can start with establishing the call leg and use the dialog identifier to correlate
with the control session. My view is that it will be better to establish the
TCP control channel connection at startup and use it for all sessions. 

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<font size=2
color=blue face=Arial><span style='font-size:11.0pt;font-family:Arial;
color:blue'>Or in Garland’s
jargon, a ‘long-lived’ control channel? I believe that would be
desirable to allow for, and should be explicitly addressed.

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'> 

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'>[Chris Boulton] I will clarify the text
where possible BUT this really is part of a package to make use of the channel
how it wants.  We create a SIP dialog which results in a control chancel
being established – you tear it down the control channel goes as well.
 If in a control package this is long lived then so be it – just
don’t tear down the SIP dialog.

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>[Roni Even] I do not think this is part of
the package to explain the usage of one control channel. Note that you may have
more then one package using the same channel. 

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Another point to consider here is how the
AS knows that the MS is up and available for robustness support, this is not
per session issue.  I think that we need top address the issues of resource
management (even a simple one) and robustness when recommending a flow.

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Roni Even

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>

---

From: "Chris Boulton" <[email-masked]>
Date: Wed, 7 Jun 2006 11:46:49 +0100

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Hi Roni – just some comments [in
red] on your comments – feel free to comment <font size=2
color=navy face=Wingdings><span style='font-size:10.0pt;font-family:Wingdings;
color:navy'>J<span
style='font-size:10.0pt;font-family:Arial;color:navy'>.

<span style='font-size:

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Chris.

<span style='font-size:

<span style='font-size:

<font size=3
face="Times New Roman"> 

<font size=2 color=navy
face=Arial>Chris,

<font size=2 color=navy
face=Arial>Some of
my thoughts

<font size=2 color=navy
face=Arial> 

<font size=2 color=blue
face=Arial>  

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'>[Chris Boulton] Yes – totally
agree.  To be honest you are correct in that this was only ever really
meant to be a placeholder and the intention was that if this work had legs it
would become a separate topic for discussion and documentation.  I can
easily take it out or leave it now that you know it is simply a pointer.

<font size=2 color=navy
face=Arial>[Roni
Even] – Currently we have a framework document and packages which are not
general mechanisms. I think that until we define a different document
structure, we should leave those sections and discuss them. 

<font size=2 color=navy
face=Arial> 

<span
style='font-size:10.0pt;font-family:Arial;color:red;font-weight:bold;
font-style:italic'>[Chris Boulton] OK – I will remove totally from next
version.

<span style='font-size:

<font size=2

<font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy;font-weight:bold;font-style:italic'> 

<font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy;font-weight:bold;font-style:italic'>[Chris Boulton] I don’t
see why you MUST have a control channel established.  It would just mean
that you can’t issue any commands on that media stream.  Does that
seem ok to everyone? At the end of the day we are talking about two mechanisms
that are not dependant on each other.   I will clarify the text in
the next revision if no-one opposes.

<font size=2 color=navy
face=Arial>[Roni
Even] My view is that you need to have the control channel established first.
There is a relationship between the control and the call leg. One example is
that the MS may need to convey a conference identifier to be used for
establishing the call leg. In the IVR case you can start with establishing the
call leg and use the dialog identifier to correlate with the control session.
My view is that it will be better to establish the TCP control channel
connection at startup and use it for all sessions. 

<font size=2 color=navy
face=Arial> 

<span
style='font-size:10.0pt;font-family:Arial;color:red;font-weight:bold;
font-style:italic'>[Chris Boulton] OK – but should this be in the framework?
 Remember that the Framework is not supposed to be media server
specific.  Perhaps specific detail like this belongs in the individual
usages of the framework (Packages)  e.g. the IVR package states that a
connection should be initiated – as per …….. .

<font size=2 color=navy
face=Arial> 

<font size=2
color=blue face=Arial><span style='font-size:11.0pt;font-family:Arial;
color:blue'>Or in <span
  style='font-size:11.0pt;font-family:Arial;color:blue'>Garland<font
size=2 color=blue face=Arial><span style='font-size:11.0pt;font-family:Arial;
color:blue'>’s jargon, a ‘long-lived’ control channel? I
believe that would be desirable to allow for, and should be explicitly
addressed.

<font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy;font-weight:bold;font-style:italic'> 

<font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy;font-weight:bold;font-style:italic'>[Chris Boulton] I will clarify
the text where possible BUT this really is part of a package to make use of the
channel how it wants.  We create a SIP dialog which results in a control
chancel being established – you tear it down the control channel goes as
well.  If in a control package this is long lived then so be it –
just don’t tear down the SIP dialog.

<font size=2 color=navy
face=Arial>[Roni
Even] I do not think this is part of the package to explain the usage of one
control channel. Note that you may have more then one package using the same
channel. 

<span
font-style:italic'> 

<span
style='font-size:10.0pt;font-family:Arial;color:red;font-weight:bold;
font-style:italic'>[Chris Boulton] Agreed  - I didn’t word that very
well.  It is the intention that a control channel remain until no packages
require it/or closure for some other reason.

<span style='font-size:

<font size=2 color=navy
face=Arial>Another
point to consider here is how the AS knows that the MS is up and available for
robustness support, this is not per session issue.  I think that we need
top address the issues of resource management (even a simple one) and
robustness when recommending a flow.

<font size=2 color=navy
face=Arial> 

<span
style='font-size:10.0pt;font-family:Arial;color:red;font-weight:bold;
font-style:italic'>[Chris Boulton] Agreed – and I also think we agreed
this would be separate.

<span style='font-size:

<font size=2 color=navy
face=Arial>Roni
Even

<font size=2 color=navy
face=Arial> 

Information contained in this e-mail and any attachments are intended for the use of the addressee only, and may contain confidential information of Ubiquity Software Corporation. All unauthorized use, disclosure or distribution is strictly prohibited.  If you are not the addressee, please notify the sender immediately and destroy all copies of this email.  Unless otherwise expressly agreed in writing signed by an officer of Ubiquity Software Corporation, nothing in this communication shall be deemed to be legally binding. Thank-you

---

From: "Chris Boulton" <[email-masked]>
Date: Wed, 7 Jun 2006 13:50:24 +0100

<font size=2 color=navy
face=Arial> 

<font

<font

<font

<font size=2 color=navy
face=Arial>[Roni

<font size=2 color=navy
face=Arial> 

<font size=2 color=red
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:red;
font-weight:bold;font-style:italic'>[Chris Boulton] OK – but should this
be in the framework?  Remember that the Framework is not supposed to be
media server specific.  Perhaps specific detail like this belongs in the
individual usages of the framework (Packages)  e.g. the IVR package states
that a connection should be initiated – as per ……..

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'>[RE:] Chris – this is not media
server specific but it defines the flow. The correlation between the Control
and SIP call leg is needed. If you establish the SIP call leg first, you can
use the dialog identifier. If you start with Control first then there is no SIP
dialog for the call leg first. This is not package specific but general
mechanism. I was also stating that for conference you need to have a URI for
the SIP call leg, so maybe the model will be to create the control session
start the specific package and then connect the call leg.

<font size=2 color=navy
face=Arial> 

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] Roni – I think we talking on different
issues.  From what I read in your latest comment I totally agree and that
is how the draft is written today.  There is a definite correlation
between the state of the SIP dialog and the connection pipe.  The
connection pipe can not exist without the SIP dialog.  If the SIP dialog
is created/terminated – the control channel is created/terminated. 
I was just commenting on the fact that the control framework does not mandate
when the connection is made for a conference – it will more than likely
be made before the first participant SIP dialog is connected BUT maybe after –
but that isn’t mandated.

<font size=3
face="Times New Roman">

---

From: "Even, Roni" <[email-masked]>
Date: Wed, 7 Jun 2006 13:50:46 +0100

Tom,
I think your suggestion make sense. To make a broader scope I think we need to define the document set that we will work on. If we adopt the package approach we need to have also the general mechanisms. This will bring up the question if all is part of the framework document or other documents are required.

We have some requirement documents but they are not complete yet and some of my points here have to do with the requirements. 

Roni

> -----Original Message-----
> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Wednesday, June 07, 2006 3:45 PM
> To: Even, Roni
> Cc: Chris Boulton; [email-masked]; [email-masked]
> Subject: Re: [mediactrl] New version of Control Framework - draft-boulton-
> sip-control-framework-02
> 
> I hate to say this -- it sounds too legacy -- but this conversation
> cries out for the development of some abstract 'call flows' (I quote
> because the work goes beyond individual calls) just to see what the
> alternatives are.
> 
> Even, Roni wrote:
> > Chris,
> >
> > In line
> >
> >
> >
> > ________________________________
> >
> > From: Chris Boulton [mailto:[email-masked]]
> > Sent: Wednesday, June 07, 2006 1:47 PM
> > To: Even, Roni; [email-masked]; [email-masked]
> > Subject: RE: [mediactrl] New version of Control Framework -
> > draft-boulton-sip-control-framework-02
> >
> >
> >
> > Hi Roni - just some comments [in red] on your comments - feel free to
> > comment :-).
> >
> >
> >
> > Chris.
> >
> >
> >
> >
> >
> >
> >
> > Chris,
> >
> > Some of my thoughts
> >
> >
> >
> >    b) It will be a sizeable topic in its own right, so should be
> > separated out. (Divide and conquer/manage.)
> > There may be some implied corollary comments, having to do with how the
> > AS knows which MS it's talking to over which control channel, which I
> > believe is an issue to include and address, but is only necessary with
> > the use of certain MS resource location approaches and not others.
> >
> >
> >
> > [Chris Boulton] Yes - totally agree.  To be honest you are correct in
> > that this was only ever really meant to be a placeholder and the
> > intention was that if this work had legs it would become a separate
> > topic for discussion and documentation.  I can easily take it out or
> > leave it now that you know it is simply a pointer.
> >
> > [Roni Even] - Currently we have a framework document and packages which
> > are not general mechanisms. I think that until we define a different
> > document structure, we should leave those sections and discuss them.
> >
> >
> >
> > [Chris Boulton] OK - I will remove totally from next version.
> >
> > [RE:] I think that those sections should remain as long as we do not
> > decide on the document structure, the information is required. It has
> > nothing to do with the next revision
> >
> >
> >
> >    A) *Must* the control channel be established before a call leg is
> > brought to the Media Server? The Control Framework for SIP draft seems
> > to only talk about setting up the control channel before a call leg is
> > brought to the MS. It might be useful to allow for both, don't know
> > whether it's problematic. Either way, it should be clarified.
> >
> >
> >
> > [Chris Boulton] I don't see why you MUST have a control channel
> > established.  It would just mean that you can't issue any commands on
> > that media stream.  Does that seem ok to everyone? At the end of the day
> > we are talking about two mechanisms that are not dependant on each
> > other.   I will clarify the text in the next revision if no-one opposes.
> >
> > [Roni Even] My view is that you need to have the control channel
> > established first. There is a relationship between the control and the
> > call leg. One example is that the MS may need to convey a conference
> > identifier to be used for establishing the call leg. In the IVR case you
> > can start with establishing the call leg and use the dialog identifier
> > to correlate with the control session. My view is that it will be better
> > to establish the TCP control channel connection at startup and use it
> > for all sessions.
> >
> >
> >
> > [Chris Boulton] OK - but should this be in the framework?  Remember that
> > the Framework is not supposed to be media server specific.  Perhaps
> > specific detail like this belongs in the individual usages of the
> > framework (Packages)  e.g. the IVR package states that a connection
> > should be initiated - as per ........
> >
> > [RE:] Chris - this is not media server specific but it defines the flow.
> > The correlation between the Control and SIP call leg is needed. If you
> > establish the SIP call leg first, you can use the dialog identifier. If
> > you start with Control first then there is no SIP dialog for the call
> > leg first. This is not package specific but general mechanism. I was
> > also stating that for conference you need to have a URI for the SIP call
> > leg, so maybe the model will be to create the control session start the
> > specific package and then connect the call leg.
> >
> >  .
> >
> >
> >
> > Or in Garland's jargon, a 'long-lived' control channel? I believe that
> > would be desirable to allow for, and should be explicitly addressed.
> >
> >
> >
> > [Chris Boulton] I will clarify the text where possible BUT this really
> > is part of a package to make use of the channel how it wants.  We create
> > a SIP dialog which results in a control chancel being established - you
> > tear it down the control channel goes as well.  If in a control package
> > this is long lived then so be it - just don't tear down the SIP dialog.
> >
> > [Roni Even] I do not think this is part of the package to explain the
> > usage of one control channel. Note that you may have more then one
> > package using the same channel.
> >
> >
> >
> > [Chris Boulton] Agreed  - I didn't word that very well.  It is the
> > intention that a control channel remain until no packages require it/or
> > closure for some other reason.
> >
> > [RE:] What I meant here is that the flow (control or call leg first)
> > should not be package specific in order to simplify the AS call flow.
> >
> >
> >
> > Another point to consider here is how the AS knows that the MS is up and
> > available for robustness support, this is not per session issue.  I
> > think that we need top address the issues of resource management (even a
> > simple one) and robustness when recommending a flow.
> >
> >
> >
> > [Chris Boulton] Agreed - and I also think we agreed this would be
> > separate.
> >
> > [RE:] I am not sure what should be separate and what should be included.
> > I think that the framework should address all issues.
> >
> >
> >
> >
> >
> > Roni Even
> >
> >
> >
> >
> >
> > Information contained in this e-mail and any attachments are intended
> > for the use of the addressee only, and may contain confidential
> > information of Ubiquity Software Corporation. All unauthorized use,
> > disclosure or distribution is strictly prohibited.  If you are not the
> > addressee, please notify the sender immediately and destroy all copies
> > of this email.  Unless otherwise expressly agreed in writing signed by
> > an officer of Ubiquity Software Corporation, nothing in this
> > communication shall be deemed to be legally binding. Thank-you
> >
> >

--------------------------
Ubiquity Software does not control or endorse the content, messages or information found in this mail list and it specifically disclaims any liability with regard to these communications.
Ubiquity Software reserves the right the restrict access to any communications in violation of the Terms and Conditions of Use for this website or as otherwise deemed improper.

---

From: "Chris Boulton" <[email-masked]>
Date: Wed, 7 Jun 2006 14:27:03 +0100

<span style='font-size:

<font size=2 color=navy
face=Arial>Chris,

<font size=2 color=navy
face=Arial>My
claims are as follows:

<font size=2 color=navy
face=Arial> 

<font size=2
color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'>1.      
<span
style='font-size:10.0pt;font-family:Arial;color:navy'>The connection between
the AS and MS can be made before any use of the MS, in this mode there will be
one connection between the AS and MS for all control sessions.

<span

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] Agreed – and possible in current
version.

<span style='font-size:

<font size=2
color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'>2.      
<span
style='font-size:10.0pt;font-family:Arial;color:navy'>The connection between
the AS and MS can be established for each control session. (IVR session,
Conference). Personally I prefer one connection. Both modes should be supported
if possible.

<span

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] Agreed – and possible in current
version.

<span style='font-size:

<font size=2
color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'>3.      
<span
style='font-size:10.0pt;font-family:Arial;color:navy'>A control message between
the AS and MS MUST be exchanged before the SIP call leg can be established. If you
think different please explain the flow that will create a conference when the
first participant calls. I assume one control connection per a conference and
not for each participant. I know that this is part of the difference between
the different MxMLs but I thought we agreed that we will use the model of one
control connection per conference.

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'>[Chris Boulton ]From below:  .
There was a concern about the number of connections between AS to MS (BTW: my
comment here is that if we have a conference identifier in the protocol we may
look at having one connection from AS to each MS and multiplex control for all
conferences based on conference identifier) – <font size=2
color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy;font-weight:bold;font-style:italic'>This is how is works today in
the ‘Conference package’.  There is a Conference reference per
conference instance that is explicitly referenced.  It can be passed down
any >=1 number of control channels to a media server. 

<font size=3
face="Times New Roman"> 

<font size=3
face="Times New Roman">d

<span

<span

<span style='font-size:

<font size=2 color=navy
face=Arial>This
text is from the <span
  style='font-size:10.0pt;font-family:Arial;color:navy'>Paris<font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'> meeting summary

<font size=2 color=navy
face=Arial> 

<font size=3
face="Times New Roman">Some agreements:

<font size=3
face="Times New Roman">The RTP goes from the
edges.

<font size=3
face="Times New Roman">There will be a Control
channel from AS to MS.  This is a conference level channel. There was a
concern about the number of connections between AS to MS (BTW: my comment here
is that if we have a conference identifier in the protocol we may look at
having one connection from AS to each MS and multiplex control for all conferences
based on conference identifier)

<font size=3
face="Times New Roman">On the control channel we
need commands to the MS and indication to the AS.

<font size=3
face="Times New Roman">Need to deal with simple
IVR non vxml systems and video.

<font size=3
face="Times New Roman"> 

<font size=3
face="Times New Roman">The solution will allow
but not mandate a proxy between the AS and MS to direct to the right MS and to
handle resources it may contradict the proposed requirements.

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>Roni 

<font size=2 color=navy
face=Arial> 

<font
size=3 face="Times New Roman">

<span
style='font-size:10.0pt;font-family:Tahoma;font-weight:bold'>From:<font
size=2 face=Tahoma> Chris
Boulton [mailto:[email-masked]] 
Sent: Wednesday, June
 07, 2006<span style='font-size:10.0pt;
font-family:Tahoma'> <span
 style='font-size:10.0pt;font-family:Tahoma'>3:52 PM<font size=2
face=Tahoma>
To: Even, Roni; [email-masked];
[email-masked]
Subject: RE: [mediactrl] New
version of Control Framework - draft-boulton-sip-control-framework-02

<font size=3
face="Times New Roman"> 

<font size=2 color=navy
face=Arial> 

<font

<font

<font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy;font-weight:bold;font-style:italic'>[Chris Boulton] I don’t see
why you MUST have a control channel established.  It would just mean that
you can’t issue any commands on that media stream.  Does that seem
ok to everyone? At the end of the day we are talking about two mechanisms that
are not dependant on each other.   I will clarify the text in the
next revision if no-one opposes.

<font size=2 color=navy
face=Arial>[Roni

<font size=2 color=navy
face=Arial> 

<font size=2 color=red

<font size=2 color=navy

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'>[Chris Boulton] Roni – I think we
talking on different issues.  From what I read in your latest comment I
totally agree and that is how the draft is written today.  There is a
definite correlation between the state of the SIP dialog and the connection
pipe.  The connection pipe can not exist without the SIP dialog.  If
the SIP dialog is created/terminated – the control channel is
created/terminated.  I was just commenting on the fact that the control
framework does not mandate when the connection is made for a conference –
it will more than likely be made before the first participant SIP dialog is
connected BUT maybe after – but that isn’t mandated.

<font size=3
face="Times New Roman"> 

<font size=3
face="Times New Roman">

<span
style='font-size:7.5pt;font-family:Verdana'>Information contained in this
e-mail and any attachments are intended for the use of the addressee only, and
may contain confidential information of Ubiquity Software Corporation. All unauthorized
use, disclosure or distribution is strictly prohibited.  If you are not
the addressee, please notify the sender immediately and destroy all copies of
this email.  Unless otherwise expressly agreed in writing signed by an
officer of Ubiquity Software Corporation, nothing in this communication shall
be deemed to be legally binding. Thank-you

---

From: "Even, Roni" <[email-masked]>
Date: Wed, 7 Jun 2006 14:31:10 +0100

<span style='font-size:

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>So now about the third point. I understood
that your suggestion is that this flow is part of the package and my suggestion
is that the flow is general and is part of the framework (or other general
document). So a control message is always before the SIP leg connection for all
AS to MS sessions

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Roni

<span style='font-size:

<font size=3
face="Times New Roman">

<span style='font-size:10.0pt;
font-family:Tahoma;font-weight:bold'>From:<font size=2
face=Tahoma> Chris Boulton
[mailto:[email-masked]] 
Sent: Wednesday, June 07, 2006
4:29 PM
To: Even, Roni; [email-masked];
[email-masked]
Subject: RE: [mediactrl] New
version of Control Framework - draft-boulton-sip-control-framework-02

<span style='font-size:
12.0pt'> 

<span style='font-size:

<font size=2 color=navy
face=Arial>Chris,

<font size=2 color=navy
face=Arial>My
claims are as follows:

<font size=2 color=navy
face=Arial> 

<font size=2
color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'>1.<span style='font-size:
7.0pt;color:navy'>       <font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'>The connection between the AS and MS can be made before any use of
the MS, in this mode there will be one connection between the AS and MS for all
control sessions.

<span

<span

<span style='font-size:

<font size=2
color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'>2.<span style='font-size:
7.0pt;color:navy'>       <font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'>The connection between the AS and MS can be established for each
control session. (IVR session, Conference). Personally I prefer one connection.
Both modes should be supported if possible.

<span

<span

<span style='font-size:

<font size=2
color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'>3.<span style='font-size:
7.0pt;color:navy'>       <font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'>A control message between the AS and MS MUST be exchanged before
the SIP call leg can be established. If you think different please explain the
flow that will create a conference when the first participant calls. I assume
one control connection per a conference and not for each participant. I know
that this is part of the difference between the different MxMLs but I thought
we agreed that we will use the model of one control connection per conference.

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy

<font size=3
face="Times New Roman"> 

<font size=3
face="Times New Roman">d

<span

<span

<span style='font-size:

<font size=2 color=navy
face=Arial>This
text is from the Paris
meeting summary

<font size=2 color=navy
face=Arial> 

<font size=3

<font size=3

<font size=3
face="Times New Roman">There will be a Control
channel from AS to MS.  This is a conference level channel. There was a
concern about the number of connections between AS to MS (BTW: my comment here
is that if we have a conference identifier in the protocol we may look at
having one connection from AS to each MS and multiplex control for all
conferences based on conference identifier)

<font size=3

<font size=3

<font size=3
face="Times New Roman"> 

<font size=3

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>Roni 

<font size=2 color=navy
face=Arial> 

<font size=3
face="Times New Roman">

<span
Sent: Wednesday, June 07, 2006
3:52 PM

<font size=3
face="Times New Roman"> 

<font size=2 color=navy
face=Arial> 

<font
size=2 color=blue face=Arial><span style='font-size:11.0pt;font-family:Arial;
color:blue'>   A) *Must* the control channel be established before a
call leg is brought to the Media Server? The Control Framework for SIP draft
seems to only talk about setting up the control channel before a call leg is
brought to the MS. It might be useful to allow for both, don’t know whether
it’s problematic. Either way, it should be clarified.

<font

<font

<font size=2 color=navy
face=Arial>[Roni

<font size=2 color=navy
face=Arial> 

<font size=2 color=red
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:red;
font-weight:bold;font-style:italic'>[Chris Boulton] OK – but should this
be in the framework?  Remember that the Framework is not supposed to be media
server specific.  Perhaps specific detail like this belongs in the
individual usages of the framework (Packages)  e.g. the IVR package states
that a connection should be initiated – as per ……..

<font size=2 color=navy

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy

<font size=3
face="Times New Roman"> 

<font size=3
face="Times New Roman">

<span
style='font-size:7.5pt;font-family:Verdana'>Information contained in this
e-mail and any attachments are intended for the use of the addressee only, and
may contain confidential information of Ubiquity Software Corporation. All
unauthorized use, disclosure or distribution is strictly prohibited.  If
you are not the addressee, please notify the sender immediately and destroy all
copies of this email.  Unless otherwise expressly agreed in writing signed
by an officer of Ubiquity Software Corporation, nothing in this communication
shall be deemed to be legally binding. Thank-you

---

From: <[email-masked]>
Date: Wed, 7 Jun 2006 17:32:30 +0100

<span style='font-size:
11.0pt;font-family:Arial;color:blue'>Roni, Chris,  

<span style='font-size:
11.0pt;font-family:Arial;color:blue'> 

<span style='font-size:
11.0pt;font-family:Arial;color:blue'>Probing on the third point some more –
I still don’t see why a blanket requirement that the control channel come
first is necessary or desirable.  Let’s take two cases:

<span style='font-size:
11.0pt;font-family:Arial;color:blue'> 

<span style='font-size:
11.0pt;font-family:Arial;color:blue'>1) IVR (the draft-boulton-sip-control-framework
is for more than just conferencing).  One motivation behind *allowing* for
the case where the call arrives first is to minimize the delay in getting the
caller to a first announcement/prompt. Suppose that for a new call the AS is to
use an MS that it does not yet have a control channel established with. One may
want the AS to initiate the control channel establishment and call setup to the
MS in parallel, rather than sequentially, to get it all to happen as fast as
possible. If so, it’s not clear which might finish first – it could
be the call setup. If so, what’s the harm? (Whichever comes first to the
MS, the call or control channel for it, there is correlation info so the MS
will know which call pertains to which control instructions.) 

<span style='font-size:
11.0pt;font-family:Arial;color:blue'> 

<span style='font-size:
11.0pt;font-family:Arial;color:blue'>As another IVR scenario, suppose an AS already
has two existing control channels (maybe two to handle volume) open to an MS. When
a new call arrives at the MS, the MS doesn’t know or care which control channel
will be used to handle the new call; the AS could use either, right? So if, instead,
the AS decided to open up another control channel after the new call arrived and
use that one for the new call, should the MS care?

<span style='font-size:
11.0pt;font-family:Arial;color:blue'>2) Conferencing. Suppose that a call participant
leg is established to the MS before the control channel, so the call leg
arrives with some sort of conference identifier, and the MS doesn’t have
any knowledge of the conference yet. Is that a problem for the MS? Why can’t
it wait to see what control instructions show up? If the MS can’t wait,
how extensive do the control instructions have to be before the call leg can
arrive? E.g., the MS has to be provided just the conference ID first over the
control channel? More? Why is that truly necessary?

<span style='font-size:
11.0pt;font-family:Arial;color:blue'> 

<span style='font-size:
11.0pt;font-family:Arial;color:blue'>Cheers,

<span style='font-size:
11.0pt;font-family:Arial;color:blue'> 

<font size=2
  color=blue face=Arial><span style='font-size:11.0pt;font-family:Arial;
  color:blue'>Gary<font size=2 color=blue
face=Arial>

<span style='font-size:
11.0pt;font-family:Arial;color:blue'> 

<font size=3
face="Times New Roman">

<span style='font-size:10.0pt;
font-family:Tahoma;font-weight:bold'>From:<font size=2
face=Tahoma> Even, Roni
[mailto:[email-masked]] 
Sent: Wednesday, June 07, 2006
9:34 AM
To: Chris Boulton; <st1:PersonName
w:st="on">Munson,Gary A (Gary);
[email-masked]
Subject: RE: [mediactrl] New
version of Control Framework - draft-boulton-sip-control-framework-02

<span style='font-size:
12.0pt'> 

<span style='font-size:

<span style='font-size:

<span style='font-size:

<span style='font-size:

<font size=3
face="Times New Roman">

<span style='font-size:10.0pt;
font-family:Tahoma;font-weight:bold'>From:<font size=2
face=Tahoma> Chris Boulton
[mailto:[email-masked]] 
Sent: Wednesday, June 07, 2006
4:29 PM
To: Even, Roni; [email-masked];
[email-masked]
Subject: RE: [mediactrl] New version
of Control Framework - draft-boulton-sip-control-framework-02

<span style='font-size:
12.0pt'> 

<span style='font-size:

<span
style='font-size:10.0pt;font-family:Arial;color:navy'>Chris,

<span
style='font-size:10.0pt;font-family:Arial;color:navy'>My claims are as follows:

<span
style='font-size:10.0pt;font-family:Arial;color:navy'> 

<font size=2
color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'>1.<span style='font-size:
7.0pt;color:navy'>       <font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'>The connection between the AS and MS can be made before any use of the
MS, in this mode there will be one connection between the AS and MS for all
control sessions.

<span

<span

<span style='font-size:

<font size=2

<span

<span

<span style='font-size:

<font size=2

<span
style='font-size:10.0pt;font-family:Arial;color:navy'> 

<font size=2 color=navy
There was a concern about the number of connections between AS to MS (BTW: my comment
here is that if we have a conference identifier in the protocol we may look at

<span
style='font-size:12.0pt'> 

<span
style='font-size:12.0pt'>d

<span

<span

<span style='font-size:

<span
style='font-size:10.0pt;font-family:Arial;color:navy'>This text is from the <st1:place
w:st="on">Paris meeting summary

<span
style='font-size:10.0pt;font-family:Arial;color:navy'> 

<span
style='font-size:12.0pt'>Some agreements:

<span
style='font-size:12.0pt'>The RTP goes from the edges.

<span
style='font-size:12.0pt'>There will be a Control channel from AS to MS.
 This is a conference level channel. There was a concern about the number
of connections between AS to MS (BTW: my comment here is that if we have a
conference identifier in the protocol we may look at having one connection from
AS to each MS and multiplex control for all conferences based on conference
identifier)

<span
style='font-size:12.0pt'>On the control channel we need commands to the MS and
indication to the AS.

<span
style='font-size:12.0pt'>Need to deal with simple IVR non vxml systems and
video.

<span
style='font-size:12.0pt'> 

<span
style='font-size:12.0pt'>The solution will allow but not mandate a proxy
between the AS and MS to direct to the right MS and to handle resources it may
contradict the proposed requirements.

<span
style='font-size:10.0pt;font-family:Arial;color:navy'> 

<span
style='font-size:10.0pt;font-family:Arial;color:navy'> 

<span
style='font-size:10.0pt;font-family:Arial;color:navy'>Roni 

<span
style='font-size:10.0pt;font-family:Arial;color:navy'> 

<font size=3
face="Times New Roman">

<span

<span
style='font-size:12.0pt'> 

<font size=2 color=navy
face=Arial> 

<font size=2

<font

<font
that you can’t issue any commands on that media stream.  Does that seem

<font size=2 color=navy
face=Arial>[Roni

<font size=2 color=navy
face=Arial> 

<font size=2 color=red

<font size=2 color=navy

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'>[Chris Boulton] Roni – I think we
talking on different issues.  From what I read in your latest comment I
totally agree and that is how the draft is written today.  There is a
definite correlation between the state of the SIP dialog and the connection
pipe.  The connection pipe can not exist without the SIP dialog.  If
the SIP dialog is created/terminated – the control channel is
created/terminated.  I was just commenting on the fact that the control framework
does not mandate when the connection is made for a conference – it will
more than likely be made before the first participant SIP dialog is connected
BUT maybe after – but that isn’t mandated.

<span
style='font-size:12.0pt'> 

<span
style='font-size:12.0pt'>

<span

---

From: "Chris Boulton" <[email-masked]>
Date: Thu, 8 Jun 2006 08:43:05 +0100

<span style='font-size:
  10.0pt;font-family:Arial;color:navy'>Gary<font size=2
color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'> - I personally agree – which is the way the current version
is written.  You can connect a Control Channel when ever you like.  If
local policy is that on start-up you will have a long lived – permanent
connection then so be it. If you want to wait until the first dialog in a
conference is connected then so be it.  I envisage each control package
having different demands and differing applications also having differing demands
(+ different deployments).  IMHO the base control framework should not
mandate this and just provide clear connection guidelines (when you do want to
connect). 

<span style='font-size:

<span style='font-size:

<span style='font-size:

<span style='font-size:

<span
style='font-size:10.0pt;font-family:Tahoma'>-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] 
Sent: 07 June 2006 17:35
To: [email-masked]; Chris
Boulton; [email-masked]
Subject: RE: [mediactrl] New
version of Control Framework - draft-boulton-sip-control-framework-02

<font size=3
face="Times New Roman"> 

<font size=2 color=blue
face=Arial>Roni,
Chris,  

<font size=2 color=blue
face=Arial> 

<font size=2 color=blue
face=Arial>Probing
on the third point some more – I still don’t see why a blanket
requirement that the control channel come first is necessary or desirable.
 Let’s take two cases:

<font size=2 color=blue
face=Arial> 

<font size=2 color=blue
face=Arial>1) IVR
(the draft-boulton-sip-control-framework is for more than just conferencing).
 One motivation behind *allowing* for the case where the call arrives
first is to minimize the delay in getting the caller to a first
announcement/prompt. Suppose that for a new call the AS is to use an MS that it
does not yet have a control channel established with. One may want the AS to
initiate the control channel establishment and call setup to the MS in
parallel, rather than sequentially, to get it all to happen as fast as
possible. If so, it’s not clear which might finish first – it could
be the call setup. If so, what’s the harm? (Whichever comes first to the
MS, the call or control channel for it, there is correlation info so the MS
will know which call pertains to which control instructions.) 

<font size=2 color=blue
face=Arial> 

<p class=MsoNormal style='margin-right:0cm;margin-bottom:12.0pt;margin-left:
36.0pt'><span style='font-size:11.0pt;
font-family:Arial;color:blue'>As another IVR scenario, suppose an AS already
has two existing control channels (maybe two to handle volume) open to an MS.
When a new call arrives at the MS, the MS doesn’t know or care which
control channel will be used to handle the new call; the AS could use either,
right? So if, instead, the AS decided to open up another control channel after
the new call arrived and use that one for the new call, should the MS care?

<font size=2 color=blue
face=Arial>2)
Conferencing. Suppose that a call participant leg is established to the MS
before the control channel, so the call leg arrives with some sort of
conference identifier, and the MS doesn’t have any knowledge of the
conference yet. Is that a problem for the MS? Why can’t it wait to see
what control instructions show up? If the MS can’t wait, how extensive do
the control instructions have to be before the call leg can arrive? E.g., the
MS has to be provided just the conference ID first over the control channel?
More? Why is that truly necessary?

<font size=2 color=blue
face=Arial> 

<font size=2 color=blue
face=Arial>Cheers,

<font size=2 color=blue
face=Arial> 

<font size=2 color=blue
  face=Arial>Gary

<font size=2 color=blue
face=Arial> 

<font

<span
style='font-size:10.0pt;font-family:Tahoma;font-weight:bold'>From:<font
size=2 face=Tahoma> Even,
Roni [mailto:[email-masked]] 
Sent: Wednesday, June 07, 2006
9:34 AM
To: Chris Boulton; Munson,Gary A
(Gary); [email-masked]
Subject: RE: [mediactrl] New
version of Control Framework - draft-boulton-sip-control-framework-02

<font size=3
face="Times New Roman"> 

<font size=2 color=navy
face=Arial>Chris,

<font size=2 color=navy
face=Arial>So now
about the third point. I understood that your suggestion is that this flow is
part of the package and my suggestion is that the flow is general and is part
of the framework (or other general document). So a control message is always
before the SIP leg connection for all AS to MS sessions

<font size=2 color=navy
face=Arial>Roni

<font size=2 color=navy
face=Arial> 

<font

<span

<font size=3
face="Times New Roman"> 

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>Chris,

<font size=2 color=navy
face=Arial>My
claims are as follows:

<font size=2 color=navy
face=Arial> 

<font

<font size=2 color=navy

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'>[Chris Boulton] Agreed – and possible
in current version.

<font size=2 color=navy
face=Arial> 

<font

<font size=2 color=navy

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'>[Chris Boulton] Agreed – and possible
in current version.

<font size=2 color=navy
face=Arial> 

<font

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy

<font size=3
face="Times New Roman"> 

<font size=3
face="Times New Roman">d

<font size=2 color=navy

<font size=2 color=navy

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>This
text is from the Paris meeting summary

<font size=2 color=navy
face=Arial> 

<font size=3

<font size=3

<font size=3

<font size=3

<font size=3

<font size=3
face="Times New Roman"> 

<font size=3

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>Roni 

<font size=2 color=navy
face=Arial> 

<font

<span

<font size=3
face="Times New Roman"> 

<font size=2 color=navy
face=Arial> 

<font

<font

<font

<font size=2 color=navy
face=Arial>[Roni

<font size=2 color=navy
face=Arial> 

<font size=2 color=red

<font size=2 color=navy

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy

<font size=3
face="Times New Roman"> 

<font size=3
face="Times New Roman">

<span

---

From: "Even, Roni" <[email-masked]>
Date: Sun, 11 Jun 2006 09:31:26 +0100

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Hi,

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>I will try again to explain my issues.

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>We have in our architecture Application
Servers and Media Servers. 

<span style='font-size:

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>1. The first question is if the Application
Servers will look for an MS for every session or will they establish a control connection
and keep it. People had concerns about timing and number of connections. In
order to establish a control connection a SIP dialog is first established and a
TCP control channel is then opened. I would like to add here that my assumption
is that both the SIP dialog and the Control channel will need to be secure so
it is SIPS and then TLS connection for the control channel. I do not mind if
the solution will enable the AS to go through this process for every IVR
session and for every conference participant if some of you think that it is
better.

<span style='font-size:

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>2. Now about the issue of what should be
sent first the message in the control channel or the SIP invite to connect the
media to the media server. I saw that the suggestion is to send them in
parallel. I do not mind, I was just stating that the framework should address
this point and define how the correlation between the two will be defined. The correlation
should not be left to the specific packages since this will complicate
development on the AS and may lead to a situation where every package will have
a different mechanism.

<span style='font-size:

<span style='font-size:

<span style='font-size:

<span style='font-size:

<font size=3
face="Times New Roman">

<span style='font-size:10.0pt;
font-family:Tahoma;font-weight:bold'>From:<font size=2
face=Tahoma> Chris Boulton
[mailto:[email-masked]] 
Sent: Thursday, June 08, 2006
10:45 AM
To: [email-masked]; Even, Roni;
[email-masked]
Subject: RE: [mediactrl] New
version of Control Framework - draft-boulton-sip-control-framework-02

<span style='font-size:
12.0pt'> 

<font size=2
  color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
  color:navy'>Gary<font size=2 color=navy
face=Arial> - I
personally agree – which is the way the current version is written. 
You can connect a Control Channel when ever you like.  If local policy is
that on start-up you will have a long lived – permanent connection then
so be it. If you want to wait until the first dialog in a conference is
connected then so be it.  I envisage each control package having different
demands and differing applications also having differing demands (+ different
deployments).  IMHO the base control framework should not mandate this and
just provide clear connection guidelines (when you do want to connect). 

<span style='font-size:

<span style='font-size:

<span style='font-size:

<span style='font-size:

<span

<font size=3
face="Times New Roman"> 

<font size=2 color=blue
face=Arial>Roni,
Chris,  

<font size=2 color=blue
face=Arial> 

<font size=2 color=blue
face=Arial>Probing

<font size=2 color=blue
face=Arial> 

<font size=2 color=blue
face=Arial>1) IVR

<font size=2 color=blue
face=Arial> 

<p class=MsoNormal style='mso-margin-top-alt:0cm;margin-right:0cm;margin-bottom:
12.0pt;margin-left:36.0pt'><span
style='font-size:11.0pt;font-family:Arial;color:blue'>As another IVR scenario,
suppose an AS already has two existing control channels (maybe two to handle
volume) open to an MS. When a new call arrives at the MS, the MS doesn’t
know or care which control channel will be used to handle the new call; the AS
could use either, right? So if, instead, the AS decided to open up another
control channel after the new call arrived and use that one for the new call,
should the MS care?

<font size=2 color=blue
face=Arial>2)

<font size=2 color=blue
face=Arial> 

<font size=2 color=blue
face=Arial>Cheers,

<font size=2 color=blue
face=Arial> 

<st1:place
 w:st="on"><span style='font-size:11.0pt;
  font-family:Arial;color:blue'>Gary

<font size=2 color=blue
face=Arial> 

<font size=3
face="Times New Roman">

<span
To: Chris Boulton; Munson,Gary A (<st1:City
w:st="on">Gary);

<font size=3
face="Times New Roman"> 

<font size=2 color=navy
face=Arial>Chris,

<font size=2 color=navy
face=Arial>So now
about the third point. I understood that your suggestion is that this flow is part
of the package and my suggestion is that the flow is general and is part of the
framework (or other general document). So a control message is always before
the SIP leg connection for all AS to MS sessions

<font size=2 color=navy
face=Arial>Roni

<font size=2 color=navy
face=Arial> 

<font size=3
face="Times New Roman">

<span

<font size=3
face="Times New Roman"> 

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>Chris,

<font size=2 color=navy
face=Arial>My
claims are as follows:

<font size=2 color=navy
face=Arial> 

<font

<font size=2 color=navy

<font size=2 color=navy

<font size=2 color=navy
face=Arial> 

<font

<font size=2 color=navy

<font size=2 color=navy

<font size=2 color=navy
face=Arial> 

<font

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy

<font size=3
face="Times New Roman"> 

<font size=3
face="Times New Roman">d

<font size=2 color=navy

<font size=2 color=navy

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>This text
is from the Paris
meeting summary

<font size=2 color=navy
face=Arial> 

<font size=3

<font size=3

<font size=3

<font size=3

<font size=3

<font size=3
face="Times New Roman"> 

<font size=3

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>Roni 

<font size=2 color=navy
face=Arial> 

<font size=3
face="Times New Roman">

<span

<font size=3
face="Times New Roman"> 

<font size=2 color=navy
face=Arial> 

<font

<font

<font

<font size=2 color=navy
face=Arial>[Roni

<font size=2 color=navy
face=Arial> 

<font size=2 color=red

<font size=2 color=navy

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'>[Chris Boulton] Roni – I think we
talking on different issues.  From what I read in your latest comment I
totally agree and that is how the draft is written today.  There is a definite
correlation between the state of the SIP dialog and the connection pipe. 
The connection pipe can not exist without the SIP dialog.  If the SIP
dialog is created/terminated – the control channel is
created/terminated.  I was just commenting on the fact that the control
framework does not mandate when the connection is made for a conference –
it will more than likely be made before the first participant SIP dialog is
connected BUT maybe after – but that isn’t mandated.

<font size=3
face="Times New Roman"> 

<font size=3
face="Times New Roman">

<span

---

From: "Chris Boulton" <[email-masked]>
Date: Mon, 12 Jun 2006 08:33:14 +0100

<font size=2 color=navy
face=Arial>Hi,

<font size=2 color=navy
face=Arial>I will
try again to explain my issues.

<font size=2 color=navy
face=Arial>We have
in our architecture Application Servers and Media Servers. 

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>1. The
first question is if the Application Servers will look for an MS for every
session or will they establish a control connection and keep it. 

<span

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] In the current version it is just a single
control channel (although there would be nothing against having >1 for
redundancy.

<span

<font size=2 color=navy
face=Arial>People
had concerns about timing and number of connections. In order to establish a
control connection a SIP dialog is first established and a TCP control channel
is then opened. I would like to add here that my assumption is that both the
SIP dialog and the Control channel will need to be secure so it is SIPS and
then TLS connection for the control channel.

<span

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] Correct – well, the draft will
certainly discuss this -  I think I have an editors note in there to
expand once the core is nailed down.

<span

<font size=2 color=navy
face=Arial> I
do not mind if the solution will enable the AS to go through this process for
every IVR session and for every conference participant if some of you think
that it is better.

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>2. Now
about the issue of what should be sent first the message in the control channel
or the SIP invite to connect the media to the media server. I saw that the
suggestion is to send them in parallel. 

<span

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] Can you expand a little?  Currently the
SDP is used to establish the underlying channel using COMEDIA – and so is
reliant on the successful SIP negotiation (offer/answer) before a control
channel connection attempt can be made. 

<span

<font size=2 color=navy
face=Arial>I do not
mind, I was just stating that the framework should address this point and
define how the correlation between the two will be defined. The correlation
should not be left to the specific packages since this will complicate
development on the AS and may lead to a situation where every package will have
a different mechanism.

<font size=2 color=navy
face=Arial> 

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] totally agreed.

<span style='font-size:

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>Roni

<font size=2 color=navy
face=Arial> 

<div style='border-top:none;border-left:none windowtext 1.0pt;border-bottom:
none;border-right:solid blue 1.5pt;padding:0cm 0cm 0cm 4.0pt'>

<font

<span
Sent: Thursday, June
 08, 2006<span style='font-size:10.0pt;
 style='font-size:10.0pt;font-family:Tahoma'>10:45 AM<font
size=2 face=Tahoma>

<font size=3
face="Times New Roman"> 

<font size=2 color=navy
  face=Arial>Gary<font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'> - I personally agree – which is the way the current version
is written.  You can connect a Control Channel when ever you like.
 If local policy is that on start-up you will have a long lived –
permanent connection then so be it. If you want to wait until the first dialog
in a conference is connected then so be it.  I envisage each control
package having different demands and differing applications also having
differing demands (+ different deployments).  IMHO the base control
framework should not mandate this and just provide clear connection guidelines
(when you do want to connect). 

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>Chris.

<font size=2 color=navy
face=Arial>  

<font size=2 color=navy
face=Arial> 

<span
Sent: 07 June 2006<font
size=2 face=Tahoma> 17:35<font
size=2 face=Tahoma>

<font size=3
face="Times New Roman"> 

<font size=2 color=blue
face=Arial>Roni,
Chris,  

<font size=2 color=blue
face=Arial> 

<font size=2 color=blue
face=Arial>Probing

<font size=2 color=blue
face=Arial> 

<font size=2 color=blue
face=Arial>1) IVR

<font size=2 color=blue
face=Arial> 

72.0pt'><span style='font-size:11.0pt;

<font size=2 color=blue
face=Arial>2)
Conferencing. Suppose that a call participant leg is established to the MS before
the control channel, so the call leg arrives with some sort of conference
identifier, and the MS doesn’t have any knowledge of the conference yet.
Is that a problem for the MS? Why can’t it wait to see what control
instructions show up? If the MS can’t wait, how extensive do the control
instructions have to be before the call leg can arrive? E.g., the MS has to be
provided just the conference ID first over the control channel? More? Why is
that truly necessary?

<font size=2 color=blue
face=Arial> 

<font size=2 color=blue
face=Arial>Cheers,

<font size=2 color=blue
face=Arial> 

<font size=2 color=blue
  face=Arial>Gary

<font size=2 color=blue
face=Arial> 

<font

<span
style='font-size:10.0pt;font-family:Tahoma;font-weight:bold'>From:<font
size=2 face=Tahoma> Even,
Roni [mailto:[email-masked]] 
Sent: Wednesday, June
 07, 2006<span style='font-size:10.0pt;
font-family:Tahoma'> <span
 style='font-size:10.0pt;font-family:Tahoma'>9:34 AM<font size=2
face=Tahoma>
To: Chris Boulton; Munson,Gary A (<font
  size=2 face=Tahoma>Gary<font
size=2 face=Tahoma>);
[email-masked]
Subject: RE: [mediactrl] New
version of Control Framework - draft-boulton-sip-control-framework-02

<font size=3
face="Times New Roman"> 

<font size=2 color=navy
face=Arial>Chris,

<font size=2 color=navy
face=Arial>So now

<font size=2 color=navy
face=Arial>Roni

<font size=2 color=navy
face=Arial> 

<div style='border-top:none;border-left:none windowtext 1.0pt;border-bottom:
none;border-right:solid blue 1.5pt;padding:0cm 0cm 0cm 4.0pt'>

<font

<span
 style='font-size:10.0pt;font-family:Tahoma'>4:29 PM<font size=2

<font size=3
face="Times New Roman"> 

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>Chris,

<font size=2 color=navy
face=Arial>My
claims are as follows:

<font size=2 color=navy
face=Arial> 

<font

<font size=2 color=navy

<font size=2 color=navy

<font size=2 color=navy
face=Arial> 

<font

<font size=2 color=navy

<font size=2 color=navy

<font size=2 color=navy
face=Arial> 

<font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'>3.<span style='font-size:
7.0pt;color:navy'>       <font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'>A control message between the AS and MS MUST be exchanged before
the SIP call leg can be established. If you think different please explain the flow
that will create a conference when the first participant calls. I assume one
control connection per a conference and not for each participant. I know that
this is part of the difference between the different MxMLs but I thought we
agreed that we will use the model of one control connection per conference.

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy

<font size=3
face="Times New Roman"> 

<font size=3
face="Times New Roman">d

<font size=2 color=navy

<font size=2 color=navy

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>This
text is from the <span

<font size=2 color=navy
face=Arial> 

<font size=3

<font size=3

<font size=3

<font size=3

<font size=3

<font size=3
face="Times New Roman"> 

<font size=3

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>Roni 

<font size=2 color=navy
face=Arial> 

<div style='border-top:none;border-left:none windowtext 1.0pt;border-bottom:
none;border-right:solid blue 1.5pt;padding:0cm 0cm 0cm 4.0pt'>

<font

<span

<font size=3
face="Times New Roman"> 

<div style='border-top:none;border-left:none windowtext 1.0pt;border-bottom:
none;border-right:solid blue 1.5pt;padding:0cm 0cm 0cm 4.0pt'>

<font size=2 color=navy
face=Arial> 

<font
size=2 color=blue face=Arial><span style='font-size:11.0pt;font-family:Arial;
color:blue'>   A) *Must* the control channel be established before a
call leg is brought to the Media Server? The Control Framework for SIP draft seems
to only talk about setting up the control channel before a call leg is brought
to the MS. It might be useful to allow for both, don’t know whether
it’s problematic. Either way, it should be clarified.

<font

<font

<font size=2 color=navy
face=Arial>[Roni

<font size=2 color=navy
face=Arial> 

<font size=2 color=red

<font size=2 color=navy

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy

<font size=3
face="Times New Roman"> 

<font size=3
face="Times New Roman">

<span

---

From: "Even, Roni" <[email-masked]>
Date: Mon, 12 Jun 2006 09:04:32 +0100

<span style='font-size:

<span style='font-size:

<span

<span style='font-size:

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Maybe I am not clear enough. In the framework
we have a control connection that get established by SIP based on COMEDIA (
Control channel). The AS also makes a SIP connection to the MS in order to
connect the media from the participant to the MS (SIP dialog). So we have two separate
channels that need to be correlated. Now the question is which message get sent
first is it the control message or the SIP dialog. 

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>The framework defines a connection-id in
section 12.1. It specifies "local" and "remote" SIP dialog
identifier which by my understanding are the from and to tags. This means that
you need to have the SIP dialog (or "early" dialog) established
before you can send a control message to the user. 

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>The discussion so far was if the order
matters. If we do not want it to matter then we need to define a connection
identifier allocated by the AS, that is not dependent on establishing a dialog.

<span style='font-size:

<span style='font-size:

<span style='font-size:

<font size=3
face="Times New Roman">

Sent: Monday, June 12, 2006 10:35
AM

<span style='font-size:
12.0pt'> 

<font size=2 color=navy
face=Arial>Hi,

<font size=2 color=navy
face=Arial>I will

<font size=2 color=navy
face=Arial>We have

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>1. The
first question is if the Application Servers will look for an MS for every session
or will they establish a control connection and keep it. 

<span

<span

<span

<font size=2 color=navy
face=Arial>People

<span

<span

<span

<font size=2 color=navy
face=Arial> I

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>2. Now

<span

<span

<span

<font size=2 color=navy
face=Arial>I do not

<font size=2 color=navy
face=Arial> 

<span

<span style='font-size:

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>Roni

<font size=2 color=navy
face=Arial> 

<font size=3
face="Times New Roman">

<span

<font size=3
face="Times New Roman"> 

<st1:place
 w:st="on"><span style='font-size:10.0pt;
  font-family:Arial;color:navy'>Gary<font

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>Chris.

<font size=2 color=navy
face=Arial>  

<font size=2 color=navy
face=Arial> 

<span

<font size=3
face="Times New Roman"> 

<font size=2 color=blue
face=Arial>Roni,
Chris,  

<font size=2 color=blue
face=Arial> 

<font size=2 color=blue
face=Arial>Probing

<font size=2 color=blue
face=Arial> 

<font size=2 color=blue
face=Arial>1) IVR
(the draft-boulton-sip-control-framework is for more than just conferencing).
 One motivation behind *allowing* for the case where the call arrives
first is to minimize the delay in getting the caller to a first announcement/prompt.
Suppose that for a new call the AS is to use an MS that it does not yet have a
control channel established with. One may want the AS to initiate the control
channel establishment and call setup to the MS in parallel, rather than
sequentially, to get it all to happen as fast as possible. If so, it’s
not clear which might finish first – it could be the call setup. If so,
what’s the harm? (Whichever comes first to the MS, the call or control
channel for it, there is correlation info so the MS will know which call
pertains to which control instructions.) 

<font size=2 color=blue
face=Arial> 

12.0pt;margin-left:72.0pt'><span

<font size=2 color=blue
face=Arial>2)

<font size=2 color=blue
face=Arial> 

<font size=2 color=blue
face=Arial>Cheers,

<font size=2 color=blue
face=Arial> 

<st1:place

<font size=2 color=blue
face=Arial> 

<font size=3
face="Times New Roman">

<span

<font size=3
face="Times New Roman"> 

<font size=2 color=navy
face=Arial>Chris,

<font size=2 color=navy
face=Arial>So now

<font size=2 color=navy
face=Arial>Roni

<font size=2 color=navy
face=Arial> 

<font size=3
face="Times New Roman">

<span

<font size=3
face="Times New Roman"> 

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>Chris,

<font size=2 color=navy
face=Arial>My
claims are as follows:

<font size=2 color=navy
face=Arial> 

<font

<font size=2 color=navy

<font size=2 color=navy

<font size=2 color=navy
face=Arial> 

<font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'>2.<span style='font-size:
7.0pt;color:navy'>       <font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'>The connection between the AS and MS can be established for each control
session. (IVR session, Conference). Personally I prefer one connection. Both
modes should be supported if possible.

<font size=2 color=navy

<font size=2 color=navy

<font size=2 color=navy
face=Arial> 

<font

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy

<font size=3
face="Times New Roman"> 

<font size=3
face="Times New Roman">d

<font size=2 color=navy

<font size=2 color=navy

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>This
text is from the Paris
meeting summary

<font size=2 color=navy
face=Arial> 

<font size=3

<font size=3

<font size=3

<font size=3

<font size=3

<font size=3
face="Times New Roman"> 

<font size=3

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>Roni 

<font size=2 color=navy
face=Arial> 

<font size=3
face="Times New Roman">

<span

<font size=3
face="Times New Roman"> 

<font size=2 color=navy
face=Arial> 

<font

<font

<font

<font size=2 color=navy
face=Arial>[Roni

<font size=2 color=navy
face=Arial> 

<font size=2 color=red

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'>[RE:] Chris – this is not media server
specific but it defines the flow. The correlation between the Control and SIP
call leg is needed. If you establish the SIP call leg first, you can use the
dialog identifier. If you start with Control first then there is no SIP dialog
for the call leg first. This is not package specific but general mechanism. I
was also stating that for conference you need to have a URI for the SIP call
leg, so maybe the model will be to create the control session start the
specific package and then connect the call leg.

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy

<font size=3
face="Times New Roman"> 

<font size=3
face="Times New Roman">

<span
style='font-size:7.5pt;font-family:Verdana'>Information contained in this e-mail
and any attachments are intended for the use of the addressee only, and may
contain confidential information of Ubiquity Software Corporation. All
unauthorized use, disclosure or distribution is strictly prohibited.  If
you are not the addressee, please notify the sender immediately and destroy all
copies of this email.  Unless otherwise expressly agreed in writing signed
by an officer of Ubiquity Software Corporation, nothing in this communication
shall be deemed to be legally binding. Thank-you

---

From: "Chris Boulton" <[email-masked]>
Date: Mon, 12 Jun 2006 10:40:26 +0100

<font size=2 color=navy
face=Arial> 

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] OK – its taken a while BUT it think
the penny has dropped <font size=2 color=navy
face=Wingdings><span style='font-size:10.0pt;font-family:Wingdings;color:navy;
font-weight:bold;font-style:italic'>J<font size=2
color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy;font-weight:bold;font-style:italic'>.

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>Maybe I
am not clear enough. In the framework we have a control connection that get
established by SIP based on COMEDIA ( Control channel). The AS also makes a SIP
connection to the MS in order to connect the media from the participant to the
MS (SIP dialog).

<span

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] Agreed.

<span

<font size=2 color=navy
face=Arial> So
we have two separate channels that need to be correlated.

<span

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] Correlated as in referenced (e.g. you can
reference a dialog in the control channel).

<span

<font size=2 color=navy
face=Arial> Now
the question is which message get sent first is it the control message or the
SIP dialog. 

<span

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] A media dialog can only be referenced (as it
stands today) once it is created – due to the use of SIP tags. 

<span style='font-size:

<font size=2 color=navy
face=Arial>The
framework defines a connection-id in section 12.1. It specifies
"local" and "remote" SIP dialog identifier which by my
understanding are the from and to tags. 

<span

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] Correct.

<span

<font size=2 color=navy
face=Arial>This
means that you need to have the SIP dialog (or "early" dialog)
established before you can send a control message to the user.

<span

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] Yes.

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>The
discussion so far was if the order matters. If we do not want it to matter then
we need to define a connection identifier allocated by the AS, that is not
dependent on establishing a dialog.

<span

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] So there are operations that you want to
carry out on a dialog before it is setup?  I think the order does matter (in
that you can’t perform a control message level operation on a dialog that
doesn’t exist).  Why do you need a connection ‘id’
allocated by the AS? 

<span

<span style='font-size:

<span style='font-size:

<span style='font-size:

---

From: "Even, Roni" <[email-masked]>
Date: Mon, 12 Jun 2006 13:13:38 +0100

<span style='font-size:

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Thanks, now we are synchronized. I was
trying to clarify this based on some previous emails I saw. I think that this
flow should be clear in the framework or we need an example document. 

<span style='font-size:

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Now about sending control messages before
the SIP dialog. The ones I see are the dialogprepare in the ivr-control-package
and the conference create in the conference-control-package which makes sense
and they do not involve any interaction with a participant.

<span style='font-size:

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Some questions:

<span style='font-size:

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>The SIP dialog arrives to the media server
who will not know what to do with it until it receives a CONTROL message from
the AS. The MS will send an immediate report back. If no report or a timeout
later the AS need to also disconnect the SIP dialog ((2) in figure 4).

<span style='font-size:

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>About multi-media support. The conference
package support both audio and video while the IVR is audio only. Do you see a
separate package for audio only conferences. If not then I suggest that the
framework will also mention that the caller preferences can include the
required media. 

<span style='font-size:

<span style='font-size:

<span style='font-size:

<span style='font-size:

<span style='font-size:

<span style='font-size:

<font size=3
face="Times New Roman">

Sent: Monday, June 12, 2006 12:43
PM

<span style='font-size:
12.0pt'> 

<font size=2 color=navy
face=Arial> 

<span

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>Maybe I
am not clear enough. In the framework we have a control connection that get established
by SIP based on COMEDIA ( Control channel). The AS also makes a SIP connection
to the MS in order to connect the media from the participant to the MS (SIP
dialog).

<span

<span

<span

<font size=2 color=navy
face=Arial> So

<span

<span

<span

<font size=2 color=navy
face=Arial> Now

<span

<span

<span style='font-size:

<font size=2 color=navy
face=Arial>The

<span

<span

<span

<font size=2 color=navy
face=Arial>This

<span

<span

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>The

<span

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] So there are operations that you want to
carry out on a dialog before it is setup?  I think the order does matter
(in that you can’t perform a control message level operation on a dialog
that doesn’t exist).  Why do you need a connection ‘id’
allocated by the AS? 

<span

<span style='font-size:

<span style='font-size:

<span style='font-size:

<span style='font-size:
12.0pt'>

<span

---

From: "Chris Boulton" <[email-masked]>
Date: Mon, 12 Jun 2006 13:59:57 +0100

<span style='font-size:

<font size=3
face="Times New Roman"> 

<font size=2 color=navy
face=Arial>Chris,

<font size=2 color=navy
face=Arial>Thanks,
now we are synchronized. I was trying to clarify this based on some previous
emails I saw. I think that this flow should be clear in the framework or we
need an example document. 

<font size=2 color=navy
face=Arial> 

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] sounds good – I included a call flow
in section 13 of the latest version (<a rel="nofollow"
href="http://www.ietf.org/internet-drafts/draft-boulton-sip-control-framework-02.txt">http://www.ietf.org/internet-drafts/draft-boulton-sip-control-framework-02.txt)
– should I expand on this example?  I also think that you are
correct and we might need a call flow doc.

<span style='font-size:

<font size=2 color=navy
face=Arial>Now
about sending control messages before the SIP dialog. The ones I see are the
dialogprepare in the ivr-control-package and the conference create in the
conference-control-package which makes sense and they do not involve any
interaction with a participant.

<font size=2 color=navy
face=Arial> 

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] Agreed – and certainly in the
Conference package the idea is that Control messages creating a conference
instance are totally independent of the dialogs.  Scott might have a
comment on dialogprepare.

<span style='font-size:

<font size=2 color=navy
face=Arial>Some
questions:

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>The SIP
dialog arrives to the media server who will not know what to do with it until
it receives a CONTROL message from the AS. The MS will send an immediate report
back. If no report or a timeout later the AS need to also disconnect the SIP
dialog ((2) in figure 4).

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>About
multi-media support. The conference package support both audio and video while
the IVR is audio only. Do you see a separate package for audio only
conferences. If not then I suggest that the framework will also mention that
the caller preferences can include the required media. 

<font size=2 color=navy
face=Arial> 

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] Good point – I don’t see there
being a separate package for audio only.

<span style='font-size:

<font size=2 color=navy
face=Arial>Roni

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial> 

<font

<span
Sent: Monday, June
 12, 2006<span style='font-size:10.0pt;
 style='font-size:10.0pt;font-family:Tahoma'>12:43 PM<font

<font size=3
face="Times New Roman"> 

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'>[Chris Boulton] OK – its taken a
while BUT it think the penny has dropped <font
size=2 color=navy face=Wingdings><span style='font-size:10.0pt;font-family:
Wingdings;color:navy;font-weight:bold;font-style:italic'>J<font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy;font-weight:bold;font-style:italic'>.

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>Maybe I

<font size=2 color=navy

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'>[Chris Boulton] Agreed.

<font size=2 color=navy

<font size=2 color=navy
face=Arial> So

<font size=2 color=navy

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'>[Chris Boulton] Correlated as in referenced
(e.g. you can reference a dialog in the control channel).

<font size=2 color=navy

<font size=2 color=navy
face=Arial> Now

<font size=2 color=navy

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'>[Chris Boulton] A media dialog can only be
referenced (as it stands today) once it is created – due to the use of
SIP tags. 

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>The

<font size=2 color=navy

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'>[Chris Boulton] Correct.

<font size=2 color=navy

<font size=2 color=navy
face=Arial>This

<font size=2 color=navy

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'>[Chris Boulton] Yes.

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial>The

<font size=2 color=navy

<font size=2 color=navy
face=Arial><span style='font-size:10.0pt;font-family:Arial;color:navy;
font-weight:bold;font-style:italic'>[Chris Boulton] So there are operations
that you want to carry out on a dialog before it is setup?  I think the
order does matter (in that you can’t perform a control message level
operation on a dialog that doesn’t exist).  Why do you need a
connection ‘id’ allocated by the AS? 

<font size=2 color=navy

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial> 

<font size=2 color=navy
face=Arial> 

<font size=3
face="Times New Roman">

<span
e-mail and any attachments are intended for the use of the addressee only, and may