Subject: [mediactrl] N connections controlling 1 session

From: Eric Burger <[email-masked]>
Date: Tue, 5 Sep 2006 02:48:02 +0100

For REQ-MCP-09, I would offer that the primary purpose of having multiple
connections control a single session is for redundancy.

That raises a few questions.  The first, obvious one is am I right?  Are
there other purposes?  If so, let us enumerate them.

On 8/1/06 4:52 AM, "Adi Even-Tzur" <[email-masked]> wrote:

> Hi All,
>  
> I'm re-sending a mail with additional requirements to
> draft-dolly-xcon-mediacntrlframe-02.txt.
> Please review it and see if you have any remarks on these comments and
> additional requirements.
>  
> 
> thanks,
> 
> Adi.
> 
>  
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Adi Even-Tzur
> Sent: Thursday, June 29, 2006 3:29 PM
> To: Rafferty, James; [email-masked]; [email-masked]
> Subject: RE: [mediactrl] FW: draft-dolly-xcon-mediacntrlframe-02.txt
> submission
>  
> Hi,
>  
> Below you can find few comments on current requirements that are required for
> video application.
> Also, there are some additional requirements, which are relevant not only for
> video applications.
>  
> Comments about current requirements:
> * REQ-MCP-04 - The application scope of the protocol shall include enhanced
> Conferencing Control and Interactive Voice Response.
> Should be changed to:
> REQ-MCP-04 - The application scope of the protocol shall include enhanced
> Conferencing Control and Interactive Multimedia Response.
>  
> * REQ-MCP-09 - The solution MUST enable one control channel between an AS and
> MS, and shall allow for the support of multiple channels.
> Can you please give an example for scenario of having N connections that
> control 1 conference? Is it for redundancy issues, or are there any use cases.
>  
> * REQ-MCP-17 - The AS shall be able to define operations that the MS will
> perform on streams like mute and gain control.
> The AS should be able also to do the following operations:
>> * map or freeze video streams to the video layout
>> * define the geometry of the video layout
>> * set graphic properties or features of the video layout, and in particular
>> for each window in the video layout.
>  
> * REQ-MCP-19 - The MS shall be able to retrieve announcements from an external
> connection. 
> Should be change to:
> REQ-MCP-19 - The MS shall be able to retrieve Multimedia announcements from an
> external connection.
>  
>  
> Additional requirements:
> ·        The AS shall be able to instruct the MS to record either the entire
> conference or a specific participant. The recording command should specify
> which media streams should be recorded.
> ·        The AS shall be able to control the playing of Multimedia
> announcements with the following options: pause, resume, skip.
>  
>  
> 
> thanks,
> 
> Adi.
> 
>  
> -----Original Message-----
> From: Rafferty, James [mailto:[email-masked]]
> Sent: Monday, June 26, 2006 4:49 PM
> To: Adi Even-Tzur; Dolly, Martin C, ALABS;
> [email-masked]
> Subject: RE: [mediactrl] FW: draft-dolly-xcon-mediacntrlframe-02.txt
> submission
>  
> Adi, 
>  
> Video is within the scope of the requirements, per REQ-MCP-07.    Certainly
> we'd expect some of the conferencing scenarios will include video support.
>  
> If you'd like to see more granularity around video requirements, specific
> suggestions are welcome.
>  
> James
>  
> 
> 
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Adi Even-Tzur
> Sent: Monday, June 26, 2006 8:55 AM
> To: Dolly, Martin C, ALABS; [email-masked]
> Subject: RE: [mediactrl] FW: draft-dolly-xcon-mediacntrlframe-02.txt
> submission
> Hi Martin,
>  
> I have a question regarding the updated version of the requirements draft 
> although there are requirements for specific application capabilities, such as
> IVR and announcement management (REQ-MCP-18-22), it is lacking any
> requirements regarding the ability of the AS to control the MS that concern
> video applications, such as control video layout etc.
> Is it on purpose and video application requirements are under REQ-MCP-14?
>  
>  
> 
> thanks,
> 
> Adi.
> 
>  
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Dolly, Martin
> C, ALABS
> Sent: Thursday, June 22, 2006 4:22 PM
> To: [email-masked]
> Subject: [mediactrl] FW: draft-dolly-xcon-mediacntrlframe-02.txt submission
>  
> Hello,
>  
> The requirements draft has been updated per the BOF meeting notes from March
> and Roni's comments, with the exception of the architectural specific comments
> and leaving media mixing for further study.
> 
>  
> 
> Also, I would like to attend ECRIT which is during the time slot proposed for
> our July meeting.
> 
>  
> 
> Cheers,
> 
>  
> 
> Martin
> 
>  
> 
> 
> From: Dolly, Martin C, ALABS
> Sent: Thursday, June 22, 2006 9:14 AM
> To: [email-masked]
> Cc: Munson, Gary A, ALABS; 'Rafferty, James'; 'Burger, Eric'
> Subject: draft-dolly-xcon-mediacntrlframe-02.txt submission
> Internet-Drafts Administrator:
>> 
>> Please accept the submission for the following
>> 
>> individual internet draft. Please let me know if you
>> 
>> need any further help with this draft.
>> 
>> Thank you very much for your help with this I-D submission.
>> 
>> Cheers, 
>> 
>>  
>> 
>> Martin
>> 
>>  
>> 
>> Draft name: draft-dolly-xcon-mediacntrlframe-0 2 .txt
>> 
>> Abstract:
>> 
>>    This document provides requirements for a protocol, that will enable
>>    one physical entity that includes the media policy server,
>>    notification server and the focus to interact with one or more
>>    physical entities that serves as mixer or media server.  It will
>>    address all phases and aspects of media handling in a conferencing
>>    service including announcements and IVR functionality.
>>  
> 

--------------------------
Ubiquity Software does not control or endorse the content, messages or information found in this mail list and it specifically disclaims any liability with regard to these communications.
Ubiquity Software reserves the right the restrict access to any communications in violation of the Terms and Conditions of Use for this website or as otherwise deemed improper.

---

From: "Even, Roni" <[email-masked]>
Date: Tue, 5 Sep 2006 07:09:45 +0100

Hi,
Req-MCP-09 does not talk about N connections to control one conference but for example one control channel per conference on a MS that runs multiple conferences.
Roni Even

> From: [email-masked] [mailto:owner-
> [email-masked]] On Behalf Of Eric Burger
> Sent: Saturday, September 02, 2006 5:01 AM
> To: Adi Even-Tzur
> Cc: IETF mediactrl
> Subject: [mediactrl] N connections controlling 1 session
> 
> Ubiquity Software does not control or endorse the content, messages or
> information found in this mail list and it specifically disclaims any
> liability with regard to these communications.
> Ubiquity Software reserves the right the restrict access to any
> communications in violation of the Terms and Conditions of Use for this
> website or as otherwise deemed improper.