Subject: [MEDIACTRL] draft-ietf-mediactrl-ivr-control-package-04: Missing <promptinfo> in section 6.2.2

From: Jean-Francois Bertrand <[email-masked]>
Date: Tue, 17 Feb 2009 18:43:19 -0800

The example in section 6.2.2 (atop page 107) shows the <dialogexit> event without a <promptinfo> element.  If I'm correct, there should have been a <promptinfo> element since there was one prompt being played.

The valid syntax should have been like this:

   <mscivr version="1.0" xmlns="urn:ietf:params:xml:ns:msc-ivr">
    <event dialogid="vxi81">
       <dialogexit status="1" >
          <promptinfo termmode="stopped" /> <!-- is this element really missing? -->
          <collectinfo termmode="noinput"/>
       </dialogexit>
    </event>
   </mscivr>

Can you validate if this is correct?

thanks
Jean-François Bertrand, ing.
Sr. Software Designer
BroadSoft, Inc.
Montreal, Qc, Canada

---

From: "McGlashan, Scott" <[email-masked]>
Date: Fri, 20 Feb 2009 15:53:11 +0000

Yes, you are correct. Fixed in -05 version.

Thanks

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jean-Francois Bertrand
Sent: Wednesday, February 18, 2009 03:43
To: [email-masked]
Subject: [MEDIACTRL] draft-ietf-mediactrl-ivr-control-package-04: Missing <promptinfo> in section 6.2.2

thanks
Jean-François Bertrand, ing.
Sr. Software Designer
BroadSoft, Inc.
Montreal, Qc, Canada
_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl