Subject: Re: [MEDIACTRL] Questions about <join> request

From: "Victor Paulsamy" <[email-masked]>
Date: Mon, 23 Feb 2009 12:15:53 -0800

Thanks Stéphane for the clarifications; appreciate them very much. Please see below for yet another question.

Stéphane Bastien [mailto:[email-masked]] wrote on, Monday, February 23, 2009 5:57 AM
-> 
-> Hi,
-> 
-> Here is my interpretation of the mixer specification. Shoot me if I'm
-> wrong! (And I'd like to know if I'm wrong - I'm working on an
-> implementation right now).
-> 
-> See below...
-> 
-> Now, if an announcement by a MS has to be whispered to, say, participant
-> A:
-> 
-> R1. <join id1="MS" id2="conf10">
-> 	<stream media="audio" direction="inactive"/>
->     </join>
-> 
-> R2.  <join id1="MS" id2="A">
-> 	<stream media="audio" direction="sendonly"/>
->     </join>
-> ...
-> 
-> The whisper is not supposed to be heard by anyone other than A.
-> 
-> [[SB]] Then you don't join MS to conf10 at all.
-> 
Thanks. 

Is there a way in which, a 'conference mixer' could be configured (using <join>) to send media from one participant to a specific participant?

As an example, think of the 'coaching' scenario. A (customer) is supposed to be hearing only B (the agent) and not the supervisor (C); however, B to hear A+C and C to hear A+B through the conference (and not connection.)
 
Thanks in advance.

--victor

---

From: Stéphane Bastien <[email-masked]>
Date: Mon, 23 Feb 2009 12:29:15 -0800

Section 6.2.2 of draft-ietf-mediactrl-mixer-control-package-05 describes how to achieve your requirements using connections. I don't think that it is possible to do it using conferences.

-----Original Message-----
From: Victor Paulsamy [mailto:[email-masked]] 
Sent: 23 février 2009 15:16
To: Stéphane Bastien; [email-masked]
Subject: RE: Questions about <join> request

(...)

---

From: Lorenzo Miniero <[email-masked]>
Date: Mon, 23 Feb 2009 23:39:42 +0100

Hi,

actually it is possible using conferences in a somehow "creative"  
way... an example is in our call flows draft, in which we use a  
conference mixer to mix what the agent and the coach can listen to,  
and a monodirectional direct connection between the customer and the  
agent. The customer is joined to the mixer for what concerns its own  
contribution (so that both the agent and the coach can hear each other  
AND the customer), and to the agent for what it must receive (so that  
the customer can only hear the agent).

Of course the approach presented in the mixer draft is more  
straightforward, but it implies the MS supports implicit mixing, which  
our implementation currently doesn't.

L.

Quoting Stéphane Bastien <[email-masked]>:

> Section 6.2.2 of draft-ietf-mediactrl-mixer-control-package-05   
> describes how to achieve your requirements using connections. I   
> don't think that it is possible to do it using conferences.
>
> As an example, think of the 'coaching' scenario. A (customer) is   
> supposed to be hearing only B (the agent) and not the supervisor   
> (C); however, B to hear A+C and C to hear A+B through the conference  
>  (and not connection.)
>
> _______________________________________________
> MEDIACTRL mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mediactrl
> Supplemental Web Site:
> http://www.standardstrack.com/ietf/mediactrl
>

-- 
Lorenzo Miniero, Junior Researcher
Dipartimento di Informatica e Sistemistica
Universita' degli Studi di Napoli "Federico II"
Via Claudio 21 -- 80125 Napoli (Italy)
Phone: +390817683821 - Fax: +390817683816
Email: [email-masked]