Subject: [MEDIACTRL] Error in section 6.3. Other Dialog Languages (draft-ietf-mediactrl-ivr-control-package-04)

From: Jean-Francois Bertrand <[email-masked]>
Date: Tue, 3 Feb 2009 15:03:46 -0800

The example in section 6.3 Other Dialog Languages of draft-ietf-mediactrl-ivr-control-package-04 is missing the connectionid attribute in the <dialogstart> element.  Also, there are extra unmatched  " at the end of both params.  If I'm correct, the syntax should have been like below:

   <mscivr version="1.0" xmlns="urn:ietf:params:xml:ns:msc-ivr">
    <dialogstart dialogid="abcd1234gefh5678" connectionid="1234567890~abcdefghijk"
                   type="application/voicexml+xml"
                   src="http://www.example.com/mydialog.vxml"
                   fetchtimeout="15s">
     <params>
      <param name="prompt1">nfs://nas01/media1.3gp</param>
      <param name="prompt2">nfs://nas01/media2.3gp</param>
     </params>
    </dialogstart>
   </mscivr>

Can you validate if this is correct?

thanks
Jean-François Bertrand, ing.
Sr. Software Designer
BroadSoft, Inc.
Montreal, Qc, Canada

---

From: Jean-Francois Bertrand <[email-masked]>
Date: Tue, 3 Feb 2009 15:21:11 -0800

also, the second paragraph of section 6.3 states that the error 409 should be reported if the MS does not support the dialog language.  It should have been 421.

thanks
Jean-François Bertrand, ing.
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Jean-Francois Bertrand [[email-masked]]
Sent: Tuesday, February 03, 2009 6:03 PM
To: [email-masked]
Subject: [MEDIACTRL] Error in section 6.3. Other Dialog Languages (draft-ietf-mediactrl-ivr-control-package-04)

thanks
Jean-François Bertrand, ing.
Sr. Software Designer
BroadSoft, Inc.
Montreal, Qc, Canada
_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "McGlashan, Scott" <[email-masked]>
Date: Fri, 13 Feb 2009 16:04:39 +0000

Correct. Fixed in -05 version.

Thanks

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jean-Francois Bertrand
Sent: Wednesday, February 04, 2009 00:04
To: [email-masked]
Subject: [MEDIACTRL] Error in section 6.3. Other Dialog Languages (draft-ietf-mediactrl-ivr-control-package-04)

thanks

---

From: "McGlashan, Scott" <[email-masked]>
Date: Fri, 13 Feb 2009 16:08:56 +0000

Correct - I thought I had changed all of these when we revised the error codes. Oh well. Fixed in -05 version.

Thanks

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jean-Francois Bertrand
Sent: Wednesday, February 04, 2009 00:21
To: [email-masked]
Subject: Re: [MEDIACTRL] Error in section 6.3. Other Dialog Languages (draft-ietf-mediactrl-ivr-control-package-04)

thanks

thanks