Subject: [MEDIACTRL] msc-mixer package - entertone and exittone functionality?

From: Stéphane Bastien <[email-masked]>
Date: Fri, 20 Feb 2009 11:40:51 -0800

Hi,

Looking at draft-ietf-mediactrl-mixer-control-package-05, I could not find the equivalent of CCXML's entertone and exittone attributes of <join>.

I'm left with using <dialogstart> to play a tone each time a participant enters or exists a conference, which is cumbersome.

Would it be possible to add entertone and exittone attributes either to msc-mixer's <join> or <createconference> ?

Thanks,

Stéphane

---

From: Lorenzo Miniero <[email-masked]>
Date: Fri, 20 Feb 2009 21:27:06 +0100

Hi Stéphane,

just for the sake of discussion, what's cumbersome in using a dialog  
to play the tone on the conference at those events? As long as it  
works, it does the job... and from how I see it, the point of control  
packages is exactly this one, providing complementary functionality  
that don't step on each other's feet. In our call flows document we  
have a similar example, with the name of the joining user being played  
on the conference when the new participant joins. Or are you just  
concerned by the fact that this way the conference package  alone  
(e.g. without having any IVR package available) wouldn't be able to  
achieve the scenario?

Lorenzo

Quoting Stéphane Bastien <[email-masked]>:

> Hi,
>
> Looking at draft-ietf-mediactrl-mixer-control-package-05, I could   
> not find the equivalent of CCXML's entertone and exittone attributes  
>  of <join>.
>
> I'm left with using <dialogstart> to play a tone each time a   
> participant enters or exists a conference, which is cumbersome.
>
> Would it be possible to add entertone and exittone attributes either  
>  to msc-mixer's <join> or <createconference> ?
>
> Thanks,
>
> Stéphane
>
>

-- 
Lorenzo Miniero, Junior Researcher
Dipartimento di Informatica e Sistemistica
Universita' degli Studi di Napoli "Federico II"
Via Claudio 21 -- 80125 Napoli (Italy)
Phone: +390817683821 - Fax: +390817683816
Email: [email-masked]

---

From: Stéphane Bastien <[email-masked]>
Date: Fri, 20 Feb 2009 12:45:55 -0800

A new participant joining a conference with a tone being played currently looks like this:

CFW 436c6125628c CONTROL
Control-Package: msc-ivr/1.0
Content-Type: application/msc-ivr/1.0+xml
Content-Length: 367

<mscivr version="1.0" xmlns="urn:ietf:params:xml:ns:msc-ivr">
<dialogstart conferenceid="1234567890~abcdefghijk" dialogid="abcd1234gefh5678" >
<dialog repeatCount="2"> 
<prompt xml:base="http://192.168.8.44/media/en/">
<media loc="entertone.wav"/>
</prompt>
</dialog>
</dialogstart>
</mscivr>

CFW 436c6125628c 202
Timeout: 30

CFW 436c6125628c REPORT
Seq: 1
Status: terminate
Control-Package: msc-ivr/1.0
Content-Type: application/msc-ivr+xml
Content-Length: 220

<mscivr version="1.0" xmlns="urn:ietf:params:xml:ns:msc-ivr">
  <response status="200" dialogid="abcd1234gefh5678"
            conferenceid="1234567890~abcdefghijk"
            reason="dialog started"/>
</mscivr>

CFW 436c6125628c 200
Seq: 1

CFW 682232016 CONTROL
Control-Package: msc-ivr/1.0
Content-Type: application/msc-ivr+xml
Content-Length: 277

<mscivr version="1.0" xmlns="urn:ietf:params:xml:ns:msc-ivr">
  <event dialogid="abcd1234gefh5678">
    <dialogexit status="1"
                reason="Dialog completed">
      <promptinfo duration="500" termmode="completed" />
    </dialogexit>
  </event>
</mscivr>

CFW 682232016 200

CFW 682231818 CONTROL
Control-Package: msc-mixer/1.0
Content-Type: application/msc-mixer+xml
Content-Length: 150

<mscmixer version="1.0" xmlns="urn:ietf:params:xml:ns:msc-mixer">
    <join id1="1234567890~abcdefghijk" id2="123456~2345678"/>
</mscmixer>

CFW 436c6125628c 200
Control-Package: msc-mixer/1.0
Content-Type: application/msc-mixer+xml
Content-Length: 100

<mscmixer version="1.0" xmlns="urn:ietf:params:xml:ns:msc-mixer">
   <response status="200"/>
</mscmixer>

I feel that this is quite chatty. I would prefer a shorter version of the add participant operation that would look like this:

CFW 682231818 CONTROL
Control-Package: msc-mixer/1.0
Content-Type: application/msc-mixer+xml
Content-Length: 150

<mscmixer version="1.0" xmlns="urn:ietf:params:xml:ns:msc-mixer">
    <join id1="1234567890~abcdefghijk" id2="123456~2345678" entertone="y" />
</mscmixer>

CFW 436c6125628c 200
Control-Package: msc-mixer/1.0
Content-Type: application/msc-mixer+xml
Content-Length: 100

<mscmixer version="1.0" xmlns="urn:ietf:params:xml:ns:msc-mixer">
   <response status="200"/>
</mscmixer>

Thanks,

Stephane

-----Original Message-----
From: Lorenzo Miniero [mailto:[email-masked]] 
Sent: 20 février 2009 15:27
To: Stéphane Bastien
Cc: [email-masked]
Subject: Re: [MEDIACTRL] msc-mixer package - entertone and exittone functionality?

Hi Stéphane,

Lorenzo