Subject: [MEDIACTRL] draft-ietf-mediactrl-ivr-control-package-04 section 4.4.2 <auditresponse> format questions

From: Jean-Francois Bertrand <[email-masked]>
Date: Tue, 10 Feb 2009 06:33:29 -0800

I have a few questions concerning the <auditresponse> format:

1) grammartypes (section 4.4.2.2.2): the draft mentions that <grammartypes> contains a sequence of 1 or more <mimetype> and that it should not include the SRGS grammar.  This is enforced by the XSD.  This renders invalid the example in section 4.4.2.  I assume that the draft should say it is a list of 0 or more mimetype.  Can you validate this?

2) prompttypes (section 4.4.2.2.4) declaration is missing from the XSD.  In fact, it seems to have been replaced by mediatypes in the XSD.  What is the element name that should be used?

thank you for looking into this.

Jean-François Bertrand, ing.
Sr. Software Designer
BroadSoft, Inc.
Montreal, Qc, Canada

---

From: "McGlashan, Scott" <[email-masked]>
Date: Fri, 13 Feb 2009 16:41:19 +0000

1. grammartypes - text and schema should have 0 or more <mimetype>. 
2. prompttypes - revision from version -01 to -02 changed 'mediatypes' to 'prompttypes' in the text but the schema should have been changed too.

Both fixed in version -05.

Thanks

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jean-Francois Bertrand
Sent: Tuesday, February 10, 2009 15:33
To: [email-masked]
Subject: [MEDIACTRL] draft-ietf-mediactrl-ivr-control-package-04 section 4.4.2 <auditresponse> format questions

Jean-François Bertrand, ing.
Sr. Software Designer
BroadSoft, Inc.
Montreal, Qc, Canada
_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl