Subject: [MEDIACTRL] Use of <codecs> in <createconference>

From: "Victor Paulsamy" <[email-masked]>
Date: Fri, 27 Feb 2009 12:57:53 -0800

What's the use of <codecs> in <createconference> control command? How
are these related to SIP (offer/answer) negotiated codecs for the media
session?

Thanks in advance.

--victor

---

From: Stéphane Bastien <[email-masked]>
Date: Sat, 28 Feb 2009 04:35:23 -0800

You raise a good question. Here is an answer for a very basic conference scenario:

1. Media Server(MS) receives SIP INVITE with an offer SDP for a media session
2. MS sends a provisional SIP response (100 or 180) with the To tag
3. MS receives <createconference> with <codecs><codec> elements
4. MS receives <join id1="confid" id2="fromtag~totag" />
5. If the codec element from <createconference> matches one of the codec in the offer SDP, send a SIP 200 OK response with that codec in the answer SDP. Also send a successful response for the <join>

Note that this method does not work if the SIP media session was first connected to an msc-ivr dialog to retrieve a PIN number, for example. For that scenario, the MS would have to transmit a SIP re-INVITE for the media session to renegotiate the codec when it receives the <join> for the conference.

Maybe the best solution is to ignore the <codecs> element of <createconference>.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Victor Paulsamy
Sent: 27 février 2009 15:58
To: [email-masked]
Subject: [MEDIACTRL] Use of <codecs> in <createconference>

Thanks in advance.

--victor
_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl