Subject: [MEDIACTRL] "Media Control Channel Framework" clarifications needed

From: "Tebesoi Elena-B10300" <[email-masked]>
Date: Thu, 27 Aug 2009 16:14:41 +0100

Hello,
 
There are some paragraphs from draft-ietf-mediactrl-sip-control-framework-10 that I find to be ambiguous and I would appreciate if you can clarify them. 
 
1. The first observation is that the terms 'the Client' and 'the Server' are not used in a consistent way.
My understanding from the above mentioned draft is that 'the Client' role would be played by an Application Server and 'the Server' role 
corresponds to the Media Server, as it is suggested by the definitions of these two terms from chapter '2.  Conventions and Terminology'.
Considering this, how should one interpret the information presented in chapter '6.3.4.1.  Timeout Negotiation for the Initial SYNC Transaction' :
 
"The initial SYNC request allows the timeout period for the control-channel keep alive mechanism to be negotiated. The following rules MUST be followed for the initial SYNC request:
   o  If the Client initiating the SDP Offer has a COMEDIA setup
      attribute equal to active, the Keep-Alive header MUST be included
      in the SYNC message generated by the offerer.  The value of the
      Keep-Alive header SHOULD be in the range of 95 to 120 seconds
      (this is consistent with SIP Outbound[I-D.ietf-sip-outbound]).
      The client that generated the SDP "Answer" (the passive client)
      MUST copy the Keep-Alive header into the 200 response to the SYNC
      message with the same value.      .....
"      
      
The paragraph describes the negotiation of the keep alive mechanism for the control-channel. The definition for the control channel indicates it to
be a reliable connection between a Client and a Server. However, the paragraph makes no reference to a Server, but instead it talks about an active
Client and a passive Client.
 
There are several other places inside the draft where the same expression is used, implying the interaction of two Clients (e.g. 6.3.4.2.  Package Negotiation).
If this proves to be an issue, the entire document should be revised.
 
2. The second question is about the 202 Reponse Code.
The definition says: 
 " The 202 response code indicates the completion of a successful
   framework protocol transaction with additional information to be
   provided at a later time through the REPORT mechanism defined in
   Section 6.3.2."
   
And in chapter 10. Examples it says:
   
   "In this example, the Control Client establishes a control channel,
   SYNCs with the Control Server, and issues a CONTROL request that
   can't be completed within the 'Transaction-Timeout', so the Control
   Server returns a 202 response code to extend the transaction."
 
My question is: the 202 response indicates the completion of a successful transaction or that the transaction will be extended?   

Elena Tebeşoi 

Software Engineer

Freescale Semiconductor Romania

45 Tudor Vladimirescu Street, 

Tati Business Center,

Bucharest, Romania 

Tel.: +40213052219

[ x ]  Public

[  ] Freescale Semiconductor Internal Use Only

[  ] Freescale Semiconductor Confidential Proprietary

---

From: Puneet Sharma <[email-masked]>
Date: Fri, 28 Aug 2009 10:21:33 +0530

Hi Elena

I agree with your point mentioned in 1st query and think that there should be clearer description in this regard.
About 2nd query, here is my understanding of a 202 response:

In case a server is in process of successfully handling a control request from Client and while doing so its transaction timer expires (which is 4 seconds in this case), it needs to update the client regarding the receipt of request and at the same time update that this is not the final response for the underlying package request. Server should then send 202 indicating the response for CONTROL request however at the same time indicating that the transaction is yet not complete (note that REPORTs have same transaction id). The updates regarding the package request (mixer/ivr) shall follow in REPORT transactions.

This comes prominently into picture when downloading/uploading external files from/to an external server (eg: see mediactrl-ivr: 4.2.2 src, 4.3.1.5 loc).

Regards,
Puneet Sharma
Senior Software Engineer
Ph: +91 124  4176333 x 5105
Mob: +91 9811621209
A R I C E N T

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tebesoi Elena-B10300
Sent: Thursday, August 27, 2009 8:45 PM
To: [email-masked]
Subject: [MEDIACTRL] "Media Control Channel Framework" clarifications needed

Hello,

Elena Tebeşoi

Software Engineer

Tati Business Center,

Bucharest, Romania

Tel.: +40213052219

[ x ]  Public

________________________________
"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error,please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."

---

From: "Tebesoi Elena-B10300" <[email-masked]>
Date: Fri, 28 Aug 2009 08:49:27 +0100

Hello,
 
This is my understanding too, that the 202 response code does not indicate the successfull completion of a transaction (with later information to be provided...)
but instead it extends the transaction, while the final transaction result will be communicated with a REPORT message.
The definition for the 202 reponse code should be updated to reflect this.
 
10x,

Elena Tebeşoi 

Software Engineer

Tati Business Center,

Bucharest, Romania 

Tel.: +40213052219

 [  ]  Public

[x] Freescale Semiconductor Internal Use Only

From: [email-masked] [mailto:[email-masked]] On Behalf Of Puneet Sharma
Sent: Friday, August 28, 2009 7:52 AM
To: Tebesoi Elena-B10300; [email-masked]
Subject: Re: [MEDIACTRL] "Media Control Channel Framework" clarificationsneeded

Hi Elena

Regards,

Puneet Sharma

Senior Software Engineer

Mob: +91 9811621209

A R I C E N T

Hello,

      

   

 

Elena Tebeşoi 

Software Engineer

Tati Business Center,

Bucharest, Romania 

Tel.: +40213052219

[ x ]  Public