Subject: Re: Use of Service Change Address

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 11 Sep 2000 09:54:58 -0400

> And this looks like a situation where the MGC would be justified in
> initiating a new TCP connection.  Does anyone else care to comment?

Yes!  I don't think this is such a case if I understand it
(I don't think there CAN be such a case).

The problem statement is multihomed host with multiple network
addresses, and neither the MG nor the MGC redundant.

First of all, the protocol as currently defined does not have
any procedures for multihomed hosts, thus anything we discuss
here is at best some suggested behavior, at worst an extension.
Whatever is done has to be implemented in both MG and MGC,
and thus invites interoperability issues.
For this scenario, the real answer is, "use SCTP".

Second, the MG, noting that the link is dead, could request
creation of another link.

Third, I'd add a reason code to cover this case, which would
cause the MG to request a new link, to be sent over one of
the live connections.

In no case would I see the MGC initiating control associations.
That's not how the protocol is defined, and as noted, we do
not wish the MG to have to have a TCP server.

Brian
>
> > -----Original Message-----
> > From: Prashant Jain [mailto:[email-masked]]
> > Sent: Sunday, September 10, 2000 8:33 AM
> > To: [email-masked]
> > Subject: Use of Service Change Address
> >
> >
> > Hi Brian, Tom, List,
> >
> > Can the Service Change Address Parameter be used in the
> > following scenario:
> >
> > Consider MG/MGC application running over a multi-homed host
> > with a single copy
> > or multiple redundant copies of TCP/IP
> > Stack in the case of IP networks. Here it is assumed that
> > MG/MGC application do
> > not support redundancy at their level.
> >
> > Now, if any network interface card or an active copy of
> > TCP/IP Stack fails,
> > System management running in the system may wish to
> > change the local ID i.e. may use another card  or use the
> > standby copy with
> > different IP address configured for it.  In this scenario, protocol
> > must  specify a way to communicate this information (of Local
> > Address Change) to
> > the other entity without breaking the existing association.
> >
> > As per the current text of the protocol,  can we send a
> > Service Change Request
> > to the other entity with DISCONNECTED method, Service Change
> > Reason as  "Loss of
> > Lower Layer Connectivity" and Service Change Address as the
> > new specified local
> > address to take care of the above scenario.
> >
> > Please do reply.
> >
> > Prashant Jain
> > HUghes Software Systems
> >
>

---

From: Chuong Nguyen <[email-masked]>
Date: Mon, 11 Sep 2000 16:32:39 -0500

> not wish the MG to have to have a TCP server.

Tom,
I am from the MGC side and I agree w/Brian that MG should not have a TCP
server.
With the defintion of Service Change Methods as defined, I don't see any
scenario that would require
MG to have a TCP server.

There was a discussion back sometimes about lost MG.
It would save time if MGC knew that the MG has lost
it connections and was hopelessly searching through it lists of MGC to
try.
It would have been quicker for MGC to establish a connection to MG to tell
it which MGC can
service the lost MG.
But this somehow violates the original intend of MG going through it lists
of MGC to try in
trying to initiate a control associations w/an MGC.

For v1, can't we just decide that MG does not have TCP server?
IF a need does arise later, it can be changed.
Maybe I am wrong but I don't see any backward compatability issue if a
change is required later.

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****