Subject: Re: packages

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 28 Sep 2000 10:38:33 -0400

The functions needed in any gateway are a complex set of interdependencies.
As a simple example, some residential gateways will have DTMF detect,
and call progress generate, while others won't.  When you have an MG
that doesn't, you need another MG (a tones and announcements generator,
possibly co-existing with a dial "register" DTMF detector) somewhere in
the network.

These kinds of decisions are defined in profiles.  If you look at the
MSF profiles (see www.msforum.org) (sorry, I'm off line right now
and can't cite the actual URL to the profile), you will see lists like
these for a particular type of gateway, with a particular set of assumptions
on network elements, underlying network infrastructure, etc.

Brian

> -----Original Message-----
> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Wednesday, September 27, 2000 6:55 PM
> To: [email-masked]
> Subject: Re: packages
>
>
> Looks reasonable to me, except that you probably need the TDM
> package in the
> access gateway too.
>
> > -----Original Message-----
> > From: Isabelle Cnudde [mailto:[email-masked]]
> > Sent: Friday, September 15, 2000 6:30 PM
> > To: [email-masked]
> > Subject: packages
> >
> >
> > Hi ,
> >
> > MEGACO defines several packages.
> > Could one tell me which ones are required in a trunking gateway and
> > which ones are required in an access gateway?
> >
> > What do you think of the following split?
> >
> > Packages for trunking GW:
> >     . Generic package
> >     . Base Root package
> >     . Basic Continuity package
> >     . Network package
> >     . RTP package
> >     . TDM Circuit package
> >
> > Packages for access GW:
> >     . Generic package
> >     . Base Root package
> >     . Basic Continuity package
> >     . Network package
> >     . RTP package
> >     . Tone Detection
> >     . Tone Generator
> >     . Basic DTMF Detector
> >     . Basic DTMF Generation
> >     . Call Progress Tones Generator
> >     . Call Progress Tones Detection
> >     . Analog Line Supervision
> >
> > Thanks for sharing your ideas/comments,
> > Isabelle
> >
>

---

From: Garland Sharratt <[email-masked]>
Date: Thu, 28 Sep 2000 08:39:52 -0700

"Rosen, Brian" wrote:

> As a simple example, some residential gateways will have DTMF detect, and call
> progress generate, while others won't.  When you have an MG that doesn't, you
> need another MG (a tones and announcements generator, possibly co-existing
> with a dial "register" DTMF detector) somewhere in the network.

In other words, a Media Server.

> [...]
> > package in the access gateway too.
> >
> > [...]

---

From: Carol Waller <[email-masked]>
Date: Thu, 28 Sep 2000 16:21:38 -0500

The MSF URLs that Brian was looking for are:

Access Gateway/Controller:
http://www.msforum.org/MSF-MEDIA-001.00-DRAFT_IA.doc
Trunking Gateway/Controller:
http://www.msforum.org/MSF-MEDIA-002.00-DRAFT_IA.doc

These are early draft versions (and there are still several holes in them);
in most places where there is still questions or controversy, we've tried to
capture it in a comment.

Carol Waller
Advisory Engineer
Next Generation Control, WorldCom
972-729-1586
pager: 888-268-0257

>From: Media Gateway Control (megaco)
>[mailto:[email-masked]]On Behalf Of Rosen, Brian
>Sent: Thursday, September 28, 2000 9:39 AM