Subject: Properties in packages

From: Nurit Shenhar <[email-masked]>
Date: Tue, 19 Sep 2000 16:42:53 +0200

Hi

Can anyone tell me where the properties from the 'root' package should be
defined? the only one that has a specific definition is the
MaxTerminationsPerContext property. (In TerminationState).

Best regards

Nurit Shenhar
AudioCodes Ltd.
Direct: +972-3-539-4155
Tel:     +972-3-539-4000
Fax:    +972-3-539-4040
email:  [email-masked]

web:    <http://www.audiocodes.com>

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 19 Sep 2000 09:49:24 -0400

Root has packages implemented on it, which define the properties.
In Annex E, there is only one package defined on root, which has one
property.
It's possible (likely) that additional packages will be defined that add
properties to root, if implemented on a particular gateway.

Brian

> -----Original Message-----
> From: Nurit Shenhar [mailto:[email-masked]]
> Sent: Tuesday, September 19, 2000 10:43 AM
> To: [email-masked]
> Subject: Properties in packages
>
>
> Hi
>

---

From: Nurit Shenhar <[email-masked]>
Date: Wed, 20 Sep 2000 10:07:12 +0200

Hi

Sorry, my question wasn't clear enough. I will try again:

The current root package in Annex E defines 5 properties:

- MaxNrOfContexts
- MaxTerminationsPerContext
- normalMGExecutionTime
- normalMGCExecutionTime
- ProvisionalResponseTimeValue

For the second one, (MaxTerminationsPerContext) it is stated:
'Defined in: TerminationState'

This properties are something that the MG and MGC should nagotiate between
tham. For example, MaxNrOfContexts should be the lowest value between the MG
and MGC default values. So what I would like to know is:

1. Are all those five properties will be sent in the TerminationState
descriptor?
2. Is there any meaning in getting a new value for a specific termination,
or should this values be modified only for the NULL context and ROOT
termination?

thenks
Nurit

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Tuesday, September 19, 2000 3:49 PM
To: [email-masked]
Subject: Re: Properties in packages

Brian

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 20 Sep 2000 08:51:04 -0400

> and MGC default values. So what I would like to know is:
Stop right there.  The MG determines MaxNrContexts and
MaxTerminationsPerContext. It isn't negotiated.  On the other
hand, the MGC doesn't need to use that many, it can use less
than the MG would allow.  That isn't negotiation.

MGs will set normalMGCexecutionTime, MGCs will set normalMGCexecutiontTime.
They aren't negotiated, but the
MGC can modify the MG's normalMGexecutionTime.
The MG can't issue Modify, so it can alter the MGC's values.

ProvisionalResponseTimer values are also not negotiated,
but again the MGC can lower the MGs value.

> 1. Are all those five properties will be sent in the TerminationState
Yes.  They are all not significant to StreamId, so they are
defined in TerminationState

> or should this values be modified only for the NULL context and ROOT
The package is defined only on ROOT, and ROOT can't be in any
context other than NULL, so you can't use this package in
any context other than NULL.