Subject: Re: Descriptor intrepretation in Move.

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 15 Sep 2000 10:50:45 -0400

I believe the termination's descriptors retain their current
value on a Move.

Brian

> -----Original Message-----
> From: Madhu Babu [mailto:[email-masked]]
> Sent: Friday, September 15, 2000 10:12 AM
> To: [email-masked]
> Subject: Descriptor intrepretation in Move.
>
>
> When termination T1 is moved from Context C1 to C2 what will
> be the descriptors
> that are valid for this termination in new context. There are
> two sections in
> the protocol that address this in two different ways. In
> section 6.2.4 first
> paragraph its said that "If not provisioned Otherwise, all
> descriptors except
> TerminationState and LocalControl default to empty/"no value"
> when a Termination
> is first created or returned to the null context". From this it can be
> understood that the same descriptors will be retained when
> moved to the new
> context. But in section 7.2.4  second paragraph mentions that
> "By convention,
> the Termination is subtracted from its previous Context".
> Does this mean that
> only the new descriptors provided in the Move command will be
> applicable and not
> the old ones?
> Regards
> -Madhubabu
> Hughes Software System.
>

---

From: Michael Brown <[email-masked]>
Date: Fri, 15 Sep 2000 16:39:01 -0400

I agree that is right. I had a co-worker ask that same question of me a few
days ago because of the use of the word subtract in the text. Perhaps a
clarification in the implementer's guide would be in order. Any changes to
the descriptors would be handled by the MGC based on it's knowledge of the
context to which the termination is moved.

Michael