Subject: Question on AuditValue

From: SSM <[email-masked]>
Date: Wed, 6 Sep 2000 19:22:30 +0530

Hi,
In case of a AuditValue command with (reference: table in 7.2.5 )
ContextID = ALL
TerminationID = Root,
the AuditReply should list all the contextIds .

If we see the ASN.1 for AuditReply, there is no provision for contextId
list .

    AuditReply ::= SEQUENCE
   {
        terminationID           TerminationID,
        auditResult             AuditResult,
        ...
   }

   AuditResult ::= CHOICE
   {
        contextAuditResult      TerminationIDList,
        terminationAuditResult  TerminationAudit
   }

So how can this be achieved ?

Thanks in advance
-sanjeev

---

From: Christian Groves <[email-masked]>
Date: Thu, 7 Sep 2000 10:31:22 +1100

G'Day Sanjeev,

I posted an email highlighting the same problem a few days ago. Its the
same for the ABNF.
Subject: Context List in H.248
Date: Mon, 4 Sep 2000 18:58:42 +1100

I think this is a fault, but there was a reply that v2 would do this.
Even if v2 does this then it is an inconsistency.

Cheers, Christian