Subject: Re: EventID for DigitMap Completion Event

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 18 Sep 2000 13:26:58 -0400

Wow, I believe you are correct.

Others, would you not agree this is a genuine bug,
which needs to be fixed in order to use the protocol?

This also implies we need wording (starting in the
Implementer's Guide).  The current document does state:
"An extended package shall not redefine or overload
a name defined in the original package. "  Perhaps
just changing "name" to "identifier" would be sufficient.
I'll note that the text could also be clearer about
not redefining an id in "earlier" packages, when multiple
levels of extension occur.

I would note that it IS okay to duplicate ids in parallel
extensions (B extends A and C extends A -- both B and C
could have the same ids that mean something different).
Packages SHOULD NOT do this, but it can be unavoidable,
because packages can be developed in parallel without
knowledge of id overlap.

Brian

> -----Original Message-----
> From: J Ramachandra [mailto:[email-masked]]
> Sent: Monday, September 18, 2000 4:20 AM
> To: [email-masked]
> Subject: EventID for DigitMap Completion Event
>
>
> Section E.6.2 under DTMF detection (dd) Package, specifies EventID as
> 0x0001 for DigitMap Completion Event (ce). But, dd extends tonedet
> package which has the same value assigned to Start Tone detected event
> (std). With the earlier discussion on 'Package Extension' methodology,
> the preferred method for representing std event in dd package
> is dd/std.
> This will clash with dd/ce, when BINARY representation is used.
>
> Is it not better to use any other unused values for ce (Probably
> 0x0004)?
>
>
> Regards,
>
> - J K Ramachandra
>   ipGen Inc.
>

---

From: "Lien, Yan Tsung" <[email-masked]>
Date: Tue, 19 Sep 2000 09:26:18 +0800

Hi;
        In MGCP, there is a call ID parameter used to associate two
connections belong to the same call.
    In MEGACO/H.248, which parameter is used to associate two contexts
belong to the same call!

---

From: Christian Groves <[email-masked]>
Date: Mon, 25 Sep 2000 07:57:36 +1100

G'Day all,

Below is the text I intend putting in the implementor's guide.

8.7 Clarification on extending packages

Description:    An extended package shall not redefine or overload an
identifier defined in the original package. For example: if package "aa"
has a signal "ab", then if package "bb" extends aa it cannot define
signal "ab".  This is also valid for not redefining an id in "earlier"
packages, when multiple levels of extension occur.
Several packages in H.248 Annex E have made this error. Corrections are
below.
Reference:      Subject: Re: EventID for DigitMap Completion Event
Date: Mon, 18 Sep 2000 13:26:58 -0400
From: "Rosen, Brian" [email-masked]
To: [email-masked]
 [Begin Correction]
Section 12.1.1 Package
A package may extend an existing package. The version of the original
package must be specified. When a package extends another package it
shall only add additional Properties, Events, Signals, Statistics and
new possible values for an existing parameter described in the original
package. An extended package shall not redefine or overload an
identifier defined in the original package. This shall also not occur
when multiple levels of extensions occur. Hence, if package B version 1
extends package A version 1, version 2 of B will not be able to extend
the A version 2 if A version 2 defines a name already in B version 1.
[End Correction]
[Begin Correction]
Section E.6.4 Events
DigitMap Completion Event
EventID: ce, 0x0004    <<<<<<<<<<<<<<<change
Generated when a digit map completes as described in section 7.1.14.
[End Correction]
[Begin Correction]
Section E.7.3

Signal Name     Signal ID/tone id
Dial Tone       dt (0x0030)
Ringing Tone    rt (0x0031)
Busy Tone       bt (0x0032)
Congestion Tone ct (0x0033)
Special Information Tone        sit(0x0034)
Warning Tone    wt (0x0035)
Payphone Recognition Tone       prt (0x0036)   <<<<<<<<<<<<<<change
Call Waiting Tone       cw (0x0037)
Caller Waiting Tone     cr (0x0038)

[End Correction]