Subject: Case sensitive DigitMap symbols?

From: Dave Sclarsky <[email-masked]>
Date: Fri, 22 Sep 2000 16:39:21 -0400

Hello,

I have questions about the use of lower case letters as DigitMap symbols.

First of all, there is a conflict between the text and the ABNF:

o The text description (7.1.14.3) allows
  symbols "A" through (at most) "K" as digit
  map symbols, but doesn't mention the lower
  case letters.

o The ABNF in B.2 defines 'digitMapLetter'
  to allow %x41-4B or %x61-6B.

Second, the DTMF detection package uses case in a
confusing way:

o The DTMF 'tone id' to Event Symbol table in
  E.6 allows "*" to be represented as either
  "E" or "e", and "#" to be represented as either
  "F" or "f".

o DigitMap Completion Events in E.6 define the
  possible values in a DigitString to be "A"
  through "F".

Is there some reason to allow lower case in digit maps?

Shouldn't the DTMF detection package define a one to one
mapping of 'tone id's to event symbols?

The combination of these rules make it difficult for
an MG to implement 7.1.14.5 number 3, where it says
that each event 'is mapped to a digit string symbol',
especially for the "*" and "#" events, unless I am
missing something!

Thanks,
============================
Dave Sclarsky
System Architect, Access Technology
S-Link Corporation
520 Fellowship Road, Suite C-304
Mt. Laurel, NJ 08054
[email-masked]
voice:856.642.9229 fax:856.642.0252
www.ss7-link.com

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 22 Sep 2000 17:03:40 -0400

Except for the case of SDP in local/remote,
the entire protocol is case insensitive.
I'll support expanding the wording in 7.1.14.3 and
E.6 to include the lower case values.

Brian

> -----Original Message-----
> From: Dave Sclarsky [mailto:[email-masked]]
> Sent: Friday, September 22, 2000 4:39 PM
> To: [email-masked]
> Subject: Case sensitive DigitMap symbols?
>
>
> Hello,
>

---

From: Dave Sclarsky <[email-masked]>
Date: Fri, 22 Sep 2000 18:57:15 -0400

Brian,

Thanks for the response.  I apologize, but I haven't
seen a clause that says the protocol is case insensitive.
Does this refer to the text encoding, or is it a blanket
statement covering all aspects of the protocol?

DaveS.

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Friday, September 22, 2000 5:04 PM
To: [email-masked]
Subject: Re: Case sensitive DigitMap symbols?

Brian

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 25 Sep 2000 09:24:46 -0400

Annex B references RFC2234, which states:

        ABNF strings are case-insensitive and
        the character set for these strings is us-ascii.

The text used to state this as a comment in the ABNF, but
somewhere that got lost.

Brian

> From: Dave Sclarsky [mailto:[email-masked]]
> Sent: Friday, September 22, 2000 6:57 PM
> To: Rosen, Brian; [email-masked]
> Cc: img
> Subject: RE: Case sensitive DigitMap symbols?
>
>
> Brian,
>

---

From: Dave Sclarsky <[email-masked]>
Date: Mon, 25 Sep 2000 09:38:59 -0400

Brian,

Thanks again.  That clarifies it for me!

Does this qualify for a note in the implementors guide???

DaveS.

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Monday, September 25, 2000 9:25 AM
To: [email-masked]
Subject: Re: Case sensitive DigitMap symbols?

Brian

---

From: Dave Sclarsky <[email-masked]>
Date: Mon, 25 Sep 2000 17:23:24 -0400

Brian,

Sorry I couldn't let this go, but I went looking
in RFC2234.  The problem with digitMapLetter is
that it doesn't use a case-insensitive ABNF string
to specify A-K.  (It does for the wildcard "x" and the
event qualifiers "L" "S" and "Z".)

Here is some more from 2234:

To specify a rule which IS case SENSITIVE,
 specify the characters individually.

 For example:
     rulename    =  %d97 %d98 %d99
 or
     rulename    =  %d97.98.99

   will match only the string which comprises only lowercased
   characters, abc.

The ABNF "Value Range Alternatives" says that it can be used
to specify "A range of alternative numeric values".  I guess this
precludes something simple like "A"-"K", which could be case insensitive.

It looks like the only way to do what we want in ABNF is to spell out
all of the alternatives (i.e. "A" / "B" / "C" etc.).

Or, maybe a comment saying that "%x41-4B denote the same events as %61-6B"
would be enough?

DaveS.

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Monday, September 25, 2000 9:25 AM
To: [email-masked]
Subject: Re: Case sensitive DigitMap symbols?

Brian

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 26 Sep 2000 08:54:02 -0400

I suppose it's all in how you interpret the
                   / %x41-4B / %x61-6B ; a-k, A-K
line.  I interpret it as being case insensitive

I think we clearly need some text stating that in
unambiguous language.

Brian

> Sent: Monday, September 25, 2000 5:23 PM

---

From: Tom-PT Taylor <[email-masked]>
Date: Wed, 27 Sep 2000 17:13:23 -0400

It's a matter of my being too careful when I rewrote the original syntax.  I
wanted to make it clear that the digit map was case-insensitive.

> Sent: Tuesday, September 26, 2000 8:54 AM