Subject: Re: H248v1 formerly Re: H.248v2 [was Re: Can MGC modify term in N ULL Context ?]

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 20 Sep 2000 14:23:56 -0400

This may be as good a time as any to start the discussions of
how we deal with the IETF "drop unimplemented features" and the
ITU "backwards compatibility must be maintained" issues.

I believe this is going to take negotiation, will be "decided"
by folks higher up the management chain then us down here,
but will benefit from all of us discussing the issues on the list.

I too do not want to see divergence, so I wish to:
        Get Megaco rechartered to stay working with ITU on
                new versions
        Come to agreement on exactly how the process will work
                as the protocol matures.

I do want to see the Proposed Standard mature to full Standard.
New RFCs will be issued (which are like versions, whether you
call them that or not).  Likewise in ITU, there are new versions that
reflect maturation of ideas.

Brian

> -----Original Message-----
> From: Michael Thomas [mailto:[email-masked]]
> Sent: Wednesday, September 20, 2000 12:44 PM
> To: [email-masked]
> Subject: H248v1 formerly Re: H.248v2 [was Re: Can MGC modify term in
> NULL Context ?]
>
>
> One basic problem is that IETF doesn't have "versions"
> per se. In the same period of time, the current proposed
> standard should be advancing to draft standard with
> the normal IETF'ism of deleting unused features, etc,
> etc. Unless a proposed standard recycles itself back
> as a new proposed standard, there is no way to add a
> bunch of new features, etc.
>
> If SG16 goes off and creates a new version which is
> not using the same criteria, something has got to
> give: either MEGACO and SG16 keep cooperating such
> that both produce a standard which will become a
> full IETF internet standard, or they diverge.
>
> I share Flemming's concern here. Without a great
> deal of explict understanding and resolution of
> how both IETF and ITU processes can be
> simultaneously satisfied (and there are challenges
> on the IETF side as well), the end result will
> be divergence which would have made this entire
> joint effort mostly a waste.
>
>              Mike
>
> Christian Groves writes:
>  > G'Day Flemming,
>  >
>  > I don't see why you have a hard time following this logic.
>  >
>  > The work on H248v2 has just started. No one has been
> excluded from this,
>  > especially the IETF. The Working Group Chair was at the
> SG16 meeting
>  > where this occured. I believe that its a decision for the
> IETF if it
>  > wants to be involved. I gather some sort of charter change would be
>  > required.
>  >
>  > We have probably at least 14 months before we decide on
> H248v2 so there
>  > is plenty of scope for other parties to be involved and
> the logistics of
>  > this involvement sorted out.
>  >
>  > Regards, Christian
>  >
>  > Flemming Andreasen wrote:
>  > >
>  > > Christian Groves wrote:
>  > >
>  > > > G'Day Flemming,
>  > > >
>  > > > No there will be one protocol(H.248, Megaco) with 2
> versions. Version 2
>  > > > following version 1. Version 2 work is just starting
> and will go
>  > > > probably for another year thus giving "the ink" plenty
> of time to dry
>  > > > before we have version 2 ready. No body has been from
> giving input to
>  > > > this work.
>  > >
>  > > I'm having a hard time following this logic. As we gain
> experience with v1, the IETF
>  > > presumably will want to advance it to Draft and Internet
> standard, yet meanwhile the ITU
>  > > will work on a successor, without the involvement of the
> IETF. Thus, for all practical
>  > > purposes, you have just declared the joint v1 protocol
> an interim ITU-T solution as they
>  > > move along on their own with v2. Maybe our WG chair or
> AD can clarify what the point with
>  > > the cooperation was and where that leaves Megaco v1 as
> compared to H.248v2 ?
>  > >
>  > > Thanks
>  > >
>  > >         Flemming
>  > >
>  > > >
>  > > >
>  > > > Regards, Christian
>  > > >
>  > > > Flemming Andreasen wrote:
>  > > > >
>  > > > > The ink is barely dry on v1 and we all went through
> tremendous efforts to ensure that
>  > > > > the IETF and ITU-T would develop a single protocol.
> Am I to understand it was a wasted
>  > > > > effort as there now will be two protocols after all
> ? Where does this leave Megaco ?
>  > > > >
>  > > > > -- Flemming
>  > > > >
>  > > > > Christian Groves wrote:
>  > > > >
>  > > > > > G'Day Flemming,
>  > > > > >
>  > > > > > Its the version after H.248v1 and SG16 are working on it.
>  > > > > >
>  > > > > > Cheers, Christian
>  > > > > >
>  > > > > > Flemming Andreasen wrote:
>  > > > > > >
>  > > > > > > Question for clarification here:
>  > > > > > >
>  > > > > > > Exactly what is H.248v2 and who is working on it ?
>  > > > > > >
>  > > > > > > -- Flemming
>  > > > > > >
>  > >
>  > > <snip>
>  > >
>  > > --
>  > > Flemming Andreasen
>  > > Cisco Systems
>  >
>

---

From: Christian Groves <[email-masked]>
Date: Mon, 25 Sep 2000 03:05:45 +1100

G'Day all,

I completely support Brian on his comments. Lets move this forward in
this forward in a positive way and discuss the issues that were raised.
Tom, do you have any thoughts on a way to address this?

Cheers, Christian