Subject: Re: Transaction Reply Context=ALL, wilcard response

From: Christian Groves <[email-masked]>
Date: Tue, 5 Sep 2000 13:27:42 +1100

G'Day Tom,

Yes I mean to w-

Cheers, Christian
>
> Tom-PT Taylor wrote:
> >
> > What do you mean by "wildcard response"?  That you precede the command
> > with a "W-"?
> >
> > > -----Original Message-----
> > > From: Christian Groves [mailto:[email-masked]]
> > > Sent: Sunday, September 03, 2000 9:23 PM
> > > To: [email-masked]
> > > Subject: Transaction Reply Context=ALL, wilcard response
> > >
> > >
> > > G'Day all,
> > >
> > > Perhaps someone can provide a clarification.
> > >
> > > In the scenario where I do a
> > > SUB(Context=ALL,Termination=?,),Wildcard-response.
> > >
> > > Do I get in the transaction reply?
> > >
> > > a)   a single TransactionReply[SUB(Context=ALL,Termination=?)]
> > >
> > > or
> > >
> > > b)   multiple commands replies
> > >        TransactionReply[SUB(Context=1,Termination=?),
> > >                         SUB(Context=2,Termination=?)
> > >                         :
> > >                         SUB(Context=*,Termination=?)
> > >
> > > There's some ambiguity in the text.
> > >
> > > Cheers, Christian
> > >

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 5 Sep 2000 08:13:58 -0400

>         The example given below shows multiple Statistics
> descriptors in
> the descriptor list for a command reply. I believe,
> the common understanding is that only the digit map descriptor and the
> error descriptors are the only two descriptors
> which can be repeated.
I have no idea of where that idea came from, I think it's incorrect

>If other descriptors can also be repeated, then
> we can have multiple Mux descriptors, if the
> MG supports multiple MUX types.
Yes

> Also since it is not feasible to take the union of SDP definitions in
> local and remote descriptors, I guess we can even have
> multiple local and remote descriptors , or do we put them as multiple
> SDP definitions in the same local/remote descriptor.
This might be open to interpretation.  I'd prefer if you actually did
send the union of the SDP, but I'd be willing to support other
ideas.  I do think if you get separate SDP, then you get multiple
local/remote descriptors in one media statement (if you audited Media).