Subject: Re: Can MGC modify term in NULL Context ?

From: Sandeep Gautam <[email-masked]>
Date: Mon, 11 Sep 2000 15:46:20 +0530

---------------------- Forwarded by Sandeep Gautam/HSS on 09/11/2000 03:43 PM
---------------------------

Sandeep Gautam
09/11/2000 11:59 AM

To:   "Rosen, Brian" <[email-masked]>
cc:

Subject:  Re: Can MGC modify term in NULL Context ?  (Document link not
      converted)

Hi,

>> Now we have defined "default" to be what the package definition
>>says it should be.

Does 'default' refer to values as defined in packages...or do they refer to the
values as provisioned on the termination ( by lets say an operator sitting on
MG). For eg. when Tom mentioned that the correct way to deal with the Echo
Cancellation problem was to set the provisioned value to 'off' for that
termination, isnt it obvious that a termination would revert back to this
'provisioned' value after subtarct rather than the default 'on' as mentioned in
the package?

Or does this provisioned value becomes default for it?

Thanx and regards,
Sandy G

"Rosen, Brian" <[email-masked]> on 09/09/2000 02:26:22 AM

Please respond to "Rosen, Brian" <[email-masked]>

To:   [email-masked]
cc:    (bcc: Sandeep Gautam/HSS)

Subject:  Re: Can MGC modify term in NULL Context ?

Now we have defined "default" to be what the package definition
says it should be.

Let's take, for example, tdmc/ec.  Suppose the MGC wanted to "permanently"
disable echo cancel on a termination.  It sets
tdmc/ec off in null context, and it stays off, unless the MGC
turns it on for a particular call.

I don't believe we ever changed that behavior, so somehow we
screwed up the words.  Here is what the text used to say:

"When a Termination is created, properties get their default values, unless
the controller specifically sets a different value.  The default value of a
property of a physical Termination can be changed by setting it to a
different value when the Termination is in the null Context.  Every time
such a Termination returns to the null Context, the values of its properties
are reset to this default value"

Brian

> -----Original Message-----
> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Friday, September 08, 2000 3:35 PM
> To: [email-masked]
> Subject: Re: Can MGC modify term in NULL Context ?
>
>
> Sorry, I have to contradict you on the second item.  See the last few
> sentences of section 7.2.3.
>
> > -----Original Message-----
> > From: Rosen, Brian [mailto:[email-masked]]
> > Sent: Friday, September 08, 2000 2:36 PM
> > To: [email-masked]
> > Subject: Re: Can MGC modify term in NULL Context ?
> >
> >
> > > The question is that does the MG allow the MGC to change
> the package
> > > property values associated with a termination in NULL context ??
> > For a physical termination, yes, absolutely
> >
> > >
> > > And, if the answer is yes does this change the default values of
> > > the package properties associated with the termination.
> > > OR, does it only modify the properties temporarily for now. If the
> > > termination is subsequently added and subtracted to and from
> > > a context,
> > > respectively the property values change to the default values
> > > before MGC modified them in NULL context.
> > It changes the current value, and the termination returns to
> > this value when it is subtracted.  You can think of this as
> > changing the default value, although it's volatile.
> >
> > Brian
> >
>

---

From: John Segers <[email-masked]>
Date: Mon, 11 Sep 2000 13:12:18 +0200

Sandeep,

Packages may specify default values for properties.  Provisioning may
override these default values.  The final paragraph of section 7.2.3
specifies this behavior.

Cheers,

John

--
John Segers                                  email: [email-masked]
Lucent Technologies                                        Room HE 303
Dept. Forward Looking Work                      phone: +31 35 687 4724
P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954