Subject: Re: Audit of Packages

From: Madhu Babu <[email-masked]>
Date: Mon, 11 Sep 2000 23:38:49 +0530

hi Brian,
the second point raises some confusion. If wildcard union response is intended
then MGC can use the switch "W-" token in the command request itself. This
serves two purposes. First  (if "W-" is present) to enable generation of
Wildcard Union response from MG  and second (without "W-") to send multiple
responses from MG with each termination and the associated packages supported in
each of the responses. The table given in Audit value command sec 7.2.5 seems to
address the same (ContextId=NULL TerminationID=ALL, Information obtained is
"Audit of all terminations in NULL context"). Is this understanding correct??
-Madhu Babu
Hughes Software Systems.

"Rosen, Brian" <[email-masked]> on 09/11/2000 09:09:01 PM

Please respond to "Rosen, Brian" <[email-masked]>

To:   [email-masked]
cc:    (bcc: Madhu B Babu/HSS)

Subject:  Audit of Packages

In some private correspondence, there was some continuing
confusion on auditValue of Packages.  Here is my current
understanding:

1. If you audit ROOT, using NULL context, you get the list
of Packages implemented on ROOT. You don't get Packages
implemented on any other terminations.

2. If you audit ALL, using NULL context, you get the union of
packages implemented on any termination in NULL.  Since, right
after boot, all terminations are in NULL, this is the normal
way you get the list of packages implemented on the gateway.
A notable side effect:
        ROOT is not in ALL.
        Therefore, Context=-{AuditValue=*{Audit{Packages}}}
                DOES NOT get you packages implemented on ROOT

3. If you audit ALL, using ALL context, you get the union
of packages implemented on any termination in any Context other
than NULL.  You would do this if you needed the packages list
when some terminations were in contexts other than NULL.

Please note that if you ask for an audit of ALL in ALL, and there
are no terminations in Contexts other than NULL, you get an
error (431 - No TerminationID matched a wildcard).

Is that everyone else's understanding?

Brian

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 11 Sep 2000 14:35:45 -0400

Yes, I'm sorry I introduced confusion -- to get the UNION
of packages implemented on a wildcarded terminationId,
including ALL, you need to use wildcard response (W-).
If you don't, you get a response for each terminationId
matched.

Brian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, September 11, 2000 2:09 PM
> To: Rosen, Brian
> Cc: [email-masked]
> Subject: Re: Audit of Packages
>
>
>
>
> hi Brian,