Subject: Re: Transaction Reply Context=ALL, wilcard response

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 5 Sep 2000 13:50:04 -0500

I always understood the intent of "W-" to mean that the response would show
unions at the most atomic level (i.e. per-parameter).  In other words, it
was meant to show the range of values supported, not something intelligible
on a per-session basis.  I have to admit that it isn't necessarily clear
what a "parameter" is in SDP (i.e.) would all "a=fmtp:" be collapsed into
one list?

> -----Original Message-----
> From: Shalini Philip [mailto:[email-masked]]
> Sent: Tuesday, September 05, 2000 4:21 AM
> To: [email-masked]
> Subject: Re: Transaction Reply Context=ALL, wilcard response
>
>
> Hello Brian, Christian & list.
>
>         The example given below shows multiple Statistics
> descriptors in
> the descriptor list for a command reply. I believe,
> the common understanding is that only the digit map descriptor and the
> error descriptors are the only two descriptors
> which can be repeated. If other descriptors can also be repeated, then
> we can have multiple Mux descriptors, if the
> MG supports multiple MUX types.
> Also since it is not feasible to take the union of SDP definitions in
> local and remote descriptors, I guess we can even have
> multiple local and remote descriptors , or do we put them as multiple
> SDP definitions in the same local/remote descriptor.
>
> Thanks & Regards,
>   Shalini Philip.
>
>
> "Rosen, Brian" wrote:
>
> >  I don't think you can do a subtract with CHOOSE.
> > You could use ALL, but not choose.
> >
> > If you ask for a wildcard response, I think you get one response per
> > value found, if they are different.  Since you get statistics on
> > results, any identical statistics reports would only be
> > repeated once.  So. assuming you used ALL, I'd expect:
> > C=1{Subtract=*{Statistics{...}, Statistics{...}....}.
> > C=2{...
> > ....
> >
> > -----Original Message-----
> > From: Christian Groves
> > To: [email-masked]
> > Sent: 9/3/00 9:22 PM
> > Subject: Transaction Reply Context=ALL, wilcard response
> >
> > G'Day all,
> >
> > Perhaps someone can provide a clarification.
> >
> > In the scenario where I do a
> > SUB(Context=ALL,Termination=?,),Wildcard-response.
> >
> > Do I get in the transaction reply?
> >
> > a)   a single TransactionReply[SUB(Context=ALL,Termination=?)]
> >
> > or
> >
> > b)   multiple commands replies
> >        TransactionReply[SUB(Context=1,Termination=?),
> >                         SUB(Context=2,Termination=?)
> >                         :
> >                         SUB(Context=*,Termination=?)
> >
> > There's some ambiguity in the text.
> >
> > Cheers, Christian
> >
> > Notice to Recipient:
> > This message is intended only for the use of the Addressee
> > and may contain information that is proprietary and confidential
> > and/or privileged by law. If you received this e-mail in error,
> > any review, use, dissemination, distribution or copying of this
> > e-mail is strictly prohibited. If you have received this e-mail in
> > error, please notify us immediately of the error by return e-mail
> > and please delete this message and all attachments from your system.
> > Thank you.
>
> --
> Regards,
>
> Shalini Philip
> Globespan Inc.
> E-Mail : mailto:[email-masked]
> Web    : http://www.globespan.net
>

---

From: John Segers <[email-masked]>
Date: Wed, 6 Sep 2000 11:10:07 +0200

Tom,

This is my understanding as well.  Relevant text appears in section
6.2.2:
        If individual responses are not required, a wildcard response
        may be requested.  In such a case, a single response is
        generated, which contains the UNION of all of the individual
        responses which otherwise would have been generated, with
        duplicate values suppressed.  For instance, given a Termination
        Ta with properties p1=a, p2=b and Termination Tb with
        properties p2=c, p3=d, a UNION response would consist of a
        wildcarded TerminationId and the sequence of properties p1=a,
        p2=b,c and p3=d.

Cheers,

John

--
John Segers                                  email: [email-masked]
Lucent Technologies                                        Room HE 303
Dept. Forward Looking Work                      phone: +31 35 687 4724
P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954

---

From: Christian Groves <[email-masked]>
Date: Thu, 7 Sep 2000 13:25:55 +1100

G'Day John,

I think we are in agreement that unions are shown at the most atomic
level. Do you see the need for some clarifying text on what is reported
back when you wildcard either the terminationID or ContextID. This first
sentence says that for w- individual responses are not required, what
does this mean for Context=ALL or/and TerminationID=ALL.

Cheers, Christian