Subject: Re: Context List in H.248

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 12 Sep 2000 11:14:47 -0400

The functionality is already available, as Shalini explains.  Changing the
syntax amounts to an optimization.  That's why I ruled it a v2 issue.

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Monday, September 11, 2000 11:01 PM
> To: [email-masked]
> Subject: Re: Context List in H.248
>
>
> G'Day Shalini,
>
> So we have an inconsistancy in the protocol. The protocol text in
> version 1 explicitely says that we have this functionality but the
> syntax doesn't allow it. To me returning a list of context
> IDs is pretty
> important functionality. So we are left with the decision to
> update the
> syntax or to remove the text. I prefer the former.
>
> Cheers, Christian
>
> Shalini Philip wrote:
> >
> > Hello Christian, list,
> >
> >     I recall this issue being discussed on the mailing list
> sometime back.
> > And it was decided that we would modify the grammar to
> return a Context Id
> > list only in V2.
> > The information of ContextId list can be conveyed by using
> different Action
> > Replies in the existing grammar. But as I see it, it is not
> possible to
> > specify an Action Reply with an empty Audit reply.
> >
> > Thanks & Regards,
> >    Shalini Philip.
> >
> > Christian Groves wrote:
> >
> > > G'Day all,
> > >
> > > I've found an inconsistency between the text and the encodings.
> > >
> > > In section 7.2.5 AuditValue it has the following table:
> > >
> > > The following illustrates other information that can be
> obtained with
> > > the Audit Command:
> > > ContextID       TerminationID   Information Obtained
> > > :
> > > All             wildcard        Audit of all matching
> Terminations and
> > >                                 the Context to which they
> are associated
> > > All             Root            List of all ContextIds
> > >
> > > However the ABNF nor the ASN.1 have the support to send
> back a list of
> > > context IDs. This is complicated by the fact the
> ContextIds sit above
> > > the command. I think the functionality is desirable and
> valid so I guess
> > > we need to fix the encodings.
> > >
> > > Firstly do people see this as a valid problem? If so one
> solution would
> > > be to add the ContextIDList to AuditReturnParameter. Do
> people have
> > > other suggestions?
> > >
> > > Cheers, Christian
> > >
> > > Notice to Recipient:
> > > This message is intended only for the use of the Addressee
> > > and may contain information that is proprietary and confidential
> > > and/or privileged by law. If you received this e-mail in error,
> > > any review, use, dissemination, distribution or copying of this
> > > e-mail is strictly prohibited. If you have received this e-mail in
> > > error, please notify us immediately of the error by return e-mail
> > > and please delete this message and all attachments from
> your system.
> > > Thank you.
> >
> > --
> > Regards,
> >
> > Shalini Philip
> > Globespan Inc.
> > E-Mail : mailto:[email-masked]
> > Web    : http://www.globespan.net
>

---

From: Christian Groves <[email-masked]>
Date: Wed, 13 Sep 2000 13:19:18 +1100

G'Day Tom,

But Shalini explains also "But as I see it, it is NOT possible to
specify an Action Reply with an empty Audit reply". I was confused with
this statement. As at least in the ASN1 we can return an empty
descriptor. I was trying to clarify this.

As I see now you can do this via ActionReplys and yes I think its
someting for v2 to look at as the action reply is a little clumsy.

Could we add some text to the Implementor's notes (informative) to say
how this is acheived in v1?

ie.
------------------------------
Implentor's Notes:
Section 7.2.5
Description:
In section 7.2.5 AuditValue it has the following table:
The following illustrates other information that can be obtained with
the Audit Command:
ContextID       TerminationID   Information Obtained
:
All             wildcard        Audit of all matching Terminations and
                                and the Context to which they are
                                associated.
All             Root            List of all ContextIds

Note: In version 1 the list of ContextIds should be returned by using
multiple Action Replys each containing a context from the list.
------------------------------

Cheers, Christian

Tom-PT Taylor wrote:
>
> The functionality is already available, as Shalini explains.  Changing
> the syntax amounts to an optimization.  That's why I ruled it a v2
> issue.
>