Subject: Re: Is Media required on the Physical Termination/Default value f or M ODE

From: "Mackey, Michael" <[email-masked]>
Date: Wed, 6 Sep 2000 10:27:30 -0400

I have to say I MUCH prefer the way the guys writing the SDP/ATM spec did it
(using the '-' to indicate not used) but as long as everyone agrees that
0.0.0.0 port 0 indicates an IP address not specified and it makes its way
into the Implementors guide ... fair enough

Michael Mackey,
Marconi Communications,
Tel: +353 1 6638407
- www.marconi.com <http://www.marconi.com>  -

> -----Original Message-----
> From: Flemming Andreasen [mailto:[email-masked]]
> Sent: Wednesday, September 06, 2000 2:53 PM
> To: Mackey, Michael
> Cc: [email-masked]
> Subject: Re: Is Media required on the Physical
> Termination/Default value
> for M ODE
>
>
> Right - SIP uses the "0.0.0.0" address trick for this.
>
> -- Flemming
>
> "Mackey, Michael" wrote:
>
> > My understanding of the SDP ABNF is that the c= line is
> mandatory at either
> > the session level or the media level and it strictly
> specifies it to be
> >
> >    connection-field =    ["c=" nettype space addrtype space
> >                          connection-address CRLF]
> >
> > which doesn't allow an empty line after the c= ....
> >
> > Michael Mackey,
> > Marconi Communications,
> > Tel: +353 1 6638407
> > - www.marconi.com <http://www.marconi.com>  -
> >
> > > -----Original Message-----
> > > From: Tom-PT Taylor [mailto:[email-masked]]
> > > Sent: Tuesday, September 05, 2000 7:40 PM
> > > To: [email-masked]
> > > Subject: Re: Is Media required on the Physical
> > > Termination/Default value
> > > f or M ODE
> > >
> > >
> > > Why not send a blank "c=" line?
> > >
> > > -----Original Message-----
> > > From: Mackey, Michael [mailto:[email-masked]]
> > > Sent: Tuesday, September 05, 2000 12:23 PM
> > > To: [email-masked]
> > > Subject: Re: Is Media required on the Physical
> > > Termination/Default value f
> > > or M ODE
> > >
> > >
> > > I wonder if someone could help me out ... I have another
> > > issue with standard
> > > SDP. If you are using Megaco in conjuction with H.323 you
> > > will probably want
> > > an MGC to ask the MG to reserve resources after receiving
> a Terminal
> > > Capability message. When specifing a remote descriptor you
> > > are currently
> > > required either to give the remote MG's IP address or use
> the CHOOSE
> > > character, but you don't receive the remote MGs IP address
> > > until later when
> > > Open Logical Channel messages are exchanged and you're
> > > certainly not asking
> > > it to choose the remote address. Is there a need for a
> not specified
> > > character (such as '-' ) similar to whats being proposed for ATM ?
> > >
> > >
> > > Michael Mackey,
> > > Marconi Communications,
> > > Tel: +353 1 6638407
> > > - www.marconi.com <http://www.marconi.com/>  -
> > >
> > > -----Original Message-----
> > > From: Rosen, Brian
> > > Sent: Tuesday, August 29, 2000 10:07 PM
> > > To: [email-masked]
> > > Subject: Re: Is Media required on the Physical
> > > Termination/Default value f
> > > or M ODE
> > >
> > >
> > > That's an acceptable default, which almost forces the MGC
> to set it to
> > > something
> > > else in order to get media to flow.
> > >
> > > Brian
> > >
> > > -----Original Message-----
> > > From: Tom-PT Taylor [mailto:[email-masked]]
> > > Sent: Tuesday, August 29, 2000 4:57 PM
> > > To: Rosen, Brian; [email-masked]
> > > Subject: RE: Is Media required on the Physical
> > > Termination/Default value f
> > > or M ODE
> > >
> > >
> > >
> > > Sorry, Brian, the natural default is "inactive".  It does
> seem that we
> > > failed to specify the defaults in 7.1.7, even though section
> > > 6.2.4 promises
> > > that we would.
> > >
> > > > -----Original Message-----
> > > > From: Rosen, Brian [ mailto:[email-masked]
> > > <mailto:[email-masked]> ]
> > > > Sent: Tuesday, August 29, 2000 4:30 PM
> > > > To: [email-masked]
> > > > Subject: Re: Is Media required on the Physical
> > > > Termination/Default value
> > > > f or M ODE
> > > >
> > > >
> > > > Okay, so what would you expect to happen if you audited media of
> > > > the physical termination.  Even if there was no
> default, it should
> > > > be one of the legal states.
> > > >
> > > > Now, suppose it's in an acceptable state, should you
> have to send
> > > > a media descriptor?
> > > >
> > > > What the folks who implemented the MG requiring the
> media descriptor
> > > > say is that "there is no mode, you haven't set it".  I
> can't deal
> > > > with that, because audit has to return a value.  So it has to be
> > > > something, and the MGC should be able to leave it, right?
> > > >
> > > > Now, I said I think MGCs should always send media!
> > > >
> > > > Brian
> > > >
> > > >
> > > >
> > > > > -----Original Message-----
> > > > > From: Michael Thomas [ mailto:[email-masked]
> > <mailto:[email-masked]> ]
> > > > Sent: Tuesday, August 29, 2000 4:25 PM
> > > > To: Rosen, Brian
> > > > Cc: [email-masked]
> > > > Subject: Is Media required on the Physical
> > > > Termination/Default value for
> > > > M ODE
> > > >
> > > >
> > > >
> > > > My general take has been that the MGC shouldn't
> > > > assume much about the MG. If it wants the MG to
> > > > do something, it should tell it. If it doesn't
> > > > know the MG's state, it should audit it.
> > > > Therefore, I think I disagree with the spec
> > > > requiring some set of semantics for underspecified
> > > > commands. What's the gain?
> > > >
> > > >               Mike
> > > >
> > > > Rosen, Brian writes:
> > > >  > Another issue from the event:
> > > >  >
> > > >  > Is it REQUIRED that the MGC send a media descriptor
> to a PHYSICAL
> > > >  > termination in order to get media to flow?
> > > >  >
> > > >  > There are two questions actually:
> > > >  > 1) Is there a default state of MODE (text is silent)
> > > >  > 2) Should the MG demand a media descriptor before allowing
> > > > media flow?
> > > >  >
> > > >  > I believe:
> > > >  > 1) The default for MODE is SendRecieve
> > > >  > 2) MGCs should always send a media descriptor, with at
> > > least a MODE
> > > >  > setting
> > > >  > 3) MGs should not depend on 2)
> > > >  >
> > > >  > Brian
> > > >  >
> > > >
> > >
>
> --
> Flemming Andreasen
> Cisco Systems
>
>

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 6 Sep 2000 10:58:29 -0400

"Mackey, Michael" wrote:

> (using the '-' to indicate not used)

That would conflict with both RFC 2327 (SDP) and RFC 2543 (SIP). For ATM, that
is probably OK since we've only defined the "IN" nettype in 2327. Actually, the
"addr" production in the SDP grammar should probably have a note to indicate it
can be extended as well.

-- Flemming

> but as long as everyone agrees that

--
Flemming Andreasen
Cisco Systems