Subject: ASN.1 BER

From: Shiv Kumar <[email-masked]>
Date: Wed, 6 Sep 2000 14:27:19 +0530

Hi,

I wanted some clarifications regarding the binary encoding.

Is there a  possibility of the binary encoding method to change
from ASN.1 BER  to  PER ?

How was BER decided upon in the first place.
Was it because it was simple, albeit costly in terms of size ?

Also, can we have some sample dump of BER encoded messages ?
I have managed to get the encoded output for a sample binary
encoded message. My decoder has no problem in parsing it.
But how do I assure myself that this is the encoded output that
everybody is looking for.  :-)

Regards
Shiv Kumar
Hughes Software Systems

---

From: Paraskevopoulos Pavlos <[email-masked]>
Date: Wed, 6 Sep 2000 14:27:38 +0300

Hi,

I wonder if someone could inform me, where to find a ASN.1 to C compiler?

Thank you in advance.

---

From: "P.Venkatesh" <[email-masked]>
Date: Thu, 7 Sep 2000 09:28:32 +0530

Hi all ,

><venkat> there is no way you can convert BER to PER directly but you may
>use some compilers to genarate BER and PER code if you have ASN.1 Definitions

>Was it because it was simple, albeit costly in terms of size ?

<venkat> BER is generally used in cases where size is significant.

>everybody is looking for.  :-)

<venkat>You can use third party compilers to generate the code for the
ASN.1 Definations and inter-operate your BER code with the generated BER code

>Hughes Software Systems

Regards
Venkatesh

----------
P.Venkatesh
Associate  Member Technical Staff
Chiplogic India Pvt. Ltd.,
Hyderabad.
ph: +91+40+3750250/251/252
fax : +91+40+3750 249
res : +91+40+7538241
email : [email-masked]
         [email-masked]

----------