Subject: Re: Audit of Packages

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 13 Sep 2000 09:42:31 -0400

Assume the gateway has 4 terminations
t1/1, t1/2, t2/1 and t2/2
Assume t1/* has packages aaa and bbb implemented on them
and t2/* has packages ccc and ddd implemented on them
Assume context 1 has t1/1 and t2/1 in it, and context 2 has
t1/2 and t2/2 in it.

Then I think
Context=1{Audit=t1/1{Audit{Packages}} returns
Context=1{Audit=t1/1{Packages{aaa,bbb}}}}

Context=*{Audit=t2/*{Audit{Packages}} returns
        Context=1{Audit=t2/1{Packages{ccc,ddd}}},
        Context=2{Audit=t2/2{Packages{ccc,ddd}}}

Context=*{W-Audit=*{Audit{Packages}} returns
Context=*{W-Audit=*{Packages{aaa,bbb,ccc,ddd}}

Brian

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Monday, September 11, 2000 7:05 PM
> To: Rosen, Brian
> Cc: [email-masked]
> Subject: Re: Audit of Packages
>
>
> G'Day Brian,
>
> What does the response look like in 3) below in the case of normal
> response and in the case of w- wilcard response?
>
> Cheers, Christian
>
> "Rosen, Brian" wrote:
> >
> > In some private correspondence, there was some continuing
> > confusion on auditValue of Packages.  Here is my current
> > understanding:
> >
> > 1. If you audit ROOT, using NULL context, you get the list
> > of Packages implemented on ROOT. You don't get Packages
> > implemented on any other terminations.
> >
> > 2. If you audit ALL, using NULL context, you get the union of
> > packages implemented on any termination in NULL.  Since, right
> > after boot, all terminations are in NULL, this is the normal
> > way you get the list of packages implemented on the gateway.
> > A notable side effect:
> >         ROOT is not in ALL.
> >         Therefore, Context=-{AuditValue=*{Audit{Packages}}}
> >                 DOES NOT get you packages implemented on ROOT
> >
> > 3. If you audit ALL, using ALL context, you get the union
> > of packages implemented on any termination in any Context other
> > than NULL.  You would do this if you needed the packages list
> > when some terminations were in contexts other than NULL.
> >
> > Please note that if you ask for an audit of ALL in ALL, and there
> > are no terminations in Contexts other than NULL, you get an
> > error (431 - No TerminationID matched a wildcard).
> >
> > Is that everyone else's understanding?
> >
> > Brian
>

---

From: Christian Groves <[email-masked]>
Date: Thu, 14 Sep 2000 11:08:32 +1100

G'Day Brian,

Sounds perfectly reasonable to me. Do you think this example is
something that can go in the implementors guide in the implementation
notes section to clarify for people what should be returned?

Cheers, Christian