Subject: RE: Property Characteristics

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 21 Jun 2001 10:28:32 -0400

1. Sec 12.1.2 Defined in:  Can a property be defined in more than one
descriptor? 
No 

2. Sec 12.1.5 Statistics: How can I define a unit? is it of type double or
int or what? Would it be better to define it as 
Statisitics Name: only descriptive
Statistics ID: Is an identifier
Type: One of:
    U_Integer : 4 byte unsigned integer
    U_Double: 8 byte unsigned integer.
Possible Values: 
There is presently no way to define an unsigned integer.  A V2 item. 
 
This definition is what followed in defining packages for RTP package. Sec
E.12.4. Should be change Type double to unsigned double as it just count the
number of package which cannot be negative?
 
3. Can a package be extended from two packages?  
No 
 
Brian

---

From: Troy Cauble <[email-masked]>
Date: Thu, 21 Jun 2001 13:51:28 -0400

Sarju:
> 2. Sec 12.1.5 Statistics: How can I define a unit? is it of type double or int or what? Would it be better to define it as 

>     There is presently no way to define an unsigned integer.  A V2 item. 

Brian,

I know unsigned integer is not listed in 12.2 or 12.1.2,
but several Annex C properties specify unsigned integer.

Sarju,

I think Statistics can be any of the types listed in 12.2.
The use of the word "Units" in 12.1.5 is just reminding
you that you have to specify the units *too*.

I don't think there's any reason to restrict statistics
to unsigned integral values.  Perhaps not even to integral
values.

-troy