Subject: Error handling

From: "Ternovsky, Igor" <[email-masked]>
Date: Wed, 6 Jun 2001 16:13:36 +0200

Hello list,

Please advice what is correct behavior when GW detects an error in
transaction.
In our implementation (as I suspect in many others) there is a message
parsing phase followed by an execution phase. Message parser decodes message
transaction by transaction.
Assume that transaction consists of a number of actions that in turn consist
of number of commands.
While parsing the transaction, parser found some error in command number n.
Is it legal in this case to reject the whole transaction without executing
the first <n-1> commands (my preference)? Or GW MUST execute the first <n-1>
commands and report error for the n's.

Thanks,

Igor Ternovsky
Virata

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 6 Jun 2001 10:29:27 -0400

Sorry, the specification is quite definite: you have to execute up to the
point of failure.

> -----Original Message-----
> From: Ternovsky, Igor [mailto:[email-masked]]
> Sent: Wednesday, June 06, 2001 10:14 AM
> To: [email-masked]'
> Cc: Kravetz, Yuri
> Subject: Error handling
> 
> 
> 
> Hello list,
>