Subject: Reply Errors

From: "Paul Lemay" <[email-masked]>
Date: Mon, 11 Jun 2001 15:54:40 -0400

Hello there,

Given a Mg that receives a transaction having 1 Action and 3 commands:

Transaction (T1)
   Action (A1)
      Command (C1)
      Command (C2)
      Command (C3)

Let say that the parsing went Ok and, an execution error occurs for C2. The
Mg reply will show an Error for C2. But what about the Action A1 and
Transaction T1? Is the Mg going to reply that the Transaction has no error
and the action has no error?

Thanks in advance.

Paul Lemay
-----------------------------------------
Concepteur Logiciel
Mediatrix Telecom, Inc.
[email-masked]

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 11 Jun 2001 16:23:31 -0400

The MG places one error descriptor at the end of the transaction response.
That error descriptor applies to C2.  Assuming context A1 was created by C1
or continues to exist despite C1, the response would report the contextID
for A1 and the result of C1 as well.  There is no transactionSuccess
response as such, just a transaction result response, and similarly at the
action level.

-----Original Message-----
From: Paul Lemay [mailto:[email-masked]]
Sent: Monday, June 11, 2001 3:55 PM
To: megaco
Subject: Reply Errors

Hello there,

Transaction (T1)
   Action (A1)
      Command (C1)
      Command (C2)
      Command (C3)

Thanks in advance.

Paul Lemay