Subject: RE: Allowed char set for Identifier

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 21 Jun 2001 10:32:08 -0400

A typo, it should use "alphabetic" for the first instance.  I think the
second can
stand (alphanumeric = characters and/or digits).
 
Terry, this is clearly an IG item.
 
Brian

-----Original Message-----
From: Sarju Garg [mailto:[email-masked]]
Sent: Thursday, June 21, 2001 8:54 AM
To: 'megaco'
Subject: Allowed char set for Identifier

Hi all,
 
I have a confusion in the allowed char set for Identifiers. In Sec 12.4, it
says the following: 
Identifiers in text encoding shall be strings of up to 64 characters,
containing no spaces, starting with an alphanumeric character and consisting
of alphanumeric characters and / or digits, and possibly including the
special character underscore ("_").
 
Shouldn't be alphanumeric be alphabet here? 
 
Or if the above statement is true, then there should be no digits mentioned
here. The text should be like:
Identifiers in text encoding shall be strings of up to 64 characters,
containing no spaces, starting with an alphanumeric character and consisting
of alphanumeric characters, and possibly including the special character
underscore ("_").
 
TIA
Sarju

---

From: Terry L Anderson <[email-masked]>
Date: Thu, 21 Jun 2001 11:24:59 -0400

I agree.  I believe the intent was do disallow the first character being
numeric.  The second instance could be
"...consisting of alphanumeric characters, and possibly..."
or
"...consisting of alphabetic characters and/or digits, and possibly..."
or
or left alone as Brian suggests.  I will make the first change and leave
the second as is unless folks write preferring one of the above.

"Rosen, Brian" wrote:

> A typo, it should use "alphabetic" for the first instance.  I think
> the second canstand (alphanumeric = characters and/or digits).Terry,
> this is clearly an IG item.Brian
>
>      Hi all, I have a confusion in the allowed char set for
>      Identifiers. In Sec 12.4, it says the following:Identifiers
>      in text encoding shall be strings of up to 64 characters,
>      containing no spaces, starting with an alphanumeric
>      character and consisting of alphanumeric characters and / or
>      digits, and possibly including the special character
>      underscore ("_").Shouldn't be alphanumeric be alphabet
>      here? Or if the above statement is true, then there should
>      be no digits mentioned here. The text should be
>      like:Identifiers in text encoding shall be strings of up to
>      64 characters, containing no spaces, starting with an
>      alphanumeric character and consisting of alphanumeric
>      characters, and possibly including the special character
>      underscore ("_").TIASarju
>
--
------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

---

From: Troy Cauble <[email-masked]>
Date: Thu, 21 Jun 2001 13:56:22 -0400

If you restrict the first character,
you will have to do it in Annex B also.

-troy

---

From: Terry L Anderson <[email-masked]>
Date: Thu, 21 Jun 2001 14:16:23 -0400

> you will have to do it in Annex B also.

I believe it is.  The statement were discussing is in 12.4 and so is referring
to identifiers in packages.  In Annex B this would be things like PackageName
and ItemID (used in pkgdName), eventParameterName, etc.  All these are NAME
which is
ALPHA *63(ALPHA / DIGIT / "_")
so I believe this is consistent with restricting the first character to
"alphabetic character".  Have you noticed a place in Annex B that does not
restrict?

---

From: Troy Cauble <[email-masked]>
Date: Thu, 21 Jun 2001 14:56:58 -0400

Terry L Anderson wrote:
> I believe it is.  

You are correct.  My mistake.