Subject: RE: Property Characteristics

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 20 Jun 2001 09:20:37 -0400

Global and read/write are independent; you can have any combination.
 
Packages should define the values.  If they don't, there is no default, and
it's implementation dependent - a bad idea.  I do believe the current
convention is that if you don't say Global, then it's "local".
 
Brian

-----Original Message-----
From: Sarju Garg [mailto:[email-masked]]
Sent: Wednesday, June 20, 2001 9:20 AM
To: 'megaco'
Subject: Property Characteristics

Hi all,
 
I have a question pertaining to property characteristics. What I understand
is that the characteristics of property is one of the following:
read and local
read/write and local
read/write and global
read and global
 
Is write and local and write and global characteristics is also possible as
Sec 12.1.2 says Characteristics: Read/Write or both and (optionally global)?
 
What is the default characteristics of the property as none of the package
define the characteristics?
 
TIA
Sarju

---

From: "Sarju Garg" <[email-masked]>
Date: Wed, 20 Jun 2001 19:25:07 +0530

But it is pretty confusing in the document. In Section 12.1.2 it says. Indicates whether a property is read-only or read-write and if it is global. Also Sec 6.2.4 says that the property mat be read-only or read/write. No mention of write in these cases.
Can we specify an unambiguous line in the document?. I feel there should be no convention in the standards. Everything should be specified explicitly whereever possible. 

Sarju

  ----- Original Message ----- 
  From: Rosen, Brian 
  To: 'Sarju Garg' ; 'megaco' 
  Sent: Wednesday, June 20, 2001 6:50 PM
  Subject: RE: Property Characteristics

   
  Brian
    -----Original Message-----
    From: Sarju Garg [mailto:[email-masked]]
    Sent: Wednesday, June 20, 2001 9:20 AM
    To: 'megaco'
    Subject: Property Characteristics

    Hi all,

    I have a question pertaining to property characteristics. What I understand is that the characteristics of property is one of the following:
    read and local
    read/write and local
    read/write and global
    read and global

    Is write and local and write and global characteristics is also possible as Sec 12.1.2 says Characteristics: Read/Write or both and (optionally global)?
     
    What is the default characteristics of the property as none of the package define the characteristics?

    TIA
    Sarju