Subject: RE: UDP/TCP Default ports.

From: suryapratap vamsi <[email-masked]>
Date: 20 Jun 2001 16:14:12 MDT

Hello Paul,
I framed the question incorrectly. Let me rephrase it again.
The MGC should support both TCP and UDP, and MG can either support TCP or UDP
or both. 
Assuming MGC is created two udp listen sockets(  2944 for text, 2945 for
binary), and MG is trying to establish communication with TCP, it's connection
will get refused.
So, there should be someway of specifing in the RFC that, the GW should try to
send the initial SvcChangeRequest with UDP transport or otherwise 
or on TCP transport.

Thanks
Surya
 
-----Original Message-----
From: Paul Long [mailto:[email-masked]]
Sent: Wednesday, June 20, 2001 5:16 PM
To: [email-masked]
Subject: RE: UDP/TCP Default ports.

The TCP port space is distinct from the UDP port space.

Paul Long
ipDialog, Inc.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of suryapratap
vamsi
Sent: Wednesday, June 20, 2001 3:54 PM
To: [email-masked]
Subject: UDP/TCP Default ports.

Hello All,
section 9.Transport says
"If TCP or UDP is used as the protocol transport and the port to which
   the initial ServiceChange request is to be sent is not otherwise
   known, that request should be sent to the default port number for the
   protocol.  This port number is 2944 for text-encoded operation or
   2945 for binary-encoded operation, for either UDP or TCP."

Since the protocol says MGC should support both UDP and TCP, how does MGC
binds for the same port for both TCP as well UDP transport ?. This is a pure
provisional/configuration issue or Is there a otherway to deal with this
problem ?
Please clarify this .

Surya

____________________________________________________________________
Get free email and a permanent address at http://www.netaddress.com/?N=1

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Thu, 21 Jun 2001 09:40:42 -0400

Hi Surya/All,
IMO the MG should be provisioned to send requests to specifics MGCs.
Similarly MGCs also will accept requests from specifics MGs. If a given MGC
is going to control a MG then both should have some provisioned information
about the existence of the other including the transport protocol they use.
IMHO this is not a big problem and protocol shouldn't insist usage of any
specific transport protocol for initial ServiceChange.
Regards
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of suryapratap
vamsi
Sent: Wednesday, June 20, 2001 6:14 PM
To: [email-masked]; [email-masked]
Subject: RE: UDP/TCP Default ports.

Hello Paul,
I framed the question incorrectly. Let me rephrase it again.
The MGC should support both TCP and UDP, and MG can either support TCP or
UDP
or both.
Assuming MGC is created two udp listen sockets(  2944 for text, 2945 for
binary), and MG is trying to establish communication with TCP, it's
connection
will get refused.
So, there should be someway of specifing in the RFC that, the GW should try
to
send the initial SvcChangeRequest with UDP transport or otherwise
or on TCP transport.

Thanks
Surya

-----Original Message-----
From: Paul Long [mailto:[email-masked]]
Sent: Wednesday, June 20, 2001 5:16 PM
To: [email-masked]
Subject: RE: UDP/TCP Default ports.

Paul Long
ipDialog, Inc.

-----Original Message-----

Hello All,
section 9.Transport says

Surya