Subject: resending megaco messge...after timeout..

From: "Atanum" <[email-masked]>
Date: Thu, 14 Jun 2001 15:21:14 +0530

Hi,
I have one basic query....
Suppose a Megaco Message structure contains mutiple transactions and with each transactions having its own transaction-id..
No if a particular transaction of that MegacoMessage structure do not get a reply..in that case do we send the whole 
Message structure again( i mean both the Transactions whose reply we already got + the transaction whose reply is not received)

or
 we extract the transaction whose reply we haven't received and sent it encapsulating with the message structure header
please see it in the below

Message structure = Message Header1 + Transaction1 + Transaction2 + Transaction 3

Say Transaction1 and Transaction2 received the reply..and we need to recend Transaction3..

Do we send it as
 Message structure = MessageHeader1 + Transaction1+Transaction2 + Transaction3

or

Message structure= MessageHeader1 + Transaction3

or

Message structure= MessageHeader2(new header) + Transaction3

If somebody ans this above query.. it will be very helpful..
Thanking in advance..

Atanu Mondal
Net Brahma Technologies
Internext Networking Software
A Microland Group Venture
[email-masked]
www.netbrahma.com
Tel : 91.80. 552 1451
Fax : 91.80. 553 7233

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Thu, 14 Jun 2001 09:07:22 -0400

Hi Atanu,

The transactions in a message are treated independently.  There is no  order
implied, there is no application or protocol acknowledgement of  a message.
Its only a means of clubbing multiple transactions from one source to a
specific destination. If there is no response for a specific transaction,
only that particular transaction need to be retransmitted. The Transactions
across a given message doesn't share the fate.

-Regards
Madhubabu
  -----Original Message-----
  From: Atanum [mailto:[email-masked]]
  Sent: Thursday, June 14, 2001 5:51 AM
  To: [email-masked]
  Cc: Rosen, Brian; Madhu Babu Brahmanapally
  Subject: resending megaco messge...after timeout..

  Hi,
  I have one basic query....
  Suppose a Megaco Message structure contains mutiple transactions and with
each transactions having its own transaction-id..
  No if a particular transaction of that MegacoMessage structure do not get
a reply..in that case do we send the whole
  Message structure again( i mean both the Transactions whose reply we
already got + the transaction whose reply is not received)

  or
   we extract the transaction whose reply we haven't received and sent it
encapsulating with the message structure header
  please see it in the below

  Message structure = Message Header1 + Transaction1 + Transaction2 +
Transaction 3

  Say Transaction1 and Transaction2 received the reply..and we need to
recend Transaction3..

  Do we send it as
   Message structure = MessageHeader1 + Transaction1+Transaction2 +
Transaction3

  or

  or

  Atanu Mondal
  Net Brahma Technologies