Subject: RE: Property Characteristics

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 20 Jun 2001 10:31:17 -0400

Here is the entire text:
 
     Characteristics: Read / Write or both, and (optionally), global: 
     Indicates whether a property is read-only, or read-write, and if 
     it is global.  If Global is omitted, the property is not global.  
     If a property is declared as global, the value of the property is 
     shared by all terminations realizing the package. 

The only part I see that is potentially confusing is whether you can have
a write-only property.  Such things used to happen in hardware design,
but it's been a LONG time since I allowed any engineer to create one.
 
I can try rewriting it:
Characteristics: A property may have one or two characteristics specified:
read/write and global.  The read/write characteristic is specified as 
"read-only" or "read-write".  Every property MUST specify read/write.
The characteristics specification MAY also include the "Global"
keyword.  If Global is specified, the value of the property is shared
by all terminations realizing the package.  If Global is not specified,
each termination realizing the package has an independent value of
the property.  
 
If you really think that makes it more clear, we can ask that the
rewritten text appear in the IG.
 
Brian

-----Original Message-----
From: Sarju Garg [mailto:[email-masked]]
Sent: Wednesday, June 20, 2001 9:55 AM
To: Rosen, Brian; 'megaco'
Subject: Re: Property Characteristics

But it is pretty confusing in the document. In Section 12.1.2 it says.
Indicates whether a property is read-only or read-write and if it is global.
Also Sec 6.2.4 says that the property mat be read-only or read/write. No
mention of write in these cases.
Can we specify an unambiguous line in the document?. I feel there should be
no convention in the standards. Everything should be specified explicitly
whereever possible. 
 
Sarju

----- Original Message ----- 
From: Rosen, Brian <mailto:[email-masked]>  
To: 'Sarju Garg' <mailto:[email-masked]>  ; 'megaco'
<mailto:[email-masked]>  
Sent: Wednesday, June 20, 2001 6:50 PM
Subject: RE: Property Characteristics

Global and read/write are independent; you can have any combination.
 
Packages should define the values.  If they don't, there is no default, and
it's implementation dependent - a bad idea.  I do believe the current
convention is that if you don't say Global, then it's "local".
 
Brian

-----Original Message-----
From: Sarju Garg [ mailto:[email-masked]
<mailto:[email-masked]> ]
Sent: Wednesday, June 20, 2001 9:20 AM
To: 'megaco'
Subject: Property Characteristics

Hi all,
 
I have a question pertaining to property characteristics. What I understand
is that the characteristics of property is one of the following:
read and local
read/write and local
read/write and global
read and global
 
Is write and local and write and global characteristics is also possible as
Sec 12.1.2 says Characteristics: Read/Write or both and (optionally global)?
 
What is the default characteristics of the property as none of the package
define the characteristics?
 
TIA
Sarju

---

From: "Sarju Garg" <[email-masked]>
Date: Thu, 21 Jun 2001 16:55:58 +0530

Yes. I think this make things more clear. What does others says about it? 

I have other queries related to package characteristics in the following section:
1. Sec 12.1.2 Defined in:  Can a property be defined in more than one descriptor?

2. Sec 12.1.5 Statistics: How can I define a unit? is it of type double or int or what? Would it be better to define it as 
Statisitics Name: only descriptive
Statistics ID: Is an identifier
Type: One of:
    U_Integer : 4 byte unsigned integer
    U_Double: 8 byte unsigned integer.
Possible Values:

This definition is what followed in defining packages for RTP package. Sec E.12.4. Should be change Type double to unsigned double as it just count the number of package which cannot be negative?

3. Can a package be extended from two packages? 

TIA 
Sarju
  ----- Original Message ----- 
  From: Rosen, Brian 
  To: 'Sarju Garg' ; 'megaco' 
  Sent: Wednesday, June 20, 2001 8:01 PM
  Subject: RE: Property Characteristics

  Here is the entire text:

   
  I can try rewriting it:

  Brian
   
    -----Original Message-----
    From: Sarju Garg [mailto:[email-masked]]
    Sent: Wednesday, June 20, 2001 9:55 AM
    To: Rosen, Brian; 'megaco'
    Subject: Re: Property Characteristics

    But it is pretty confusing in the document. In Section 12.1.2 it says. Indicates whether a property is read-only or read-write and if it is global. Also Sec 6.2.4 says that the property mat be read-only or read/write. No mention of write in these cases.
    Can we specify an unambiguous line in the document?. I feel there should be no convention in the standards. Everything should be specified explicitly whereever possible. 

    Sarju

      ----- Original Message ----- 
      From: Rosen, Brian 
      To: 'Sarju Garg' ; 'megaco' 
      Sent: Wednesday, June 20, 2001 6:50 PM
      Subject: RE: Property Characteristics

       
      Brian
        -----Original Message-----
        From: Sarju Garg [mailto:[email-masked]]
        Sent: Wednesday, June 20, 2001 9:20 AM
        To: 'megaco'
        Subject: Property Characteristics

        Hi all,

        I have a question pertaining to property characteristics. What I understand is that the characteristics of property is one of the following:
        read and local
        read/write and local
        read/write and global
        read and global

        Is write and local and write and global characteristics is also possible as Sec 12.1.2 says Characteristics: Read/Write or both and (optionally global)?
         
        What is the default characteristics of the property as none of the package define the characteristics?

        TIA
        Sarju

---

From: Christian Groves <[email-masked]>
Date: Fri, 22 Jun 2001 11:55:13 +1000

G'Day,

I think the text should stay as stands in H.248.

Christian