Subject: RE: How to Determine the Termination Type

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 21 Jun 2001 11:41:00 -0400

I keep forgetting that sometimes people take what I say too literally.
 
Here is an example - on outgoing calls, the particular trunk to be seized
can
be determined by the MG instead of the MGC.  In this case, use of
"$" on the physical termination is quite reasonable.  MGs must be able to
handle $ on any termination.
 
However, I disagree with your statement about using wildcarded termination
IDs.  If you supply a wildcarded termination ID, the MG must use that
information.
If your MG is built so that terminations with similar capabilities have
similar
terminationIds (as almost all will be), and you get a wildcarded
terminationId,
then you CAN use that to determine the "type" of termination.  If SDP is 
given, it MUST match (i.e. be compatible with the wildcarded terminationId).
If the SDP and the terminationId don't "match", that is an error.
 
Brian

-----Original Message-----
From: Madhu Babu Brahmanapally [mailto:[email-masked]]
Sent: Thursday, June 21, 2001 11:01 AM
To: 'Rosen, Brian'; 'Sarju Garg'; 'megaco'
Subject: RE: How to Determine the Termination Type

Hi Brian,All,
 
In case of choosing any physical trunk IMO $ can be useful for choosing
physical termination too.  MGs shouldn't assume that $ in ADD only comes for
creation of Ephemeral Termination, and logic should be based on the
descriptors rather than the wildcard termination Identifier. Of course as
Brian, suggested enough parameters needs to be specified by the MGC.
 
-Regards
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Rosen, Brian
Sent: Thursday, June 21, 2001 10:34 AM
To: 'Sarju Garg'; 'megaco'
Subject: RE: How to Determine the Termination Type

In most cases, you won't use $ with a physical termination because it
usually matters
which physical port you want. 
 
However, the rule is that you must specify (using local/remote) enough
parameters
to allow the MG to choose the type of termination correctly.
 
Brian

-----Original Message-----
From: Sarju Garg [mailto:[email-masked]]
Sent: Thursday, June 21, 2001 4:53 AM
To: 'megaco'
Subject: How to Determine the Termination Type

Hi all,
 
Suppose MG application supports RTP, PSTN termination. The termination are
allocated by the MG application for a call? So the ADD command specify $ for
the termination name so that MG can allocate a termination  and return it to
MGC application. How does the MG application come to know that receiving an
ADD command is for which type of termination - for RTP termination or PSTN
termination? I believe Local/Remote descriptors are required for RTP
terminations. So can Local/Remote descriptor be used for this purpose? 
 
TIA
Sarju

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 21 Jun 2001 14:15:50 -0400

Because we would have to define an entirely new syntax for
termination type, with some kind of name space, and some
rules for how to disambiguate types.  I thought about it,
but it turns out that any sane implementation has to verify
all the things it now uses to deduce the type, and you
don't actually save any code.

Anyway, as you know, it's too late.

Brian

P.S. ?33?  (I'm from Pittsburgh, it's real near Latrobe - which
is pronounced "lay-trowb" -- home of Rolling Rock beer)

> From: Troy Cauble [mailto:[email-masked]]
> Sent: Thursday, June 21, 2001 2:04 PM
> To: Rosen, Brian
> Cc: 'Sarju Garg'; 'megaco'
> Subject: Re: How to Determine the Termination Type
> 
> 
> > 
> > In most cases, you won't use $ with a physical termination 
> because it usually matters
> > However, the rule is that you must specify (using 
> local/remote) enough parameters
> I know it's too late to change, but I must rant again:
> 
> If the MGC KNOWS the type it wants, why can't it just 
> TELL the MG.  Making the MG deduce the type is stupid.
> 
> Why send the MG any details?  Make it deduce everything.
> "Read my mind."
> 
> -troy
> 
> P.S.  I'm thinking of a number...
>