Subject: ASN.1: extraInfo OPTIONAL

From: Troy Cauble <[email-masked]>
Date: Mon, 11 Jun 2001 13:48:03 -0400

The sub-object below is used in 3 places in the ASN.1 spec.,
EventParameter, SigParameter, and PropertyParm.

        extraInfo       CHOICE
                {
                        relation        Relation,
                        range           BOOLEAN,
                        sublist         BOOLEAN
                } OPTIONAL,

The fact that the whole object is optional is hard to align
with the text encoding.  What relationship is implied when
no extra info is sent?

Also, why was this so complicated anyway?  extraInfo is
a CHOICE of an ENUMERATED or one of two BOOLEANs.  Why
wasn't it all just an ENUMERATED?

-troy

---

From: Christian Groves <[email-masked]>
Date: Mon, 18 Jun 2001 15:05:31 +1000

G'Day Troy,

Its optional because you don't need to send extraInfo in a majority of
cases. A one to one relationship is implied if not sent. ie. property =
value (does this really need to be stated????). 

In hindsight the enum may have been nicer the optional was the way we
went at the time.

Cheers, Christian

---

From: Troy Cauble <[email-masked]>
Date: Mon, 18 Jun 2001 09:59:41 -0400

> value (does this really need to be stated????).

Yes it does.  There's an explicit way to encode equalTo,
why would we assume there's two ways.

I'll settle for knowing it's equalTo, but for v2 we really 
should avoid having 2 ways to encode the same thing.

-troy