Subject: Few clarification in RFC3015

From: Nitin Kumar <[email-masked]>
Date: Thu, 21 Jun 2001 00:01:31 +0530

Hi Folks,

Just looking for following clarification.

1. In a TransactionRequest, are ActionRequests processed in order or only
Commands in an ActionRequest are executed sequencially ? RFC says "Commands
within a Transaction are executed sequentially."

2. Few lines from the RFC on page number 135, section D.1.4..
"Upon receipt of a final response following receipt of
   provisional responses, an immediate confirmation shall be sent, and
   normal repetition timers shall be used thereafter."

Now what does "normal repetition timers shall be used thereafter" mean in
above extract?

i hope to receive some insights.

regards,

-nitin

Ind Telesoft Pvt. Ltd.
104, Koramangla Industrial Estate,
5th Block, Bangalore 560 095
Tel : 5508930,  5521937,  5529758-62 ext-259
Fax : 5521164
mailto:[email-masked]
http:\\www.telesoftinc.com

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 21 Jun 2001 09:54:43 -0400

The Transaction is the unit of control here, not the action.
If you want to execute the other actions if there is an error,
put them in separate transactions.  Just because there are
different contexts does not necessarily mean you want the
actions to proceed.  If you do, use the optional command.

Anyway, we probably wouldn't change the protocol in this way
at this point - it would be non-backwards compatible.

Brian

> -----Original Message-----
> From: Nitin Kumar [mailto:[email-masked]]
> Sent: Thursday, June 21, 2001 1:51 AM
> To: 'Terry L Anderson'; Rosen, Brian
> Cc: [email-masked]'
> Subject: RE: Few clarification in RFC3015
> 
> 
> ok...
> thats what even i thought..
> now if actions in a transaction are processed in sequence 
> then consider
> following scenario
> 
> TransactionRequest
> {
> 	Action1
> 	{
> 		command1
> 		command2
> 	}
> 	Action2
> 	{
> 		command1
> 		command2
> 		command3
> 	}
> 	Action3
> 	{
> 		command1
> 		command2
> 	}
> }
> 
> Suppose all commands are manatory. Lets assume command2 in 
> Action2 generates
> some error or is not processed successfully then
> does it mean that command3 of Action2 as well as any further 
> action i.e.
> Action3 will not be executed?
> 
> If yes, then my doubt is: when every Action is concerned with 
> different
> Context.. then why failure of one command in one Action 
> should bother other
> Action with in the same transaction?
> 
> We should be able to process every Action sequentially and 
> independently.
> 
> regards,
> 
> -nitin
> 
> 
> 
> -----Original Message-----
> From: Terry L Anderson [mailto:[email-masked]]
> Sent: Thursday, June 21, 2001 3:23 AM
> To: Rosen, Brian
> Cc: 'Nitin Kumar'; [email-masked]'
> Subject: Re: Few clarification in RFC3015
> 
> 
> 
> 
> "Rosen, Brian" wrote:
> 
> > Hmmm, maybe we should edit that text to say:
> > "Actions in a transaction and commands within an action are
> > executed sequentially in the order they appear in the transaction."
> >
> > Terry?
> 
> That is certainly the intent and the way I would read the current text
> ("commands in order" - the fact that they are grouped into 
> actions doesn't
> alter their order).  But your text is certainly more 
> explicit.  I have no
> trouble with it.  I'll put it in.
> 
> >
> >
> > "Normal Repitition timers" are the timer values defined in D.1.3
> >
> > Brian
> >
> > > -----Original Message-----
> > > From: Nitin Kumar [mailto:[email-masked]]
> > > Sent: Wednesday, June 20, 2001 2:32 PM
> > > To: [email-masked]'
> > > Subject: Few clarification in RFC3015
> > >
> > >
> > > Hi Folks,
> > >
> --
> ------------------------------------------------------------
> Terry L Anderson              mailto:[email-masked]
> Tel:908.582.7013   Fax:908.582.6729
> Lucent Technologies/INS/Voice Over IP Access Networks
> Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
> http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 22 Jun 2001 08:31:31 -0400

Well I thought the text was clear enough as it was, but someone
got confused.  While we will forever be in this state.  In this
case, there are three entities - transactions, actions and
commands.  The text talks about the order of transaction execution,
and it talks about the order of command execution but is
silent on the order of action execution.  I thought, given that,
an edit was warranted.

I agree that just because someone is confused doesn't mean we 
have to add something to the I-G.

Brian

> From: Christian Groves [mailto:[email-masked]]
> Sent: Thursday, June 21, 2001 9:47 PM
> To: Terry L Anderson
> Cc: Rosen, Brian; 'Nitin Kumar'; [email-masked]'
> G'Day,
> Why should we make this change if the it currently says so in 
> the text?
> This seems to me that we're adding things just for changes 
> sake. Not all
> questions to this list have result in a change in the IG.
> 
> Cheers, Christian
> 
> Terry L Anderson wrote:
> > 
> > "Rosen, Brian" wrote:
> >

---

From: Nitin Kumar <[email-masked]>
Date: Sat, 23 Jun 2001 11:56:32 +0530

So, whats the final decision??

The language won't be changed in the Specification...

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Friday, June 22, 2001 6:02 PM
To: 'Christian Groves'; Terry L Anderson
Cc: 'Nitin Kumar'; [email-masked]'
Subject: RE: Few clarification in RFC3015

Brian