Subject: RE: Few clarification in RFC3015

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 20 Jun 2001 17:22:30 -0400

Hmmm, maybe we should edit that text to say:
"Actions in a transaction and commands within an action are
executed sequentially in the order they appear in the transaction."

Terry?

"Normal Repitition timers" are the timer values defined in D.1.3

Brian

> -----Original Message-----
> From: Nitin Kumar [mailto:[email-masked]]
> Sent: Wednesday, June 20, 2001 2:32 PM
> To: [email-masked]'
> Subject: Few clarification in RFC3015
> 
> 
> Hi Folks,
> 
> Just looking for following clarification.
> 
> 1. In a TransactionRequest, are ActionRequests processed in 
> order or only
> Commands in an ActionRequest are executed sequencially ? RFC 
> says "Commands
> within a Transaction are executed sequentially."
> 
> 2. Few lines from the RFC on page number 135, section D.1.4..
> "Upon receipt of a final response following receipt of
>    provisional responses, an immediate confirmation shall be sent, and
>    normal repetition timers shall be used thereafter."
> 
> Now what does "normal repetition timers shall be used 
> thereafter" mean in
> above extract?
> 
> i hope to receive some insights.
> 
> regards,
> 
> -nitin
> 
> Ind Telesoft Pvt. Ltd.
> 104, Koramangla Industrial Estate,
> 5th Block, Bangalore 560 095
> Tel : 5508930,  5521937,  5529758-62 ext-259
> Fax : 5521164
> mailto:[email-masked]
> http:\\www.telesoftinc.com
>

---

From: Troy Cauble <[email-masked]>
Date: Wed, 20 Jun 2001 17:41:28 -0400

I suggest a shortened version, the trailing clause was
confusing.

"Actions in a transaction and commands within an action are
executed sequentially in the order they appear."

-troy

---

From: Terry L Anderson <[email-masked]>
Date: Wed, 20 Jun 2001 17:52:51 -0400

> executed sequentially in the order they appear in the transaction."

That is certainly the intent and the way I would read the current text
("commands in order" - the fact that they are grouped into actions doesn't
alter their order).  But your text is certainly more explicit.  I have no
trouble with it.  I'll put it in.

--
------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

---

From: Christian Groves <[email-masked]>
Date: Fri, 22 Jun 2001 11:47:04 +1000

G'Day,

Why should we make this change if the it currently says so in the text?
This seems to me that we're adding things just for changes sake. Not all
questions to this list have result in a change in the IG.

Cheers, Christian