Subject: Query on case insensitivity

From: [email-masked]
Date: Wed, 20 Jun 2001 10:57:23 +0530

Hi all,
     ABNF syntax notation is CASE INSENSITIVE, apart from the SDP and whatever
comes within quotes should not be validated.
My queries:
1.  In case of short and long tokens can we mix both of them like

     MEGACO/1 [123.123.123.123]:55555
          P = 50005 {
               Context = - { N = A5555 }
Is it allowed?

2.  Can we have tokens like   "TranACTIONresponSEAck" , I mean mix of lower and
upper case in one token ?

3. Can we have short tokens in lower case or mix case like  "rc" or "rC"  for
ReceiveOnly ?

regards/
Amit

---

From: "PSK Chakravarthi" <[email-masked]>
Date: Wed, 20 Jun 2001 12:37:54 +0530

I have got the following doubt.
If the originating and terminating termination IDs are on the same gateway and
gateway supports two TDM terminations in a context, is it required to craete a
ephenmeral termination for this call?

Message flow between MGC and MG:

1. MGC send ADD command to originating MG
    a) Choose a context ID
    b) Add a TDM termination
    c) Choose a Ephemeral termination
    d) Reserve Local Descriptor
    e) set MODE to Receive only.

2. MGC now finds that call is terminating on the same MG.  Also MGC knows that
MG is capable of adding two TDMs to the same context.  At this point what should
be the command to the MG?
Is it required to SUBTRACT the ephemeral termination and send ADD for adding new
TDM to the same context? or
Simply sending ADD for new TDM to the same context is sufficient?

thanks & regards
Chak

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Wed, 20 Jun 2001 11:27:31 -0400

Hi All,
The creation of ephemeral termination can be done either after digit
analysis or before it. Each has its own advantages and disadvantages.

1) If Ephemeral termination is created before digit analysis, situation may
occur where the destination user/termination is connected to the same MG and
there is no need to create an ephemeral termination (as PSK mentioned). But
this has the advantage that the call wont be dropped due to lack of
resource, as ephemeral resources are pre-reserved at the MG. (in case Add
fails later to add ephemeral termination).

2) If Ephemeral termination is created after digit analysis, it takes care
of all situation where destination user may/may not connected to the same
MG. But when Ephemeral termination is added later, there is no
pre-reservation of the ephemeral resources at the origination MG.

In case of 1) if the call doesn't mature, reserving the resources doesn't
gain anything. Consideration that the destination user on the same MG is
less probable, Method 2 IMO will be a better choice.

Regards
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Terry L Anderson
Sent: Wednesday, June 20, 2001 11:01 AM
To: PSK Chakravarthi
Cc: [email-masked]
Subject: Re: Ephemeral Termination

> Simply sending ADD for new TDM to the same context is sufficient?

It would be better if MGC "finds" that the call is terminated on the same MG
before
sending the ADD, in step 1c, but if since step c (which you call "Choose a
Ephemeral
termination) is an Add with wildcard, MGC must certainly Subtract it if it
chooses
later not to use it.  The Subtract deletes the ephemeral termination and
releases
its resources.

--
------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

---

From: Terry L Anderson <[email-masked]>
Date: Wed, 20 Jun 2001 11:00:56 -0400

> Simply sending ADD for new TDM to the same context is sufficient?

It would be better if MGC "finds" that the call is terminated on the same MG before
sending the ADD, in step 1c, but if since step c (which you call "Choose a Ephemeral
termination) is an Add with wildcard, MGC must certainly Subtract it if it chooses
later not to use it.  The Subtract deletes the ephemeral termination and releases
its resources.