Subject: RE: Few clarification in RFC3015

From: Nitin Kumar <[email-masked]>
Date: Thu, 21 Jun 2001 11:20:51 +0530

ok...
thats what even i thought..
now if actions in a transaction are processed in sequence then consider
following scenario

TransactionRequest
{
	Action1
	{
		command1
		command2
	}
	Action2
	{
		command1
		command2
		command3
	}
	Action3
	{
		command1
		command2
	}
}

Suppose all commands are manatory. Lets assume command2 in Action2 generates
some error or is not processed successfully then
does it mean that command3 of Action2 as well as any further action i.e.
Action3 will not be executed?

If yes, then my doubt is: when every Action is concerned with different
Context.. then why failure of one command in one Action should bother other
Action with in the same transaction?

We should be able to process every Action sequentially and independently.

regards,

-nitin

-----Original Message-----
From: Terry L Anderson [mailto:[email-masked]]
Sent: Thursday, June 21, 2001 3:23 AM
To: Rosen, Brian
Cc: 'Nitin Kumar'; [email-masked]'
Subject: Re: Few clarification in RFC3015

"Rosen, Brian" wrote:

> Hmmm, maybe we should edit that text to say:
> "Actions in a transaction and commands within an action are
> executed sequentially in the order they appear in the transaction."
>
> Terry?

That is certainly the intent and the way I would read the current text
("commands in order" - the fact that they are grouped into actions doesn't
alter their order).  But your text is certainly more explicit.  I have no
trouble with it.  I'll put it in.

>
>
> "Normal Repitition timers" are the timer values defined in D.1.3
>
> Brian
>
> > -----Original Message-----
> > From: Nitin Kumar [mailto:[email-masked]]
> > Sent: Wednesday, June 20, 2001 2:32 PM
> > To: [email-masked]'
> > Subject: Few clarification in RFC3015
> >
> >
> > Hi Folks,
> >
> > Just looking for following clarification.
> >
> > 1. In a TransactionRequest, are ActionRequests processed in
> > order or only
> > Commands in an ActionRequest are executed sequencially ? RFC
> > says "Commands
> > within a Transaction are executed sequentially."
> >
> > 2. Few lines from the RFC on page number 135, section D.1.4..
> > "Upon receipt of a final response following receipt of
> >    provisional responses, an immediate confirmation shall be sent, and
> >    normal repetition timers shall be used thereafter."
> >
> > Now what does "normal repetition timers shall be used
> > thereafter" mean in
> > above extract?
> >
> > i hope to receive some insights.
> >
> > regards,
> >
> > -nitin
> >
> > Ind Telesoft Pvt. Ltd.
> > 104, Koramangla Industrial Estate,
> > 5th Block, Bangalore 560 095
> > Tel : 5508930,  5521937,  5529758-62 ext-259
> > Fax : 5521164
> > mailto:[email-masked]
> > http:\\www.telesoftinc.com
> >

--
------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Thu, 21 Jun 2001 09:53:51 -0400

Hi Nitin,
In the example you considered Action1 Action2 and Action3 are clubbed in a
single command as there is some dependency between the three contexts. If
there is none then they don't qualify to be clubbed in a single transaction.
They may be part of single message with different transaction Ids. But once
clubbed (due to whatever reasons) the execution of the actions and commands
within should be in order.
-Regards
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Nitin Kumar
Sent: Thursday, June 21, 2001 1:51 AM
To: 'Terry L Anderson'; Rosen, Brian
Cc: [email-masked]'
Subject: RE: Few clarification in RFC3015

ok...

TransactionRequest
{
	Action1
	{
		command1
		command2
	}
	Action2
	{
		command1
		command2
		command3
	}
	Action3
	{
		command1
		command2
	}
}

regards,

-nitin

---

From: Terry L Anderson <[email-masked]>
Date: Thu, 21 Jun 2001 10:59:48 -0400

> Action with in the same transaction?

If you want Action3 to be executed regardless of the success of Action1&2 put
them into separate Transactions (they can still be in the same message).
Transactions are precisely to tie actions and commands to success of previous.
I cannot think of a reason you would want to ensure action3 was executed
sequentally after action2 but did not care if action2 succeeded.