Subject: RE: Ephemeral Termination

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 21 Jun 2001 09:51:11 -0400

There is no way this will reduce call setup time.
Since you do not have the destination information, you
will have to MODIFY the ephemeral when you do.  The processing
time for the Modify won't be substantially more than doing
an Add at that point, and there is no difference to the actual
operation of the gateway.

Brian

> -----Original Message-----
> From: PSK Chakravarthi [mailto:[email-masked]]
> Sent: Thursday, June 21, 2001 1:43 AM
> To: Rosen, Brian; 'Madhu Babu Brahmanapally'; 'Terry L Anderson'
> Cc: [email-masked]
> Subject: Re: Ephemeral Termination
> 
> 
> The reason for creating Ephemeral and reserving SDP before knowing the
> termination is
> to reduce the call setup time.
> 
> thanks & regards
> Chak
> ----- Original Message -----
> From: "Rosen, Brian" <[email-masked]>
> To: "'Madhu Babu Brahmanapally'" <[email-masked]>; 
> "'Terry L Anderson'"
> <[email-masked]>; "'PSK Chakravarthi'" 
> <[email-masked]>
> Cc: <[email-masked]>
> Sent: Wednesday, June 20, 2001 9:07 PM
> Subject: RE: Ephemeral Termination
> 
> 
> > I'm not at all sure what "resources" you can reserve before you
> > know the destination:
> >
> > For an IP network, you can reserve a UDP port I suppose, but until
> > you negotiate the SDP, you can't reserve bandwidth.  You can't
> > make any QoS reservation for the same reason.
> >
> > It's worse on an ATM network.
> >
> > I think there is nothing to be gained by #1
> >
> > Brian
> >
> > > -----Original Message-----
> > > From: Madhu Babu Brahmanapally [mailto:[email-masked]]
> > > Sent: Wednesday, June 20, 2001 11:28 AM
> > > To: 'Terry L Anderson'; 'PSK Chakravarthi'
> > > Cc: [email-masked]
> > > Subject: RE: Ephemeral Termination
> > >
> > >
> > > Hi All,
> > > The creation of ephemeral termination can be done either 
> after digit
> > > analysis or before it. Each has its own advantages and 
> disadvantages.
> > >
> > > 1) If Ephemeral termination is created before digit analysis,
> > > situation may
> > > occur where the destination user/termination is connected to
> > > the same MG and
> > > there is no need to create an ephemeral termination (as PSK
> > > mentioned). But
> > > this has the advantage that the call wont be dropped due 
> to lack of
> > > resource, as ephemeral resources are pre-reserved at the MG.
> > > (in case Add
> > > fails later to add ephemeral termination).
> > >
> > > 2) If Ephemeral termination is created after digit analysis,
> > > it takes care
> > > of all situation where destination user may/may not connected
> > > to the same
> > > MG. But when Ephemeral termination is added later, there is no
> > > pre-reservation of the ephemeral resources at the origination MG.
> > >
> > > In case of 1) if the call doesn't mature, reserving the
> > > resources doesn't
> > > gain anything. Consideration that the destination user on the
> > > same MG is
> > > less probable, Method 2 IMO will be a better choice.
> > >
> > > Regards
> > > Madhubabu
> > >
> > > -----Original Message-----
> > > From: [email-masked]
> > > [mailto:[email-masked]]On Behalf Of Terry
> > > L Anderson
> > > Sent: Wednesday, June 20, 2001 11:01 AM
> > > To: PSK Chakravarthi
> > > Cc: [email-masked]
> > > Subject: Re: Ephemeral Termination
> > >
> > >
> > >
> > >
> > > PSK Chakravarthi wrote:
> > >
> > > > I have got the following doubt.
> > > > If the originating and terminating termination IDs are on
> > > the same gateway
> > > and
> > > > gateway supports two TDM terminations in a context, is it
> > > required to
> > > craete a
> > > > ephenmeral termination for this call?
> > > >
> > > > Message flow between MGC and MG:
> > > >
> > > > 1. MGC send ADD command to originating MG
> > > >     a) Choose a context ID
> > > >     b) Add a TDM termination
> > > >     c) Choose a Ephemeral termination
> > > >     d) Reserve Local Descriptor
> > > >     e) set MODE to Receive only.
> > > >
> > > > 2. MGC now finds that call is terminating on the same MG.
> > > Also MGC knows
> > > that
> > > > MG is capable of adding two TDMs to the same context.  At
> > > this point what
> > > should
> > > > be the command to the MG?
> > > > Is it required to SUBTRACT the ephemeral termination and
> > > send ADD for
> > > adding new
> > > > TDM to the same context? or
> > > > Simply sending ADD for new TDM to the same context is 
> sufficient?
> > >
> > > It would be better if MGC "finds" that the call is terminated
> > > on the same MG
> > > before
> > > sending the ADD, in step 1c, but if since step c (which you
> > > call "Choose a
> > > Ephemeral
> > > termination) is an Add with wildcard, MGC must certainly
> > > Subtract it if it
> > > chooses
> > > later not to use it.  The Subtract deletes the ephemeral
> > > termination and
> > > releases
> > > its resources.
> > >
> > > > thanks & regards
> > > > Chak
> > >
> > > --
> > > ------------------------------------------------------------
> > > Terry L Anderson              mailto:[email-masked]
> > > Tel:908.582.7013   Fax:908.582.6729
> > > Lucent Technologies/INS/Voice Over IP Access Networks
> > > Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
> > > http://its.lucent.com/~tla (Lucent internal) 
http://www.gti.net/tla

---

From: "PSK Chakravarthi" <[email-masked]>
Date: Thu, 21 Jun 2001 19:40:07 +0530

The reason for creating Ephemeral and reserving SDP before knowing the
termination is to reduce the call setup time.

Following is the MGC processing.

1. Soon after receiving IAM send ADD command to the originating MG for
    a)Creating Ephemeral
    b)Reserving SDP for Local
    c)Simultaneously start digit analysis
After finding termination
(By this time ADD response would have been received, if not MGC need to wait for
ADD response)
If terminating trunk belongs to the same MG
   a) send ADD command to add the second termination to the same context.
       This ADD command will have empty Local descriptor to release resources
previously allocated.
       Note that ephemeral is not SUBTRACTED.  Also MODIFY to originating MG is
not required as    MG is going to make only hairpin connection.
If the terminating MG is not same as originating MG
Send ADD command to terminating MG
   a) Creating Ephemeral
   b) Reserving SDP for Local
   c) Setting SDP remote as Local returned by the originating MG.
After receiving the ADD response from terminating MG
Send MODIFY to originating MG for setting remote Descriptor.

If you send ADD command to the originating MG only after knowing the terminator,
MGC had completed processing of the call but now it need to wait for sending
three commands
(ADD to originating MG, ADD to terminating MG and MODIFY to originating MG) and
their responses.

Take the case of trunking gateway, where the number of calls originating on a MG
and terminating on the same MG are much less than calls originated and
terminated on two different MGs.

thanks & regards
Chak

----- Original Message -----
From: "Rosen, Brian" <[email-masked]>
To: "'PSK Chakravarthi'" <[email-masked]>; "'Madhu Babu
Brahmanapally'" <[email-masked]>; "'Terry L Anderson'" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, June 21, 2001 7:21 PM
Subject: RE: Ephemeral Termination

---

From: Chuong Nguyen <[email-masked]>
Date: Thu, 21 Jun 2001 09:24:16 -0500

I am a bit lost as to where this discussion is leading to.
Is a Megaco Standard change requested here or just a discussion on
a particular prefer implementation?

Chuong

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****