Subject: Re-transmission of messages......

From: "Atanum" <[email-masked]>
Date: Fri, 1 Jun 2001 10:06:29 +0530

Hi,
I have some doubt regarding the re-transmission of messages....
If I understand correctly.. the transactions inside a megaco message are treated seperately and reply and reply-acknowledgement
are send seperately for each transactions(reply-acknowledgement can be sent for a series in one shot). 

My question is that whether a timer is to be maintained for each seperate transactions ?

If that is so then if reply comes for some transaction in a message and for the other if the timer times out, then whether the transaction
for which the timer timed out will be again formed into seperate message and sent....and if that be so, then whether the message header remains
same as before...

I will be thankful if somebody please answer this query of mine

Regards
Atanu Mondal
Net Brahma Technologies
Internext Networking Software
A Microland Group Venture
[email-masked]
www.netbrahma.com
Tel : 91.80. 552 1451
Fax : 91.80. 553 7233

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 1 Jun 2001 06:55:50 -0400

Each message header is formed independently, regardless of the contents.

-----Original Message-----
From: Atanum [mailto:[email-masked]]
Sent: Friday, June 01, 2001 12:36 AM
To: megaco
Cc: Madhu Babu Brahmanapally; Rosen, Brian
Subject: Re-transmission of messages......

Hi,
I have some doubt regarding the re-transmission of messages....
If I understand correctly.. the transactions inside a megaco message are
treated seperately and reply and reply-acknowledgement
are send seperately for each transactions(reply-acknowledgement can be sent
for a series in one shot). 
 
My question is that whether a timer is to be maintained for each seperate
transactions ?
 
If that is so then if reply comes for some transaction in a message and for
the other if the timer times out, then whether the transaction
for which the timer timed out will be again formed into seperate message and
sent....and if that be so, then whether the message header remains
same as before...

Regards
Atanu Mondal
Net Brahma Technologies

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 1 Jun 2001 08:37:48 -0400

And each transaction has a separate timer.

Brian

> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Friday, June 01, 2001 6:56 AM
> To: 'Atanum'; 'megaco'
> Subject: RE: Re-transmission of messages......
> 
> 
> are send seperately for each 
> transactions(reply-acknowledgement can be sent