Subject: how to identify a conference resource

From: "mu lj" <[email-masked]>
Date: Wed, 27 Jun 2001 11:42:09 +0800

hi all:
   I have a question about conference resource. Media Server has many 
conference resource and hasn't trunk terminations or analog line 
terminations. how to use termination to identify a conference in Media 
Server? how does MGC distinguish different conferences using megaco 
protocol in Media Server?  
_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 27 Jun 2001 08:29:46 -0400

There are several models people have proposed.
One is that each conference is a context, and ephemerals representing the
network flows
are the "ports".  That is the easiest one to implement.  You could also have
physical
ports if your hardware could do that.

Another model is that each "port" is represented as a physical terminal, and
you have
a collection of two termination contexts.  In this model, there is a
property on the
physical ports that has a  "conference id".  This model has the advantage
that the
MGC can easily track the resources in the Media Server.

I haven't seen a concrete package proposal yet.  Either model will work
fine.

Brian

> -----Original Message-----
> From: mu lj [mailto:[email-masked]]
> Sent: Tuesday, June 26, 2001 11:42 PM
> To: [email-masked]
> Subject: how to identify a conference resource
> 
> 
> hi all:

---

From: "mu lj" <[email-masked]>
Date: Thu, 28 Jun 2001 10:14:25 +0800

hi:
  Thanks your answer.
  In megaco protocol,there is a way describle a 3-part service use 
topology.but when 3-part resources are in Media Server,how to use 
termination to identify a 3-part?

Mu Lingjiang

>From: "Rosen, Brian" <[email-masked]>
>To: "'mu lj'" <[email-masked]>, [email-masked]
>Subject: RE: how to identify a conference resource
>Date: Wed, 27 Jun 2001 08:29:46 -0400
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 28 Jun 2001 09:10:46 -0400

I would not use topology to control a 3-way call (two parties talking, one
on
hold, ability to switch to the "on hold" part).  I would do that with two
contexts, one of which had two terminations, the other of which had one
(if silence to the held party was desired) or two (if music-on-hold was
provided) terminations, using Move to change parties.  The Media
Server could do the same.

Brian

> Sent: Wednesday, June 27, 2001 10:14 PM
> To: [email-masked]; [email-masked]
> >are the "ports".  That is the easiest one to implement.  You 
> could also 
> have
> >physical
> >Another model is that each "port" is represented as a 
> physical terminal, 
> and
> >you have

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 28 Jun 2001 10:38:02 -0400

Just a quick clarification, as my main background is in line features: This
scenario is not a three-way call, but is rather call waiting, since the
third party is never talking to the other two.  Three-way call is,
essentially, a three-port conference.

Kevin

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]] 
Sent: Thursday, June 28, 2001 9:11 AM
To: 'mu lj'; [email-masked]
Subject: RE: how to identify a conference resource

Brian

---

From: "mu lj" <[email-masked]>
Date: Fri, 29 Jun 2001 13:58:49 +0800

ok,I agree "Three-way call is a three-port conference". 
But how to use termination to identify a three-port conference in Media
Server? 

>From: "Kevin Boyle" <[email-masked]>
>To: [email-masked]
>Subject: FW: how to identify a conference resource
>Date: Thu, 28 Jun 2001 10:38:02 -0400
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 29 Jun 2001 09:37:42 -0400

Same answer.

Either you have 3 terminations in a context (at a media server, they would
be
3 ephemeral terminations), or three 2 termination contexts, with the
physical
terminations representing ports on the conference bridge, and implementing
a package that provided a "conferenceId" property.

Brian

> Sent: Friday, June 29, 2001 1:59 AM
> To: [email-masked]; [email-masked]
> Subject: Re: FW: how to identify a conference resource
> 
> 
> >Just a quick clarification, as my main background is in line 
> features: 
> This