Subject: RE: Ephemeral Termination

From: Al Varney <[email-masked]>
Date: Wed, 20 Jun 2001 11:16:50 -0500

Brian,

At 11:37 6/20/2001 -0400, Rosen, Brian wrote:
>I'm not at all sure what "resources" you can reserve before you
>know the destination:
>
>For an IP network, you can reserve a UDP port I suppose, but until
>you negotiate the SDP, you can't reserve bandwidth.  You can't
>make any QoS reservation for the same reason.
>
>It's worse on an ATM network.
>
>I think there is nothing to be gained by #1

    On the other hand, if NO resources are used, why bother removing the 
Ephemeral from the Context?

    The original question was "Is it REQUIRED to remove the Ephemeral prior 
to ADDing the second TDM termination?"

    I think the answer is "no" (in disagreement with my colleague 
Terry).  If you are willing to waste the time/overhead of pre-allocating an 
Ephemeral, there doesn't seem to be much harm in letting it "hang around" 
for the duration of a call.  You may not get all the possible capacity out 
of the MG if you use it that way, but MEGACO certainly doesn't REQUIRE you 
to Subtract it -- before or after ADDing the second TDM.

    Who knows, maybe you're keeping it around to support possible wire-tap 
applications?

Al Varney

>Brian
>
> > -----Original Message-----
> > From: Madhu Babu Brahmanapally [mailto:[email-masked]]
> > Sent: Wednesday, June 20, 2001 11:28 AM
> > To: 'Terry L Anderson'; 'PSK Chakravarthi'
> > Cc: [email-masked]
> > Subject: RE: Ephemeral Termination
> >
> >
> > Hi All,
> > The creation of ephemeral termination can be done either after digit
> > analysis or before it. Each has its own advantages and disadvantages.
> >
> > 1) If Ephemeral termination is created before digit analysis,
> > situation may
> > occur where the destination user/termination is connected to
> > the same MG and
> > there is no need to create an ephemeral termination (as PSK
> > mentioned). But
> > this has the advantage that the call wont be dropped due to lack of
> > resource, as ephemeral resources are pre-reserved at the MG.
> > (in case Add
> > fails later to add ephemeral termination).
> >
> > 2) If Ephemeral termination is created after digit analysis,
> > it takes care
> > of all situation where destination user may/may not connected
> > to the same
> > MG. But when Ephemeral termination is added later, there is no
> > pre-reservation of the ephemeral resources at the origination MG.
> >
> > In case of 1) if the call doesn't mature, reserving the
> > resources doesn't
> > gain anything. Consideration that the destination user on the
> > same MG is
> > less probable, Method 2 IMO will be a better choice.
> >
> > Regards
> > Madhubabu
> >
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Terry
> > L Anderson
> > Sent: Wednesday, June 20, 2001 11:01 AM
> > To: PSK Chakravarthi
> > Cc: [email-masked]
> > Subject: Re: Ephemeral Termination
> >
> >
> >
> >
> > PSK Chakravarthi wrote:
> >
> > > I have got the following doubt.
> > > If the originating and terminating termination IDs are on
> > the same gateway
> > and
> > > gateway supports two TDM terminations in a context, is it
> > required to
> > craete a
> > > ephenmeral termination for this call?
> > >
> > > Message flow between MGC and MG:
> > >
> > > 1. MGC send ADD command to originating MG
> > >     a) Choose a context ID
> > >     b) Add a TDM termination
> > >     c) Choose a Ephemeral termination
> > >     d) Reserve Local Descriptor
> > >     e) set MODE to Receive only.
> > >
> > > 2. MGC now finds that call is terminating on the same MG.
> > Also MGC knows
> > that
> > > MG is capable of adding two TDMs to the same context.  At
> > this point what
> > should
> > > be the command to the MG?
> > > Is it required to SUBTRACT the ephemeral termination and
> > send ADD for
> > adding new
> > > TDM to the same context? or
> > > Simply sending ADD for new TDM to the same context is sufficient?
> >
> > It would be better if MGC "finds" that the call is terminated
> > on the same MG
> > before
> > sending the ADD, in step 1c, but if since step c (which you
> > call "Choose a
> > Ephemeral
> > termination) is an Add with wildcard, MGC must certainly
> > Subtract it if it
> > chooses
> > later not to use it.  The Subtract deletes the ephemeral
> > termination and
> > releases
> > its resources.
> >
> > > thanks & regards
> > > Chak
> >
> > --
> > ------------------------------------------------------------
> > Terry L Anderson              mailto:[email-masked]
> > Tel:908.582.7013   Fax:908.582.6729
> > Lucent Technologies/INS/Voice Over IP Access Networks
> > Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
> > http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla
> >
> >

---

From: Terry L Anderson <[email-masked]>
Date: Wed, 20 Jun 2001 13:49:53 -0400

Al -
You are, of course, correct that you are not required to Subtract it at the
beginning of the call.  My point was that you must subtract it sometime -
Adding another TDM termination does not magically remove it.  You can of course
wait until the end of the call and subtract it at the same time as the  two TDM
terminations, if that is desirable for some reason, but it would seem simpler
(but not required) to Subtract it in the same transaction as the second TDM
Add.