Subject: termination inheritance

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Thu, 07 Jun 2001 08:46:35 +0200

Hello,

I just have a question.

Imagine we have a Root termination with an event Descriptor.
If we create a new Termination in the Gateway, does it have to inherit
that event descriptor?

Thanks
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
       ALCATEL

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 7 Jun 2001 09:27:33 -0400

No.
 
Let me phrase that in the terms we usually use.
If your MG implements a package defined on Root, that has an event
descriptor,
only the root termination will have that event descriptor.  When we
instantiate
terminations on the gateway (which happens at boot time for physical
terminations, and when an Add command is executed for ephemeral 
terminations), the set of packages implemented on that termination depend on
the type of termination.  It would be unusual to implement the same package
on root and another type of termination.  No currently defined packages
could
be used that way.
 
Brian

-----Original Message-----
From: Fernando Vallejo Lazaro [mailto:[email-masked]]
Sent: Thursday, June 07, 2001 2:47 AM
To: [email-masked]
Subject: termination inheritance

Hello, 

I just have a question. 

Imagine we have a Root termination with an event Descriptor. 
If we create a new Termination in the Gateway, does it have to inherit that
event descriptor? 

Thanks 
Fernando 

-- 

Fernando Vallejo Lazaro

Phone:  +34 91 330 8279

       ALCATEL