Subject: RE: ABNF Question: digit maps embedded in events

From: Nurit Shenhar <[email-masked]>
Date: Wed, 6 Jun 2001 17:47:51 +0200

Sorry to step in so late, I only now examined this thread.

We had a discussion once about digit maps, and the conclusion was that the
first option in the digitMapDescriptor (only value) is meaningless, and was
left there by mistake. There is no point to program a termination with an
unnamed digit map, as we won't be able to activate it in the eventDM... So I
think the correct syntax should be:

eventDM = DigitMapToken EQUAL (( digitMapName ) / (LBRKT digitMapValue
RBRKT))

digitMapDescriptor = DigitMapToken EQUAL  digitMapName [LBRKT digitMapValue
RBRKT] 

Nurit

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Friday, June 01, 2001 7:51 PM
To: 'Troy Cauble'; Megaco Mailing List (E-mail)
Subject: RE: ABNF Question: digit maps embedded in events

Because it was intended to be symmetric in the beginning,
what is written is incorrect.  We have caught and fixed
several of these.  When a proposal actually changes what 
the original intention/documentation/text vs ABNF(ASN.1) is,
then we defer it.

Brian

> -----Original Message-----
> From: Troy Cauble [mailto:[email-masked]]
> Sent: Friday, June 01, 2001 11:22 AM
> To: Megaco Mailing List (E-mail)
> Subject: Re: ABNF Question: digit maps embedded in events
> 
> 
> 
> Just curious, but why doesn't this get squashed for
> being an unnecessary change?  Nothing's broken except
> the symmetry.
> 
> More useful changes have been delayed to v2.
> 
> Please treat this as a question, not a complaint!
> Christian, Tom, Brian, et. al. are doing a great job.
> 
> -troy
> 
> 
> Christian Groves wrote:
> > 
> > Just in time. I'll add it to the implementors' guide.
> > 
> > Christian
> > 
> > Tom-PT Taylor wrote:
> > >
> > > Yes, and I suspect I'm the guilty typist.
> > >
> > > > -----Original Message-----
> > > > From: Rosen, Brian [mailto:[email-masked]]
> > > > Sent: Wednesday, May 30, 2001 3:44 PM
> > > > To: 'Steven Weisz'; Megaco Mailing List (E-mail)
> > > > Cc: Taylor, Tom-PT [NORSE:B881:EXCH]
> > > > Subject: RE: ABNF Question: digit maps embedded in events
> > > >
> > > >
> > > > I usually defer to Tom on any digitMap questions.
> > > > I can't tell you how many hours I (and several others
> > > > including Abdullah Rayhan) spent pouring over the
> > > > ABNF to ferret out such problems.
> > > >
> > > > Yes, I agree, it should be
> > > > digitMap={...
> > > > and not
> > > > digitMap{...
> > > >
> > > > I think this qualifies as a typo and deserves an IG entry.
> > > > Tom, do you agree?
> > > >
> > > > Brian
> > > >
> > > > > -----Original Message-----
> > > > > From: Steven Weisz [mailto:[email-masked]]
> > > > > Sent: Wednesday, May 30, 2001 3:08 PM
> > > > > To: Megaco Mailing List (E-mail)
> > > > > Subject: ABNF Question: digit maps embedded in events
> > > > >
> > > > >
> > > > > Hi List,
> > > > >
> > > > > I asked this question a few weeks ago and still have not
> > > > > found an answer.
> > > > > Does anyone have an opinion?
> > > > >
> > > > > It is a quick question concerning a digit map embedded in a
> > > > > requested event.
> > > > > Specifically, if you look at the ABNF the embedded digit map
> > > > > is defined as
> > > > >
> > > > > eventDM = DigitMapToken (( EQUAL digitMapName ) / (LBRKT
> > > > digitMapValue
> > > > > RBRKT))
> > > > >
> > > > > and a digit map descriptor is defined as:
> > > > >
> > > > > digitMapDescriptor = DigitMapToken EQUAL (( LBRKT
> > > > > digitMapValue RBRKT ) /
> > > > >                      ( digitMapName [LBRKT 
> digitMapValue RBRKT] ))
> > >
> > > > >
> > > > > It obvious that they are very similar, as I believe was
> > > > > intended but there
> > > > > is one thing that is bothering me in eventDM. That is it
> > > > > seems to me that
> > > > > the EQUAL should be right after DigitMapToken as is 
> the case in
> > > > > digitMapDescriptor. So we would instead have:
> > > > >
> > > > > eventDM = DigitMapToken EQUAL (( digitMapName ) / (LBRKT
> > > > digitMapValue
> > > > > RBRKT))
> > > > >
> > > > > Does this make sense?
> > > > >
> > > > > Thanks,
> > > > >
> > > > > Steve
> > > > >
> > > >
>

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Wed, 6 Jun 2001 11:19:45 -0400

HI Nurit/all,
Why the digit map value is meaningless??
-Regards
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Nurit Shenhar
Sent: Wednesday, June 06, 2001 11:48 AM
To: 'Megaco (E-mail)
Subject: RE: ABNF Question: digit maps embedded in events

Nurit

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Friday, June 01, 2001 7:51 PM
To: 'Troy Cauble'; Megaco Mailing List (E-mail)
Subject: RE: ABNF Question: digit maps embedded in events

Brian