Subject: [Megaco] Partial name in Topology descriptor

From: Christer Holmberg <[email-masked]>
Date: Wed, 21 Nov 2001 08:56:11 +0200

Hi,

I have a question on the Topology descriptor issue.

Chapter 7.1.18 says:

"if a CHOOSE wildcard occurs in T1 or T2, then a partial name SHALL NOT
be specified"

What does this "partial name" mean? Does it mean that I can't use
"RTP/$"
as a ID for one termination in the descriptor?

eg.

Topology {J7.1,RTP/$,bothway)

Regards,

Christer Holmberg
Ericsson Finland

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Nurit Shenhar <[email-masked]>
Date: Thu, 22 Nov 2001 09:22:53 +0200

Hello Christian, Christer

What will be the case if we add more than one RTP in the command? e.g:

Transaction
   Topology (?,t1,oneway)
   ADD.req(TID=rtp/?),
   ADD.req(TID=rtp/?)

and even more complicated, what if we want different topology for each of
the new RTPs?

Nurit

-----Original Message-----
From: Christian Groves [mailto:[email-masked]]
Sent: Thursday, November 22, 2001 8:29 AM
To: Christer Holmberg
Cc: megaco ietf
Subject: Re: [Megaco] Partial name in Topology descriptor

Hello Christer,

See below.

Christian

Christer Holmberg wrote:
> 
> Hi,
> 
> >From what I understand partial is a partial termination ID as you
> >describe. It took me a while to remember why we had this. Its the
> >termination ID in the ADD or MOD that would drive the selection of the
> >appropriate termination ID not the partial ID in the topology descriptor
> >so it was thought that CHOOSE by itself was enough.
> 
> Yes, but wasn't that back when the general understanding was that
> emphemeral termination IDs was completely assigned by the media gatewai?

[CHG] No

> Currently, however, the call agent IS allowed to assign the ID, or parts
> of it, so I guess it affects the Topology descriptor too.
> 
> If I ADD "RTP/$" I should also be allowed to use it in the Topology
> descriptor. Otherwise I would have to send a MODIFY, with the Topology
> descriptor, when I get the full Termination ID from the media gateway in
> the ADD reply.

Yes you can do what you want. Remember that Topology isn't part of the
ADD command. Therefore if you do:

Transaction
   Topology (?,t1,oneway)
   ADD.req(TID=rtp/?)

Reply
   Topology (Rtp/t2,t1,oneway)
   ADD.rep(TID=rtp/t2)
> > Regards, Christian
> > Christer Holmberg wrote: