Subject: [Megaco] Race condition between Modify and Subtract

From: Raphael Tryster <[email-masked]>
Date: Sun, 18 Nov 2001 15:54:48 +0200

I have a question about RFC 3015 paragraph 9.1.2, which states that "...a
media gateway may sometimes receive a Modify command that applies to a
previously subtracted termination.  Such commands should be ignored, and an
error code should be returned".

Since it is permitted for Modify commands to operate on terminations that
are in the Null context, how does an MG distinguish between the following
cases?

1.	Modify was sent before Subtract, but the commands were received in
the wrong order.  The MG should ignore the Modify.
2.	Subtract was sent (possibly long) before Modify, and received in the
same order.  The MG should process the Modify because this is the beginning
of setting up a new call.

Could the context id of the Modify command be used to distinguish the cases?
Perhaps a Modify command that refers to the termination in the Null context
should be considered new and processed, while a Modify command that refers
to the termination in a non-Null context (while the MG considers the
termination to be in the Null context) should be considered obsolete and
ignored.  This solution looks less attractive when we consider that the
rules might be different if the command is Add or Move instead of Modify.

Any other ideas as to how to make this distinction?

Raphael Tryster

---

From: Atanu Mondal <[email-masked]>
Date: Mon, 19 Nov 2001 10:55:46 +0530

Hi List,
I need some clarification regarding the addition of a termination in the
context.
How does a gateway understand that it need to create a ephemeral
termination and not physical termination.
Should there be any condition when the agent can send a "Add =$ "to
choose any physical termination
of the gateway, or the "$" is only meant for ephemeral termination only.

Thanking in advance

Regards
Atanu Mondal
Net Brahma Technologies Ltd

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Atanu Mondal <[email-masked]>
Date: Mon, 19 Nov 2001 10:55:46 +0530

Hi List,

Thanking in advance

Regards
Atanu Mondal

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Mon, 19 Nov 2001 08:43:46 +0100

Hi,

I think '$' only applies for ephemeral terminations. The physical
terminations
are provisionned by system management in the MG (for example an external
application used by an operator).

Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Mon, 19 Nov 2001 08:43:46 +0100

Hi,

Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: "Usha Iyer" <[email-masked]>
Date: Mon, 19 Nov 2001 14:40:46 +0530

Hi,

The usage of '$' is not restricted to just ephemeral terminations .
Section  6.35 of the IG clarifies this. 
Also acc. to the dicussion on the mailing list ( ref  thread with sub : 'How to Determine the Termination Type'), the only way to deduce this would be by looking at the descriptors in the command coz for Eph Term , you would get the Local/Remote Descriptors in the command .

Reg 
Usha

----- Original Message ----- 
  From: Fernando Vallejo Lazaro 
  To: Atanu Mondal 
  Cc: [email-masked] 
  Sent: Monday, November 19, 2001 1:13 PM
  Subject: Re: [Megaco] Race condition between Modify and Subtract

  Hi, 
  I think '$' only applies for ephemeral terminations. The physical terminations 
  are provisionned by system management in the MG (for example an external 
  application used by an operator). 

  Regards 
  Fernando 

  Atanu Mondal wrote: 

    Hi List, 

    Regards 
    Atanu Mondal 

-- 
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: "Usha Iyer" <[email-masked]>
Date: Mon, 19 Nov 2001 14:40:46 +0530

Hi,

Reg 
Usha

----- Original Message ----- 
  From: Fernando Vallejo Lazaro 
  To: Atanu Mondal 
  Cc: [email-masked] 
  Sent: Monday, November 19, 2001 1:13 PM
  Subject: Re: [Megaco] Race condition between Modify and Subtract

  Hi, 

  Regards 
  Fernando 

  Atanu Mondal wrote: 

    Hi List, 

    Regards 
    Atanu Mondal 

-- 
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: "Usha Iyer" <[email-masked]>
Date: Mon, 19 Nov 2001 15:08:57 +0530

The logic would of course fail if  we have a SDP for TDM circuits ..
  ----- Original Message ----- 
  From: Usha Iyer 
  To: Fernando Vallejo Lazaro ; Atanu Mondal 
  Cc: [email-masked] 
  Sent: Monday, November 19, 2001 2:40 PM
  Subject: Re: [Megaco] Race condition between Modify and Subtract

  Hi,

  Reg 
  Usha

  ----- Original Message ----- 
    From: Fernando Vallejo Lazaro 
    To: Atanu Mondal 
    Cc: [email-masked] 
    Sent: Monday, November 19, 2001 1:13 PM
    Subject: Re: [Megaco] Race condition between Modify and Subtract

    Hi, 

    Regards 
    Fernando 

    Atanu Mondal wrote: 

      Hi List, 

      Regards 
      Atanu Mondal 

-- 
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: "Usha Iyer" <[email-masked]>
Date: Mon, 19 Nov 2001 15:08:57 +0530

----- Original Message ----- 
  From: Usha Iyer 
  To: Fernando Vallejo Lazaro ; Atanu Mondal 
  Cc: [email-masked] 
  Sent: Monday, November 19, 2001 2:40 PM
  Subject: Re: [Megaco] Race condition between Modify and Subtract

  Hi,

  Reg 
  Usha

  ----- Original Message ----- 
    From: Fernando Vallejo Lazaro 
    To: Atanu Mondal 
    Cc: [email-masked] 
    Sent: Monday, November 19, 2001 1:13 PM
    Subject: Re: [Megaco] Race condition between Modify and Subtract

    Hi, 

    Regards 
    Fernando 

    Atanu Mondal wrote: 

      Hi List, 

      Regards 
      Atanu Mondal 

-- 
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL