Subject: [Megaco] Problem with actionReply when only contextRequest exists

From: Nurit Shenhar <[email-masked]>
Date: Thu, 22 Nov 2001 10:00:41 +0200

Hi

What should be the answer for the folloing command?

MEGACO/1 [10.2.1.228]:2944
T=38{
C = 1 {
TP { TERM1 , TERM2 , BW}}}

Best regards

Nurit Shenhar
AudioCodes Ltd.
Direct: +972-3-539-4155
Tel:     +972-3-539-4000
Fax:    +972-3-539-4040
email:  [email-masked]

web:    <http://www.audiocodes.com>

************************************************************************************************************
This email and any files transmitted with it are confidential material.
They are intended solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error please notify [email-masked]
and permanently delete the e-mail and files.
***********************************************************************************************************

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Usha Iyer" <[email-masked]>
Date: Thu, 22 Nov 2001 14:30:59 +0530

Nurit , 
   This problem was addressed some time back on the list . 
   The reply in your case would be 
#1     MEGACO/1 [A.B.C.D]:2944 P=38{C = 1{TP { TERM1 , TERM2 , BW}}} 

As this repeats the info sent in the command it was proposed to modify the ABNF spec for ActionReply to 
    actionReply   = CtxToken EQUAL ContextID [ LBRKT  
                          ( errorDescriptor / commandReply ) RBRKT ]

so that u could have something like 
#2     MEGACO/1 [A.B.C.D]:2944 P=38{C=1} 

    But as this change is not yet included in v2 ,  u'll have to go with #1 

Regards
Usha

---

From: "Usha Iyer" <[email-masked]>
Date: Thu, 22 Nov 2001 14:30:59 +0530

Nurit , 

Regards
Usha