Subject: [Megaco] RE: live IP address switching

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 1 Nov 2001 19:09:07 -0500

The syntax certainly supports the operation.  You would simply do a Modify
on the termination, specifying the new information in Local or Remote.

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Wednesday, October 31, 2001 6:00 PM
To: 'Christian Groves'; Blatherwick, Peter
Cc: [email-masked]; Taylor, Tom-PT [CAR:B881:EXCH]; Rosen, Brian
Subject: live IP address switching

Hello, 

Can we use Megaco to support "switching one IP address/port number pair of a
live RTP termination to a different IP address/port number pair without
tearing down the call" in a particular MG? Internally, the RTP termination
does not need to change so the jitter buffer receives packets first from one
source, then a different one. The question is if Megaco supports this and
what are the exact commands needed between the MG and MGC, and if the delay
introduced acceptable. 

This feature can be useful in cases such as load balancing management and
ethernet redundancy.

Thanks
Kai Miao  

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 1 Nov 2001 19:09:07 -0500

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Wednesday, October 31, 2001 6:00 PM
To: 'Christian Groves'; Blatherwick, Peter
Cc: [email-masked]; Taylor, Tom-PT [CAR:B881:EXCH]; Rosen, Brian
Subject: live IP address switching

Hello, 

Thanks
Kai Miao

---

From: "Miao, Kai" <[email-masked]>
Date: Fri, 2 Nov 2001 10:26:25 -0500

Can I also use ServiceChange by specifying ServiceChangeMethod as "graceful"
for one termination and "restart" another termination after expiration of
the ServiceChangeDelay? This will avoid any hickups which could happen with
using "Modify".

Kai 

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Wednesday, October 31, 2001 6:00 PM
To: 'Christian Groves'; Blatherwick, Peter
Cc: [email-masked]; Taylor, Tom-PT [CAR:B881:EXCH]; Rosen, Brian
Subject: live IP address switching

Hello, 

Thanks
Kai Miao

---

From: "Miao, Kai" <[email-masked]>
Date: Fri, 2 Nov 2001 10:26:25 -0500

Kai 

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Wednesday, October 31, 2001 6:00 PM
To: 'Christian Groves'; Blatherwick, Peter
Cc: [email-masked]; Taylor, Tom-PT [CAR:B881:EXCH]; Rosen, Brian
Subject: live IP address switching

Hello, 

Thanks
Kai Miao

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 2 Nov 2001 11:33:01 -0500

SC Restart does not get a termination added to a context.  I am inferring
that you would like to add two terminations to the context - one inservice
and the other out of service.  When time for the switch, one would be taken
down with SC Graceful, and the other brought into service via SC Restart...
is that correct?  If so, then this scenario is not allowed, since you may
not add out of service terminations to contexts.

Kevin

 -----Original Message-----
From: 	Miao, Kai [mailto:[email-masked]] 
Sent:	Friday, November 02, 2001 10:26 AM
To:	Taylor, Tom-PT [CAR:B881:EXCH]; Miao, Kai
Cc:	[email-masked]
Subject:	[Megaco] RE: live IP address switching

Kai 

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Wednesday, October 31, 2001 6:00 PM
To: 'Christian Groves'; Blatherwick, Peter
Cc: [email-masked]; Taylor, Tom-PT [CAR:B881:EXCH]; Rosen, Brian
Subject: live IP address switching

Hello, 

Thanks
Kai Miao

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 2 Nov 2001 11:33:01 -0500

Kevin

 -----Original Message-----
From: 	Miao, Kai [mailto:[email-masked]] 
Sent:	Friday, November 02, 2001 10:26 AM
To:	Taylor, Tom-PT [CAR:B881:EXCH]; Miao, Kai
Cc:	[email-masked]
Subject:	[Megaco] RE: live IP address switching

Kai 

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Wednesday, October 31, 2001 6:00 PM
To: 'Christian Groves'; Blatherwick, Peter
Cc: [email-masked]; Taylor, Tom-PT [CAR:B881:EXCH]; Rosen, Brian
Subject: live IP address switching

Hello, 

Thanks
Kai Miao

---

From: "Miao, Kai" <[email-masked]>
Date: Fri, 2 Nov 2001 12:42:18 -0500

Tom,

Modify is always from MGC to MG. How can a MG initiate such an operation?
Maybe, the MGC has to have some knowledge beforehand about the load
balancing policy of a particular MG?

Kai 

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Wednesday, October 31, 2001 6:00 PM
To: 'Christian Groves'; Blatherwick, Peter
Cc: [email-masked]; Taylor, Tom-PT [CAR:B881:EXCH]; Rosen, Brian
Subject: live IP address switching

Hello, 

Thanks
Kai Miao

---

From: "Miao, Kai" <[email-masked]>
Date: Fri, 2 Nov 2001 12:42:18 -0500

Tom,

Kai 

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Wednesday, October 31, 2001 6:00 PM
To: 'Christian Groves'; Blatherwick, Peter
Cc: [email-masked]; Taylor, Tom-PT [CAR:B881:EXCH]; Rosen, Brian
Subject: live IP address switching

Hello, 

Thanks
Kai Miao

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 6 Nov 2001 00:38:56 -0500

Not sure this makes sense.  You're proposing that the MGC do a ServiceChange
on the RTP termination?  This would have no effect on MG behaviour.  Simply
adding the second RTP termination, which presumably supports the new
address, then subtracting the old one, might be a workable solution.

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Friday, November 02, 2001 11:26 PM
To: Taylor, Tom-PT [CAR:B881:EXCH]; Miao, Kai
Cc: [email-masked]
Subject: RE: live IP address switching

Kai 

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Wednesday, October 31, 2001 6:00 PM
To: 'Christian Groves'; Blatherwick, Peter
Cc: [email-masked]; Taylor, Tom-PT [CAR:B881:EXCH]; Rosen, Brian
Subject: live IP address switching

Hello, 

Thanks
Kai Miao

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 6 Nov 2001 00:38:56 -0500

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Friday, November 02, 2001 11:26 PM
To: Taylor, Tom-PT [CAR:B881:EXCH]; Miao, Kai
Cc: [email-masked]
Subject: RE: live IP address switching

Kai 

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Wednesday, October 31, 2001 6:00 PM
To: 'Christian Groves'; Blatherwick, Peter
Cc: [email-masked]; Taylor, Tom-PT [CAR:B881:EXCH]; Rosen, Brian
Subject: live IP address switching

Hello, 

Thanks
Kai Miao

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 9 Nov 2001 15:18:47 -0500

Rather late to respond to this, but I'm catching up on a large backlog of
mail.  Now I understand what you're asking: can the MG initiate an action to
switch termination addresses?  This is going to be difficult.  The only
faint possibility I see is that the MGC is aware that the MG might want to
substitute terminations and enables an event which allows each termination
to notify the MG that its address should be replaced.  The event would
contain the new address.

Don't forget that the MGC has to signal the far end in order to coordinate
any changes in address. 

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Saturday, November 03, 2001 1:42 AM
To: Taylor, Tom-PT [CAR:B881:EXCH]; Miao, Kai
Cc: [email-masked]
Subject: RE: live IP address switching

Tom,

Kai 

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Wednesday, October 31, 2001 6:00 PM
To: 'Christian Groves'; Blatherwick, Peter
Cc: [email-masked]; Taylor, Tom-PT [CAR:B881:EXCH]; Rosen, Brian
Subject: live IP address switching

Hello, 

Thanks
Kai Miao

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 9 Nov 2001 15:18:47 -0500

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Saturday, November 03, 2001 1:42 AM
To: Taylor, Tom-PT [CAR:B881:EXCH]; Miao, Kai
Cc: [email-masked]
Subject: RE: live IP address switching

Tom,

Kai 

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Wednesday, October 31, 2001 6:00 PM
To: 'Christian Groves'; Blatherwick, Peter
Cc: [email-masked]; Taylor, Tom-PT [CAR:B881:EXCH]; Rosen, Brian
Subject: live IP address switching

Hello, 

Thanks
Kai Miao

---

From: "Miao, Kai" <[email-masked]>
Date: Fri, 9 Nov 2001 18:11:42 -0500

Is it then fair to say that the current version of Megaco can not support
balancing of call load between different address ports on a MG under its
control? 
 
Or is it a solvable problem in that a new service can be added in the MGC,
making it capable of controlling the amount of load each address port can
have?

-----Original Message----- 
From: Miao, Kai [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Saturday, November 03, 2001 1:42 AM 
To: Taylor, Tom-PT [CAR:B881:EXCH]; Miao, Kai 
Cc: [email-masked] 
Subject: RE: live IP address switching 

Tom, 

Kai 

-----Original Message----- 
From: Tom-PT Taylor [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Thursday, November 01, 2001 7:09 PM 
To: Miao, Kai 
Cc: [email-masked] 
Subject: RE: live IP address switching 

-----Original Message----- 
From: Miao, Kai [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Wednesday, October 31, 2001 6:00 PM 
To: 'Christian Groves'; Blatherwick, Peter 
Cc: [email-masked]; Taylor, Tom-PT [CAR:B881:EXCH]; Rosen, Brian 
Subject: live IP address switching 

Hello, 

Thanks 
Kai Miao

---

From: "Miao, Kai" <[email-masked]>
Date: Fri, 9 Nov 2001 18:11:42 -0500

-----Original Message----- 
From: Miao, Kai [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Saturday, November 03, 2001 1:42 AM 
To: Taylor, Tom-PT [CAR:B881:EXCH]; Miao, Kai 
Cc: [email-masked] 
Subject: RE: live IP address switching 

Tom, 

Kai 

-----Original Message----- 
From: Miao, Kai [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Wednesday, October 31, 2001 6:00 PM 
To: 'Christian Groves'; Blatherwick, Peter 
Cc: [email-masked]; Taylor, Tom-PT [CAR:B881:EXCH]; Rosen, Brian 
Subject: live IP address switching 

Hello, 

Thanks 
Kai Miao

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 12 Nov 2001 09:48:34 -0500

It's probably possible to do this, but the real question is, is this a real
question?
 
Under what circumstances is it reasonable to do this kind of load balancing?
In any reasonably sized MG, with any reasonable network interface, there is
no
point in load balancing.  There is a point in having two interfaces for
redundancy
in a failure scenario, but load balancing is not something I think is worth
worrying
about.
 
Brian

 

-----Original Message----- 
From: Miao, Kai [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Saturday, November 03, 2001 1:42 AM 
To: Taylor, Tom-PT [CAR:B881:EXCH]; Miao, Kai 
Cc: [email-masked] 
Subject: RE: live IP address switching 

Tom, 

Kai 

-----Original Message----- 
From: Miao, Kai [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Wednesday, October 31, 2001 6:00 PM 
To: 'Christian Groves'; Blatherwick, Peter 
Cc: [email-masked]; Taylor, Tom-PT [CAR:B881:EXCH]; Rosen, Brian 
Subject: live IP address switching 

Hello, 

Thanks 
Kai Miao

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 12 Nov 2001 09:48:34 -0500

Brian

 

-----Original Message----- 
From: Miao, Kai [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Saturday, November 03, 2001 1:42 AM 
To: Taylor, Tom-PT [CAR:B881:EXCH]; Miao, Kai 
Cc: [email-masked] 
Subject: RE: live IP address switching 

Tom, 

Kai 

-----Original Message----- 
From: Miao, Kai [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Wednesday, October 31, 2001 6:00 PM 
To: 'Christian Groves'; Blatherwick, Peter 
Cc: [email-masked]; Taylor, Tom-PT [CAR:B881:EXCH]; Rosen, Brian 
Subject: live IP address switching 

Hello, 

Thanks 
Kai Miao

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 12 Nov 2001 10:22:40 -0500

Hmmm ... now you're talking balancing of call load, where I thought you were
talking about switching addresses within calls.  Seems to me that between
calls the MG has all the freedom it needs to balance load, assuming the MGC
provides that freedom by leaving the address as CHOOSE within the
LocalDescriptor.

Going back to what I thought you were proposing (changing addresses on an
RTP termination in mid-flow), your second paragraph is a reasonable
statement of the possibilities.

 

-----Original Message----- 
From: Miao, Kai [mailto:[email-masked]] 
Sent: Saturday, November 03, 2001 1:42 AM 
To: Taylor, Tom-PT [CAR:B881:EXCH]; Miao, Kai 
Cc: [email-masked] 
Subject: RE: live IP address switching 

Tom, 

-----Original Message----- 
From: Miao, Kai [mailto:[email-masked]] 
Sent: Wednesday, October 31, 2001 6:00 PM 
To: 'Christian Groves'; Blatherwick, Peter 
Cc: [email-masked]; Taylor, Tom-PT [CAR:B881:EXCH]; Rosen, Brian 
Subject: live IP address switching 

Hello,

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 12 Nov 2001 10:22:40 -0500

-----Original Message----- 
From: Miao, Kai [mailto:[email-masked]] 
Sent: Saturday, November 03, 2001 1:42 AM 
To: Taylor, Tom-PT [CAR:B881:EXCH]; Miao, Kai 
Cc: [email-masked] 
Subject: RE: live IP address switching 

Tom, 

-----Original Message----- 
From: Miao, Kai [mailto:[email-masked]] 
Sent: Wednesday, October 31, 2001 6:00 PM 
To: 'Christian Groves'; Blatherwick, Peter 
Cc: [email-masked]; Taylor, Tom-PT [CAR:B881:EXCH]; Rosen, Brian 
Subject: live IP address switching 

Hello,