Subject: [Megaco] Transaction Processing

From: Niraj Kedar <[email-masked]>
Date: Sun, 11 Nov 2001 06:28:33 -0800 (PST)

Hi,

The RFC 3015 mentions a priority indicator for
Context(value 1 through 15). This indicates priority
processing of the context on the MG. This means that
the MG processes commands in a 'Context-wise' fashion
rather then 'Transaction-wise'. 

If a particular implementation provides facility of
context priority processing, there will be a complex
mingling of contexts from different transactions, as
per their priority and some transaction with many
contexts and relatively low priority might have to
wait too long. This might cause them to timeout and
being retransmitted. There is a possibility that they
might not be processed at all.

Any solution for this.

thanx,
niraj

__________________________________________________
Do You Yahoo!?
Find a job, post your resume.
http://careers.yahoo.com

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 12 Nov 2001 10:02:26 -0500

Priority is used, IMO in a system which requires all calls to
state priority, and priority is strictly applied, usually
including preemption.  In this case, it doesn't matter how long
it takes to execute a low priority action.

I was once discussing such systems with someone who had
experience and asked him if there were 1,024 priority 3 (low)
calls each of 64K, and one priority 2 call with 64M, and a priority
1 call came in which needed 64M, could you take down the one
64M, priority 2 call first.  The answer is no, you pre-empt all
the priority 3 calls first.  If you still need more, then take
down the priority 2 calls.

A good implementation would probably return a meaningful error
to the low priority transactions when it saw they were being
delayed too long. 

I suspect this is not an actual problem, and you will run out of
bandwidth much sooner than you will run out of processing power for
transactions when priority is applied.

Brian

> -----Original Message-----
> From: Niraj Kedar [mailto:[email-masked]]
> Sent: Sunday, November 11, 2001 9:29 AM
> To: [email-masked]
> Subject: [Megaco] Transaction Processing
> 
> 
> Hi,
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 12 Nov 2001 10:02:26 -0500

Brian