Subject: [Megaco] Version Negotiation Failure

From: [email-masked]
Date: Mon, 12 Nov 2001 15:55:36 +0530

Hi,
     I have a doubt regarding behaviour of MG if MGC sends error "Version Not
Supported"  in service change reply.
Should MG contact secondary MGCs ? Also, should MG delete the association if no
secondary MGCs are configured ?
Please clarify.

regards
Rakhi

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 12 Nov 2001 11:19:29 -0500

Two points are clear here:
 1) If the MG cannot agree on a version with the MGC, they cannot work
together.  The association between them cannot be considered to have been
established until the MG receives back an error-free ServiceChange reply, so
there is no association to be cleared.
 2) Assuming the MG cannot change to the version the MGC supports, its only
choice is to seek an association with another MGC.  If that is impossible,
the MG cannot operate until something changes.  This is a situation brought
about by the upgrade procedures of the network operator -- it may be a
mistake, or the nature of the MG may be such that a brief period of outage
is acceptable.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, November 12, 2001 5:26 AM
To: [email-masked]
Subject: [Megaco] Version Negotiation Failure

Hi,
     I have a doubt regarding behaviour of MG if MGC sends error "Version
Not
Supported"  in service change reply.
Should MG contact secondary MGCs ? Also, should MG delete the association if
no
secondary MGCs are configured ?
Please clarify.

regards
Rakhi

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 12 Nov 2001 11:19:29 -0500

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, November 12, 2001 5:26 AM
To: [email-masked]
Subject: [Megaco] Version Negotiation Failure

Hi,

regards
Rakhi