Subject: [Megaco] Megaco : DigitMap Descriptor

From: [email-masked]
Date: Wed, 7 Nov 2001 10:38:00 +0100

Hi all,

We wonder how to define the DigitMap in the following case :

On detecton of a digit, the MGC wants the MG to report  this event
immediately without using any timer.

MGC wants also the MG to continue to receive other  digits and to report them
one by one until the MGC asks to stop. In this case how the MGC can disable
the DigitMap?

In the report, does the ObservedEventsDescriptor contain one digit or all the
digits received at this time?

Thank-you for your help.
Best regards,
Jean-Luc

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Wed, 07 Nov 2001 11:29:46 +0100

Hi,

I guess that if you dont want to wait to notify the digit you
may have a dialplan like {x}.
Then if you want to stop the report of digits you can send
a Modify with an EventsDescriptor without the event dd/ce.
You should report the digits one by one.

There is another possibility: using as a dialplan {x.} (note the dot)
with a short timer of zero or close to zero.

Regards
Fernando

[email-masked] wrote:

  Hi all,

  MGC wants also the MG to continue to receive other  digits and to
report them
  one by one until the MGC asks to stop. In this case how the MGC can
disable
  the DigitMap?

  In the report, does the ObservedEventsDescriptor contain one digit or
all the
  digits received at this time?

  Thank-you for your help.
  Best regards,
  Jean-Luc

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

Subject: Re: [Megaco] Megaco : DigitMap Descriptor
From: Fernando Vallejo Lazaro <[email-masked]>
To: [email-masked]
Date: Wed, 07 Nov 2001 11:14:38 +0100

Hi,

I guess that if you dont want to wait to notify the digit you
may have a dialplan like {x}.
Then if you want to stop the report of digits you can send
a Modify with an EventsDescriptor without the event dd/ce.
You should report the digits one by one.

There is another possibility: using as a dialplan {x.} (note the dot)
with a short timer of zero or close to zero.

Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Wed, 07 Nov 2001 11:29:46 +0100

Hi,

Regards
Fernando

  Hi all,

  Thank-you for your help.
  Best regards,
  Jean-Luc

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

Hi,

Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 7 Nov 2001 13:55:54 -0500

For this particular scenario, why don't you ask for dd/* in the Events
Descriptor?  The behavior will be exactly as you describe.

Kevin

 -----Original Message-----
From: 	[email-masked] [mailto:[email-masked]] 
Sent:	Wednesday, November 07, 2001 4:38 AM
To:	[email-masked]
Subject:	[Megaco] Megaco : DigitMap Descriptor

Hi all,

MGC wants also the MG to continue to receive other  digits and to report
them
one by one until the MGC asks to stop. In this case how the MGC can disable
the DigitMap?

In the report, does the ObservedEventsDescriptor contain one digit or all
the
digits received at this time?

Thank-you for your help.
Best regards,
Jean-Luc

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 7 Nov 2001 13:55:54 -0500

Kevin

 -----Original Message-----
From: 	[email-masked] [mailto:[email-masked]] 
Sent:	Wednesday, November 07, 2001 4:38 AM
To:	[email-masked]
Subject:	[Megaco] Megaco : DigitMap Descriptor

Hi all,

Thank-you for your help.
Best regards,
Jean-Luc

---

From: Dan Elbert <[email-masked]>
Date: Wed, 7 Nov 2001 14:25:48 -0500

The problem with this is that the digitmap gets deactivated when the event
completion (matching of the pattern) is reported.
So you"ll get only 1 digit.
I think in this case you cannot use digitmap, just ask for the digits
explicitly and process them one by one.
You can do both at the same time but in this case you don't gain much.
When you don't want any more digits just send an Event Descriptor with no
digits.
 
Dan Elbert
RADVISION
 
-----Original Message-----
From: Fernando Vallejo Lazaro [mailto:[email-masked]]
Sent: Wednesday, November 07, 2001 5:30 AM
To: [email-masked]
Subject: Re: [Megaco] Megaco : DigitMap Descriptor

Hi, 
  
Regards 
Fernando 
<http://www1.ietf.org/mailman/listinfo/megaco>  
-- 
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: Dan Elbert <[email-masked]>
Date: Wed, 7 Nov 2001 14:25:48 -0500

Dan Elbert
RADVISION
 
-----Original Message-----
From: Fernando Vallejo Lazaro [mailto:[email-masked]]
Sent: Wednesday, November 07, 2001 5:30 AM
To: [email-masked]
Subject: Re: [Megaco] Megaco : DigitMap Descriptor

Hi, 
  
Regards 
Fernando